DedNetInv Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedApiInv |
Classe pubblica | DedNetInvApp | Classe principale che inizializza le funzionalità vere e proprie dell'addin.
Classe pubblica | DedNetInvAppAskCopyAttrOnDerivedEventArgs | Argomento utilizzato per l'evento override richiesta copia attributi sul derivato
Classe pubblica | DedNetInvAppChangeDsInfoStructEventArgs | Argomento utilizzato per l'evento di modifica struttura del docStructInfo
Classe pubblica | DedNetInvAppDedInvInvokeBasePublishEventArgs | Argomento utilizzato per l'evento legato alla pubblicazione di base del ded
Classe pubblica | DedNetInvAppDedInvPublishEventArgs | Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Classe pubblica | DedNetInvAppImportOnSaveEventArgs | Argomento utilizzato per l'evento di salvataggio di ipartmember o iassemblymember
Classe pubblica | DedNetInvAppImportPackAndGoAfterLoadEventArgs | Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Classe pubblica | DedNetInvAppImportPackAndGoDocAttrCompareEventArgs | Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Classe pubblica | DedNetInvAppImportPackAndGoMappingRootEventArgs |
Classe pubblica | DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs |
Classe pubblica | DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs |
Classe pubblica | DedNetInvAppInvRilCheckCoherenceEventArgs | Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Classe pubblica | DedNetInvAppInvRilPublishEventArgs | Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Classe pubblica | DedNetInvAppModifyingDocumentsEventArgs | Argomento utilizzato per l'evento di scelta checkout/checkin nel onfiledirty.
Classe pubblica | DedNetInvAppMultiSaverExecutionInfoEventArgs | Argomento utilizzato per l'evento di before e after esecuzione del salva multiplo
Classe pubblica | DedNetInvAppMultiSaverItemElaborationEventArgs | Argomento utilizzato per l'evento di before e after esecuzione del singolo elemento nel salva multiplo
Classe pubblica | DedNetInvAppMultiSaverOverrideDedTypeEventArgs | Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Classe pubblica | DedNetInvAppResolutionEventArgs | Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Classe pubblica | DedNetInvAppUpdateDataDescriptor | Oggetto di servizio per l'aggiornamento dell'anagrafica
Classe pubblica | DedNetInvAppUpdateDataDescriptors | Lista di descrittori di aggiornamento dell'anagrafica
Classe pubblica | DedNetInvOldFileResolution | Classe per la gestione della risoluzione degli oldFile
Classe pubblica | DedNetInvOldFileResolutionOnFileResolutionOldPathItem |
Classe pubblica | DedNetInvOldFileResolutionOnFileResolutionOldPathList |
Classe pubblica | DedNetInvOldFileResolutionOnFileResolutionSostItem |
Classe pubblica | DedNetInvOldFileResolutionOnFileResolutionSostItemList |
Classe pubblica | DedNetInvServer | Classe che implementa l'interfaccia di collegamento per gli AddIn di inventor, punto d'ingresso dell'applicazione. Non espongo a COM perché sono caricato dal QsInvLoader.
Classe pubblica | DocumentMonitorSync | Classe utilizzata per la sincronizzazione degli eventi sui documenti.
Classe pubblica | FileStateElement | Oggetto descrivente un singolo documento ed il suo stato. Funge da ponte tra chi sa determinare lo stato del documento e deve decidere cosa fare nelle varie situazioni e chi deve visualizzare lo stato del documento e le sue dipendenze.
Classe pubblica | FileStateElementList | Lista di elementi di tipo FileStateElement.
Classe pubblica | FileStateManager | Gestisce lo stato di tutti i documenti presenti in Inventor aperti in modo visibile o meno. Centralizza le funzionalità necessarie al Check-in/out o al riservarsi o meno i documenti. Attraverso l'implementazione di una stessa interfaccia rende possibile avere un albero di documenti con la gestione integrata del loro stato, fruibile sia nel DedPlus che nel Ded tradizionale. Pensa questa classe a registrarsi agli eventi e visualizzare il browser con lo stato dei documenti. Chiama i metodi dell'interfaccia, necessari al check-out/riservo dei documenti.
Classe pubblica | InteractiveMeasurement | Classe per la gestione interattiva della misurazione
Classe pubblica | InvCurSelInfo | Raccoglie le informazioni sulla selezione corrente e sullo stato di attivazione nel caso di un assieme. Fotografa la situazione attuale del documento attivo, dell'eventuale documento in editazione e della selezione corrente.
Classe pubblica | InvDocStructInfo | Oggetto specializzato che espande il DocStructInfo e ne aggiunge delle proprietà ed informazioni specifiche sul documento in memoria di Inventor.
Classe pubblica | InvDocStructInfoEventHandlers | Classe gestione eventi client del DoscStructInfo
Classe pubblica | InvDocStructInfoExtensions | Extension methods associati ad InvDocStructInfo
Classe pubblica | InvDocStructInfoFileDescriptor |
Classe pubblica | Lua | Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Classe pubblica | ModifyingDocumentInfo | Contiene le informazioni su di un documento che è in fase di modifica da parte dell'utente. Una lista di questi oggetti, raccolta nell'evento OnFileDirty, è utile per capire se impedire o meno l'operazione di modifica e per comunicarlo all'utente tramite finestra di dialogo.
Classe pubblica | ModifyingDocumentInfoList | Lista di elementi di tipo ModifyingDocumentInfo.
Classe pubblica | Options |
Classe pubblica | OptionsCancelStartingStateConfiguration | Classe per la gestione dei formati di pubblicazione in cambio stato di anagrafica
Classe pubblica | OptionsLocalizedCategoryAttribute | Gestione localizzazione categorie
Classe pubblica | OptionsLocalizedDisplayNameAttribute | Gestione localizzazione display name
Classe pubblica | OptionsSaveDistChildrenRestrictionStatusConfiguration | Classe per la gestione degli stati che invalidano il salvataggio distinta se presenti nei figli
Classe pubblica | OptionsSaveDistOnBomStructureConfiguration | Classe per la gestione dei formati di pubblicazione in cambio stato di anagrafica
Classe pubblica | QsPropertiesInterfaceWrapper |
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | ResolveFileForm |
Classe pubblica | SelInfoItem | Classe descrivente un singolo elemento della selezione presente.
Classe pubblica | SelInfoItemList | Lista di elementi SelInfoItem.
Classe pubblica | Util | Contiene utilità generali per Inventor.
Classe pubblica | UtilPrtDwgExporterHelper | Classe gestione pubblicazioni tramite modulo TopInventor.
Classe pubblica | UtilQsPublisherHelper | Classe gestione pubblicazioni tramite modulo QsPublisher.
Classe pubblica | UtilSpecialStructInfos | Classe per la gestione dati delle strutture speciali
Classe pubblica | UtilSubclassHWND | Subclassa la finestra principale di inventor o quella di un documento per segnalarne la chiusura.
Interfacce
 | Interfaccia | Descrizione
Interfaccia pubblica | IFileStateInformer |
Delegate
 | Delegate | Descrizione
Delegate pubblico | FileStateManagerActivateEventHandler | Elemento che si verifica quando un elemento è stato aggiunto.
Delegate pubblico | UtilEnumWindowProcess |
Delegate pubblico | UtilSubclassHWNDClosingWindowEventEventHandler |
Delegate pubblico | UtilSubclassHWNDCommandWindowEventEventHandler |
Delegate pubblico | UtilSubclassHWNDDestroyWindowEventEventHandler |
Delegate pubblico | UtilSubclassHWNDWindowActivatedEventEventHandler |
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedNetInvAppOnFileDirtyBehaviour | Possibili comportamnti alla notifica dell'onFileDirty su di un documento
Enumerazione pubblica | DedNetInvOldFileResolutionRispostaUtenteSost |
Enumerazione pubblica | SpecialStructEnum | Descrive se un documento sia una struttura speciale e se sìis, di che tipo sia. Gli elementi FrameGeneratorContainer, DesignAcceleratorContainer e PipingContainer possono essere effettivamente trovati insieme, mentre tutti gli altri si escludono a vicenda.
Enumerazione pubblica | UtilDataAttrTypeEnum | Tipo di attributi da leggere/scrivere nel documento.

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe DedApiInv
Gerarchia di ereditarietà
SystemObject
DedNetInvDedApiInv

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedApiInv
Public Class DedApiInv
public ref class DedApiInv
type DedApiInv =  class end

Il tipo DedApiInv espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApiInv |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | ChangeDrawingReference | Modifica il riferimento della tavola utilizzando apprentice
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando la logica di Inventor con relativa pubblicazione
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Metodo pubblico | UpdateAllEmptyDocumentInternalName | Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedApiInv

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedApiInv(
    DedNetApplication app,
    DedLuaApplication luaApp
)
Public Sub New (
    app As DedNetApplication,
    luaApp As DedLuaApplication
)
public:
DedApiInv(
    DedNetApplication^ app,
    DedLuaApplication^ luaApp
)
new :
        app : DedNetApplication *
        luaApp : DedLuaApplication -> DedApiInv

Parametri

app
Tipo: DedNetApplication
luaApp
Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Proprietà di DedApiInv

Il tipo DedApiInv espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Proprietà DedApiInv.LastException

Libreria DedNetInv

Proprietà DedApiInvLastException

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Tipo: Exception
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodi di DedApiInv

Il tipo DedApiInv espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | ChangeDrawingReference | Modifica il riferimento della tavola utilizzando apprentice
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando la logica di Inventor con relativa pubblicazione
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Metodo pubblico | UpdateAllEmptyDocumentInternalName | Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato
Torna su
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.AssociaDoc

Metodo DedApiInvAssociaDoc

Associa documento. Riceve in ingresso una table di parametri.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssociaDoc(
    LuaTable args
)
Public Function AssociaDoc (
    args As LuaTable
) As Boolean
public:
bool AssociaDoc(
    LuaTable^ args
)
member AssociaDoc :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
id : id anagrafica (obbligatorio) rev : revisione dell'anagrafica (obbligatorio) silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil enforceOverwriteMode : indica se deve essere sovrascritto o creare una rappresentazione - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Tipo: Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.ChangeDrawingReference

Metodo DedApiInvChangeDrawingReference

Modifica il riferimento della tavola utilizzando apprentice

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ChangeDrawingReference(
    LuaTable args
)
Public Function ChangeDrawingReference (
    args As LuaTable
) As Boolean
public:
bool ChangeDrawingReference(
    LuaTable^ args
)
member ChangeDrawingReference :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
Argomenti da passare al metodo : drawingFullName : fullpath della tavola da modificare (obbligatorio) newModelRefPath : percorso del nuovo modello da usare in sostituzione (obbligatorio) oldModelRefPath : percorso del modello da sostituire. Se non passato viene utilizzato il primo riferimento

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.Rilascia

Metodo DedApiInvRilascia

Esegue il rilascio dell'anagrafica utilizzando la logica di Inventor con relativa pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Rilascia(
    LuaTable args
)
Public Function Rilascia (
    args As LuaTable
) As Boolean
public:
bool Rilascia(
    LuaTable^ args
)
member Rilascia :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
Argomenti del Rilascio

Valore di ritorno

Tipo: Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.SalvaNelDb

Metodo DedApiInvSalvaNelDb

Creazione dell'anagrafica. Riceve in ingresso una table di parametri.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SalvaNelDb(
    LuaTable args
)
Public Function SalvaNelDb (
    args As LuaTable
) As Boolean
public:
bool SalvaNelDb(
    LuaTable^ args
)
member SalvaNelDb :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
dbpath : path di salvataggio dell'anagrafica (obbligatorio) progr : progressivo (obbligatorio) rev : revisione dell'anagrafica infoUser : eventuale tassello utente format : informazione sul formato silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil attrs : LuaTable contenente prompt e valori degli attributi da preimpostare nell'anagrafica in creazione validateAttrs : indica se validare gli attributi 1/nil forcedata : Indica se utilizzare gli attributi passati invece di calcolarli - 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Tipo: Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.ShowLastException

Metodo DedApiInvShowLastException

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowLastException()
Public Sub ShowLastException
public:
void ShowLastException()
member ShowLastException : unit -> unit
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Metodo DedApiInv.UpdateAllEmptyDocumentInternalName

Metodo DedApiInvUpdateAllEmptyDocumentInternalName

Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void UpdateAllEmptyDocumentInternalName()
Public Sub UpdateAllEmptyDocumentInternalName
public:
void UpdateAllEmptyDocumentInternalName()
member UpdateAllEmptyDocumentInternalName : unit -> unit
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Campi di DedApiInv

Il tipo DedApiInv espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Campo DedApiInv._app

Campo DedApiInv_app

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Campo DedApiInv._luaApp

Campo DedApiInv_luaApp

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication _luaApp
Public _luaApp As DedLuaApplication
public:
DedLuaApplication^ _luaApp
val mutable _luaApp: DedLuaApplication

Valore del campo

Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedApiInv
Namespace DedNetInv


Classe DedNetInvApp
Classe principale che inizializza le funzionalità vere e proprie dell'addin.
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvApp

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetInvApp : IFileStateInformer
Public Class DedNetInvApp
    Implements IFileStateInformer
public ref class DedNetInvApp : IFileStateInformer
type DedNetInvApp =
    class
        interface IFileStateInformer
    end

Il tipo DedNetInvApp espone i seguenti membri.

Proprietà
Nome | Descrizione
ActiveProjectIsShared | Restituisce se il progetto attivo sia shared.
AddInClassID | Restituisce il classid in formato stringa da utilizzare per la registrazione dei menu.
AllowSaveRevisionOniPart | Indica se permettere la revisione su iPart o iAssembly
ApprenticeServer | Apprentice di Inventor.
AssemblyInvPath | Restituisce il percorso della cartella bin nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QsMech15_Inv2012_debug\bin.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
DedOptions | Restituisce le opzioni DedNetInv
DiscardDocChangesSilently | Indica se durante l'onFileDirty è necessario scartare in modo forzato e silenzioso le modifiche.
DistintaComponenti | Restituisce il comando di visualizzazione distinta componenti
EditingSketch | Variabile semaforo che, se impostata a True, indica che si sta editando uno schizzo.
EnableLogOnChange | Variabile semaforo che, se impostata a True, abilita il log del cambio occorrenza. Viene imposta nel file LUA presente sotto la cartella PERS.
EnforceCheckOutSilently | Determina se durante l'onFileDirty deve porre i documenti in checkout senza chiedere nulla all'utente
FileStateManager | Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreDocStatusSilently | Determina se durante l'onFileDirty è necessario lasciare passare le modifiche senza modificare lo stato del documento. Viene utilizzato nelle funzioni di servizio che creano delle copie dei file
InNewSubstituteCreation | Restituisce se si è nel comando di nuovo livello di dettaglio sostituto.
InvApp | Restituisce l'applicazione di Inventor.
IsDedInvOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsDedInvOpenOnAfterActivation | Indica se è in esecuzione il post attivazione di apertura di un documento di Inventor.
IsDedInvSaveInDBRunning | Restituisce se il salva nel database sia o meno in esecuzione.
IsDedInvSaveRevRunning | Restituisce se il salva revisione sia o meno in esecuzione.
IsFileResolutionEventFiring | Indica se è in corso la gestione dell'evento di risoluzione file
IsMigratingOperationRunning | Indica se è in esecuzione la migrazione di un file.
IsSavingOnOpenEventStateCommand | Indica se il salvataggio è avvenuto nell'evento di apertura del cambio stato
IsStateCommandRunning | Indica se è in esecuzione un comando di cambio stato
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
ReplaceComponent | Restituisce il form di sostituzione dei componet
ReplaceComponentForm | Restituisce il form di sostituzione dei componet
Ricerca | Restituisce il comando per effettuare la ricerca.
ServiceOpeningSubstituteDocument | Indica se è in corso una apertura del sostituto di servizio
ShowAttributi | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
ShowDipendenze | Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.
ShowDocumentAssistant | Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
Torna su
Metodi
 | Nome | Descrizione
 | AddOnHelpEventCommand | Metodo che aggiunge al ButtonDefinition, l'evento di OnHelp che permette di aprire una specifica pagina del manuale.
Metodo pubblico | AllowHotTracking | Determina se l'elemento è passibile di hot tracking
 | ApplicationEvents_OnNewDocument | Evento creazione nuovo documento. Dopo la creazione imposto il displayname con il randomico in modo da non trovarmi parte1 o assieme1. Lo faccio solo sui modelli perchè gli altri documenti sono salvati sempre come file associati.
 | BeginApprenticeServer | Inizializza l'apprentice oppure ne incrementa il contatore. Se restituisce false vuol dire che non è disponibile su questa postazione.
 | CreaArchiviaDoc | Crea e restituisce il comando di Archivia documento.
 | CreaArchiviaDocParte | Crea e restituisce il comando di Archivia documento.
 | CreaFindInRicerca | Crea e restituisce il comando di Individua nella ricerca.
 | CreateAggiornaAttributidaDB | Crea e restituisce il comando di Aggiornamento attributi dal database.
 | CreateAggiornaDocumentoLocale | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateAllineaAttributi | Crea e restituisce il comando di AllineaAttributi.
 | CreateAllineaAttributiRicorsivo | Crea e restituisce il comando di AllineaAttributiRicorsivo.
 | CreateAnnullaCheckoOut | Crea il comando annulla checkout su selezione
 | CreateApriconOpzioniComponente | Crea e restituisce il comando di apri con opzioni
 | CreateApriFileAllegati | Crea e restituisce il comando di Apertura file associati.
 | CreateApriFileAssociati | Crea e restituisce il comando di Apertura file associati.
 | CreateApriInLettura | Crea e restituisce il comando di apri in lettura.
 | CreateApriInModifica | Crea e restituisce il comando di apri in modifica.
 | CreateApriInNuovaFinestra | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateAssociaPresentazione | Crea e restituisce il comando Associa Presentazione
 | CreateAssociaTavola | Crea e restituisce il comando Associa Tavola
 | CreateAssociatedECO | Crea e restituisce il comando di Visualizza ECO associati.
 | CreateAssociatedTranslations | Crea e restituisce il comando di Visualizza traduzioni.
 | CreateCambiaPassword | Crea e restituisce il comando di Cambia password.
 | CreateCambioStato | Crea e restituisce il comando di cambio stato.
 | CreateCambioStatoMultiplo | Crea e restituisce il comando di cambio stato.
 | CreateCaricaBody | Crea e restituisce il comando di carica parte.
 | CreateCaricaNuovaRapp | Crea e restituisce il comando di carica nuova rappresentazione.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteDerivato | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteOpzioni | Crea e restituisce il comando di carica parte con opzioni.
 | CreateCheckIn | Crea il comando checkin su singolo documento
 | CreateCheckInAssociati | Creo il comando singolo di checkin con associati
 | CreateCheckInStruttura | Crea il comando checkin che propaga a tutta la struttura
 | CreateCheckInStrutturaAssociati | Crea il comando checkin che propaga a tutta la struttura considerando anche i file associati
 | CreateCheckOut | Crea il comando checkout su singolo documento
 | CreateCheckOutStruttura | Crea il comando checkout struttura
 | CreateCheckOutStrutturaDirty | Crea il comando checkout struttura
 | CreateCompileFactoryTableAttrs | Creazione comando di aggionrnamento member di iPartFactory
 | CreateComponenteDaAnagrafica | Crea e restituisce il comando di ComponenteDaAnagrafica.
 | CreateConfiguraDistinta | Crea e restituisce il comando di Configura Distinta.
 | CreateControlloCoerenzaRiferimenti | Crea e restituisce il comando Sostituisci Modello Tavola
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di Crea tavola ricambi.
 | CreateDistintaComponenti | Crea e restituisce il comando di Distinta componenti.
 | CreateDistintaEsplosa | Crea e restituisce il comando di Distinta Esplosa.
 | CreateDistintaImplosa | Crea e restituisce il comando di Distinta Implosa.
 | CreateDocAssocInv | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateDocRecognizer | Crea e restituisce il comando di registrazione files.
 | CreateDocumentStatesAnalyzer | Crea e restituisce il comando di analisi stati
 | CreateDownloadProject | Crea e restituisce il comando DownloadProject.
 | CreateEditaAttributiSoloDB | Crea e restituisce il comando EditaAttributiSoloDb.
 | CreateEditaCommesse | Crea e restituisce il comando di Edita commesse.
 | CreateEditaDistinta | Crea e restituisce il comando di Edita distinta.
 | CreateEditaECO | Crea e restituisce il comando di Edita ECO.
 | CreateEseguiLua | Crea e restituisce il comando di Apertura file associati.
 | CreateForceMarkerAlingment | Crea il comando per forzare l'allineamento del docuemnto
 | CreateFormAbout | Crea e restituisce il comando di About.
 | CreateHelp | Crea e restituisce il comando di Help.
 | CreateIndividuaGrafica | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateInvAssociaConf | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateInvAssociaConfPrt | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateInvAssociaDocument | Crea e restituisce il comando CreaInvAssociaDocument.
 | CreateInvAssociaDocumentPrt | Crea e restituisce il comando CreaInvAssociaDocument parte.
 | CreateInvScollegaConf | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateLavorazione | Crea e ritorna il comando di poni in lavorazione.
 | CreateLavorazioneMultiplo | Crea e ritorna il comando di poni in lavorazione.
 | CreateLinkDED | Crea e restituisce il comando di LinkDEDApplicazione.
 | CreateLoginCommand | Crea e restituisce il comando specifico di login
 | CreateMarkerInfo | Crea il comando per visualizzare lo stato di allineamento del documento
 | CreateModificaSuperato | Crea e ritorna il comando di RettificaSuperato.
 | CreateNewRepresentation | Crea e ritorna il comando di nuova rappresentazione
 | CreateNewRicerca | Crea e restituisce il comando di nuova ricerca.
 | CreateOpzioniApplicazione | Crea e restituisce il comando di Opzioni Applicazione.
 | CreatePackAndGoExport | Crea e restituisce il comando di apri con opzioni
 | CreatePackAndGoImport | Crea e restituisce il comando CreaInvAssociaDocument parte.
 | CreatePublish | Crea il comando pubblica su singolo documento
 | CreatePublishProject | Crea e restituisce il comando UploadProject.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | CreatePublishStruttura | Crea il comando pubblica su singolo documento
 | CreatePwsCache | Crea e restituisce il comando di Gestione dell'area locale.
 | CreateRegistra | Crea il comando registrazione documento
 | CreateReleaseFactoryMember | Creazione comando di rilascio factory e tutti i member
 | CreateRicerca | Crea e restituisce il comando di ricerca.
 | CreateRicercaDocAssociati | Crea e restituisce il comando di rappresentazioni.
 | CreateRicercaDocumenti | Crea e restituisce il comando di ricerca documentale.
 | CreateRilascio | Crea e restituisce il comando di rilascio.
 | CreateRilascioMultiplo | Crea e restituisce il comando di rilascio.
 | CreateSalva | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaDist | Crea e restituisce il comando di Salva Distinta
 | CreateSalvaMultiplo | Crea e restituisce il comando di Salva Multiplo.
 | CreateSalvaPartBody | Crea e restituisce il comando di Salva Part Body.
 | CreateSalvaPrt | Crea e restituisce il comando di Salva Parte nel Database.
 | CreateSalvaPrtConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaPrtRev | Crea e restituisce il comando di Salva Parte Revisione.
 | CreateSalvaPrtVariante | Crea e restituisce il comando di Salva Parte Variante nel Database.
 | CreateSalvaPrtVarianteConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaRev | Crea e restituisce il comando di Salva Revisione.
 | CreateSalvaSuperato | Crea e ritorna il comando di SalvaSuperato.
 | CreateSalvaVariante | Crea e restituisce il comando di Salva Variante nel Database.
 | CreateSalvaVarianteConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSaveFactoryMemberRevision | Creazione comando di revisione di tutti i member
 | CreateSblocca | Crea il comando sblocca su singolo documento
 | CreateSostituisciComponente | Crea e restituisce il comando di sostituisci componente
 | CreateSostituisciComponenteDerivato | Crea e restituisce il comando di sostituisci componente
 | CreateSostituisciComponenteRapidoSelezione | Crea e restituisce il comando di sostituisci componente rapido sulla selezione
 | CreateSostituisciComponenteRapidoTutti | Crea e restituisce il comando di sostituisci componente rapido tutti
 | CreateSostituisciComponenteRapidoTuttiStessoLivello | Crea e restituisce il comando di sostituisci componente rapido stesso padre
 | CreateSostituisciMoved | Crea il comando di sostituzione dei documenti che sono "moved".
 | CreateSostituisciRiferimenti | Crea e restituisce il comando Sostituisci Modello Tavola
 | CreateStatoDocumento | Crea e restituisce il comando di stato documento.
 | CreateTabellaRevisioni | Crea e restituisce il comando di Tabella Revisioni.
 | CreateTrovaNelBrowser | Crea e restituisce il comando "Trova nel Browser"
 | CreateUpdateBranchInformations | Creo il comando di caricamento informazioni del ramo
 | CreateUpdateMembersFromFactory | Creazione comando di aggionrnamento member di iPartFactory
 | CreateUpdateOldRev | Crea e restituisce il comando di Aggiornamento revisioni superate.
 | CreateWhereUsedInv | Crea il comando di aggiornamento della versione locale dei documenti
 | CreaVisualaDiagDep | Crea e restituisce il comando di Albero dipendenze avanzato.
Metodo pubblico | DedpTopDistPre | Gestione evento DedpTopDistPre
 | EndApprenticeServer | Chiude l'apprentice oppure ne decrementa il contatore.
 | FindCommandByInternalName | Metodo che ritorna l'oggetto 'InvCommandBase' rappresentante il comando specificato in ingresso.
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetAnagStateName | Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato
Metodo pubblico | GetAttr | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...
Metodo pubblico | GetData | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetMovedDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetSelectionImageKey | Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce il nome dell'immagine che descrive lo stato di un elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento passato possiede figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è associaoto ad un documento dirty
Metodo pubblico | IsInventorFile | Verifica se un file appartenga o meno ad Inventor.
 | Log | Registra l'eccezione nel file di log dell'applicazione.
 | LogError | Registra l'informazione nel file di log dell'applicazione.
 | LogInfo | Registra l'informazione nel file di log dell'applicazione.
 | LogWarning | Registra il warning nel file di log dell'applicazione.
Metodo pubblico | MakeInvCommandContext | Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.
 | OnAddTiesApprenticeEvent | Lancia l'evento di AddTiesApprenticeEvent
 | OnAskCopyAttrOnDerivedEvent | Lancia l'evento di AskCopyAttrOnDerivedEvent
 | OnChangeDsInfoStructOnPackAndGoExportEvent | Lancia l'evento di ChangeDocStructInfoStructureOnPackAndGoExportEvent
 | OnDedInvInvokeBasePublishEvent | Lancia evento legato all'invoke del ded della pubblicazione di base
 | OnDedInvPublishEvent | Lancia evento di pubblicazione formati in Inventor
Metodo pubblico | OnElementDoubleClicked | Gestione doppio click su elemento
Metodo pubblico | OnElementsSelected | Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento
Metodo pubblico | OnHotTrackElementClicked | Gestione click singolo su elemento hottracked
 | OnImportMemberOnSaveEvent | Lancia l'evento di ImportMemberOnSaveEvent
 | OnImportOnSaveEvent | Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
 | OnInvRilInvRilCheckCoherence | Lancia evento di gestione controllo coerenza riferimenti al rilascio in Inventor
 | OnInvRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
 | OnModifyingDocumentsEvent |
 | OnMultiSaverElaborateItemEvent | Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.
 | OnMultiSaverElaborateStructEvent | Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.
 | OnMultiSaverOverrideDedTypeEvent | Lancia evento di override della famiglia in fase di salva multiplo
 | OnMultiSaverPopulateListEvent | Lancia evento di popolamento della lista criteri di salvataggio multiplo. Permette all'utente di definire nuove modalità o sovrascrivere le modalità predefinite.
Torna su
Eventi
Nome | Descrizione
AddTiesApprenticeEvent | Evento per gestire la creazione dei Ties tramite Apprentice.
AskCopyAttrOnDerivedEvent | Evento che permette l'override della richiesta di copia attributi nel comando di carica parte come derivato
ChangeDsInfoStructOnPackAndGoExportEvent |
DedInvInvokeBasePublishEvent | Evento legato all'invoke del ded della pubblicazione di base
DedInvPublishEvent | Evento di pubblicazione formati in Inventor
ImportMemberOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio degli iPartMember o iAssemblyMember
ImportOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
InvRilInvRilCheckCoherence | Evento di gestione controllo coerenza riferimenti al rilascio in Inventor
InvRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
ModifyingDocumentsEvent | Evento per la gestione della scelta del checkout o no dei documento sul file dirty.
MultiSaverElaborateItemEvent | Evento di popolamento della lista criteri di salvataggio multiplo
MultiSaverElaborateStructEvent | Evento di popolamento della lista criteri di salvataggio multiplo
MultiSaverOverrideDedTypeEvent | Evento di override famiglia di salvataggio multiplo
MultiSaverPopulateListEvent | Evento di popolamento della lista criteri di salvataggio multiplo
Torna su
Campi
Nome | Descrizione
_isDedInvSaveRevRunning | Inidica se il salva revisione sia o meno in esecuzione
ATTRIBUTEFORM |
DedNetInvDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DOCUMENTASSISTANT |
DOCUMENTSFORM |
OpenSyncMonitor | Monitor per sapere se un particolare sia o meno in fase di apertura.
REPLACECOMPONENTFORM |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Proprietà di DedNetInvApp

Il tipo DedNetInvApp espone i seguenti membri.

Proprietà
Nome | Descrizione
ActiveProjectIsShared | Restituisce se il progetto attivo sia shared.
AddInClassID | Restituisce il classid in formato stringa da utilizzare per la registrazione dei menu.
AllowSaveRevisionOniPart | Indica se permettere la revisione su iPart o iAssembly
ApprenticeServer | Apprentice di Inventor.
AssemblyInvPath | Restituisce il percorso della cartella bin nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QsMech15_Inv2012_debug\bin.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
DedOptions | Restituisce le opzioni DedNetInv
DiscardDocChangesSilently | Indica se durante l'onFileDirty è necessario scartare in modo forzato e silenzioso le modifiche.
DistintaComponenti | Restituisce il comando di visualizzazione distinta componenti
EditingSketch | Variabile semaforo che, se impostata a True, indica che si sta editando uno schizzo.
EnableLogOnChange | Variabile semaforo che, se impostata a True, abilita il log del cambio occorrenza. Viene imposta nel file LUA presente sotto la cartella PERS.
EnforceCheckOutSilently | Determina se durante l'onFileDirty deve porre i documenti in checkout senza chiedere nulla all'utente
FileStateManager | Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreDocStatusSilently | Determina se durante l'onFileDirty è necessario lasciare passare le modifiche senza modificare lo stato del documento. Viene utilizzato nelle funzioni di servizio che creano delle copie dei file
InNewSubstituteCreation | Restituisce se si è nel comando di nuovo livello di dettaglio sostituto.
InvApp | Restituisce l'applicazione di Inventor.
IsDedInvOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsDedInvOpenOnAfterActivation | Indica se è in esecuzione il post attivazione di apertura di un documento di Inventor.
IsDedInvSaveInDBRunning | Restituisce se il salva nel database sia o meno in esecuzione.
IsDedInvSaveRevRunning | Restituisce se il salva revisione sia o meno in esecuzione.
IsFileResolutionEventFiring | Indica se è in corso la gestione dell'evento di risoluzione file
IsMigratingOperationRunning | Indica se è in esecuzione la migrazione di un file.
IsSavingOnOpenEventStateCommand | Indica se il salvataggio è avvenuto nell'evento di apertura del cambio stato
IsStateCommandRunning | Indica se è in esecuzione un comando di cambio stato
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
ReplaceComponent | Restituisce il form di sostituzione dei componet
ReplaceComponentForm | Restituisce il form di sostituzione dei componet
Ricerca | Restituisce il comando per effettuare la ricerca.
ServiceOpeningSubstituteDocument | Indica se è in corso una apertura del sostituto di servizio
ShowAttributi | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
ShowDipendenze | Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.
ShowDocumentAssistant | Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
Torna su
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ActiveProjectIsShared

Proprietà DedNetInvAppActiveProjectIsShared

Restituisce se il progetto attivo sia shared.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ActiveProjectIsShared { get; }
Public Shared ReadOnly Property ActiveProjectIsShared As Boolean
    Get
public:
static property bool ActiveProjectIsShared {
    bool get ();
}
static member ActiveProjectIsShared : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.AddInClassID

Proprietà DedNetInvAppAddInClassID

Restituisce il classid in formato stringa da utilizzare per la registrazione dei menu.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string AddInClassID { get; }
Public Shared ReadOnly Property AddInClassID As String
    Get
public:
static property String^ AddInClassID {
    String^ get ();
}
static member AddInClassID : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.AllowSaveRevisionOniPart

Proprietà DedNetInvAppAllowSaveRevisionOniPart

Indica se permettere la revisione su iPart o iAssembly

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool AllowSaveRevisionOniPart { get; set; }
Public Shared Property AllowSaveRevisionOniPart As Boolean
    Get
    Set
public:
static property bool AllowSaveRevisionOniPart {
    bool get ();
    void set (bool value);
}
static member AllowSaveRevisionOniPart : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ApprenticeServer

Proprietà DedNetInvAppApprenticeServer

Apprentice di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InvApprNetApplicationInterface ApprenticeServer { get; }
Public Shared ReadOnly Property ApprenticeServer As InvApprNetApplicationInterface
    Get
public:
static property InvApprNetApplicationInterface^ ApprenticeServer {
    InvApprNetApplicationInterface^ get ();
}
static member ApprenticeServer : InvApprNetApplicationInterface with get

Valore della proprietà

Tipo: InvApprNetApplicationInterface
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.AssemblyInvPath

Proprietà DedNetInvAppAssemblyInvPath

Restituisce il percorso della cartella bin nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QsMech15_Inv2012_debug\bin.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string AssemblyInvPath { get; }
Public Shared ReadOnly Property AssemblyInvPath As String
    Get
public:
static property String^ AssemblyInvPath {
    String^ get ();
}
static member AssemblyInvPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.DedNetApp

Proprietà DedNetInvAppDedNetApp

Restituisce l'applicazione DedNetApplication sottostante.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication DedNetApp { get; }
Public Shared ReadOnly Property DedNetApp As DedNetApplication
    Get
public:
static property DedNetApplication^ DedNetApp {
    DedNetApplication^ get ();
}
static member DedNetApp : DedNetApplication with get

Valore della proprietà

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.DedNetInstallPath

Proprietà DedNetInvAppDedNetInstallPath

Restituisce il percorso di installazione del DedNet.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string DedNetInstallPath { get; }
Public Shared ReadOnly Property DedNetInstallPath As String
    Get
public:
static property String^ DedNetInstallPath {
    String^ get ();
}
static member DedNetInstallPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.DedOptions

Proprietà DedNetInvAppDedOptions

Restituisce le opzioni DedNetInv

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Options DedOptions { get; }
Public Shared ReadOnly Property DedOptions As Options
    Get
public:
static property Options^ DedOptions {
    Options^ get ();
}
static member DedOptions : Options with get

Valore della proprietà

Tipo: Options
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.DiscardDocChangesSilently

Proprietà DedNetInvAppDiscardDocChangesSilently

Indica se durante l'onFileDirty è necessario scartare in modo forzato e silenzioso le modifiche.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DiscardDocChangesSilently { get; set; }
Public Shared Property DiscardDocChangesSilently As Boolean
    Get
    Set
public:
static property bool DiscardDocChangesSilently {
    bool get ();
    void set (bool value);
}
static member DiscardDocChangesSilently : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.DistintaComponenti

Proprietà DedNetInvAppDistintaComponenti

Restituisce il comando di visualizzazione distinta componenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaComponenti DistintaComponenti { get; }
Public Shared ReadOnly Property DistintaComponenti As DistintaComponenti
    Get
public:
static property DistintaComponenti^ DistintaComponenti {
    DistintaComponenti^ get ();
}
static member DistintaComponenti : DistintaComponenti with get

Valore della proprietà

Tipo: DistintaComponenti
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.EditingSketch

Proprietà DedNetInvAppEditingSketch

Variabile semaforo che, se impostata a True, indica che si sta editando uno schizzo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool EditingSketch { get; }
Public Shared ReadOnly Property EditingSketch As Boolean
    Get
public:
static property bool EditingSketch {
    bool get ();
}
static member EditingSketch : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.EnableLogOnChange

Proprietà DedNetInvAppEnableLogOnChange

Variabile semaforo che, se impostata a True, abilita il log del cambio occorrenza. Viene imposta nel file LUA presente sotto la cartella PERS.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool EnableLogOnChange { get; set; }
Public Shared Property EnableLogOnChange As Boolean
    Get
    Set
public:
static property bool EnableLogOnChange {
    bool get ();
    void set (bool value);
}
static member EnableLogOnChange : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.EnforceCheckOutSilently

Proprietà DedNetInvAppEnforceCheckOutSilently

Determina se durante l'onFileDirty deve porre i documenti in checkout senza chiedere nulla all'utente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool EnforceCheckOutSilently { get; set; }
Public Shared Property EnforceCheckOutSilently As Boolean
    Get
    Set
public:
static property bool EnforceCheckOutSilently {
    bool get ();
    void set (bool value);
}
static member EnforceCheckOutSilently : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.FileStateManager

Proprietà DedNetInvAppFileStateManager

Restituisce l'oggetto gestore dello stato dei file. Utilizzato dal browser delle dipendenze dei documenti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FileStateManager FileStateManager { get; }
Public Shared ReadOnly Property FileStateManager As FileStateManager
    Get
public:
static property FileStateManager^ FileStateManager {
    FileStateManager^ get ();
}
static member FileStateManager : FileStateManager with get

Valore della proprietà

Tipo: FileStateManager
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.HideCompareDialogOnSavingDwg

Proprietà DedNetInvAppHideCompareDialogOnSavingDwg

Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HideCompareDialogOnSavingDwg { get; set; }
Public Shared Property HideCompareDialogOnSavingDwg As Boolean
    Get
    Set
public:
static property bool HideCompareDialogOnSavingDwg {
    bool get ();
    void set (bool value);
}
static member HideCompareDialogOnSavingDwg : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.HideWarningMessageOnModDocCheckout

Proprietà DedNetInvAppHideWarningMessageOnModDocCheckout

Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HideWarningMessageOnModDocCheckout { get; set; }
Public Shared Property HideWarningMessageOnModDocCheckout As Boolean
    Get
    Set
public:
static property bool HideWarningMessageOnModDocCheckout {
    bool get ();
    void set (bool value);
}
static member HideWarningMessageOnModDocCheckout : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IgnoreDocStatusSilently

Proprietà DedNetInvAppIgnoreDocStatusSilently

Determina se durante l'onFileDirty è necessario lasciare passare le modifiche senza modificare lo stato del documento. Viene utilizzato nelle funzioni di servizio che creano delle copie dei file

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreDocStatusSilently { get; set; }
Public Shared Property IgnoreDocStatusSilently As Boolean
    Get
    Set
public:
static property bool IgnoreDocStatusSilently {
    bool get ();
    void set (bool value);
}
static member IgnoreDocStatusSilently : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.InNewSubstituteCreation

Proprietà DedNetInvAppInNewSubstituteCreation

Restituisce se si è nel comando di nuovo livello di dettaglio sostituto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool InNewSubstituteCreation { get; }
Public Shared ReadOnly Property InNewSubstituteCreation As Boolean
    Get
public:
static property bool InNewSubstituteCreation {
    bool get ();
}
static member InNewSubstituteCreation : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.InvApp

Proprietà DedNetInvAppInvApp

Restituisce l'applicazione di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Application InvApp { get; }
Public Shared ReadOnly Property InvApp As Application
    Get
public:
static property Application^ InvApp {
    Application^ get ();
}
static member InvApp : Application with get

Valore della proprietà

Tipo: Application
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsDedInvOpenDocRunning

Proprietà DedNetInvAppIsDedInvOpenDocRunning

Indica se è in esecuzione il comando di apertura documenti di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedInvOpenDocRunning { get; set; }
Public Shared Property IsDedInvOpenDocRunning As Boolean
    Get
    Set
public:
static property bool IsDedInvOpenDocRunning {
    bool get ();
    void set (bool value);
}
static member IsDedInvOpenDocRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsDedInvOpenOnAfterActivation

Proprietà DedNetInvAppIsDedInvOpenOnAfterActivation

Indica se è in esecuzione il post attivazione di apertura di un documento di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedInvOpenOnAfterActivation { get; set; }
Public Shared Property IsDedInvOpenOnAfterActivation As Boolean
    Get
    Set
public:
static property bool IsDedInvOpenOnAfterActivation {
    bool get ();
    void set (bool value);
}
static member IsDedInvOpenOnAfterActivation : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsDedInvSaveInDBRunning

Proprietà DedNetInvAppIsDedInvSaveInDBRunning

Restituisce se il salva nel database sia o meno in esecuzione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedInvSaveInDBRunning { get; }
Public Shared ReadOnly Property IsDedInvSaveInDBRunning As Boolean
    Get
public:
static property bool IsDedInvSaveInDBRunning {
    bool get ();
}
static member IsDedInvSaveInDBRunning : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsDedInvSaveRevRunning

Proprietà DedNetInvAppIsDedInvSaveRevRunning

Restituisce se il salva revisione sia o meno in esecuzione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedInvSaveRevRunning { get; }
Public Shared ReadOnly Property IsDedInvSaveRevRunning As Boolean
    Get
public:
static property bool IsDedInvSaveRevRunning {
    bool get ();
}
static member IsDedInvSaveRevRunning : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsFileResolutionEventFiring

Proprietà DedNetInvAppIsFileResolutionEventFiring

Indica se è in corso la gestione dell'evento di risoluzione file

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFileResolutionEventFiring { get; set; }
Public Shared Property IsFileResolutionEventFiring As Boolean
    Get
    Set
public:
static property bool IsFileResolutionEventFiring {
    bool get ();
    void set (bool value);
}
static member IsFileResolutionEventFiring : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsMigratingOperationRunning

Proprietà DedNetInvAppIsMigratingOperationRunning

Indica se è in esecuzione la migrazione di un file.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMigratingOperationRunning { get; set; }
Public Shared Property IsMigratingOperationRunning As Boolean
    Get
    Set
public:
static property bool IsMigratingOperationRunning {
    bool get ();
    void set (bool value);
}
static member IsMigratingOperationRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsSavingOnOpenEventStateCommand

Proprietà DedNetInvAppIsSavingOnOpenEventStateCommand

Indica se il salvataggio è avvenuto nell'evento di apertura del cambio stato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSavingOnOpenEventStateCommand { get; set; }
Public Shared Property IsSavingOnOpenEventStateCommand As Boolean
    Get
    Set
public:
static property bool IsSavingOnOpenEventStateCommand {
    bool get ();
    void set (bool value);
}
static member IsSavingOnOpenEventStateCommand : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.IsStateCommandRunning

Proprietà DedNetInvAppIsStateCommandRunning

Indica se è in esecuzione un comando di cambio stato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsStateCommandRunning { get; set; }
Public Shared Property IsStateCommandRunning As Boolean
    Get
    Set
public:
static property bool IsStateCommandRunning {
    bool get ();
    void set (bool value);
}
static member IsStateCommandRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.LuaApp

Proprietà DedNetInvAppLuaApp

Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedLuaApplication LuaApp { get; }
Public Shared ReadOnly Property LuaApp As DedLuaApplication
    Get
public:
static property DedLuaApplication^ LuaApp {
    DedLuaApplication^ get ();
}
static member LuaApp : DedLuaApplication with get

Valore della proprietà

Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ReplaceComponent

Proprietà DedNetInvAppReplaceComponent

Restituisce il form di sostituzione dei componet

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponente ReplaceComponent { get; }
Public Shared ReadOnly Property ReplaceComponent As SostituisciComponente
    Get
public:
static property SostituisciComponente^ ReplaceComponent {
    SostituisciComponente^ get ();
}
static member ReplaceComponent : SostituisciComponente with get

Valore della proprietà

Tipo: SostituisciComponente
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ReplaceComponentForm

Proprietà DedNetInvAppReplaceComponentForm

Restituisce il form di sostituzione dei componet

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedInvReplaceComponentForm ReplaceComponentForm { get; }
Public Shared ReadOnly Property ReplaceComponentForm As DedInvReplaceComponentForm
    Get
public:
static property DedInvReplaceComponentForm^ ReplaceComponentForm {
    DedInvReplaceComponentForm^ get ();
}
static member ReplaceComponentForm : DedInvReplaceComponentForm with get

Valore della proprietà

Tipo: DedInvReplaceComponentForm
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.Ricerca

Proprietà DedNetInvAppRicerca

Restituisce il comando per effettuare la ricerca.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindCommand Ricerca { get; }
Public Shared ReadOnly Property Ricerca As FindCommand
    Get
public:
static property FindCommand^ Ricerca {
    FindCommand^ get ();
}
static member Ricerca : FindCommand with get

Valore della proprietà

Tipo: FindCommand
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ServiceOpeningSubstituteDocument

Proprietà DedNetInvAppServiceOpeningSubstituteDocument

Indica se è in corso una apertura del sostituto di servizio

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ServiceOpeningSubstituteDocument { get; set; }
Public Shared Property ServiceOpeningSubstituteDocument As Boolean
    Get
    Set
public:
static property bool ServiceOpeningSubstituteDocument {
    bool get ();
    void set (bool value);
}
static member ServiceOpeningSubstituteDocument : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ShowAttributi

Proprietà DedNetInvAppShowAttributi

Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Attributi ShowAttributi { get; }
Public Shared ReadOnly Property ShowAttributi As Attributi
    Get
public:
static property Attributi^ ShowAttributi {
    Attributi^ get ();
}
static member ShowAttributi : Attributi with get

Valore della proprietà

Tipo: Attributi
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ShowDipendenze

Proprietà DedNetInvAppShowDipendenze

Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AlberoDocumenti ShowDipendenze { get; }
Public Shared ReadOnly Property ShowDipendenze As AlberoDocumenti
    Get
public:
static property AlberoDocumenti^ ShowDipendenze {
    AlberoDocumenti^ get ();
}
static member ShowDipendenze : AlberoDocumenti with get

Valore della proprietà

Tipo: AlberoDocumenti
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.ShowDocumentAssistant

Proprietà DedNetInvAppShowDocumentAssistant

Restituisce il comando di visualizzazione dipendenze utilizzato dall'add-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocumentAssistant ShowDocumentAssistant { get; }
Public Shared ReadOnly Property ShowDocumentAssistant As DocumentAssistant
    Get
public:
static property DocumentAssistant^ ShowDocumentAssistant {
    DocumentAssistant^ get ();
}
static member ShowDocumentAssistant : DocumentAssistant with get

Valore della proprietà

Tipo: DocumentAssistant
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Proprietà DedNetInvApp.Xmx

Proprietà DedNetInvAppXmx

Restitusice l'oggetto per la traduzione dei messaggi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static XMX Xmx { get; }
Public Shared ReadOnly Property Xmx As XMX
    Get
public:
static property XMX^ Xmx {
    XMX^ get ();
}
static member Xmx : XMX with get

Valore della proprietà

Tipo: XMX
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodi di DedNetInvApp

Il tipo DedNetInvApp espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | AddOnHelpEventCommand | Metodo che aggiunge al ButtonDefinition, l'evento di OnHelp che permette di aprire una specifica pagina del manuale.
Metodo pubblico | AllowHotTracking | Determina se l'elemento è passibile di hot tracking
 | ApplicationEvents_OnNewDocument | Evento creazione nuovo documento. Dopo la creazione imposto il displayname con il randomico in modo da non trovarmi parte1 o assieme1. Lo faccio solo sui modelli perchè gli altri documenti sono salvati sempre come file associati.
 | BeginApprenticeServer | Inizializza l'apprentice oppure ne incrementa il contatore. Se restituisce false vuol dire che non è disponibile su questa postazione.
 | CreaArchiviaDoc | Crea e restituisce il comando di Archivia documento.
 | CreaArchiviaDocParte | Crea e restituisce il comando di Archivia documento.
 | CreaFindInRicerca | Crea e restituisce il comando di Individua nella ricerca.
 | CreateAggiornaAttributidaDB | Crea e restituisce il comando di Aggiornamento attributi dal database.
 | CreateAggiornaDocumentoLocale | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateAllineaAttributi | Crea e restituisce il comando di AllineaAttributi.
 | CreateAllineaAttributiRicorsivo | Crea e restituisce il comando di AllineaAttributiRicorsivo.
 | CreateAnnullaCheckoOut | Crea il comando annulla checkout su selezione
 | CreateApriconOpzioniComponente | Crea e restituisce il comando di apri con opzioni
 | CreateApriFileAllegati | Crea e restituisce il comando di Apertura file associati.
 | CreateApriFileAssociati | Crea e restituisce il comando di Apertura file associati.
 | CreateApriInLettura | Crea e restituisce il comando di apri in lettura.
 | CreateApriInModifica | Crea e restituisce il comando di apri in modifica.
 | CreateApriInNuovaFinestra | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateAssociaPresentazione | Crea e restituisce il comando Associa Presentazione
 | CreateAssociaTavola | Crea e restituisce il comando Associa Tavola
 | CreateAssociatedECO | Crea e restituisce il comando di Visualizza ECO associati.
 | CreateAssociatedTranslations | Crea e restituisce il comando di Visualizza traduzioni.
 | CreateCambiaPassword | Crea e restituisce il comando di Cambia password.
 | CreateCambioStato | Crea e restituisce il comando di cambio stato.
 | CreateCambioStatoMultiplo | Crea e restituisce il comando di cambio stato.
 | CreateCaricaBody | Crea e restituisce il comando di carica parte.
 | CreateCaricaNuovaRapp | Crea e restituisce il comando di carica nuova rappresentazione.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteDerivato | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteOpzioni | Crea e restituisce il comando di carica parte con opzioni.
 | CreateCheckIn | Crea il comando checkin su singolo documento
 | CreateCheckInAssociati | Creo il comando singolo di checkin con associati
 | CreateCheckInStruttura | Crea il comando checkin che propaga a tutta la struttura
 | CreateCheckInStrutturaAssociati | Crea il comando checkin che propaga a tutta la struttura considerando anche i file associati
 | CreateCheckOut | Crea il comando checkout su singolo documento
 | CreateCheckOutStruttura | Crea il comando checkout struttura
 | CreateCheckOutStrutturaDirty | Crea il comando checkout struttura
 | CreateCompileFactoryTableAttrs | Creazione comando di aggionrnamento member di iPartFactory
 | CreateComponenteDaAnagrafica | Crea e restituisce il comando di ComponenteDaAnagrafica.
 | CreateConfiguraDistinta | Crea e restituisce il comando di Configura Distinta.
 | CreateControlloCoerenzaRiferimenti | Crea e restituisce il comando Sostituisci Modello Tavola
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di Crea tavola ricambi.
 | CreateDistintaComponenti | Crea e restituisce il comando di Distinta componenti.
 | CreateDistintaEsplosa | Crea e restituisce il comando di Distinta Esplosa.
 | CreateDistintaImplosa | Crea e restituisce il comando di Distinta Implosa.
 | CreateDocAssocInv | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateDocRecognizer | Crea e restituisce il comando di registrazione files.
 | CreateDocumentStatesAnalyzer | Crea e restituisce il comando di analisi stati
 | CreateDownloadProject | Crea e restituisce il comando DownloadProject.
 | CreateEditaAttributiSoloDB | Crea e restituisce il comando EditaAttributiSoloDb.
 | CreateEditaCommesse | Crea e restituisce il comando di Edita commesse.
 | CreateEditaDistinta | Crea e restituisce il comando di Edita distinta.
 | CreateEditaECO | Crea e restituisce il comando di Edita ECO.
 | CreateEseguiLua | Crea e restituisce il comando di Apertura file associati.
 | CreateForceMarkerAlingment | Crea il comando per forzare l'allineamento del docuemnto
 | CreateFormAbout | Crea e restituisce il comando di About.
 | CreateHelp | Crea e restituisce il comando di Help.
 | CreateIndividuaGrafica | Crea il comando di aggiornamento della versione locale dei documenti
 | CreateInvAssociaConf | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateInvAssociaConfPrt | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateInvAssociaDocument | Crea e restituisce il comando CreaInvAssociaDocument.
 | CreateInvAssociaDocumentPrt | Crea e restituisce il comando CreaInvAssociaDocument parte.
 | CreateInvScollegaConf | Crea e restituisce il comando CreaInvAssociaConf.
 | CreateLavorazione | Crea e ritorna il comando di poni in lavorazione.
 | CreateLavorazioneMultiplo | Crea e ritorna il comando di poni in lavorazione.
 | CreateLinkDED | Crea e restituisce il comando di LinkDEDApplicazione.
 | CreateLoginCommand | Crea e restituisce il comando specifico di login
 | CreateMarkerInfo | Crea il comando per visualizzare lo stato di allineamento del documento
 | CreateModificaSuperato | Crea e ritorna il comando di RettificaSuperato.
 | CreateNewRepresentation | Crea e ritorna il comando di nuova rappresentazione
 | CreateNewRicerca | Crea e restituisce il comando di nuova ricerca.
 | CreateOpzioniApplicazione | Crea e restituisce il comando di Opzioni Applicazione.
 | CreatePackAndGoExport | Crea e restituisce il comando di apri con opzioni
 | CreatePackAndGoImport | Crea e restituisce il comando CreaInvAssociaDocument parte.
 | CreatePublish | Crea il comando pubblica su singolo documento
 | CreatePublishProject | Crea e restituisce il comando UploadProject.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | CreatePublishStruttura | Crea il comando pubblica su singolo documento
 | CreatePwsCache | Crea e restituisce il comando di Gestione dell'area locale.
 | CreateRegistra | Crea il comando registrazione documento
 | CreateReleaseFactoryMember | Creazione comando di rilascio factory e tutti i member
 | CreateRicerca | Crea e restituisce il comando di ricerca.
 | CreateRicercaDocAssociati | Crea e restituisce il comando di rappresentazioni.
 | CreateRicercaDocumenti | Crea e restituisce il comando di ricerca documentale.
 | CreateRilascio | Crea e restituisce il comando di rilascio.
 | CreateRilascioMultiplo | Crea e restituisce il comando di rilascio.
 | CreateSalva | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaDist | Crea e restituisce il comando di Salva Distinta
 | CreateSalvaMultiplo | Crea e restituisce il comando di Salva Multiplo.
 | CreateSalvaPartBody | Crea e restituisce il comando di Salva Part Body.
 | CreateSalvaPrt | Crea e restituisce il comando di Salva Parte nel Database.
 | CreateSalvaPrtConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaPrtRev | Crea e restituisce il comando di Salva Parte Revisione.
 | CreateSalvaPrtVariante | Crea e restituisce il comando di Salva Parte Variante nel Database.
 | CreateSalvaPrtVarianteConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSalvaRev | Crea e restituisce il comando di Salva Revisione.
 | CreateSalvaSuperato | Crea e ritorna il comando di SalvaSuperato.
 | CreateSalvaVariante | Crea e restituisce il comando di Salva Variante nel Database.
 | CreateSalvaVarianteConf | Crea e restituisce il comando di Salva nel Database.
 | CreateSaveFactoryMemberRevision | Creazione comando di revisione di tutti i member
 | CreateSblocca | Crea il comando sblocca su singolo documento
 | CreateSostituisciComponente | Crea e restituisce il comando di sostituisci componente
 | CreateSostituisciComponenteDerivato | Crea e restituisce il comando di sostituisci componente
 | CreateSostituisciComponenteRapidoSelezione | Crea e restituisce il comando di sostituisci componente rapido sulla selezione
 | CreateSostituisciComponenteRapidoTutti | Crea e restituisce il comando di sostituisci componente rapido tutti
 | CreateSostituisciComponenteRapidoTuttiStessoLivello | Crea e restituisce il comando di sostituisci componente rapido stesso padre
 | CreateSostituisciMoved | Crea il comando di sostituzione dei documenti che sono "moved".
 | CreateSostituisciRiferimenti | Crea e restituisce il comando Sostituisci Modello Tavola
 | CreateStatoDocumento | Crea e restituisce il comando di stato documento.
 | CreateTabellaRevisioni | Crea e restituisce il comando di Tabella Revisioni.
 | CreateTrovaNelBrowser | Crea e restituisce il comando "Trova nel Browser"
 | CreateUpdateBranchInformations | Creo il comando di caricamento informazioni del ramo
 | CreateUpdateMembersFromFactory | Creazione comando di aggionrnamento member di iPartFactory
 | CreateUpdateOldRev | Crea e restituisce il comando di Aggiornamento revisioni superate.
 | CreateWhereUsedInv | Crea il comando di aggiornamento della versione locale dei documenti
 | CreaVisualaDiagDep | Crea e restituisce il comando di Albero dipendenze avanzato.
Metodo pubblico | DedpTopDistPre | Gestione evento DedpTopDistPre
 | EndApprenticeServer | Chiude l'apprentice oppure ne decrementa il contatore.
 | FindCommandByInternalName | Metodo che ritorna l'oggetto 'InvCommandBase' rappresentante il comando specificato in ingresso.
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetAnagStateName | Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato
Metodo pubblico | GetAttr | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...
Metodo pubblico | GetData | Restituisce il valore dell'attributo identificato dal nome passato
Metodo pubblico | GetDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetMovedDocument | Restituisce il documento associato all'oggetto
Metodo pubblico | GetSelectionImageKey | Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce il nome dell'immagine che descrive lo stato di un elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento passato possiede figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è associaoto ad un documento dirty
Metodo pubblico | IsInventorFile | Verifica se un file appartenga o meno ad Inventor.
 | Log | Registra l'eccezione nel file di log dell'applicazione.
 | LogError | Registra l'informazione nel file di log dell'applicazione.
 | LogInfo | Registra l'informazione nel file di log dell'applicazione.
 | LogWarning | Registra il warning nel file di log dell'applicazione.
Metodo pubblico | MakeInvCommandContext | Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.
 | OnAddTiesApprenticeEvent | Lancia l'evento di AddTiesApprenticeEvent
 | OnAskCopyAttrOnDerivedEvent | Lancia l'evento di AskCopyAttrOnDerivedEvent
 | OnChangeDsInfoStructOnPackAndGoExportEvent | Lancia l'evento di ChangeDocStructInfoStructureOnPackAndGoExportEvent
 | OnDedInvInvokeBasePublishEvent | Lancia evento legato all'invoke del ded della pubblicazione di base
 | OnDedInvPublishEvent | Lancia evento di pubblicazione formati in Inventor
Metodo pubblico | OnElementDoubleClicked | Gestione doppio click su elemento
Metodo pubblico | OnElementsSelected | Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento
Metodo pubblico | OnHotTrackElementClicked | Gestione click singolo su elemento hottracked
 | OnImportMemberOnSaveEvent | Lancia l'evento di ImportMemberOnSaveEvent
 | OnImportOnSaveEvent | Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
 | OnInvRilInvRilCheckCoherence | Lancia evento di gestione controllo coerenza riferimenti al rilascio in Inventor
 | OnInvRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
 | OnModifyingDocumentsEvent |
 | OnMultiSaverElaborateItemEvent | Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.
 | OnMultiSaverElaborateStructEvent | Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.
 | OnMultiSaverOverrideDedTypeEvent | Lancia evento di override della famiglia in fase di salva multiplo
 | OnMultiSaverPopulateListEvent | Lancia evento di popolamento della lista criteri di salvataggio multiplo. Permette all'utente di definire nuove modalità o sovrascrivere le modalità predefinite.
Torna su
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.AddOnHelpEventCommand

Metodo DedNetInvAppAddOnHelpEventCommand

Metodo che aggiunge al ButtonDefinition, l'evento di OnHelp che permette di aprire una specifica pagina del manuale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AddOnHelpEventCommand(
    ButtonDefinition item,
    string topic
)
Public Shared Sub AddOnHelpEventCommand (
    item As ButtonDefinition,
    topic As String
)
public:
static void AddOnHelpEventCommand(
    ButtonDefinition^ item,
    String^ topic
)
static member AddOnHelpEventCommand :
        item : ButtonDefinition *
        topic : string -> unit

Parametri

item
Tipo: ButtonDefinition
Bottone nella ribbon.
topic
Tipo: SystemString
Topic del manuale da aprire se premuto il tasto F1.
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.AllowHotTracking

Metodo DedNetInvAppAllowHotTracking

Determina se l'elemento è passibile di hot tracking

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
virtual bool AllowHotTracking(
    FileStateElement^ el
) sealed
abstract AllowHotTracking :
        el : FileStateElement -> bool
override AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean

Implementa

IFileStateInformerAllowHotTracking(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.ApplicationEvents_OnNewDocument

Metodo DedNetInvAppApplicationEvents_OnNewDocument

Evento creazione nuovo documento. Dopo la creazione imposto il displayname con il randomico in modo da non trovarmi parte1 o assieme1. Lo faccio solo sui modelli perchè gli altri documenti sono salvati sempre come file associati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void ApplicationEvents_OnNewDocument(
    _Document DocumentObject,
    EventTimingEnum BeforeOrAfter,
    NameValueMap Context,
    out HandlingCodeEnum HandlingCode
)
Public Shared Sub ApplicationEvents_OnNewDocument (
    DocumentObject As _Document,
    BeforeOrAfter As EventTimingEnum,
    Context As NameValueMap,
    <OutAttribute> ByRef HandlingCode As HandlingCodeEnum
)
public:
static void ApplicationEvents_OnNewDocument(
    _Document^ DocumentObject,
    EventTimingEnum BeforeOrAfter,
    NameValueMap^ Context,
    [OutAttribute] HandlingCodeEnum% HandlingCode
)
static member ApplicationEvents_OnNewDocument :
        DocumentObject : _Document *
        BeforeOrAfter : EventTimingEnum *
        Context : NameValueMap *
        HandlingCode : HandlingCodeEnum byref -> unit

Parametri

DocumentObject
Tipo: _Document
BeforeOrAfter
Tipo: EventTimingEnum
Context
Tipo: NameValueMap
HandlingCode
Tipo: HandlingCodeEnum
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.BeginApprenticeServer

Metodo DedNetInvAppBeginApprenticeServer

Inizializza l'apprentice oppure ne incrementa il contatore. Se restituisce false vuol dire che non è disponibile su questa postazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool BeginApprenticeServer()
Public Shared Function BeginApprenticeServer As Boolean
public:
static bool BeginApprenticeServer()
static member BeginApprenticeServer : unit -> bool

Valore di ritorno

Tipo: Boolean
Restituisce se l'inizializzazione sia riuscita.
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreaArchiviaDoc

Metodo DedNetInvAppCreaArchiviaDoc

Crea e restituisce il comando di Archivia documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ArchiviaDoc CreaArchiviaDoc()
Public Shared Function CreaArchiviaDoc As ArchiviaDoc
public:
static ArchiviaDoc^ CreaArchiviaDoc()
static member CreaArchiviaDoc : unit -> ArchiviaDoc

Valore di ritorno

Tipo: ArchiviaDoc
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreaArchiviaDocParte

Metodo DedNetInvAppCreaArchiviaDocParte

Crea e restituisce il comando di Archivia documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ArchiviaDoc CreaArchiviaDocParte()
Public Shared Function CreaArchiviaDocParte As ArchiviaDoc
public:
static ArchiviaDoc^ CreaArchiviaDocParte()
static member CreaArchiviaDocParte : unit -> ArchiviaDoc

Valore di ritorno

Tipo: ArchiviaDoc
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreaFindInRicerca

Metodo DedNetInvAppCreaFindInRicerca

Crea e restituisce il comando di Individua nella ricerca.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindInRicerca CreaFindInRicerca()
Public Shared Function CreaFindInRicerca As FindInRicerca
public:
static FindInRicerca^ CreaFindInRicerca()
static member CreaFindInRicerca : unit -> FindInRicerca

Valore di ritorno

Tipo: FindInRicerca
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAggiornaAttributidaDB

Metodo DedNetInvAppCreateAggiornaAttributidaDB

Crea e restituisce il comando di Aggiornamento attributi dal database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AggiornaAttributiDaDB CreateAggiornaAttributidaDB()
Public Shared Function CreateAggiornaAttributidaDB As AggiornaAttributiDaDB
public:
static AggiornaAttributiDaDB^ CreateAggiornaAttributidaDB()
static member CreateAggiornaAttributidaDB : unit -> AggiornaAttributiDaDB

Valore di ritorno

Tipo: AggiornaAttributiDaDB
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAggiornaDocumentoLocale

Metodo DedNetInvAppCreateAggiornaDocumentoLocale

Crea il comando di aggiornamento della versione locale dei documenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AggiornaDocumentoLocale CreateAggiornaDocumentoLocale()
Public Shared Function CreateAggiornaDocumentoLocale As AggiornaDocumentoLocale
public:
static AggiornaDocumentoLocale^ CreateAggiornaDocumentoLocale()
static member CreateAggiornaDocumentoLocale : unit -> AggiornaDocumentoLocale

Valore di ritorno

Tipo: AggiornaDocumentoLocale
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAllineaAttributi

Metodo DedNetInvAppCreateAllineaAttributi

Crea e restituisce il comando di AllineaAttributi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AllineaAttributi CreateAllineaAttributi()
Public Shared Function CreateAllineaAttributi As AllineaAttributi
public:
static AllineaAttributi^ CreateAllineaAttributi()
static member CreateAllineaAttributi : unit -> AllineaAttributi

Valore di ritorno

Tipo: AllineaAttributi
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAllineaAttributiRicorsivo

Metodo DedNetInvAppCreateAllineaAttributiRicorsivo

Crea e restituisce il comando di AllineaAttributiRicorsivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AllineaAttributiRicorsivo CreateAllineaAttributiRicorsivo()
Public Shared Function CreateAllineaAttributiRicorsivo As AllineaAttributiRicorsivo
public:
static AllineaAttributiRicorsivo^ CreateAllineaAttributiRicorsivo()
static member CreateAllineaAttributiRicorsivo : unit -> AllineaAttributiRicorsivo

Valore di ritorno

Tipo: AllineaAttributiRicorsivo
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAnnullaCheckoOut

Metodo DedNetInvAppCreateAnnullaCheckoOut

Crea il comando annulla checkout su selezione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AnnullaCheckOut CreateAnnullaCheckoOut()
Public Shared Function CreateAnnullaCheckoOut As AnnullaCheckOut
public:
static AnnullaCheckOut^ CreateAnnullaCheckoOut()
static member CreateAnnullaCheckoOut : unit -> AnnullaCheckOut

Valore di ritorno

Tipo: AnnullaCheckOut
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriconOpzioniComponente

Metodo DedNetInvAppCreateApriconOpzioniComponente

Crea e restituisce il comando di apri con opzioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriconOpzioni CreateApriconOpzioniComponente()
Public Shared Function CreateApriconOpzioniComponente As ApriconOpzioni
public:
static ApriconOpzioni^ CreateApriconOpzioniComponente()
static member CreateApriconOpzioniComponente : unit -> ApriconOpzioni

Valore di ritorno

Tipo: ApriconOpzioni
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriFileAllegati

Metodo DedNetInvAppCreateApriFileAllegati

Crea e restituisce il comando di Apertura file associati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriFileAllegati()
Public Shared Function CreateApriFileAllegati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriFileAllegati()
static member CreateApriFileAllegati : unit -> ApriFileAssociati

Valore di ritorno

Tipo: ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriFileAssociati

Metodo DedNetInvAppCreateApriFileAssociati

Crea e restituisce il comando di Apertura file associati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriFileAssociati CreateApriFileAssociati()
Public Shared Function CreateApriFileAssociati As ApriFileAssociati
public:
static ApriFileAssociati^ CreateApriFileAssociati()
static member CreateApriFileAssociati : unit -> ApriFileAssociati

Valore di ritorno

Tipo: ApriFileAssociati
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriInLettura

Metodo DedNetInvAppCreateApriInLettura

Crea e restituisce il comando di apri in lettura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInLettura CreateApriInLettura()
Public Shared Function CreateApriInLettura As ApriInLettura
public:
static ApriInLettura^ CreateApriInLettura()
static member CreateApriInLettura : unit -> ApriInLettura

Valore di ritorno

Tipo: ApriInLettura
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriInModifica

Metodo DedNetInvAppCreateApriInModifica

Crea e restituisce il comando di apri in modifica.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInModifica CreateApriInModifica()
Public Shared Function CreateApriInModifica As ApriInModifica
public:
static ApriInModifica^ CreateApriInModifica()
static member CreateApriInModifica : unit -> ApriInModifica

Valore di ritorno

Tipo: ApriInModifica
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateApriInNuovaFinestra

Metodo DedNetInvAppCreateApriInNuovaFinestra

Crea il comando di aggiornamento della versione locale dei documenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ApriInNuovaFinestra CreateApriInNuovaFinestra()
Public Shared Function CreateApriInNuovaFinestra As ApriInNuovaFinestra
public:
static ApriInNuovaFinestra^ CreateApriInNuovaFinestra()
static member CreateApriInNuovaFinestra : unit -> ApriInNuovaFinestra

Valore di ritorno

Tipo: ApriInNuovaFinestra
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAssociaPresentazione

Metodo DedNetInvAppCreateAssociaPresentazione

Crea e restituisce il comando Associa Presentazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociaPresentazione CreateAssociaPresentazione()
Public Shared Function CreateAssociaPresentazione As AssociaPresentazione
public:
static AssociaPresentazione^ CreateAssociaPresentazione()
static member CreateAssociaPresentazione : unit -> AssociaPresentazione

Valore di ritorno

Tipo: AssociaPresentazione
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAssociaTavola

Metodo DedNetInvAppCreateAssociaTavola

Crea e restituisce il comando Associa Tavola

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociaTavola CreateAssociaTavola()
Public Shared Function CreateAssociaTavola As AssociaTavola
public:
static AssociaTavola^ CreateAssociaTavola()
static member CreateAssociaTavola : unit -> AssociaTavola

Valore di ritorno

Tipo: AssociaTavola
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAssociatedECO

Metodo DedNetInvAppCreateAssociatedECO

Crea e restituisce il comando di Visualizza ECO associati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociatedECO CreateAssociatedECO()
Public Shared Function CreateAssociatedECO As AssociatedECO
public:
static AssociatedECO^ CreateAssociatedECO()
static member CreateAssociatedECO : unit -> AssociatedECO

Valore di ritorno

Tipo: AssociatedECO
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateAssociatedTranslations

Metodo DedNetInvAppCreateAssociatedTranslations

Crea e restituisce il comando di Visualizza traduzioni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssociatedTranslations CreateAssociatedTranslations()
Public Shared Function CreateAssociatedTranslations As AssociatedTranslations
public:
static AssociatedTranslations^ CreateAssociatedTranslations()
static member CreateAssociatedTranslations : unit -> AssociatedTranslations

Valore di ritorno

Tipo: AssociatedTranslations
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCambiaPassword

Metodo DedNetInvAppCreateCambiaPassword

Crea e restituisce il comando di Cambia password.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaPassword CreateCambiaPassword()
Public Shared Function CreateCambiaPassword As CambiaPassword
public:
static CambiaPassword^ CreateCambiaPassword()
static member CreateCambiaPassword : unit -> CambiaPassword

Valore di ritorno

Tipo: CambiaPassword
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCambioStato

Metodo DedNetInvAppCreateCambioStato

Crea e restituisce il comando di cambio stato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaStato CreateCambioStato()
Public Shared Function CreateCambioStato As CambiaStato
public:
static CambiaStato^ CreateCambioStato()
static member CreateCambioStato : unit -> CambiaStato

Valore di ritorno

Tipo: CambiaStato
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCambioStatoMultiplo

Metodo DedNetInvAppCreateCambioStatoMultiplo

Crea e restituisce il comando di cambio stato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CambiaStato CreateCambioStatoMultiplo()
Public Shared Function CreateCambioStatoMultiplo As CambiaStato
public:
static CambiaStato^ CreateCambioStatoMultiplo()
static member CreateCambioStatoMultiplo : unit -> CambiaStato

Valore di ritorno

Tipo: CambiaStato
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCaricaBody

Metodo DedNetInvAppCreateCaricaBody

Crea e restituisce il comando di carica parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaBody CreateCaricaBody()
Public Shared Function CreateCaricaBody As CaricaBody
public:
static CaricaBody^ CreateCaricaBody()
static member CreateCaricaBody : unit -> CaricaBody

Valore di ritorno

Tipo: CaricaBody
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCaricaNuovaRapp

Metodo DedNetInvAppCreateCaricaNuovaRapp

Crea e restituisce il comando di carica nuova rappresentazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaNewRep CreateCaricaNuovaRapp()
Public Shared Function CreateCaricaNuovaRapp As CaricaNewRep
public:
static CaricaNewRep^ CreateCaricaNuovaRapp()
static member CreateCaricaNuovaRapp : unit -> CaricaNewRep

Valore di ritorno

Tipo: CaricaNewRep
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCaricaParte

Metodo DedNetInvAppCreateCaricaParte

Crea e restituisce il comando di carica parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParte()
Public Shared Function CreateCaricaParte As CaricaParte
public:
static CaricaParte^ CreateCaricaParte()
static member CreateCaricaParte : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCaricaParteDerivato

Metodo DedNetInvAppCreateCaricaParteDerivato

Crea e restituisce il comando di carica parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParteDerivato()
Public Shared Function CreateCaricaParteDerivato As CaricaParte
public:
static CaricaParte^ CreateCaricaParteDerivato()
static member CreateCaricaParteDerivato : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCaricaParteOpzioni

Metodo DedNetInvAppCreateCaricaParteOpzioni

Crea e restituisce il comando di carica parte con opzioni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParteOpzioni()
Public Shared Function CreateCaricaParteOpzioni As CaricaParte
public:
static CaricaParte^ CreateCaricaParteOpzioni()
static member CreateCaricaParteOpzioni : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckIn

Metodo DedNetInvAppCreateCheckIn

Crea il comando checkin su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckIn()
Public Shared Function CreateCheckIn As CheckIn
public:
static CheckIn^ CreateCheckIn()
static member CreateCheckIn : unit -> CheckIn

Valore di ritorno

Tipo: CheckIn
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckInAssociati

Metodo DedNetInvAppCreateCheckInAssociati

Creo il comando singolo di checkin con associati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInAssociati()
Public Shared Function CreateCheckInAssociati As CheckIn
public:
static CheckIn^ CreateCheckInAssociati()
static member CreateCheckInAssociati : unit -> CheckIn

Valore di ritorno

Tipo: CheckIn
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckInStruttura

Metodo DedNetInvAppCreateCheckInStruttura

Crea il comando checkin che propaga a tutta la struttura

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStruttura()
Public Shared Function CreateCheckInStruttura As CheckIn
public:
static CheckIn^ CreateCheckInStruttura()
static member CreateCheckInStruttura : unit -> CheckIn

Valore di ritorno

Tipo: CheckIn
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckInStrutturaAssociati

Metodo DedNetInvAppCreateCheckInStrutturaAssociati

Crea il comando checkin che propaga a tutta la struttura considerando anche i file associati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckInStrutturaAssociati()
Public Shared Function CreateCheckInStrutturaAssociati As CheckIn
public:
static CheckIn^ CreateCheckInStrutturaAssociati()
static member CreateCheckInStrutturaAssociati : unit -> CheckIn

Valore di ritorno

Tipo: CheckIn
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckOut

Metodo DedNetInvAppCreateCheckOut

Crea il comando checkout su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOut()
Public Shared Function CreateCheckOut As CheckOut
public:
static CheckOut^ CreateCheckOut()
static member CreateCheckOut : unit -> CheckOut

Valore di ritorno

Tipo: CheckOut
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckOutStruttura

Metodo DedNetInvAppCreateCheckOutStruttura

Crea il comando checkout struttura

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStruttura()
Public Shared Function CreateCheckOutStruttura As CheckOut
public:
static CheckOut^ CreateCheckOutStruttura()
static member CreateCheckOutStruttura : unit -> CheckOut

Valore di ritorno

Tipo: CheckOut
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCheckOutStrutturaDirty

Metodo DedNetInvAppCreateCheckOutStrutturaDirty

Crea il comando checkout struttura

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOutStrutturaDirty()
Public Shared Function CreateCheckOutStrutturaDirty As CheckOut
public:
static CheckOut^ CreateCheckOutStrutturaDirty()
static member CreateCheckOutStrutturaDirty : unit -> CheckOut

Valore di ritorno

Tipo: CheckOut
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCompileFactoryTableAttrs

Metodo DedNetInvAppCreateCompileFactoryTableAttrs

Creazione comando di aggionrnamento member di iPartFactory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CompileFactoryTableAttrs CreateCompileFactoryTableAttrs()
Public Shared Function CreateCompileFactoryTableAttrs As CompileFactoryTableAttrs
public:
static CompileFactoryTableAttrs^ CreateCompileFactoryTableAttrs()
static member CreateCompileFactoryTableAttrs : unit -> CompileFactoryTableAttrs

Valore di ritorno

Tipo: CompileFactoryTableAttrs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateComponenteDaAnagrafica

Metodo DedNetInvAppCreateComponenteDaAnagrafica

Crea e restituisce il comando di ComponenteDaAnagrafica.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaComponenteAnagrafica CreateComponenteDaAnagrafica()
Public Shared Function CreateComponenteDaAnagrafica As CreaComponenteAnagrafica
public:
static CreaComponenteAnagrafica^ CreateComponenteDaAnagrafica()
static member CreateComponenteDaAnagrafica : unit -> CreaComponenteAnagrafica

Valore di ritorno

Tipo: CreaComponenteAnagrafica
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateConfiguraDistinta

Metodo DedNetInvAppCreateConfiguraDistinta

Crea e restituisce il comando di Configura Distinta.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ConfiguraDistinta CreateConfiguraDistinta()
Public Shared Function CreateConfiguraDistinta As ConfiguraDistinta
public:
static ConfiguraDistinta^ CreateConfiguraDistinta()
static member CreateConfiguraDistinta : unit -> ConfiguraDistinta

Valore di ritorno

Tipo: ConfiguraDistinta
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateControlloCoerenzaRiferimenti

Metodo DedNetInvAppCreateControlloCoerenzaRiferimenti

Crea e restituisce il comando Sostituisci Modello Tavola

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ControlloCoerenzaRiferimenti CreateControlloCoerenzaRiferimenti()
Public Shared Function CreateControlloCoerenzaRiferimenti As ControlloCoerenzaRiferimenti
public:
static ControlloCoerenzaRiferimenti^ CreateControlloCoerenzaRiferimenti()
static member CreateControlloCoerenzaRiferimenti : unit -> ControlloCoerenzaRiferimenti

Valore di ritorno

Tipo: ControlloCoerenzaRiferimenti
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateCreateSparePartsDrawing

Metodo DedNetInvAppCreateCreateSparePartsDrawing

Crea e restituisce il comando di Crea tavola ricambi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreateSparePartsDrawing CreateCreateSparePartsDrawing()
Public Shared Function CreateCreateSparePartsDrawing As CreateSparePartsDrawing
public:
static CreateSparePartsDrawing^ CreateCreateSparePartsDrawing()
static member CreateCreateSparePartsDrawing : unit -> CreateSparePartsDrawing

Valore di ritorno

Tipo: CreateSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDistintaComponenti

Metodo DedNetInvAppCreateDistintaComponenti

Crea e restituisce il comando di Distinta componenti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaComponenti CreateDistintaComponenti()
Public Shared Function CreateDistintaComponenti As DistintaComponenti
public:
static DistintaComponenti^ CreateDistintaComponenti()
static member CreateDistintaComponenti : unit -> DistintaComponenti

Valore di ritorno

Tipo: DistintaComponenti
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDistintaEsplosa

Metodo DedNetInvAppCreateDistintaEsplosa

Crea e restituisce il comando di Distinta Esplosa.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaEsplosa CreateDistintaEsplosa()
Public Shared Function CreateDistintaEsplosa As DistintaEsplosa
public:
static DistintaEsplosa^ CreateDistintaEsplosa()
static member CreateDistintaEsplosa : unit -> DistintaEsplosa

Valore di ritorno

Tipo: DistintaEsplosa
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDistintaImplosa

Metodo DedNetInvAppCreateDistintaImplosa

Crea e restituisce il comando di Distinta Implosa.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DistintaImplosa CreateDistintaImplosa()
Public Shared Function CreateDistintaImplosa As DistintaImplosa
public:
static DistintaImplosa^ CreateDistintaImplosa()
static member CreateDistintaImplosa : unit -> DistintaImplosa

Valore di ritorno

Tipo: DistintaImplosa
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDocAssocInv

Metodo DedNetInvAppCreateDocAssocInv

Crea il comando di aggiornamento della versione locale dei documenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocAssocInv CreateDocAssocInv()
Public Shared Function CreateDocAssocInv As DocAssocInv
public:
static DocAssocInv^ CreateDocAssocInv()
static member CreateDocAssocInv : unit -> DocAssocInv

Valore di ritorno

Tipo: DocAssocInv
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDocRecognizer

Metodo DedNetInvAppCreateDocRecognizer

Crea e restituisce il comando di registrazione files.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocRecognizer CreateDocRecognizer()
Public Shared Function CreateDocRecognizer As DocRecognizer
public:
static DocRecognizer^ CreateDocRecognizer()
static member CreateDocRecognizer : unit -> DocRecognizer

Valore di ritorno

Tipo: DocRecognizer
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDocumentStatesAnalyzer

Metodo DedNetInvAppCreateDocumentStatesAnalyzer

Crea e restituisce il comando di analisi stati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InvDataStatisticsAnalyzer CreateDocumentStatesAnalyzer()
Public Shared Function CreateDocumentStatesAnalyzer As InvDataStatisticsAnalyzer
public:
static InvDataStatisticsAnalyzer^ CreateDocumentStatesAnalyzer()
static member CreateDocumentStatesAnalyzer : unit -> InvDataStatisticsAnalyzer

Valore di ritorno

Tipo: InvDataStatisticsAnalyzer
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateDownloadProject

Metodo DedNetInvAppCreateDownloadProject

Crea e restituisce il comando DownloadProject.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DownloadProject CreateDownloadProject()
Public Shared Function CreateDownloadProject As DownloadProject
public:
static DownloadProject^ CreateDownloadProject()
static member CreateDownloadProject : unit -> DownloadProject

Valore di ritorno

Tipo: DownloadProject
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateEditaAttributiSoloDB

Metodo DedNetInvAppCreateEditaAttributiSoloDB

Crea e restituisce il comando EditaAttributiSoloDb.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaAttributiSoloDB CreateEditaAttributiSoloDB()
Public Shared Function CreateEditaAttributiSoloDB As EditaAttributiSoloDB
public:
static EditaAttributiSoloDB^ CreateEditaAttributiSoloDB()
static member CreateEditaAttributiSoloDB : unit -> EditaAttributiSoloDB

Valore di ritorno

Tipo: EditaAttributiSoloDB
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateEditaCommesse

Metodo DedNetInvAppCreateEditaCommesse

Crea e restituisce il comando di Edita commesse.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaCommesse CreateEditaCommesse()
Public Shared Function CreateEditaCommesse As EditaCommesse
public:
static EditaCommesse^ CreateEditaCommesse()
static member CreateEditaCommesse : unit -> EditaCommesse

Valore di ritorno

Tipo: EditaCommesse
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateEditaDistinta

Metodo DedNetInvAppCreateEditaDistinta

Crea e restituisce il comando di Edita distinta.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaDistinta CreateEditaDistinta()
Public Shared Function CreateEditaDistinta As EditaDistinta
public:
static EditaDistinta^ CreateEditaDistinta()
static member CreateEditaDistinta : unit -> EditaDistinta

Valore di ritorno

Tipo: EditaDistinta
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateEditaECO

Metodo DedNetInvAppCreateEditaECO

Crea e restituisce il comando di Edita ECO.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EditaECO CreateEditaECO()
Public Shared Function CreateEditaECO As EditaECO
public:
static EditaECO^ CreateEditaECO()
static member CreateEditaECO : unit -> EditaECO

Valore di ritorno

Tipo: EditaECO
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateEseguiLua

Metodo DedNetInvAppCreateEseguiLua

Crea e restituisce il comando di Apertura file associati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static EseguiLua CreateEseguiLua()
Public Shared Function CreateEseguiLua As EseguiLua
public:
static EseguiLua^ CreateEseguiLua()
static member CreateEseguiLua : unit -> EseguiLua

Valore di ritorno

Tipo: EseguiLua
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateForceMarkerAlingment

Metodo DedNetInvAppCreateForceMarkerAlingment

Crea il comando per forzare l'allineamento del docuemnto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ForceMarkerAlingment CreateForceMarkerAlingment()
Public Shared Function CreateForceMarkerAlingment As ForceMarkerAlingment
public:
static ForceMarkerAlingment^ CreateForceMarkerAlingment()
static member CreateForceMarkerAlingment : unit -> ForceMarkerAlingment

Valore di ritorno

Tipo: ForceMarkerAlingment
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateFormAbout

Metodo DedNetInvAppCreateFormAbout

Crea e restituisce il comando di About.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FormAbout CreateFormAbout()
Public Shared Function CreateFormAbout As FormAbout
public:
static FormAbout^ CreateFormAbout()
static member CreateFormAbout : unit -> FormAbout

Valore di ritorno

Tipo: FormAbout
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateHelp

Metodo DedNetInvAppCreateHelp

Crea e restituisce il comando di Help.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Help CreateHelp()
Public Shared Function CreateHelp As Help
public:
static Help^ CreateHelp()
static member CreateHelp : unit -> Help

Valore di ritorno

Tipo: Help
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateIndividuaGrafica

Metodo DedNetInvAppCreateIndividuaGrafica

Crea il comando di aggiornamento della versione locale dei documenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IndividuaGrafica CreateIndividuaGrafica()
Public Shared Function CreateIndividuaGrafica As IndividuaGrafica
public:
static IndividuaGrafica^ CreateIndividuaGrafica()
static member CreateIndividuaGrafica : unit -> IndividuaGrafica

Valore di ritorno

Tipo: IndividuaGrafica
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateInvAssociaConf

Metodo DedNetInvAppCreateInvAssociaConf

Crea e restituisce il comando CreaInvAssociaConf.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaInvAssociaConf CreateInvAssociaConf()
Public Shared Function CreateInvAssociaConf As CreaInvAssociaConf
public:
static CreaInvAssociaConf^ CreateInvAssociaConf()
static member CreateInvAssociaConf : unit -> CreaInvAssociaConf

Valore di ritorno

Tipo: CreaInvAssociaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateInvAssociaConfPrt

Metodo DedNetInvAppCreateInvAssociaConfPrt

Crea e restituisce il comando CreaInvAssociaConf.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaInvAssociaConf CreateInvAssociaConfPrt()
Public Shared Function CreateInvAssociaConfPrt As CreaInvAssociaConf
public:
static CreaInvAssociaConf^ CreateInvAssociaConfPrt()
static member CreateInvAssociaConfPrt : unit -> CreaInvAssociaConf

Valore di ritorno

Tipo: CreaInvAssociaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateInvAssociaDocument

Metodo DedNetInvAppCreateInvAssociaDocument

Crea e restituisce il comando CreaInvAssociaDocument.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaInvAssociaDocument CreateInvAssociaDocument()
Public Shared Function CreateInvAssociaDocument As CreaInvAssociaDocument
public:
static CreaInvAssociaDocument^ CreateInvAssociaDocument()
static member CreateInvAssociaDocument : unit -> CreaInvAssociaDocument

Valore di ritorno

Tipo: CreaInvAssociaDocument
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateInvAssociaDocumentPrt

Metodo DedNetInvAppCreateInvAssociaDocumentPrt

Crea e restituisce il comando CreaInvAssociaDocument parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaInvAssociaDocument CreateInvAssociaDocumentPrt()
Public Shared Function CreateInvAssociaDocumentPrt As CreaInvAssociaDocument
public:
static CreaInvAssociaDocument^ CreateInvAssociaDocumentPrt()
static member CreateInvAssociaDocumentPrt : unit -> CreaInvAssociaDocument

Valore di ritorno

Tipo: CreaInvAssociaDocument
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateInvScollegaConf

Metodo DedNetInvAppCreateInvScollegaConf

Crea e restituisce il comando CreaInvAssociaConf.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaInvDisconnectConf CreateInvScollegaConf()
Public Shared Function CreateInvScollegaConf As CreaInvDisconnectConf
public:
static CreaInvDisconnectConf^ CreateInvScollegaConf()
static member CreateInvScollegaConf : unit -> CreaInvDisconnectConf

Valore di ritorno

Tipo: CreaInvDisconnectConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateLavorazione

Metodo DedNetInvAppCreateLavorazione

Crea e ritorna il comando di poni in lavorazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Lavorazione CreateLavorazione()
Public Shared Function CreateLavorazione As Lavorazione
public:
static Lavorazione^ CreateLavorazione()
static member CreateLavorazione : unit -> Lavorazione

Valore di ritorno

Tipo: Lavorazione
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateLavorazioneMultiplo

Metodo DedNetInvAppCreateLavorazioneMultiplo

Crea e ritorna il comando di poni in lavorazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Lavorazione CreateLavorazioneMultiplo()
Public Shared Function CreateLavorazioneMultiplo As Lavorazione
public:
static Lavorazione^ CreateLavorazioneMultiplo()
static member CreateLavorazioneMultiplo : unit -> Lavorazione

Valore di ritorno

Tipo: Lavorazione
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateLinkDED

Metodo DedNetInvAppCreateLinkDED

Crea e restituisce il comando di LinkDEDApplicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LinkDED CreateLinkDED()
Public Shared Function CreateLinkDED As LinkDED
public:
static LinkDED^ CreateLinkDED()
static member CreateLinkDED : unit -> LinkDED

Valore di ritorno

Tipo: LinkDED
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateLoginCommand

Metodo DedNetInvAppCreateLoginCommand

Crea e restituisce il comando specifico di login

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InvUserLogin CreateLoginCommand()
Public Shared Function CreateLoginCommand As InvUserLogin
public:
static InvUserLogin^ CreateLoginCommand()
static member CreateLoginCommand : unit -> InvUserLogin

Valore di ritorno

Tipo: InvUserLogin
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateMarkerInfo

Metodo DedNetInvAppCreateMarkerInfo

Crea il comando per visualizzare lo stato di allineamento del documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static MarkerInfo CreateMarkerInfo()
Public Shared Function CreateMarkerInfo As MarkerInfo
public:
static MarkerInfo^ CreateMarkerInfo()
static member CreateMarkerInfo : unit -> MarkerInfo

Valore di ritorno

Tipo: MarkerInfo
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateModificaSuperato

Metodo DedNetInvAppCreateModificaSuperato

Crea e ritorna il comando di RettificaSuperato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ModificaSuperato CreateModificaSuperato()
Public Shared Function CreateModificaSuperato As ModificaSuperato
public:
static ModificaSuperato^ CreateModificaSuperato()
static member CreateModificaSuperato : unit -> ModificaSuperato

Valore di ritorno

Tipo: ModificaSuperato
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateNewRepresentation

Metodo DedNetInvAppCreateNewRepresentation

Crea e ritorna il comando di nuova rappresentazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreaNuovaRappresentazione CreateNewRepresentation()
Public Shared Function CreateNewRepresentation As CreaNuovaRappresentazione
public:
static CreaNuovaRappresentazione^ CreateNewRepresentation()
static member CreateNewRepresentation : unit -> CreaNuovaRappresentazione

Valore di ritorno

Tipo: CreaNuovaRappresentazione
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateNewRicerca

Metodo DedNetInvAppCreateNewRicerca

Crea e restituisce il comando di nuova ricerca.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Ricerca CreateNewRicerca()
Public Shared Function CreateNewRicerca As Ricerca
public:
static Ricerca^ CreateNewRicerca()
static member CreateNewRicerca : unit -> Ricerca

Valore di ritorno

Tipo: Ricerca
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateOpzioniApplicazione

Metodo DedNetInvAppCreateOpzioniApplicazione

Crea e restituisce il comando di Opzioni Applicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OpzioniApplicazione CreateOpzioniApplicazione()
Public Shared Function CreateOpzioniApplicazione As OpzioniApplicazione
public:
static OpzioniApplicazione^ CreateOpzioniApplicazione()
static member CreateOpzioniApplicazione : unit -> OpzioniApplicazione

Valore di ritorno

Tipo: OpzioniApplicazione
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePackAndGoExport

Metodo DedNetInvAppCreatePackAndGoExport

Crea e restituisce il comando di apri con opzioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoExport CreatePackAndGoExport()
Public Shared Function CreatePackAndGoExport As PackAndGoExport
public:
static PackAndGoExport^ CreatePackAndGoExport()
static member CreatePackAndGoExport : unit -> PackAndGoExport

Valore di ritorno

Tipo: PackAndGoExport
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePackAndGoImport

Metodo DedNetInvAppCreatePackAndGoImport

Crea e restituisce il comando CreaInvAssociaDocument parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoImport CreatePackAndGoImport()
Public Shared Function CreatePackAndGoImport As PackAndGoImport
public:
static PackAndGoImport^ CreatePackAndGoImport()
static member CreatePackAndGoImport : unit -> PackAndGoImport

Valore di ritorno

Tipo: PackAndGoImport
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePublish

Metodo DedNetInvAppCreatePublish

Crea il comando pubblica su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePublish()
Public Shared Function CreatePublish As Pubblica
public:
static Pubblica^ CreatePublish()
static member CreatePublish : unit -> Pubblica

Valore di ritorno

Tipo: Pubblica
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePublishProject

Metodo DedNetInvAppCreatePublishProject

Crea e restituisce il comando UploadProject.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PublishProject CreatePublishProject()
Public Shared Function CreatePublishProject As PublishProject
public:
static PublishProject^ CreatePublishProject()
static member CreatePublishProject : unit -> PublishProject

Valore di ritorno

Tipo: PublishProject
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePublishSparePartsDrawing

Metodo DedNetInvAppCreatePublishSparePartsDrawing

Crea e restituisce il comando di Pubblic tavola ricambi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PublishSparePartsDrawing CreatePublishSparePartsDrawing()
Public Shared Function CreatePublishSparePartsDrawing As PublishSparePartsDrawing
public:
static PublishSparePartsDrawing^ CreatePublishSparePartsDrawing()
static member CreatePublishSparePartsDrawing : unit -> PublishSparePartsDrawing

Valore di ritorno

Tipo: PublishSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePublishStruttura

Metodo DedNetInvAppCreatePublishStruttura

Crea il comando pubblica su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Pubblica CreatePublishStruttura()
Public Shared Function CreatePublishStruttura As Pubblica
public:
static Pubblica^ CreatePublishStruttura()
static member CreatePublishStruttura : unit -> Pubblica

Valore di ritorno

Tipo: Pubblica
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreatePwsCache

Metodo DedNetInvAppCreatePwsCache

Crea e restituisce il comando di Gestione dell'area locale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PwsCache CreatePwsCache()
Public Shared Function CreatePwsCache As PwsCache
public:
static PwsCache^ CreatePwsCache()
static member CreatePwsCache : unit -> PwsCache

Valore di ritorno

Tipo: PwsCache
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRegistra

Metodo DedNetInvAppCreateRegistra

Crea il comando registrazione documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Registra CreateRegistra()
Public Shared Function CreateRegistra As Registra
public:
static Registra^ CreateRegistra()
static member CreateRegistra : unit -> Registra

Valore di ritorno

Tipo: Registra
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateReleaseFactoryMember

Metodo DedNetInvAppCreateReleaseFactoryMember

Creazione comando di rilascio factory e tutti i member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ReleaseFactoryMember CreateReleaseFactoryMember()
Public Shared Function CreateReleaseFactoryMember As ReleaseFactoryMember
public:
static ReleaseFactoryMember^ CreateReleaseFactoryMember()
static member CreateReleaseFactoryMember : unit -> ReleaseFactoryMember

Valore di ritorno

Tipo: ReleaseFactoryMember
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRicerca

Metodo DedNetInvAppCreateRicerca

Crea e restituisce il comando di ricerca.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Ricerca CreateRicerca()
Public Shared Function CreateRicerca As Ricerca
public:
static Ricerca^ CreateRicerca()
static member CreateRicerca : unit -> Ricerca

Valore di ritorno

Tipo: Ricerca
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRicercaDocAssociati

Metodo DedNetInvAppCreateRicercaDocAssociati

Crea e restituisce il comando di rappresentazioni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindDoc CreateRicercaDocAssociati()
Public Shared Function CreateRicercaDocAssociati As FindDoc
public:
static FindDoc^ CreateRicercaDocAssociati()
static member CreateRicercaDocAssociati : unit -> FindDoc

Valore di ritorno

Tipo: FindDoc
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRicercaDocumenti

Metodo DedNetInvAppCreateRicercaDocumenti

Crea e restituisce il comando di ricerca documentale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindDoc CreateRicercaDocumenti()
Public Shared Function CreateRicercaDocumenti As FindDoc
public:
static FindDoc^ CreateRicercaDocumenti()
static member CreateRicercaDocumenti : unit -> FindDoc

Valore di ritorno

Tipo: FindDoc
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRilascio

Metodo DedNetInvAppCreateRilascio

Crea e restituisce il comando di rilascio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Rilascia CreateRilascio()
Public Shared Function CreateRilascio As Rilascia
public:
static Rilascia^ CreateRilascio()
static member CreateRilascio : unit -> Rilascia

Valore di ritorno

Tipo: Rilascia
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateRilascioMultiplo

Metodo DedNetInvAppCreateRilascioMultiplo

Crea e restituisce il comando di rilascio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Rilascia CreateRilascioMultiplo()
Public Shared Function CreateRilascioMultiplo As Rilascia
public:
static Rilascia^ CreateRilascioMultiplo()
static member CreateRilascioMultiplo : unit -> Rilascia

Valore di ritorno

Tipo: Rilascia
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalva

Metodo DedNetInvAppCreateSalva

Crea e restituisce il comando di Salva nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalva()
Public Shared Function CreateSalva As Salva
public:
static Salva^ CreateSalva()
static member CreateSalva : unit -> Salva

Valore di ritorno

Tipo: Salva
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaConf

Metodo DedNetInvAppCreateSalvaConf

Crea e restituisce il comando di Salva nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaConf()
Public Shared Function CreateSalvaConf As SalvaConf
public:
static SalvaConf^ CreateSalvaConf()
static member CreateSalvaConf : unit -> SalvaConf

Valore di ritorno

Tipo: SalvaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaDist

Metodo DedNetInvAppCreateSalvaDist

Crea e restituisce il comando di Salva Distinta

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaDist CreateSalvaDist()
Public Shared Function CreateSalvaDist As SalvaDist
public:
static SalvaDist^ CreateSalvaDist()
static member CreateSalvaDist : unit -> SalvaDist

Valore di ritorno

Tipo: SalvaDist
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaMultiplo

Metodo DedNetInvAppCreateSalvaMultiplo

Crea e restituisce il comando di Salva Multiplo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaMultiplo CreateSalvaMultiplo()
Public Shared Function CreateSalvaMultiplo As SalvaMultiplo
public:
static SalvaMultiplo^ CreateSalvaMultiplo()
static member CreateSalvaMultiplo : unit -> SalvaMultiplo

Valore di ritorno

Tipo: SalvaMultiplo
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPartBody

Metodo DedNetInvAppCreateSalvaPartBody

Crea e restituisce il comando di Salva Part Body.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaPartBody CreateSalvaPartBody()
Public Shared Function CreateSalvaPartBody As SalvaPartBody
public:
static SalvaPartBody^ CreateSalvaPartBody()
static member CreateSalvaPartBody : unit -> SalvaPartBody

Valore di ritorno

Tipo: SalvaPartBody
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPrt

Metodo DedNetInvAppCreateSalvaPrt

Crea e restituisce il comando di Salva Parte nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaPrt()
Public Shared Function CreateSalvaPrt As Salva
public:
static Salva^ CreateSalvaPrt()
static member CreateSalvaPrt : unit -> Salva

Valore di ritorno

Tipo: Salva
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPrtConf

Metodo DedNetInvAppCreateSalvaPrtConf

Crea e restituisce il comando di Salva nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaPrtConf()
Public Shared Function CreateSalvaPrtConf As SalvaConf
public:
static SalvaConf^ CreateSalvaPrtConf()
static member CreateSalvaPrtConf : unit -> SalvaConf

Valore di ritorno

Tipo: SalvaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPrtRev

Metodo DedNetInvAppCreateSalvaPrtRev

Crea e restituisce il comando di Salva Parte Revisione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaRev CreateSalvaPrtRev()
Public Shared Function CreateSalvaPrtRev As SalvaRev
public:
static SalvaRev^ CreateSalvaPrtRev()
static member CreateSalvaPrtRev : unit -> SalvaRev

Valore di ritorno

Tipo: SalvaRev
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPrtVariante

Metodo DedNetInvAppCreateSalvaPrtVariante

Crea e restituisce il comando di Salva Parte Variante nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaPrtVariante()
Public Shared Function CreateSalvaPrtVariante As Salva
public:
static Salva^ CreateSalvaPrtVariante()
static member CreateSalvaPrtVariante : unit -> Salva

Valore di ritorno

Tipo: Salva
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaPrtVarianteConf

Metodo DedNetInvAppCreateSalvaPrtVarianteConf

Crea e restituisce il comando di Salva nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaPrtVarianteConf()
Public Shared Function CreateSalvaPrtVarianteConf As SalvaConf
public:
static SalvaConf^ CreateSalvaPrtVarianteConf()
static member CreateSalvaPrtVarianteConf : unit -> SalvaConf

Valore di ritorno

Tipo: SalvaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaRev

Metodo DedNetInvAppCreateSalvaRev

Crea e restituisce il comando di Salva Revisione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaRev CreateSalvaRev()
Public Shared Function CreateSalvaRev As SalvaRev
public:
static SalvaRev^ CreateSalvaRev()
static member CreateSalvaRev : unit -> SalvaRev

Valore di ritorno

Tipo: SalvaRev
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaSuperato

Metodo DedNetInvAppCreateSalvaSuperato

Crea e ritorna il comando di SalvaSuperato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaSuperato CreateSalvaSuperato()
Public Shared Function CreateSalvaSuperato As SalvaSuperato
public:
static SalvaSuperato^ CreateSalvaSuperato()
static member CreateSalvaSuperato : unit -> SalvaSuperato

Valore di ritorno

Tipo: SalvaSuperato
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaVariante

Metodo DedNetInvAppCreateSalvaVariante

Crea e restituisce il comando di Salva Variante nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Salva CreateSalvaVariante()
Public Shared Function CreateSalvaVariante As Salva
public:
static Salva^ CreateSalvaVariante()
static member CreateSalvaVariante : unit -> Salva

Valore di ritorno

Tipo: Salva
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSalvaVarianteConf

Metodo DedNetInvAppCreateSalvaVarianteConf

Crea e restituisce il comando di Salva nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SalvaConf CreateSalvaVarianteConf()
Public Shared Function CreateSalvaVarianteConf As SalvaConf
public:
static SalvaConf^ CreateSalvaVarianteConf()
static member CreateSalvaVarianteConf : unit -> SalvaConf

Valore di ritorno

Tipo: SalvaConf
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSaveFactoryMemberRevision

Metodo DedNetInvAppCreateSaveFactoryMemberRevision

Creazione comando di revisione di tutti i member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SaveFactoryMemberRevision CreateSaveFactoryMemberRevision()
Public Shared Function CreateSaveFactoryMemberRevision As SaveFactoryMemberRevision
public:
static SaveFactoryMemberRevision^ CreateSaveFactoryMemberRevision()
static member CreateSaveFactoryMemberRevision : unit -> SaveFactoryMemberRevision

Valore di ritorno

Tipo: SaveFactoryMemberRevision
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSblocca

Metodo DedNetInvAppCreateSblocca

Crea il comando sblocca su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Sblocca CreateSblocca()
Public Shared Function CreateSblocca As Sblocca
public:
static Sblocca^ CreateSblocca()
static member CreateSblocca : unit -> Sblocca

Valore di ritorno

Tipo: Sblocca
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciComponente

Metodo DedNetInvAppCreateSostituisciComponente

Crea e restituisce il comando di sostituisci componente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponente CreateSostituisciComponente()
Public Shared Function CreateSostituisciComponente As SostituisciComponente
public:
static SostituisciComponente^ CreateSostituisciComponente()
static member CreateSostituisciComponente : unit -> SostituisciComponente

Valore di ritorno

Tipo: SostituisciComponente
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciComponenteDerivato

Metodo DedNetInvAppCreateSostituisciComponenteDerivato

Crea e restituisce il comando di sostituisci componente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteDerivato CreateSostituisciComponenteDerivato()
Public Shared Function CreateSostituisciComponenteDerivato As SostituisciComponenteDerivato
public:
static SostituisciComponenteDerivato^ CreateSostituisciComponenteDerivato()
static member CreateSostituisciComponenteDerivato : unit -> SostituisciComponenteDerivato

Valore di ritorno

Tipo: SostituisciComponenteDerivato
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciComponenteRapidoSelezione

Metodo DedNetInvAppCreateSostituisciComponenteRapidoSelezione

Crea e restituisce il comando di sostituisci componente rapido sulla selezione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoSelezione()
Public Shared Function CreateSostituisciComponenteRapidoSelezione As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoSelezione()
static member CreateSostituisciComponenteRapidoSelezione : unit -> SostituisciComponenteRapido

Valore di ritorno

Tipo: SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciComponenteRapidoTutti

Metodo DedNetInvAppCreateSostituisciComponenteRapidoTutti

Crea e restituisce il comando di sostituisci componente rapido tutti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoTutti()
Public Shared Function CreateSostituisciComponenteRapidoTutti As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoTutti()
static member CreateSostituisciComponenteRapidoTutti : unit -> SostituisciComponenteRapido

Valore di ritorno

Tipo: SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciComponenteRapidoTuttiStessoLivello

Metodo DedNetInvAppCreateSostituisciComponenteRapidoTuttiStessoLivello

Crea e restituisce il comando di sostituisci componente rapido stesso padre

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciComponenteRapido CreateSostituisciComponenteRapidoTuttiStessoLivello()
Public Shared Function CreateSostituisciComponenteRapidoTuttiStessoLivello As SostituisciComponenteRapido
public:
static SostituisciComponenteRapido^ CreateSostituisciComponenteRapidoTuttiStessoLivello()
static member CreateSostituisciComponenteRapidoTuttiStessoLivello : unit -> SostituisciComponenteRapido

Valore di ritorno

Tipo: SostituisciComponenteRapido
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciMoved

Metodo DedNetInvAppCreateSostituisciMoved

Crea il comando di sostituzione dei documenti che sono "moved".

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciMoved CreateSostituisciMoved()
Public Shared Function CreateSostituisciMoved As SostituisciMoved
public:
static SostituisciMoved^ CreateSostituisciMoved()
static member CreateSostituisciMoved : unit -> SostituisciMoved

Valore di ritorno

Tipo: SostituisciMoved
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateSostituisciRiferimenti

Metodo DedNetInvAppCreateSostituisciRiferimenti

Crea e restituisce il comando Sostituisci Modello Tavola

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static SostituisciRiferimenti CreateSostituisciRiferimenti()
Public Shared Function CreateSostituisciRiferimenti As SostituisciRiferimenti
public:
static SostituisciRiferimenti^ CreateSostituisciRiferimenti()
static member CreateSostituisciRiferimenti : unit -> SostituisciRiferimenti

Valore di ritorno

Tipo: SostituisciRiferimenti
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateStatoDocumento

Metodo DedNetInvAppCreateStatoDocumento

Crea e restituisce il comando di stato documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static StatoDocumento CreateStatoDocumento()
Public Shared Function CreateStatoDocumento As StatoDocumento
public:
static StatoDocumento^ CreateStatoDocumento()
static member CreateStatoDocumento : unit -> StatoDocumento

Valore di ritorno

Tipo: StatoDocumento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateTabellaRevisioni

Metodo DedNetInvAppCreateTabellaRevisioni

Crea e restituisce il comando di Tabella Revisioni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static TabellaRevisioni CreateTabellaRevisioni()
Public Shared Function CreateTabellaRevisioni As TabellaRevisioni
public:
static TabellaRevisioni^ CreateTabellaRevisioni()
static member CreateTabellaRevisioni : unit -> TabellaRevisioni

Valore di ritorno

Tipo: TabellaRevisioni
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateTrovaNelBrowser

Metodo DedNetInvAppCreateTrovaNelBrowser

Crea e restituisce il comando "Trova nel Browser"

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindInBrowser CreateTrovaNelBrowser()
Public Shared Function CreateTrovaNelBrowser As FindInBrowser
public:
static FindInBrowser^ CreateTrovaNelBrowser()
static member CreateTrovaNelBrowser : unit -> FindInBrowser

Valore di ritorno

Tipo: FindInBrowser
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateUpdateBranchInformations

Metodo DedNetInvAppCreateUpdateBranchInformations

Creo il comando di caricamento informazioni del ramo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static UpdateBranchInformations CreateUpdateBranchInformations()
Public Shared Function CreateUpdateBranchInformations As UpdateBranchInformations
public:
static UpdateBranchInformations^ CreateUpdateBranchInformations()
static member CreateUpdateBranchInformations : unit -> UpdateBranchInformations

Valore di ritorno

Tipo: UpdateBranchInformations
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateUpdateMembersFromFactory

Metodo DedNetInvAppCreateUpdateMembersFromFactory

Creazione comando di aggionrnamento member di iPartFactory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static UpdateMembersFromFactory CreateUpdateMembersFromFactory()
Public Shared Function CreateUpdateMembersFromFactory As UpdateMembersFromFactory
public:
static UpdateMembersFromFactory^ CreateUpdateMembersFromFactory()
static member CreateUpdateMembersFromFactory : unit -> UpdateMembersFromFactory

Valore di ritorno

Tipo: UpdateMembersFromFactory
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateUpdateOldRev

Metodo DedNetInvAppCreateUpdateOldRev

Crea e restituisce il comando di Aggiornamento revisioni superate.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static UpdateOldRev CreateUpdateOldRev()
Public Shared Function CreateUpdateOldRev As UpdateOldRev
public:
static UpdateOldRev^ CreateUpdateOldRev()
static member CreateUpdateOldRev : unit -> UpdateOldRev

Valore di ritorno

Tipo: UpdateOldRev
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreateWhereUsedInv

Metodo DedNetInvAppCreateWhereUsedInv

Crea il comando di aggiornamento della versione locale dei documenti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static WhereUsedInv CreateWhereUsedInv()
Public Shared Function CreateWhereUsedInv As WhereUsedInv
public:
static WhereUsedInv^ CreateWhereUsedInv()
static member CreateWhereUsedInv : unit -> WhereUsedInv

Valore di ritorno

Tipo: WhereUsedInv
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.CreaVisualaDiagDep

Metodo DedNetInvAppCreaVisualaDiagDep

Crea e restituisce il comando di Albero dipendenze avanzato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static VisualaDiagDep CreaVisualaDiagDep()
Public Shared Function CreaVisualaDiagDep As VisualaDiagDep
public:
static VisualaDiagDep^ CreaVisualaDiagDep()
static member CreaVisualaDiagDep : unit -> VisualaDiagDep

Valore di ritorno

Tipo: VisualaDiagDep
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.DedpTopDistPre

Metodo DedNetInvAppDedpTopDistPre

Gestione evento DedpTopDistPre

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DedpTopDistPre()
Public Sub DedpTopDistPre
public:
void DedpTopDistPre()
member DedpTopDistPre : unit -> unit
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.EndApprenticeServer

Metodo DedNetInvAppEndApprenticeServer

Chiude l'apprentice oppure ne decrementa il contatore.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void EndApprenticeServer()
Public Shared Sub EndApprenticeServer
public:
static void EndApprenticeServer()
static member EndApprenticeServer : unit -> unit
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.FindCommandByInternalName

Metodo DedNetInvAppFindCommandByInternalName

Metodo che ritorna l'oggetto 'InvCommandBase' rappresentante il comando specificato in ingresso.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InvCommandBase FindCommandByInternalName(
    string cmdInternalName
)
Public Shared Function FindCommandByInternalName (
    cmdInternalName As String
) As InvCommandBase
public:
static InvCommandBase^ FindCommandByInternalName(
    String^ cmdInternalName
)
static member FindCommandByInternalName :
        cmdInternalName : string -> InvCommandBase

Parametri

cmdInternalName
Tipo: SystemString
Internalname del comando da ricercare.

Valore di ritorno

Tipo: InvCommandBase
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetActiveElement

Metodo DedNetInvAppGetActiveElement

Restituisce l'elemento correntemente attivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
virtual FileStateElement^ GetActiveElement() sealed
abstract GetActiveElement : unit -> FileStateElement
override GetActiveElement : unit -> FileStateElement

Valore di ritorno

Tipo: FileStateElement

Implementa

IFileStateInformerGetActiveElement
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetAnagStateImageKey

Metodo DedNetInvAppGetAnagStateImageKey

Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
virtual Image^ GetAnagStateImageKey(
    FileStateElement^ el
) sealed
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image
override GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Image

Implementa

IFileStateInformerGetAnagStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetAnagStateName

Metodo DedNetInvAppGetAnagStateName

Restituisce il il nome dello stato dell'anagrafica associata all'elemento passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
virtual String^ GetAnagStateName(
    FileStateElement^ el
) sealed
abstract GetAnagStateName :
        el : FileStateElement -> string
override GetAnagStateName :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: String

Implementa

IFileStateInformerGetAnagStateName(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetAttr

Metodo DedNetInvAppGetAttr

Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAttr(
    FileStateElement el,
    string attrPrompt
)
Public Function GetAttr (
    el As FileStateElement,
    attrPrompt As String
) As String
public:
virtual String^ GetAttr(
    FileStateElement^ el,
    String^ attrPrompt
) sealed
abstract GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string
override GetAttr :
        el : FileStateElement *
        attrPrompt : string -> string

Parametri

el
Tipo: DedNetInvFileStateElement
attrPrompt
Tipo: SystemString

Valore di ritorno

Tipo: String

Implementa

IFileStateInformerGetAttr(FileStateElement, String)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetChildrenElements

Metodo DedNetInvAppGetChildrenElements

Ritorna gli elementi figli dell'oggetto passato. Per creare la struttura non utilizzo l'InvDocStructInfo per come gestisce la costruzione dei figli. Per agevolare il flusso dei dati nelle operazioni gli oggetti dei Ties vengono riciclati. Questo può causare problemi se ad esempio ho una reference nipote disponibile ed una figlia che invece non lo è...

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
virtual FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
) sealed
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList
override GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento Padre

Valore di ritorno

Tipo: FileStateElementList
Lista di elementi

Implementa

IFileStateInformerGetChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetData

Metodo DedNetInvAppGetData

Restituisce il valore dell'attributo identificato dal nome passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData GetData(
    FileStateElement el
)
Public Function GetData (
    el As FileStateElement
) As DedData
public:
virtual DedData^ GetData(
    FileStateElement^ el
) sealed
abstract GetData :
        el : FileStateElement -> DedData
override GetData :
        el : FileStateElement -> DedData

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedData

Implementa

IFileStateInformerGetData(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetDocument

Metodo DedNetInvAppGetDocument

Restituisce il documento associato all'oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetDocument(
    FileStateElement^ el
) sealed
abstract GetDocument :
        el : FileStateElement -> DedDoc
override GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc

Implementa

IFileStateInformerGetDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetMovedDocument

Metodo DedNetInvAppGetMovedDocument

Restituisce il documento associato all'oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
virtual DedDoc^ GetMovedDocument(
    FileStateElement^ el
) sealed
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc
override GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc

Implementa

IFileStateInformerGetMovedDocument(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetSelectionImageKey

Metodo DedNetInvAppGetSelectionImageKey

Restituisce il nome dell'immagine che rappresenta un elemento. L'immagine rispecchia il tipo di documento ed è quella standard di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetSelectionImageKey(
    FileStateElement^ el
) sealed
abstract GetSelectionImageKey :
        el : FileStateElement -> string
override GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento per il quale fornire il nome dell'immagine.

Valore di ritorno

Tipo: String

Implementa

IFileStateInformerGetSelectionImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetState

Metodo DedNetInvAppGetState

Restituisce lo stato dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int GetState(
    FileStateElement el
)
Public Function GetState (
    el As FileStateElement
) As Integer
public:
virtual int GetState(
    FileStateElement^ el
) sealed
abstract GetState :
        el : FileStateElement -> int
override GetState :
        el : FileStateElement -> int

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento da valutare.

Valore di ritorno

Tipo: Int32

Implementa

IFileStateInformerGetState(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.GetStateImageKey

Metodo DedNetInvAppGetStateImageKey

Restituisce il nome dell'immagine che descrive lo stato di un elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
virtual String^ GetStateImageKey(
    FileStateElement^ el
) sealed
abstract GetStateImageKey :
        el : FileStateElement -> string
override GetStateImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento per il quale fornire il nome dell'immagine.

Valore di ritorno

Tipo: String

Implementa

IFileStateInformerGetStateImageKey(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.HasChildrenElements

Metodo DedNetInvAppHasChildrenElements

Indica se l'elemento passato possiede figli

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
virtual bool HasChildrenElements(
    FileStateElement^ el
) sealed
abstract HasChildrenElements :
        el : FileStateElement -> bool
override HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento di riferimento

Valore di ritorno

Tipo: Boolean

Implementa

IFileStateInformerHasChildrenElements(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.IsDirty

Metodo DedNetInvAppIsDirty

Ritorna vero se l'elemento passato è associaoto ad un documento dirty

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
virtual bool IsDirty(
    FileStateElement^ el
) sealed
abstract IsDirty :
        el : FileStateElement -> bool
override IsDirty :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento di riferimento

Valore di ritorno

Tipo: Boolean
Stato dirtye

Implementa

IFileStateInformerIsDirty(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.IsInventorFile

Metodo DedNetInvAppIsInventorFile

Verifica se un file appartenga o meno ad Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsInventorFile(
    string fileName
)
Public Function IsInventorFile (
    fileName As String
) As Boolean
public:
bool IsInventorFile(
    String^ fileName
)
member IsInventorFile :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Restituisce true se si tratta di un file di Inventor altrimenti false.
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.Log

Metodo DedNetInvAppLog

Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex,
    bool silent
)
Public Shared Sub Log (
    ex As Exception,
    silent As Boolean
)
public:
static void Log(
    Exception^ ex,
    bool silent
)
static member Log :
        ex : Exception *
        silent : bool -> unit

Parametri

ex
Tipo: SystemException
Eccezione da registrare.
silent
Tipo: SystemBoolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.LogError

Metodo DedNetInvAppLogError

Registra l'informazione nel file di log dell'applicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogError(
    string str
)
Public Shared Sub LogError (
    str As String
)
public:
static void LogError(
    String^ str
)
static member LogError :
        str : string -> unit

Parametri

str
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.LogInfo

Metodo DedNetInvAppLogInfo

Registra l'informazione nel file di log dell'applicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string str
)
Public Shared Sub LogInfo (
    str As String
)
public:
static void LogInfo(
    String^ str
)
static member LogInfo :
        str : string -> unit

Parametri

str
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.LogWarning

Metodo DedNetInvAppLogWarning

Registra il warning nel file di log dell'applicazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogWarning(
    string str
)
Public Shared Sub LogWarning (
    str As String
)
public:
static void LogWarning(
    String^ str
)
static member LogWarning :
        str : string -> unit

Parametri

str
Tipo: SystemString
Testo da inserire come warning
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.MakeInvCommandContext

Metodo DedNetInvAppMakeInvCommandContext

Ritorna l'oggetto context di Inventor in base alla lista di elementi passati dal controllo delle dipendenze documentali.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvCommandContext MakeInvCommandContext(
    FileStateElementList elsList
)
Public Function MakeInvCommandContext (
    elsList As FileStateElementList
) As DedInvCommandContext
public:
virtual DedInvCommandContext^ MakeInvCommandContext(
    FileStateElementList^ elsList
) sealed
abstract MakeInvCommandContext :
        elsList : FileStateElementList -> DedInvCommandContext
override MakeInvCommandContext :
        elsList : FileStateElementList -> DedInvCommandContext

Parametri

elsList
Tipo: DedNetInvFileStateElementList
Lista degli elementi da considerare per la creazione del contesto

Valore di ritorno

Tipo: DedInvCommandContext

Implementa

IFileStateInformerMakeInvCommandContext(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnAddTiesApprenticeEvent

Metodo DedNetInvAppOnAddTiesApprenticeEvent

Lancia l'evento di AddTiesApprenticeEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnAddTiesApprenticeEvent(
    Object sender,
    DedNetInvAppResolutionEventArgs e
)
Public Shared Sub OnAddTiesApprenticeEvent (
    sender As Object,
    e As DedNetInvAppResolutionEventArgs
)
public:
static void OnAddTiesApprenticeEvent(
    Object^ sender,
    DedNetInvAppResolutionEventArgs^ e
)
static member OnAddTiesApprenticeEvent :
        sender : Object *
        e : DedNetInvAppResolutionEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnAskCopyAttrOnDerivedEvent

Metodo DedNetInvAppOnAskCopyAttrOnDerivedEvent

Lancia l'evento di AskCopyAttrOnDerivedEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnAskCopyAttrOnDerivedEvent(
    Object sender,
    DedNetInvAppAskCopyAttrOnDerivedEventArgs e
)
Public Shared Sub OnAskCopyAttrOnDerivedEvent (
    sender As Object,
    e As DedNetInvAppAskCopyAttrOnDerivedEventArgs
)
public:
static void OnAskCopyAttrOnDerivedEvent(
    Object^ sender,
    DedNetInvAppAskCopyAttrOnDerivedEventArgs^ e
)
static member OnAskCopyAttrOnDerivedEvent :
        sender : Object *
        e : DedNetInvAppAskCopyAttrOnDerivedEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppAskCopyAttrOnDerivedEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnChangeDsInfoStructOnPackAndGoExportEvent

Metodo DedNetInvAppOnChangeDsInfoStructOnPackAndGoExportEvent

Lancia l'evento di ChangeDocStructInfoStructureOnPackAndGoExportEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnChangeDsInfoStructOnPackAndGoExportEvent(
    Object sender,
    DedNetInvAppChangeDsInfoStructEventArgs e
)
Public Shared Sub OnChangeDsInfoStructOnPackAndGoExportEvent (
    sender As Object,
    e As DedNetInvAppChangeDsInfoStructEventArgs
)
public:
static void OnChangeDsInfoStructOnPackAndGoExportEvent(
    Object^ sender,
    DedNetInvAppChangeDsInfoStructEventArgs^ e
)
static member OnChangeDsInfoStructOnPackAndGoExportEvent :
        sender : Object *
        e : DedNetInvAppChangeDsInfoStructEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppChangeDsInfoStructEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnDedInvInvokeBasePublishEvent

Metodo DedNetInvAppOnDedInvInvokeBasePublishEvent

Lancia evento legato all'invoke del ded della pubblicazione di base

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDedInvInvokeBasePublishEvent(
    Object sender,
    DedNetInvAppDedInvInvokeBasePublishEventArgs e
)
Public Shared Sub OnDedInvInvokeBasePublishEvent (
    sender As Object,
    e As DedNetInvAppDedInvInvokeBasePublishEventArgs
)
public:
static void OnDedInvInvokeBasePublishEvent(
    Object^ sender,
    DedNetInvAppDedInvInvokeBasePublishEventArgs^ e
)
static member OnDedInvInvokeBasePublishEvent :
        sender : Object *
        e : DedNetInvAppDedInvInvokeBasePublishEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Applicazione di Ded per Inventor
e
Tipo: DedNetInvDedNetInvAppDedInvInvokeBasePublishEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnDedInvPublishEvent

Metodo DedNetInvAppOnDedInvPublishEvent

Lancia evento di pubblicazione formati in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDedInvPublishEvent(
    Object sender,
    DedNetInvAppDedInvPublishEventArgs e
)
Public Shared Sub OnDedInvPublishEvent (
    sender As Object,
    e As DedNetInvAppDedInvPublishEventArgs
)
public:
static void OnDedInvPublishEvent(
    Object^ sender,
    DedNetInvAppDedInvPublishEventArgs^ e
)
static member OnDedInvPublishEvent :
        sender : Object *
        e : DedNetInvAppDedInvPublishEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Applicazione di Ded per Inventor
e
Tipo: DedNetInvDedNetInvAppDedInvPublishEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnElementDoubleClicked

Metodo DedNetInvAppOnElementDoubleClicked

Gestione doppio click su elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
virtual void OnElementDoubleClicked(
    FileStateElement^ el
) sealed
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit
override OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement

Implementa

IFileStateInformerOnElementDoubleClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnElementsSelected

Metodo DedNetInvAppOnElementsSelected

Si occupa di allineare la selezione dell'albero con la selezione dell'occorrenze a livello di documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
virtual void OnElementsSelected(
    FileStateElementList^ elsList
) sealed
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit
override OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList
Tipo: DedNetInvFileStateElementList
Lista degli elementi da considerare per la selezione

Implementa

IFileStateInformerOnElementsSelected(FileStateElementList)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnHotTrackElementClicked

Metodo DedNetInvAppOnHotTrackElementClicked

Gestione click singolo su elemento hottracked

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
virtual bool OnHotTrackElementClicked(
    FileStateElement^ el
) sealed
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool
override OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean

Implementa

IFileStateInformerOnHotTrackElementClicked(FileStateElement)
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportMemberOnSaveEvent

Metodo DedNetInvAppOnImportMemberOnSaveEvent

Lancia l'evento di ImportMemberOnSaveEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportMemberOnSaveEvent(
    Object sender,
    DedNetInvAppImportOnSaveEventArgs e
)
Public Shared Sub OnImportMemberOnSaveEvent (
    sender As Object,
    e As DedNetInvAppImportOnSaveEventArgs
)
public:
static void OnImportMemberOnSaveEvent(
    Object^ sender,
    DedNetInvAppImportOnSaveEventArgs^ e
)
static member OnImportMemberOnSaveEvent :
        sender : Object *
        e : DedNetInvAppImportOnSaveEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportOnSaveEvent

Metodo DedNetInvAppOnImportOnSaveEvent

Lancia l'evento di ImportOnSaveEvent sui documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportOnSaveEvent(
    Object sender,
    DedNetInvAppImportOnSaveEventArgs e
)
Public Shared Sub OnImportOnSaveEvent (
    sender As Object,
    e As DedNetInvAppImportOnSaveEventArgs
)
public:
static void OnImportOnSaveEvent(
    Object^ sender,
    DedNetInvAppImportOnSaveEventArgs^ e
)
static member OnImportOnSaveEvent :
        sender : Object *
        e : DedNetInvAppImportOnSaveEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportPackAndGoAfterLoadEvent

Metodo DedNetInvAppOnImportPackAndGoAfterLoadEvent

Lancia l'evento di ImportPackAndGoAfterLoadEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoAfterLoadEvent(
    Object sender,
    DedNetInvAppImportPackAndGoAfterLoadEventArgs e
)
Public Shared Sub OnImportPackAndGoAfterLoadEvent (
    sender As Object,
    e As DedNetInvAppImportPackAndGoAfterLoadEventArgs
)
public:
static void OnImportPackAndGoAfterLoadEvent(
    Object^ sender,
    DedNetInvAppImportPackAndGoAfterLoadEventArgs^ e
)
static member OnImportPackAndGoAfterLoadEvent :
        sender : Object *
        e : DedNetInvAppImportPackAndGoAfterLoadEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportPackAndGoDocAttrCompareEvent

Metodo DedNetInvAppOnImportPackAndGoDocAttrCompareEvent

Lancia l'evento di ImportPackAndGoDocAttrCompareEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoDocAttrCompareEvent(
    Object sender,
    DedNetInvAppImportPackAndGoDocAttrCompareEventArgs e
)
Public Shared Sub OnImportPackAndGoDocAttrCompareEvent (
    sender As Object,
    e As DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
)
public:
static void OnImportPackAndGoDocAttrCompareEvent(
    Object^ sender,
    DedNetInvAppImportPackAndGoDocAttrCompareEventArgs^ e
)
static member OnImportPackAndGoDocAttrCompareEvent :
        sender : Object *
        e : DedNetInvAppImportPackAndGoDocAttrCompareEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportPackAndGoMappingRootEvent

Metodo DedNetInvAppOnImportPackAndGoMappingRootEvent

Lancia l'evento di ImportPackAndGoMappingRootEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoMappingRootEvent(
    Object sender,
    DedNetInvAppImportPackAndGoMappingRootEventArgs e
)
Public Shared Sub OnImportPackAndGoMappingRootEvent (
    sender As Object,
    e As DedNetInvAppImportPackAndGoMappingRootEventArgs
)
public:
static void OnImportPackAndGoMappingRootEvent(
    Object^ sender,
    DedNetInvAppImportPackAndGoMappingRootEventArgs^ e
)
static member OnImportPackAndGoMappingRootEvent :
        sender : Object *
        e : DedNetInvAppImportPackAndGoMappingRootEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportPackAndGoOverrideCheckOverwriteOperationEvent

Metodo DedNetInvAppOnImportPackAndGoOverrideCheckOverwriteOperationEvent

Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object sender,
    DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoOverrideCheckOverwriteOperationEvent (
    sender As Object,
    e As DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
)
public:
static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object^ sender,
    DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^ e
)
static member OnImportPackAndGoOverrideCheckOverwriteOperationEvent :
        sender : Object *
        e : DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnImportPackAndGoPresetCodingOperationEvent

Metodo DedNetInvAppOnImportPackAndGoPresetCodingOperationEvent

Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoPresetCodingOperationEvent(
    Object sender,
    DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoPresetCodingOperationEvent (
    sender As Object,
    e As DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
)
public:
static void OnImportPackAndGoPresetCodingOperationEvent(
    Object^ sender,
    DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs^ e
)
static member OnImportPackAndGoPresetCodingOperationEvent :
        sender : Object *
        e : DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnInvRilInvRilCheckCoherence

Metodo DedNetInvAppOnInvRilInvRilCheckCoherence

Lancia evento di gestione controllo coerenza riferimenti al rilascio in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnInvRilInvRilCheckCoherence(
    Object sender,
    DedNetInvAppInvRilCheckCoherenceEventArgs e
)
Public Shared Sub OnInvRilInvRilCheckCoherence (
    sender As Object,
    e As DedNetInvAppInvRilCheckCoherenceEventArgs
)
public:
static void OnInvRilInvRilCheckCoherence(
    Object^ sender,
    DedNetInvAppInvRilCheckCoherenceEventArgs^ e
)
static member OnInvRilInvRilCheckCoherence :
        sender : Object *
        e : DedNetInvAppInvRilCheckCoherenceEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Applicazione di Ded per Inventor
e
Tipo: DedNetInvDedNetInvAppInvRilCheckCoherenceEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnInvRilPublishEvent

Metodo DedNetInvAppOnInvRilPublishEvent

Lancia evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnInvRilPublishEvent(
    Object sender,
    DedNetInvAppInvRilPublishEventArgs e
)
Public Shared Sub OnInvRilPublishEvent (
    sender As Object,
    e As DedNetInvAppInvRilPublishEventArgs
)
public:
static void OnInvRilPublishEvent(
    Object^ sender,
    DedNetInvAppInvRilPublishEventArgs^ e
)
static member OnInvRilPublishEvent :
        sender : Object *
        e : DedNetInvAppInvRilPublishEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Applicazione di Ded per Inventor
e
Tipo: DedNetInvDedNetInvAppInvRilPublishEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnModifyingDocumentsEvent

Metodo DedNetInvAppOnModifyingDocumentsEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnModifyingDocumentsEvent(
    Object sender,
    DedNetInvAppModifyingDocumentsEventArgs e
)
Public Shared Sub OnModifyingDocumentsEvent (
    sender As Object,
    e As DedNetInvAppModifyingDocumentsEventArgs
)
public:
static void OnModifyingDocumentsEvent(
    Object^ sender,
    DedNetInvAppModifyingDocumentsEventArgs^ e
)
static member OnModifyingDocumentsEvent :
        sender : Object *
        e : DedNetInvAppModifyingDocumentsEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetInvDedNetInvAppModifyingDocumentsEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnMultiSaverElaborateItemEvent

Metodo DedNetInvAppOnMultiSaverElaborateItemEvent

Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverElaborateItemEvent(
    Object sender,
    DedNetInvAppMultiSaverItemElaborationEventArgs e
)
Public Shared Sub OnMultiSaverElaborateItemEvent (
    sender As Object,
    e As DedNetInvAppMultiSaverItemElaborationEventArgs
)
public:
static void OnMultiSaverElaborateItemEvent(
    Object^ sender,
    DedNetInvAppMultiSaverItemElaborationEventArgs^ e
)
static member OnMultiSaverElaborateItemEvent :
        sender : Object *
        e : DedNetInvAppMultiSaverItemElaborationEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Form salvataggio multiplo
e
Tipo: DedNetInvDedNetInvAppMultiSaverItemElaborationEventArgs
Argomenti standard dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnMultiSaverElaborateStructEvent

Metodo DedNetInvAppOnMultiSaverElaborateStructEvent

Lancia evento di esecuzione dell'elaborazione del salva multiplo sulla struttura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverElaborateStructEvent(
    Object sender,
    DedNetInvAppMultiSaverExecutionInfoEventArgs e
)
Public Shared Sub OnMultiSaverElaborateStructEvent (
    sender As Object,
    e As DedNetInvAppMultiSaverExecutionInfoEventArgs
)
public:
static void OnMultiSaverElaborateStructEvent(
    Object^ sender,
    DedNetInvAppMultiSaverExecutionInfoEventArgs^ e
)
static member OnMultiSaverElaborateStructEvent :
        sender : Object *
        e : DedNetInvAppMultiSaverExecutionInfoEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Form salvataggio multiplo
e
Tipo: DedNetInvDedNetInvAppMultiSaverExecutionInfoEventArgs
Argomenti standard dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnMultiSaverOverrideDedTypeEvent

Metodo DedNetInvAppOnMultiSaverOverrideDedTypeEvent

Lancia evento di override della famiglia in fase di salva multiplo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverOverrideDedTypeEvent(
    Object sender,
    DedNetInvAppMultiSaverOverrideDedTypeEventArgs e
)
Public Shared Sub OnMultiSaverOverrideDedTypeEvent (
    sender As Object,
    e As DedNetInvAppMultiSaverOverrideDedTypeEventArgs
)
public:
static void OnMultiSaverOverrideDedTypeEvent(
    Object^ sender,
    DedNetInvAppMultiSaverOverrideDedTypeEventArgs^ e
)
static member OnMultiSaverOverrideDedTypeEvent :
        sender : Object *
        e : DedNetInvAppMultiSaverOverrideDedTypeEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Form salvataggio multiplo
e
Tipo: DedNetInvDedNetInvAppMultiSaverOverrideDedTypeEventArgs
Argomenti standard dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Metodo DedNetInvApp.OnMultiSaverPopulateListEvent

Metodo DedNetInvAppOnMultiSaverPopulateListEvent

Lancia evento di popolamento della lista criteri di salvataggio multiplo. Permette all'utente di definire nuove modalità o sovrascrivere le modalità predefinite.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnMultiSaverPopulateListEvent(
    Object sender,
    EventArgs e
)
Public Shared Sub OnMultiSaverPopulateListEvent (
    sender As Object,
    e As EventArgs
)
public:
static void OnMultiSaverPopulateListEvent(
    Object^ sender,
    EventArgs^ e
)
static member OnMultiSaverPopulateListEvent :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender
Tipo: SystemObject
Form salvataggio multiplo
e
Tipo: SystemEventArgs
Argomenti standard dell'evento
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Eventi di DedNetInvApp

Il tipo DedNetInvApp espone i seguenti membri.

Eventi
Nome | Descrizione
AddTiesApprenticeEvent | Evento per gestire la creazione dei Ties tramite Apprentice.
AskCopyAttrOnDerivedEvent | Evento che permette l'override della richiesta di copia attributi nel comando di carica parte come derivato
ChangeDsInfoStructOnPackAndGoExportEvent |
DedInvInvokeBasePublishEvent | Evento legato all'invoke del ded della pubblicazione di base
DedInvPublishEvent | Evento di pubblicazione formati in Inventor
ImportMemberOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio degli iPartMember o iAssemblyMember
ImportOnSaveEvent | Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
InvRilInvRilCheckCoherence | Evento di gestione controllo coerenza riferimenti al rilascio in Inventor
InvRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
ModifyingDocumentsEvent | Evento per la gestione della scelta del checkout o no dei documento sul file dirty.
MultiSaverElaborateItemEvent | Evento di popolamento della lista criteri di salvataggio multiplo
MultiSaverElaborateStructEvent | Evento di popolamento della lista criteri di salvataggio multiplo
MultiSaverOverrideDedTypeEvent | Evento di override famiglia di salvataggio multiplo
MultiSaverPopulateListEvent | Evento di popolamento della lista criteri di salvataggio multiplo
Torna su
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.AddTiesApprenticeEvent

Evento DedNetInvAppAddTiesApprenticeEvent
Evento per gestire la creazione dei Ties tramite Apprentice.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppResolutionEventArgs> AddTiesApprenticeEvent
Public Shared Event AddTiesApprenticeEvent As EventHandler(Of DedNetInvAppResolutionEventArgs)
public:
static  event EventHandler<DedNetInvAppResolutionEventArgs^>^ AddTiesApprenticeEvent {
    void add (EventHandler<DedNetInvAppResolutionEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppResolutionEventArgs^>^ value);
}
member AddTiesApprenticeEvent : IEvent<EventHandler<DedNetInvAppResolutionEventArgs>,
    DedNetInvAppResolutionEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.AskCopyAttrOnDerivedEvent

Evento DedNetInvAppAskCopyAttrOnDerivedEvent
Evento che permette l'override della richiesta di copia attributi nel comando di carica parte come derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppAskCopyAttrOnDerivedEventArgs> AskCopyAttrOnDerivedEvent
Public Shared Event AskCopyAttrOnDerivedEvent As EventHandler(Of DedNetInvAppAskCopyAttrOnDerivedEventArgs)
public:
static  event EventHandler<DedNetInvAppAskCopyAttrOnDerivedEventArgs^>^ AskCopyAttrOnDerivedEvent {
    void add (EventHandler<DedNetInvAppAskCopyAttrOnDerivedEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppAskCopyAttrOnDerivedEventArgs^>^ value);
}
member AskCopyAttrOnDerivedEvent : IEvent<EventHandler<DedNetInvAppAskCopyAttrOnDerivedEventArgs>,
    DedNetInvAppAskCopyAttrOnDerivedEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppAskCopyAttrOnDerivedEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ChangeDsInfoStructOnPackAndGoExportEvent

Evento DedNetInvAppChangeDsInfoStructOnPackAndGoExportEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppChangeDsInfoStructEventArgs> ChangeDsInfoStructOnPackAndGoExportEvent
Public Shared Event ChangeDsInfoStructOnPackAndGoExportEvent As EventHandler(Of DedNetInvAppChangeDsInfoStructEventArgs)
public:
static  event EventHandler<DedNetInvAppChangeDsInfoStructEventArgs^>^ ChangeDsInfoStructOnPackAndGoExportEvent {
    void add (EventHandler<DedNetInvAppChangeDsInfoStructEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppChangeDsInfoStructEventArgs^>^ value);
}
member ChangeDsInfoStructOnPackAndGoExportEvent : IEvent<EventHandler<DedNetInvAppChangeDsInfoStructEventArgs>,
    DedNetInvAppChangeDsInfoStructEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppChangeDsInfoStructEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.DedInvInvokeBasePublishEvent

Evento DedNetInvAppDedInvInvokeBasePublishEvent
Evento legato all'invoke del ded della pubblicazione di base

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppDedInvInvokeBasePublishEventArgs> DedInvInvokeBasePublishEvent
Public Shared Event DedInvInvokeBasePublishEvent As EventHandler(Of DedNetInvAppDedInvInvokeBasePublishEventArgs)
public:
static  event EventHandler<DedNetInvAppDedInvInvokeBasePublishEventArgs^>^ DedInvInvokeBasePublishEvent {
    void add (EventHandler<DedNetInvAppDedInvInvokeBasePublishEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppDedInvInvokeBasePublishEventArgs^>^ value);
}
member DedInvInvokeBasePublishEvent : IEvent<EventHandler<DedNetInvAppDedInvInvokeBasePublishEventArgs>,
    DedNetInvAppDedInvInvokeBasePublishEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppDedInvInvokeBasePublishEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.DedInvPublishEvent

Evento DedNetInvAppDedInvPublishEvent
Evento di pubblicazione formati in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppDedInvPublishEventArgs> DedInvPublishEvent
Public Shared Event DedInvPublishEvent As EventHandler(Of DedNetInvAppDedInvPublishEventArgs)
public:
static  event EventHandler<DedNetInvAppDedInvPublishEventArgs^>^ DedInvPublishEvent {
    void add (EventHandler<DedNetInvAppDedInvPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppDedInvPublishEventArgs^>^ value);
}
member DedInvPublishEvent : IEvent<EventHandler<DedNetInvAppDedInvPublishEventArgs>,
    DedNetInvAppDedInvPublishEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppDedInvPublishEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportMemberOnSaveEvent

Evento DedNetInvAppImportMemberOnSaveEvent
Evento per gestire l'azione da attuare in fase di salvataggio degli iPartMember o iAssemblyMember

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportOnSaveEventArgs> ImportMemberOnSaveEvent
Public Shared Event ImportMemberOnSaveEvent As EventHandler(Of DedNetInvAppImportOnSaveEventArgs)
public:
static  event EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ ImportMemberOnSaveEvent {
    void add (EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ value);
}
member ImportMemberOnSaveEvent : IEvent<EventHandler<DedNetInvAppImportOnSaveEventArgs>,
    DedNetInvAppImportOnSaveEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportOnSaveEvent

Evento DedNetInvAppImportOnSaveEvent
Evento per gestire l'azione da attuare in fase di salvataggio dei documenti che sono all'interno delle root definite in ROOTS_RECOGNIZED_ON_DBSAVE

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportOnSaveEventArgs> ImportOnSaveEvent
Public Shared Event ImportOnSaveEvent As EventHandler(Of DedNetInvAppImportOnSaveEventArgs)
public:
static  event EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ ImportOnSaveEvent {
    void add (EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportOnSaveEventArgs^>^ value);
}
member ImportOnSaveEvent : IEvent<EventHandler<DedNetInvAppImportOnSaveEventArgs>,
    DedNetInvAppImportOnSaveEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportOnSaveEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportPackAndGoAfterLoadEvent

Evento DedNetInvAppImportPackAndGoAfterLoadEvent
Evento per effettuare modifiche al form dopo il caricamento dei dati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportPackAndGoAfterLoadEventArgs> ImportPackAndGoAfterLoadEvent
Public Shared Event ImportPackAndGoAfterLoadEvent As EventHandler(Of DedNetInvAppImportPackAndGoAfterLoadEventArgs)
public:
static  event EventHandler<DedNetInvAppImportPackAndGoAfterLoadEventArgs^>^ ImportPackAndGoAfterLoadEvent {
    void add (EventHandler<DedNetInvAppImportPackAndGoAfterLoadEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportPackAndGoAfterLoadEventArgs^>^ value);
}
member ImportPackAndGoAfterLoadEvent : IEvent<EventHandler<DedNetInvAppImportPackAndGoAfterLoadEventArgs>,
    DedNetInvAppImportPackAndGoAfterLoadEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportPackAndGoDocAttrCompareEvent

Evento DedNetInvAppImportPackAndGoDocAttrCompareEvent
Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportPackAndGoDocAttrCompareEventArgs> ImportPackAndGoDocAttrCompareEvent
Public Shared Event ImportPackAndGoDocAttrCompareEvent As EventHandler(Of DedNetInvAppImportPackAndGoDocAttrCompareEventArgs)
public:
static  event EventHandler<DedNetInvAppImportPackAndGoDocAttrCompareEventArgs^>^ ImportPackAndGoDocAttrCompareEvent {
    void add (EventHandler<DedNetInvAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
}
member ImportPackAndGoDocAttrCompareEvent : IEvent<EventHandler<DedNetInvAppImportPackAndGoDocAttrCompareEventArgs>,
    DedNetInvAppImportPackAndGoDocAttrCompareEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportPackAndGoMappingRootEvent

Evento DedNetInvAppImportPackAndGoMappingRootEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportPackAndGoMappingRootEventArgs> ImportPackAndGoMappingRootEvent
Public Shared Event ImportPackAndGoMappingRootEvent As EventHandler(Of DedNetInvAppImportPackAndGoMappingRootEventArgs)
public:
static  event EventHandler<DedNetInvAppImportPackAndGoMappingRootEventArgs^>^ ImportPackAndGoMappingRootEvent {
    void add (EventHandler<DedNetInvAppImportPackAndGoMappingRootEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportPackAndGoMappingRootEventArgs^>^ value);
}
member ImportPackAndGoMappingRootEvent : IEvent<EventHandler<DedNetInvAppImportPackAndGoMappingRootEventArgs>,
    DedNetInvAppImportPackAndGoMappingRootEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEvent

Evento DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEvent
Evento di override del settaggio del check in caso di operazione di codifica

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs> ImportPackAndGoOverrideCheckOverwriteOperationEvent
Public Shared Event ImportPackAndGoOverrideCheckOverwriteOperationEvent As EventHandler(Of DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs)
public:
static  event EventHandler<DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ ImportPackAndGoOverrideCheckOverwriteOperationEvent {
    void add (EventHandler<DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
}
member ImportPackAndGoOverrideCheckOverwriteOperationEvent : IEvent<EventHandler<DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>,
    DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ImportPackAndGoPresetCodingOperationEvent

Evento DedNetInvAppImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs> ImportPackAndGoPresetCodingOperationEvent
Public Shared Event ImportPackAndGoPresetCodingOperationEvent As EventHandler(Of DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs)
public:
static  event EventHandler<DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs^>^ ImportPackAndGoPresetCodingOperationEvent {
    void add (EventHandler<DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
}
member ImportPackAndGoPresetCodingOperationEvent : IEvent<EventHandler<DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs>,
    DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.InvRilInvRilCheckCoherence

Evento DedNetInvAppInvRilInvRilCheckCoherence
Evento di gestione controllo coerenza riferimenti al rilascio in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppInvRilCheckCoherenceEventArgs> InvRilInvRilCheckCoherence
Public Shared Event InvRilInvRilCheckCoherence As EventHandler(Of DedNetInvAppInvRilCheckCoherenceEventArgs)
public:
static  event EventHandler<DedNetInvAppInvRilCheckCoherenceEventArgs^>^ InvRilInvRilCheckCoherence {
    void add (EventHandler<DedNetInvAppInvRilCheckCoherenceEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppInvRilCheckCoherenceEventArgs^>^ value);
}
member InvRilInvRilCheckCoherence : IEvent<EventHandler<DedNetInvAppInvRilCheckCoherenceEventArgs>,
    DedNetInvAppInvRilCheckCoherenceEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppInvRilCheckCoherenceEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.InvRilPublishEvent

Evento DedNetInvAppInvRilPublishEvent
Evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppInvRilPublishEventArgs> InvRilPublishEvent
Public Shared Event InvRilPublishEvent As EventHandler(Of DedNetInvAppInvRilPublishEventArgs)
public:
static  event EventHandler<DedNetInvAppInvRilPublishEventArgs^>^ InvRilPublishEvent {
    void add (EventHandler<DedNetInvAppInvRilPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppInvRilPublishEventArgs^>^ value);
}
member InvRilPublishEvent : IEvent<EventHandler<DedNetInvAppInvRilPublishEventArgs>,
    DedNetInvAppInvRilPublishEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppInvRilPublishEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.ModifyingDocumentsEvent

Evento DedNetInvAppModifyingDocumentsEvent
Evento per la gestione della scelta del checkout o no dei documento sul file dirty.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppModifyingDocumentsEventArgs> ModifyingDocumentsEvent
Public Shared Event ModifyingDocumentsEvent As EventHandler(Of DedNetInvAppModifyingDocumentsEventArgs)
public:
static  event EventHandler<DedNetInvAppModifyingDocumentsEventArgs^>^ ModifyingDocumentsEvent {
    void add (EventHandler<DedNetInvAppModifyingDocumentsEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppModifyingDocumentsEventArgs^>^ value);
}
member ModifyingDocumentsEvent : IEvent<EventHandler<DedNetInvAppModifyingDocumentsEventArgs>,
    DedNetInvAppModifyingDocumentsEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppModifyingDocumentsEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.MultiSaverElaborateItemEvent

Evento DedNetInvAppMultiSaverElaborateItemEvent
Evento di popolamento della lista criteri di salvataggio multiplo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppMultiSaverItemElaborationEventArgs> MultiSaverElaborateItemEvent
Public Shared Event MultiSaverElaborateItemEvent As EventHandler(Of DedNetInvAppMultiSaverItemElaborationEventArgs)
public:
static  event EventHandler<DedNetInvAppMultiSaverItemElaborationEventArgs^>^ MultiSaverElaborateItemEvent {
    void add (EventHandler<DedNetInvAppMultiSaverItemElaborationEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppMultiSaverItemElaborationEventArgs^>^ value);
}
member MultiSaverElaborateItemEvent : IEvent<EventHandler<DedNetInvAppMultiSaverItemElaborationEventArgs>,
    DedNetInvAppMultiSaverItemElaborationEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppMultiSaverItemElaborationEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.MultiSaverElaborateStructEvent

Evento DedNetInvAppMultiSaverElaborateStructEvent
Evento di popolamento della lista criteri di salvataggio multiplo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppMultiSaverExecutionInfoEventArgs> MultiSaverElaborateStructEvent
Public Shared Event MultiSaverElaborateStructEvent As EventHandler(Of DedNetInvAppMultiSaverExecutionInfoEventArgs)
public:
static  event EventHandler<DedNetInvAppMultiSaverExecutionInfoEventArgs^>^ MultiSaverElaborateStructEvent {
    void add (EventHandler<DedNetInvAppMultiSaverExecutionInfoEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppMultiSaverExecutionInfoEventArgs^>^ value);
}
member MultiSaverElaborateStructEvent : IEvent<EventHandler<DedNetInvAppMultiSaverExecutionInfoEventArgs>,
    DedNetInvAppMultiSaverExecutionInfoEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppMultiSaverExecutionInfoEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.MultiSaverOverrideDedTypeEvent

Evento DedNetInvAppMultiSaverOverrideDedTypeEvent
Evento di override famiglia di salvataggio multiplo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetInvAppMultiSaverOverrideDedTypeEventArgs> MultiSaverOverrideDedTypeEvent
Public Shared Event MultiSaverOverrideDedTypeEvent As EventHandler(Of DedNetInvAppMultiSaverOverrideDedTypeEventArgs)
public:
static  event EventHandler<DedNetInvAppMultiSaverOverrideDedTypeEventArgs^>^ MultiSaverOverrideDedTypeEvent {
    void add (EventHandler<DedNetInvAppMultiSaverOverrideDedTypeEventArgs^>^ value);
    void remove (EventHandler<DedNetInvAppMultiSaverOverrideDedTypeEventArgs^>^ value);
}
member MultiSaverOverrideDedTypeEvent : IEvent<EventHandler<DedNetInvAppMultiSaverOverrideDedTypeEventArgs>,
    DedNetInvAppMultiSaverOverrideDedTypeEventArgs>

Valore

Tipo: SystemEventHandler DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Evento DedNetInvApp.MultiSaverPopulateListEvent

Evento DedNetInvAppMultiSaverPopulateListEvent
Evento di popolamento della lista criteri di salvataggio multiplo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<EventArgs> MultiSaverPopulateListEvent
Public Shared Event MultiSaverPopulateListEvent As EventHandler(Of EventArgs)
public:
static  event EventHandler<EventArgs^>^ MultiSaverPopulateListEvent {
    void add (EventHandler<EventArgs^>^ value);
    void remove (EventHandler<EventArgs^>^ value);
}
member MultiSaverPopulateListEvent : IEvent<EventHandler<EventArgs>,
    EventArgs>

Valore

Tipo: SystemEventHandler EventArgs
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campi di DedNetInvApp

Il tipo DedNetInvApp espone i seguenti membri.

Campi
Nome | Descrizione
_isDedInvSaveRevRunning | Inidica se il salva revisione sia o meno in esecuzione
ATTRIBUTEFORM |
DedNetInvDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DOCUMENTASSISTANT |
DOCUMENTSFORM |
OpenSyncMonitor | Monitor per sapere se un particolare sia o meno in fase di apertura.
REPLACECOMPONENTFORM |
Torna su
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp._isDedInvSaveRevRunning

Campo DedNetInvApp_isDedInvSaveRevRunning
Inidica se il salva revisione sia o meno in esecuzione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool _isDedInvSaveRevRunning
Public Shared _isDedInvSaveRevRunning As Boolean
public:
static bool _isDedInvSaveRevRunning
static val mutable _isDedInvSaveRevRunning: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.ATTRIBUTEFORM

Campo DedNetInvAppATTRIBUTEFORM

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string ATTRIBUTEFORM = "AttributeForm"
Public Const ATTRIBUTEFORM As String = "AttributeForm"
public:
literal String^ ATTRIBUTEFORM = "AttributeForm"
static val mutable ATTRIBUTEFORM: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.DedNetInvDataRowVerString

Campo DedNetInvAppDedNetInvDataRowVerString
Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetInvDataRowVerString = "DedNetInvDataRowVer"
Public Const DedNetInvDataRowVerString As String = "DedNetInvDataRowVer"
public:
literal String^ DedNetInvDataRowVerString = "DedNetInvDataRowVer"
static val mutable DedNetInvDataRowVerString: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.DOCUMENTASSISTANT

Campo DedNetInvAppDOCUMENTASSISTANT

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DOCUMENTASSISTANT = "DocumentAssistant"
Public Const DOCUMENTASSISTANT As String = "DocumentAssistant"
public:
literal String^ DOCUMENTASSISTANT = "DocumentAssistant"
static val mutable DOCUMENTASSISTANT: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.DOCUMENTSFORM

Campo DedNetInvAppDOCUMENTSFORM

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DOCUMENTSFORM = "DocumentsForm"
Public Const DOCUMENTSFORM As String = "DocumentsForm"
public:
literal String^ DOCUMENTSFORM = "DocumentsForm"
static val mutable DOCUMENTSFORM: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.OpenSyncMonitor

Campo DedNetInvAppOpenSyncMonitor
Monitor per sapere se un particolare sia o meno in fase di apertura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static readonly DocumentMonitorSync OpenSyncMonitor
Public Shared ReadOnly OpenSyncMonitor As DocumentMonitorSync
public:
static initonly DocumentMonitorSync^ OpenSyncMonitor
static val OpenSyncMonitor: DocumentMonitorSync

Valore del campo

Tipo: DocumentMonitorSync
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Campo DedNetInvApp.REPLACECOMPONENTFORM

Campo DedNetInvAppREPLACECOMPONENTFORM

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string REPLACECOMPONENTFORM = "ReplaceComponentForm"
Public Const REPLACECOMPONENTFORM As String = "ReplaceComponentForm"
public:
literal String^ REPLACECOMPONENTFORM = "ReplaceComponentForm"
static val mutable REPLACECOMPONENTFORM: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvApp
Namespace DedNetInv


Classe DedNetInvApp.AskCopyAttrOnDerivedEventArgs

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Argomento utilizzato per l'evento override richiesta copia attributi sul derivato
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppAskCopyAttrOnDerivedEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AskCopyAttrOnDerivedEventArgs : DedEventArgs
Public Class AskCopyAttrOnDerivedEventArgs
    Inherits DedEventArgs
public ref class AskCopyAttrOnDerivedEventArgs : public DedEventArgs
type AskCopyAttrOnDerivedEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppAskCopyAttrOnDerivedEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppAskCopyAttrOnDerivedEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveDocument | Restituisce il documento attivo di Inventor
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CloneAttributes | Determina se copiare o meno gli attributi
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | DerivedDocAnagrInfo | Restituisce l'informer di documento e anagrafica soggetto della derivazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.AskCopyAttrOnDerivedEventArgs

Costruttore DedNetInvAppAskCopyAttrOnDerivedEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AskCopyAttrOnDerivedEventArgs(
    Document actdoc,
    DedCommandDocAnagrInfo derivedDocAnagrInfo
)
Public Sub New (
    actdoc As Document,
    derivedDocAnagrInfo As DedCommandDocAnagrInfo
)
public:
AskCopyAttrOnDerivedEventArgs(
    Document^ actdoc,
    DedCommandDocAnagrInfo^ derivedDocAnagrInfo
)
new :
        actdoc : Document *
        derivedDocAnagrInfo : DedCommandDocAnagrInfo -> AskCopyAttrOnDerivedEventArgs

Parametri

actdoc
Tipo: Document
derivedDocAnagrInfo
Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Namespace DedNetInv


Proprietà di AskCopyAttrOnDerivedEventArgs

Il tipo DedNetInvAppAskCopyAttrOnDerivedEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveDocument | Restituisce il documento attivo di Inventor
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CloneAttributes | Determina se copiare o meno gli attributi
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | DerivedDocAnagrInfo | Restituisce l'informer di documento e anagrafica soggetto della derivazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.AskCopyAttrOnDerivedEventArgs.ActiveDocument

Proprietà DedNetInvAppAskCopyAttrOnDerivedEventArgsActiveDocument

Restituisce il documento attivo di Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document ActiveDocument { get; }
Public ReadOnly Property ActiveDocument As Document
    Get
public:
property Document^ ActiveDocument {
    Document^ get ();
}
member ActiveDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.AskCopyAttrOnDerivedEventArgs.CloneAttributes

Proprietà DedNetInvAppAskCopyAttrOnDerivedEventArgsCloneAttributes

Determina se copiare o meno gli attributi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CloneAttributes { get; set; }
Public Property CloneAttributes As Boolean
    Get
    Set
public:
property bool CloneAttributes {
    bool get ();
    void set (bool value);
}
member CloneAttributes : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.AskCopyAttrOnDerivedEventArgs.DerivedDocAnagrInfo

Proprietà DedNetInvAppAskCopyAttrOnDerivedEventArgsDerivedDocAnagrInfo

Restituisce l'informer di documento e anagrafica soggetto della derivazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DerivedDocAnagrInfo { get; }
Public ReadOnly Property DerivedDocAnagrInfo As DedCommandDocAnagrInfo
    Get
public:
property DedCommandDocAnagrInfo^ DerivedDocAnagrInfo {
    DedCommandDocAnagrInfo^ get ();
}
member DerivedDocAnagrInfo : DedCommandDocAnagrInfo with get

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe DedNetInvAppAskCopyAttrOnDerivedEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ChangeDsInfoStructEventArgs

Classe DedNetInvAppChangeDsInfoStructEventArgs
Argomento utilizzato per l'evento di modifica struttura del docStructInfo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppChangeDsInfoStructEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ChangeDsInfoStructEventArgs : DedEventArgs
Public Class ChangeDsInfoStructEventArgs
    Inherits DedEventArgs
public ref class ChangeDsInfoStructEventArgs : public DedEventArgs
type ChangeDsInfoStructEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppChangeDsInfoStructEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppChangeDsInfoStructEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InvDsInfo | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ChangeDsInfoStructEventArgs

Costruttore DedNetInvAppChangeDsInfoStructEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ChangeDsInfoStructEventArgs(
    InvDocStructInfo invDsInfo
)
Public Sub New (
    invDsInfo As InvDocStructInfo
)
public:
ChangeDsInfoStructEventArgs(
    InvDocStructInfo^ invDsInfo
)
new :
        invDsInfo : InvDocStructInfo -> ChangeDsInfoStructEventArgs

Parametri

invDsInfo
Tipo: DedNetInvInvDocStructInfo
Vedi anche

Documentazione

Classe DedNetInvAppChangeDsInfoStructEventArgs
Namespace DedNetInv


Proprietà di ChangeDsInfoStructEventArgs

Il tipo DedNetInvAppChangeDsInfoStructEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InvDsInfo | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppChangeDsInfoStructEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ChangeDsInfoStructEventArgs.InvDsInfo

Proprietà DedNetInvAppChangeDsInfoStructEventArgsInvDsInfo

Restituisce il docstructinfo in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo InvDsInfo { get; }
Public ReadOnly Property InvDsInfo As InvDocStructInfo
    Get
public:
property InvDocStructInfo^ InvDsInfo {
    InvDocStructInfo^ get ();
}
member InvDsInfo : InvDocStructInfo with get

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe DedNetInvAppChangeDsInfoStructEventArgs
Namespace DedNetInv


Classe DedNetInvApp.DedInvInvokeBasePublishEventArgs

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Argomento utilizzato per l'evento legato alla pubblicazione di base del ded
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppDedInvInvokeBasePublishEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvInvokeBasePublishEventArgs : DedEventArgs
Public Class DedInvInvokeBasePublishEventArgs
    Inherits DedEventArgs
public ref class DedInvInvokeBasePublishEventArgs : public DedEventArgs
type DedInvInvokeBasePublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppDedInvInvokeBasePublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppDedInvInvokeBasePublishEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | FileOut | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | MethodName | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.DedInvInvokeBasePublishEventArgs

Costruttore DedNetInvAppDedInvInvokeBasePublishEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvInvokeBasePublishEventArgs(
    Document pubDoc,
    string methodName,
    string fout
)
Public Sub New (
    pubDoc As Document,
    methodName As String,
    fout As String
)
public:
DedInvInvokeBasePublishEventArgs(
    Document^ pubDoc,
    String^ methodName,
    String^ fout
)
new :
        pubDoc : Document *
        methodName : string *
        fout : string -> DedInvInvokeBasePublishEventArgs

Parametri

pubDoc
Tipo: Document
methodName
Tipo: SystemString
fout
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Namespace DedNetInv


Proprietà di DedInvInvokeBasePublishEventArgs

Il tipo DedNetInvAppDedInvInvokeBasePublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | FileOut | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | MethodName | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvInvokeBasePublishEventArgs.FileOut

Proprietà DedNetInvAppDedInvInvokeBasePublishEventArgsFileOut

Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FileOut { get; }
Public ReadOnly Property FileOut As String
    Get
public:
property String^ FileOut {
    String^ get ();
}
member FileOut : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvInvokeBasePublishEventArgs.MethodName

Proprietà DedNetInvAppDedInvInvokeBasePublishEventArgsMethodName

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string MethodName { get; }
Public ReadOnly Property MethodName As String
    Get
public:
property String^ MethodName {
    String^ get ();
}
member MethodName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvInvokeBasePublishEventArgs.PublishingInvDoc

Proprietà DedNetInvAppDedInvInvokeBasePublishEventArgsPublishingInvDoc

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document PublishingInvDoc { get; }
Public ReadOnly Property PublishingInvDoc As Document
    Get
public:
property Document^ PublishingInvDoc {
    Document^ get ();
}
member PublishingInvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppDedInvInvokeBasePublishEventArgs
Namespace DedNetInv


Classe DedNetInvApp.DedInvPublishEventArgs

Classe DedNetInvAppDedInvPublishEventArgs
Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppDedInvPublishEventArgs
DedNetInvDedNetInvAppInvRilPublishEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvPublishEventArgs : DedEventArgs
Public Class DedInvPublishEventArgs
    Inherits DedEventArgs
public ref class DedInvPublishEventArgs : public DedEventArgs
type DedInvPublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppDedInvPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppDedInvPublishEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.DedInvPublishEventArgs

Costruttore DedNetInvAppDedInvPublishEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvPublishEventArgs(
    DedDoc dedDoc,
    DedData data,
    Document pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    dedDoc As DedDoc,
    data As DedData,
    pubDoc As Document,
    pubMan As DedPublicationManager
)
public:
DedInvPublishEventArgs(
    DedDoc^ dedDoc,
    DedData^ data,
    Document^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        dedDoc : DedDoc *
        data : DedData *
        pubDoc : Document *
        pubMan : DedPublicationManager -> DedInvPublishEventArgs

Parametri

dedDoc
Tipo: DedDoc
data
Tipo: DedData
pubDoc
Tipo: Document
pubMan
Tipo: DedPublicationManager
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Proprietà di DedInvPublishEventArgs

Il tipo DedNetInvAppDedInvPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvPublishEventArgs.Data

Proprietà DedNetInvAppDedInvPublishEventArgsData

Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvPublishEventArgs.Document

Proprietà DedNetInvAppDedInvPublishEventArgsDocument

Restituisce il documento in elaborazione dal comando.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvPublishEventArgs.PublicationManager

Proprietà DedNetInvAppDedInvPublishEventArgsPublicationManager

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager PublicationManager { get; }
Public ReadOnly Property PublicationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ PublicationManager {
    DedPublicationManager^ get ();
}
member PublicationManager : DedPublicationManager with get

Valore della proprietà

Tipo: DedPublicationManager
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.DedInvPublishEventArgs.PublishingInvDoc

Proprietà DedNetInvAppDedInvPublishEventArgsPublishingInvDoc

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document PublishingInvDoc { get; }
Public ReadOnly Property PublishingInvDoc As Document
    Get
public:
property Document^ PublishingInvDoc {
    Document^ get ();
}
member PublishingInvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppDedInvPublishEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportOnSaveEventArgs

Classe DedNetInvAppImportOnSaveEventArgs
Argomento utilizzato per l'evento di salvataggio di ipartmember o iassemblymember
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppImportOnSaveEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportOnSaveEventArgs : DedEventArgs
Public Class ImportOnSaveEventArgs
    Inherits DedEventArgs
public ref class ImportOnSaveEventArgs : public DedEventArgs
type ImportOnSaveEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppImportOnSaveEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportOnSaveEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | ImportFileInNewData | Restituisce il docstructinfo in elaborazione.
Proprietà pubblica | InvDsInfo | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportOnSaveEventArgs

Costruttore DedNetInvAppImportOnSaveEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportOnSaveEventArgs(
    InvDocStructInfo invDsInfo,
    bool importFileInNewData
)
Public Sub New (
    invDsInfo As InvDocStructInfo,
    importFileInNewData As Boolean
)
public:
ImportOnSaveEventArgs(
    InvDocStructInfo^ invDsInfo,
    bool importFileInNewData
)
new :
        invDsInfo : InvDocStructInfo *
        importFileInNewData : bool -> ImportOnSaveEventArgs

Parametri

invDsInfo
Tipo: DedNetInvInvDocStructInfo
importFileInNewData
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedNetInvAppImportOnSaveEventArgs
Namespace DedNetInv


Proprietà di ImportOnSaveEventArgs

Il tipo DedNetInvAppImportOnSaveEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | ImportFileInNewData | Restituisce il docstructinfo in elaborazione.
Proprietà pubblica | InvDsInfo | Restituisce il docstructinfo in elaborazione.
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportOnSaveEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportOnSaveEventArgs.ImportFileInNewData

Proprietà DedNetInvAppImportOnSaveEventArgsImportFileInNewData

Restituisce il docstructinfo in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ImportFileInNewData { get; set; }
Public Property ImportFileInNewData As Boolean
    Get
    Set
public:
property bool ImportFileInNewData {
    bool get ();
    void set (bool value);
}
member ImportFileInNewData : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppImportOnSaveEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportOnSaveEventArgs.InvDsInfo

Proprietà DedNetInvAppImportOnSaveEventArgsInvDsInfo

Restituisce il docstructinfo in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo InvDsInfo { get; }
Public ReadOnly Property InvDsInfo As InvDocStructInfo
    Get
public:
property InvDocStructInfo^ InvDsInfo {
    InvDocStructInfo^ get ();
}
member InvDsInfo : InvDocStructInfo with get

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe DedNetInvAppImportOnSaveEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportPackAndGoAfterLoadEventArgs

Classe DedNetInvAppImportPackAndGoAfterLoadEventArgs
Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetInvDedNetInvAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoAfterLoadEventArgs : EventArgs
Public Class ImportPackAndGoAfterLoadEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoAfterLoadEventArgs : public EventArgs
type ImportPackAndGoAfterLoadEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetInvAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportPackAndGoAfterLoadEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportPackAndGoAfterLoadEventArgs

Costruttore DedNetInvAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoAfterLoadEventArgs(
    DedInvPackAndGoImportForm frm
)
Public Sub New (
    frm As DedInvPackAndGoImportForm
)
public:
ImportPackAndGoAfterLoadEventArgs(
    DedInvPackAndGoImportForm^ frm
)
new :
        frm : DedInvPackAndGoImportForm -> ImportPackAndGoAfterLoadEventArgs

Parametri

frm
Tipo: DedNetInv.FormsDedInvPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetInv


Proprietà di ImportPackAndGoAfterLoadEventArgs

Il tipo DedNetInvAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoAfterLoadEventArgs.Frm

Proprietà DedNetInvAppImportPackAndGoAfterLoadEventArgsFrm

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvPackAndGoImportForm Frm { get; set; }
Public Property Frm As DedInvPackAndGoImportForm
    Get
    Set
public:
property DedInvPackAndGoImportForm^ Frm {
    DedInvPackAndGoImportForm^ get ();
    void set (DedInvPackAndGoImportForm^ value);
}
member Frm : DedInvPackAndGoImportForm with get, set

Valore della proprietà

Tipo: DedInvPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoAfterLoadEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppImportPackAndGoDocAttrCompareEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoDocAttrCompareEventArgs : DedEventArgs
Public Class ImportPackAndGoDocAttrCompareEventArgs
    Inherits DedEventArgs
public ref class ImportPackAndGoDocAttrCompareEventArgs : public DedEventArgs
type ImportPackAndGoDocAttrCompareEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportPackAndGoDocAttrCompareEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs

Costruttore DedNetInvAppImportPackAndGoDocAttrCompareEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp,
    DedData data,
    DedDataPart dataDoc
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper,
    data As DedData,
    dataDoc As DedDataPart
)
public:
ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp,
    DedData^ data,
    DedDataPart^ dataDoc
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper *
        data : DedData *
        dataDoc : DedDataPart -> ImportPackAndGoDocAttrCompareEventArgs

Parametri

dedcase
Tipo: DedNetInv.CommandsPackAndGoImportDedCases
dbMaster
Tipo: SystemBoolean
pckNodeWrp
Tipo: DedNetInv.CommandsPackAndGoNodeWrapper
data
Tipo: DedData
dataDoc
Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà di ImportPackAndGoDocAttrCompareEventArgs

Il tipo DedNetInvAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.Data

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsData

Ritorna l'anagrafica associata al nodo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.DataDoc

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsDataDoc

Ritorna il DedDataPart associato al documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DataDoc { get; }
Public ReadOnly Property DataDoc As DedDataPart
    Get
public:
property DedDataPart^ DataDoc {
    DedDataPart^ get ();
}
member DataDoc : DedDataPart with get

Valore della proprietà

Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.DbMaster

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsDbMaster

Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.DedCase

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsDedCase

Ritorna la tipologia di importazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.PackAndGoNodeWrapper

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsPackAndGoNodeWrapper

Wrapper associato all'evento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoDocAttrCompareEventArgs.UsesDocValues

Proprietà DedNetInvAppImportPackAndGoDocAttrCompareEventArgsUsesDocValues

Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UsesDocValues { get; set; }
Public Property UsesDocValues As Boolean
    Get
    Set
public:
property bool UsesDocValues {
    bool get ();
    void set (bool value);
}
member UsesDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoDocAttrCompareEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportPackAndGoMappingRootEventArgs

Classe DedNetInvAppImportPackAndGoMappingRootEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetInvDedNetInvAppImportPackAndGoMappingRootEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoMappingRootEventArgs : EventArgs
Public Class ImportPackAndGoMappingRootEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoMappingRootEventArgs : public EventArgs
type ImportPackAndGoMappingRootEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetInvAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportPackAndGoMappingRootEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportPackAndGoMappingRootEventArgs

Costruttore DedNetInvAppImportPackAndGoMappingRootEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject> ipjPaths
)
Public Sub New (
    ipjPaths As List(Of MappingRootObject)
)
public:
ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject^>^ ipjPaths
)
new :
        ipjPaths : List<MappingRootObject> -> ImportPackAndGoMappingRootEventArgs

Parametri

ipjPaths
Tipo: System.Collections.GenericList MappingRootObject
Mappatura root.
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoMappingRootEventArgs
Namespace DedNetInv


Proprietà di ImportPackAndGoMappingRootEventArgs

Il tipo DedNetInvAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoMappingRootEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoMappingRootEventArgs.IpjPaths

Proprietà DedNetInvAppImportPackAndGoMappingRootEventArgsIpjPaths

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<MappingRootObject> IpjPaths { get; set; }
Public Property IpjPaths As List(Of MappingRootObject)
    Get
    Set
public:
property List<MappingRootObject^>^ IpjPaths {
    List<MappingRootObject^>^ get ();
    void set (List<MappingRootObject^>^ value);
}
member IpjPaths : List<MappingRootObject> with get, set

Valore della proprietà

Tipo: List MappingRootObject
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoMappingRootEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetInvDedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : EventArgs
Public Class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : public EventArgs
type ImportPackAndGoOverrideCheckOverwriteOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper
)
public:
ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper -> ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Parametri

dedcase
Tipo: DedNetInv.CommandsPackAndGoImportDedCases
dbMaster
Tipo: SystemBoolean
pckNodeWrp
Tipo: DedNetInv.CommandsPackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Proprietà di ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Il tipo DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DbMaster

Proprietà DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDbMaster

Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DedCase

Proprietà DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDedCase

Ritorna la tipologia di importazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.OverrideCheck

Proprietà DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsOverrideCheck

Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OverrideCheck { get; set; }
Public Property OverrideCheck As Boolean
    Get
    Set
public:
property bool OverrideCheck {
    bool get ();
    void set (bool value);
}
member OverrideCheck : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.PackAndGoNodeWrapper

Proprietà DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsPackAndGoNodeWrapper

Wrapper associato all'evento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetInvDedNetInvAppImportPackAndGoPresetCodingOperationEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoPresetCodingOperationEventArgs : EventArgs
Public Class ImportPackAndGoPresetCodingOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoPresetCodingOperationEventArgs : public EventArgs
type ImportPackAndGoPresetCodingOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Note | Note da visualizzare nella finestra.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs

Costruttore DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoPresetCodingOperationEventArgs(
    string fullfilename,
    Dictionary<string, Object> dizAttr
)
Public Sub New (
    fullfilename As String,
    dizAttr As Dictionary(Of String, Object)
)
public:
ImportPackAndGoPresetCodingOperationEventArgs(
    String^ fullfilename,
    Dictionary<String^, Object^>^ dizAttr
)
new :
        fullfilename : string *
        dizAttr : Dictionary<string, Object> -> ImportPackAndGoPresetCodingOperationEventArgs

Parametri

fullfilename
Tipo: SystemString
Filename del documento in importazione.
dizAttr
Tipo: System.Collections.GenericDictionary String, Object
Dizionario contenete attributi documento.
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà di ImportPackAndGoPresetCodingOperationEventArgs

Il tipo DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Note | Note da visualizzare nella finestra.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Data

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsData

Anagrafica da associare al documento in importazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.DedCase

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsDedCase

Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.DedType

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsDedType

Famiglia nel quale codificare il documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.DestRoot

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsDestRoot

Nome della root nella quale posizionare il file ( nel caso clona o libreria )

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.DizAttr

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsDizAttr

Dizionario con attributi ( prompt,valore )

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DizAttr { get; }
Public ReadOnly Property DizAttr As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ DizAttr {
    Dictionary<String^, Object^>^ get ();
}
member DizAttr : Dictionary<string, Object> with get

Valore della proprietà

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Fullfilename

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsFullfilename

Nome del file in importazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Fullfilename { get; }
Public ReadOnly Property Fullfilename As String
    Get
public:
property String^ Fullfilename {
    String^ get ();
}
member Fullfilename : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.InfoUser

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsInfoUser

Tassello utente da utilizzare.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.NewFullFileName

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsNewFullFileName

Nuovo file da utilizzare nel caso di operazione di Salta.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Note

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsNote

Note da visualizzare nella finestra.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}
member Note : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Operation

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsOperation

Operazione da effettuare sul file

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation Operation { get; set; }
Public Property Operation As PackAndGoImportOperation
    Get
    Set
public:
property PackAndGoImportOperation Operation {
    PackAndGoImportOperation get ();
    void set (PackAndGoImportOperation value);
}
member Operation : PackAndGoImportOperation with get, set

Valore della proprietà

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Progr

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsProgr

Progressivo da utilizzare.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ImportPackAndGoPresetCodingOperationEventArgs.Rev

Proprietà DedNetInvAppImportPackAndGoPresetCodingOperationEventArgsRev

Revisione da utilizzare.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppImportPackAndGoPresetCodingOperationEventArgs
Namespace DedNetInv


Classe DedNetInvApp.InvRilCheckCoherenceEventArgs

Classe DedNetInvAppInvRilCheckCoherenceEventArgs
Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppInvRilCheckCoherenceEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvRilCheckCoherenceEventArgs : DedEventArgs
Public Class InvRilCheckCoherenceEventArgs
    Inherits DedEventArgs
public ref class InvRilCheckCoherenceEventArgs : public DedEventArgs
type InvRilCheckCoherenceEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppInvRilCheckCoherenceEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppInvRilCheckCoherenceEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | StateCommandArgs | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.InvRilCheckCoherenceEventArgs

Costruttore DedNetInvAppInvRilCheckCoherenceEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvRilCheckCoherenceEventArgs(
    StateCommandEventArgs stateCmdArgs,
    Document pubDoc
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As Document
)
public:
InvRilCheckCoherenceEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    Document^ pubDoc
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : Document -> InvRilCheckCoherenceEventArgs

Parametri

stateCmdArgs
Tipo: StateCommandEventArgs
pubDoc
Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppInvRilCheckCoherenceEventArgs
Namespace DedNetInv


Proprietà di InvRilCheckCoherenceEventArgs

Il tipo DedNetInvAppInvRilCheckCoherenceEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Proprietà pubblica | StateCommandArgs | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppInvRilCheckCoherenceEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.InvRilCheckCoherenceEventArgs.PublishingInvDoc

Proprietà DedNetInvAppInvRilCheckCoherenceEventArgsPublishingInvDoc

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document PublishingInvDoc { get; }
Public ReadOnly Property PublishingInvDoc As Document
    Get
public:
property Document^ PublishingInvDoc {
    Document^ get ();
}
member PublishingInvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppInvRilCheckCoherenceEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.InvRilCheckCoherenceEventArgs.StateCommandArgs

Proprietà DedNetInvAppInvRilCheckCoherenceEventArgsStateCommandArgs

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public StateCommandEventArgs StateCommandArgs { get; }
Public ReadOnly Property StateCommandArgs As StateCommandEventArgs
    Get
public:
property StateCommandEventArgs^ StateCommandArgs {
    StateCommandEventArgs^ get ();
}
member StateCommandArgs : StateCommandEventArgs with get

Valore della proprietà

Tipo: StateCommandEventArgs
Vedi anche

Documentazione

Classe DedNetInvAppInvRilCheckCoherenceEventArgs
Namespace DedNetInv


Classe DedNetInvApp.InvRilPublishEventArgs

Classe DedNetInvAppInvRilPublishEventArgs
Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppDedInvPublishEventArgs
DedNetInvDedNetInvAppInvRilPublishEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvRilPublishEventArgs : DedNetInvAppDedInvPublishEventArgs
Public Class InvRilPublishEventArgs
    Inherits DedNetInvAppDedInvPublishEventArgs
public ref class InvRilPublishEventArgs : public DedNetInvAppDedInvPublishEventArgs
type InvRilPublishEventArgs =
    class
        inherit DedNetInvAppDedInvPublishEventArgs
    end

Il tipo DedNetInvAppInvRilPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppInvRilPublishEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione. (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando. (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Inventor oggetto di pubblicazione (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.InvRilPublishEventArgs

Costruttore DedNetInvAppInvRilPublishEventArgs

Costruttore

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvRilPublishEventArgs(
    StateCommandEventArgs stateCmdArgs,
    Document pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As Document,
    pubMan As DedPublicationManager
)
public:
InvRilPublishEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    Document^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : Document *
        pubMan : DedPublicationManager -> InvRilPublishEventArgs

Parametri

stateCmdArgs
Tipo: StateCommandEventArgs
pubDoc
Tipo: Document
pubMan
Tipo: DedPublicationManager
Vedi anche

Documentazione

Classe DedNetInvAppInvRilPublishEventArgs
Namespace DedNetInv


Proprietà di InvRilPublishEventArgs

Il tipo DedNetInvAppInvRilPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione. (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando. (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Inventor oggetto di pubblicazione (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Proprietà pubblica | PublishingInvDoc | Restituisce il documento di Inventor oggetto di pubblicazione (Ereditato da DedNetInvAppDedInvPublishEventArgs.)
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppInvRilPublishEventArgs
Namespace DedNetInv


Classe DedNetInvApp.ModifyingDocumentsEventArgs

Classe DedNetInvAppModifyingDocumentsEventArgs
Argomento utilizzato per l'evento di scelta checkout/checkin nel onfiledirty.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppModifyingDocumentsEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentsEventArgs : DedEventArgs
Public Class ModifyingDocumentsEventArgs
    Inherits DedEventArgs
public ref class ModifyingDocumentsEventArgs : public DedEventArgs
type ModifyingDocumentsEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppModifyingDocumentsEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppModifyingDocumentsEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | ModifyingDocList | Restituisce il ModifyingDocumentInfoList in elaborazione.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ModifyingDocumentsEventArgs

Costruttore DedNetInvAppModifyingDocumentsEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentsEventArgs(
    ModifyingDocumentInfoList modifyingDocList
)
Public Sub New (
    modifyingDocList As ModifyingDocumentInfoList
)
public:
ModifyingDocumentsEventArgs(
    ModifyingDocumentInfoList^ modifyingDocList
)
new :
        modifyingDocList : ModifyingDocumentInfoList -> ModifyingDocumentsEventArgs

Parametri

modifyingDocList
Tipo: DedNetInvModifyingDocumentInfoList
Vedi anche

Documentazione

Classe DedNetInvAppModifyingDocumentsEventArgs
Namespace DedNetInv


Proprietà di ModifyingDocumentsEventArgs

Il tipo DedNetInvAppModifyingDocumentsEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | ModifyingDocList | Restituisce il ModifyingDocumentInfoList in elaborazione.
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppModifyingDocumentsEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ModifyingDocumentsEventArgs.ModifyingDocList

Proprietà DedNetInvAppModifyingDocumentsEventArgsModifyingDocList

Restituisce il ModifyingDocumentInfoList in elaborazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList ModifyingDocList { get; }
Public ReadOnly Property ModifyingDocList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ ModifyingDocList {
    ModifyingDocumentInfoList^ get ();
}
member ModifyingDocList : ModifyingDocumentInfoList with get

Valore della proprietà

Tipo: ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe DedNetInvAppModifyingDocumentsEventArgs
Namespace DedNetInv


Classe DedNetInvApp.MultiSaverExecutionInfoEventArgs

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Argomento utilizzato per l'evento di before e after esecuzione del salva multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppMultiSaverExecutionInfoEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverExecutionInfoEventArgs : DedEventArgs
Public Class MultiSaverExecutionInfoEventArgs
    Inherits DedEventArgs
public ref class MultiSaverExecutionInfoEventArgs : public DedEventArgs
type MultiSaverExecutionInfoEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppMultiSaverExecutionInfoEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppMultiSaverExecutionInfoEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InvolvedNodes | Nodi coinvolti nell'operazioni
Proprietà pubblica | Message | Famiglia selezionata
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SkipElaboration | Famiglia selezionata
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.MultiSaverExecutionInfoEventArgs

Costruttore DedNetInvAppMultiSaverExecutionInfoEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverExecutionInfoEventArgs(
    List<DedInvSaveMulipleFormMultiSaverNodeDescriptor> involvedNodes,
    DedInvSaveMulipleFormMultiSaverModeCriteria activeCriteria,
    DedType selectedType
)
Public Sub New (
    involvedNodes As List(Of DedInvSaveMulipleFormMultiSaverNodeDescriptor),
    activeCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria,
    selectedType As DedType
)
public:
MultiSaverExecutionInfoEventArgs(
    List<DedInvSaveMulipleFormMultiSaverNodeDescriptor^>^ involvedNodes,
    DedInvSaveMulipleFormMultiSaverModeCriteria^ activeCriteria,
    DedType^ selectedType
)
new :
        involvedNodes : List<DedInvSaveMulipleFormMultiSaverNodeDescriptor> *
        activeCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria *
        selectedType : DedType -> MultiSaverExecutionInfoEventArgs

Parametri

involvedNodes
Tipo: System.Collections.GenericList DedInvSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria
selectedType
Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà di MultiSaverExecutionInfoEventArgs

Il tipo DedNetInvAppMultiSaverExecutionInfoEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InvolvedNodes | Nodi coinvolti nell'operazioni
Proprietà pubblica | Message | Famiglia selezionata
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SkipElaboration | Famiglia selezionata
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverExecutionInfoEventArgs.ActiveCriteria

Proprietà DedNetInvAppMultiSaverExecutionInfoEventArgsActiveCriteria

Criterio attivo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedInvSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedInvSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverExecutionInfoEventArgs.InvolvedNodes

Proprietà DedNetInvAppMultiSaverExecutionInfoEventArgsInvolvedNodes

Nodi coinvolti nell'operazioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedInvSaveMulipleFormMultiSaverNodeDescriptor> InvolvedNodes { get; }
Public ReadOnly Property InvolvedNodes As List(Of DedInvSaveMulipleFormMultiSaverNodeDescriptor)
    Get
public:
property List<DedInvSaveMulipleFormMultiSaverNodeDescriptor^>^ InvolvedNodes {
    List<DedInvSaveMulipleFormMultiSaverNodeDescriptor^>^ get ();
}
member InvolvedNodes : List<DedInvSaveMulipleFormMultiSaverNodeDescriptor> with get

Valore della proprietà

Tipo: List DedInvSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverExecutionInfoEventArgs.Message

Proprietà DedNetInvAppMultiSaverExecutionInfoEventArgsMessage

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverExecutionInfoEventArgs.SelectedType

Proprietà DedNetInvAppMultiSaverExecutionInfoEventArgsSelectedType

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedType { get; set; }
Public Property SelectedType As DedType
    Get
    Set
public:
property DedType^ SelectedType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverExecutionInfoEventArgs.SkipElaboration

Proprietà DedNetInvAppMultiSaverExecutionInfoEventArgsSkipElaboration

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipElaboration { get; set; }
Public Property SkipElaboration As Boolean
    Get
    Set
public:
property bool SkipElaboration {
    bool get ();
    void set (bool value);
}
member SkipElaboration : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverExecutionInfoEventArgs
Namespace DedNetInv


Classe DedNetInvApp.MultiSaverItemElaborationEventArgs

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Argomento utilizzato per l'evento di before e after esecuzione del singolo elemento nel salva multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppMultiSaverItemElaborationEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverItemElaborationEventArgs : DedEventArgs
Public Class MultiSaverItemElaborationEventArgs
    Inherits DedEventArgs
public ref class MultiSaverItemElaborationEventArgs : public DedEventArgs
type MultiSaverItemElaborationEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppMultiSaverItemElaborationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppMultiSaverItemElaborationEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Anagrafica impostata da pers Lua
Proprietà pubblica | Doc | Anagrafica impostata da pers Lua
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | FreeCode | FreeCode impostato da pers Lua
Proprietà pubblica | FreeFile | FreeFile impostato da pers Lua
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | Message | Famiglia selezionata
Proprietà pubblica | NodeItem | Nodi coinvolti nell'operazioni
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SkipElaboration | Famiglia selezionata
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.MultiSaverItemElaborationEventArgs

Costruttore DedNetInvAppMultiSaverItemElaborationEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverItemElaborationEventArgs(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor item,
    DedInvSaveMulipleFormMultiSaverModeCriteria activeCriteria,
    DedType selectedType
)
Public Sub New (
    item As DedInvSaveMulipleFormMultiSaverNodeDescriptor,
    activeCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria,
    selectedType As DedType
)
public:
MultiSaverItemElaborationEventArgs(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ item,
    DedInvSaveMulipleFormMultiSaverModeCriteria^ activeCriteria,
    DedType^ selectedType
)
new :
        item : DedInvSaveMulipleFormMultiSaverNodeDescriptor *
        activeCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria *
        selectedType : DedType -> MultiSaverItemElaborationEventArgs

Parametri

item
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria
selectedType
Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà di MultiSaverItemElaborationEventArgs

Il tipo DedNetInvAppMultiSaverItemElaborationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Anagrafica impostata da pers Lua
Proprietà pubblica | Doc | Anagrafica impostata da pers Lua
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | FreeCode | FreeCode impostato da pers Lua
Proprietà pubblica | FreeFile | FreeFile impostato da pers Lua
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | Message | Famiglia selezionata
Proprietà pubblica | NodeItem | Nodi coinvolti nell'operazioni
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Proprietà pubblica | SelectedType | Famiglia selezionata
Proprietà pubblica | SkipElaboration | Famiglia selezionata
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.ActiveCriteria

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsActiveCriteria

Criterio attivo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedInvSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedInvSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.Data

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsData

Anagrafica impostata da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.Doc

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsDoc

Anagrafica impostata da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Doc { get; set; }
Public Property Doc As DedDoc
    Get
    Set
public:
property DedDoc^ Doc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Doc : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.FreeCode

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsFreeCode

FreeCode impostato da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FreeCode { get; set; }
Public Property FreeCode As String
    Get
    Set
public:
property String^ FreeCode {
    String^ get ();
    void set (String^ value);
}
member FreeCode : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.FreeFile

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsFreeFile

FreeFile impostato da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FreeFile { get; set; }
Public Property FreeFile As String
    Get
    Set
public:
property String^ FreeFile {
    String^ get ();
    void set (String^ value);
}
member FreeFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.InfoUser

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsInfoUser

Infouser impostato da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.Message

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsMessage

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.NodeItem

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsNodeItem

Nodi coinvolti nell'operazioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverNodeDescriptor NodeItem { get; }
Public ReadOnly Property NodeItem As DedInvSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedInvSaveMulipleFormMultiSaverNodeDescriptor^ NodeItem {
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member NodeItem : DedInvSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.Progr

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsProgr

Progr impostato da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.Rev

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsRev

Rev impostato da pers Lua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.SelectedType

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsSelectedType

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedType { get; set; }
Public Property SelectedType As DedType
    Get
    Set
public:
property DedType^ SelectedType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverItemElaborationEventArgs.SkipElaboration

Proprietà DedNetInvAppMultiSaverItemElaborationEventArgsSkipElaboration

Famiglia selezionata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipElaboration { get; set; }
Public Property SkipElaboration As Boolean
    Get
    Set
public:
property bool SkipElaboration {
    bool get ();
    void set (bool value);
}
member SkipElaboration : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverItemElaborationEventArgs
Namespace DedNetInv


Classe DedNetInvApp.MultiSaverOverrideDedTypeEventArgs

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetInvDedNetInvAppMultiSaverOverrideDedTypeEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverOverrideDedTypeEventArgs : DedEventArgs
Public Class MultiSaverOverrideDedTypeEventArgs
    Inherits DedEventArgs
public ref class MultiSaverOverrideDedTypeEventArgs : public DedEventArgs
type MultiSaverOverrideDedTypeEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetInvAppMultiSaverOverrideDedTypeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppMultiSaverOverrideDedTypeEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | NodeItem | Nodi coinvolti nell'operazioni
Proprietà pubblica | OverrideType | Famiglia da utilizzare per l'override
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.MultiSaverOverrideDedTypeEventArgs

Costruttore DedNetInvAppMultiSaverOverrideDedTypeEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverOverrideDedTypeEventArgs(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor item,
    DedInvSaveMulipleFormMultiSaverModeCriteria activeCriteria
)
Public Sub New (
    item As DedInvSaveMulipleFormMultiSaverNodeDescriptor,
    activeCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria
)
public:
MultiSaverOverrideDedTypeEventArgs(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ item,
    DedInvSaveMulipleFormMultiSaverModeCriteria^ activeCriteria
)
new :
        item : DedInvSaveMulipleFormMultiSaverNodeDescriptor *
        activeCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria -> MultiSaverOverrideDedTypeEventArgs

Parametri

item
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor
activeCriteria
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetInv


Proprietà di MultiSaverOverrideDedTypeEventArgs

Il tipo DedNetInvAppMultiSaverOverrideDedTypeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActiveCriteria | Criterio attivo
Proprietà pubblica | BeforeOrAfter | Restituisce il momento dell'evento rispetto l'azione. (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | Restituisce o imposta il valore restituito dal comando. Questo argomento viene preso in considerazione solo se HandlingCode = Handled. (Ereditato da DedEventArgs.)
Proprietà pubblica | Exception | Eccezione per eventuale annullamento dell'evento. Utilizzabile da script.... (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento. (Ereditato da DedEventArgs.)
Proprietà pubblica | NodeItem | Nodi coinvolti nell'operazioni
Proprietà pubblica | OverrideType | Famiglia da utilizzare per l'override
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverOverrideDedTypeEventArgs.ActiveCriteria

Proprietà DedNetInvAppMultiSaverOverrideDedTypeEventArgsActiveCriteria

Criterio attivo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteria ActiveCriteria { get; }
Public ReadOnly Property ActiveCriteria As DedInvSaveMulipleFormMultiSaverModeCriteria
    Get
public:
property DedInvSaveMulipleFormMultiSaverModeCriteria^ ActiveCriteria {
    DedInvSaveMulipleFormMultiSaverModeCriteria^ get ();
}
member ActiveCriteria : DedInvSaveMulipleFormMultiSaverModeCriteria with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteria
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverOverrideDedTypeEventArgs.NodeItem

Proprietà DedNetInvAppMultiSaverOverrideDedTypeEventArgsNodeItem

Nodi coinvolti nell'operazioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverNodeDescriptor NodeItem { get; }
Public ReadOnly Property NodeItem As DedInvSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedInvSaveMulipleFormMultiSaverNodeDescriptor^ NodeItem {
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member NodeItem : DedInvSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.MultiSaverOverrideDedTypeEventArgs.OverrideType

Proprietà DedNetInvAppMultiSaverOverrideDedTypeEventArgsOverrideType

Famiglia da utilizzare per l'override

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType OverrideType { get; set; }
Public Property OverrideType As DedType
    Get
    Set
public:
property DedType^ OverrideType {
    DedType^ get ();
    void set (DedType^ value);
}
member OverrideType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedNetInvAppMultiSaverOverrideDedTypeEventArgs
Namespace DedNetInv


Enumerazione DedNetInvApp.OnFileDirtyBehaviour

Enumerazione DedNetInvAppOnFileDirtyBehaviour
Possibili comportamnti alla notifica dell'onFileDirty su di un documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum OnFileDirtyBehaviour
Public Enumeration OnFileDirtyBehaviour
public enum class OnFileDirtyBehaviour
type OnFileDirtyBehaviour
Membri
Nome | Valore | Descrizione
ShowForm | 0 |
IgnoreDocStatus | 1 |
EnforceCheckOut | 2 |
Vedi anche

Documentazione

Namespace DedNetInv


Classe DedNetInvApp.ResolutionEventArgs

Classe DedNetInvAppResolutionEventArgs
Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetInvDedNetInvAppResolutionEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolutionEventArgs : EventArgs
Public Class ResolutionEventArgs
    Inherits EventArgs
public ref class ResolutionEventArgs : public EventArgs
type ResolutionEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetInvAppResolutionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppResolutionEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.ResolutionEventArgs

Costruttore DedNetInvAppResolutionEventArgs

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ResolutionEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
ResolutionEventArgs(
    String^ fileName
)
new :
        fileName : string -> ResolutionEventArgs

Parametri

fileName
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvAppResolutionEventArgs
Namespace DedNetInv


Proprietà di ResolutionEventArgs

Il tipo DedNetInvAppResolutionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppResolutionEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ResolutionEventArgs.FileName

Proprietà DedNetInvAppResolutionEventArgsFileName

Nome del file non trovato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppResolutionEventArgs
Namespace DedNetInv


Proprietà DedNetInvApp.ResolutionEventArgs.SostFileName

Proprietà DedNetInvAppResolutionEventArgsSostFileName

Nuovo file da sostituire

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SostFileName { get; set; }
Public Property SostFileName As String
    Get
    Set
public:
property String^ SostFileName {
    String^ get ();
    void set (String^ value);
}
member SostFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppResolutionEventArgs
Namespace DedNetInv


Classe DedNetInvApp.UpdateDataDescriptor

Classe DedNetInvAppUpdateDataDescriptor
Oggetto di servizio per l'aggiornamento dell'anagrafica
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvAppUpdateDataDescriptor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDataDescriptor
Public Class UpdateDataDescriptor
public ref class UpdateDataDescriptor
type UpdateDataDescriptor =  class end

Il tipo DedNetInvAppUpdateDataDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppUpdateDataDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | DocDataPart |
Proprietà pubblica | InvDoc |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.UpdateDataDescriptor

Costruttore DedNetInvAppUpdateDataDescriptor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateDataDescriptor()
Public Sub New
public:
UpdateDataDescriptor()
new : unit -> UpdateDataDescriptor
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Proprietà di UpdateDataDescriptor

Il tipo DedNetInvAppUpdateDataDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config |
Proprietà pubblica | Data |
Proprietà pubblica | DocDataPart |
Proprietà pubblica | InvDoc |
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Proprietà DedNetInvApp.UpdateDataDescriptor.Config

Proprietà DedNetInvAppUpdateDataDescriptorConfig

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Proprietà DedNetInvApp.UpdateDataDescriptor.Data

Proprietà DedNetInvAppUpdateDataDescriptorData

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Proprietà DedNetInvApp.UpdateDataDescriptor.DocDataPart

Proprietà DedNetInvAppUpdateDataDescriptorDocDataPart

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DocDataPart { get; set; }
Public Property DocDataPart As DedDataPart
    Get
    Set
public:
property DedDataPart^ DocDataPart {
    DedDataPart^ get ();
    void set (DedDataPart^ value);
}
member DocDataPart : DedDataPart with get, set

Valore della proprietà

Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Proprietà DedNetInvApp.UpdateDataDescriptor.InvDoc

Proprietà DedNetInvAppUpdateDataDescriptorInvDoc

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; set; }
Public Property InvDoc As Document
    Get
    Set
public:
property Document^ InvDoc {
    Document^ get ();
    void set (Document^ value);
}
member InvDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptor
Namespace DedNetInv


Classe DedNetInvApp.UpdateDataDescriptors

Classe DedNetInvAppUpdateDataDescriptors
Lista di descrittori di aggiornamento dell'anagrafica
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetInvAppUpdateDataDescriptor
DedNetInvDedNetInvAppUpdateDataDescriptors

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateDataDescriptors : List<DedNetInvAppUpdateDataDescriptor>
Public Class UpdateDataDescriptors
    Inherits List(Of DedNetInvAppUpdateDataDescriptor)
public ref class UpdateDataDescriptors : public List<DedNetInvAppUpdateDataDescriptor^>
type UpdateDataDescriptors =
    class
        inherit List<DedNetInvAppUpdateDataDescriptor>
    end

Il tipo DedNetInvAppUpdateDataDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvAppUpdateDataDescriptors |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvApp.UpdateDataDescriptors

Costruttore DedNetInvAppUpdateDataDescriptors

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateDataDescriptors()
Public Sub New
public:
UpdateDataDescriptors()
new : unit -> UpdateDataDescriptors
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptors
Namespace DedNetInv


Metodi di UpdateDataDescriptors

Il tipo DedNetInvAppUpdateDataDescriptors espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Torna su
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptors
Namespace DedNetInv


Metodo DedNetInvApp.UpdateDataDescriptors.Add

Metodo DedNetInvAppUpdateDataDescriptorsAdd

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    DedDataPart docDataPart,
    DedData data,
    Document invDoc,
    string config
)
Public Sub Add (
    docDataPart As DedDataPart,
    data As DedData,
    invDoc As Document,
    config As String
)
public:
void Add(
    DedDataPart^ docDataPart,
    DedData^ data,
    Document^ invDoc,
    String^ config
)
member Add :
        docDataPart : DedDataPart *
        data : DedData *
        invDoc : Document *
        config : string -> unit

Parametri

docDataPart
Tipo: DedDataPart
data
Tipo: DedData
invDoc
Tipo: Document
config
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvAppUpdateDataDescriptors
Namespace DedNetInv


Classe DedNetInvOldFileResolution
Classe per la gestione della risoluzione degli oldFile
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvOldFileResolution

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetInvOldFileResolution
Public Class DedNetInvOldFileResolution
public ref class DedNetInvOldFileResolution
type DedNetInvOldFileResolution =  class end

Il tipo DedNetInvOldFileResolution espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvOldFileResolution |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetReplaceFullFileName | Ricava il file da utilizzare per la risoluzione del file in apertura, in base ai parametri utilizzati per costruire l'oggetto ed in base alle scelte precedentemente effettuate dall'utente. Restituisce stringa vuota se non si devono effettuare sostituzioni.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvOldFileResolution

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetInvOldFileResolution(
    string RelativeFileName,
    string LibraryName,
    NameValueMap Context,
    Application InvApp
)
Public Sub New (
    RelativeFileName As String,
    LibraryName As String,
    Context As NameValueMap,
    InvApp As Application
)
public:
DedNetInvOldFileResolution(
    String^ RelativeFileName,
    String^ LibraryName,
    NameValueMap^ Context,
    Application^ InvApp
)
new :
        RelativeFileName : string *
        LibraryName : string *
        Context : NameValueMap *
        InvApp : Application -> DedNetInvOldFileResolution

Parametri

RelativeFileName
Tipo: SystemString
LibraryName
Tipo: SystemString
Context
Tipo: NameValueMap
InvApp
Tipo: Application
Vedi anche

Documentazione

Classe DedNetInvOldFileResolution
Namespace DedNetInv


Metodi di DedNetInvOldFileResolution

Il tipo DedNetInvOldFileResolution espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | GetReplaceFullFileName | Ricava il file da utilizzare per la risoluzione del file in apertura, in base ai parametri utilizzati per costruire l'oggetto ed in base alle scelte precedentemente effettuate dall'utente. Restituisce stringa vuota se non si devono effettuare sostituzioni.
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolution
Namespace DedNetInv


Metodo DedNetInvOldFileResolution.GetReplaceFullFileName

Metodo DedNetInvOldFileResolutionGetReplaceFullFileName

Ricava il file da utilizzare per la risoluzione del file in apertura, in base ai parametri utilizzati per costruire l'oggetto ed in base alle scelte precedentemente effettuate dall'utente. Restituisce stringa vuota se non si devono effettuare sostituzioni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetReplaceFullFileName()
Public Function GetReplaceFullFileName As String
public:
String^ GetReplaceFullFileName()
member GetReplaceFullFileName : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvOldFileResolution
Namespace DedNetInv


Classe DedNetInvOldFileResolution.OnFileResolutionOldPathItem

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvOldFileResolutionOnFileResolutionOldPathItem

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionOldPathItem
Public Class OnFileResolutionOldPathItem
public ref class OnFileResolutionOldPathItem
type OnFileResolutionOldPathItem =  class end

Il tipo DedNetInvOldFileResolutionOnFileResolutionOldPathItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvOldFileResolutionOnFileResolutionOldPathItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Path |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvOldFileResolution.OnFileResolutionOldPathItem

Costruttore DedNetInvOldFileResolutionOnFileResolutionOldPathItem

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionOldPathItem(
    string path
)
Public Sub New (
    path As String
)
public:
OnFileResolutionOldPathItem(
    String^ path
)
new :
        path : string -> OnFileResolutionOldPathItem

Parametri

path
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Namespace DedNetInv


Proprietà di OnFileResolutionOldPathItem

Il tipo DedNetInvOldFileResolutionOnFileResolutionOldPathItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Path |
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Namespace DedNetInv


Proprietà DedNetInvOldFileResolution.OnFileResolutionOldPathItem.Path

Proprietà DedNetInvOldFileResolutionOnFileResolutionOldPathItemPath

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Namespace DedNetInv


Metodi di OnFileResolutionOldPathItem

Il tipo DedNetInvOldFileResolutionOnFileResolutionOldPathItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Namespace DedNetInv


Metodo DedNetInvOldFileResolution.OnFileResolutionOldPathItem.Equals

Metodo DedNetInvOldFileResolutionOnFileResolutionOldPathItemEquals

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathItem
Namespace DedNetInv


Classe DedNetInvOldFileResolution.OnFileResolutionOldPathList

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetInvOldFileResolutionOnFileResolutionOldPathItem
DedNetInvDedNetInvOldFileResolutionOnFileResolutionOldPathList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionOldPathList : List<DedNetInvOldFileResolutionOnFileResolutionOldPathItem>
Public Class OnFileResolutionOldPathList
    Inherits List(Of DedNetInvOldFileResolutionOnFileResolutionOldPathItem)
public ref class OnFileResolutionOldPathList : public List<DedNetInvOldFileResolutionOnFileResolutionOldPathItem^>
type OnFileResolutionOldPathList =
    class
        inherit List<DedNetInvOldFileResolutionOnFileResolutionOldPathItem>
    end

Il tipo DedNetInvOldFileResolutionOnFileResolutionOldPathList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvOldFileResolutionOnFileResolutionOldPathList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | Contains |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvOldFileResolution.OnFileResolutionOldPathList

Costruttore DedNetInvOldFileResolutionOnFileResolutionOldPathList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionOldPathList()
Public Sub New
public:
OnFileResolutionOldPathList()
new : unit -> OnFileResolutionOldPathList
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathList
Namespace DedNetInv


Metodi di OnFileResolutionOldPathList

Il tipo DedNetInvOldFileResolutionOnFileResolutionOldPathList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add |
Metodo pubblico | Contains |
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathList
Namespace DedNetInv


Metodo DedNetInvOldFileResolution.OnFileResolutionOldPathList.Add

Metodo DedNetInvOldFileResolutionOnFileResolutionOldPathListAdd

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    string oldPath
)
Public Sub Add (
    oldPath As String
)
public:
void Add(
    String^ oldPath
)
member Add :
        oldPath : string -> unit

Parametri

oldPath
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathList
Namespace DedNetInv


Metodo DedNetInvOldFileResolution.OnFileResolutionOldPathList.Contains

Metodo DedNetInvOldFileResolutionOnFileResolutionOldPathListContains

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Contains(
    string oldPath
)
Public Function Contains (
    oldPath As String
) As Boolean
public:
bool Contains(
    String^ oldPath
)
member Contains :
        oldPath : string -> bool

Parametri

oldPath
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionOldPathList
Namespace DedNetInv


Classe DedNetInvOldFileResolution.OnFileResolutionSostItem

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvOldFileResolutionOnFileResolutionSostItem

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItem
Public Class OnFileResolutionSostItem
public ref class OnFileResolutionSostItem
type OnFileResolutionSostItem =  class end

Il tipo DedNetInvOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvOldFileResolutionOnFileResolutionSostItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Campo pubblico | PreviewFile |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvOldFileResolution.OnFileResolutionSostItem

Costruttore DedNetInvOldFileResolutionOnFileResolutionSostItem

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItem()
Public Sub New
public:
OnFileResolutionSostItem()
new : unit -> OnFileResolutionSostItem
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Proprietà di OnFileResolutionSostItem

Il tipo DedNetInvOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Proprietà DedNetInvOldFileResolution.OnFileResolutionSostItem.DbFile

Proprietà DedNetInvOldFileResolutionOnFileResolutionSostItemDbFile

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbFile { get; set; }
Public Property DbFile As String
    Get
    Set
public:
property String^ DbFile {
    String^ get ();
    void set (String^ value);
}
member DbFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Proprietà DedNetInvOldFileResolution.OnFileResolutionSostItem.OldFile

Proprietà DedNetInvOldFileResolutionOnFileResolutionSostItemOldFile

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Campi di OnFileResolutionSostItem

Il tipo DedNetInvOldFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Campo pubblico | PreviewFile |
Torna su
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Campo DedNetInvOldFileResolution.OnFileResolutionSostItem.DocGuid

Campo DedNetInvOldFileResolutionOnFileResolutionSostItemDocGuid

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocGuid
Public DocGuid As Guid
public:
Guid DocGuid
val mutable DocGuid: Guid

Valore del campo

Tipo: Guid
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Campo DedNetInvOldFileResolution.OnFileResolutionSostItem.PreviewFile

Campo DedNetInvOldFileResolutionOnFileResolutionSostItemPreviewFile

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string PreviewFile
Public PreviewFile As String
public:
String^ PreviewFile
val mutable PreviewFile: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItem
Namespace DedNetInv


Classe DedNetInvOldFileResolution.OnFileResolutionSostItemList

Classe DedNetInvOldFileResolutionOnFileResolutionSostItemList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetInvOldFileResolutionOnFileResolutionSostItem
DedNetInvDedNetInvOldFileResolutionOnFileResolutionSostItemList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItemList : List<DedNetInvOldFileResolutionOnFileResolutionSostItem>
Public Class OnFileResolutionSostItemList
    Inherits List(Of DedNetInvOldFileResolutionOnFileResolutionSostItem)
public ref class OnFileResolutionSostItemList : public List<DedNetInvOldFileResolutionOnFileResolutionSostItem^>
type OnFileResolutionSostItemList =
    class
        inherit List<DedNetInvOldFileResolutionOnFileResolutionSostItem>
    end

Il tipo DedNetInvOldFileResolutionOnFileResolutionSostItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvOldFileResolutionOnFileResolutionSostItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvOldFileResolution.OnFileResolutionSostItemList

Costruttore DedNetInvOldFileResolutionOnFileResolutionSostItemList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItemList()
Public Sub New
public:
OnFileResolutionSostItemList()
new : unit -> OnFileResolutionSostItemList
Vedi anche

Documentazione

Classe DedNetInvOldFileResolutionOnFileResolutionSostItemList
Namespace DedNetInv


Enumerazione DedNetInvOldFileResolution.RispostaUtenteSost

Enumerazione DedNetInvOldFileResolutionRispostaUtenteSost

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum RispostaUtenteSost
Public Enumeration RispostaUtenteSost
public enum class RispostaUtenteSost
type RispostaUtenteSost
Membri
Nome | Valore | Descrizione
Si | 0 |
No | 1 |
SiTutti | 2 |
NoTutti | 3 |
Vedi anche

Documentazione

Namespace DedNetInv


Classe DedNetInvServer
Classe che implementa l'interfaccia di collegamento per gli AddIn di inventor, punto d'ingresso dell'applicazione. Non espongo a COM perché sono caricato dal QsInvLoader.
Gerarchia di ereditarietà
SystemObject
DedNetInvDedNetInvServer

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetInvServer : ApplicationAddInServer
Public Class DedNetInvServer
    Implements ApplicationAddInServer
public ref class DedNetInvServer : ApplicationAddInServer
type DedNetInvServer =
    class
        interface ApplicationAddInServer
    end

Il tipo DedNetInvServer espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetInvServer |
Torna su
Proprietà
 | Nome | Descrizione
 | App | Restituisce l'istanza dell'applicazione add-in.
Proprietà pubblica | Automation | Nessuna implementazione.
 | Loaded | Restitusice se il caricamento sia andato a buon fine.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Inizializzazione.
Metodo pubblico | Deactivate | Chiusura.
Metodo pubblico | ExecuteCommand | Nessuna implementazione.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DedNetInvServer

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetInvServer()
Public Sub New
public:
DedNetInvServer()
new : unit -> DedNetInvServer
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Proprietà di DedNetInvServer

Il tipo DedNetInvServer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
 | App | Restituisce l'istanza dell'applicazione add-in.
Proprietà pubblica | Automation | Nessuna implementazione.
 | Loaded | Restitusice se il caricamento sia andato a buon fine.
Torna su
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Proprietà DedNetInvServer.App

Proprietà DedNetInvServerApp

Restituisce l'istanza dell'applicazione add-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetInvApp App { get; }
Public Shared ReadOnly Property App As DedNetInvApp
    Get
public:
static property DedNetInvApp^ App {
    DedNetInvApp^ get ();
}
static member App : DedNetInvApp with get

Valore della proprietà

Tipo: DedNetInvApp
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Proprietà DedNetInvServer.Automation

Proprietà DedNetInvServerAutomation

Nessuna implementazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Automation { get; }
Public ReadOnly Property Automation As Object
    Get
public:
virtual property Object^ Automation {
    Object^ get () sealed;
}
abstract Automation : Object with get
override Automation : Object with get

Valore della proprietà

Tipo: Object

Implementa

ApplicationAddInServer.Automation
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Proprietà DedNetInvServer.Loaded

Proprietà DedNetInvServerLoaded

Restitusice se il caricamento sia andato a buon fine.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool Loaded { get; }
Public Shared ReadOnly Property Loaded As Boolean
    Get
public:
static property bool Loaded {
    bool get ();
}
static member Loaded : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Metodi di DedNetInvServer

Il tipo DedNetInvServer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Inizializzazione.
Metodo pubblico | Deactivate | Chiusura.
Metodo pubblico | ExecuteCommand | Nessuna implementazione.
Torna su
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Metodo DedNetInvServer.Activate

Metodo DedNetInvServerActivate

Inizializzazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Activate(
    ApplicationAddInSite AddInSiteObject,
    bool FirstTime
)
Public Sub Activate (
    AddInSiteObject As ApplicationAddInSite,
    FirstTime As Boolean
)
public:
virtual void Activate(
    ApplicationAddInSite^ AddInSiteObject,
    bool FirstTime
) sealed
abstract Activate :
        AddInSiteObject : ApplicationAddInSite *
        FirstTime : bool -> unit
override Activate :
        AddInSiteObject : ApplicationAddInSite *
        FirstTime : bool -> unit

Parametri

AddInSiteObject
Tipo: ApplicationAddInSite
FirstTime
Tipo: SystemBoolean

Implementa

ApplicationAddInServer.Activate(ApplicationAddInSite, Boolean)
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Metodo DedNetInvServer.Deactivate

Metodo DedNetInvServerDeactivate

Chiusura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Deactivate()
Public Sub Deactivate
public:
virtual void Deactivate() sealed
abstract Deactivate : unit -> unit
override Deactivate : unit -> unit

Implementa

ApplicationAddInServer.Deactivate
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Metodo DedNetInvServer.ExecuteCommand

Metodo DedNetInvServerExecuteCommand

Nessuna implementazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ExecuteCommand(
    int CommandID
)
Public Sub ExecuteCommand (
    CommandID As Integer
)
public:
virtual void ExecuteCommand(
    int CommandID
) sealed
abstract ExecuteCommand :
        CommandID : int -> unit
override ExecuteCommand :
        CommandID : int -> unit

Parametri

CommandID
Tipo: SystemInt32

Implementa

ApplicationAddInServer.ExecuteCommand(Int32)
Vedi anche

Documentazione

Classe DedNetInvServer
Namespace DedNetInv


Classe DocumentMonitorSync
Classe utilizzata per la sincronizzazione degli eventi sui documenti.
Gerarchia di ereditarietà
SystemObject
DedNetInvDocumentMonitorSync

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentMonitorSync
Public Class DocumentMonitorSync
public ref class DocumentMonitorSync
type DocumentMonitorSync =  class end

Il tipo DocumentMonitorSync espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentMonitorSync | Costruttore.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | IsDocInEvent | Verifica se un documento è registrato negli eventi.
Metodo pubblico | StartDocEvent | Segna come in modifica il documento individuato dal nome completo. Se è già presente nella lista non fa niente.
Metodo pubblico | StopDocEvent | Toglie il documento dalla lista dei documenti in modifica. Se non è già presente nella lista non fa niente.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore DocumentMonitorSync

Costruttore.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentMonitorSync()
Public Sub New
public:
DocumentMonitorSync()
new : unit -> DocumentMonitorSync
Vedi anche

Documentazione

Classe DocumentMonitorSync
Namespace DedNetInv


Metodi di DocumentMonitorSync

Il tipo DocumentMonitorSync espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | IsDocInEvent | Verifica se un documento è registrato negli eventi.
Metodo pubblico | StartDocEvent | Segna come in modifica il documento individuato dal nome completo. Se è già presente nella lista non fa niente.
Metodo pubblico | StopDocEvent | Toglie il documento dalla lista dei documenti in modifica. Se non è già presente nella lista non fa niente.
Torna su
Vedi anche

Documentazione

Classe DocumentMonitorSync
Namespace DedNetInv


Metodo DocumentMonitorSync.IsDocInEvent

Metodo DocumentMonitorSyncIsDocInEvent

Verifica se un documento è registrato negli eventi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDocInEvent(
    string fullfilename
)
Public Function IsDocInEvent (
    fullfilename As String
) As Boolean
public:
bool IsDocInEvent(
    String^ fullfilename
)
member IsDocInEvent :
        fullfilename : string -> bool

Parametri

fullfilename
Tipo: SystemString
Indice stringa che identifica il documento (nome completo del documento) che si vuole controllare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentMonitorSync
Namespace DedNetInv


Metodo DocumentMonitorSync.StartDocEvent

Metodo DocumentMonitorSyncStartDocEvent

Segna come in modifica il documento individuato dal nome completo. Se è già presente nella lista non fa niente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void StartDocEvent(
    string fullfilename
)
Public Sub StartDocEvent (
    fullfilename As String
)
public:
void StartDocEvent(
    String^ fullfilename
)
member StartDocEvent :
        fullfilename : string -> unit

Parametri

fullfilename
Tipo: SystemString
Indice stringa che identifica il documento (nome completo del documento).
Vedi anche

Documentazione

Classe DocumentMonitorSync
Namespace DedNetInv


Metodo DocumentMonitorSync.StopDocEvent

Metodo DocumentMonitorSyncStopDocEvent

Toglie il documento dalla lista dei documenti in modifica. Se non è già presente nella lista non fa niente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void StopDocEvent(
    string fullfilename
)
Public Sub StopDocEvent (
    fullfilename As String
)
public:
void StopDocEvent(
    String^ fullfilename
)
member StopDocEvent :
        fullfilename : string -> unit

Parametri

fullfilename
Tipo: SystemString
Indice stringa che identifica il documento (nome completo del documento).
Vedi anche

Documentazione

Classe DocumentMonitorSync
Namespace DedNetInv


Classe FileStateElement
Oggetto descrivente un singolo documento ed il suo stato. Funge da ponte tra chi sa determinare lo stato del documento e deve decidere cosa fare nelle varie situazioni e chi deve visualizzare lo stato del documento e le sue dipendenze.
Gerarchia di ereditarietà
SystemObject
DedNetInvFileStateElement

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElement
Public Class FileStateElement
public ref class FileStateElement
type FileStateElement =  class end

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config | Configurazione/modelstate dell'elemento
Proprietà pubblica | Data | Anagrafica associata all'elemento
Proprietà pubblica | Description | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | Document | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | Embedded | Imposta o restituisce se l'elemento è embeddato (anycad)
Proprietà pubblica | Existing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | FullDocumentName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | FullFileName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | InvDoc | Documento di Inventor se esistente
Proprietà pubblica | IsMultiBody | Indica se l'elemento identifica un componente virtuale
Proprietà pubblica | IsVirtual | Indica se l'elemento identifica un componente virtuale
Proprietà pubblica | Missing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | NameOnly | Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.
Proprietà pubblica | StateID | Restituisce o imposta lo stato dell'elemento.
Proprietà pubblica | StopScan | Ferma la riocorsione
Proprietà pubblica | VirtualOccurrence | Occorrenza virtuale associata se esistente
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | RefreshElement | Forza il ricarimento del documento
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Proprietà di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config | Configurazione/modelstate dell'elemento
Proprietà pubblica | Data | Anagrafica associata all'elemento
Proprietà pubblica | Description | Imposta o restituisce la descrizione di questo elemento.
Proprietà pubblica | Document | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | Embedded | Imposta o restituisce se l'elemento è embeddato (anycad)
Proprietà pubblica | Existing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | FullDocumentName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | FullFileName | Nome completo del file sotteso a questo elemento.
Proprietà pubblica | InvDoc | Documento di Inventor se esistente
Proprietà pubblica | IsMultiBody | Indica se l'elemento identifica un componente virtuale
Proprietà pubblica | IsVirtual | Indica se l'elemento identifica un componente virtuale
Proprietà pubblica | Missing | Imposta o restituisce se l'elemento è mancante
Proprietà pubblica | NameOnly | Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.
Proprietà pubblica | StateID | Restituisce o imposta lo stato dell'elemento.
Proprietà pubblica | StopScan | Ferma la riocorsione
Proprietà pubblica | VirtualOccurrence | Occorrenza virtuale associata se esistente
Torna su
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Config

Proprietà FileStateElementConfig

Configurazione/modelstate dell'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; set; }
Public Property Config As String
    Get
    Set
public:
property String^ Config {
    String^ get ();
    void set (String^ value);
}
member Config : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Data

Proprietà FileStateElementData

Anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Description

Proprietà FileStateElementDescription

Imposta o restituisce la descrizione di questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Document

Proprietà FileStateElementDocument

Nome completo del file sotteso a questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Embedded

Proprietà FileStateElementEmbedded

Imposta o restituisce se l'elemento è embeddato (anycad)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Embedded { get; set; }
Public Property Embedded As Boolean
    Get
    Set
public:
property bool Embedded {
    bool get ();
    void set (bool value);
}
member Embedded : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Existing

Proprietà FileStateElementExisting

Imposta o restituisce se l'elemento è mancante

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Existing { get; }
Public ReadOnly Property Existing As Boolean
    Get
public:
property bool Existing {
    bool get ();
}
member Existing : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.FullDocumentName

Proprietà FileStateElementFullDocumentName

Nome completo del file sotteso a questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullDocumentName { get; }
Public ReadOnly Property FullDocumentName As String
    Get
public:
property String^ FullDocumentName {
    String^ get ();
}
member FullDocumentName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.FullFileName

Proprietà FileStateElementFullFileName

Nome completo del file sotteso a questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.InvDoc

Proprietà FileStateElementInvDoc

Documento di Inventor se esistente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; set; }
Public Property InvDoc As Document
    Get
    Set
public:
property Document^ InvDoc {
    Document^ get ();
    void set (Document^ value);
}
member InvDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.IsMultiBody

Proprietà FileStateElementIsMultiBody

Indica se l'elemento identifica un componente virtuale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsMultiBody { get; }
Public ReadOnly Property IsMultiBody As Boolean
    Get
public:
property bool IsMultiBody {
    bool get ();
}
member IsMultiBody : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.IsVirtual

Proprietà FileStateElementIsVirtual

Indica se l'elemento identifica un componente virtuale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsVirtual { get; }
Public ReadOnly Property IsVirtual As Boolean
    Get
public:
property bool IsVirtual {
    bool get ();
}
member IsVirtual : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.Missing

Proprietà FileStateElementMissing

Imposta o restituisce se l'elemento è mancante

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Missing { get; set; }
Public Property Missing As Boolean
    Get
    Set
public:
property bool Missing {
    bool get ();
    void set (bool value);
}
member Missing : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.NameOnly

Proprietà FileStateElementNameOnly

Restituisce il solo nome senza estensione del file con eventuale livello di dettaglio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NameOnly { get; }
Public ReadOnly Property NameOnly As String
    Get
public:
property String^ NameOnly {
    String^ get ();
}
member NameOnly : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.StateID

Proprietà FileStateElementStateID

Restituisce o imposta lo stato dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int StateID { get; set; }
Public Property StateID As Integer
    Get
    Set
public:
property int StateID {
    int get ();
    void set (int value);
}
member StateID : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.StopScan

Proprietà FileStateElementStopScan

Ferma la riocorsione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool StopScan { get; set; }
Public Property StopScan As Boolean
    Get
    Set
public:
property bool StopScan {
    bool get ();
    void set (bool value);
}
member StopScan : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Proprietà FileStateElement.VirtualOccurrence

Proprietà FileStateElementVirtualOccurrence

Occorrenza virtuale associata se esistente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence VirtualOccurrence { get; set; }
Public Property VirtualOccurrence As ComponentOccurrence
    Get
    Set
public:
property ComponentOccurrence^ VirtualOccurrence {
    ComponentOccurrence^ get ();
    void set (ComponentOccurrence^ value);
}
member VirtualOccurrence : ComponentOccurrence with get, set

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Metodi di FileStateElement

Il tipo FileStateElement espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | RefreshElement | Forza il ricarimento del documento
Torna su
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Metodo FileStateElement.Equals

Metodo FileStateElementEquals

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Metodo FileStateElement.RefreshElement

Metodo FileStateElementRefreshElement

Forza il ricarimento del documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshElement(
    bool reloadMoved
)
Public Sub RefreshElement (
    reloadMoved As Boolean
)
public:
void RefreshElement(
    bool reloadMoved
)
member RefreshElement :
        reloadMoved : bool -> unit

Parametri

reloadMoved
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe FileStateElement
Namespace DedNetInv


Classe FileStateElementList
Lista di elementi di tipo FileStateElement.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList FileStateElement
DedNetInvFileStateElementList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementList : List<FileStateElement>
Public Class FileStateElementList
    Inherits List(Of FileStateElement)
public ref class FileStateElementList : public List<FileStateElement^>
type FileStateElementList =
    class
        inherit List<FileStateElement>
    end

Il tipo FileStateElementList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateElementList |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore FileStateElementList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList()
Public Sub New
public:
FileStateElementList()
new : unit -> FileStateElementList
Vedi anche

Documentazione

Classe FileStateElementList
Namespace DedNetInv


Classe FileStateManager
Gestisce lo stato di tutti i documenti presenti in Inventor aperti in modo visibile o meno. Centralizza le funzionalità necessarie al Check-in/out o al riservarsi o meno i documenti. Attraverso l'implementazione di una stessa interfaccia rende possibile avere un albero di documenti con la gestione integrata del loro stato, fruibile sia nel DedPlus che nel Ded tradizionale. Pensa questa classe a registrarsi agli eventi e visualizzare il browser con lo stato dei documenti. Chiama i metodi dell'interfaccia, necessari al check-out/riservo dei documenti.
Gerarchia di ereditarietà
SystemObject
DedNetInvFileStateManager

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateManager
Public Class FileStateManager
public ref class FileStateManager
type FileStateManager =  class end

Il tipo FileStateManager espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FileStateManager | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvApp | Restituisce l'applicazione di Inventor sottesa all'oggetto.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il Nome dello stato d'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restrituisce il valore della proprietà passata.
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetElement | Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.
Metodo pubblico | GetMovedDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetVirtualElement | Restituisce l'elemento con le informazioni del componente virtuale. Overload ottimizzato per i virtuali, evita chiamate al database ridondanti
Metodo pubblico | HasChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è in uno stato di dirty
Metodo pubblico | MakeInvCommandContext | Ritorna il contesto per i comandi contestuali in base agli oggetti passati
Metodo protetto | OnElementActivatedEvent | Solleva l'evento ElementActivatedEvent.
Metodo protetto | OnElementChangedEvent | Solleva l'evento ElementChangedEvent.
Metodo pubblico | OnElementDoubleClicked | Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento
Metodo pubblico | OnElementsSelected | Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero
Metodo pubblico | OnHotTrackElementClicked | Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link
Metodo pubblico | RaiseElementActivatedEvent | Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.
Metodo pubblico | RaiseElementChangedEvent | Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.
Metodo pubblico | ReloadElementInformations | Ricarico le informazioni legate al nodo
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent | Evento che si verifica quando un elemento è diventato attivo.
Evento pubblico | ElementChangedEvent | Elemento che si verifica quando un elemento è stato modificato.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore FileStateManager

Costruttore unico.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateManager(
    Application invApp,
    IFileStateInformer informer
)
Public Sub New (
    invApp As Application,
    informer As IFileStateInformer
)
public:
FileStateManager(
    Application^ invApp,
    IFileStateInformer^ informer
)
new :
        invApp : Application *
        informer : IFileStateInformer -> FileStateManager

Parametri

invApp
Tipo: Application
Applicazione di Inventor di riferimento.
informer
Tipo: DedNetInvIFileStateInformer
Oggetto al quale chiedere informazioni sui singoli elementi.
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Proprietà di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | InvApp | Restituisce l'applicazione di Inventor sottesa all'oggetto.
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Proprietà FileStateManager.InvApp

Proprietà FileStateManagerInvApp

Restituisce l'applicazione di Inventor sottesa all'oggetto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Application InvApp { get; }
Public ReadOnly Property InvApp As Application
    Get
public:
property Application^ InvApp {
    Application^ get ();
}
member InvApp : Application with get

Valore della proprietà

Tipo: Application
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il Nome dello stato d'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restrituisce il valore della proprietà passata.
Metodo pubblico | GetChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetElement | Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.
Metodo pubblico | GetMovedDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.
Metodo pubblico | GetVirtualElement | Restituisce l'elemento con le informazioni del componente virtuale. Overload ottimizzato per i virtuali, evita chiamate al database ridondanti
Metodo pubblico | HasChildrenElements | Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è in uno stato di dirty
Metodo pubblico | MakeInvCommandContext | Ritorna il contesto per i comandi contestuali in base agli oggetti passati
Metodo protetto | OnElementActivatedEvent | Solleva l'evento ElementActivatedEvent.
Metodo protetto | OnElementChangedEvent | Solleva l'evento ElementChangedEvent.
Metodo pubblico | OnElementDoubleClicked | Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento
Metodo pubblico | OnElementsSelected | Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero
Metodo pubblico | OnHotTrackElementClicked | Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link
Metodo pubblico | RaiseElementActivatedEvent | Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.
Metodo pubblico | RaiseElementChangedEvent | Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.
Metodo pubblico | ReloadElementInformations | Ricarico le informazioni legate al nodo
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.AllowHotTracking

Metodo FileStateManagerAllowHotTracking

Chiama la funzione dell'informer che dermina se il nodo ammette hot tracking

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowHotTracking(
    FileStateElement el
)
Public Function AllowHotTracking (
    el As FileStateElement
) As Boolean
public:
bool AllowHotTracking(
    FileStateElement^ el
)
member AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetActiveElement

Metodo FileStateManagerGetActiveElement

Restituisce l'elemento correntemente attivo. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager. Restituisce null se non ci sono elementi attivi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetActiveElement()
Public Function GetActiveElement As FileStateElement
public:
FileStateElement^ GetActiveElement()
member GetActiveElement : unit -> FileStateElement

Valore di ritorno

Tipo: FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetAnagStateImageKey

Metodo FileStateManagerGetAnagStateImageKey

Restituisce l'immagine o icona associata allo stato d'anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image GetAnagStateImageKey(
    FileStateElement el
)
Public Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
public:
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
member GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Image
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetAnagStateName

Metodo FileStateManagerGetAnagStateName

Restituisce il Nome dello stato d'anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAnagStateName(
    FileStateElement el
)
Public Function GetAnagStateName (
    el As FileStateElement
) As String
public:
String^ GetAnagStateName(
    FileStateElement^ el
)
member GetAnagStateName :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetAttr

Metodo FileStateManagerGetAttr

Restrituisce il valore della proprietà passata.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object GetAttr(
    FileStateElement el,
    string nome
)
Public Function GetAttr (
    el As FileStateElement,
    nome As String
) As Object
public:
Object^ GetAttr(
    FileStateElement^ el,
    String^ nome
)
member GetAttr :
        el : FileStateElement *
        nome : string -> Object

Parametri

el
Tipo: DedNetInvFileStateElement
nome
Tipo: SystemString

Valore di ritorno

Tipo: Object
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetChildrenElements

Metodo FileStateManagerGetChildrenElements

Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementList GetChildrenElements(
    FileStateElement el
)
Public Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
public:
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
member GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: FileStateElementList
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetDocument

Metodo FileStateManagerGetDocument

Ritorna il documento associato all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetDocument(
    FileStateElement el
)
Public Function GetDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetDocument(
    FileStateElement^ el
)
member GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetElement

Metodo FileStateManagerGetElement

Restituisce l'elemento con le informazioni del documento. Se esiste già lo restituisce altrimenti lo crea, lo aggiunge e lo restituisce.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetElement(
    string fullFileName,
    string fullDocumentName,
    string config = "*"
)
Public Function GetElement (
    fullFileName As String,
    fullDocumentName As String,
    Optional config As String = "*"
) As FileStateElement
public:
FileStateElement^ GetElement(
    String^ fullFileName,
    String^ fullDocumentName,
    String^ config = L"*"
)
member GetElement :
        fullFileName : string *
        fullDocumentName : string *
        ?config : string
(* Defaults:
        let _config = defaultArg config "*"
*)
-> FileStateElement

Parametri

fullFileName
Tipo: SystemString
fullDocumentName
Tipo: SystemString
config (Optional)
Tipo: SystemString

Valore di ritorno

Tipo: FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetMovedDocument

Metodo FileStateManagerGetMovedDocument

Ritorna il documento associato all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc GetMovedDocument(
    FileStateElement el
)
Public Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
public:
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
member GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetSelectionImageKey

Metodo FileStateManagerGetSelectionImageKey

Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetSelectionImageKey(
    FileStateElement el
)
Public Function GetSelectionImageKey (
    el As FileStateElement
) As String
public:
String^ GetSelectionImageKey(
    FileStateElement^ el
)
member GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento in oggetto.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetStateImageKey

Metodo FileStateManagerGetStateImageKey

Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento. Per ottenerlo viene interrogato l'oggetto IFileStateInformer contenuto nel FileStateManager.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetStateImageKey(
    FileStateElement el
)
Public Function GetStateImageKey (
    el As FileStateElement
) As String
public:
String^ GetStateImageKey(
    FileStateElement^ el
)
member GetStateImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento in oggetto.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.GetVirtualElement

Metodo FileStateManagerGetVirtualElement

Restituisce l'elemento con le informazioni del componente virtuale. Overload ottimizzato per i virtuali, evita chiamate al database ridondanti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement GetVirtualElement(
    ComponentOccurrence occ
)
Public Function GetVirtualElement (
    occ As ComponentOccurrence
) As FileStateElement
public:
FileStateElement^ GetVirtualElement(
    ComponentOccurrence^ occ
)
member GetVirtualElement :
        occ : ComponentOccurrence -> FileStateElement

Parametri

occ
Tipo: ComponentOccurrence

Valore di ritorno

Tipo: FileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.HasChildrenElements

Metodo FileStateManagerHasChildrenElements

Ritorna gli elementi figli dell'elemento passato. Utilizza il document descriptor come mezzo più sicuro per ottenere questo risultato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasChildrenElements(
    FileStateElement el
)
Public Function HasChildrenElements (
    el As FileStateElement
) As Boolean
public:
bool HasChildrenElements(
    FileStateElement^ el
)
member HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.IsDirty

Metodo FileStateManagerIsDirty

Ritorna vero se l'elemento passato è in uno stato di dirty

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDirty(
    FileStateElement el
)
Public Function IsDirty (
    el As FileStateElement
) As Boolean
public:
bool IsDirty(
    FileStateElement^ el
)
member IsDirty :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.MakeInvCommandContext

Metodo FileStateManagerMakeInvCommandContext

Ritorna il contesto per i comandi contestuali in base agli oggetti passati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvCommandContext MakeInvCommandContext(
    FileStateElementList elsList
)
Public Function MakeInvCommandContext (
    elsList As FileStateElementList
) As DedInvCommandContext
public:
DedInvCommandContext^ MakeInvCommandContext(
    FileStateElementList^ elsList
)
member MakeInvCommandContext :
        elsList : FileStateElementList -> DedInvCommandContext

Parametri

elsList
Tipo: DedNetInvFileStateElementList

Valore di ritorno

Tipo: DedInvCommandContext
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.OnElementActivatedEvent

Metodo FileStateManagerOnElementActivatedEvent

Solleva l'evento ElementActivatedEvent.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementActivatedEvent(
    bool restoreStatus
)
Protected Sub OnElementActivatedEvent (
    restoreStatus As Boolean
)
protected:
void OnElementActivatedEvent(
    bool restoreStatus
)
member OnElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.OnElementChangedEvent

Metodo FileStateManagerOnElementChangedEvent

Solleva l'evento ElementChangedEvent.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnElementChangedEvent(
    FileStateElement el
)
Protected Sub OnElementChangedEvent (
    el As FileStateElement
)
protected:
void OnElementChangedEvent(
    FileStateElement^ el
)
member OnElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento da passare all'evento.
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.OnElementDoubleClicked

Metodo FileStateManagerOnElementDoubleClicked

Chiama la funzione dell'informer che si occupa di gestire il doppio click sull'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementDoubleClicked(
    FileStateElement el
)
Public Sub OnElementDoubleClicked (
    el As FileStateElement
)
public:
void OnElementDoubleClicked(
    FileStateElement^ el
)
member OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.OnElementsSelected

Metodo FileStateManagerOnElementsSelected

Chiama la funzione dell'informer che si occupa di gestire la selezione di elementi sull'albero

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnElementsSelected(
    FileStateElementList elsList
)
Public Sub OnElementsSelected (
    elsList As FileStateElementList
)
public:
void OnElementsSelected(
    FileStateElementList^ elsList
)
member OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList
Tipo: DedNetInvFileStateElementList
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.OnHotTrackElementClicked

Metodo FileStateManagerOnHotTrackElementClicked

Chiama la funzione dell'informer che si occupa di gestire il click singolo sull'elemento in stato di link

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnHotTrackElementClicked(
    FileStateElement el
)
Public Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
public:
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
member OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.RaiseElementActivatedEvent

Metodo FileStateManagerRaiseElementActivatedEvent

Solleva l'evento ElementActivatedEvent con l'elemento passato come argomento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementActivatedEvent(
    bool restoreStatus
)
Public Sub RaiseElementActivatedEvent (
    restoreStatus As Boolean
)
public:
void RaiseElementActivatedEvent(
    bool restoreStatus
)
member RaiseElementActivatedEvent :
        restoreStatus : bool -> unit

Parametri

restoreStatus
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.RaiseElementChangedEvent

Metodo FileStateManagerRaiseElementChangedEvent

Solleva l'evento ElementChangedEvent con l'elemento passato come argomento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RaiseElementChangedEvent(
    FileStateElement el
)
Public Sub RaiseElementChangedEvent (
    el As FileStateElement
)
public:
void RaiseElementChangedEvent(
    FileStateElement^ el
)
member RaiseElementChangedEvent :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento di cui si vuole notificare l'avvenuto aggiornamento.
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Metodo FileStateManager.ReloadElementInformations

Metodo FileStateManagerReloadElementInformations

Ricarico le informazioni legate al nodo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ReloadElementInformations(
    FileStateElement el,
    bool reloadMoved
)
Public Sub ReloadElementInformations (
    el As FileStateElement,
    reloadMoved As Boolean
)
public:
void ReloadElementInformations(
    FileStateElement^ el,
    bool reloadMoved
)
member ReloadElementInformations :
        el : FileStateElement *
        reloadMoved : bool -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento di riferimento
reloadMoved
Tipo: SystemBoolean
Indica se ricaricare eventuali documenti moved
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Eventi di FileStateManager

Il tipo FileStateManager espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ElementActivatedEvent | Evento che si verifica quando un elemento è diventato attivo.
Evento pubblico | ElementChangedEvent | Elemento che si verifica quando un elemento è stato modificato.
Torna su
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Evento FileStateManager.ElementActivatedEvent

Evento FileStateManagerElementActivatedEvent
Evento che si verifica quando un elemento è diventato attivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event FileStateManagerActivateEventHandler ElementActivatedEvent
Public Event ElementActivatedEvent As FileStateManagerActivateEventHandler
public:
 event FileStateManagerActivateEventHandler^ ElementActivatedEvent {
    void add (FileStateManagerActivateEventHandler^ value);
    void remove (FileStateManagerActivateEventHandler^ value);
}
member ElementActivatedEvent : IEvent<FileStateManagerActivateEventHandler,
    EventArgs>

Valore

Tipo: DedNetInvFileStateManagerActivateEventHandler
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Evento FileStateManager.ElementChangedEvent

Evento FileStateManagerElementChangedEvent
Elemento che si verifica quando un elemento è stato modificato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ElementChangedEvent
Public Event ElementChangedEvent As EventHandler
public:
 event EventHandler^ ElementChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ElementChangedEvent : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe FileStateManager
Namespace DedNetInv


Delegate FileStateManager.ActivateEventHandler

Delegate FileStateManagerActivateEventHandler
Elemento che si verifica quando un elemento è stato aggiunto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void ActivateEventHandler(
    bool restoreStatus
)
Public Delegate Sub ActivateEventHandler (
    restoreStatus As Boolean
)
public delegate void ActivateEventHandler(
    bool restoreStatus
)
type ActivateEventHandler =
    delegate of
        restoreStatus : bool -> unit

Parametri

restoreStatus
Tipo: SystemBoolean
Vedi anche

Documentazione

Namespace DedNetInv


Interfaccia IFileStateInformer

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public interface IFileStateInformer
Public Interface IFileStateInformer
public interface class IFileStateInformer
type IFileStateInformer =  interface end

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Restituisce true se l'elemento ammeytte hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il nome dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restituisce il valore della proprietà passata
Metodo pubblico | GetChildrenElements | Restutuisce gli elementi figli dell'elemento passato.
Metodo pubblico | GetData | Ritorna l'anagrafica associata all'elemento
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetMovedDocument | Ritorna il documento moved associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento ha figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è dirty
Metodo pubblico | MakeInvCommandContext | Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.
Metodo pubblico | OnElementDoubleClicked | Gestione del doppio click su singolo elemento
Metodo pubblico | OnElementsSelected | Gestione della selezione degli elementi sul controllo
Metodo pubblico | OnHotTrackElementClicked | Gestione del singolo click su elemento hot tracking
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Metodi di IFileStateInformer

Il tipo IFileStateInformer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllowHotTracking | Restituisce true se l'elemento ammeytte hot tracking
Metodo pubblico | GetActiveElement | Restituisce l'elemento correntemente attivo.
Metodo pubblico | GetAnagStateImageKey | Restituisce l'immagine dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAnagStateName | Restituisce il nome dello stato dell'anagrafica associata all'elemento
Metodo pubblico | GetAttr | Restituisce il valore della proprietà passata
Metodo pubblico | GetChildrenElements | Restutuisce gli elementi figli dell'elemento passato.
Metodo pubblico | GetData | Ritorna l'anagrafica associata all'elemento
Metodo pubblico | GetDocument | Ritorna il documento associato all'elemento
Metodo pubblico | GetMovedDocument | Ritorna il documento moved associato all'elemento
Metodo pubblico | GetSelectionImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.
Metodo pubblico | GetState | Restituisce lo stato dell'elemento.
Metodo pubblico | GetStateImageKey | Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.
Metodo pubblico | HasChildrenElements | Indica se l'elemento ha figli
Metodo pubblico | IsDirty | Ritorna vero se l'elemento passato è dirty
Metodo pubblico | MakeInvCommandContext | Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.
Metodo pubblico | OnElementDoubleClicked | Gestione del doppio click su singolo elemento
Metodo pubblico | OnElementsSelected | Gestione della selezione degli elementi sul controllo
Metodo pubblico | OnHotTrackElementClicked | Gestione del singolo click su elemento hot tracking
Torna su
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.AllowHotTracking

Metodo IFileStateInformerAllowHotTracking

Restituisce true se l'elemento ammeytte hot tracking

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool AllowHotTracking(
    FileStateElement el
)
Function AllowHotTracking (
    el As FileStateElement
) As Boolean
bool AllowHotTracking(
    FileStateElement^ el
)
abstract AllowHotTracking :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetActiveElement

Metodo IFileStateInformerGetActiveElement

Restituisce l'elemento correntemente attivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
FileStateElement GetActiveElement()
Function GetActiveElement As FileStateElement
FileStateElement^ GetActiveElement()
abstract GetActiveElement : unit -> FileStateElement

Valore di ritorno

Tipo: FileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetAnagStateImageKey

Metodo IFileStateInformerGetAnagStateImageKey

Restituisce l'immagine dello stato dell'anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
Image GetAnagStateImageKey(
    FileStateElement el
)
Function GetAnagStateImageKey (
    el As FileStateElement
) As Image
Image^ GetAnagStateImageKey(
    FileStateElement^ el
)
abstract GetAnagStateImageKey :
        el : FileStateElement -> Image

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Image
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetAnagStateName

Metodo IFileStateInformerGetAnagStateName

Restituisce il nome dello stato dell'anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetAnagStateName(
    FileStateElement el
)
Function GetAnagStateName (
    el As FileStateElement
) As String
String^ GetAnagStateName(
    FileStateElement^ el
)
abstract GetAnagStateName :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetAttr

Metodo IFileStateInformerGetAttr

Restituisce il valore della proprietà passata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetAttr(
    FileStateElement el,
    string attrName
)
Function GetAttr (
    el As FileStateElement,
    attrName As String
) As String
String^ GetAttr(
    FileStateElement^ el,
    String^ attrName
)
abstract GetAttr :
        el : FileStateElement *
        attrName : string -> string

Parametri

el
Tipo: DedNetInvFileStateElement
attrName
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetChildrenElements

Metodo IFileStateInformerGetChildrenElements

Restutuisce gli elementi figli dell'elemento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
FileStateElementList GetChildrenElements(
    FileStateElement el
)
Function GetChildrenElements (
    el As FileStateElement
) As FileStateElementList
FileStateElementList^ GetChildrenElements(
    FileStateElement^ el
)
abstract GetChildrenElements :
        el : FileStateElement -> FileStateElementList

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: FileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetData

Metodo IFileStateInformerGetData

Ritorna l'anagrafica associata all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedData GetData(
    FileStateElement el
)
Function GetData (
    el As FileStateElement
) As DedData
DedData^ GetData(
    FileStateElement^ el
)
abstract GetData :
        el : FileStateElement -> DedData

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetDocument

Metodo IFileStateInformerGetDocument

Ritorna il documento associato all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetDocument(
    FileStateElement el
)
Function GetDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetDocument(
    FileStateElement^ el
)
abstract GetDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetMovedDocument

Metodo IFileStateInformerGetMovedDocument

Ritorna il documento moved associato all'elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedDoc GetMovedDocument(
    FileStateElement el
)
Function GetMovedDocument (
    el As FileStateElement
) As DedDoc
DedDoc^ GetMovedDocument(
    FileStateElement^ el
)
abstract GetMovedDocument :
        el : FileStateElement -> DedDoc

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetSelectionImageKey

Metodo IFileStateInformerGetSelectionImageKey

Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di selezione dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetSelectionImageKey(
    FileStateElement el
)
Function GetSelectionImageKey (
    el As FileStateElement
) As String
String^ GetSelectionImageKey(
    FileStateElement^ el
)
abstract GetSelectionImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento in oggetto.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetState

Metodo IFileStateInformerGetState

Restituisce lo stato dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
int GetState(
    FileStateElement el
)
Function GetState (
    el As FileStateElement
) As Integer
int GetState(
    FileStateElement^ el
)
abstract GetState :
        el : FileStateElement -> int

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento da verificare.

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.GetStateImageKey

Metodo IFileStateInformerGetStateImageKey

Restituisce l'indice stringa o nome dell'immagine rappresentante l'icona di stato dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
string GetStateImageKey(
    FileStateElement el
)
Function GetStateImageKey (
    el As FileStateElement
) As String
String^ GetStateImageKey(
    FileStateElement^ el
)
abstract GetStateImageKey :
        el : FileStateElement -> string

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento in oggetto.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.HasChildrenElements

Metodo IFileStateInformerHasChildrenElements

Indica se l'elemento ha figli

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool HasChildrenElements(
    FileStateElement el
)
Function HasChildrenElements (
    el As FileStateElement
) As Boolean
bool HasChildrenElements(
    FileStateElement^ el
)
abstract HasChildrenElements :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.IsDirty

Metodo IFileStateInformerIsDirty

Ritorna vero se l'elemento passato è dirty

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool IsDirty(
    FileStateElement el
)
Function IsDirty (
    el As FileStateElement
) As Boolean
bool IsDirty(
    FileStateElement^ el
)
abstract IsDirty :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.MakeInvCommandContext

Metodo IFileStateInformerMakeInvCommandContext

Restituisce il contesto dei comandi contestuali in base alla lista di oggetti passati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
DedInvCommandContext MakeInvCommandContext(
    FileStateElementList elsList
)
Function MakeInvCommandContext (
    elsList As FileStateElementList
) As DedInvCommandContext
DedInvCommandContext^ MakeInvCommandContext(
    FileStateElementList^ elsList
)
abstract MakeInvCommandContext :
        elsList : FileStateElementList -> DedInvCommandContext

Parametri

elsList
Tipo: DedNetInvFileStateElementList

Valore di ritorno

Tipo: DedInvCommandContext
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.OnElementDoubleClicked

Metodo IFileStateInformerOnElementDoubleClicked

Gestione del doppio click su singolo elemento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
void OnElementDoubleClicked(
    FileStateElement el
)
Sub OnElementDoubleClicked (
    el As FileStateElement
)
void OnElementDoubleClicked(
    FileStateElement^ el
)
abstract OnElementDoubleClicked :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.OnElementsSelected

Metodo IFileStateInformerOnElementsSelected

Gestione della selezione degli elementi sul controllo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
void OnElementsSelected(
    FileStateElementList elsList
)
Sub OnElementsSelected (
    elsList As FileStateElementList
)
void OnElementsSelected(
    FileStateElementList^ elsList
)
abstract OnElementsSelected :
        elsList : FileStateElementList -> unit

Parametri

elsList
Tipo: DedNetInvFileStateElementList
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Metodo IFileStateInformer.OnHotTrackElementClicked

Metodo IFileStateInformerOnHotTrackElementClicked

Gestione del singolo click su elemento hot tracking

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
bool OnHotTrackElementClicked(
    FileStateElement el
)
Function OnHotTrackElementClicked (
    el As FileStateElement
) As Boolean
bool OnHotTrackElementClicked(
    FileStateElement^ el
)
abstract OnHotTrackElementClicked :
        el : FileStateElement -> bool

Parametri

el
Tipo: DedNetInvFileStateElement

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Interfaccia IFileStateInformer
Namespace DedNetInv


Classe InteractiveMeasurement
Classe per la gestione interattiva della misurazione
Gerarchia di ereditarietà
SystemObject
DedNetInvInteractiveMeasurement

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InteractiveMeasurement
Public Class InteractiveMeasurement
public ref class InteractiveMeasurement
type InteractiveMeasurement =  class end

Il tipo InteractiveMeasurement espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InteractiveMeasurement |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Measure |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore InteractiveMeasurement

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InteractiveMeasurement(
    Application invAppl
)
Public Sub New (
    invAppl As Application
)
public:
InteractiveMeasurement(
    Application^ invAppl
)
new :
        invAppl : Application -> InteractiveMeasurement

Parametri

invAppl
Tipo: Application
Vedi anche

Documentazione

Classe InteractiveMeasurement
Namespace DedNetInv


Metodi di InteractiveMeasurement

Il tipo InteractiveMeasurement espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Measure |
Torna su
Vedi anche

Documentazione

Classe InteractiveMeasurement
Namespace DedNetInv


Metodo InteractiveMeasurement.Measure

Metodo InteractiveMeasurementMeasure

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public double Measure(
    MeasureTypeEnum MeasureType
)
Public Function Measure (
    MeasureType As MeasureTypeEnum
) As Double
public:
double Measure(
    MeasureTypeEnum MeasureType
)
member Measure :
        MeasureType : MeasureTypeEnum -> float

Parametri

MeasureType
Tipo: MeasureTypeEnum

Valore di ritorno

Tipo: Double
Vedi anche

Documentazione

Classe InteractiveMeasurement
Namespace DedNetInv


Classe InvCurSelInfo
Raccoglie le informazioni sulla selezione corrente e sullo stato di attivazione nel caso di un assieme. Fotografa la situazione attuale del documento attivo, dell'eventuale documento in editazione e della selezione corrente.
Gerarchia di ereditarietà
SystemObject
DedNetInvInvCurSelInfo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvCurSelInfo
Public Class InvCurSelInfo
public ref class InvCurSelInfo
type InvCurSelInfo =  class end

Il tipo InvCurSelInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InvCurSelInfo | Costruttore unico. Tutte le informazioni vengono raccolte qui, all'atto dell'inizializzazione.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FirstElement | Restituisce il primo elemento selezionato oppure null se non ci sono documenti aperti.
Proprietà pubblica | HasDerivedComponentSelected | Indica se ci sono oggetti model state nella selezione
Proprietà pubblica | HasModelStatesSelected | Indica se ci sono oggetti model state nella selezione
Proprietà pubblica | HasSelectedElements | Restituisce se ci sono elementi selezionati.
Proprietà pubblica | IsEditSelected | Restituisce se sia selezionato EditDocument.
Proprietà pubblica | IsTopSelected | Restituisce se sia selezionato TopDocument (true anche se non si tratta di assieme).
Proprietà pubblica | MultiSelect | Indica se sia in atto una selezione multipla.
Proprietà pubblica | SingleSelect | Indica se sia in atto una singola selezione o se risulti selezionato solo il TopDocument o solo l'EditDocument. Restituisce false se non ci sono documenti.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | EditDocument | Restituisce le informazioni sul documento che è in modifica (TopDocument oppure sotto-occorrenza attivata dall'utente).
Campo pubblico | EditMode | Indica se ci sia un documento attivato con doppio click dall'utente (nel caso di TopDocument di tipo assieme).
Campo pubblico | Elements | Restituisce la lista di elementi correntemente selezionati. La lista restituita è sempre inizializzata ma vuota in caso di assenza di documenti.
Campo pubblico | IsMultibodyDocument | Inidica se il documento è in modalità multibody
Campo pubblico | SelectedViews | In ambiente disegno, restituisce la lista delle viste selezionate in modo trasversale rispetto agli elements.
Campo pubblico | ThereAreDocuments | Restituisce true se è presente un documento attivo altrimenti false.
Campo pubblico | TopDocument | Restituisce le informazioni sul documento principale.
Campo pubblico | TopHasDerivedComponents | Ritorna vero se il documento corrente ha dei riferimenti derivati
Campo pubblico | TopHasModelStates | Ritorna vero se il documento corrente ha dei model states
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore InvCurSelInfo

Costruttore unico. Tutte le informazioni vengono raccolte qui, all'atto dell'inizializzazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvCurSelInfo()
Public Sub New
public:
InvCurSelInfo()
new : unit -> InvCurSelInfo
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà di InvCurSelInfo

Il tipo InvCurSelInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FirstElement | Restituisce il primo elemento selezionato oppure null se non ci sono documenti aperti.
Proprietà pubblica | HasDerivedComponentSelected | Indica se ci sono oggetti model state nella selezione
Proprietà pubblica | HasModelStatesSelected | Indica se ci sono oggetti model state nella selezione
Proprietà pubblica | HasSelectedElements | Restituisce se ci sono elementi selezionati.
Proprietà pubblica | IsEditSelected | Restituisce se sia selezionato EditDocument.
Proprietà pubblica | IsTopSelected | Restituisce se sia selezionato TopDocument (true anche se non si tratta di assieme).
Proprietà pubblica | MultiSelect | Indica se sia in atto una selezione multipla.
Proprietà pubblica | SingleSelect | Indica se sia in atto una singola selezione o se risulti selezionato solo il TopDocument o solo l'EditDocument. Restituisce false se non ci sono documenti.
Torna su
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.FirstElement

Proprietà InvCurSelInfoFirstElement

Restituisce il primo elemento selezionato oppure null se non ci sono documenti aperti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem FirstElement { get; }
Public ReadOnly Property FirstElement As SelInfoItem
    Get
public:
property SelInfoItem^ FirstElement {
    SelInfoItem^ get ();
}
member FirstElement : SelInfoItem with get

Valore della proprietà

Tipo: SelInfoItem
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.HasDerivedComponentSelected

Proprietà InvCurSelInfoHasDerivedComponentSelected

Indica se ci sono oggetti model state nella selezione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDerivedComponentSelected { get; }
Public ReadOnly Property HasDerivedComponentSelected As Boolean
    Get
public:
property bool HasDerivedComponentSelected {
    bool get ();
}
member HasDerivedComponentSelected : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.HasModelStatesSelected

Proprietà InvCurSelInfoHasModelStatesSelected

Indica se ci sono oggetti model state nella selezione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasModelStatesSelected { get; }
Public ReadOnly Property HasModelStatesSelected As Boolean
    Get
public:
property bool HasModelStatesSelected {
    bool get ();
}
member HasModelStatesSelected : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.HasSelectedElements

Proprietà InvCurSelInfoHasSelectedElements

Restituisce se ci sono elementi selezionati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasSelectedElements { get; }
Public ReadOnly Property HasSelectedElements As Boolean
    Get
public:
property bool HasSelectedElements {
    bool get ();
}
member HasSelectedElements : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.IsEditSelected

Proprietà InvCurSelInfoIsEditSelected

Restituisce se sia selezionato EditDocument.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsEditSelected { get; }
Public ReadOnly Property IsEditSelected As Boolean
    Get
public:
property bool IsEditSelected {
    bool get ();
}
member IsEditSelected : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.IsTopSelected

Proprietà InvCurSelInfoIsTopSelected

Restituisce se sia selezionato TopDocument (true anche se non si tratta di assieme).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsTopSelected { get; }
Public ReadOnly Property IsTopSelected As Boolean
    Get
public:
property bool IsTopSelected {
    bool get ();
}
member IsTopSelected : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.MultiSelect

Proprietà InvCurSelInfoMultiSelect

Indica se sia in atto una selezione multipla.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MultiSelect { get; }
Public ReadOnly Property MultiSelect As Boolean
    Get
public:
property bool MultiSelect {
    bool get ();
}
member MultiSelect : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Proprietà InvCurSelInfo.SingleSelect

Proprietà InvCurSelInfoSingleSelect

Indica se sia in atto una singola selezione o se risulti selezionato solo il TopDocument o solo l'EditDocument. Restituisce false se non ci sono documenti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SingleSelect { get; }
Public ReadOnly Property SingleSelect As Boolean
    Get
public:
property bool SingleSelect {
    bool get ();
}
member SingleSelect : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Metodi di InvCurSelInfo

Il tipo InvCurSelInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Torna su
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Metodo InvCurSelInfo.Equals

Metodo InvCurSelInfoEquals

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campi di InvCurSelInfo

Il tipo InvCurSelInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | EditDocument | Restituisce le informazioni sul documento che è in modifica (TopDocument oppure sotto-occorrenza attivata dall'utente).
Campo pubblico | EditMode | Indica se ci sia un documento attivato con doppio click dall'utente (nel caso di TopDocument di tipo assieme).
Campo pubblico | Elements | Restituisce la lista di elementi correntemente selezionati. La lista restituita è sempre inizializzata ma vuota in caso di assenza di documenti.
Campo pubblico | IsMultibodyDocument | Inidica se il documento è in modalità multibody
Campo pubblico | SelectedViews | In ambiente disegno, restituisce la lista delle viste selezionate in modo trasversale rispetto agli elements.
Campo pubblico | ThereAreDocuments | Restituisce true se è presente un documento attivo altrimenti false.
Campo pubblico | TopDocument | Restituisce le informazioni sul documento principale.
Campo pubblico | TopHasDerivedComponents | Ritorna vero se il documento corrente ha dei riferimenti derivati
Campo pubblico | TopHasModelStates | Ritorna vero se il documento corrente ha dei model states
Torna su
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.EditDocument

Campo InvCurSelInfoEditDocument
Restituisce le informazioni sul documento che è in modifica (TopDocument oppure sotto-occorrenza attivata dall'utente).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItem EditDocument
Public ReadOnly EditDocument As SelInfoItem
public:
initonly SelInfoItem^ EditDocument
val EditDocument: SelInfoItem

Valore del campo

Tipo: SelInfoItem
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.EditMode

Campo InvCurSelInfoEditMode
Indica se ci sia un documento attivato con doppio click dall'utente (nel caso di TopDocument di tipo assieme).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool EditMode
Public ReadOnly EditMode As Boolean
public:
initonly bool EditMode
val EditMode: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.Elements

Campo InvCurSelInfoElements
Restituisce la lista di elementi correntemente selezionati. La lista restituita è sempre inizializzata ma vuota in caso di assenza di documenti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItemList Elements
Public ReadOnly Elements As SelInfoItemList
public:
initonly SelInfoItemList^ Elements
val Elements: SelInfoItemList

Valore del campo

Tipo: SelInfoItemList
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.IsMultibodyDocument

Campo InvCurSelInfoIsMultibodyDocument
Inidica se il documento è in modalità multibody

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool IsMultibodyDocument
Public ReadOnly IsMultibodyDocument As Boolean
public:
initonly bool IsMultibodyDocument
val IsMultibodyDocument: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.SelectedViews

Campo InvCurSelInfoSelectedViews
In ambiente disegno, restituisce la lista delle viste selezionate in modo trasversale rispetto agli elements.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly List<DrawingView> SelectedViews
Public ReadOnly SelectedViews As List(Of DrawingView)
public:
initonly List<DrawingView^>^ SelectedViews
val SelectedViews: List<DrawingView>

Valore del campo

Tipo: List DrawingView
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.ThereAreDocuments

Campo InvCurSelInfoThereAreDocuments
Restituisce true se è presente un documento attivo altrimenti false.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool ThereAreDocuments
Public ReadOnly ThereAreDocuments As Boolean
public:
initonly bool ThereAreDocuments
val ThereAreDocuments: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.TopDocument

Campo InvCurSelInfoTopDocument
Restituisce le informazioni sul documento principale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly SelInfoItem TopDocument
Public ReadOnly TopDocument As SelInfoItem
public:
initonly SelInfoItem^ TopDocument
val TopDocument: SelInfoItem

Valore del campo

Tipo: SelInfoItem
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.TopHasDerivedComponents

Campo InvCurSelInfoTopHasDerivedComponents
Ritorna vero se il documento corrente ha dei riferimenti derivati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool TopHasDerivedComponents
Public ReadOnly TopHasDerivedComponents As Boolean
public:
initonly bool TopHasDerivedComponents
val TopHasDerivedComponents: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Campo InvCurSelInfo.TopHasModelStates

Campo InvCurSelInfoTopHasModelStates
Ritorna vero se il documento corrente ha dei model states

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool TopHasModelStates
Public ReadOnly TopHasModelStates As Boolean
public:
initonly bool TopHasModelStates
val TopHasModelStates: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCurSelInfo
Namespace DedNetInv


Classe InvDocStructInfo
Oggetto specializzato che espande il DocStructInfo e ne aggiunge delle proprietà ed informazioni specifiche sul documento in memoria di Inventor.
Gerarchia di ereditarietà
SystemObject
DocStructInfo
DedNetInvInvDocStructInfo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvDocStructInfo : DocStructInfo
Public Class InvDocStructInfo
    Inherits DocStructInfo
public ref class InvDocStructInfo : public DocStructInfo
type InvDocStructInfo =
    class
        inherit DocStructInfo
    end

Il tipo InvDocStructInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | InvDocStructInfo | Passa la costruzione alla classe base aggiungendo le informazioni del documento di Inventor. Ho bisogno sia del percorso completo del file che del documento perché possono esserci dei documenti nuovi non salvati dei quali è già stato stabilito il percorso completo ma dei quali non esiste il file. Il FileDescriptor ha tutte le info ma il Document può essere null se il documento è stato scaricato dalla memoria (soppresso, ecc.).
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | AssemblyInSubstituteRepresentation | Restituisce se il documento sia un assieme impostato nel LOD sostituto.
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Sovrascrive DocStructInfo.CfgDescr.)
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta. (Ereditato da DocStructInfo.)
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true). (Ereditato da DocStructInfo.)
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento letta dal documento in tempo reale (Sovrascrive DocStructInfo.Config.)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo.)
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client. (Ereditato da DocStructInfo.)
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5. (Ereditato da DocStructInfo.)
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard (Ereditato da DocStructInfo.)
Proprietà pubblica | FileDescriptor | Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite. (Ereditato da DocStructInfo.)
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle) (Ereditato da DocStructInfo.)
Proprietà pubblica | FullFileName | Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze. (Ereditato da DocStructInfo.)
Proprietà pubblica | HasInvDoc | Restituisce se ci sia un documento abbinato al file (se c'é il file c'é anche il documento).
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasSubstitutes | Override della proprietà. Se serve calcola su richiesta la presenza di sostituti al primo livello. (Sovrascrive DocStructInfo.HasSubstitutes.)
Proprietà pubblica | IncludePartFactory | Determina se includere o meno le part factory nel makeChildren auto
Proprietà pubblica | InternalName | Ritorna la revisione del database del documento di Inventor (Sovrascrive DocStructInfo.InternalName.)
Proprietà pubblica | InvDoc | Restituisce il documento abbinato a questo elemento oppure il primo documento trovato in Inventor, abbinato a questo file, oppure null se non si tratta di un documento aperto in Inventor.
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata. (Ereditato da DocStructInfo.)
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un iPart oppure un iAssembly Member
Proprietà pubblica | IsLayoutAsset | Override della proprietà di base. Ritorna true se l'oggetto è un asset della factory. (Sovrascrive DocStructInfo.IsLayoutAsset.)
Proprietà pubblica | IsModel | Restituisce se l'elemento faccia riferimento ad un modello (affidabile solo se il documento sotteso esiste).
Proprietà pubblica | IsModelStateFactory | Restituisce vero se si tratta di un documento member in relazione alla gestione model state
Proprietà pubblica | IsModelStateMember | Restituisce vero se si tratta di un documento member in relazione alla gestione model state
Proprietà pubblica | IsParentSubstitute | Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto del padre. (Sovrascrive DocStructInfo.IsParentSubstitute.)
Proprietà pubblica | IsSaveable | Indica se il documento è salvabile in fase di checkin
Proprietà pubblica | IsSpecialStructContainer | Override della proprietà della classe base. Definisce se l'oggetto è un contenitore di strutture speciali. (Sovrascrive DocStructInfo.IsSpecialStructContainer.)
Proprietà pubblica | IsSpecialStructElement | (Sovrascrive DocStructInfo.IsSpecialStructElement.)
Proprietà pubblica | IsSpecialStructParent | Ritorna true se l'oggetto è un elemento padre di struttura speciale.
Proprietà pubblica | IsSubstitute | Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto. (Sovrascrive DocStructInfo.IsSubstitute.)
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita. (Ereditato da DocStructInfo.)
Proprietà pubblica | Lod | Restituisce il livello di dettaglio ell'elemento (può essere null).
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client (Ereditato da DocStructInfo.)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato. (Ereditato da DocStructInfo.)
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root. (Ereditato da DocStructInfo.)
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo.)
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato (Ereditato da DocStructInfo.)
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio. (Ereditato da DocStructInfo.)
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference (Ereditato da DocStructInfo.)
Proprietà pubblica | SpecialStructType | Restituisce se si tratti di un elemento di una struttura speciale e di quale tipo.
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze. (Ereditato da DocStructInfo.)
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione. (Ereditato da DocStructInfo.)
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto. (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor). (Ereditato da DocStructInfo.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura) (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista. (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddSbloccaOperation | Sblocca un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto. (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor).)
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(String).)
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che le dipendenze non vengono calcolate sull'oggetto ma in base al filename passato. E' utile quando si devono calcolare le dipendenze di un file relative però ad una sua versione backuppata. Vedi caso backup della revisione con documento in checkout. (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String).)
Metodo pubblico | Equals | (Ereditato da DocStructInfo.)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo.)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo.)
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale (Ereditato da DocStructInfo.)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfo.GetHashString.)
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null. (Ereditato da DocStructInfo.)
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo.)
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo.)
 | IsInventorDwg | Restituisce se si tratti di un file di Inventor.
 | IsInventorFile | Verifica se un file appartenga o meno ad Inventor.
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando i documenti aperti in Inventor oppure l'apprentice o le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database. (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura. (Ereditato da DocStructInfo.)
 | MakeFromDocDocStructInfo | Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromDocList | Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileListUsingApprentice | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromInvDocList | Crea e restituisce una lista di struttura documento da una lista di documenti di inventor. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file. (Ereditato da DocStructInfo.)
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null). (Ereditato da DocStructInfo.)
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName). (Ereditato da DocStructInfo.)
Metodo pubblico | ToString | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean).)
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Verifica solo che, se è attiva l'area locale, tutti i padri siano in checkin. (Sovrascrive DocStructInfo.UpdateParentReferences.)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo.)
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore InvDocStructInfo

Passa la costruzione alla classe base aggiungendo le informazioni del documento di Inventor. Ho bisogno sia del percorso completo del file che del documento perché possono esserci dei documenti nuovi non salvati dei quali è già stato stabilito il percorso completo ma dei quali non esiste il file. Il FileDescriptor ha tutte le info ma il Document può essere null se il documento è stato scaricato dalla memoria (soppresso, ecc.).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected InvDocStructInfo(
    DedNetApplication app,
    DocStructInfoCollection parent,
    DocStructInfoDictionary elements,
    DocStructInfoOperationListDictionary operations,
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Protected Sub New (
    app As DedNetApplication,
    parent As DocStructInfoCollection,
    elements As DocStructInfoDictionary,
    operations As DocStructInfoOperationListDictionary,
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
)
protected:
InvDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoCollection^ parent,
    DocStructInfoDictionary^ elements,
    DocStructInfoOperationListDictionary^ operations,
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
new :
        app : DedNetApplication *
        parent : DocStructInfoCollection *
        elements : DocStructInfoDictionary *
        operations : DocStructInfoOperationListDictionary *
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> InvDocStructInfo

Parametri

app
Tipo: DedNetApplication
parent
Tipo: DocStructInfoCollection
elements
Tipo: DocStructInfoDictionary
operations
Tipo: DocStructInfoOperationListDictionary
fileDescr
Tipo: DocStructInfoFileDescriptor
depType
Tipo: DocDepEnum
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà di InvDocStructInfo

Il tipo InvDocStructInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | Restituisce l'applicazione di appartenenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | AssemblyInSubstituteRepresentation | Restituisce se il documento sia un assieme impostato nel LOD sostituto.
Proprietà pubblica | CfgDescr | Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate. (Sovrascrive DocStructInfo.CfgDescr.)
Proprietà pubblica | ChildrenMade | Restituisce o imposta se il calcolo delle dipendenza sia già stato eseguito per questo elemento. Viene impostato dalla procedura di calcolo dei figli (quella automatica o quella fatta dal client elaborando i documenti in memoria) per evitare di rielaborare lo stesso elemento più di una volta. (Ereditato da DocStructInfo.)
Proprietà pubblica | CloneFullName | Restitsuice il percorso completo di destinazione qualora l'elemento sia da clonare (ToClone = true). (Ereditato da DocStructInfo.)
Proprietà pubblica | Config | Restitusice o imposta la configurazione dell'elemento letta dal documento in tempo reale (Sovrascrive DocStructInfo.Config.)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo.)
Proprietà pubblica | DelToMake | Indica che si deve creare il .del del file di partenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | DepType | Restituisce la tipologia di dipendenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | Description | Restitusice o imposta una descrizione libera dell'elemento. Utile soprattutto nei nuovi elementi che sono presenti solo in memoria del client. (Ereditato da DocStructInfo.)
Proprietà pubblica | DocRowVer | Restituisce il DocRowVer calcolato tramite Md5. (Ereditato da DocStructInfo.)
Proprietà pubblica | DoNotMoveOrDelete | Restituisce o imposta se dell'oggetto associato non si deve creare il .moved o il .del. Permette di eseguire l'override del comportamento standard (Ereditato da DocStructInfo.)
Proprietà pubblica | FileDescriptor | Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).
Proprietà pubblica | FileOperationExecuted | Restitusice le operazioni su file di tutte le operazioni presenti nella lista siano state eseguite. (Ereditato da DocStructInfo.)
Proprietà pubblica | FirstOperation | Restituisce la prima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | Folder | Cartella nella quale spostare il file (usata nell'importazione di cartelle) (Ereditato da DocStructInfo.)
Proprietà pubblica | FullFileName | Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).
Proprietà pubblica | HasChildren | Restitusice se questo elemento ha delle dipendenze. (Ereditato da DocStructInfo.)
Proprietà pubblica | HasInvDoc | Restituisce se ci sia un documento abbinato al file (se c'é il file c'é anche il documento).
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasSubstitutes | Override della proprietà. Se serve calcola su richiesta la presenza di sostituti al primo livello. (Sovrascrive DocStructInfo.HasSubstitutes.)
Proprietà pubblica | IncludePartFactory | Determina se includere o meno le part factory nel makeChildren auto
Proprietà pubblica | InternalName | Ritorna la revisione del database del documento di Inventor (Sovrascrive DocStructInfo.InternalName.)
Proprietà pubblica | InvDoc | Restituisce il documento abbinato a questo elemento oppure il primo documento trovato in Inventor, abbinato a questo file, oppure null se non si tratta di un documento aperto in Inventor.
Proprietà pubblica | IsElaborated | Restituisce se l'ultima operazione sia o meno stata effettuata. (Ereditato da DocStructInfo.)
Proprietà pubblica | IsiModelMember | Restituisce se l'elemento sia o meno un iPart oppure un iAssembly Member
Proprietà pubblica | IsLayoutAsset | Override della proprietà di base. Ritorna true se l'oggetto è un asset della factory. (Sovrascrive DocStructInfo.IsLayoutAsset.)
Proprietà pubblica | IsModel | Restituisce se l'elemento faccia riferimento ad un modello (affidabile solo se il documento sotteso esiste).
Proprietà pubblica | IsModelStateFactory | Restituisce vero se si tratta di un documento member in relazione alla gestione model state
Proprietà pubblica | IsModelStateMember | Restituisce vero se si tratta di un documento member in relazione alla gestione model state
Proprietà pubblica | IsParentSubstitute | Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto del padre. (Sovrascrive DocStructInfo.IsParentSubstitute.)
Proprietà pubblica | IsSaveable | Indica se il documento è salvabile in fase di checkin
Proprietà pubblica | IsSpecialStructContainer | Override della proprietà della classe base. Definisce se l'oggetto è un contenitore di strutture speciali. (Sovrascrive DocStructInfo.IsSpecialStructContainer.)
Proprietà pubblica | IsSpecialStructElement | (Sovrascrive DocStructInfo.IsSpecialStructElement.)
Proprietà pubblica | IsSpecialStructParent | Ritorna true se l'oggetto è un elemento padre di struttura speciale.
Proprietà pubblica | IsSubstitute | Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto. (Sovrascrive DocStructInfo.IsSubstitute.)
Proprietà pubblica | LastOperation | Restituisce l'ultima operazione presente nella lista delle operazioni di questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperationEnum | Restituisce l'ultima operazione eseguita. (Ereditato da DocStructInfo.)
Proprietà pubblica | Lod | Restituisce il livello di dettaglio ell'elemento (può essere null).
Proprietà pubblica | MakeChildrenOutOfMemory | Impone di creare i figli senza utilizzare eventuali informazioni in memoria del client (Ereditato da DocStructInfo.)
Proprietà pubblica | MoveInsteadOfCopy | Restituisce se il documento debba essere spostato invece di importato. (Ereditato da DocStructInfo.)
Proprietà pubblica | OperationList | Restituisce la lista in sola lettura, presenti per questo elemento. (Ereditato da DocStructInfo.)
Proprietà pubblica | Parent | Restituisce la collezione alla quale appartiene questo elemento. Restituisce null se si tratta della root. (Ereditato da DocStructInfo.)
Proprietà pubblica | ReferenceUpdated | Restituisce o imposta se l'aggiornamento del riferimento fisico del file sia o meno avvenuta. (Ereditato da DocStructInfo.)
Proprietà pubblica | RelocateInfo | Restituisce o imposta il percorso completo dell'elemento che deve essere ripuntato anzichè elaborato (Ereditato da DocStructInfo.)
Proprietà pubblica | SavingTypeDoc | Restituisce o imposta che tipo di relazione abbia questo elemento, in relazione al documento in salvataggio. Serve al comando di salva nel db per capire se un elemento sia stato aggiunto come file associato oppure come file referenziato oppure se si tratti proprio del documento in salvataggio. (Ereditato da DocStructInfo.)
Proprietà pubblica | SkipReferenceUpdate | Restituisce se l'ultima operazione deve evitare l'aggiornamento delle reference (Ereditato da DocStructInfo.)
Proprietà pubblica | SpecialStructType | Restituisce se si tratti di un elemento di una struttura speciale e di quale tipo.
Proprietà pubblica | Ties | Restituisce la collezione delle dipendenze. (Ereditato da DocStructInfo.)
Proprietà pubblica | ToClone | Restitusice se l'elemento sia o meno da clonare. Leggere in CloneFullName il percorso completo di destinazione. (Ereditato da DocStructInfo.)
Proprietà pubblica | UserData | Restituisce o imposta i dati utente abbinati a questo oggetto. (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInDb | Restituisce se il file risultasse già registrato nel Database in partenza. (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInLibraryPath | Restituisce o imposta se il file di partenza sia o meno in un percorso di libreria (di Inventor). (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.AssemblyInSubstituteRepresentation

Proprietà InvDocStructInfoAssemblyInSubstituteRepresentation

Restituisce se il documento sia un assieme impostato nel LOD sostituto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssemblyInSubstituteRepresentation { get; }
Public ReadOnly Property AssemblyInSubstituteRepresentation As Boolean
    Get
public:
property bool AssemblyInSubstituteRepresentation {
    bool get ();
}
member AssemblyInSubstituteRepresentation : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.CfgDescr

Proprietà InvDocStructInfoCfgDescr

Restitusice o imposta la configurazione dell'elemento. Utile per la gestione delle configurazioni/modelstate.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override ConfigDescriptor CfgDescr { get; }
Public Overrides ReadOnly Property CfgDescr As ConfigDescriptor
    Get
public:
virtual property ConfigDescriptor^ CfgDescr {
    ConfigDescriptor^ get () override;
}
abstract CfgDescr : ConfigDescriptor with get
override CfgDescr : ConfigDescriptor with get

Valore della proprietà

Tipo: ConfigDescriptor
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.Config

Proprietà InvDocStructInfoConfig

Restitusice o imposta la configurazione dell'elemento letta dal documento in tempo reale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string Config { get; }
Public Overrides ReadOnly Property Config As String
    Get
public:
virtual property String^ Config {
    String^ get () override;
}
abstract Config : string with get
override Config : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.Data

Proprietà InvDocStructInfoData

Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.FileDescriptor

Proprietà InvDocStructInfoFileDescriptor

Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileDescriptor FileDescriptor { get; }
Public ReadOnly Property FileDescriptor As FileDescriptor
    Get
public:
property FileDescriptor^ FileDescriptor {
    FileDescriptor^ get ();
}
member FileDescriptor : FileDescriptor with get

Valore della proprietà

Tipo: FileDescriptor
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.FullFileName

Proprietà InvDocStructInfoFullFileName

Restituisce il descrittore di file utilizzato per creare questo elemento (potrebbe essere null).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.HasInvDoc

Proprietà InvDocStructInfoHasInvDoc

Restituisce se ci sia un documento abbinato al file (se c'é il file c'é anche il documento).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasInvDoc { get; }
Public ReadOnly Property HasInvDoc As Boolean
    Get
public:
property bool HasInvDoc {
    bool get ();
}
member HasInvDoc : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.HasSubstitutes

Proprietà InvDocStructInfoHasSubstitutes

Override della proprietà. Se serve calcola su richiesta la presenza di sostituti al primo livello.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool HasSubstitutes { get; set; }
Public Overrides Property HasSubstitutes As Boolean
    Get
    Set
public:
virtual property bool HasSubstitutes {
    bool get () override;
    void set (bool value) override;
}
abstract HasSubstitutes : bool with get, set
override HasSubstitutes : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IncludePartFactory

Proprietà InvDocStructInfoIncludePartFactory

Determina se includere o meno le part factory nel makeChildren auto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IncludePartFactory { get; }
Public ReadOnly Property IncludePartFactory As Boolean
    Get
public:
property bool IncludePartFactory {
    bool get ();
}
member IncludePartFactory : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.InternalName

Proprietà InvDocStructInfoInternalName

Ritorna la revisione del database del documento di Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string InternalName { get; }
Public Overrides ReadOnly Property InternalName As String
    Get
public:
virtual property String^ InternalName {
    String^ get () override;
}
abstract InternalName : string with get
override InternalName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.InvDoc

Proprietà InvDocStructInfoInvDoc

Restituisce il documento abbinato a questo elemento oppure il primo documento trovato in Inventor, abbinato a questo file, oppure null se non si tratta di un documento aperto in Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; }
Public ReadOnly Property InvDoc As Document
    Get
public:
property Document^ InvDoc {
    Document^ get ();
}
member InvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsiModelMember

Proprietà InvDocStructInfoIsiModelMember

Restituisce se l'elemento sia o meno un iPart oppure un iAssembly Member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsiModelMember { get; }
Public ReadOnly Property IsiModelMember As Boolean
    Get
public:
property bool IsiModelMember {
    bool get ();
}
member IsiModelMember : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsLayoutAsset

Proprietà InvDocStructInfoIsLayoutAsset

Override della proprietà di base. Ritorna true se l'oggetto è un asset della factory.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool IsLayoutAsset { get; }
Public Overrides ReadOnly Property IsLayoutAsset As Boolean
    Get
public:
virtual property bool IsLayoutAsset {
    bool get () override;
}
abstract IsLayoutAsset : bool with get
override IsLayoutAsset : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsModel

Proprietà InvDocStructInfoIsModel

Restituisce se l'elemento faccia riferimento ad un modello (affidabile solo se il documento sotteso esiste).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsModel { get; }
Public ReadOnly Property IsModel As Boolean
    Get
public:
property bool IsModel {
    bool get ();
}
member IsModel : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsModelStateFactory

Proprietà InvDocStructInfoIsModelStateFactory

Restituisce vero se si tratta di un documento member in relazione alla gestione model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsModelStateFactory { get; }
Public ReadOnly Property IsModelStateFactory As Boolean
    Get
public:
property bool IsModelStateFactory {
    bool get ();
}
member IsModelStateFactory : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsModelStateMember

Proprietà InvDocStructInfoIsModelStateMember

Restituisce vero se si tratta di un documento member in relazione alla gestione model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsModelStateMember { get; }
Public ReadOnly Property IsModelStateMember As Boolean
    Get
public:
property bool IsModelStateMember {
    bool get ();
}
member IsModelStateMember : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsParentSubstitute

Proprietà InvDocStructInfoIsParentSubstitute

Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto del padre.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool IsParentSubstitute { get; set; }
Public Overrides Property IsParentSubstitute As Boolean
    Get
    Set
public:
virtual property bool IsParentSubstitute {
    bool get () override;
    void set (bool value) override;
}
abstract IsParentSubstitute : bool with get, set
override IsParentSubstitute : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsSaveable

Proprietà InvDocStructInfoIsSaveable

Indica se il documento è salvabile in fase di checkin

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSaveable { get; }
Public ReadOnly Property IsSaveable As Boolean
    Get
public:
property bool IsSaveable {
    bool get ();
}
member IsSaveable : bool with get

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsSpecialStructContainer

Proprietà InvDocStructInfoIsSpecialStructContainer

Override della proprietà della classe base. Definisce se l'oggetto è un contenitore di strutture speciali.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool IsSpecialStructContainer { get; }
Public Overrides ReadOnly Property IsSpecialStructContainer As Boolean
    Get
public:
virtual property bool IsSpecialStructContainer {
    bool get () override;
}
abstract IsSpecialStructContainer : bool with get
override IsSpecialStructContainer : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsSpecialStructElement

Proprietà InvDocStructInfoIsSpecialStructElement

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool IsSpecialStructElement { get; }
Public Overrides ReadOnly Property IsSpecialStructElement As Boolean
    Get
public:
virtual property bool IsSpecialStructElement {
    bool get () override;
}
abstract IsSpecialStructElement : bool with get
override IsSpecialStructElement : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsSpecialStructParent

Proprietà InvDocStructInfoIsSpecialStructParent

Ritorna true se l'oggetto è un elemento padre di struttura speciale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSpecialStructParent { get; }
Public ReadOnly Property IsSpecialStructParent As Boolean
    Get
public:
property bool IsSpecialStructParent {
    bool get ();
}
member IsSpecialStructParent : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.IsSubstitute

Proprietà InvDocStructInfoIsSubstitute

Override della proprietà di base. Se serve calcola su richiesta se l'elmento è un sostituto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool IsSubstitute { get; set; }
Public Overrides Property IsSubstitute As Boolean
    Get
    Set
public:
virtual property bool IsSubstitute {
    bool get () override;
    void set (bool value) override;
}
abstract IsSubstitute : bool with get, set
override IsSubstitute : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.Lod

Proprietà InvDocStructInfoLod

Restituisce il livello di dettaglio ell'elemento (può essere null).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LevelOfDetailRepresentation Lod { get; }
Public ReadOnly Property Lod As LevelOfDetailRepresentation
    Get
public:
property LevelOfDetailRepresentation^ Lod {
    LevelOfDetailRepresentation^ get ();
}
member Lod : LevelOfDetailRepresentation with get

Valore della proprietà

Tipo: LevelOfDetailRepresentation
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Proprietà InvDocStructInfo.SpecialStructType

Proprietà InvDocStructInfoSpecialStructType

Restituisce se si tratti di un elemento di una struttura speciale e di quale tipo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SpecialStructEnum SpecialStructType { get; }
Public ReadOnly Property SpecialStructType As SpecialStructEnum
    Get
public:
property SpecialStructEnum SpecialStructType {
    SpecialStructEnum get ();
}
member SpecialStructType : SpecialStructEnum with get

Valore della proprietà

Tipo: SpecialStructEnum
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodi di InvDocStructInfo

Il tipo InvDocStructInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | Annulla il check-out di un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInOperation | Imposta in checkin un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e si assicura che anche tutte le sue dipendenze siano copiane nella pws. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | Imposta in checkout un documento e tutte le sue dipendenze. Delegate per la notifica del documento in pws più vecchio rispetto a quello nel vault.Indica se l'operazione sia stata aggiunta come sotto-operazione di un CheckOutStruttura.Indica se ignorare il blocco legato allo stato dell'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String, Boolean) | Copia un documento da una posizione ad un'altra accettando che il file di partenza non sia presente nel Database. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Aggiunge anche un'operazione di creazione prima di sé stessa, per creare il documento di destinazione della copia. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation | Valuta le informazioni presenti nell'ultima operazione disponibile e, se il documento non è presente, lo crea con il file impostato nell'operazione. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation(String) | Crea un nuovo documento leggendo le informazioni presenti nell'ultima operazione disponibile ma utilizzando il percorso di file passato come argomento. Se il documento esiste già non fa nulla se non verificare che non si tratti di un nuovo documento (in questo caso solleva una eccezione) ed imposta l'operazione come effettuata. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedData) | Scollega il documento presente nell'ultima operazione, da un'anagrafica. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedComm) | Scollega il documento presente nell'ultima operazione, da una commessa. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da scollegare sia effettivamente collegato alla commessa. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | Copia il file dal vault all'area locale. Non effettua controlli sui permessi. Copia anche tutti i file dipendenti, necessari al documento principale. (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | Operazione di esportazione del documento (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | Operazione di esportazione del documento (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingStrutturaOperation | Operazione di esportazione del documento (struttura) (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInOperation | Forza in checkin un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | Imposta in checkin una struttura di documenti. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedComm, OperationChoiceEnum) | Copia il documentodi partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo alla commessa. Le logiche sono le stesse dell'importazione legata all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedEco, OperationChoiceEnum) | Copia il documento di partenza, proveniente da qualsiasi origine, nella posizione corrette per associarlo all'Eco. Le logiche sono le stesse dell'importazione legata alla commessa. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | Copia il documento di partenza, sia che esso sia codificato o meno, nella corretta posizione per associarlo all'anagrafica. Calcola il contesto corretto in base all'estensione del file. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di copia + link, per creare il documento di destinazione e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedComm) | Collega il documento ad una commessa (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedEco) | Collega il documento ad un Eco (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData, ConfigDescriptor, Boolean) | Collega il documento presente nell'ultima operazione, ad una anagrafica e con un particolare contesto. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che sia presente il documento da collegare e che il contesto di collegamento sia valido. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | Sposta un documento da una posizione ad un'altra utilizzando lo stesso ID documento. Il guid del documento rimane lo stesso di partenza perché si presume che si stia lavorando su disco e non in memoria (non è considerato il caso di lavorare in memoria per rinominare un file). Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che non esista il documento sul file di destinazione. Rimane da operare lo spostamento fisico da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaStrutturaOperation | Aggiunge una operazione di pubblicazione. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedComm) | Associa un file ad una commessa creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean, ConfigDescriptor, Boolean) | Associa un file ad un'anagrafica creando il documento se non esiste già, lasciando il file col nome originale. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, controlla solo che sia possibile collegare il documento con il contesto richiesto. Aggiunge anche due operazioni prima di sé stessa, di crea(se necessrio) + link, per creare il documento e collegarlo all'anagrafica. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | Operazione di rilocazione di un file esterno su un documento interno. Permette di "puntare" semplicemente il documento interno ma anche di eseguire l'overwrite fisico come nel caso del replace. (Ereditato da DocStructInfo.)
Metodo pubblico | AddRemovingOperation | Elimina il documento presente nell'ultima operazione. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che il documento da eliminare esista. (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(String) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | Copia un file sul file fisico di un altro documento sostituendolo. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante. Controlla solo che esista il documento di destinazione. Aggiunge anche un'operazione di creazione per le dipendenze, per essere sicuri di avere nel Db tutti documenti dipendenti e di aggiornamento per il documento in sostituzione. Rimane da operare la copia fisica da parte del comando chiamante oppure del client. (Ereditato da DocStructInfo.)
Metodo pubblico | AddSbloccaOperation | Sblocca un documento. (Ereditato da DocStructInfo.)
Metodo pubblico | AddUpdatingOperation | Effettua l'operazione di aggiornamento del documento nel Database leggendo l'ultima operazione disponibile ed imposta con Updating l'operazione. Verifica che il documento esista già e poi aggiorna il documento nel Database con le sue dipendenze. Non effettua controlli sui permessi, presume che l'abbia fatto il comando chiamante, non controlla nemmeno l'esistenza del file. L'operazione da effettuare successivamente, se il file non esiste già, è di crearlo nella posizione di destinazione. (Ereditato da DocStructInfo.)
Metodo pubblico | BottomUpCall | Chiama tutti gli elementi, compreso l'elemento corrente, ma per ultimo, partendo dal basso (ultimi nodi) e procedendo verso l'alto. (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor).)
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(String).)
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che le dipendenze non vengono calcolate sull'oggetto ma in base al filename passato. E' utile quando si devono calcolare le dipendenze di un file relative però ad una sua versione backuppata. Vedi caso backup della revisione con documento in checkout. (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String).)
Metodo pubblico | Equals | (Ereditato da DocStructInfo.)
Metodo pubblico | FileNameAreEquals | (Ereditato da DocStructInfo.)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo.)
Metodo pubblico | GetAllSpecialChildren | Ritorna tutti i figli dell'elemento che sono elementi della struttura speciale (Ereditato da DocStructInfo.)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfo.GetHashString.)
Metodo pubblico | GetLastQueuedOperation | Ritorna l'ultima operazione presente in lista appartenenete al tipo specificato. Se l'operazione non esiste ritorna null. (Ereditato da DocStructInfo.)
Metodo pubblico | GetOperation | Se esiste ritorna l'operazione corrispondente al tipo passato altrimenti null. (Ereditato da DocStructInfo.)
Metodo pubblico | HasOperation | Ritorna vero se nella lista delle operazioni è presente quella corrispondente al tipo passato (Ereditato da DocStructInfo.)
 | IsInventorDwg | Restituisce se si tratti di un file di Inventor.
 | IsInventorFile | Verifica se un file appartenga o meno ad Inventor.
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando i documenti aperti in Inventor oppure l'apprentice o le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database. (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAutoByDocDep | Crea la struttura utilizzando esclusivamente le dipendenze nel database. E' necessaria quando si devono indagare documenti che sono già salvati nel db come ad esempio nelle operazioni di apertura. (Ereditato da DocStructInfo.)
 | MakeFromDocDocStructInfo | Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromDocList | Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromFileListUsingApprentice | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
 | MakeFromInvDocList | Crea e restituisce una lista di struttura documento da una lista di documenti di inventor. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | Rebuild | Solo nel caso l'elemento non sia stato elaborato ed abbia nella lista la sola DocStructOperationBase, la ricrea con il file name già presente. Viene usata per ricreare il documento se questo è cambiato pur non cambiando il suo percorso file. (Ereditato da DocStructInfo.)
Metodo pubblico | SetNotToClone | Imposta questo elemento come Non da Clonare (ToClone = false e CloneFullName = null). (Ereditato da DocStructInfo.)
Metodo pubblico | SetToClone | Imposta questo elemento come da Clonare (ToClone = true) e CloneFullName = destFullName). (Ereditato da DocStructInfo.)
Metodo pubblico | ToString | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean).)
Metodo pubblico | UpdateDocumentData | Aggiorna tutti il documento dell'oggetto e di tutti i figli (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateParentReferences | Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Verifica solo che, se è attiva l'area locale, tutti i padri siano in checkin. (Sovrascrive DocStructInfo.UpdateParentReferences.)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo

Metodo InvDocStructInfoCreateDocStructInfo

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor).)
Metodo pubblico | CreateDocStructInfo(String) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(String).)
Metodo pubblico | CreateDocStructInfo(String, ConfigDescriptor) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
 | CreateDocStructInfo(DedNetApplication, String) | Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo (DocStructInfoFileDescriptor)

Metodo InvDocStructInfoCreateDocStructInfo (DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor -> DocStructInfo

Parametri

fileDescr
Tipo: DocStructInfoFileDescriptor
File del quale ricavere le informazioni

Valore di ritorno

Tipo: DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo (String)

Metodo InvDocStructInfoCreateDocStructInfo (String)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    string fileName
)
Public Overrides Function CreateDocStructInfo (
    fileName As String
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    String^ fileName
) override
abstract CreateDocStructInfo :
        fileName : string -> DocStructInfo
override CreateDocStructInfo :
        fileName : string -> DocStructInfo

Parametri

fileName
Tipo: SystemString
File del quale ricavere le informazioni

Valore di ritorno

Tipo: DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo (DocStructInfoFileDescriptor, DocStructInfo)

Metodo InvDocStructInfoCreateDocStructInfo (DocStructInfoFileDescriptor, DocStructInfo)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr,
    DocStructInfo parent
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor,
    parent As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr,
    DocStructInfo^ parent
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo

Parametri

fileDescr
Tipo: DocStructInfoFileDescriptor
Descrittore file del quale ricavere le informazioni
parent
Tipo: DocStructInfo
Padre dell'elemento.

Valore di ritorno

Tipo: DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo (DedNetApplication, DocStructInfoFileDescriptor)

Metodo InvDocStructInfoCreateDocStructInfo (DedNetApplication, DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InvDocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    DocStructInfoFileDescriptor fileDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileDescr As DocStructInfoFileDescriptor
) As InvDocStructInfo
public:
static InvDocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoFileDescriptor^ fileDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileDescr : DocStructInfoFileDescriptor -> InvDocStructInfo

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileDescr
Tipo: DocStructInfoFileDescriptor
File del quale ricavere le informazioni.

Valore di ritorno

Tipo: InvDocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.CreateDocStructInfo (DedNetApplication, String)

Metodo InvDocStructInfoCreateDocStructInfo (DedNetApplication, String)
Crea e restituisce un nuovo oggetto InvDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti. Viene passato anche il fileName perché il documento potrebbe essere nuovo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    string fileName
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileName As String
) As DocStructInfo
public:
static DocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    String^ fileName
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileName : string -> DocStructInfo

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileName
Tipo: SystemString
File del quale ricavere le informazioni.

Valore di ritorno

Tipo: DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di CreateDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.EnforcedMakeChildrenAuto

Metodo InvDocStructInfoEnforcedMakeChildrenAuto

La logica è la stessa del MakeChildrenAuto solo che le dipendenze non vengono calcolate sull'oggetto ma in base al filename passato. E' utile quando si devono calcolare le dipendenze di un file relative però ad una sua versione backuppata. Vedi caso backup della revisione con documento in checkout.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void EnforcedMakeChildrenAuto(
    string enforcedTiesSourceFileName
)
Public Overrides Sub EnforcedMakeChildrenAuto (
    enforcedTiesSourceFileName As String
)
public:
virtual void EnforcedMakeChildrenAuto(
    String^ enforcedTiesSourceFileName
) override
abstract EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit
override EnforcedMakeChildrenAuto :
        enforcedTiesSourceFileName : string -> unit

Parametri

enforcedTiesSourceFileName
Tipo: SystemString
File name sul quale calcolare le dipendenze
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.GetHashString

Metodo InvDocStructInfoGetHashString

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetHashString()
Public Overrides Function GetHashString As String
public:
virtual String^ GetHashString() override
abstract GetHashString : unit -> string
override GetHashString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.IsInventorDwg

Metodo InvDocStructInfoIsInventorDwg

Restituisce se si tratti di un file di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsInventorDwg(
    string fileName
)
Public Shared Function IsInventorDwg (
    fileName As String
) As Boolean
public:
static bool IsInventorDwg(
    String^ fileName
)
static member IsInventorDwg :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da analizzare.

Valore di ritorno

Tipo: Boolean
Restitusice true se si tratta di un file di Inventor.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.IsInventorFile

Metodo InvDocStructInfoIsInventorFile

Verifica se un file appartenga o meno ad Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsInventorFile(
    string fileName
)
Public Shared Function IsInventorFile (
    fileName As String
) As Boolean
public:
static bool IsInventorFile(
    String^ fileName
)
static member IsInventorFile :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Restituisce true se si tratta di un file di Inventor altrimenti false.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeChildrenAuto

Metodo InvDocStructInfoMakeChildrenAuto

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando i documenti aperti in Inventor oppure l'apprentice o le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | Metodo virtuale per la creazione della struttura ovverridato da client. Se il client non specifica il metodo utilizza comunque le dipendenze salvate nel database. (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeChildrenAuto

Metodo InvDocStructInfoMakeChildrenAuto

Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando i documenti aperti in Inventor oppure l'apprentice o le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void MakeChildrenAuto()
Public Overrides Sub MakeChildrenAuto
public:
virtual void MakeChildrenAuto() override
abstract MakeChildrenAuto : unit -> unit
override MakeChildrenAuto : unit -> unit
Vedi anche

Documentazione

Classe InvDocStructInfo
Overload di MakeChildrenAuto
Namespace DedNetInv


Metodo InvDocStructInfo.MakeFromDocDocStructInfo

Metodo InvDocStructInfoMakeFromDocDocStructInfo

Crea e restituisce una lista di struttura documento clonata da una esistente. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocDocStructInfo(
    DedNetApplication app,
    DocStructInfoList docList
)
Public Shared Function MakeFromDocDocStructInfo (
    app As DedNetApplication,
    docList As DocStructInfoList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoList^ docList
)
static member MakeFromDocDocStructInfo :
        app : DedNetApplication *
        docList : DocStructInfoList -> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
docList
Tipo: DocStructInfoList
Lista di documenti da elaborare.

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeFromDocList

Metodo InvDocStructInfoMakeFromDocList

Crea e restituisce una lista di struttura documento data una lista di documenti, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromDocList(
    DedNetApplication app,
    DedDocList docList
)
Public Shared Function MakeFromDocList (
    app As DedNetApplication,
    docList As DedDocList
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromDocList(
    DedNetApplication^ app,
    DedDocList^ docList
)
static member MakeFromDocList :
        app : DedNetApplication *
        docList : DedDocList -> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
docList
Tipo: DedDocList
Lista di documenti da elaborare.

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeFromFileList

Metodo InvDocStructInfoMakeFromFileList

Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList,
    bool _makeChildrenOutOfMemory = false
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String(),
    Optional _makeChildrenOutOfMemory As Boolean = false
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList,
    bool _makeChildrenOutOfMemory = false
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] *
        ?_makeChildrenOutOfMemory : bool
(* Defaults:
        let __makeChildrenOutOfMemory = defaultArg _makeChildrenOutOfMemory false
*)
-> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileList
Tipo: SystemString
Lista di file da elaborare.
_makeChildrenOutOfMemory (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeFromFileListUsingApprentice

Metodo InvDocStructInfoMakeFromFileListUsingApprentice

Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileListUsingApprentice(
    DedNetApplication app,
    string[] fileList
)
Public Shared Function MakeFromFileListUsingApprentice (
    app As DedNetApplication,
    fileList As String()
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileListUsingApprentice(
    DedNetApplication^ app,
    array<String^>^ fileList
)
static member MakeFromFileListUsingApprentice :
        app : DedNetApplication *
        fileList : string[] -> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileList
Tipo: SystemString
Lista di file da elaborare.

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.MakeFromInvDocList

Metodo InvDocStructInfoMakeFromInvDocList

Crea e restituisce una lista di struttura documento da una lista di documenti di inventor. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromInvDocList(
    DedNetApplication app,
    IEnumerable<Document> invDocs
)
Public Shared Function MakeFromInvDocList (
    app As DedNetApplication,
    invDocs As IEnumerable(Of Document)
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromInvDocList(
    DedNetApplication^ app,
    IEnumerable<Document^>^ invDocs
)
static member MakeFromInvDocList :
        app : DedNetApplication *
        invDocs : IEnumerable<Document> -> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
invDocs
Tipo: System.Collections.GenericIEnumerable Document
Lista di documenti di Inventor da elaborare.

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.UpdateData

Metodo InvDocStructInfoUpdateData

Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateData(
    bool updateRowVer = true
)
Public Overrides Sub UpdateData (
    Optional updateRowVer As Boolean = true
)
public:
virtual void UpdateData(
    bool updateRowVer = true
) override
abstract UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit
override UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit

Parametri

updateRowVer (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.UpdateParentReferences

Metodo InvDocStructInfoUpdateParentReferences

Aggiorna i riferimenti fisici dei file genitori, di primo livello, per questo elemento. Verifica solo che, se è attiva l'area locale, tutti i padri siano in checkin.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateParentReferences()
Public Overrides Sub UpdateParentReferences
public:
virtual void UpdateParentReferences() override
abstract UpdateParentReferences : unit -> unit
override UpdateParentReferences : unit -> unit
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Metodo InvDocStructInfo.UpdateReferences

Metodo InvDocStructInfoUpdateReferences

Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateReferences()
Public Overrides Sub UpdateReferences
public:
virtual void UpdateReferences() override
abstract UpdateReferences : unit -> unit
override UpdateReferences : unit -> unit
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Campi di InvDocStructInfo

Il tipo InvDocStructInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Elements | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo.)
Campo protetto | Operations | Elementi già presenti nella struttura, utilizzata per evitare duplicati a parità di file. (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfo
Namespace DedNetInv


Classe InvDocStructInfoEventHandlers
Classe gestione eventi client del DoscStructInfo
Gerarchia di ereditarietà
SystemObject
DedNetInvInvDocStructInfoEventHandlers

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvDocStructInfoEventHandlers
Public Class InvDocStructInfoEventHandlers
public ref class InvDocStructInfoEventHandlers
type InvDocStructInfoEventHandlers =  class end

Il tipo InvDocStructInfoEventHandlers espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InvDocStructInfoEventHandlers |
Torna su
Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore InvDocStructInfoEventHandlers

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfoEventHandlers()
Public Sub New
public:
InvDocStructInfoEventHandlers()
new : unit -> InvDocStructInfoEventHandlers
Vedi anche

Documentazione

Classe InvDocStructInfoEventHandlers
Namespace DedNetInv


Metodi di InvDocStructInfoEventHandlers

Il tipo InvDocStructInfoEventHandlers espone i seguenti membri.

Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfoEventHandlers
Namespace DedNetInv


Metodo InvDocStructInfoEventHandlers.InitializeDocStructInfoEvents

Metodo InvDocStructInfoEventHandlersInitializeDocStructInfoEvents

Metodo che inizializza gli eventi

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void InitializeDocStructInfoEvents()
Public Shared Sub InitializeDocStructInfoEvents
public:
static void InitializeDocStructInfoEvents()
static member InitializeDocStructInfoEvents : unit -> unit
Vedi anche

Documentazione

Classe InvDocStructInfoEventHandlers
Namespace DedNetInv


Metodo InvDocStructInfoEventHandlers.OnDocStructInfoCreated

Metodo InvDocStructInfoEventHandlersOnDocStructInfoCreated

Evento chiamato al termine della creazione di un nuovo struct info

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDocStructInfoCreated(
    Object sender,
    ResolveDocStructInfoEventArgs args
)
Public Shared Sub OnDocStructInfoCreated (
    sender As Object,
    args As ResolveDocStructInfoEventArgs
)
public:
static void OnDocStructInfoCreated(
    Object^ sender,
    ResolveDocStructInfoEventArgs^ args
)
static member OnDocStructInfoCreated :
        sender : Object *
        args : ResolveDocStructInfoEventArgs -> unit

Parametri

sender
Tipo: SystemObject
args
Tipo: ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe InvDocStructInfoEventHandlers
Namespace DedNetInv


Classe InvDocStructInfoExtensions
Extension methods associati ad InvDocStructInfo
Gerarchia di ereditarietà
SystemObject
DedNetInvInvDocStructInfoExtensions

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class InvDocStructInfoExtensions
<ExtensionAttribute>
Public NotInheritable Class InvDocStructInfoExtensions
[ExtensionAttribute]
public ref class InvDocStructInfoExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type InvDocStructInfoExtensions =  class end

Il tipo InvDocStructInfoExtensions espone i seguenti membri.

Metodi
Nome | Descrizione
ContainsFactory | Ritorna vero se la collezione contiene già la factory relativa al member passato o viceversa. Il metodo ha senso solo per documenti padre non modello, quindi tavole e presentazioni
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Metodi di InvDocStructInfoExtensions

Il tipo InvDocStructInfoExtensions espone i seguenti membri.

Metodi
Nome | Descrizione
ContainsFactory | Ritorna vero se la collezione contiene già la factory relativa al member passato o viceversa. Il metodo ha senso solo per documenti padre non modello, quindi tavole e presentazioni
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfoExtensions
Namespace DedNetInv


Metodo InvDocStructInfoExtensions.ContainsFactory

Metodo InvDocStructInfoExtensionsContainsFactory

Ritorna vero se la collezione contiene già la factory relativa al member passato o viceversa. Il metodo ha senso solo per documenti padre non modello, quindi tavole e presentazioni

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ContainsFactory(
    this DocStructInfoCollection dsc,
    Document parentDocument,
    InvDocStructInfoFileDescriptor invFileDescr
)
<ExtensionAttribute>
Public Shared Function ContainsFactory (
    dsc As DocStructInfoCollection,
    parentDocument As Document,
    invFileDescr As InvDocStructInfoFileDescriptor
) As Boolean
public:
[ExtensionAttribute]
static bool ContainsFactory(
    DocStructInfoCollection^ dsc,
    Document^ parentDocument,
    InvDocStructInfoFileDescriptor^ invFileDescr
)
[<ExtensionAttribute>]
static member ContainsFactory :
        dsc : DocStructInfoCollection *
        parentDocument : Document *
        invFileDescr : InvDocStructInfoFileDescriptor -> bool

Parametri

dsc
Tipo: DocStructInfoCollection
parentDocument
Tipo: Document
invFileDescr
Tipo: DedNetInvInvDocStructInfoFileDescriptor

Valore di ritorno

Tipo: Boolean

Nota d'uso

In Visual Basic e C# puoi chiamare questo metodo come metodo di istanza su qualunque oggetto di tipo DocStructInfoCollection. Quando usi la sintassi del metodo di istanza, devi omettere il primo parametro. Per maggiori informazioni, vedi Metodi di estensione (Visual Basic) o Metodi di estensione (C# Programming Guide).
Vedi anche

Documentazione

Classe InvDocStructInfoExtensions
Namespace DedNetInv


Classe InvDocStructInfoFileDescriptor
Gerarchia di ereditarietà
SystemObject
DocStructInfoFileDescriptor
DedNetInvInvDocStructInfoFileDescriptor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvDocStructInfoFileDescriptor : DocStructInfoFileDescriptor
Public Class InvDocStructInfoFileDescriptor
    Inherits DocStructInfoFileDescriptor
public ref class InvDocStructInfoFileDescriptor : public DocStructInfoFileDescriptor
type InvDocStructInfoFileDescriptor =
    class
        inherit DocStructInfoFileDescriptor
    end

Il tipo InvDocStructInfoFileDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InvDocStructInfoFileDescriptor(Document, String, Boolean) |
Metodo pubblico | InvDocStructInfoFileDescriptor(Document, String, Boolean, ConfigDescriptor) |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | InvDoc |
Proprietà pubblica | IsSubstitute |
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato (Ereditato da DocStructInfoFileDescriptor.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfoFileDescriptor.GetHashString.)
Metodo pubblico | GetSimpleHashString | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | ToString | (Ereditato da DocStructInfoFileDescriptor.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore InvDocStructInfoFileDescriptor

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | InvDocStructInfoFileDescriptor(Document, String, Boolean) |
Metodo pubblico | InvDocStructInfoFileDescriptor(Document, String, Boolean, ConfigDescriptor) |
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Costruttore InvDocStructInfoFileDescriptor (Document, String, Boolean)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfoFileDescriptor(
    Document invDoc,
    string fileName,
    bool isSubstitute
)
Public Sub New (
    invDoc As Document,
    fileName As String,
    isSubstitute As Boolean
)
public:
InvDocStructInfoFileDescriptor(
    Document^ invDoc,
    String^ fileName,
    bool isSubstitute
)
new :
        invDoc : Document *
        fileName : string *
        isSubstitute : bool -> InvDocStructInfoFileDescriptor

Parametri

invDoc
Tipo: Document
fileName
Tipo: SystemString
isSubstitute
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Overload di InvDocStructInfoFileDescriptor
Namespace DedNetInv


Costruttore InvDocStructInfoFileDescriptor (Document, String, Boolean, ConfigDescriptor)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfoFileDescriptor(
    Document invDoc,
    string fileName,
    bool isSubstitute,
    ConfigDescriptor cfgDescr
)
Public Sub New (
    invDoc As Document,
    fileName As String,
    isSubstitute As Boolean,
    cfgDescr As ConfigDescriptor
)
public:
InvDocStructInfoFileDescriptor(
    Document^ invDoc,
    String^ fileName,
    bool isSubstitute,
    ConfigDescriptor^ cfgDescr
)
new :
        invDoc : Document *
        fileName : string *
        isSubstitute : bool *
        cfgDescr : ConfigDescriptor -> InvDocStructInfoFileDescriptor

Parametri

invDoc
Tipo: Document
fileName
Tipo: SystemString
isSubstitute
Tipo: SystemBoolean
cfgDescr
Tipo: ConfigDescriptor
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Overload di InvDocStructInfoFileDescriptor
Namespace DedNetInv


Proprietà di InvDocStructInfoFileDescriptor

Il tipo InvDocStructInfoFileDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CfgDecr | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | Config | Restituisce il nome della configurazione sottesa a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | FileName | Restituisce il file name sotteso a questo elemento. (Ereditato da DocStructInfoFileDescriptor.)
Proprietà pubblica | InvDoc |
Proprietà pubblica | IsSubstitute |
Proprietà pubblica | VaultPath | Restituisce il path di vault dato il descrittore creato (Ereditato da DocStructInfoFileDescriptor.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Proprietà InvDocStructInfoFileDescriptor.InvDoc

Proprietà InvDocStructInfoFileDescriptorInvDoc

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; }
Public ReadOnly Property InvDoc As Document
    Get
public:
property Document^ InvDoc {
    Document^ get ();
}
member InvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Proprietà InvDocStructInfoFileDescriptor.IsSubstitute

Proprietà InvDocStructInfoFileDescriptorIsSubstitute

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSubstitute { get; }
Public ReadOnly Property IsSubstitute As Boolean
    Get
public:
property bool IsSubstitute {
    bool get ();
}
member IsSubstitute : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Metodi di InvDocStructInfoFileDescriptor

Il tipo InvDocStructInfoFileDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetFileNameHashString | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | GetHashString | (Sovrascrive DocStructInfoFileDescriptor.GetHashString.)
Metodo pubblico | GetSimpleHashString | (Ereditato da DocStructInfoFileDescriptor.)
Metodo pubblico | ToString | (Ereditato da DocStructInfoFileDescriptor.)
Torna su
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Metodo InvDocStructInfoFileDescriptor.GetHashString

Metodo InvDocStructInfoFileDescriptorGetHashString

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetHashString()
Public Overrides Function GetHashString As String
public:
virtual String^ GetHashString() override
abstract GetHashString : unit -> string
override GetHashString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe InvDocStructInfoFileDescriptor
Namespace DedNetInv


Classe Lua
Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Gerarchia di ereditarietà
SystemObject
DedNetInvLua

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Lua =  class end

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
SilentUpdateDedDisOnSave | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnSave per non visualizzare messaggi all'utente durante il salvataggio.
Torna su
Metodi
Nome | Descrizione
CloseBomEnforcedOpenedDocs | Chiama l'omonima funzione per chiudere i documenti aperti in modo forzato da GetBomData.
DedInvFileResolution | Chiama l'evento OnFileResolution utilizzando la funzione LuaStartEvent. La funzione lua che gestisce l'evento può modificare gli argomenti che qui sono passati byref: fullFileName ed HandlingCode.
DedInvGetDistSaveStruct | Carica la struttura della distinta in salvataggio
DedInvGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DedInvOnCloseDocument | Chiama la funzione omonima passandogli tutti i parametri.
DedInvOnOpenDocument | Chiama la funzione omonima passandogli tutti i parametri.
DedNetBuildContextMenuStruct | Chiama l'omonima funzione lua.
DedNetBuildMenuStruct | Chiama l'omonima funzione lua.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Proprietà di Lua

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
SilentUpdateDedDisOnSave | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnSave per non visualizzare messaggi all'utente durante il salvataggio.
Torna su
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Proprietà Lua.SilentUpdateDedDisOnOpen

Proprietà LuaSilentUpdateDedDisOnOpen

Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SilentUpdateDedDisOnOpen { get; }
Public Shared ReadOnly Property SilentUpdateDedDisOnOpen As Boolean
    Get
public:
static property bool SilentUpdateDedDisOnOpen {
    bool get ();
}
static member SilentUpdateDedDisOnOpen : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Proprietà Lua.SilentUpdateDedDisOnSave

Proprietà LuaSilentUpdateDedDisOnSave

Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnSave per non visualizzare messaggi all'utente durante il salvataggio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SilentUpdateDedDisOnSave { get; }
Public Shared ReadOnly Property SilentUpdateDedDisOnSave As Boolean
    Get
public:
static property bool SilentUpdateDedDisOnSave {
    bool get ();
}
static member SilentUpdateDedDisOnSave : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodi di Lua

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CloseBomEnforcedOpenedDocs | Chiama l'omonima funzione per chiudere i documenti aperti in modo forzato da GetBomData.
DedInvFileResolution | Chiama l'evento OnFileResolution utilizzando la funzione LuaStartEvent. La funzione lua che gestisce l'evento può modificare gli argomenti che qui sono passati byref: fullFileName ed HandlingCode.
DedInvGetDistSaveStruct | Carica la struttura della distinta in salvataggio
DedInvGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DedInvOnCloseDocument | Chiama la funzione omonima passandogli tutti i parametri.
DedInvOnOpenDocument | Chiama la funzione omonima passandogli tutti i parametri.
DedNetBuildContextMenuStruct | Chiama l'omonima funzione lua.
DedNetBuildMenuStruct | Chiama l'omonima funzione lua.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
Torna su
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.CloseBomEnforcedOpenedDocs

Metodo LuaCloseBomEnforcedOpenedDocs

Chiama l'omonima funzione per chiudere i documenti aperti in modo forzato da GetBomData.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CloseBomEnforcedOpenedDocs()
Public Shared Sub CloseBomEnforcedOpenedDocs
public:
static void CloseBomEnforcedOpenedDocs()
static member CloseBomEnforcedOpenedDocs : unit -> unit
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedInvFileResolution

Metodo LuaDedInvFileResolution

Chiama l'evento OnFileResolution utilizzando la funzione LuaStartEvent. La funzione lua che gestisce l'evento può modificare gli argomenti che qui sono passati byref: fullFileName ed HandlingCode.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedInvFileResolution(
    string RelativeFileName,
    string LibraryName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap Context,
    DedEventTimeFileResolutionEnum EventTimingDed,
    ref string fullFileName,
    ref HandlingCodeEnum HandlingCode
)
Public Shared Sub DedInvFileResolution (
    RelativeFileName As String,
    LibraryName As String,
    BeforeOrAfter As EventTimingEnum,
    Context As NameValueMap,
    EventTimingDed As DedEventTimeFileResolutionEnum,
    ByRef fullFileName As String,
    ByRef HandlingCode As HandlingCodeEnum
)
public:
static void DedInvFileResolution(
    String^ RelativeFileName,
    String^ LibraryName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap^ Context,
    DedEventTimeFileResolutionEnum EventTimingDed,
    String^% fullFileName,
    HandlingCodeEnum% HandlingCode
)
static member DedInvFileResolution :
        RelativeFileName : string *
        LibraryName : string *
        BeforeOrAfter : EventTimingEnum *
        Context : NameValueMap *
        EventTimingDed : DedEventTimeFileResolutionEnum *
        fullFileName : string byref *
        HandlingCode : HandlingCodeEnum byref -> unit

Parametri

RelativeFileName
Tipo: SystemString
LibraryName
Tipo: SystemString
BeforeOrAfter
Tipo: EventTimingEnum
Context
Tipo: NameValueMap
EventTimingDed
Tipo: DedEventTimeFileResolutionEnum
fullFileName
Tipo: SystemString
HandlingCode
Tipo: HandlingCodeEnum
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedInvGetDistSaveStruct

Metodo LuaDedInvGetDistSaveStruct

Carica la struttura della distinta in salvataggio

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedInvGetDistSaveStruct(
    LuaTable args
)
Public Shared Function DedInvGetDistSaveStruct (
    args As LuaTable
) As LuaTable
public:
static LuaTable^ DedInvGetDistSaveStruct(
    LuaTable^ args
)
static member DedInvGetDistSaveStruct :
        args : LuaTable -> LuaTable

Parametri

args
Tipo: LuaTable

Valore di ritorno

Tipo: LuaTable
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedInvGetLolForDistSave

Metodo LuaDedInvGetLolForDistSave

Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedInvGetLolForDistSave(
    LuaTable arg
)
Public Shared Function DedInvGetLolForDistSave (
    arg As LuaTable
) As LuaTable
public:
static LuaTable^ DedInvGetLolForDistSave(
    LuaTable^ arg
)
static member DedInvGetLolForDistSave :
        arg : LuaTable -> LuaTable

Parametri

arg
Tipo: LuaTable

Valore di ritorno

Tipo: LuaTable
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedInvOnCloseDocument

Metodo LuaDedInvOnCloseDocument

Chiama la funzione omonima passandogli tutti i parametri.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedInvOnCloseDocument(
    _Document DocumentObject,
    string FullDocumentName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap Context,
    out HandlingCodeEnum HandlingCode
)
Public Shared Sub DedInvOnCloseDocument (
    DocumentObject As _Document,
    FullDocumentName As String,
    BeforeOrAfter As EventTimingEnum,
    Context As NameValueMap,
    <OutAttribute> ByRef HandlingCode As HandlingCodeEnum
)
public:
static void DedInvOnCloseDocument(
    _Document^ DocumentObject,
    String^ FullDocumentName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap^ Context,
    [OutAttribute] HandlingCodeEnum% HandlingCode
)
static member DedInvOnCloseDocument :
        DocumentObject : _Document *
        FullDocumentName : string *
        BeforeOrAfter : EventTimingEnum *
        Context : NameValueMap *
        HandlingCode : HandlingCodeEnum byref -> unit

Parametri

DocumentObject
Tipo: _Document
FullDocumentName
Tipo: SystemString
BeforeOrAfter
Tipo: EventTimingEnum
Context
Tipo: NameValueMap
HandlingCode
Tipo: HandlingCodeEnum
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedInvOnOpenDocument

Metodo LuaDedInvOnOpenDocument

Chiama la funzione omonima passandogli tutti i parametri.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedInvOnOpenDocument(
    _Document DocumentObject,
    string FullDocumentName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap Context,
    out HandlingCodeEnum HandlingCode
)
Public Shared Sub DedInvOnOpenDocument (
    DocumentObject As _Document,
    FullDocumentName As String,
    BeforeOrAfter As EventTimingEnum,
    Context As NameValueMap,
    <OutAttribute> ByRef HandlingCode As HandlingCodeEnum
)
public:
static void DedInvOnOpenDocument(
    _Document^ DocumentObject,
    String^ FullDocumentName,
    EventTimingEnum BeforeOrAfter,
    NameValueMap^ Context,
    [OutAttribute] HandlingCodeEnum% HandlingCode
)
static member DedInvOnOpenDocument :
        DocumentObject : _Document *
        FullDocumentName : string *
        BeforeOrAfter : EventTimingEnum *
        Context : NameValueMap *
        HandlingCode : HandlingCodeEnum byref -> unit

Parametri

DocumentObject
Tipo: _Document
FullDocumentName
Tipo: SystemString
BeforeOrAfter
Tipo: EventTimingEnum
Context
Tipo: NameValueMap
HandlingCode
Tipo: HandlingCodeEnum
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedNetBuildContextMenuStruct

Metodo LuaDedNetBuildContextMenuStruct

Chiama l'omonima funzione lua.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedNetBuildContextMenuStruct(
    CommandBar commandBar,
    InvCurSelInfo selInfo
)
Public Shared Sub DedNetBuildContextMenuStruct (
    commandBar As CommandBar,
    selInfo As InvCurSelInfo
)
public:
static void DedNetBuildContextMenuStruct(
    CommandBar^ commandBar,
    InvCurSelInfo^ selInfo
)
static member DedNetBuildContextMenuStruct :
        commandBar : CommandBar *
        selInfo : InvCurSelInfo -> unit

Parametri

commandBar
Tipo: CommandBar
selInfo
Tipo: DedNetInvInvCurSelInfo
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.DedNetBuildMenuStruct

Metodo LuaDedNetBuildMenuStruct

Chiama l'omonima funzione lua.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedNetBuildMenuStruct(
    Ribbons ribbons,
    string addInClassID
)
Public Shared Sub DedNetBuildMenuStruct (
    ribbons As Ribbons,
    addInClassID As String
)
public:
static void DedNetBuildMenuStruct(
    Ribbons^ ribbons,
    String^ addInClassID
)
static member DedNetBuildMenuStruct :
        ribbons : Ribbons *
        addInClassID : string -> unit

Parametri

ribbons
Tipo: Ribbons
addInClassID
Tipo: SystemString
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Metodo Lua.TopEditAttrPost

Metodo LuaTopEditAttrPost

Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void TopEditAttrPost(
    Object prt
)
Public Shared Sub TopEditAttrPost (
    prt As Object
)
public:
static void TopEditAttrPost(
    Object^ prt
)
static member TopEditAttrPost :
        prt : Object -> unit

Parametri

prt
Tipo: SystemObject
Parte da passare all'evento.
Vedi anche

Documentazione

Classe Lua
Namespace DedNetInv


Classe ModifyingDocumentInfo
Contiene le informazioni su di un documento che è in fase di modifica da parte dell'utente. Una lista di questi oggetti, raccolta nell'evento OnFileDirty, è utile per capire se impedire o meno l'operazione di modifica e per comunicarlo all'utente tramite finestra di dialogo.
Gerarchia di ereditarietà
SystemObject
DedNetInvModifyingDocumentInfo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentInfo
Public Class ModifyingDocumentInfo
public ref class ModifyingDocumentInfo
type ModifyingDocumentInfo =  class end

Il tipo ModifyingDocumentInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfo(String) | Inizializza l'oggetto cone le informazioni necessarie.
Metodo pubblico | ModifyingDocumentInfo(String, String) | Inizializza l'oggetto cone le informazioni necessarie.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask | Se l'utente può modificare l'elemento (UserCanModify = true) questa proprietà indica di visualizzare però l'informazione all'utente per una conferma.
Proprietà pubblica | CurrentStateDescription | Restituisce la descrizione di questo elemento, relativamente al suo stato.
Proprietà pubblica | Datas | Restituisce la lista delle anagrafiche alle quali il documento è collegato come file primario. Può restituire null se il file non è registrato nel Database.
Proprietà pubblica | DedDoc | Restituisce il DedDoc abbinato al file oppure null se il file non è registrato nel Database.
Proprietà pubblica | FullDocumentName | Restituisce il percorso completo dell'elemento.
Proprietà pubblica | FullFileName | Restituisce il percorso completo dell'elemento.
Proprietà pubblica | HasDatas | Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento) e sia anche associato ad una o più anagrafiche come file primario.
Proprietà pubblica | HasDocument | Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento).
Proprietà pubblica | HasToBeCheckedOut | Controlla se l'elemento sia da mettere in check-out dall'utente, perché attualmente in check-in.
Proprietà pubblica | HasToBeUpdated | Il documento necessita di essere aggiornato. Non è pobbile apportare quindi modifiche.
Proprietà pubblica | IsCheckedIn | Restituisce se l'elemento sia attualmente in check-in.
Proprietà pubblica | IsCheckOutAble | Restituisce se l'elemento sia attualmente in check-in.
Proprietà pubblica | NeedReload | Restituisce se l'elemento necessita di essere ricaricato
Proprietà pubblica | UserCanModify | Restituisce se l'utente può, come risultato di tutte le considerazioni, modificare questo elemento.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore ModifyingDocumentInfo

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfo(String) | Inizializza l'oggetto cone le informazioni necessarie.
Metodo pubblico | ModifyingDocumentInfo(String, String) | Inizializza l'oggetto cone le informazioni necessarie.
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Costruttore ModifyingDocumentInfo (String)
Inizializza l'oggetto cone le informazioni necessarie.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfo(
    string fullfileName
)
Public Sub New (
    fullfileName As String
)
public:
ModifyingDocumentInfo(
    String^ fullfileName
)
new :
        fullfileName : string -> ModifyingDocumentInfo

Parametri

fullfileName
Tipo: SystemString
Percorso completo del file da utilizzare per l'inizializzazione.
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Overload di ModifyingDocumentInfo
Namespace DedNetInv


Costruttore ModifyingDocumentInfo (String, String)
Inizializza l'oggetto cone le informazioni necessarie.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfo(
    string fullfileName,
    string state
)
Public Sub New (
    fullfileName As String,
    state As String
)
public:
ModifyingDocumentInfo(
    String^ fullfileName,
    String^ state
)
new :
        fullfileName : string *
        state : string -> ModifyingDocumentInfo

Parametri

fullfileName
Tipo: SystemString
Percorso completo del file da utilizzare per l'inizializzazione.
state
Tipo: SystemString
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Overload di ModifyingDocumentInfo
Namespace DedNetInv


Proprietà di ModifyingDocumentInfo

Il tipo ModifyingDocumentInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask | Se l'utente può modificare l'elemento (UserCanModify = true) questa proprietà indica di visualizzare però l'informazione all'utente per una conferma.
Proprietà pubblica | CurrentStateDescription | Restituisce la descrizione di questo elemento, relativamente al suo stato.
Proprietà pubblica | Datas | Restituisce la lista delle anagrafiche alle quali il documento è collegato come file primario. Può restituire null se il file non è registrato nel Database.
Proprietà pubblica | DedDoc | Restituisce il DedDoc abbinato al file oppure null se il file non è registrato nel Database.
Proprietà pubblica | FullDocumentName | Restituisce il percorso completo dell'elemento.
Proprietà pubblica | FullFileName | Restituisce il percorso completo dell'elemento.
Proprietà pubblica | HasDatas | Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento) e sia anche associato ad una o più anagrafiche come file primario.
Proprietà pubblica | HasDocument | Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento).
Proprietà pubblica | HasToBeCheckedOut | Controlla se l'elemento sia da mettere in check-out dall'utente, perché attualmente in check-in.
Proprietà pubblica | HasToBeUpdated | Il documento necessita di essere aggiornato. Non è pobbile apportare quindi modifiche.
Proprietà pubblica | IsCheckedIn | Restituisce se l'elemento sia attualmente in check-in.
Proprietà pubblica | IsCheckOutAble | Restituisce se l'elemento sia attualmente in check-in.
Proprietà pubblica | NeedReload | Restituisce se l'elemento necessita di essere ricaricato
Proprietà pubblica | UserCanModify | Restituisce se l'utente può, come risultato di tutte le considerazioni, modificare questo elemento.
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.Ask

Proprietà ModifyingDocumentInfoAsk

Se l'utente può modificare l'elemento (UserCanModify = true) questa proprietà indica di visualizzare però l'informazione all'utente per una conferma.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; }
Public ReadOnly Property Ask As Boolean
    Get
public:
property bool Ask {
    bool get ();
}
member Ask : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.CurrentStateDescription

Proprietà ModifyingDocumentInfoCurrentStateDescription

Restituisce la descrizione di questo elemento, relativamente al suo stato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string CurrentStateDescription { get; set; }
Public Property CurrentStateDescription As String
    Get
    Set
public:
property String^ CurrentStateDescription {
    String^ get ();
    void set (String^ value);
}
member CurrentStateDescription : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.Datas

Proprietà ModifyingDocumentInfoDatas

Restituisce la lista delle anagrafiche alle quali il documento è collegato come file primario. Può restituire null se il file non è registrato nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataList Datas { get; }
Public ReadOnly Property Datas As DedDataList
    Get
public:
property DedDataList^ Datas {
    DedDataList^ get ();
}
member Datas : DedDataList with get

Valore della proprietà

Tipo: DedDataList
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.DedDoc

Proprietà ModifyingDocumentInfoDedDoc

Restituisce il DedDoc abbinato al file oppure null se il file non è registrato nel Database.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.FullDocumentName

Proprietà ModifyingDocumentInfoFullDocumentName

Restituisce il percorso completo dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullDocumentName { get; set; }
Public Property FullDocumentName As String
    Get
    Set
public:
property String^ FullDocumentName {
    String^ get ();
    void set (String^ value);
}
member FullDocumentName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.FullFileName

Proprietà ModifyingDocumentInfoFullFileName

Restituisce il percorso completo dell'elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.HasDatas

Proprietà ModifyingDocumentInfoHasDatas

Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento) e sia anche associato ad una o più anagrafiche come file primario.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDatas { get; }
Public ReadOnly Property HasDatas As Boolean
    Get
public:
property bool HasDatas {
    bool get ();
}
member HasDatas : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.HasDocument

Proprietà ModifyingDocumentInfoHasDocument

Restituisce se questo elemento sia registrato nel Database (abbia o meno il documento).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDocument { get; }
Public ReadOnly Property HasDocument As Boolean
    Get
public:
property bool HasDocument {
    bool get ();
}
member HasDocument : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.HasToBeCheckedOut

Proprietà ModifyingDocumentInfoHasToBeCheckedOut

Controlla se l'elemento sia da mettere in check-out dall'utente, perché attualmente in check-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeCheckedOut { get; set; }
Public Property HasToBeCheckedOut As Boolean
    Get
    Set
public:
property bool HasToBeCheckedOut {
    bool get ();
    void set (bool value);
}
member HasToBeCheckedOut : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.HasToBeUpdated

Proprietà ModifyingDocumentInfoHasToBeUpdated

Il documento necessita di essere aggiornato. Non è pobbile apportare quindi modifiche.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeUpdated { get; }
Public ReadOnly Property HasToBeUpdated As Boolean
    Get
public:
property bool HasToBeUpdated {
    bool get ();
}
member HasToBeUpdated : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.IsCheckedIn

Proprietà ModifyingDocumentInfoIsCheckedIn

Restituisce se l'elemento sia attualmente in check-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckedIn { get; }
Public ReadOnly Property IsCheckedIn As Boolean
    Get
public:
property bool IsCheckedIn {
    bool get ();
}
member IsCheckedIn : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.IsCheckOutAble

Proprietà ModifyingDocumentInfoIsCheckOutAble

Restituisce se l'elemento sia attualmente in check-in.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckOutAble { get; }
Public ReadOnly Property IsCheckOutAble As Boolean
    Get
public:
property bool IsCheckOutAble {
    bool get ();
}
member IsCheckOutAble : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.NeedReload

Proprietà ModifyingDocumentInfoNeedReload

Restituisce se l'elemento necessita di essere ricaricato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NeedReload { get; }
Public ReadOnly Property NeedReload As Boolean
    Get
public:
property bool NeedReload {
    bool get ();
}
member NeedReload : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Proprietà ModifyingDocumentInfo.UserCanModify

Proprietà ModifyingDocumentInfoUserCanModify

Restituisce se l'utente può, come risultato di tutte le considerazioni, modificare questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanModify { get; }
Public ReadOnly Property UserCanModify As Boolean
    Get
public:
property bool UserCanModify {
    bool get ();
}
member UserCanModify : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfo
Namespace DedNetInv


Classe ModifyingDocumentInfoList
Lista di elementi di tipo ModifyingDocumentInfo.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList ModifyingDocumentInfo
DedNetInvModifyingDocumentInfoList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentInfoList : List<ModifyingDocumentInfo>
Public Class ModifyingDocumentInfoList
    Inherits List(Of ModifyingDocumentInfo)
public ref class ModifyingDocumentInfoList : public List<ModifyingDocumentInfo^>
type ModifyingDocumentInfoList =
    class
        inherit List<ModifyingDocumentInfo>
    end

Il tipo ModifyingDocumentInfoList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentInfoList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask | Scorre tutti gli elementi e restituisce se anche solo un elemento sia impostato come Ask. Se anche solo un elemento è Ask restituisce true.
Proprietà pubblica | AskList | Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | CannotModifyList | Restituisce la lista degli elementi che non sono modificabili e quindi da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | HasToBeUpdated | Scorre tutti gli elementi e restituisce true se anche solo un elemento sia impostato come elemento che necessita aggiornamento.
Proprietà pubblica | HasToBeUpdatedList | Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | UserCanModify | Scorre tutti gli elementi e restituisce se tutti gli elementi siano modificabili. Se anche solo un elemento non è modificabile restituisce false.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore ModifyingDocumentInfoList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList()
Public Sub New
public:
ModifyingDocumentInfoList()
new : unit -> ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà di ModifyingDocumentInfoList

Il tipo ModifyingDocumentInfoList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Ask | Scorre tutti gli elementi e restituisce se anche solo un elemento sia impostato come Ask. Se anche solo un elemento è Ask restituisce true.
Proprietà pubblica | AskList | Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | CannotModifyList | Restituisce la lista degli elementi che non sono modificabili e quindi da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | HasToBeUpdated | Scorre tutti gli elementi e restituisce true se anche solo un elemento sia impostato come elemento che necessita aggiornamento.
Proprietà pubblica | HasToBeUpdatedList | Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.
Proprietà pubblica | UserCanModify | Scorre tutti gli elementi e restituisce se tutti gli elementi siano modificabili. Se anche solo un elemento non è modificabile restituisce false.
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.Ask

Proprietà ModifyingDocumentInfoListAsk

Scorre tutti gli elementi e restituisce se anche solo un elemento sia impostato come Ask. Se anche solo un elemento è Ask restituisce true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; }
Public ReadOnly Property Ask As Boolean
    Get
public:
property bool Ask {
    bool get ();
}
member Ask : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.AskList

Proprietà ModifyingDocumentInfoListAskList

Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList AskList { get; }
Public ReadOnly Property AskList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ AskList {
    ModifyingDocumentInfoList^ get ();
}
member AskList : ModifyingDocumentInfoList with get

Valore della proprietà

Tipo: ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.CannotModifyList

Proprietà ModifyingDocumentInfoListCannotModifyList

Restituisce la lista degli elementi che non sono modificabili e quindi da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList CannotModifyList { get; }
Public ReadOnly Property CannotModifyList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ CannotModifyList {
    ModifyingDocumentInfoList^ get ();
}
member CannotModifyList : ModifyingDocumentInfoList with get

Valore della proprietà

Tipo: ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.HasToBeUpdated

Proprietà ModifyingDocumentInfoListHasToBeUpdated

Scorre tutti gli elementi e restituisce true se anche solo un elemento sia impostato come elemento che necessita aggiornamento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasToBeUpdated { get; }
Public ReadOnly Property HasToBeUpdated As Boolean
    Get
public:
property bool HasToBeUpdated {
    bool get ();
}
member HasToBeUpdated : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.HasToBeUpdatedList

Proprietà ModifyingDocumentInfoListHasToBeUpdatedList

Restituisce la lista degli elementi che sono modificabili ma da visualizzare all'utente. Restituisce una lista sempre inizializzata ed eventualmente vuota.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList HasToBeUpdatedList { get; }
Public ReadOnly Property HasToBeUpdatedList As ModifyingDocumentInfoList
    Get
public:
property ModifyingDocumentInfoList^ HasToBeUpdatedList {
    ModifyingDocumentInfoList^ get ();
}
member HasToBeUpdatedList : ModifyingDocumentInfoList with get

Valore della proprietà

Tipo: ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Proprietà ModifyingDocumentInfoList.UserCanModify

Proprietà ModifyingDocumentInfoListUserCanModify

Scorre tutti gli elementi e restituisce se tutti gli elementi siano modificabili. Se anche solo un elemento non è modificabile restituisce false.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserCanModify { get; }
Public ReadOnly Property UserCanModify As Boolean
    Get
public:
property bool UserCanModify {
    bool get ();
}
member UserCanModify : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentInfoList
Namespace DedNetInv


Classe Options
Gerarchia di ereditarietà
SystemObject
DedNetInvOptions

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Options
Public Class Options
public ref class Options
type Options =  class end

Il tipo Options espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Options |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddAssociatedFilesCreatingNewRep |
Proprietà pubblica | AlignDataNotWorkingOnDocument |
Proprietà pubblica | AlignDataOnVirtualOccurrence |
Proprietà pubblica | CancelStartingState |
Proprietà pubblica | CheckDrawingReferenceCoherence |
Proprietà pubblica | ConsiderVirtualSearchingCancelState |
Proprietà pubblica | ContextSensitiveToolBar |
Proprietà pubblica | ExecuteFindBrowserOnEditDocument |
Proprietà pubblica | ExecuteMultilevelCancelStartingStateCheck |
Proprietà pubblica | ExecuteParentCheckOnRemovingApprovation |
Proprietà pubblica | HideDirtyHighlight |
Proprietà pubblica | IncludeVirtualComponents |
Proprietà pubblica | OnFileDirtyActiveBehaviour |
Proprietà pubblica | PubStepExt |
Proprietà pubblica | QuickDocChangeStateMode |
Proprietà pubblica | RestrictSaveDistApprovedConfiguration |
Proprietà pubblica | RestrictSaveDistOnLavAnag |
Proprietà pubblica | RestrictSaveDistOutOfDateConfiguration |
Proprietà pubblica | RestrictSaveDistPendingApprovalConfiguration |
Proprietà pubblica | RestrictSaveDistUnchangeableConfiguration |
Proprietà pubblica | RestrictSaveDistWritableOutOfDateConfiguration |
Proprietà pubblica | SaveDistBomStructure |
Proprietà pubblica | SaveDistChildrenRestrictionConfiguration |
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | SetDeferUpdatesOnDrawing |
Proprietà pubblica | SmartResolution |
Proprietà pubblica | TimeSaverMode |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Options

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Options()
Public Sub New
public:
Options()
new : unit -> Options
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà di Options

Il tipo Options espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddAssociatedFilesCreatingNewRep |
Proprietà pubblica | AlignDataNotWorkingOnDocument |
Proprietà pubblica | AlignDataOnVirtualOccurrence |
Proprietà pubblica | CancelStartingState |
Proprietà pubblica | CheckDrawingReferenceCoherence |
Proprietà pubblica | ConsiderVirtualSearchingCancelState |
Proprietà pubblica | ContextSensitiveToolBar |
Proprietà pubblica | ExecuteFindBrowserOnEditDocument |
Proprietà pubblica | ExecuteMultilevelCancelStartingStateCheck |
Proprietà pubblica | ExecuteParentCheckOnRemovingApprovation |
Proprietà pubblica | HideDirtyHighlight |
Proprietà pubblica | IncludeVirtualComponents |
Proprietà pubblica | OnFileDirtyActiveBehaviour |
Proprietà pubblica | PubStepExt |
Proprietà pubblica | QuickDocChangeStateMode |
Proprietà pubblica | RestrictSaveDistApprovedConfiguration |
Proprietà pubblica | RestrictSaveDistOnLavAnag |
Proprietà pubblica | RestrictSaveDistOutOfDateConfiguration |
Proprietà pubblica | RestrictSaveDistPendingApprovalConfiguration |
Proprietà pubblica | RestrictSaveDistUnchangeableConfiguration |
Proprietà pubblica | RestrictSaveDistWritableOutOfDateConfiguration |
Proprietà pubblica | SaveDistBomStructure |
Proprietà pubblica | SaveDistChildrenRestrictionConfiguration |
Proprietà pubblica | SaveDistOnApproved |
Proprietà pubblica | SetDeferUpdatesOnDrawing |
Proprietà pubblica | SmartResolution |
Proprietà pubblica | TimeSaverMode |
Torna su
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.AddAssociatedFilesCreatingNewRep

Proprietà OptionsAddAssociatedFilesCreatingNewRep

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AddAssociatedFilesCreatingNewRep { get; set; }
Public Property AddAssociatedFilesCreatingNewRep As Boolean
    Get
    Set
public:
property bool AddAssociatedFilesCreatingNewRep {
    bool get ();
    void set (bool value);
}
member AddAssociatedFilesCreatingNewRep : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.AlignDataNotWorkingOnDocument

Proprietà OptionsAlignDataNotWorkingOnDocument

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlignDataNotWorkingOnDocument { get; set; }
Public Property AlignDataNotWorkingOnDocument As Boolean
    Get
    Set
public:
property bool AlignDataNotWorkingOnDocument {
    bool get ();
    void set (bool value);
}
member AlignDataNotWorkingOnDocument : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.AlignDataOnVirtualOccurrence

Proprietà OptionsAlignDataOnVirtualOccurrence

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlignDataOnVirtualOccurrence { get; set; }
Public Property AlignDataOnVirtualOccurrence As Boolean
    Get
    Set
public:
property bool AlignDataOnVirtualOccurrence {
    bool get ();
    void set (bool value);
}
member AlignDataOnVirtualOccurrence : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.CancelStartingState

Proprietà OptionsCancelStartingState

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OptionsCancelStartingStateConfiguration CancelStartingState { get; set; }
Public Property CancelStartingState As OptionsCancelStartingStateConfiguration
    Get
    Set
public:
property OptionsCancelStartingStateConfiguration^ CancelStartingState {
    OptionsCancelStartingStateConfiguration^ get ();
    void set (OptionsCancelStartingStateConfiguration^ value);
}
member CancelStartingState : OptionsCancelStartingStateConfiguration with get, set

Valore della proprietà

Tipo: OptionsCancelStartingStateConfiguration
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.CheckDrawingReferenceCoherence

Proprietà OptionsCheckDrawingReferenceCoherence

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CheckDrawingReferenceCoherence { get; set; }
Public Property CheckDrawingReferenceCoherence As Boolean
    Get
    Set
public:
property bool CheckDrawingReferenceCoherence {
    bool get ();
    void set (bool value);
}
member CheckDrawingReferenceCoherence : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.ConsiderVirtualSearchingCancelState

Proprietà OptionsConsiderVirtualSearchingCancelState

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ConsiderVirtualSearchingCancelState { get; set; }
Public Property ConsiderVirtualSearchingCancelState As Boolean
    Get
    Set
public:
property bool ConsiderVirtualSearchingCancelState {
    bool get ();
    void set (bool value);
}
member ConsiderVirtualSearchingCancelState : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.ContextSensitiveToolBar

Proprietà OptionsContextSensitiveToolBar

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContextSensitiveToolBar { get; set; }
Public Property ContextSensitiveToolBar As Boolean
    Get
    Set
public:
property bool ContextSensitiveToolBar {
    bool get ();
    void set (bool value);
}
member ContextSensitiveToolBar : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.ExecuteFindBrowserOnEditDocument

Proprietà OptionsExecuteFindBrowserOnEditDocument

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteFindBrowserOnEditDocument { get; set; }
Public Property ExecuteFindBrowserOnEditDocument As Boolean
    Get
    Set
public:
property bool ExecuteFindBrowserOnEditDocument {
    bool get ();
    void set (bool value);
}
member ExecuteFindBrowserOnEditDocument : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.ExecuteMultilevelCancelStartingStateCheck

Proprietà OptionsExecuteMultilevelCancelStartingStateCheck

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteMultilevelCancelStartingStateCheck { get; set; }
Public Property ExecuteMultilevelCancelStartingStateCheck As Boolean
    Get
    Set
public:
property bool ExecuteMultilevelCancelStartingStateCheck {
    bool get ();
    void set (bool value);
}
member ExecuteMultilevelCancelStartingStateCheck : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.ExecuteParentCheckOnRemovingApprovation

Proprietà OptionsExecuteParentCheckOnRemovingApprovation

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExecuteParentCheckOnRemovingApprovation { get; set; }
Public Property ExecuteParentCheckOnRemovingApprovation As Boolean
    Get
    Set
public:
property bool ExecuteParentCheckOnRemovingApprovation {
    bool get ();
    void set (bool value);
}
member ExecuteParentCheckOnRemovingApprovation : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.HideDirtyHighlight

Proprietà OptionsHideDirtyHighlight

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HideDirtyHighlight { get; set; }
Public Property HideDirtyHighlight As Boolean
    Get
    Set
public:
property bool HideDirtyHighlight {
    bool get ();
    void set (bool value);
}
member HideDirtyHighlight : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.IncludeVirtualComponents

Proprietà OptionsIncludeVirtualComponents

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IncludeVirtualComponents { get; set; }
Public Property IncludeVirtualComponents As Boolean
    Get
    Set
public:
property bool IncludeVirtualComponents {
    bool get ();
    void set (bool value);
}
member IncludeVirtualComponents : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.OnFileDirtyActiveBehaviour

Proprietà OptionsOnFileDirtyActiveBehaviour

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetInvAppOnFileDirtyBehaviour OnFileDirtyActiveBehaviour { get; set; }
Public Property OnFileDirtyActiveBehaviour As DedNetInvAppOnFileDirtyBehaviour
    Get
    Set
public:
property DedNetInvAppOnFileDirtyBehaviour OnFileDirtyActiveBehaviour {
    DedNetInvAppOnFileDirtyBehaviour get ();
    void set (DedNetInvAppOnFileDirtyBehaviour value);
}
member OnFileDirtyActiveBehaviour : DedNetInvAppOnFileDirtyBehaviour with get, set

Valore della proprietà

Tipo: DedNetInvAppOnFileDirtyBehaviour
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.PubStepExt

Proprietà OptionsPubStepExt

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string PubStepExt { get; set; }
Public Property PubStepExt As String
    Get
    Set
public:
property String^ PubStepExt {
    String^ get ();
    void set (String^ value);
}
member PubStepExt : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.QuickDocChangeStateMode

Proprietà OptionsQuickDocChangeStateMode

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool QuickDocChangeStateMode { get; set; }
Public Property QuickDocChangeStateMode As Boolean
    Get
    Set
public:
property bool QuickDocChangeStateMode {
    bool get ();
    void set (bool value);
}
member QuickDocChangeStateMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistApprovedConfiguration

Proprietà OptionsRestrictSaveDistApprovedConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistApprovedConfiguration { get; set; }
Public Property RestrictSaveDistApprovedConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistApprovedConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistApprovedConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

Tipo: RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistOnLavAnag

Proprietà OptionsRestrictSaveDistOnLavAnag

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RestrictSaveDistOnLavAnag { get; set; }
Public Property RestrictSaveDistOnLavAnag As Boolean
    Get
    Set
public:
property bool RestrictSaveDistOnLavAnag {
    bool get ();
    void set (bool value);
}
member RestrictSaveDistOnLavAnag : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistOutOfDateConfiguration

Proprietà OptionsRestrictSaveDistOutOfDateConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistOutOfDateConfiguration { get; set; }
Public Property RestrictSaveDistOutOfDateConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistOutOfDateConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistOutOfDateConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

Tipo: RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistPendingApprovalConfiguration

Proprietà OptionsRestrictSaveDistPendingApprovalConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistPendingApprovalConfiguration { get; set; }
Public Property RestrictSaveDistPendingApprovalConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistPendingApprovalConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistPendingApprovalConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

Tipo: RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistUnchangeableConfiguration

Proprietà OptionsRestrictSaveDistUnchangeableConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistUnchangeableConfiguration { get; set; }
Public Property RestrictSaveDistUnchangeableConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistUnchangeableConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistUnchangeableConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

Tipo: RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.RestrictSaveDistWritableOutOfDateConfiguration

Proprietà OptionsRestrictSaveDistWritableOutOfDateConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RestrictSaveDistStates RestrictSaveDistWritableOutOfDateConfiguration { get; set; }
Public Property RestrictSaveDistWritableOutOfDateConfiguration As RestrictSaveDistStates
    Get
    Set
public:
property RestrictSaveDistStates RestrictSaveDistWritableOutOfDateConfiguration {
    RestrictSaveDistStates get ();
    void set (RestrictSaveDistStates value);
}
member RestrictSaveDistWritableOutOfDateConfiguration : RestrictSaveDistStates with get, set

Valore della proprietà

Tipo: RestrictSaveDistStates
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.SaveDistBomStructure

Proprietà OptionsSaveDistBomStructure

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OptionsSaveDistOnBomStructureConfiguration SaveDistBomStructure { get; set; }
Public Property SaveDistBomStructure As OptionsSaveDistOnBomStructureConfiguration
    Get
    Set
public:
property OptionsSaveDistOnBomStructureConfiguration^ SaveDistBomStructure {
    OptionsSaveDistOnBomStructureConfiguration^ get ();
    void set (OptionsSaveDistOnBomStructureConfiguration^ value);
}
member SaveDistBomStructure : OptionsSaveDistOnBomStructureConfiguration with get, set

Valore della proprietà

Tipo: OptionsSaveDistOnBomStructureConfiguration
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionConfiguration

Proprietà OptionsSaveDistChildrenRestrictionConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OptionsSaveDistChildrenRestrictionStatusConfiguration SaveDistChildrenRestrictionConfiguration { get; set; }
Public Property SaveDistChildrenRestrictionConfiguration As OptionsSaveDistChildrenRestrictionStatusConfiguration
    Get
    Set
public:
property OptionsSaveDistChildrenRestrictionStatusConfiguration^ SaveDistChildrenRestrictionConfiguration {
    OptionsSaveDistChildrenRestrictionStatusConfiguration^ get ();
    void set (OptionsSaveDistChildrenRestrictionStatusConfiguration^ value);
}
member SaveDistChildrenRestrictionConfiguration : OptionsSaveDistChildrenRestrictionStatusConfiguration with get, set

Valore della proprietà

Tipo: OptionsSaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.SaveDistOnApproved

Proprietà OptionsSaveDistOnApproved

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SaveDistOnApproved { get; set; }
Public Property SaveDistOnApproved As Boolean
    Get
    Set
public:
property bool SaveDistOnApproved {
    bool get ();
    void set (bool value);
}
member SaveDistOnApproved : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.SetDeferUpdatesOnDrawing

Proprietà OptionsSetDeferUpdatesOnDrawing

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SetDeferUpdatesOnDrawing { get; set; }
Public Property SetDeferUpdatesOnDrawing As Boolean
    Get
    Set
public:
property bool SetDeferUpdatesOnDrawing {
    bool get ();
    void set (bool value);
}
member SetDeferUpdatesOnDrawing : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.SmartResolution

Proprietà OptionsSmartResolution

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SmartResolution { get; set; }
Public Property SmartResolution As Boolean
    Get
    Set
public:
property bool SmartResolution {
    bool get ();
    void set (bool value);
}
member SmartResolution : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Proprietà Options.TimeSaverMode

Proprietà OptionsTimeSaverMode

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool TimeSaverMode { get; set; }
Public Property TimeSaverMode As Boolean
    Get
    Set
public:
property bool TimeSaverMode {
    bool get ();
    void set (bool value);
}
member TimeSaverMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Options
Namespace DedNetInv


Classe Options.CancelStartingStateConfiguration

Classe OptionsCancelStartingStateConfiguration
Classe per la gestione dei formati di pubblicazione in cambio stato di anagrafica
Gerarchia di ereditarietà
SystemObject
DedNetInvOptionsCancelStartingStateConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CancelStartingStateConfiguration
Public Class CancelStartingStateConfiguration
public ref class CancelStartingStateConfiguration
type CancelStartingStateConfiguration =  class end

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsCancelStartingStateConfiguration | Costruttore default
Metodo pubblico | OptionsCancelStartingStateConfiguration(OptionsCancelStartingStateConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working | Proprietà pubbliche descrizione del formato
Torna su
Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore CancelStartingStateConfiguration

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OptionsCancelStartingStateConfiguration | Costruttore default
Metodo pubblico | OptionsCancelStartingStateConfiguration(OptionsCancelStartingStateConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Costruttore Options.CancelStartingStateConfiguration

Costruttore OptionsCancelStartingStateConfiguration

Costruttore default

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CancelStartingStateConfiguration()
Public Sub New
public:
CancelStartingStateConfiguration()
new : unit -> CancelStartingStateConfiguration
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Overload di OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Costruttore Options.CancelStartingStateConfiguration (Options.CancelStartingStateConfiguration)

Costruttore OptionsCancelStartingStateConfiguration (OptionsCancelStartingStateConfiguration)
Costruttore con inizializzazione da altro oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CancelStartingStateConfiguration(
    OptionsCancelStartingStateConfiguration obj
)
Public Sub New (
    obj As OptionsCancelStartingStateConfiguration
)
public:
CancelStartingStateConfiguration(
    OptionsCancelStartingStateConfiguration^ obj
)
new :
        obj : OptionsCancelStartingStateConfiguration -> CancelStartingStateConfiguration

Parametri

obj
Tipo: DedNetInvOptionsCancelStartingStateConfiguration
Oggetto dello stesso tipo da clonare
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Overload di OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Proprietà di CancelStartingStateConfiguration

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Proprietà pubblica | Working | Proprietà pubbliche descrizione del formato
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Proprietà Options.CancelStartingStateConfiguration.OutOfDate

Proprietà OptionsCancelStartingStateConfigurationOutOfDate

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutOfDate { get; set; }
Public Property OutOfDate As Boolean
    Get
    Set
public:
property bool OutOfDate {
    bool get ();
    void set (bool value);
}
member OutOfDate : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Proprietà Options.CancelStartingStateConfiguration.PendingApproval

Proprietà OptionsCancelStartingStateConfigurationPendingApproval

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PendingApproval { get; set; }
Public Property PendingApproval As Boolean
    Get
    Set
public:
property bool PendingApproval {
    bool get ();
    void set (bool value);
}
member PendingApproval : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Proprietà Options.CancelStartingStateConfiguration.Unchangeable

Proprietà OptionsCancelStartingStateConfigurationUnchangeable

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Unchangeable { get; set; }
Public Property Unchangeable As Boolean
    Get
    Set
public:
property bool Unchangeable {
    bool get ();
    void set (bool value);
}
member Unchangeable : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Proprietà Options.CancelStartingStateConfiguration.Working

Proprietà OptionsCancelStartingStateConfigurationWorking

Proprietà pubbliche descrizione del formato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Working { get; set; }
Public Property Working As Boolean
    Get
    Set
public:
property bool Working {
    bool get ();
    void set (bool value);
}
member Working : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Metodi di CancelStartingStateConfiguration

Il tipo OptionsCancelStartingStateConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Metodo Options.CancelStartingStateConfiguration.FromDescriptor

Metodo OptionsCancelStartingStateConfigurationFromDescriptor

Riconversione della stringa in oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OptionsCancelStartingStateConfiguration FromDescriptor(
    string cancelStatesDescriptor
)
Public Shared Function FromDescriptor (
    cancelStatesDescriptor As String
) As OptionsCancelStartingStateConfiguration
public:
static OptionsCancelStartingStateConfiguration^ FromDescriptor(
    String^ cancelStatesDescriptor
)
static member FromDescriptor :
        cancelStatesDescriptor : string -> OptionsCancelStartingStateConfiguration

Parametri

cancelStatesDescriptor
Tipo: SystemString

Valore di ritorno

Tipo: OptionsCancelStartingStateConfiguration
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Metodo Options.CancelStartingStateConfiguration.ToString

Metodo OptionsCancelStartingStateConfigurationToString

Conversione dell'oggetto in stringa

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe OptionsCancelStartingStateConfiguration
Namespace DedNetInv


Classe Options.LocalizedCategoryAttribute

Classe OptionsLocalizedCategoryAttribute
Gestione localizzazione categorie
Gerarchia di ereditarietà
SystemObject
SystemAttribute
System.ComponentModelCategoryAttribute
DedNetInvOptionsLocalizedCategoryAttribute

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LocalizedCategoryAttribute : CategoryAttribute
Public Class LocalizedCategoryAttribute
    Inherits CategoryAttribute
public ref class LocalizedCategoryAttribute : public CategoryAttribute
type LocalizedCategoryAttribute =
    class
        inherit CategoryAttribute
    end

Il tipo OptionsLocalizedCategoryAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsLocalizedCategoryAttribute |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | GetLocalizedString | (Sovrascrive CategoryAttributeGetLocalizedString(String).)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Options.LocalizedCategoryAttribute

Costruttore OptionsLocalizedCategoryAttribute

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LocalizedCategoryAttribute(
    string resourceKey,
    Type resourceType
)
Public Sub New (
    resourceKey As String,
    resourceType As Type
)
public:
LocalizedCategoryAttribute(
    String^ resourceKey,
    Type^ resourceType
)
new :
        resourceKey : string *
        resourceType : Type -> LocalizedCategoryAttribute

Parametri

resourceKey
Tipo: SystemString
resourceType
Tipo: SystemType
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetInv


Metodi di LocalizedCategoryAttribute

Il tipo OptionsLocalizedCategoryAttribute espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | GetLocalizedString | (Sovrascrive CategoryAttributeGetLocalizedString(String).)
Torna su
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetInv


Metodo Options.LocalizedCategoryAttribute.GetLocalizedString

Metodo OptionsLocalizedCategoryAttributeGetLocalizedString

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override string GetLocalizedString(
    string value
)
Protected Overrides Function GetLocalizedString (
    value As String
) As String
protected:
virtual String^ GetLocalizedString(
    String^ value
) override
abstract GetLocalizedString :
        value : string -> string
override GetLocalizedString :
        value : string -> string

Parametri

value
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe OptionsLocalizedCategoryAttribute
Namespace DedNetInv


Classe Options.LocalizedDisplayNameAttribute

Classe OptionsLocalizedDisplayNameAttribute
Gestione localizzazione display name
Gerarchia di ereditarietà
SystemObject
SystemAttribute
System.ComponentModelDisplayNameAttribute
DedNetInvOptionsLocalizedDisplayNameAttribute

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LocalizedDisplayNameAttribute : DisplayNameAttribute
Public Class LocalizedDisplayNameAttribute
    Inherits DisplayNameAttribute
public ref class LocalizedDisplayNameAttribute : public DisplayNameAttribute
type LocalizedDisplayNameAttribute =
    class
        inherit DisplayNameAttribute
    end

Il tipo OptionsLocalizedDisplayNameAttribute espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsLocalizedDisplayNameAttribute |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisplayName | (Sovrascrive DisplayNameAttributeDisplayName.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Options.LocalizedDisplayNameAttribute

Costruttore OptionsLocalizedDisplayNameAttribute

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LocalizedDisplayNameAttribute(
    string resourceKey,
    Type resourceType
)
Public Sub New (
    resourceKey As String,
    resourceType As Type
)
public:
LocalizedDisplayNameAttribute(
    String^ resourceKey,
    Type^ resourceType
)
new :
        resourceKey : string *
        resourceType : Type -> LocalizedDisplayNameAttribute

Parametri

resourceKey
Tipo: SystemString
resourceType
Tipo: SystemType
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetInv


Proprietà di LocalizedDisplayNameAttribute

Il tipo OptionsLocalizedDisplayNameAttribute espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DisplayName | (Sovrascrive DisplayNameAttributeDisplayName.)
Torna su
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetInv


Proprietà Options.LocalizedDisplayNameAttribute.DisplayName

Proprietà OptionsLocalizedDisplayNameAttributeDisplayName

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string DisplayName { get; }
Public Overrides ReadOnly Property DisplayName As String
    Get
public:
virtual property String^ DisplayName {
    String^ get () override;
}
abstract DisplayName : string with get
override DisplayName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe OptionsLocalizedDisplayNameAttribute
Namespace DedNetInv


Classe Options.SaveDistChildrenRestrictionStatusConfiguration

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Classe per la gestione degli stati che invalidano il salvataggio distinta se presenti nei figli
Gerarchia di ereditarietà
SystemObject
DedNetInvOptionsSaveDistChildrenRestrictionStatusConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistChildrenRestrictionStatusConfiguration
Public Class SaveDistChildrenRestrictionStatusConfiguration
public ref class SaveDistChildrenRestrictionStatusConfiguration
type SaveDistChildrenRestrictionStatusConfiguration =  class end

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration | Costruttore default
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration(OptionsSaveDistChildrenRestrictionStatusConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Approved | Proprietà pubbliche descrizione del formato
Proprietà pubblica | ModifyingOutOfDate |
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Torna su
Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore SaveDistChildrenRestrictionStatusConfiguration

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration | Costruttore default
Metodo pubblico | OptionsSaveDistChildrenRestrictionStatusConfiguration(OptionsSaveDistChildrenRestrictionStatusConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Costruttore Options.SaveDistChildrenRestrictionStatusConfiguration

Costruttore OptionsSaveDistChildrenRestrictionStatusConfiguration

Costruttore default

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistChildrenRestrictionStatusConfiguration()
Public Sub New
public:
SaveDistChildrenRestrictionStatusConfiguration()
new : unit -> SaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Overload di OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Costruttore Options.SaveDistChildrenRestrictionStatusConfiguration (Options.SaveDistChildrenRestrictionStatusConfiguration)

Costruttore OptionsSaveDistChildrenRestrictionStatusConfiguration (OptionsSaveDistChildrenRestrictionStatusConfiguration)
Costruttore con inizializzazione da altro oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistChildrenRestrictionStatusConfiguration(
    OptionsSaveDistChildrenRestrictionStatusConfiguration obj
)
Public Sub New (
    obj As OptionsSaveDistChildrenRestrictionStatusConfiguration
)
public:
SaveDistChildrenRestrictionStatusConfiguration(
    OptionsSaveDistChildrenRestrictionStatusConfiguration^ obj
)
new :
        obj : OptionsSaveDistChildrenRestrictionStatusConfiguration -> SaveDistChildrenRestrictionStatusConfiguration

Parametri

obj
Tipo: DedNetInvOptionsSaveDistChildrenRestrictionStatusConfiguration
Oggetto dello stesso tipo da clonare
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Overload di OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà di SaveDistChildrenRestrictionStatusConfiguration

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Approved | Proprietà pubbliche descrizione del formato
Proprietà pubblica | ModifyingOutOfDate |
Proprietà pubblica | OutOfDate |
Proprietà pubblica | PendingApproval |
Proprietà pubblica | Unchangeable |
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.Approved

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationApproved

Proprietà pubbliche descrizione del formato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Approved { get; set; }
Public Property Approved As Boolean
    Get
    Set
public:
property bool Approved {
    bool get ();
    void set (bool value);
}
member Approved : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.ModifyingOutOfDate

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationModifyingOutOfDate

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ModifyingOutOfDate { get; set; }
Public Property ModifyingOutOfDate As Boolean
    Get
    Set
public:
property bool ModifyingOutOfDate {
    bool get ();
    void set (bool value);
}
member ModifyingOutOfDate : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.OutOfDate

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationOutOfDate

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutOfDate { get; set; }
Public Property OutOfDate As Boolean
    Get
    Set
public:
property bool OutOfDate {
    bool get ();
    void set (bool value);
}
member OutOfDate : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.PendingApproval

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationPendingApproval

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PendingApproval { get; set; }
Public Property PendingApproval As Boolean
    Get
    Set
public:
property bool PendingApproval {
    bool get ();
    void set (bool value);
}
member PendingApproval : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistChildrenRestrictionStatusConfiguration.Unchangeable

Proprietà OptionsSaveDistChildrenRestrictionStatusConfigurationUnchangeable

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Unchangeable { get; set; }
Public Property Unchangeable As Boolean
    Get
    Set
public:
property bool Unchangeable {
    bool get ();
    void set (bool value);
}
member Unchangeable : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Metodi di SaveDistChildrenRestrictionStatusConfiguration

Il tipo OptionsSaveDistChildrenRestrictionStatusConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Metodo Options.SaveDistChildrenRestrictionStatusConfiguration.FromDescriptor

Metodo OptionsSaveDistChildrenRestrictionStatusConfigurationFromDescriptor

Riconversione della stringa in oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OptionsSaveDistChildrenRestrictionStatusConfiguration FromDescriptor(
    string saveDistChildrenRestrictionStatusConfiguration
)
Public Shared Function FromDescriptor (
    saveDistChildrenRestrictionStatusConfiguration As String
) As OptionsSaveDistChildrenRestrictionStatusConfiguration
public:
static OptionsSaveDistChildrenRestrictionStatusConfiguration^ FromDescriptor(
    String^ saveDistChildrenRestrictionStatusConfiguration
)
static member FromDescriptor :
        saveDistChildrenRestrictionStatusConfiguration : string -> OptionsSaveDistChildrenRestrictionStatusConfiguration

Parametri

saveDistChildrenRestrictionStatusConfiguration
Tipo: SystemString

Valore di ritorno

Tipo: OptionsSaveDistChildrenRestrictionStatusConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Metodo Options.SaveDistChildrenRestrictionStatusConfiguration.ToString

Metodo OptionsSaveDistChildrenRestrictionStatusConfigurationToString

Conversione dell'oggetto in stringa

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe OptionsSaveDistChildrenRestrictionStatusConfiguration
Namespace DedNetInv


Classe Options.SaveDistOnBomStructureConfiguration

Classe OptionsSaveDistOnBomStructureConfiguration
Classe per la gestione dei formati di pubblicazione in cambio stato di anagrafica
Gerarchia di ereditarietà
SystemObject
DedNetInvOptionsSaveDistOnBomStructureConfiguration

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SaveDistOnBomStructureConfiguration
Public Class SaveDistOnBomStructureConfiguration
public ref class SaveDistOnBomStructureConfiguration
type SaveDistOnBomStructureConfiguration =  class end

Il tipo OptionsSaveDistOnBomStructureConfiguration espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistOnBomStructureConfiguration | Costruttore default
Metodo pubblico | OptionsSaveDistOnBomStructureConfiguration(OptionsSaveDistOnBomStructureConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Inseparable |
Proprietà pubblica | Normal | Proprietà pubbliche descrizione del formato
Proprietà pubblica | Phantom |
Proprietà pubblica | Purchased |
Proprietà pubblica | Reference |
Torna su
Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore SaveDistOnBomStructureConfiguration

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | OptionsSaveDistOnBomStructureConfiguration | Costruttore default
Metodo pubblico | OptionsSaveDistOnBomStructureConfiguration(OptionsSaveDistOnBomStructureConfiguration) | Costruttore con inizializzazione da altro oggetto
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Costruttore Options.SaveDistOnBomStructureConfiguration

Costruttore OptionsSaveDistOnBomStructureConfiguration

Costruttore default

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistOnBomStructureConfiguration()
Public Sub New
public:
SaveDistOnBomStructureConfiguration()
new : unit -> SaveDistOnBomStructureConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Overload di OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Costruttore Options.SaveDistOnBomStructureConfiguration (Options.SaveDistOnBomStructureConfiguration)

Costruttore OptionsSaveDistOnBomStructureConfiguration (OptionsSaveDistOnBomStructureConfiguration)
Costruttore con inizializzazione da altro oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveDistOnBomStructureConfiguration(
    OptionsSaveDistOnBomStructureConfiguration obj
)
Public Sub New (
    obj As OptionsSaveDistOnBomStructureConfiguration
)
public:
SaveDistOnBomStructureConfiguration(
    OptionsSaveDistOnBomStructureConfiguration^ obj
)
new :
        obj : OptionsSaveDistOnBomStructureConfiguration -> SaveDistOnBomStructureConfiguration

Parametri

obj
Tipo: DedNetInvOptionsSaveDistOnBomStructureConfiguration
Oggetto dello stesso tipo da clonare
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Overload di OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà di SaveDistOnBomStructureConfiguration

Il tipo OptionsSaveDistOnBomStructureConfiguration espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Inseparable |
Proprietà pubblica | Normal | Proprietà pubbliche descrizione del formato
Proprietà pubblica | Phantom |
Proprietà pubblica | Purchased |
Proprietà pubblica | Reference |
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistOnBomStructureConfiguration.Inseparable

Proprietà OptionsSaveDistOnBomStructureConfigurationInseparable

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Inseparable { get; set; }
Public Property Inseparable As Boolean
    Get
    Set
public:
property bool Inseparable {
    bool get ();
    void set (bool value);
}
member Inseparable : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistOnBomStructureConfiguration.Normal

Proprietà OptionsSaveDistOnBomStructureConfigurationNormal

Proprietà pubbliche descrizione del formato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Normal { get; set; }
Public Property Normal As Boolean
    Get
    Set
public:
property bool Normal {
    bool get ();
    void set (bool value);
}
member Normal : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistOnBomStructureConfiguration.Phantom

Proprietà OptionsSaveDistOnBomStructureConfigurationPhantom

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Phantom { get; set; }
Public Property Phantom As Boolean
    Get
    Set
public:
property bool Phantom {
    bool get ();
    void set (bool value);
}
member Phantom : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistOnBomStructureConfiguration.Purchased

Proprietà OptionsSaveDistOnBomStructureConfigurationPurchased

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Purchased { get; set; }
Public Property Purchased As Boolean
    Get
    Set
public:
property bool Purchased {
    bool get ();
    void set (bool value);
}
member Purchased : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Proprietà Options.SaveDistOnBomStructureConfiguration.Reference

Proprietà OptionsSaveDistOnBomStructureConfigurationReference

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Reference { get; set; }
Public Property Reference As Boolean
    Get
    Set
public:
property bool Reference {
    bool get ();
    void set (bool value);
}
member Reference : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Metodi di SaveDistOnBomStructureConfiguration

Il tipo OptionsSaveDistOnBomStructureConfiguration espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | FromDescriptor | Riconversione della stringa in oggetto
Metodo pubblico | ToString | Conversione dell'oggetto in stringa (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Metodo Options.SaveDistOnBomStructureConfiguration.FromDescriptor

Metodo OptionsSaveDistOnBomStructureConfigurationFromDescriptor

Riconversione della stringa in oggetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static OptionsSaveDistOnBomStructureConfiguration FromDescriptor(
    string saveDistOnBomSctuctureDescriptor
)
Public Shared Function FromDescriptor (
    saveDistOnBomSctuctureDescriptor As String
) As OptionsSaveDistOnBomStructureConfiguration
public:
static OptionsSaveDistOnBomStructureConfiguration^ FromDescriptor(
    String^ saveDistOnBomSctuctureDescriptor
)
static member FromDescriptor :
        saveDistOnBomSctuctureDescriptor : string -> OptionsSaveDistOnBomStructureConfiguration

Parametri

saveDistOnBomSctuctureDescriptor
Tipo: SystemString

Valore di ritorno

Tipo: OptionsSaveDistOnBomStructureConfiguration
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Metodo Options.SaveDistOnBomStructureConfiguration.ToString

Metodo OptionsSaveDistOnBomStructureConfigurationToString

Conversione dell'oggetto in stringa

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe OptionsSaveDistOnBomStructureConfiguration
Namespace DedNetInv


Classe QsPropertiesInterfaceWrapper
Gerarchia di ereditarietà
SystemObject
DedNetInvQsPropertiesInterfaceWrapper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsPropertiesInterfaceWrapper : IDataOptions
Public Class QsPropertiesInterfaceWrapper
    Implements IDataOptions
public ref class QsPropertiesInterfaceWrapper : IDataOptions
type QsPropertiesInterfaceWrapper =
    class
        interface IDataOptions
    end

Il tipo QsPropertiesInterfaceWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsPropertiesInterfaceWrapper |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Cancel |
Metodo pubblico | GetPropertiesObject |
Metodo pubblico | Load |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore QsPropertiesInterfaceWrapper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsPropertiesInterfaceWrapper()
Public Sub New
public:
QsPropertiesInterfaceWrapper()
new : unit -> QsPropertiesInterfaceWrapper
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Metodi di QsPropertiesInterfaceWrapper

Il tipo QsPropertiesInterfaceWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Cancel |
Metodo pubblico | GetPropertiesObject |
Metodo pubblico | Load |
Metodo pubblico | Save |
Torna su
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Metodo QsPropertiesInterfaceWrapper.Cancel

Metodo QsPropertiesInterfaceWrapperCancel

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Cancel()
Public Sub Cancel
public:
virtual void Cancel() sealed
abstract Cancel : unit -> unit
override Cancel : unit -> unit

Implementa

IDataOptions.Cancel
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Metodo QsPropertiesInterfaceWrapper.GetPropertiesObject

Metodo QsPropertiesInterfaceWrapperGetPropertiesObject

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object GetPropertiesObject()
Public Function GetPropertiesObject As Object
public:
virtual Object^ GetPropertiesObject() sealed
abstract GetPropertiesObject : unit -> Object
override GetPropertiesObject : unit -> Object

Valore di ritorno

Tipo: Object

Implementa

IDataOptions.GetPropertiesObject
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Metodo QsPropertiesInterfaceWrapper.Load

Metodo QsPropertiesInterfaceWrapperLoad

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Load()
Public Sub Load
public:
virtual void Load() sealed
abstract Load : unit -> unit
override Load : unit -> unit

Implementa

IDataOptions.Load
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Metodo QsPropertiesInterfaceWrapper.Save

Metodo QsPropertiesInterfaceWrapperSave

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
virtual void Save() sealed
abstract Save : unit -> unit
override Save : unit -> unit

Implementa

IDataOptions.Save
Vedi anche

Documentazione

Classe QsPropertiesInterfaceWrapper
Namespace DedNetInv


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
DedNetInvQsResources

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore QsResources

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s
Tipo: SystemString
a
Tipo: System.ReflectionAssembly
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetInv


Metodi di QsResources
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetInv


Metodo QsResources.GetString

Metodo QsResourcesGetString

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources
Namespace DedNetInv


Metodo QsResources.GetString (String)

Metodo QsResourcesGetString (String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNetInv


Metodo QsResources.GetString (String, CultureInfo)

Metodo QsResourcesGetString (String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name
Tipo: SystemString
culture
Tipo: System.GlobalizationCultureInfo

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString
Namespace DedNetInv


Classe ResolveFileForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInvResolveFileForm

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolveFileForm : BaseForm
Public Class ResolveFileForm
    Inherits BaseForm
public ref class ResolveFileForm : public BaseForm
type ResolveFileForm =
    class
        inherit BaseForm
    end

Il tipo ResolveFileForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ResolveFileForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ReferencingFile |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore ResolveFileForm

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ResolveFileForm(
    DedNetApplication app,
    DedNetInvOldFileResolutionOnFileResolutionSostItemList lst,
    DedNetInvOldFileResolutionRispostaUtenteSost risp
)
Public Sub New (
    app As DedNetApplication,
    lst As DedNetInvOldFileResolutionOnFileResolutionSostItemList,
    risp As DedNetInvOldFileResolutionRispostaUtenteSost
)
public:
ResolveFileForm(
    DedNetApplication^ app,
    DedNetInvOldFileResolutionOnFileResolutionSostItemList^ lst,
    DedNetInvOldFileResolutionRispostaUtenteSost risp
)
new :
        app : DedNetApplication *
        lst : DedNetInvOldFileResolutionOnFileResolutionSostItemList *
        risp : DedNetInvOldFileResolutionRispostaUtenteSost -> ResolveFileForm

Parametri

app
Tipo: DedNetApplication
lst
Tipo: DedNetInvDedNetInvOldFileResolutionOnFileResolutionSostItemList
risp
Tipo: DedNetInvDedNetInvOldFileResolutionRispostaUtenteSost
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Proprietà di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ReferencingFile |
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Proprietà ResolveFileForm.ReferencingFile

Proprietà ResolveFileFormReferencingFile

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ReferencingFile { get; set; }
Public Property ReferencingFile As String
    Get
    Set
public:
property String^ ReferencingFile {
    String^ get ();
    void set (String^ value);
}
member ReferencingFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Proprietà ResolveFileForm.SetText

Proprietà ResolveFileFormSetText

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SetText { get; set; }
Public Property SetText As String
    Get
    Set
public:
property String^ SetText {
    String^ get ();
    void set (String^ value);
}
member SetText : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Metodi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Metodo ResolveFileForm.Dispose

Metodo ResolveFileFormDispose

Clean up any resources being used.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Eventi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Campi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm
Namespace DedNetInv


Classe SelInfoItem
Classe descrivente un singolo elemento della selezione presente.
Gerarchia di ereditarietà
SystemObject
DedNetInvSelInfoItem

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SelInfoItem
Public Class SelInfoItem
public ref class SelInfoItem
type SelInfoItem =  class end

Il tipo SelInfoItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelInfoItem(ComponentOccurrence) | Costruttore con Occorrenza di Inventor.
Metodo pubblico | SelInfoItem(DerivedAssemblyComponent) | Costruttore con componente assieme derivato
Metodo pubblico | SelInfoItem(DerivedPartComponent) | Costruttore con componente parte derivato
Metodo pubblico | SelInfoItem(Document) | Costruttore con Documento di Inventor.
Metodo pubblico | SelInfoItem(ModelState) | Costruttore con ModelState. Utilizzato quando viene selezionato l'oggetto ms
Metodo pubblico | SelInfoItem(PartBody) | Costruttore con Documento di Inventor.
Metodo pubblico | SelInfoItem(String) | Costruttore con filename. Utilizzato solo per riferimenti da albero documento
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config | Restituisce la configurazione
Proprietà pubblica | DedData | Restituisce l'anagrafica abbinata a questo elemento.
Proprietà pubblica | DedDoc | Restituisce il DedDoc abbinato a questo elemento.
Proprietà pubblica | DocumentIsAssembly | Restituisce se il documento sia un assieme. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsDrawing | Restituisce se il documento sia una messa in tavola. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsModel | Restituisce se il documento sia un modello. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsPart | Restituisce se il documento sia una parte. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsPartFactory | Restituisce se il documento sia una iPartFactory. Ha senso solo se DocumentIsPart = true.
Proprietà pubblica | DocumentIsPresentation | Restituisce se il documento sia una presentazione. Ha senso solo se HasDocument = true.
Proprietà pubblica | HasDedData | Restituisce se l'elemento abbia l'anagrafica.
Proprietà pubblica | HasDedDoc | Restituisce se l'elemento abbia o meno il DedDoc.
Proprietà pubblica | HasDocument | Restituisce se questo elemento abbia il Documento di Inventor.
Proprietà pubblica | HasModelStates | Ritorna true se il documento ha dei model states
Proprietà pubblica | IsCustomModelState | Ritorna vero se il model state è il secondario
Proprietà pubblica | IsDerivedAssemblyComponent | Restituisce se questo elemento sia un componente assieme derivato
Proprietà pubblica | IsDerivedPartComponent | Restituisce se questo elemento sia un componente parte derivato
Proprietà pubblica | IsEditDocument | Restituisce se il documento sia il documento in editazione. Ha senso solo se HasDocument = true.
Proprietà pubblica | IsMainModelState | Ritorna vero se il model state selezionato è il principale
Proprietà pubblica | IsModelState | Restituisce se questo elemento abbia un modelstate associato
Proprietà pubblica | IsOccurrence | Restituisce se questo elemento sia una occorrenza.
Proprietà pubblica | IsPartBody | Restituisce se questo elemento abbia un partbody associato
Proprietà pubblica | IsTopDocument | Restituisce se il documento sia il documento attivo. Ha senso solo se HasDocument = true.
Proprietà pubblica | OccurrenceIsSubstitute | Restituisce se si tratti di una occorrenza sostituto di dettaglio.
Proprietà pubblica | OccurrenceIsSuppressedOrMissing | Restituisce se l'occorrenza, rappresentata da questo elemento, sia mancante. Ha senso solo se IsOccurrence = true.
Proprietà pubblica | OccurrenceIsVirtual | Restituisce se l'occorrenza, rappresentata da questo elemento, sia virtuale. Ha senso solo se IsOccurrence = true.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | InvDerivedAssemblyComponent | Componente assieme derivato
Campo pubblico | InvDerivedPartComponent | Componente parte derivato
Campo pubblico | InvDocument | Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.
Campo pubblico | InvModelState | Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.
Campo pubblico | InvOccurrence | Restituisce l'Occorrenza di Inventor abbinata a questo elemento oppure null se non si tratta di una occorrenza.
Campo pubblico | PartBody | Restituisce l'oggetto partbody in caso di selezione specifica
Campo pubblico | RawReferenceFileName | Filename di una reference extra cad
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore SelInfoItem

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | SelInfoItem(ComponentOccurrence) | Costruttore con Occorrenza di Inventor.
Metodo pubblico | SelInfoItem(DerivedAssemblyComponent) | Costruttore con componente assieme derivato
Metodo pubblico | SelInfoItem(DerivedPartComponent) | Costruttore con componente parte derivato
Metodo pubblico | SelInfoItem(Document) | Costruttore con Documento di Inventor.
Metodo pubblico | SelInfoItem(ModelState) | Costruttore con ModelState. Utilizzato quando viene selezionato l'oggetto ms
Metodo pubblico | SelInfoItem(PartBody) | Costruttore con Documento di Inventor.
Metodo pubblico | SelInfoItem(String) | Costruttore con filename. Utilizzato solo per riferimenti da albero documento
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (ComponentOccurrence)
Costruttore con Occorrenza di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    ComponentOccurrence occ
)
Public Sub New (
    occ As ComponentOccurrence
)
public:
SelInfoItem(
    ComponentOccurrence^ occ
)
new :
        occ : ComponentOccurrence -> SelInfoItem

Parametri

occ
Tipo: ComponentOccurrence
Occorrenza da utilizzare per l'inizializzazione.
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (DerivedAssemblyComponent)
Costruttore con componente assieme derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    DerivedAssemblyComponent dac
)
Public Sub New (
    dac As DerivedAssemblyComponent
)
public:
SelInfoItem(
    DerivedAssemblyComponent^ dac
)
new :
        dac : DerivedAssemblyComponent -> SelInfoItem

Parametri

dac
Tipo: DerivedAssemblyComponent
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (DerivedPartComponent)
Costruttore con componente parte derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    DerivedPartComponent dpc
)
Public Sub New (
    dpc As DerivedPartComponent
)
public:
SelInfoItem(
    DerivedPartComponent^ dpc
)
new :
        dpc : DerivedPartComponent -> SelInfoItem

Parametri

dpc
Tipo: DerivedPartComponent
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (Document)
Costruttore con Documento di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    Document doc
)
Public Sub New (
    doc As Document
)
public:
SelInfoItem(
    Document^ doc
)
new :
        doc : Document -> SelInfoItem

Parametri

doc
Tipo: Document
Documento da utilizzare per l'inizializzazione.
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (ModelState)
Costruttore con ModelState. Utilizzato quando viene selezionato l'oggetto ms

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    ModelState ms
)
Public Sub New (
    ms As ModelState
)
public:
SelInfoItem(
    ModelState^ ms
)
new :
        ms : ModelState -> SelInfoItem

Parametri

ms
Tipo: ModelState
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (PartBody)
Costruttore con Documento di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    PartBody body
)
Public Sub New (
    body As PartBody
)
public:
SelInfoItem(
    PartBody^ body
)
new :
        body : PartBody -> SelInfoItem

Parametri

body
Tipo: PartBody
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Costruttore SelInfoItem (String)
Costruttore con filename. Utilizzato solo per riferimenti da albero documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItem(
    string fn
)
Public Sub New (
    fn As String
)
public:
SelInfoItem(
    String^ fn
)
new :
        fn : string -> SelInfoItem

Parametri

fn
Tipo: SystemString
Filename utilizzato per ricavare documento ed anagrafica
Vedi anche

Documentazione

Classe SelInfoItem
Overload di SelInfoItem
Namespace DedNetInv


Proprietà di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Config | Restituisce la configurazione
Proprietà pubblica | DedData | Restituisce l'anagrafica abbinata a questo elemento.
Proprietà pubblica | DedDoc | Restituisce il DedDoc abbinato a questo elemento.
Proprietà pubblica | DocumentIsAssembly | Restituisce se il documento sia un assieme. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsDrawing | Restituisce se il documento sia una messa in tavola. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsModel | Restituisce se il documento sia un modello. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsPart | Restituisce se il documento sia una parte. Ha senso solo se HasDocument = true.
Proprietà pubblica | DocumentIsPartFactory | Restituisce se il documento sia una iPartFactory. Ha senso solo se DocumentIsPart = true.
Proprietà pubblica | DocumentIsPresentation | Restituisce se il documento sia una presentazione. Ha senso solo se HasDocument = true.
Proprietà pubblica | HasDedData | Restituisce se l'elemento abbia l'anagrafica.
Proprietà pubblica | HasDedDoc | Restituisce se l'elemento abbia o meno il DedDoc.
Proprietà pubblica | HasDocument | Restituisce se questo elemento abbia il Documento di Inventor.
Proprietà pubblica | HasModelStates | Ritorna true se il documento ha dei model states
Proprietà pubblica | IsCustomModelState | Ritorna vero se il model state è il secondario
Proprietà pubblica | IsDerivedAssemblyComponent | Restituisce se questo elemento sia un componente assieme derivato
Proprietà pubblica | IsDerivedPartComponent | Restituisce se questo elemento sia un componente parte derivato
Proprietà pubblica | IsEditDocument | Restituisce se il documento sia il documento in editazione. Ha senso solo se HasDocument = true.
Proprietà pubblica | IsMainModelState | Ritorna vero se il model state selezionato è il principale
Proprietà pubblica | IsModelState | Restituisce se questo elemento abbia un modelstate associato
Proprietà pubblica | IsOccurrence | Restituisce se questo elemento sia una occorrenza.
Proprietà pubblica | IsPartBody | Restituisce se questo elemento abbia un partbody associato
Proprietà pubblica | IsTopDocument | Restituisce se il documento sia il documento attivo. Ha senso solo se HasDocument = true.
Proprietà pubblica | OccurrenceIsSubstitute | Restituisce se si tratti di una occorrenza sostituto di dettaglio.
Proprietà pubblica | OccurrenceIsSuppressedOrMissing | Restituisce se l'occorrenza, rappresentata da questo elemento, sia mancante. Ha senso solo se IsOccurrence = true.
Proprietà pubblica | OccurrenceIsVirtual | Restituisce se l'occorrenza, rappresentata da questo elemento, sia virtuale. Ha senso solo se IsOccurrence = true.
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.Config

Proprietà SelInfoItemConfig

Restituisce la configurazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Config { get; }
Public ReadOnly Property Config As String
    Get
public:
property String^ Config {
    String^ get ();
}
member Config : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DedData

Proprietà SelInfoItemDedData

Restituisce l'anagrafica abbinata a questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; }
Public ReadOnly Property DedData As DedData
    Get
public:
property DedData^ DedData {
    DedData^ get ();
}
member DedData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DedDoc

Proprietà SelInfoItemDedDoc

Restituisce il DedDoc abbinato a questo elemento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsAssembly

Proprietà SelInfoItemDocumentIsAssembly

Restituisce se il documento sia un assieme. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsAssembly { get; }
Public ReadOnly Property DocumentIsAssembly As Boolean
    Get
public:
property bool DocumentIsAssembly {
    bool get ();
}
member DocumentIsAssembly : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsDrawing

Proprietà SelInfoItemDocumentIsDrawing

Restituisce se il documento sia una messa in tavola. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsDrawing { get; }
Public ReadOnly Property DocumentIsDrawing As Boolean
    Get
public:
property bool DocumentIsDrawing {
    bool get ();
}
member DocumentIsDrawing : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsModel

Proprietà SelInfoItemDocumentIsModel

Restituisce se il documento sia un modello. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsModel { get; }
Public ReadOnly Property DocumentIsModel As Boolean
    Get
public:
property bool DocumentIsModel {
    bool get ();
}
member DocumentIsModel : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsPart

Proprietà SelInfoItemDocumentIsPart

Restituisce se il documento sia una parte. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsPart { get; }
Public ReadOnly Property DocumentIsPart As Boolean
    Get
public:
property bool DocumentIsPart {
    bool get ();
}
member DocumentIsPart : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsPartFactory

Proprietà SelInfoItemDocumentIsPartFactory

Restituisce se il documento sia una iPartFactory. Ha senso solo se DocumentIsPart = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsPartFactory { get; }
Public ReadOnly Property DocumentIsPartFactory As Boolean
    Get
public:
property bool DocumentIsPartFactory {
    bool get ();
}
member DocumentIsPartFactory : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.DocumentIsPresentation

Proprietà SelInfoItemDocumentIsPresentation

Restituisce se il documento sia una presentazione. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocumentIsPresentation { get; }
Public ReadOnly Property DocumentIsPresentation As Boolean
    Get
public:
property bool DocumentIsPresentation {
    bool get ();
}
member DocumentIsPresentation : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.HasDedData

Proprietà SelInfoItemHasDedData

Restituisce se l'elemento abbia l'anagrafica.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDedData { get; }
Public ReadOnly Property HasDedData As Boolean
    Get
public:
property bool HasDedData {
    bool get ();
}
member HasDedData : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.HasDedDoc

Proprietà SelInfoItemHasDedDoc

Restituisce se l'elemento abbia o meno il DedDoc.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDedDoc { get; }
Public ReadOnly Property HasDedDoc As Boolean
    Get
public:
property bool HasDedDoc {
    bool get ();
}
member HasDedDoc : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.HasDocument

Proprietà SelInfoItemHasDocument

Restituisce se questo elemento abbia il Documento di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasDocument { get; }
Public ReadOnly Property HasDocument As Boolean
    Get
public:
property bool HasDocument {
    bool get ();
}
member HasDocument : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.HasModelStates

Proprietà SelInfoItemHasModelStates

Ritorna true se il documento ha dei model states

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasModelStates { get; }
Public ReadOnly Property HasModelStates As Boolean
    Get
public:
property bool HasModelStates {
    bool get ();
}
member HasModelStates : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsCustomModelState

Proprietà SelInfoItemIsCustomModelState

Ritorna vero se il model state è il secondario

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCustomModelState { get; }
Public ReadOnly Property IsCustomModelState As Boolean
    Get
public:
property bool IsCustomModelState {
    bool get ();
}
member IsCustomModelState : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsDerivedAssemblyComponent

Proprietà SelInfoItemIsDerivedAssemblyComponent

Restituisce se questo elemento sia un componente assieme derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDerivedAssemblyComponent { get; }
Public ReadOnly Property IsDerivedAssemblyComponent As Boolean
    Get
public:
property bool IsDerivedAssemblyComponent {
    bool get ();
}
member IsDerivedAssemblyComponent : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsDerivedPartComponent

Proprietà SelInfoItemIsDerivedPartComponent

Restituisce se questo elemento sia un componente parte derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDerivedPartComponent { get; }
Public ReadOnly Property IsDerivedPartComponent As Boolean
    Get
public:
property bool IsDerivedPartComponent {
    bool get ();
}
member IsDerivedPartComponent : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsEditDocument

Proprietà SelInfoItemIsEditDocument

Restituisce se il documento sia il documento in editazione. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsEditDocument { get; }
Public ReadOnly Property IsEditDocument As Boolean
    Get
public:
property bool IsEditDocument {
    bool get ();
}
member IsEditDocument : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsMainModelState

Proprietà SelInfoItemIsMainModelState

Ritorna vero se il model state selezionato è il principale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsMainModelState { get; }
Public ReadOnly Property IsMainModelState As Boolean
    Get
public:
property bool IsMainModelState {
    bool get ();
}
member IsMainModelState : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsModelState

Proprietà SelInfoItemIsModelState

Restituisce se questo elemento abbia un modelstate associato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsModelState { get; }
Public ReadOnly Property IsModelState As Boolean
    Get
public:
property bool IsModelState {
    bool get ();
}
member IsModelState : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsOccurrence

Proprietà SelInfoItemIsOccurrence

Restituisce se questo elemento sia una occorrenza.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsOccurrence { get; }
Public ReadOnly Property IsOccurrence As Boolean
    Get
public:
property bool IsOccurrence {
    bool get ();
}
member IsOccurrence : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsPartBody

Proprietà SelInfoItemIsPartBody

Restituisce se questo elemento abbia un partbody associato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsPartBody { get; }
Public ReadOnly Property IsPartBody As Boolean
    Get
public:
property bool IsPartBody {
    bool get ();
}
member IsPartBody : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.IsTopDocument

Proprietà SelInfoItemIsTopDocument

Restituisce se il documento sia il documento attivo. Ha senso solo se HasDocument = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsTopDocument { get; }
Public ReadOnly Property IsTopDocument As Boolean
    Get
public:
property bool IsTopDocument {
    bool get ();
}
member IsTopDocument : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.OccurrenceIsSubstitute

Proprietà SelInfoItemOccurrenceIsSubstitute

Restituisce se si tratti di una occorrenza sostituto di dettaglio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OccurrenceIsSubstitute { get; }
Public ReadOnly Property OccurrenceIsSubstitute As Boolean
    Get
public:
property bool OccurrenceIsSubstitute {
    bool get ();
}
member OccurrenceIsSubstitute : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.OccurrenceIsSuppressedOrMissing

Proprietà SelInfoItemOccurrenceIsSuppressedOrMissing

Restituisce se l'occorrenza, rappresentata da questo elemento, sia mancante. Ha senso solo se IsOccurrence = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OccurrenceIsSuppressedOrMissing { get; }
Public ReadOnly Property OccurrenceIsSuppressedOrMissing As Boolean
    Get
public:
property bool OccurrenceIsSuppressedOrMissing {
    bool get ();
}
member OccurrenceIsSuppressedOrMissing : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Proprietà SelInfoItem.OccurrenceIsVirtual

Proprietà SelInfoItemOccurrenceIsVirtual

Restituisce se l'occorrenza, rappresentata da questo elemento, sia virtuale. Ha senso solo se IsOccurrence = true.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OccurrenceIsVirtual { get; }
Public ReadOnly Property OccurrenceIsVirtual As Boolean
    Get
public:
property bool OccurrenceIsVirtual {
    bool get ();
}
member OccurrenceIsVirtual : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Metodi di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Metodo SelInfoItem.Equals

Metodo SelInfoItemEquals

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Metodo SelInfoItem.GetHashCode

Metodo SelInfoItemGetHashCode

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Metodo SelInfoItem.ToString

Metodo SelInfoItemToString

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campi di SelInfoItem

Il tipo SelInfoItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | InvDerivedAssemblyComponent | Componente assieme derivato
Campo pubblico | InvDerivedPartComponent | Componente parte derivato
Campo pubblico | InvDocument | Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.
Campo pubblico | InvModelState | Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.
Campo pubblico | InvOccurrence | Restituisce l'Occorrenza di Inventor abbinata a questo elemento oppure null se non si tratta di una occorrenza.
Campo pubblico | PartBody | Restituisce l'oggetto partbody in caso di selezione specifica
Campo pubblico | RawReferenceFileName | Filename di una reference extra cad
Torna su
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.InvDerivedAssemblyComponent

Campo SelInfoItemInvDerivedAssemblyComponent
Componente assieme derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly DerivedAssemblyComponent InvDerivedAssemblyComponent
Public ReadOnly InvDerivedAssemblyComponent As DerivedAssemblyComponent
public:
initonly DerivedAssemblyComponent^ InvDerivedAssemblyComponent
val InvDerivedAssemblyComponent: DerivedAssemblyComponent

Valore del campo

Tipo: DerivedAssemblyComponent
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.InvDerivedPartComponent

Campo SelInfoItemInvDerivedPartComponent
Componente parte derivato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly DerivedPartComponent InvDerivedPartComponent
Public ReadOnly InvDerivedPartComponent As DerivedPartComponent
public:
initonly DerivedPartComponent^ InvDerivedPartComponent
val InvDerivedPartComponent: DerivedPartComponent

Valore del campo

Tipo: DerivedPartComponent
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.InvDocument

Campo SelInfoItemInvDocument
Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly Document InvDocument
Public ReadOnly InvDocument As Document
public:
initonly Document^ InvDocument
val InvDocument: Document

Valore del campo

Tipo: Document
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.InvModelState

Campo SelInfoItemInvModelState
Restituisce il Documento di Inventor abbinato a questo elemento oppure null se per esempio si tratta di una occorrenza senza documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly ModelState InvModelState
Public ReadOnly InvModelState As ModelState
public:
initonly ModelState^ InvModelState
val InvModelState: ModelState

Valore del campo

Tipo: ModelState
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.InvOccurrence

Campo SelInfoItemInvOccurrence
Restituisce l'Occorrenza di Inventor abbinata a questo elemento oppure null se non si tratta di una occorrenza.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly ComponentOccurrence InvOccurrence
Public ReadOnly InvOccurrence As ComponentOccurrence
public:
initonly ComponentOccurrence^ InvOccurrence
val InvOccurrence: ComponentOccurrence

Valore del campo

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.PartBody

Campo SelInfoItemPartBody
Restituisce l'oggetto partbody in caso di selezione specifica

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly PartBody PartBody
Public ReadOnly PartBody As PartBody
public:
initonly PartBody^ PartBody
val PartBody: PartBody

Valore del campo

Tipo: PartBody
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Campo SelInfoItem.RawReferenceFileName

Campo SelInfoItemRawReferenceFileName
Filename di una reference extra cad

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly string RawReferenceFileName
Public ReadOnly RawReferenceFileName As String
public:
initonly String^ RawReferenceFileName
val RawReferenceFileName: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe SelInfoItem
Namespace DedNetInv


Classe SelInfoItemList
Lista di elementi SelInfoItem.
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList SelInfoItem
DedNetInvSelInfoItemList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SelInfoItemList : List<SelInfoItem>
Public Class SelInfoItemList
    Inherits List(Of SelInfoItem)
public ref class SelInfoItemList : public List<SelInfoItem^>
type SelInfoItemList =
    class
        inherit List<SelInfoItem>
    end

Il tipo SelInfoItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SelInfoItemList |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedOccurrencesAreEqual | Restituisce se tutte le occorrenze selezionate siano uguali. Per verificarsi questo caso, devono tutte avere lo stesso documento (file) sottostante e nessuna deve essere virtuale o priva di documento. In più non deve essere selezionato il TopDocument.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore SelInfoItemList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SelInfoItemList()
Public Sub New
public:
SelInfoItemList()
new : unit -> SelInfoItemList
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetInv


Proprietà di SelInfoItemList

Il tipo SelInfoItemList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AllSelectedOccurrencesAreEqual | Restituisce se tutte le occorrenze selezionate siano uguali. Per verificarsi questo caso, devono tutte avere lo stesso documento (file) sottostante e nessuna deve essere virtuale o priva di documento. In più non deve essere selezionato il TopDocument.
Torna su
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetInv


Proprietà SelInfoItemList.AllSelectedOccurrencesAreEqual

Proprietà SelInfoItemListAllSelectedOccurrencesAreEqual

Restituisce se tutte le occorrenze selezionate siano uguali. Per verificarsi questo caso, devono tutte avere lo stesso documento (file) sottostante e nessuna deve essere virtuale o priva di documento. In più non deve essere selezionato il TopDocument.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllSelectedOccurrencesAreEqual { get; }
Public ReadOnly Property AllSelectedOccurrencesAreEqual As Boolean
    Get
public:
property bool AllSelectedOccurrencesAreEqual {
    bool get ();
}
member AllSelectedOccurrencesAreEqual : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SelInfoItemList
Namespace DedNetInv


Enumerazione SpecialStructEnum
Descrive se un documento sia una struttura speciale e se sìis, di che tipo sia. Gli elementi FrameGeneratorContainer, DesignAcceleratorContainer e PipingContainer possono essere effettivamente trovati insieme, mentre tutti gli altri si escludono a vicenda.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum SpecialStructEnum
<FlagsAttribute>
Public Enumeration SpecialStructEnum
[FlagsAttribute]
public enum class SpecialStructEnum
[<FlagsAttribute>]
type SpecialStructEnum
Membri
Nome | Valore | Descrizione
None | 0 |
FrameGeneratorContainer | 1 | Assieme contenente sturttura del Frame Generator.
DesignAcceleratorContainer | 2 | Assieme contenente sturtture del Design Accelerator.
PipingContainer | 4 | Assieme contenente sturtture del Piping.
CableAndHarnessContainer | 8 | Assieme contenente sturtture del Piping.
FrameGeneratorFrameDoc | 16 |
FrameGeneratorSkeletonDoc | 32 |
FrameGeneratorFrameMemberDoc | 64 |
DesignAcceleratorAssembly | 128 |
DesignAcceleratorPart | 256 |
PipingAssembly | 512 |
PipingSubAssembly | 1024 |
PipingPercorso | 2048 |
CableAndHarnessAssembly | 4096 |
CableAndHarnessPart | 8192 |
CableAndHarnessNailboardDrawing | 16384 |
FrameGeneratorFrameEndPlate | 32768 |
Vedi anche

Documentazione

Namespace DedNetInv


Classe Util
Contiene utilità generali per Inventor.
Gerarchia di ereditarietà
SystemObject
DedNetInvUtil

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Util
Public NotInheritable Class Util
public ref class Util abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util =  class end

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AddCommandButton | Funzione che permette di gestire la visualizzazione dei pulsanti all'interno di una barra.
AddPopUpCommandBar | Restituisce o crea la barra dei comandi con il nome passato.
AskMemberSelection | Dato il fullpath di una factory (ipart/iassembly) chiede la selezione di un member Le eventuali eccezioni sono sollevate verso il chiamante
AskUseMasterModelState(ComponentOccurrence, Boolean, String) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare la il model state corrente del documento passato.
AskUseMasterModelState(Document, Boolean, ModelState) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare il model state corrente del documento passato.
AssertActiveDocument | Verifica che sia presente un documento attivo in Inventor e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertDataHasSameRevType | Verifica che il documento non sia già associato in configurazione Default a un'altra anagrafica con tipologia di revisioe differente da quella passata
AssertDataNotHasSameExt | Verifica che l'anagrafica non abbia già collegato un documento con la stessa estensione
AssertDocHasData | Controlla che il documento non sia associato a nessuna anagrafica.
AssertDocHasModelStates | Controlla che il documento abbia effettivamente dei model state
AssertDocHasNotModelStates | Controlla che il documento non presenti dei model state
AssertDocIsAssembly | Controlla che il documento passato non sia Nothing e sia un assieme, altrimenti lancia un'eccezione.
AssertDocIsDrawing | Controlla che il documento passato non sia Nothing e sia una messa in tavola, altrimenti lancia un'eccezione.
AssertDocIsFactory | Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.
AssertDocIsInDb | Controlla che il documento passato sia registrato nel database
AssertDocIsModel | Controlla che il documento passato non sia Nothing e sia un modello, altrimenti lancia un'eccezione. lancia un'eccezione.
AssertDocIsNotEditAllMemberScope | Controlla che il documento non sia in modalità di editazione di tutti i ms
AssertDocIsNotInMsSubstitute | Controllo che il documento non sia attivo in un ms sostituto
AssertDocIsNotNothing | Controlla che il documento non sia Nothing, altrimenti lancia un'eccezione.
AssertDocIsNotTopDocument | Controlla che il documento passato non sia Nothing e non sia la parte principale del documento.
AssertDocIsPart | Controlla che il documento passato non sia Nothing e sia una parte, altrimenti lancia un'eccezione.
AssertDocIsPartFactory | Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.
AssertDocIsSavableSpecialStruct | Verifica se il documento sia una struttura speciale salvabile, in caso contrario solleva una eccezione.
AssertDocIsTopDocument | Controlla che il documento passato non sia Nothing e sia la parte principale del documento.
AssertDocIsValidOcc | Controlla che il documento passato non sia Nothing, altrimenti, essendo derivato da una occorrenza, visualizza un messaggio.
AssertDocument | Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertEditDocisTopDocument | Controlla che il documento in editazione sia il
AssertOccurrenceIsNotSubstitute | Solleva una eccezione se l'occorrenza passata è un sostituto.
AssertOccurrenceIsNotSuppressedOrMissing | Solleva una eccezione se l'occorrenza passata è soppressa o mancante.
AssertOccurrenceIsNotVirtual | Solleva una eccezione se l'occorrenza passata è virtuale.
AssertOccurrenceIsNotWelds | Solleva una eccezione se l'occorrenza passata è una saldatura.
AssertReadDataFromInvDoc | Viene utilizzata la funzione ReadDataFromInvDoc() per avere l'anagrafica del documento passato. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.
AssertReadDataFromInvDocOrMatchingModelState | Viene utilizzata la funzione che controlla l'anagrafica dal model state corrente. Può essere anche una anagrafica di un altra configurazione se contenuta nelle proprietà.
AssertReadDataFromInvOcc | Viene utilizzata la funzione ReadDataFromInvOcc() per avere l'anagrafica dell'occorrenza passata. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
AttrListEnabler | Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.
CalcolaNomeSostituto | Ritorna il nome del sostituto dato il nome completo del modello di riferimento e la lista dei sostituti già denominati
CheckPositionalRepresentation | Controllo le impostazioni della rappresentazione di posizione nel documento e opzionalmente dei documenti referenziati. Se l'utente conferma imposta la rappresentazione di posizione principale. Opzionalmente è possibile farsi tornare la rappresentazione corrente del documento principale.
CloseWindow | Chiude la finestra identificata dall'hadle passato.
CopiaSostituti | Copia nella destinazione tutti i sostituti.
CopiaStruttureSpeciali | Copia tutti i file appartenenti alle strutture speciali presenti sotto all'elemento passato. Lavora in modo ricorsivo.
CopyOLEandExtraCadReference | Copia i riferimenti OLE ed Extra Cad del documento passato. Da utilizzare nei delegate...
DataToInvDoc | Scrive tutti gli attributi di anagrafica in un documento.
DataToInvFile | Scrive tutti gli attributi di anagrafica in un file di Inventor.
DataToInvOcc | Scrive tutti gli attributi di anagrafica in un documento.
DataToModelState | Scrive l'anagrafica sul model state passato. Se esiste il documento utilizza il metodo classico, diversamente sfrutta la scrittura in tabella
DedDataPart2InvDoc | Scrive i dati presenti nel DedDataPart nel documento.
DedDataPart2InvFile | Scrive i dati presenti nel DedDataPart nel file di Inventor ( tramite apprentice ).
DedDataPart2InvOcc | Scrive i dati presenti nel DedDataPart nell'occorrenza.
DedDataPart2ModelState | Scrivi i dati presenti nel DedDataPart nel model state
DedDataPart2PartBody | Scrive i dati presenti nel DedDataPart nel partBody.
DocumentHasDerivedReferences | Ritorna true se il documento ha dei riferimenti di derivazione
DocumentIsAssembly | Restituisce se il documento passato è IAM o IPT.
DocumentIsDrawing | Restituisce se il documento passato è IDW o DWG.
DocumentIsDrawingOrPresentation | Restituisce se il documento passato è tavola o presentazione.
DocumentIsModel | Restituisce se il documento passato è IAM o IPT.
DocumentIsModelOrPresentation | Restituisce se il documento passato è tavola o presentazione.
DocumentIsOpenVisible | Ritorna true se il documento è aperto in modo visibile
DocumentIsPart | Restituisce se il documento passato è IPT.
DocumentIsPresentation | Restituisce se il documento passato è IPN.
EliminaOwnerShipStruttureSpeciali | Ripristina le caratteristiche di ownership dei componenti di struttura speciale
FileIsAssembly | Verifica e restituisce se il file passato sia o meno un file di assime.
FileIsInventor | Verifica e restituisce se il file passato sia o meno un file di interesse per Inventor.
FileIsInventorDwg | Verifica e restituisce se il file passato sia o meno un file dwg di Inventor.
FileIsModel | Verifica e restituisce se il file passato sia o meno un file di modello di inventor.
FileIsPart | Verifica e restituisce se il file passato sia o meno un file di parte.
FileIsPresentation | Verifica e restituisce se il file passato sia o meno un file di assime.
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
FindDocumentInCollection | Cerca e restituisce il documento abbinato ad un file. Restituisce null se non lo trova. Lo cerca nella collezione di documenti passati (Documents oppure VisibleDocuments).
FindInventorDocument(String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
FindInventorDocument(String, String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
FindInventorFile | Cerca tra i file aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il file non risulta aperto in Inventor.
FindInventorMemberDocument(String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
FindInventorMemberDocument(String, String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName. Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
FormatAttr | Legge e restituisce il valore di un attributo dal documento/occorrenza di inventor, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo.
GetActiveLOD | Restituisce il livello di dettaglio attivo.
GetActiveModelState | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActiveModelStateKey | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActiveModelStateName | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActualModelStateName | Dato un filename ed una configurazione, ritorna l'effettivo nome del model state
GetAllInventorFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetApplicationUserVer | Restituisce la versione di inventor da visualizzare all'utente.
GetAssembly | Restituisce il documento convertito in AssemblyDocument oppure null se non riesce.
GetAssociativeForeignFilename | Restituisce se il documento passato è di modello.
GetAttrList | Restituisce la lista di attributi richiesti, abbinati all'anagrafica passata. L'anagrafica può essere anche null, in tal caso viene restituita la lista degli attributi di Tutti i tipi.
GetBomStructure | Restituisce la BOMStructureEnum del documento passato.
GetCfgStructure | Restituisce la struttura delle configurazioni del documento passato.
GetChildControls | Ritorna una lista di controlli contenuti nella finestra passata.
GetConfigName(ModelState) | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetConfigName(String) | Dato il nome di una configurazione, Restituisce il nome secondo lo standard DED+
GetDataFromDedDoc | Ritorna l'anagrafica associata al documento
GetDerivedDocs | Restituisce la lista dei documenti derivati di una parte (.ipt). Se non trova alcun documento restituisce la lista vuota.
GetDesktopWindow |
GetDrawing | Restituisce il documento convertito in DrawingDocument oppure null se non riesce.
GetEmbeddedIcon | Data l'estensione restituisce l'icona dell'oggetto embedded (Anycad)
GetFullDocumentNameOnOpenOptions | In caso di assieme ritorna il full document name compatibilmente con le impostazioni di livello di dettaglio in apertura. L'opzione può essere principale, tutti i comp. soppressi, tutte le parti soppresse ed ultimo attivo.
GetHWndText | Ritorna la caption della finestra / controllo.
GetLastDataRowVer(Document) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(ModelState) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura.
GetLastDataRowVer(String) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetMasterLOD | Restituisce il livello di dettaglio principale.
GetMasterModelState | Se esiste, dato il documento ritorna il master model state
GetModelStateKey | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetModelStateName | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetModelStateNames | Ritorna i model states del documento. E' sempre l'elenco dei model state della factory
GetModelStates | Ritorna i model states del documento. E' sempre l'elenco dei model state della factory
GetNastranInCADReferences(Document) | Ritorna la lista dei riferimenti Nastran dato il documento passato
GetNastranInCADReferences(String) | Ritorna la lista dei riferimenti Nastran dato il filename passato
GetOccurrenceNameWithoutPosNumber | Ritorna il nome dell'occorrenza privato della posizione
GetPart | Restituisce il documento convertito in PartDocument oppure null se non riesce.
GetPresentation | Restituisce il documento convertito in PresentationDocument oppure null se non riesce.
GetPreview | Ritorna l'anteprima del documento sotto forma di bitmap
GetQsPublisherOutName | Dato il documento attivo e la configurazione del publisher calcolo il nome di pubblicazione in base alle regole del publish manager eventualmente personalizzate tramite evento. Anche in caso di formati potenzialmente multifoglio ritorno il nome completo. Sarà poi il publisher a fornire a posteriori la formattazione corretta.
GetSafeReferenceFullFileName | Dato il descrittore ritorna il percorso del riferimento più coerente possibile col progetto. ResolvedFullFileName è però più affidabile nel caso Inventor abbia risolto tramite path del progetto in un percorso diverso dall'ultimo usato (secondo Barbara Hann).
GetSmallFileIcon | Data la tipologia di documento ritorna l'icona dalla risorse del progetto
HasModelStates | Ritorna vero se il documento ha dei model state
ImpostaDatiClonazioneStrutture | Imposta ricorsivamente, da clonare gli elementi delle strutture speciali, compresi i dati necessari alla clonazione.
InvDoc2DedDataPart(Document) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere ed avere l'elenco attributi.
InvDoc2DedDataPart(Document, DedAttrList) | Legge i dati dal documento e li inserisce in una DedDataPart. Legge direttamente l'elenco attributi dal parametro passato.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum, Boolean) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvDoc2DedDoc | Legge il percorso del documento passato e ne resituisce il DedDoc. Se il documento non è ancora salvato o se non è nel Database restituisce null. Ignora eventuali errori.
InvDocAttrMatchData | Controlla se gli attributi ID e REV letti nel documento coincidono con quelli associati all'anagrafica passata
InvFile2DedDataPart(String, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, DedAttrList) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum) | Legge i dati dal file di inventor secondo la tiplogia richiesta e li inserisce in una DedDataPart.
InvFileAttrMatchData | Controlla se gli attributi ID e REV letti nel file coincidono con quelli associati all'anagrafica passata
InvOcc2DedDataPart(ComponentOccurrence, DedAttrList) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Utilizza la lista di attributi passata
InvOcc2DedDataPart(ComponentOccurrence, UtilDataAttrTypeEnum) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvOcc2DedDoc | Legge il percorso dell'occorrenza passata e ne resituisce il DedDoc. Se l'occorrenza non è ancora salvata o se non è nel Database o se non ha associato alcun file, restituisce null. Ignora eventuali errori.
IsAnyCadReferenceName | Dato il path del riferimento padre e il path del file in oggetto ritorna vero se si tratta di un potenziale documento di anycad.
IsAssemblyFactory | Restituisce vero se il documento passato è una Part Factory
IsAssemblyMember | Restituisce vero se il documento passato è un Part Member
IsCableHarnessDocument | Dato il documento in ingresso determina se si tratta di un documento di cavi e cablaggi.
IsDerivedDoc | Stabilisce se il documento padre è un derivato del documento figlio
IsDrawing | Restituisce se il documento passato sia una messa in tavola.
IsEmbeddedDocument | Restituisce se il documento passato è di modello.
IsFactoryAssetInstance | Restituisce vero se si tratta di un documento rappresentante un asset della factory
IsiAssemblyOccurrence | Restituisce vero se l'occorrenza si trova nel contesto di un
IsInventorDwg | Restituisce se il documento sia un dwg di inventor.
IsMasterModelState | Ritorna vero se il documento è in configurazione master
IsModel | Restituisce se il documento passato è di modello. Se fallisce è quasi sicuramente per la corruzione del documento. L'eccezione viene comunque registrata.
IsModelStateFactory | Ritorna vero se il documento è il model state factory
IsModelStateMember | Ritorna vero se il documento è il model state member
IsPartFactory | Restituisce vero se il documento passato è una Part Factory
IsPartMember | Restituisce vero se il documento passato è un Part Member
IsPresentation | Restituisce se il documento passato sia una presentazione.
IsRoutedSystemDocument | Dato il documento in ingresso determina se si tratta di un documento di piping.
IsSubstituteDescriptor | Identifica se il document descriptor passato rappresenta un sosituto.
IsSubstituteModelState | Ritorna vero se il documento è in una configurazione sostituto
IsSubstitutePart | Controlla se la parte passata è un sostituto. Dalla 2022 il comodissimo flag non è più impostato.
IsUnreferencedSubstituteModelState | Ritorna vero se il documento è in una configurazione sostituto
LogTubeAndPipeAddinActivationStatus | Logga lo stato di attivazione del plugin di tubi e tubature
MakeStructFileName | Dato il nome di partenza genera il nuovo nome da assegnare al file della struttura speciale. Verifica se il prefisso, il nome del padre di partenza ed il numero random sono presenti. In tal caso li elimina per ricrearli in base ai parametri passati.
MigrateFile | Migra il file alla release corrente di inventor. Ignora lo stato di sola lettura e lo stato del documento. E' al servizione dell'aggiornamento riferimenti nel caso di debba procedere tramite apprentice.
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum, Boolean) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
OnFileResolutionStruttureSpeciali | Core delle operazioni che si devono effettuare durante l'OnFileResolution per la sostituzione delle strutture speciali.
Open(String, Boolean, String) | Apre il file passato e ne restituisce il documento. Se la configurazione passata è nulla o vuota viene aperta la configurazione leggendo le opzioni di Inventor (Last o Master). Se viene passata la configurazione ma non esiste viene aperta sempre la Master. Solleva una eccezione se non riesce ad aprirlo.
Open(String, Boolean, DedData, DedDoc, String) |
OpenWithOptions | Apre il file passato e ne restituisce il documento. Se la configurazione passata non esiste o è nulla viene aperto sempre in Master.
OrderDocumentList | Riordino il tutto in modo da ottenere il seguente ordinamento : iam/inest - ipt - ipn - idw.
PartBody2DedDataPart | Legge i dati dal partbody e li inserisce in un DedDataPart
PartHasMultipleSolidBodies | Ritorna vero se il documento di tipo 'parte' è costituito da più di un body
PathIsLibrary | Verifica se il percorso sia o meno di libreria.
PathIsRootLibrary | Verifica se il percorso sia in una root libreria.
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllProperties(Document) | Legge tutte le proprietà del documento.
ReadAllProperties(String) | Legge tutte le proprietà del documento.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromInvDoc(Document, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvDoc(Document, String, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvDocOrMatchingModelState | Prova prima a reperire l'anagrafica usando ReadDataFromInvDoc con configurazione specifica se non trova nulla allora fa un controllo più leggero senza usare la configurazione (serve per reperire l'anagrafica anche delle rappresentazioni che non sono direttamente associate all'anagrafica)
ReadDataFromInvDocProperties | Legge l'anagrafica solamente dagli attributi del documento di Inventor
ReadDataFromInvFile | Legge il dedid ed il dedrev da un file di Inventor e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvFileProperties | Legge l'anagrafica solamente dagli attributi del file
ReadDataFromInvOcc | Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvOccOrMatchingModelState | Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvOccProperties | Legge l'anagrafica solamente dagli attributi dell'ocorenza di Inventor.
ReadDataFromModelState | Legge l'anagrafica dal model state. Se il documento esiste, utilizza quello in modo tradizionale. Se il documento non esiste, preleva l'anagrafica associata tramite il legame documentale
ReadDataFromPartBodyProperties | Legge l'anagrafica solamente dagli attributi del documento di Inventor
ReadSubstituteList | Legge il documento e se si tratta di un assieme, cerca tutti i sostituti di dettaglio presenti. Li restituisce in una lista sempre inizializzata ed eventualmente vuota. ATTENZIONE! Sulla 2022 ha senso solo per versioni inferiori alla 2022.2 diversamente non sarà nemmeno chiamata
RefreshAllDocuments | Esegue un refresh di tutti i documenti in memoria. Di default inventor è silenziato
RemoveHiddenAttribute | Rimuove l'attributo nascosto
ReplaceAllDerivedDocumentReferences | Sostituisce tutti i componenti derivati con il file passato
ReplaceDerivedDocumentReference | Sostituisce il componente derivato specificato con il file passato. Se il file non viene trovato non sostituisce niente
RipristinaDocumentiStruttureSpeciali | Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.
RipristinaOwnerShipStruttureSpeciali | Ripristina le caratteristiche di ownership dei componenti di struttura speciale
RipristinaPartNumberStruttureSpeciali | Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.
Save | Salva il documento su se stesso con tutte le sue dipendenze.
SaveAs | Salva il documento passato nella posizione specificata. Effettua un SaveAs oppure un SaveCopyAs in base all'opzione.
SaveDistBomStructureAllowed | Restituisce true se è consentito il salvataggio della distinta in base alle impostazioni utente e alla bomstructure del documento .
SetDeferUpdates | In caso di documento tavola imposta il posticipa aggiornamenti. Diversamente non fa niente
SetLastDataRowVer(Document, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(String, Guid) | Imposta nel file di Inventor il rowver utilizzato per aggiornare i dati nel documento. La scrittura viene eseguita solo se necessario.
SetOnFileDirtyFlags | Setta i semafori dell'onFileDirty in base al comportamento passato
SostituisciAssiemeInSostituto | Sostituisce l'eventuale riferimento dell'assieme nelle parti dei sostituti di dettaglio dell'assieme stesso.
SostituisciComponentiStruttureSpeciali | Sostituisce tutti i sotto-componenti delle strutture speciali dal documento passato.
SostituisciSostituti | Sostituisce tutti i sostituti di livello di dettaglio dell'elemento passato.
SostituisciSostitutoSingolo | Sostituisce il sostituto di dettaglio nell'assieme passato.
SubMenuExists | Metodo che ritorna 0 se il sottomenu non è presente nella CommandBar, 1 altrimenti.
UpdateProjectLibraryPaths | Aggiorna
UpdateReference | Scorre tutte le dipendenze di primo livello di un documento e le sostituisce con la nuova destinazione.
UpdateSingleDocumentOLEReference | Funzione di aggiornamento di una reference su singolo documento
UpdateSingleDocumentReference | Funzione di aggiornamento di una reference su singolo documento
UpdateSingleFullDocumentNameReference | Funzione di aggiornamento di una reference su singolo documento
WriteAllProperties(DedDoc) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, Document) | Scrive tutte le proprietà del documento nel Database
WriteAttr | Scrive il valore di un attributo nel documento/occorrenza di inventor, convertendolo prima in testo in base al tipo dati dell'attributo.
Torna su
Campi
Nome | Descrizione
_dataTimeMin |
ActiveProjectLibraryPaths | Cache dei percorsi di libreria del progetto
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Metodi di Util

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AddCommandButton | Funzione che permette di gestire la visualizzazione dei pulsanti all'interno di una barra.
AddPopUpCommandBar | Restituisce o crea la barra dei comandi con il nome passato.
AskMemberSelection | Dato il fullpath di una factory (ipart/iassembly) chiede la selezione di un member Le eventuali eccezioni sono sollevate verso il chiamante
AskUseMasterModelState(ComponentOccurrence, Boolean, String) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare la il model state corrente del documento passato.
AskUseMasterModelState(Document, Boolean, ModelState) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare il model state corrente del documento passato.
AssertActiveDocument | Verifica che sia presente un documento attivo in Inventor e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertDataHasSameRevType | Verifica che il documento non sia già associato in configurazione Default a un'altra anagrafica con tipologia di revisioe differente da quella passata
AssertDataNotHasSameExt | Verifica che l'anagrafica non abbia già collegato un documento con la stessa estensione
AssertDocHasData | Controlla che il documento non sia associato a nessuna anagrafica.
AssertDocHasModelStates | Controlla che il documento abbia effettivamente dei model state
AssertDocHasNotModelStates | Controlla che il documento non presenti dei model state
AssertDocIsAssembly | Controlla che il documento passato non sia Nothing e sia un assieme, altrimenti lancia un'eccezione.
AssertDocIsDrawing | Controlla che il documento passato non sia Nothing e sia una messa in tavola, altrimenti lancia un'eccezione.
AssertDocIsFactory | Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.
AssertDocIsInDb | Controlla che il documento passato sia registrato nel database
AssertDocIsModel | Controlla che il documento passato non sia Nothing e sia un modello, altrimenti lancia un'eccezione. lancia un'eccezione.
AssertDocIsNotEditAllMemberScope | Controlla che il documento non sia in modalità di editazione di tutti i ms
AssertDocIsNotInMsSubstitute | Controllo che il documento non sia attivo in un ms sostituto
AssertDocIsNotNothing | Controlla che il documento non sia Nothing, altrimenti lancia un'eccezione.
AssertDocIsNotTopDocument | Controlla che il documento passato non sia Nothing e non sia la parte principale del documento.
AssertDocIsPart | Controlla che il documento passato non sia Nothing e sia una parte, altrimenti lancia un'eccezione.
AssertDocIsPartFactory | Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.
AssertDocIsSavableSpecialStruct | Verifica se il documento sia una struttura speciale salvabile, in caso contrario solleva una eccezione.
AssertDocIsTopDocument | Controlla che il documento passato non sia Nothing e sia la parte principale del documento.
AssertDocIsValidOcc | Controlla che il documento passato non sia Nothing, altrimenti, essendo derivato da una occorrenza, visualizza un messaggio.
AssertDocument | Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertEditDocisTopDocument | Controlla che il documento in editazione sia il
AssertOccurrenceIsNotSubstitute | Solleva una eccezione se l'occorrenza passata è un sostituto.
AssertOccurrenceIsNotSuppressedOrMissing | Solleva una eccezione se l'occorrenza passata è soppressa o mancante.
AssertOccurrenceIsNotVirtual | Solleva una eccezione se l'occorrenza passata è virtuale.
AssertOccurrenceIsNotWelds | Solleva una eccezione se l'occorrenza passata è una saldatura.
AssertReadDataFromInvDoc | Viene utilizzata la funzione ReadDataFromInvDoc() per avere l'anagrafica del documento passato. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.
AssertReadDataFromInvDocOrMatchingModelState | Viene utilizzata la funzione che controlla l'anagrafica dal model state corrente. Può essere anche una anagrafica di un altra configurazione se contenuta nelle proprietà.
AssertReadDataFromInvOcc | Viene utilizzata la funzione ReadDataFromInvOcc() per avere l'anagrafica dell'occorrenza passata. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
AttrListEnabler | Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.
CalcolaNomeSostituto | Ritorna il nome del sostituto dato il nome completo del modello di riferimento e la lista dei sostituti già denominati
CheckPositionalRepresentation | Controllo le impostazioni della rappresentazione di posizione nel documento e opzionalmente dei documenti referenziati. Se l'utente conferma imposta la rappresentazione di posizione principale. Opzionalmente è possibile farsi tornare la rappresentazione corrente del documento principale.
CloseWindow | Chiude la finestra identificata dall'hadle passato.
CopiaSostituti | Copia nella destinazione tutti i sostituti.
CopiaStruttureSpeciali | Copia tutti i file appartenenti alle strutture speciali presenti sotto all'elemento passato. Lavora in modo ricorsivo.
CopyOLEandExtraCadReference | Copia i riferimenti OLE ed Extra Cad del documento passato. Da utilizzare nei delegate...
DataToInvDoc | Scrive tutti gli attributi di anagrafica in un documento.
DataToInvFile | Scrive tutti gli attributi di anagrafica in un file di Inventor.
DataToInvOcc | Scrive tutti gli attributi di anagrafica in un documento.
DataToModelState | Scrive l'anagrafica sul model state passato. Se esiste il documento utilizza il metodo classico, diversamente sfrutta la scrittura in tabella
DedDataPart2InvDoc | Scrive i dati presenti nel DedDataPart nel documento.
DedDataPart2InvFile | Scrive i dati presenti nel DedDataPart nel file di Inventor ( tramite apprentice ).
DedDataPart2InvOcc | Scrive i dati presenti nel DedDataPart nell'occorrenza.
DedDataPart2ModelState | Scrivi i dati presenti nel DedDataPart nel model state
DedDataPart2PartBody | Scrive i dati presenti nel DedDataPart nel partBody.
DocumentHasDerivedReferences | Ritorna true se il documento ha dei riferimenti di derivazione
DocumentIsAssembly | Restituisce se il documento passato è IAM o IPT.
DocumentIsDrawing | Restituisce se il documento passato è IDW o DWG.
DocumentIsDrawingOrPresentation | Restituisce se il documento passato è tavola o presentazione.
DocumentIsModel | Restituisce se il documento passato è IAM o IPT.
DocumentIsModelOrPresentation | Restituisce se il documento passato è tavola o presentazione.
DocumentIsOpenVisible | Ritorna true se il documento è aperto in modo visibile
DocumentIsPart | Restituisce se il documento passato è IPT.
DocumentIsPresentation | Restituisce se il documento passato è IPN.
EliminaOwnerShipStruttureSpeciali | Ripristina le caratteristiche di ownership dei componenti di struttura speciale
FileIsAssembly | Verifica e restituisce se il file passato sia o meno un file di assime.
FileIsInventor | Verifica e restituisce se il file passato sia o meno un file di interesse per Inventor.
FileIsInventorDwg | Verifica e restituisce se il file passato sia o meno un file dwg di Inventor.
FileIsModel | Verifica e restituisce se il file passato sia o meno un file di modello di inventor.
FileIsPart | Verifica e restituisce se il file passato sia o meno un file di parte.
FileIsPresentation | Verifica e restituisce se il file passato sia o meno un file di assime.
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
FindDocumentInCollection | Cerca e restituisce il documento abbinato ad un file. Restituisce null se non lo trova. Lo cerca nella collezione di documenti passati (Documents oppure VisibleDocuments).
FindInventorDocument(String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
FindInventorDocument(String, String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
FindInventorFile | Cerca tra i file aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il file non risulta aperto in Inventor.
FindInventorMemberDocument(String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
FindInventorMemberDocument(String, String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName. Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
FormatAttr | Legge e restituisce il valore di un attributo dal documento/occorrenza di inventor, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo.
GetActiveLOD | Restituisce il livello di dettaglio attivo.
GetActiveModelState | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActiveModelStateKey | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActiveModelStateName | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetActualModelStateName | Dato un filename ed una configurazione, ritorna l'effettivo nome del model state
GetAllInventorFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetApplicationUserVer | Restituisce la versione di inventor da visualizzare all'utente.
GetAssembly | Restituisce il documento convertito in AssemblyDocument oppure null se non riesce.
GetAssociativeForeignFilename | Restituisce se il documento passato è di modello.
GetAttrList | Restituisce la lista di attributi richiesti, abbinati all'anagrafica passata. L'anagrafica può essere anche null, in tal caso viene restituita la lista degli attributi di Tutti i tipi.
GetBomStructure | Restituisce la BOMStructureEnum del documento passato.
GetCfgStructure | Restituisce la struttura delle configurazioni del documento passato.
GetChildControls | Ritorna una lista di controlli contenuti nella finestra passata.
GetConfigName(ModelState) | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetConfigName(String) | Dato il nome di una configurazione, Restituisce il nome secondo lo standard DED+
GetDataFromDedDoc | Ritorna l'anagrafica associata al documento
GetDerivedDocs | Restituisce la lista dei documenti derivati di una parte (.ipt). Se non trova alcun documento restituisce la lista vuota.
GetDesktopWindow |
GetDrawing | Restituisce il documento convertito in DrawingDocument oppure null se non riesce.
GetEmbeddedIcon | Data l'estensione restituisce l'icona dell'oggetto embedded (Anycad)
GetFullDocumentNameOnOpenOptions | In caso di assieme ritorna il full document name compatibilmente con le impostazioni di livello di dettaglio in apertura. L'opzione può essere principale, tutti i comp. soppressi, tutte le parti soppresse ed ultimo attivo.
GetHWndText | Ritorna la caption della finestra / controllo.
GetLastDataRowVer(Document) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(ModelState) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura.
GetLastDataRowVer(String) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetMasterLOD | Restituisce il livello di dettaglio principale.
GetMasterModelState | Se esiste, dato il documento ritorna il master model state
GetModelStateKey | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetModelStateName | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetModelStateNames | Ritorna i model states del documento. E' sempre l'elenco dei model state della factory
GetModelStates | Ritorna i model states del documento. E' sempre l'elenco dei model state della factory
GetNastranInCADReferences(Document) | Ritorna la lista dei riferimenti Nastran dato il documento passato
GetNastranInCADReferences(String) | Ritorna la lista dei riferimenti Nastran dato il filename passato
GetOccurrenceNameWithoutPosNumber | Ritorna il nome dell'occorrenza privato della posizione
GetPart | Restituisce il documento convertito in PartDocument oppure null se non riesce.
GetPresentation | Restituisce il documento convertito in PresentationDocument oppure null se non riesce.
GetPreview | Ritorna l'anteprima del documento sotto forma di bitmap
GetQsPublisherOutName | Dato il documento attivo e la configurazione del publisher calcolo il nome di pubblicazione in base alle regole del publish manager eventualmente personalizzate tramite evento. Anche in caso di formati potenzialmente multifoglio ritorno il nome completo. Sarà poi il publisher a fornire a posteriori la formattazione corretta.
GetSafeReferenceFullFileName | Dato il descrittore ritorna il percorso del riferimento più coerente possibile col progetto. ResolvedFullFileName è però più affidabile nel caso Inventor abbia risolto tramite path del progetto in un percorso diverso dall'ultimo usato (secondo Barbara Hann).
GetSmallFileIcon | Data la tipologia di documento ritorna l'icona dalla risorse del progetto
HasModelStates | Ritorna vero se il documento ha dei model state
ImpostaDatiClonazioneStrutture | Imposta ricorsivamente, da clonare gli elementi delle strutture speciali, compresi i dati necessari alla clonazione.
InvDoc2DedDataPart(Document) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere ed avere l'elenco attributi.
InvDoc2DedDataPart(Document, DedAttrList) | Legge i dati dal documento e li inserisce in una DedDataPart. Legge direttamente l'elenco attributi dal parametro passato.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum, Boolean) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvDoc2DedDoc | Legge il percorso del documento passato e ne resituisce il DedDoc. Se il documento non è ancora salvato o se non è nel Database restituisce null. Ignora eventuali errori.
InvDocAttrMatchData | Controlla se gli attributi ID e REV letti nel documento coincidono con quelli associati all'anagrafica passata
InvFile2DedDataPart(String, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, DedAttrList) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum) | Legge i dati dal file di inventor secondo la tiplogia richiesta e li inserisce in una DedDataPart.
InvFileAttrMatchData | Controlla se gli attributi ID e REV letti nel file coincidono con quelli associati all'anagrafica passata
InvOcc2DedDataPart(ComponentOccurrence, DedAttrList) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Utilizza la lista di attributi passata
InvOcc2DedDataPart(ComponentOccurrence, UtilDataAttrTypeEnum) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvOcc2DedDoc | Legge il percorso dell'occorrenza passata e ne resituisce il DedDoc. Se l'occorrenza non è ancora salvata o se non è nel Database o se non ha associato alcun file, restituisce null. Ignora eventuali errori.
IsAnyCadReferenceName | Dato il path del riferimento padre e il path del file in oggetto ritorna vero se si tratta di un potenziale documento di anycad.
IsAssemblyFactory | Restituisce vero se il documento passato è una Part Factory
IsAssemblyMember | Restituisce vero se il documento passato è un Part Member
IsCableHarnessDocument | Dato il documento in ingresso determina se si tratta di un documento di cavi e cablaggi.
IsDerivedDoc | Stabilisce se il documento padre è un derivato del documento figlio
IsDrawing | Restituisce se il documento passato sia una messa in tavola.
IsEmbeddedDocument | Restituisce se il documento passato è di modello.
IsFactoryAssetInstance | Restituisce vero se si tratta di un documento rappresentante un asset della factory
IsiAssemblyOccurrence | Restituisce vero se l'occorrenza si trova nel contesto di un
IsInventorDwg | Restituisce se il documento sia un dwg di inventor.
IsMasterModelState | Ritorna vero se il documento è in configurazione master
IsModel | Restituisce se il documento passato è di modello. Se fallisce è quasi sicuramente per la corruzione del documento. L'eccezione viene comunque registrata.
IsModelStateFactory | Ritorna vero se il documento è il model state factory
IsModelStateMember | Ritorna vero se il documento è il model state member
IsPartFactory | Restituisce vero se il documento passato è una Part Factory
IsPartMember | Restituisce vero se il documento passato è un Part Member
IsPresentation | Restituisce se il documento passato sia una presentazione.
IsRoutedSystemDocument | Dato il documento in ingresso determina se si tratta di un documento di piping.
IsSubstituteDescriptor | Identifica se il document descriptor passato rappresenta un sosituto.
IsSubstituteModelState | Ritorna vero se il documento è in una configurazione sostituto
IsSubstitutePart | Controlla se la parte passata è un sostituto. Dalla 2022 il comodissimo flag non è più impostato.
IsUnreferencedSubstituteModelState | Ritorna vero se il documento è in una configurazione sostituto
LogTubeAndPipeAddinActivationStatus | Logga lo stato di attivazione del plugin di tubi e tubature
MakeStructFileName | Dato il nome di partenza genera il nuovo nome da assegnare al file della struttura speciale. Verifica se il prefisso, il nome del padre di partenza ed il numero random sono presenti. In tal caso li elimina per ricrearli in base ai parametri passati.
MigrateFile | Migra il file alla release corrente di inventor. Ignora lo stato di sola lettura e lo stato del documento. E' al servizione dell'aggiornamento riferimenti nel caso di debba procedere tramite apprentice.
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum, Boolean) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
OnFileResolutionStruttureSpeciali | Core delle operazioni che si devono effettuare durante l'OnFileResolution per la sostituzione delle strutture speciali.
Open(String, Boolean, String) | Apre il file passato e ne restituisce il documento. Se la configurazione passata è nulla o vuota viene aperta la configurazione leggendo le opzioni di Inventor (Last o Master). Se viene passata la configurazione ma non esiste viene aperta sempre la Master. Solleva una eccezione se non riesce ad aprirlo.
Open(String, Boolean, DedData, DedDoc, String) |
OpenWithOptions | Apre il file passato e ne restituisce il documento. Se la configurazione passata non esiste o è nulla viene aperto sempre in Master.
OrderDocumentList | Riordino il tutto in modo da ottenere il seguente ordinamento : iam/inest - ipt - ipn - idw.
PartBody2DedDataPart | Legge i dati dal partbody e li inserisce in un DedDataPart
PartHasMultipleSolidBodies | Ritorna vero se il documento di tipo 'parte' è costituito da più di un body
PathIsLibrary | Verifica se il percorso sia o meno di libreria.
PathIsRootLibrary | Verifica se il percorso sia in una root libreria.
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllProperties(Document) | Legge tutte le proprietà del documento.
ReadAllProperties(String) | Legge tutte le proprietà del documento.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromInvDoc(Document, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvDoc(Document, String, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvDocOrMatchingModelState | Prova prima a reperire l'anagrafica usando ReadDataFromInvDoc con configurazione specifica se non trova nulla allora fa un controllo più leggero senza usare la configurazione (serve per reperire l'anagrafica anche delle rappresentazioni che non sono direttamente associate all'anagrafica)
ReadDataFromInvDocProperties | Legge l'anagrafica solamente dagli attributi del documento di Inventor
ReadDataFromInvFile | Legge il dedid ed il dedrev da un file di Inventor e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvFileProperties | Legge l'anagrafica solamente dagli attributi del file
ReadDataFromInvOcc | Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvOccOrMatchingModelState | Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvOccProperties | Legge l'anagrafica solamente dagli attributi dell'ocorenza di Inventor.
ReadDataFromModelState | Legge l'anagrafica dal model state. Se il documento esiste, utilizza quello in modo tradizionale. Se il documento non esiste, preleva l'anagrafica associata tramite il legame documentale
ReadDataFromPartBodyProperties | Legge l'anagrafica solamente dagli attributi del documento di Inventor
ReadSubstituteList | Legge il documento e se si tratta di un assieme, cerca tutti i sostituti di dettaglio presenti. Li restituisce in una lista sempre inizializzata ed eventualmente vuota. ATTENZIONE! Sulla 2022 ha senso solo per versioni inferiori alla 2022.2 diversamente non sarà nemmeno chiamata
RefreshAllDocuments | Esegue un refresh di tutti i documenti in memoria. Di default inventor è silenziato
RemoveHiddenAttribute | Rimuove l'attributo nascosto
ReplaceAllDerivedDocumentReferences | Sostituisce tutti i componenti derivati con il file passato
ReplaceDerivedDocumentReference | Sostituisce il componente derivato specificato con il file passato. Se il file non viene trovato non sostituisce niente
RipristinaDocumentiStruttureSpeciali | Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.
RipristinaOwnerShipStruttureSpeciali | Ripristina le caratteristiche di ownership dei componenti di struttura speciale
RipristinaPartNumberStruttureSpeciali | Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.
Save | Salva il documento su se stesso con tutte le sue dipendenze.
SaveAs | Salva il documento passato nella posizione specificata. Effettua un SaveAs oppure un SaveCopyAs in base all'opzione.
SaveDistBomStructureAllowed | Restituisce true se è consentito il salvataggio della distinta in base alle impostazioni utente e alla bomstructure del documento .
SetDeferUpdates | In caso di documento tavola imposta il posticipa aggiornamenti. Diversamente non fa niente
SetLastDataRowVer(Document, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(String, Guid) | Imposta nel file di Inventor il rowver utilizzato per aggiornare i dati nel documento. La scrittura viene eseguita solo se necessario.
SetOnFileDirtyFlags | Setta i semafori dell'onFileDirty in base al comportamento passato
SostituisciAssiemeInSostituto | Sostituisce l'eventuale riferimento dell'assieme nelle parti dei sostituti di dettaglio dell'assieme stesso.
SostituisciComponentiStruttureSpeciali | Sostituisce tutti i sotto-componenti delle strutture speciali dal documento passato.
SostituisciSostituti | Sostituisce tutti i sostituti di livello di dettaglio dell'elemento passato.
SostituisciSostitutoSingolo | Sostituisce il sostituto di dettaglio nell'assieme passato.
SubMenuExists | Metodo che ritorna 0 se il sottomenu non è presente nella CommandBar, 1 altrimenti.
UpdateProjectLibraryPaths | Aggiorna
UpdateReference | Scorre tutte le dipendenze di primo livello di un documento e le sostituisce con la nuova destinazione.
UpdateSingleDocumentOLEReference | Funzione di aggiornamento di una reference su singolo documento
UpdateSingleDocumentReference | Funzione di aggiornamento di una reference su singolo documento
UpdateSingleFullDocumentNameReference | Funzione di aggiornamento di una reference su singolo documento
WriteAllProperties(DedDoc) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, Document) | Scrive tutte le proprietà del documento nel Database
WriteAttr | Scrive il valore di un attributo nel documento/occorrenza di inventor, convertendolo prima in testo in base al tipo dati dell'attributo.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AddCommandButton

Metodo UtilAddCommandButton

Funzione che permette di gestire la visualizzazione dei pulsanti all'interno di una barra.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AddCommandButton(
    CommandBar bar,
    ButtonDefinition item,
    bool visible
)
Public Shared Sub AddCommandButton (
    bar As CommandBar,
    item As ButtonDefinition,
    visible As Boolean
)
public:
static void AddCommandButton(
    CommandBar^ bar,
    ButtonDefinition^ item,
    bool visible
)
static member AddCommandButton :
        bar : CommandBar *
        item : ButtonDefinition *
        visible : bool -> unit

Parametri

bar
Tipo: CommandBar
Barra alla quale aggiungere/rimuove il pulsante.
item
Tipo: ButtonDefinition
Pulsante da aggiungere/rimuovere.
visible
Tipo: SystemBoolean
Se true aggiunge il pulsante altrimenti lo elimina.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AddPopUpCommandBar

Metodo UtilAddPopUpCommandBar

Restituisce o crea la barra dei comandi con il nome passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CommandBar AddPopUpCommandBar(
    string name,
    string internalName
)
Public Shared Function AddPopUpCommandBar (
    name As String,
    internalName As String
) As CommandBar
public:
static CommandBar^ AddPopUpCommandBar(
    String^ name,
    String^ internalName
)
static member AddPopUpCommandBar :
        name : string *
        internalName : string -> CommandBar

Parametri

name
Tipo: SystemString
Nome della barra dei comandi.
internalName
Tipo: SystemString
Nome interno della barra.

Valore di ritorno

Tipo: CommandBar
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AskMemberSelection

Metodo UtilAskMemberSelection

Dato il fullpath di una factory (ipart/iassembly) chiede la selezione di un member Le eventuali eccezioni sono sollevate verso il chiamante

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string AskMemberSelection(
    string factoryFullFileName
)
Public Shared Function AskMemberSelection (
    factoryFullFileName As String
) As String
public:
static String^ AskMemberSelection(
    String^ factoryFullFileName
)
static member AskMemberSelection :
        factoryFullFileName : string -> string

Parametri

factoryFullFileName
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AskUseMasterModelState

Metodo UtilAskUseMasterModelState

Lista degli overload
Nome | Descrizione
AskUseMasterModelState(ComponentOccurrence, Boolean, String) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare la il model state corrente del documento passato.
AskUseMasterModelState(Document, Boolean, ModelState) | Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare il model state corrente del documento passato.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AskUseMasterModelState (ComponentOccurrence, Boolean, String)

Metodo UtilAskUseMasterModelState (ComponentOccurrence, Boolean, String)
Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare la il model state corrente del documento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool AskUseMasterModelState(
    ComponentOccurrence occ,
    bool askUser,
    out string oldModelState
)
Public Shared Function AskUseMasterModelState (
    occ As ComponentOccurrence,
    askUser As Boolean,
    <OutAttribute> ByRef oldModelState As String
) As Boolean
public:
static bool AskUseMasterModelState(
    ComponentOccurrence^ occ,
    bool askUser,
    [OutAttribute] String^% oldModelState
)
static member AskUseMasterModelState :
        occ : ComponentOccurrence *
        askUser : bool *
        oldModelState : string byref -> bool

Parametri

occ
Tipo: ComponentOccurrence
askUser
Tipo: SystemBoolean
oldModelState
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
True se tutto ok, false se il comando è stato annullato
Vedi anche

Documentazione

Classe Util
Overload di AskUseMasterModelState
Namespace DedNetInv


Metodo Util.AskUseMasterModelState (Document, Boolean, ModelState)

Metodo UtilAskUseMasterModelState (Document, Boolean, ModelState)
Controllo le impostazioni dei model state. Se l'utente conferma imposta il model state principale. Opzionalmente è possibile farsi tornare il model state corrente del documento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool AskUseMasterModelState(
    Document doc,
    bool askUser,
    out ModelState oldModelState
)
Public Shared Function AskUseMasterModelState (
    doc As Document,
    askUser As Boolean,
    <OutAttribute> ByRef oldModelState As ModelState
) As Boolean
public:
static bool AskUseMasterModelState(
    Document^ doc,
    bool askUser,
    [OutAttribute] ModelState^% oldModelState
)
static member AskUseMasterModelState :
        doc : Document *
        askUser : bool *
        oldModelState : ModelState byref -> bool

Parametri

doc
Tipo: Document
askUser
Tipo: SystemBoolean
oldModelState
Tipo: ModelState

Valore di ritorno

Tipo: Boolean
True se tutto ok, false se il comando è stato annullato
Vedi anche

Documentazione

Classe Util
Overload di AskUseMasterModelState
Namespace DedNetInv


Metodo Util.AssertActiveDocument

Metodo UtilAssertActiveDocument

Verifica che sia presente un documento attivo in Inventor e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document AssertActiveDocument()
Public Shared Function AssertActiveDocument As Document
public:
static Document^ AssertActiveDocument()
static member AssertActiveDocument : unit -> Document

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertAllDocumentsClose

Metodo UtilAssertAllDocumentsClose

Controlla che non ci siano dei documenti aperti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertAllDocumentsClose()
Public Shared Sub AssertAllDocumentsClose
public:
static void AssertAllDocumentsClose()
static member AssertAllDocumentsClose : unit -> unit
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertCurrentDocument

Metodo UtilAssertCurrentDocument

Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertCurrentDocument()
Public Shared Function AssertCurrentDocument As DedDoc
public:
static DedDoc^ AssertCurrentDocument()
static member AssertCurrentDocument : unit -> DedDoc

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDataHasSameRevType

Metodo UtilAssertDataHasSameRevType

Verifica che il documento non sia già associato in configurazione Default a un'altra anagrafica con tipologia di revisioe differente da quella passata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDataHasSameRevType(
    DedDoc doc,
    DedData data
)
Public Shared Sub AssertDataHasSameRevType (
    doc As DedDoc,
    data As DedData
)
public:
static void AssertDataHasSameRevType(
    DedDoc^ doc,
    DedData^ data
)
static member AssertDataHasSameRevType :
        doc : DedDoc *
        data : DedData -> unit

Parametri

doc
Tipo: DedDoc
Documento
data
Tipo: DedData
Anagrafica
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDataNotHasSameExt

Metodo UtilAssertDataNotHasSameExt

Verifica che l'anagrafica non abbia già collegato un documento con la stessa estensione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDataNotHasSameExt(
    DedData data,
    string ext
)
Public Shared Sub AssertDataNotHasSameExt (
    data As DedData,
    ext As String
)
public:
static void AssertDataNotHasSameExt(
    DedData^ data,
    String^ ext
)
static member AssertDataNotHasSameExt :
        data : DedData *
        ext : string -> unit

Parametri

data
Tipo: DedData
Anagrafica
ext
Tipo: SystemString
Estensione senza il punto
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocHasData

Metodo UtilAssertDocHasData

Controlla che il documento non sia associato a nessuna anagrafica.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocHasData(
    Document oDoc
)
Public Shared Sub AssertDocHasData (
    oDoc As Document
)
public:
static void AssertDocHasData(
    Document^ oDoc
)
static member AssertDocHasData :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocHasModelStates

Metodo UtilAssertDocHasModelStates

Controlla che il documento abbia effettivamente dei model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocHasModelStates(
    Document oDoc
)
Public Shared Sub AssertDocHasModelStates (
    oDoc As Document
)
public:
static void AssertDocHasModelStates(
    Document^ oDoc
)
static member AssertDocHasModelStates :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocHasNotModelStates

Metodo UtilAssertDocHasNotModelStates

Controlla che il documento non presenti dei model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocHasNotModelStates(
    Document oDoc
)
Public Shared Sub AssertDocHasNotModelStates (
    oDoc As Document
)
public:
static void AssertDocHasNotModelStates(
    Document^ oDoc
)
static member AssertDocHasNotModelStates :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsAssembly

Metodo UtilAssertDocIsAssembly

Controlla che il documento passato non sia Nothing e sia un assieme, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsAssembly(
    Document oDoc
)
Public Shared Sub AssertDocIsAssembly (
    oDoc As Document
)
public:
static void AssertDocIsAssembly(
    Document^ oDoc
)
static member AssertDocIsAssembly :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsDrawing

Metodo UtilAssertDocIsDrawing

Controlla che il documento passato non sia Nothing e sia una messa in tavola, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsDrawing(
    Document oDoc
)
Public Shared Sub AssertDocIsDrawing (
    oDoc As Document
)
public:
static void AssertDocIsDrawing(
    Document^ oDoc
)
static member AssertDocIsDrawing :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsFactory

Metodo UtilAssertDocIsFactory

Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsFactory(
    Document oDoc
)
Public Shared Sub AssertDocIsFactory (
    oDoc As Document
)
public:
static void AssertDocIsFactory(
    Document^ oDoc
)
static member AssertDocIsFactory :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsInDb

Metodo UtilAssertDocIsInDb

Controlla che il documento passato sia registrato nel database

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsInDb(
    Document oDoc
)
Public Shared Sub AssertDocIsInDb (
    oDoc As Document
)
public:
static void AssertDocIsInDb(
    Document^ oDoc
)
static member AssertDocIsInDb :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da controllare
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsModel

Metodo UtilAssertDocIsModel

Controlla che il documento passato non sia Nothing e sia un modello, altrimenti lancia un'eccezione. lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsModel(
    Document oDoc
)
Public Shared Sub AssertDocIsModel (
    oDoc As Document
)
public:
static void AssertDocIsModel(
    Document^ oDoc
)
static member AssertDocIsModel :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsNotEditAllMemberScope

Metodo UtilAssertDocIsNotEditAllMemberScope

Controlla che il documento non sia in modalità di editazione di tutti i ms

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotEditAllMemberScope(
    Document oDoc
)
Public Shared Sub AssertDocIsNotEditAllMemberScope (
    oDoc As Document
)
public:
static void AssertDocIsNotEditAllMemberScope(
    Document^ oDoc
)
static member AssertDocIsNotEditAllMemberScope :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsNotInMsSubstitute

Metodo UtilAssertDocIsNotInMsSubstitute

Controllo che il documento non sia attivo in un ms sostituto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotInMsSubstitute(
    Document oDoc
)
Public Shared Sub AssertDocIsNotInMsSubstitute (
    oDoc As Document
)
public:
static void AssertDocIsNotInMsSubstitute(
    Document^ oDoc
)
static member AssertDocIsNotInMsSubstitute :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsNotNothing

Metodo UtilAssertDocIsNotNothing

Controlla che il documento non sia Nothing, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotNothing(
    Document oDoc
)
Public Shared Sub AssertDocIsNotNothing (
    oDoc As Document
)
public:
static void AssertDocIsNotNothing(
    Document^ oDoc
)
static member AssertDocIsNotNothing :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsNotTopDocument

Metodo UtilAssertDocIsNotTopDocument

Controlla che il documento passato non sia Nothing e non sia la parte principale del documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsNotTopDocument(
    Document oDoc
)
Public Shared Sub AssertDocIsNotTopDocument (
    oDoc As Document
)
public:
static void AssertDocIsNotTopDocument(
    Document^ oDoc
)
static member AssertDocIsNotTopDocument :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsPart

Metodo UtilAssertDocIsPart

Controlla che il documento passato non sia Nothing e sia una parte, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsPart(
    Document oDoc
)
Public Shared Sub AssertDocIsPart (
    oDoc As Document
)
public:
static void AssertDocIsPart(
    Document^ oDoc
)
static member AssertDocIsPart :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsPartFactory

Metodo UtilAssertDocIsPartFactory

Controlla che il documento passato non sia Nothing e sia una iPartFactory, altrimenti lancia un'eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsPartFactory(
    Document oDoc
)
Public Shared Sub AssertDocIsPartFactory (
    oDoc As Document
)
public:
static void AssertDocIsPartFactory(
    Document^ oDoc
)
static member AssertDocIsPartFactory :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsSavableSpecialStruct

Metodo UtilAssertDocIsSavableSpecialStruct

Verifica se il documento sia una struttura speciale salvabile, in caso contrario solleva una eccezione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsSavableSpecialStruct(
    SpecialStructEnum tipoStruct,
    bool isSavePrt
)
Public Shared Sub AssertDocIsSavableSpecialStruct (
    tipoStruct As SpecialStructEnum,
    isSavePrt As Boolean
)
public:
static void AssertDocIsSavableSpecialStruct(
    SpecialStructEnum tipoStruct,
    bool isSavePrt
)
static member AssertDocIsSavableSpecialStruct :
        tipoStruct : SpecialStructEnum *
        isSavePrt : bool -> unit

Parametri

tipoStruct
Tipo: DedNetInvSpecialStructEnum
Tipo di struttura del documento da verificare.
isSavePrt
Tipo: SystemBoolean
Indica se si tratti o meno di salva parte.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsTopDocument

Metodo UtilAssertDocIsTopDocument

Controlla che il documento passato non sia Nothing e sia la parte principale del documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsTopDocument(
    Document oDoc
)
Public Shared Sub AssertDocIsTopDocument (
    oDoc As Document
)
public:
static void AssertDocIsTopDocument(
    Document^ oDoc
)
static member AssertDocIsTopDocument :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocIsValidOcc

Metodo UtilAssertDocIsValidOcc

Controlla che il documento passato non sia Nothing, altrimenti, essendo derivato da una occorrenza, visualizza un messaggio.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertDocIsValidOcc(
    Document oDoc
)
Public Shared Sub AssertDocIsValidOcc (
    oDoc As Document
)
public:
static void AssertDocIsValidOcc(
    Document^ oDoc
)
static member AssertDocIsValidOcc :
        oDoc : Document -> unit

Parametri

oDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo:
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertDocument

Metodo UtilAssertDocument

Cerca di ricavare il DedDoc dal documento correntemente attivo e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertDocument(
    Document invDoc
)
Public Shared Function AssertDocument (
    invDoc As Document
) As DedDoc
public:
static DedDoc^ AssertDocument(
    Document^ invDoc
)
static member AssertDocument :
        invDoc : Document -> DedDoc

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertEditDocisTopDocument

Metodo UtilAssertEditDocisTopDocument

Controlla che il documento in editazione sia il

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertEditDocisTopDocument()
Public Shared Sub AssertEditDocisTopDocument
public:
static void AssertEditDocisTopDocument()
static member AssertEditDocisTopDocument : unit -> unit
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertOccurrenceIsNotSubstitute

Metodo UtilAssertOccurrenceIsNotSubstitute

Solleva una eccezione se l'occorrenza passata è un sostituto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertOccurrenceIsNotSubstitute(
    ComponentOccurrence invOcc
)
Public Shared Sub AssertOccurrenceIsNotSubstitute (
    invOcc As ComponentOccurrence
)
public:
static void AssertOccurrenceIsNotSubstitute(
    ComponentOccurrence^ invOcc
)
static member AssertOccurrenceIsNotSubstitute :
        invOcc : ComponentOccurrence -> unit

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza da controllare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertOccurrenceIsNotSuppressedOrMissing

Metodo UtilAssertOccurrenceIsNotSuppressedOrMissing

Solleva una eccezione se l'occorrenza passata è soppressa o mancante.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertOccurrenceIsNotSuppressedOrMissing(
    ComponentOccurrence invOcc
)
Public Shared Sub AssertOccurrenceIsNotSuppressedOrMissing (
    invOcc As ComponentOccurrence
)
public:
static void AssertOccurrenceIsNotSuppressedOrMissing(
    ComponentOccurrence^ invOcc
)
static member AssertOccurrenceIsNotSuppressedOrMissing :
        invOcc : ComponentOccurrence -> unit

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza da controllare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertOccurrenceIsNotVirtual

Metodo UtilAssertOccurrenceIsNotVirtual

Solleva una eccezione se l'occorrenza passata è virtuale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertOccurrenceIsNotVirtual(
    ComponentOccurrence invOcc
)
Public Shared Sub AssertOccurrenceIsNotVirtual (
    invOcc As ComponentOccurrence
)
public:
static void AssertOccurrenceIsNotVirtual(
    ComponentOccurrence^ invOcc
)
static member AssertOccurrenceIsNotVirtual :
        invOcc : ComponentOccurrence -> unit

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza da controllare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertOccurrenceIsNotWelds

Metodo UtilAssertOccurrenceIsNotWelds

Solleva una eccezione se l'occorrenza passata è una saldatura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertOccurrenceIsNotWelds(
    ComponentOccurrence invOcc
)
Public Shared Sub AssertOccurrenceIsNotWelds (
    invOcc As ComponentOccurrence
)
public:
static void AssertOccurrenceIsNotWelds(
    ComponentOccurrence^ invOcc
)
static member AssertOccurrenceIsNotWelds :
        invOcc : ComponentOccurrence -> unit

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza da controllare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertReadDataFromInvDoc

Metodo UtilAssertReadDataFromInvDoc

Viene utilizzata la funzione ReadDataFromInvDoc() per avere l'anagrafica del documento passato. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromInvDoc(
    Document invDoc
)
Public Shared Function AssertReadDataFromInvDoc (
    invDoc As Document
) As DedData
public:
static DedData^ AssertReadDataFromInvDoc(
    Document^ invDoc
)
static member AssertReadDataFromInvDoc :
        invDoc : Document -> DedData

Parametri

invDoc
Tipo: Document
Documento del quale leggere l'anagrafica.

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertReadDataFromInvDocOrMatchingModelState

Metodo UtilAssertReadDataFromInvDocOrMatchingModelState

Viene utilizzata la funzione che controlla l'anagrafica dal model state corrente. Può essere anche una anagrafica di un altra configurazione se contenuta nelle proprietà.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromInvDocOrMatchingModelState(
    Document invDoc
)
Public Shared Function AssertReadDataFromInvDocOrMatchingModelState (
    invDoc As Document
) As DedData
public:
static DedData^ AssertReadDataFromInvDocOrMatchingModelState(
    Document^ invDoc
)
static member AssertReadDataFromInvDocOrMatchingModelState :
        invDoc : Document -> DedData

Parametri

invDoc
Tipo: Document
Documento del quale leggere l'anagrafica.

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AssertReadDataFromInvOcc

Metodo UtilAssertReadDataFromInvOcc

Viene utilizzata la funzione ReadDataFromInvOcc() per avere l'anagrafica dell'occorrenza passata. Restituisce l'anagrafica oppure solleva un'eccezione per avvisare l'utente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromInvOcc(
    ComponentOccurrence invOcc
)
Public Shared Function AssertReadDataFromInvOcc (
    invOcc As ComponentOccurrence
) As DedData
public:
static DedData^ AssertReadDataFromInvOcc(
    ComponentOccurrence^ invOcc
)
static member AssertReadDataFromInvOcc :
        invOcc : ComponentOccurrence -> DedData

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza dalla quale leggere l'anagrafica.

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AttrListDisabler

Metodo UtilAttrListDisabler

Lista degli overload
Nome | Descrizione
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.AttrListDisabler (DedAttrList)

Metodo UtilAttrListDisabler (DedAttrList)
Disabilita tutti gli attributi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList
)
static member AttrListDisabler :
        inList : DedAttrList -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale

Valore di ritorno

Tipo: DedAttrList
Lista modificat
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler
Namespace DedNetInv


Metodo Util.AttrListDisabler (DedAttrList, DedAttrEnvDestEnum)

Metodo UtilAttrListDisabler (DedAttrList, DedAttrEnvDestEnum)
Disabilita gli attributi del tipo passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListDisabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale
attrEnvDestType
Tipo: DedAttrEnvDestEnum

Valore di ritorno

Tipo: DedAttrList
Lista modificat
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler
Namespace DedNetInv


Metodo Util.AttrListEnabler

Metodo UtilAttrListEnabler

Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListEnabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListEnabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListEnabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListEnabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale
attrEnvDestType
Tipo: DedAttrEnvDestEnum
Tipo di attributi di riferimento

Valore di ritorno

Tipo: DedAttrList
Lista modificata
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CalcolaNomeSostituto

Metodo UtilCalcolaNomeSostituto

Ritorna il nome del sostituto dato il nome completo del modello di riferimento e la lista dei sostituti già denominati

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string CalcolaNomeSostituto(
    string fullModelFileName
)
Public Shared Function CalcolaNomeSostituto (
    fullModelFileName As String
) As String
public:
static String^ CalcolaNomeSostituto(
    String^ fullModelFileName
)
static member CalcolaNomeSostituto :
        fullModelFileName : string -> string

Parametri

fullModelFileName
Tipo: SystemString

Valore di ritorno

Tipo: String
Nuovo nome del sostituto
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CheckPositionalRepresentation

Metodo UtilCheckPositionalRepresentation

Controllo le impostazioni della rappresentazione di posizione nel documento e opzionalmente dei documenti referenziati. Se l'utente conferma imposta la rappresentazione di posizione principale. Opzionalmente è possibile farsi tornare la rappresentazione corrente del documento principale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckPositionalRepresentation(
    Document topDocument,
    bool checkReferenced,
    bool askUser,
    out PositionalRepresentation mainPositionalRepresentation
)
Public Shared Function CheckPositionalRepresentation (
    topDocument As Document,
    checkReferenced As Boolean,
    askUser As Boolean,
    <OutAttribute> ByRef mainPositionalRepresentation As PositionalRepresentation
) As Boolean
public:
static bool CheckPositionalRepresentation(
    Document^ topDocument,
    bool checkReferenced,
    bool askUser,
    [OutAttribute] PositionalRepresentation^% mainPositionalRepresentation
)
static member CheckPositionalRepresentation :
        topDocument : Document *
        checkReferenced : bool *
        askUser : bool *
        mainPositionalRepresentation : PositionalRepresentation byref -> bool

Parametri

topDocument
Tipo: Document
checkReferenced
Tipo: SystemBoolean
askUser
Tipo: SystemBoolean
mainPositionalRepresentation
Tipo: PositionalRepresentation

Valore di ritorno

Tipo: Boolean
True se tutto ok, false se il comando è stato annullato
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CloseWindow

Metodo UtilCloseWindow

Chiude la finestra identificata dall'hadle passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CloseWindow(
    IntPtr hwnd
)
Public Shared Sub CloseWindow (
    hwnd As IntPtr
)
public:
static void CloseWindow(
    IntPtr hwnd
)
static member CloseWindow :
        hwnd : IntPtr -> unit

Parametri

hwnd
Tipo: SystemIntPtr
Hwnd della finestra da chiudere
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CopiaSostituti

Metodo UtilCopiaSostituti

Copia nella destinazione tutti i sostituti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CopiaSostituti(
    InvDocStructInfo item
)
Public Shared Sub CopiaSostituti (
    item As InvDocStructInfo
)
public:
static void CopiaSostituti(
    InvDocStructInfo^ item
)
static member CopiaSostituti :
        item : InvDocStructInfo -> unit

Parametri

item
Tipo: DedNetInvInvDocStructInfo
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CopiaStruttureSpeciali

Metodo UtilCopiaStruttureSpeciali

Copia tutti i file appartenenti alle strutture speciali presenti sotto all'elemento passato. Lavora in modo ricorsivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CopiaStruttureSpeciali(
    DocStructInfoCollection items,
    bool headerStructure = true
)
Public Shared Sub CopiaStruttureSpeciali (
    items As DocStructInfoCollection,
    Optional headerStructure As Boolean = true
)
public:
static void CopiaStruttureSpeciali(
    DocStructInfoCollection^ items,
    bool headerStructure = true
)
static member CopiaStruttureSpeciali :
        items : DocStructInfoCollection *
        ?headerStructure : bool
(* Defaults:
        let _headerStructure = defaultArg headerStructure true
*)
-> unit

Parametri

items
Tipo: DocStructInfoCollection
Elementi da elaborare.
headerStructure (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.CopyOLEandExtraCadReference

Metodo UtilCopyOLEandExtraCadReference

Copia i riferimenti OLE ed Extra Cad del documento passato. Da utilizzare nei delegate...

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CopyOLEandExtraCadReference(
    InvDocStructInfo item
)
Public Shared Sub CopyOLEandExtraCadReference (
    item As InvDocStructInfo
)
public:
static void CopyOLEandExtraCadReference(
    InvDocStructInfo^ item
)
static member CopyOLEandExtraCadReference :
        item : InvDocStructInfo -> unit

Parametri

item
Tipo: DedNetInvInvDocStructInfo
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DataToInvDoc

Metodo UtilDataToInvDoc

Scrive tutti gli attributi di anagrafica in un documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToInvDoc(
    DedData data,
    Document invDoc,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
Public Shared Sub DataToInvDoc (
    data As DedData,
    invDoc As Document,
    Optional enforceOperation As Boolean = false,
    Optional ignoreEsclAttrList As Boolean = false
)
public:
static void DataToInvDoc(
    DedData^ data,
    Document^ invDoc,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
static member DataToInvDoc :
        data : DedData *
        invDoc : Document *
        ?enforceOperation : bool *
        ?ignoreEsclAttrList : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
        let _ignoreEsclAttrList = defaultArg ignoreEsclAttrList false
*)
-> unit

Parametri

data
Tipo: DedData
Anagrafica dalla quale leggere.
invDoc
Tipo: Document
Documento nel quale scrivere.
enforceOperation (Optional)
Tipo: SystemBoolean
Se attivo forzo l'operazione. Copia anche se il documento non corrisponde al deddata passato.
ignoreEsclAttrList (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DataToInvFile

Metodo UtilDataToInvFile

Scrive tutti gli attributi di anagrafica in un file di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToInvFile(
    DedData data,
    string fileName,
    bool enforceOperation = false
)
Public Shared Sub DataToInvFile (
    data As DedData,
    fileName As String,
    Optional enforceOperation As Boolean = false
)
public:
static void DataToInvFile(
    DedData^ data,
    String^ fileName,
    bool enforceOperation = false
)
static member DataToInvFile :
        data : DedData *
        fileName : string *
        ?enforceOperation : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
*)
-> unit

Parametri

data
Tipo: DedData
Anagrafica da associare al file di Inventor
fileName
Tipo: SystemString
Nome file che rappresenta il documento di Inventor
enforceOperation (Optional)
Tipo: SystemBoolean
Se attivo forzo l'operazione. Copia anche se il documento non corrisponde al deddata passato.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DataToInvOcc

Metodo UtilDataToInvOcc

Scrive tutti gli attributi di anagrafica in un documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToInvOcc(
    DedData data,
    ComponentOccurrence invOcc,
    bool enforceOperation = false
)
Public Shared Sub DataToInvOcc (
    data As DedData,
    invOcc As ComponentOccurrence,
    Optional enforceOperation As Boolean = false
)
public:
static void DataToInvOcc(
    DedData^ data,
    ComponentOccurrence^ invOcc,
    bool enforceOperation = false
)
static member DataToInvOcc :
        data : DedData *
        invOcc : ComponentOccurrence *
        ?enforceOperation : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
*)
-> unit

Parametri

data
Tipo: DedData
Anagrafica dalla quale leggere.
invOcc
Tipo: ComponentOccurrence
Occorrenza nella quale scrivere.
enforceOperation (Optional)
Tipo: SystemBoolean
Se attivo forzo l'operazione. Copia anche se il documento non corrisponde al deddata passato.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DataToModelState

Metodo UtilDataToModelState

Scrive l'anagrafica sul model state passato. Se esiste il documento utilizza il metodo classico, diversamente sfrutta la scrittura in tabella

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DataToModelState(
    DedData data,
    ModelState ms,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
Public Shared Sub DataToModelState (
    data As DedData,
    ms As ModelState,
    Optional enforceOperation As Boolean = false,
    Optional ignoreEsclAttrList As Boolean = false
)
public:
static void DataToModelState(
    DedData^ data,
    ModelState^ ms,
    bool enforceOperation = false,
    bool ignoreEsclAttrList = false
)
static member DataToModelState :
        data : DedData *
        ms : ModelState *
        ?enforceOperation : bool *
        ?ignoreEsclAttrList : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
        let _ignoreEsclAttrList = defaultArg ignoreEsclAttrList false
*)
-> unit

Parametri

data
Tipo: DedData
Anagrafica di riferimento
ms
Tipo: ModelState
Model state di riferimento
enforceOperation (Optional)
Tipo: SystemBoolean
Se attivo forza l'operazione
ignoreEsclAttrList (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DedDataPart2InvDoc

Metodo UtilDedDataPart2InvDoc

Scrive i dati presenti nel DedDataPart nel documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2InvDoc(
    IDedData dataPart,
    Document invDoc,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2InvDoc (
    dataPart As IDedData,
    invDoc As Document,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2InvDoc(
    IDedData^ dataPart,
    Document^ invDoc,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2InvDoc :
        dataPart : IDedData *
        invDoc : Document *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart
Tipo: IDedData
Dati da scrivere.
invDoc
Tipo: Document
Documento di inventor nel quale scrivere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera scrivere nel documento.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DedDataPart2InvFile

Metodo UtilDedDataPart2InvFile

Scrive i dati presenti nel DedDataPart nel file di Inventor ( tramite apprentice ).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2InvFile(
    IDedData dataPart,
    string filename,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2InvFile (
    dataPart As IDedData,
    filename As String,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2InvFile(
    IDedData^ dataPart,
    String^ filename,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2InvFile :
        dataPart : IDedData *
        filename : string *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart
Tipo: IDedData
Dati da scrivere.
filename
Tipo: SystemString
File di interesse di Inventor
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera scrivere nell'occorrenza.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DedDataPart2InvOcc

Metodo UtilDedDataPart2InvOcc

Scrive i dati presenti nel DedDataPart nell'occorrenza.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2InvOcc(
    DedDataPart dataPart,
    ComponentOccurrence invOcc,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2InvOcc (
    dataPart As DedDataPart,
    invOcc As ComponentOccurrence,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2InvOcc(
    DedDataPart^ dataPart,
    ComponentOccurrence^ invOcc,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2InvOcc :
        dataPart : DedDataPart *
        invOcc : ComponentOccurrence *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart
Tipo: DedDataPart
Dati da scrivere.
invOcc
Tipo: ComponentOccurrence
Occorrenza di inventor nella quale scrivere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera scrivere nell'occorrenza.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DedDataPart2ModelState

Metodo UtilDedDataPart2ModelState

Scrivi i dati presenti nel DedDataPart nel model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2ModelState(
    IDedData dataPart,
    ModelState ms,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2ModelState (
    dataPart As IDedData,
    ms As ModelState,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2ModelState(
    IDedData^ dataPart,
    ModelState^ ms,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2ModelState :
        dataPart : IDedData *
        ms : ModelState *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart
Tipo: IDedData
ms
Tipo: ModelState
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DedDataPart2PartBody

Metodo UtilDedDataPart2PartBody

Scrive i dati presenti nel DedDataPart nel partBody.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDataPart2PartBody(
    IDedData dataPart,
    PartBody partBody,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Sub DedDataPart2PartBody (
    dataPart As IDedData,
    partBody As PartBody,
    attrsType As UtilDataAttrTypeEnum
)
public:
static void DedDataPart2PartBody(
    IDedData^ dataPart,
    PartBody^ partBody,
    UtilDataAttrTypeEnum attrsType
)
static member DedDataPart2PartBody :
        dataPart : IDedData *
        partBody : PartBody *
        attrsType : UtilDataAttrTypeEnum -> unit

Parametri

dataPart
Tipo: IDedData
Dati da scrivere.
partBody
Tipo: PartBody
PartBody nel quale scrivere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera scrivere nel documento.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentHasDerivedReferences

Metodo UtilDocumentHasDerivedReferences

Ritorna true se il documento ha dei riferimenti di derivazione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentHasDerivedReferences(
    Document oDoc
)
Public Shared Function DocumentHasDerivedReferences (
    oDoc As Document
) As Boolean
public:
static bool DocumentHasDerivedReferences(
    Document^ oDoc
)
static member DocumentHasDerivedReferences :
        oDoc : Document -> bool

Parametri

oDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsAssembly

Metodo UtilDocumentIsAssembly

Restituisce se il documento passato è IAM o IPT.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsAssembly(
    DedDoc doc
)
Public Shared Function DocumentIsAssembly (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsAssembly(
    DedDoc^ doc
)
static member DocumentIsAssembly :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsDrawing

Metodo UtilDocumentIsDrawing

Restituisce se il documento passato è IDW o DWG.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsDrawing(
    DedDoc doc
)
Public Shared Function DocumentIsDrawing (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsDrawing(
    DedDoc^ doc
)
static member DocumentIsDrawing :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsDrawingOrPresentation

Metodo UtilDocumentIsDrawingOrPresentation

Restituisce se il documento passato è tavola o presentazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsDrawingOrPresentation(
    DedDoc doc
)
Public Shared Function DocumentIsDrawingOrPresentation (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsDrawingOrPresentation(
    DedDoc^ doc
)
static member DocumentIsDrawingOrPresentation :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsModel

Metodo UtilDocumentIsModel

Restituisce se il documento passato è IAM o IPT.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsModel(
    DedDoc doc
)
Public Shared Function DocumentIsModel (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsModel(
    DedDoc^ doc
)
static member DocumentIsModel :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsModelOrPresentation

Metodo UtilDocumentIsModelOrPresentation

Restituisce se il documento passato è tavola o presentazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsModelOrPresentation(
    DedDoc doc
)
Public Shared Function DocumentIsModelOrPresentation (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsModelOrPresentation(
    DedDoc^ doc
)
static member DocumentIsModelOrPresentation :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsOpenVisible

Metodo UtilDocumentIsOpenVisible

Ritorna true se il documento è aperto in modo visibile

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsOpenVisible(
    Document doc
)
Public Shared Function DocumentIsOpenVisible (
    doc As Document
) As Boolean
public:
static bool DocumentIsOpenVisible(
    Document^ doc
)
static member DocumentIsOpenVisible :
        doc : Document -> bool

Parametri

doc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsPart

Metodo UtilDocumentIsPart

Restituisce se il documento passato è IPT.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsPart(
    DedDoc doc
)
Public Shared Function DocumentIsPart (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsPart(
    DedDoc^ doc
)
static member DocumentIsPart :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.DocumentIsPresentation

Metodo UtilDocumentIsPresentation

Restituisce se il documento passato è IPN.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocumentIsPresentation(
    DedDoc doc
)
Public Shared Function DocumentIsPresentation (
    doc As DedDoc
) As Boolean
public:
static bool DocumentIsPresentation(
    DedDoc^ doc
)
static member DocumentIsPresentation :
        doc : DedDoc -> bool

Parametri

doc
Tipo: DedDoc
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.EliminaOwnerShipStruttureSpeciali

Metodo UtilEliminaOwnerShipStruttureSpeciali

Ripristina le caratteristiche di ownership dei componenti di struttura speciale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void EliminaOwnerShipStruttureSpeciali(
    DocStructInfoCollection items,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub EliminaOwnerShipStruttureSpeciali (
    items As DocStructInfoCollection,
    specStructInfos As UtilSpecialStructInfos
)
public:
static void EliminaOwnerShipStruttureSpeciali(
    DocStructInfoCollection^ items,
    UtilSpecialStructInfos^ specStructInfos
)
static member EliminaOwnerShipStruttureSpeciali :
        items : DocStructInfoCollection *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

items
Tipo: DocStructInfoCollection
Elementi dell'assieme principale del quale sostituire tutti i componenti speciali.
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsAssembly

Metodo UtilFileIsAssembly

Verifica e restituisce se il file passato sia o meno un file di assime.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsAssembly(
    string fileName
)
Public Shared Function FileIsAssembly (
    fileName As String
) As Boolean
public:
static bool FileIsAssembly(
    String^ fileName
)
static member FileIsAssembly :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsInventor

Metodo UtilFileIsInventor

Verifica e restituisce se il file passato sia o meno un file di interesse per Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsInventor(
    string fileName
)
Public Shared Function FileIsInventor (
    fileName As String
) As Boolean
public:
static bool FileIsInventor(
    String^ fileName
)
static member FileIsInventor :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsInventorDwg

Metodo UtilFileIsInventorDwg

Verifica e restituisce se il file passato sia o meno un file dwg di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsInventorDwg(
    string fileName
)
Public Shared Function FileIsInventorDwg (
    fileName As String
) As Boolean
public:
static bool FileIsInventorDwg(
    String^ fileName
)
static member FileIsInventorDwg :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsModel

Metodo UtilFileIsModel

Verifica e restituisce se il file passato sia o meno un file di modello di inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsModel(
    string fileName
)
Public Shared Function FileIsModel (
    fileName As String
) As Boolean
public:
static bool FileIsModel(
    String^ fileName
)
static member FileIsModel :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsPart

Metodo UtilFileIsPart

Verifica e restituisce se il file passato sia o meno un file di parte.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsPart(
    string fileName
)
Public Shared Function FileIsPart (
    fileName As String
) As Boolean
public:
static bool FileIsPart(
    String^ fileName
)
static member FileIsPart :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FileIsPresentation

Metodo UtilFileIsPresentation

Verifica e restituisce se il file passato sia o meno un file di assime.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsPresentation(
    string fileName
)
Public Shared Function FileIsPresentation (
    fileName As String
) As Boolean
public:
static bool FileIsPresentation(
    String^ fileName
)
static member FileIsPresentation :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FillWithAssociatedFiles

Metodo UtilFillWithAssociatedFiles

Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList FillWithAssociatedFiles(
    InvDocStructInfo infoItem,
    bool ignoreDataDocs = false
)
Public Shared Function FillWithAssociatedFiles (
    infoItem As InvDocStructInfo,
    Optional ignoreDataDocs As Boolean = false
) As DocStructInfoList
public:
static DocStructInfoList^ FillWithAssociatedFiles(
    InvDocStructInfo^ infoItem,
    bool ignoreDataDocs = false
)
static member FillWithAssociatedFiles :
        infoItem : InvDocStructInfo *
        ?ignoreDataDocs : bool
(* Defaults:
        let _ignoreDataDocs = defaultArg ignoreDataDocs false
*)
-> DocStructInfoList

Parametri

infoItem
Tipo: DedNetInvInvDocStructInfo
Elemento del quale trovare i file associati.
ignoreDataDocs (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DocStructInfoList
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FindDocumentInCollection

Metodo UtilFindDocumentInCollection

Cerca e restituisce il documento abbinato ad un file. Restituisce null se non lo trova. Lo cerca nella collezione di documenti passati (Documents oppure VisibleDocuments).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document FindDocumentInCollection(
    IEnumerator enumerator,
    string fileName
)
Public Shared Function FindDocumentInCollection (
    enumerator As IEnumerator,
    fileName As String
) As Document
public:
static Document^ FindDocumentInCollection(
    IEnumerator^ enumerator,
    String^ fileName
)
static member FindDocumentInCollection :
        enumerator : IEnumerator *
        fileName : string -> Document

Parametri

enumerator
Tipo: System.CollectionsIEnumerator
Enumeratore della collezione.
fileName
Tipo: SystemString
Nome completo del documento da cercare.

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FindInventorDocument

Metodo UtilFindInventorDocument

Lista degli overload
Nome | Descrizione
FindInventorDocument(String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
FindInventorDocument(String, String, Boolean) | Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FindInventorDocument (String, Boolean)

Metodo UtilFindInventorDocument (String, Boolean)
Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document FindInventorDocument(
    string fullDocumentName,
    bool ensureReturnFactory = false
)
Public Shared Function FindInventorDocument (
    fullDocumentName As String,
    Optional ensureReturnFactory As Boolean = false
) As Document
public:
static Document^ FindInventorDocument(
    String^ fullDocumentName,
    bool ensureReturnFactory = false
)
static member FindInventorDocument :
        fullDocumentName : string *
        ?ensureReturnFactory : bool
(* Defaults:
        let _ensureReturnFactory = defaultArg ensureReturnFactory false
*)
-> Document

Parametri

fullDocumentName
Tipo: SystemString
ensureReturnFactory (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di FindInventorDocument
Namespace DedNetInv


Metodo Util.FindInventorDocument (String, String, Boolean)

Metodo UtilFindInventorDocument (String, String, Boolean)
Cerca tra i documenti aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il documento non risulta aperto in Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document FindInventorDocument(
    string fullFileName,
    string config,
    bool ensureReturnFactory = false
)
Public Shared Function FindInventorDocument (
    fullFileName As String,
    config As String,
    Optional ensureReturnFactory As Boolean = false
) As Document
public:
static Document^ FindInventorDocument(
    String^ fullFileName,
    String^ config,
    bool ensureReturnFactory = false
)
static member FindInventorDocument :
        fullFileName : string *
        config : string *
        ?ensureReturnFactory : bool
(* Defaults:
        let _ensureReturnFactory = defaultArg ensureReturnFactory false
*)
-> Document

Parametri

fullFileName
Tipo: SystemString
Percorso del file da utilizzare per la ricerca.
config
Tipo: SystemString
ensureReturnFactory (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di FindInventorDocument
Namespace DedNetInv


Metodo Util.FindInventorFile

Metodo UtilFindInventorFile

Cerca tra i file aperti e presenti in Inventor e, se lo trova lo restituisce. Restituisce null se il file non risulta aperto in Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static File FindInventorFile(
    string fullFileName
)
Public Shared Function FindInventorFile (
    fullFileName As String
) As File
public:
static File^ FindInventorFile(
    String^ fullFileName
)
static member FindInventorFile :
        fullFileName : string -> File

Parametri

fullFileName
Tipo: SystemString
Percorso del file da utilizzare per la ricerca.

Valore di ritorno

Tipo: File
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FindInventorMemberDocument

Metodo UtilFindInventorMemberDocument

Lista degli overload
Nome | Descrizione
FindInventorMemberDocument(String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
FindInventorMemberDocument(String, String) | Cerca e restituisce il documento member abbinato ad un fullDocumentName. Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.FindInventorMemberDocument (String)

Metodo UtilFindInventorMemberDocument (String)
Cerca e restituisce il documento member abbinato ad un fullDocumentName Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document FindInventorMemberDocument(
    string fullDocumentName
)
Public Shared Function FindInventorMemberDocument (
    fullDocumentName As String
) As Document
public:
static Document^ FindInventorMemberDocument(
    String^ fullDocumentName
)
static member FindInventorMemberDocument :
        fullDocumentName : string -> Document

Parametri

fullDocumentName
Tipo: SystemString
Nome completo del documento da cercare.

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di FindInventorMemberDocument
Namespace DedNetInv


Metodo Util.FindInventorMemberDocument (String, String)

Metodo UtilFindInventorMemberDocument (String, String)
Cerca e restituisce il documento member abbinato ad un fullDocumentName. Se il documento non ha model states ma ha il fulldocumentname corretto viene comunque ritornato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document FindInventorMemberDocument(
    string fullFileName,
    string config
)
Public Shared Function FindInventorMemberDocument (
    fullFileName As String,
    config As String
) As Document
public:
static Document^ FindInventorMemberDocument(
    String^ fullFileName,
    String^ config
)
static member FindInventorMemberDocument :
        fullFileName : string *
        config : string -> Document

Parametri

fullFileName
Tipo: SystemString
Nome completo del file da cercare.
config
Tipo: SystemString
Configurazione di riferimento

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di FindInventorMemberDocument
Namespace DedNetInv


Metodo Util.FormatAttr

Metodo UtilFormatAttr

Legge e restituisce il valore di un attributo dal documento/occorrenza di inventor, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Object FormatAttr(
    QsInvAttr attrManager,
    DedAttr attr,
    ComponentOccurrence prt
)
Public Shared Function FormatAttr (
    attrManager As QsInvAttr,
    attr As DedAttr,
    prt As ComponentOccurrence
) As Object
public:
static Object^ FormatAttr(
    QsInvAttr^ attrManager,
    DedAttr^ attr,
    ComponentOccurrence^ prt
)
static member FormatAttr :
        attrManager : QsInvAttr *
        attr : DedAttr *
        prt : ComponentOccurrence -> Object

Parametri

attrManager
Tipo: QsInvAttr
Oggetto inizializzato da utilizzare per leggere il valore dell'attributo.
attr
Tipo: DedAttr
Attributo da leggere.
prt
Tipo: ComponentOccurrence

Valore di ritorno

Tipo: Object
Restituisce il valore letto oppure null se non lo trova o se non riesce a convertirlo nel tipo di dati richiesto.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetActiveLOD

Metodo UtilGetActiveLOD

Restituisce il livello di dettaglio attivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LevelOfDetailRepresentation GetActiveLOD(
    AssemblyDocument asmDoc
)
Public Shared Function GetActiveLOD (
    asmDoc As AssemblyDocument
) As LevelOfDetailRepresentation
public:
static LevelOfDetailRepresentation^ GetActiveLOD(
    AssemblyDocument^ asmDoc
)
static member GetActiveLOD :
        asmDoc : AssemblyDocument -> LevelOfDetailRepresentation

Parametri

asmDoc
Tipo: AssemblyDocument
Assieme da analizzare.

Valore di ritorno

Tipo: LevelOfDetailRepresentation
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetActiveModelState

Metodo UtilGetActiveModelState

Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ModelState GetActiveModelState(
    Document invDoc
)
Public Shared Function GetActiveModelState (
    invDoc As Document
) As ModelState
public:
static ModelState^ GetActiveModelState(
    Document^ invDoc
)
static member GetActiveModelState :
        invDoc : Document -> ModelState

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: ModelState
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetActiveModelStateKey

Metodo UtilGetActiveModelStateKey

Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveModelStateKey(
    Document invDoc
)
Public Shared Function GetActiveModelStateKey (
    invDoc As Document
) As String
public:
static String^ GetActiveModelStateKey(
    Document^ invDoc
)
static member GetActiveModelStateKey :
        invDoc : Document -> string

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetActiveModelStateName

Metodo UtilGetActiveModelStateName

Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActiveModelStateName(
    Document invDoc
)
Public Shared Function GetActiveModelStateName (
    invDoc As Document
) As String
public:
static String^ GetActiveModelStateName(
    Document^ invDoc
)
static member GetActiveModelStateName :
        invDoc : Document -> string

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetActualModelStateName

Metodo UtilGetActualModelStateName

Dato un filename ed una configurazione, ritorna l'effettivo nome del model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetActualModelStateName(
    string config
)
Public Shared Function GetActualModelStateName (
    config As String
) As String
public:
static String^ GetActualModelStateName(
    String^ config
)
static member GetActualModelStateName :
        config : string -> string

Parametri

config
Tipo: SystemString
Configurazione secondo lo standard DED+

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetAllInventorFiles

Metodo UtilGetAllInventorFiles

Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetAllInventorFiles(
    string refPath
)
Public Shared Function GetAllInventorFiles (
    refPath As String
) As List(Of String)
public:
static List<String^>^ GetAllInventorFiles(
    String^ refPath
)
static member GetAllInventorFiles :
        refPath : string -> List<string>

Parametri

refPath
Tipo: SystemString

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetApplicationUserVer

Metodo UtilGetApplicationUserVer

Restituisce la versione di inventor da visualizzare all'utente.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetApplicationUserVer(
    Application app
)
Public Shared Function GetApplicationUserVer (
    app As Application
) As String
public:
static String^ GetApplicationUserVer(
    Application^ app
)
static member GetApplicationUserVer :
        app : Application -> string

Parametri

app
Tipo: Application

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetAssembly

Metodo UtilGetAssembly

Restituisce il documento convertito in AssemblyDocument oppure null se non riesce.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AssemblyDocument GetAssembly(
    Document invDoc
)
Public Shared Function GetAssembly (
    invDoc As Document
) As AssemblyDocument
public:
static AssemblyDocument^ GetAssembly(
    Document^ invDoc
)
static member GetAssembly :
        invDoc : Document -> AssemblyDocument

Parametri

invDoc
Tipo: Document
Documento da convertire.

Valore di ritorno

Tipo: AssemblyDocument
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetAssociativeForeignFilename

Metodo UtilGetAssociativeForeignFilename

Restituisce se il documento passato è di modello.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetAssociativeForeignFilename(
    Document invDoc
)
Public Shared Function GetAssociativeForeignFilename (
    invDoc As Document
) As String
public:
static String^ GetAssociativeForeignFilename(
    Document^ invDoc
)
static member GetAssociativeForeignFilename :
        invDoc : Document -> string

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetAttrList

Metodo UtilGetAttrList

Restituisce la lista di attributi richiesti, abbinati all'anagrafica passata. L'anagrafica può essere anche null, in tal caso viene restituita la lista degli attributi di Tutti i tipi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList GetAttrList(
    IDedData data,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function GetAttrList (
    data As IDedData,
    attrsType As UtilDataAttrTypeEnum
) As DedAttrList
public:
static DedAttrList^ GetAttrList(
    IDedData^ data,
    UtilDataAttrTypeEnum attrsType
)
static member GetAttrList :
        data : IDedData *
        attrsType : UtilDataAttrTypeEnum -> DedAttrList

Parametri

data
Tipo: IDedData
Anagrafica dalla quale leggere la lista degli attributi (se null viene restituita la lista degli attributi di Tutti i tipi).
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi richiesta.

Valore di ritorno

Tipo: DedAttrList
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetBomStructure

Metodo UtilGetBomStructure

Restituisce la BOMStructureEnum del documento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static BOMStructureEnum GetBomStructure(
    Document invDoc
)
Public Shared Function GetBomStructure (
    invDoc As Document
) As BOMStructureEnum
public:
static BOMStructureEnum GetBomStructure(
    Document^ invDoc
)
static member GetBomStructure :
        invDoc : Document -> BOMStructureEnum

Parametri

invDoc
Tipo: Document
Documento di Inventor

Valore di ritorno

Tipo: BOMStructureEnum
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetCfgStructure

Metodo UtilGetCfgStructure

Restituisce la struttura delle configurazioni del documento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, string> GetCfgStructure(
    Document invdoc
)
Public Shared Function GetCfgStructure (
    invdoc As Document
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ GetCfgStructure(
    Document^ invdoc
)
static member GetCfgStructure :
        invdoc : Document -> Dictionary<string, string>

Parametri

invdoc
Tipo: Document
Documento

Valore di ritorno

Tipo: Dictionary String, String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetChildControls

Metodo UtilGetChildControls

Ritorna una lista di controlli contenuti nella finestra passata.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IntPtr[] GetChildControls(
    IntPtr ParentHandle
)
Public Shared Function GetChildControls (
    ParentHandle As IntPtr
) As IntPtr()
public:
static array<IntPtr>^ GetChildControls(
    IntPtr ParentHandle
)
static member GetChildControls :
        ParentHandle : IntPtr -> IntPtr[]

Parametri

ParentHandle
Tipo: SystemIntPtr
Handle di riferimento

Valore di ritorno

Tipo: IntPtr
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetConfigName

Metodo UtilGetConfigName

Lista degli overload
Nome | Descrizione
GetConfigName(ModelState) | Ritorna il nome della configurazione corrente del documento secondo lo standard DED+
GetConfigName(String) | Dato il nome di una configurazione, Restituisce il nome secondo lo standard DED+
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetConfigName (ModelState)

Metodo UtilGetConfigName (ModelState)
Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetConfigName(
    ModelState ms
)
Public Shared Function GetConfigName (
    ms As ModelState
) As String
public:
static String^ GetConfigName(
    ModelState^ ms
)
static member GetConfigName :
        ms : ModelState -> string

Parametri

ms
Tipo: ModelState

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Overload di GetConfigName
Namespace DedNetInv


Metodo Util.GetConfigName (String)

Metodo UtilGetConfigName (String)
Dato il nome di una configurazione, Restituisce il nome secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetConfigName(
    string config
)
Public Shared Function GetConfigName (
    config As String
) As String
public:
static String^ GetConfigName(
    String^ config
)
static member GetConfigName :
        config : string -> string

Parametri

config
Tipo: SystemString
Configurazione

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Overload di GetConfigName
Namespace DedNetInv


Metodo Util.GetDataFromDedDoc

Metodo UtilGetDataFromDedDoc

Ritorna l'anagrafica associata al documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData GetDataFromDedDoc(
    DedDoc ddoc
)
Public Shared Function GetDataFromDedDoc (
    ddoc As DedDoc
) As DedData
public:
static DedData^ GetDataFromDedDoc(
    DedDoc^ ddoc
)
static member GetDataFromDedDoc :
        ddoc : DedDoc -> DedData

Parametri

ddoc
Tipo: DedDoc
Documento di riferimento

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetDerivedDocs

Metodo UtilGetDerivedDocs

Restituisce la lista dei documenti derivati di una parte (.ipt). Se non trova alcun documento restituisce la lista vuota.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<Document> GetDerivedDocs(
    Document oDoc
)
Public Shared Function GetDerivedDocs (
    oDoc As Document
) As List(Of Document)
public:
static List<Document^>^ GetDerivedDocs(
    Document^ oDoc
)
static member GetDerivedDocs :
        oDoc : Document -> List<Document>

Parametri

oDoc
Tipo: Document
Oggetto Document di Inventor.

Valore di ritorno

Tipo: List Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetDesktopWindow

Metodo UtilGetDesktopWindow

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static IntPtr GetDesktopWindow()
Public Shared Function GetDesktopWindow As IntPtr
public:
static IntPtr GetDesktopWindow()
static member GetDesktopWindow : unit -> IntPtr

Valore di ritorno

Tipo: IntPtr
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetDrawing

Metodo UtilGetDrawing

Restituisce il documento convertito in DrawingDocument oppure null se non riesce.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DrawingDocument GetDrawing(
    Document invDoc
)
Public Shared Function GetDrawing (
    invDoc As Document
) As DrawingDocument
public:
static DrawingDocument^ GetDrawing(
    Document^ invDoc
)
static member GetDrawing :
        invDoc : Document -> DrawingDocument

Parametri

invDoc
Tipo: Document
Documento da convertire.

Valore di ritorno

Tipo: DrawingDocument
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetEmbeddedIcon

Metodo UtilGetEmbeddedIcon

Data l'estensione restituisce l'icona dell'oggetto embedded (Anycad)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Image GetEmbeddedIcon(
    string ext
)
Public Shared Function GetEmbeddedIcon (
    ext As String
) As Image
public:
static Image^ GetEmbeddedIcon(
    String^ ext
)
static member GetEmbeddedIcon :
        ext : string -> Image

Parametri

ext
Tipo: SystemString
estensione con .

Valore di ritorno

Tipo: Image
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetFullDocumentNameOnOpenOptions

Metodo UtilGetFullDocumentNameOnOpenOptions

In caso di assieme ritorna il full document name compatibilmente con le impostazioni di livello di dettaglio in apertura. L'opzione può essere principale, tutti i comp. soppressi, tutte le parti soppresse ed ultimo attivo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetFullDocumentNameOnOpenOptions(
    string fullFileName,
    string lastActiveLodFileName = null
)
Public Shared Function GetFullDocumentNameOnOpenOptions (
    fullFileName As String,
    Optional lastActiveLodFileName As String = Nothing
) As String
public:
static String^ GetFullDocumentNameOnOpenOptions(
    String^ fullFileName,
    String^ lastActiveLodFileName = nullptr
)
static member GetFullDocumentNameOnOpenOptions :
        fullFileName : string *
        ?lastActiveLodFileName : string
(* Defaults:
        let _lastActiveLodFileName = defaultArg lastActiveLodFileName null
*)
-> string

Parametri

fullFileName
Tipo: SystemString
Nome completo del documento d'assieme
lastActiveLodFileName (Optional)
Tipo: SystemString
Nome completo del documento d'assieme dal quale reperire eventualmente le informazioni su l'ultimo livello di dettaglio.

Valore di ritorno

Tipo: String
FullDocumentName dell'assieme
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetHWndText

Metodo UtilGetHWndText

Ritorna la caption della finestra / controllo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetHWndText(
    IntPtr hwnd
)
Public Shared Function GetHWndText (
    hwnd As IntPtr
) As String
public:
static String^ GetHWndText(
    IntPtr hwnd
)
static member GetHWndText :
        hwnd : IntPtr -> string

Parametri

hwnd
Tipo: SystemIntPtr
Handle di riferimento

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetLastDataRowVer

Metodo UtilGetLastDataRowVer

Lista degli overload
Nome | Descrizione
GetLastDataRowVer(Document) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(ModelState) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura.
GetLastDataRowVer(String) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetLastDataRowVer (Document)

Metodo UtilGetLastDataRowVer (Document)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    Document invDoc
)
Public Shared Function GetLastDataRowVer (
    invDoc As Document
) As Guid
public:
static Guid GetLastDataRowVer(
    Document^ invDoc
)
static member GetLastDataRowVer :
        invDoc : Document -> Guid

Parametri

invDoc
Tipo: Document
Documento dal quale leggere.

Valore di ritorno

Tipo: Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer
Namespace DedNetInv


Metodo Util.GetLastDataRowVer (ModelState)

Metodo UtilGetLastDataRowVer (ModelState)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    ModelState ms
)
Public Shared Function GetLastDataRowVer (
    ms As ModelState
) As Guid
public:
static Guid GetLastDataRowVer(
    ModelState^ ms
)
static member GetLastDataRowVer :
        ms : ModelState -> Guid

Parametri

ms
Tipo: ModelState

Valore di ritorno

Tipo: Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer
Namespace DedNetInv


Metodo Util.GetLastDataRowVer (String)

Metodo UtilGetLastDataRowVer (String)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    string fullFileName
)
Public Shared Function GetLastDataRowVer (
    fullFileName As String
) As Guid
public:
static Guid GetLastDataRowVer(
    String^ fullFileName
)
static member GetLastDataRowVer :
        fullFileName : string -> Guid

Parametri

fullFileName
Tipo: SystemString
File name dal quale leggere.

Valore di ritorno

Tipo: Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer
Namespace DedNetInv


Metodo Util.GetMasterLOD

Metodo UtilGetMasterLOD

Restituisce il livello di dettaglio principale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LevelOfDetailRepresentation GetMasterLOD(
    AssemblyDocument asmDoc
)
Public Shared Function GetMasterLOD (
    asmDoc As AssemblyDocument
) As LevelOfDetailRepresentation
public:
static LevelOfDetailRepresentation^ GetMasterLOD(
    AssemblyDocument^ asmDoc
)
static member GetMasterLOD :
        asmDoc : AssemblyDocument -> LevelOfDetailRepresentation

Parametri

asmDoc
Tipo: AssemblyDocument
Assieme da analizzare.

Valore di ritorno

Tipo: LevelOfDetailRepresentation
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetMasterModelState

Metodo UtilGetMasterModelState

Se esiste, dato il documento ritorna il master model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ModelState GetMasterModelState(
    Document invDoc
)
Public Shared Function GetMasterModelState (
    invDoc As Document
) As ModelState
public:
static ModelState^ GetMasterModelState(
    Document^ invDoc
)
static member GetMasterModelState :
        invDoc : Document -> ModelState

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: ModelState
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetModelStateKey

Metodo UtilGetModelStateKey

Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetModelStateKey(
    Document invDoc,
    ModelState ms
)
Public Shared Function GetModelStateKey (
    invDoc As Document,
    ms As ModelState
) As String
public:
static String^ GetModelStateKey(
    Document^ invDoc,
    ModelState^ ms
)
static member GetModelStateKey :
        invDoc : Document *
        ms : ModelState -> string

Parametri

invDoc
Tipo: Document
ms
Tipo: ModelState

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetModelStateName

Metodo UtilGetModelStateName

Ritorna il nome della configurazione corrente del documento secondo lo standard DED+

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetModelStateName(
    Document invDoc,
    string msKey
)
Public Shared Function GetModelStateName (
    invDoc As Document,
    msKey As String
) As String
public:
static String^ GetModelStateName(
    Document^ invDoc,
    String^ msKey
)
static member GetModelStateName :
        invDoc : Document *
        msKey : string -> string

Parametri

invDoc
Tipo: Document
msKey
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetModelStateNames

Metodo UtilGetModelStateNames

Ritorna i model states del documento. E' sempre l'elenco dei model state della factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetModelStateNames(
    Document invDoc
)
Public Shared Function GetModelStateNames (
    invDoc As Document
) As List(Of String)
public:
static List<String^>^ GetModelStateNames(
    Document^ invDoc
)
static member GetModelStateNames :
        invDoc : Document -> List<string>

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetModelStates

Metodo UtilGetModelStates

Ritorna i model states del documento. E' sempre l'elenco dei model state della factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ModelStates GetModelStates(
    Document invDoc
)
Public Shared Function GetModelStates (
    invDoc As Document
) As ModelStates
public:
static ModelStates^ GetModelStates(
    Document^ invDoc
)
static member GetModelStates :
        invDoc : Document -> ModelStates

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: ModelStates
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetNastranInCADReferences

Metodo UtilGetNastranInCADReferences

Lista degli overload
Nome | Descrizione
GetNastranInCADReferences(Document) | Ritorna la lista dei riferimenti Nastran dato il documento passato
GetNastranInCADReferences(String) | Ritorna la lista dei riferimenti Nastran dato il filename passato
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetNastranInCADReferences (Document)

Metodo UtilGetNastranInCADReferences (Document)
Ritorna la lista dei riferimenti Nastran dato il documento passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetNastranInCADReferences(
    Document invDoc
)
Public Shared Function GetNastranInCADReferences (
    invDoc As Document
) As List(Of String)
public:
static List<String^>^ GetNastranInCADReferences(
    Document^ invDoc
)
static member GetNastranInCADReferences :
        invDoc : Document -> List<string>

Parametri

invDoc
Tipo: Document
Documento in esame

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util
Overload di GetNastranInCADReferences
Namespace DedNetInv


Metodo Util.GetNastranInCADReferences (String)

Metodo UtilGetNastranInCADReferences (String)
Ritorna la lista dei riferimenti Nastran dato il filename passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetNastranInCADReferences(
    string filename
)
Public Shared Function GetNastranInCADReferences (
    filename As String
) As List(Of String)
public:
static List<String^>^ GetNastranInCADReferences(
    String^ filename
)
static member GetNastranInCADReferences :
        filename : string -> List<string>

Parametri

filename
Tipo: SystemString
Documento in esame

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util
Overload di GetNastranInCADReferences
Namespace DedNetInv


Metodo Util.GetOccurrenceNameWithoutPosNumber

Metodo UtilGetOccurrenceNameWithoutPosNumber

Ritorna il nome dell'occorrenza privato della posizione

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetOccurrenceNameWithoutPosNumber(
    string occFullName
)
Public Shared Function GetOccurrenceNameWithoutPosNumber (
    occFullName As String
) As String
public:
static String^ GetOccurrenceNameWithoutPosNumber(
    String^ occFullName
)
static member GetOccurrenceNameWithoutPosNumber :
        occFullName : string -> string

Parametri

occFullName
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetPart

Metodo UtilGetPart

Restituisce il documento convertito in PartDocument oppure null se non riesce.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartDocument GetPart(
    Document invDoc
)
Public Shared Function GetPart (
    invDoc As Document
) As PartDocument
public:
static PartDocument^ GetPart(
    Document^ invDoc
)
static member GetPart :
        invDoc : Document -> PartDocument

Parametri

invDoc
Tipo: Document
Documento da convertire.

Valore di ritorno

Tipo: PartDocument
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetPresentation

Metodo UtilGetPresentation

Restituisce il documento convertito in PresentationDocument oppure null se non riesce.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PresentationDocument GetPresentation(
    Document invDoc
)
Public Shared Function GetPresentation (
    invDoc As Document
) As PresentationDocument
public:
static PresentationDocument^ GetPresentation(
    Document^ invDoc
)
static member GetPresentation :
        invDoc : Document -> PresentationDocument

Parametri

invDoc
Tipo: Document
Documento da convertire.

Valore di ritorno

Tipo: PresentationDocument
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetPreview

Metodo UtilGetPreview

Ritorna l'anteprima del documento sotto forma di bitmap

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap GetPreview(
    Document doc
)
Public Shared Function GetPreview (
    doc As Document
) As Bitmap
public:
static Bitmap^ GetPreview(
    Document^ doc
)
static member GetPreview :
        doc : Document -> Bitmap

Parametri

doc
Tipo: Document

Valore di ritorno

Tipo: Bitmap
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetQsPublisherOutName

Metodo UtilGetQsPublisherOutName

Dato il documento attivo e la configurazione del publisher calcolo il nome di pubblicazione in base alle regole del publish manager eventualmente personalizzate tramite evento. Anche in caso di formati potenzialmente multifoglio ritorno il nome completo. Sarà poi il publisher a fornire a posteriori la formattazione corretta.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetQsPublisherOutName(
    Document invDoc,
    string cfg
)
Public Shared Function GetQsPublisherOutName (
    invDoc As Document,
    cfg As String
) As String
public:
static String^ GetQsPublisherOutName(
    Document^ invDoc,
    String^ cfg
)
static member GetQsPublisherOutName :
        invDoc : Document *
        cfg : string -> string

Parametri

invDoc
Tipo: Document
Documento di inventor in pubblicazione
cfg
Tipo: SystemString
Configurazione ottenuta dal descrittore del QsPublisher

Valore di ritorno

Tipo: String
Se può torna il file name di pubblicazione. Se non è possibile ritorna null
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetSafeReferenceFullFileName

Metodo UtilGetSafeReferenceFullFileName

Dato il descrittore ritorna il percorso del riferimento più coerente possibile col progetto. ResolvedFullFileName è però più affidabile nel caso Inventor abbia risolto tramite path del progetto in un percorso diverso dall'ultimo usato (secondo Barbara Hann).

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetSafeReferenceFullFileName(
    FileDescriptor fDescr
)
Public Shared Function GetSafeReferenceFullFileName (
    fDescr As FileDescriptor
) As String
public:
static String^ GetSafeReferenceFullFileName(
    FileDescriptor^ fDescr
)
static member GetSafeReferenceFullFileName :
        fDescr : FileDescriptor -> string

Parametri

fDescr
Tipo: FileDescriptor

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.GetSmallFileIcon

Metodo UtilGetSmallFileIcon

Data la tipologia di documento ritorna l'icona dalla risorse del progetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Image GetSmallFileIcon(
    Document invDoc
)
Public Shared Function GetSmallFileIcon (
    invDoc As Document
) As Image
public:
static Image^ GetSmallFileIcon(
    Document^ invDoc
)
static member GetSmallFileIcon :
        invDoc : Document -> Image

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Image
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.HasModelStates

Metodo UtilHasModelStates

Ritorna vero se il documento ha dei model state

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HasModelStates(
    Document invDoc
)
Public Shared Function HasModelStates (
    invDoc As Document
) As Boolean
public:
static bool HasModelStates(
    Document^ invDoc
)
static member HasModelStates :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ImpostaDatiClonazioneStrutture

Metodo UtilImpostaDatiClonazioneStrutture

Imposta ricorsivamente, da clonare gli elementi delle strutture speciali, compresi i dati necessari alla clonazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void ImpostaDatiClonazioneStrutture(
    DocStructInfoCollection items,
    string destMainAssemblyFullName,
    string parentNameOnlyFrom,
    List<string> madeList,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub ImpostaDatiClonazioneStrutture (
    items As DocStructInfoCollection,
    destMainAssemblyFullName As String,
    parentNameOnlyFrom As String,
    madeList As List(Of String),
    specStructInfos As UtilSpecialStructInfos
)
public:
static void ImpostaDatiClonazioneStrutture(
    DocStructInfoCollection^ items,
    String^ destMainAssemblyFullName,
    String^ parentNameOnlyFrom,
    List<String^>^ madeList,
    UtilSpecialStructInfos^ specStructInfos
)
static member ImpostaDatiClonazioneStrutture :
        items : DocStructInfoCollection *
        destMainAssemblyFullName : string *
        parentNameOnlyFrom : string *
        madeList : List<string> *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

items
Tipo: DocStructInfoCollection
Elementi da elaborare.
destMainAssemblyFullName
Tipo: SystemString
Percorso completo di destinazione dell'assieme in salvataggio.
parentNameOnlyFrom
Tipo: SystemString
Solo nome del padre in salvataggio.
madeList
Tipo: System.Collections.GenericList String
Lista degli elementi già creati in modo da non creare due nomi uguali.
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvDoc2DedDataPart

Metodo UtilInvDoc2DedDataPart

Lista degli overload
Nome | Descrizione
InvDoc2DedDataPart(Document) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere ed avere l'elenco attributi.
InvDoc2DedDataPart(Document, DedAttrList) | Legge i dati dal documento e li inserisce in una DedDataPart. Legge direttamente l'elenco attributi dal parametro passato.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
InvDoc2DedDataPart(Document, UtilDataAttrTypeEnum, Boolean) | Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvDoc2DedDataPart (Document)

Metodo UtilInvDoc2DedDataPart (Document)
Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere ed avere l'elenco attributi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvDoc2DedDataPart(
    Document invDoc
)
Public Shared Function InvDoc2DedDataPart (
    invDoc As Document
) As DedDataPart
public:
static DedDataPart^ InvDoc2DedDataPart(
    Document^ invDoc
)
static member InvDoc2DedDataPart :
        invDoc : Document -> DedDataPart

Parametri

invDoc
Tipo: Document
Documento di inventor dal quale leggere i dati.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvDoc2DedDataPart
Namespace DedNetInv


Metodo Util.InvDoc2DedDataPart (Document, DedAttrList)

Metodo UtilInvDoc2DedDataPart (Document, DedAttrList)
Legge i dati dal documento e li inserisce in una DedDataPart. Legge direttamente l'elenco attributi dal parametro passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvDoc2DedDataPart(
    Document invDoc,
    DedAttrList attrList
)
Public Shared Function InvDoc2DedDataPart (
    invDoc As Document,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ InvDoc2DedDataPart(
    Document^ invDoc,
    DedAttrList^ attrList
)
static member InvDoc2DedDataPart :
        invDoc : Document *
        attrList : DedAttrList -> DedDataPart

Parametri

invDoc
Tipo: Document
Documento di inventor dal quale leggere i dati.
attrList
Tipo: DedAttrList
Elenco attributi per creare il dedDataPart.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvDoc2DedDataPart
Namespace DedNetInv


Metodo Util.InvDoc2DedDataPart (Document, Util.DataAttrTypeEnum)

Metodo UtilInvDoc2DedDataPart (Document, UtilDataAttrTypeEnum)
Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvDoc2DedDataPart(
    Document invDoc,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function InvDoc2DedDataPart (
    invDoc As Document,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ InvDoc2DedDataPart(
    Document^ invDoc,
    UtilDataAttrTypeEnum attrsType
)
static member InvDoc2DedDataPart :
        invDoc : Document *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

invDoc
Tipo: Document
Documento di inventor dal quale leggere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera leggere dal documento.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvDoc2DedDataPart
Namespace DedNetInv


Metodo Util.InvDoc2DedDataPart (Document, Util.DataAttrTypeEnum, Boolean)

Metodo UtilInvDoc2DedDataPart (Document, UtilDataAttrTypeEnum, Boolean)
Legge i dati dal documento e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvDoc2DedDataPart(
    Document invDoc,
    UtilDataAttrTypeEnum attrsType,
    bool checkDataMatching
)
Public Shared Function InvDoc2DedDataPart (
    invDoc As Document,
    attrsType As UtilDataAttrTypeEnum,
    checkDataMatching As Boolean
) As DedDataPart
public:
static DedDataPart^ InvDoc2DedDataPart(
    Document^ invDoc,
    UtilDataAttrTypeEnum attrsType,
    bool checkDataMatching
)
static member InvDoc2DedDataPart :
        invDoc : Document *
        attrsType : UtilDataAttrTypeEnum *
        checkDataMatching : bool -> DedDataPart

Parametri

invDoc
Tipo: Document
Documento di inventor dal quale leggere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera leggere dal documento.
checkDataMatching
Tipo: SystemBoolean
Indica se effettuare o meno il controllo di coerenza. Se false considera buona l'anagrafica letta dagli attributi

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvDoc2DedDataPart
Namespace DedNetInv


Metodo Util.InvDoc2DedDoc

Metodo UtilInvDoc2DedDoc

Legge il percorso del documento passato e ne resituisce il DedDoc. Se il documento non è ancora salvato o se non è nel Database restituisce null. Ignora eventuali errori.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc InvDoc2DedDoc(
    Document doc
)
Public Shared Function InvDoc2DedDoc (
    doc As Document
) As DedDoc
public:
static DedDoc^ InvDoc2DedDoc(
    Document^ doc
)
static member InvDoc2DedDoc :
        doc : Document -> DedDoc

Parametri

doc
Tipo: Document
Documento di inventor.

Valore di ritorno

Tipo: DedDoc
Restituisce il DedDoc associato al documento oppure null se non lo trova.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvDocAttrMatchData

Metodo UtilInvDocAttrMatchData

Controlla se gli attributi ID e REV letti nel documento coincidono con quelli associati all'anagrafica passata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool InvDocAttrMatchData(
    Document invDoc,
    DedData data
)
Public Shared Function InvDocAttrMatchData (
    invDoc As Document,
    data As DedData
) As Boolean
public:
static bool InvDocAttrMatchData(
    Document^ invDoc,
    DedData^ data
)
static member InvDocAttrMatchData :
        invDoc : Document *
        data : DedData -> bool

Parametri

invDoc
Tipo: Document
Documento di Inventor
data
Tipo: DedData
Anagrafica di riferimento per il confronto

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvFile2DedDataPart

Metodo UtilInvFile2DedDataPart

Lista degli overload
Nome | Descrizione
InvFile2DedDataPart(String, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, DedAttrList) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
InvFile2DedDataPart(String, DedType, UtilDataAttrTypeEnum) | Legge i dati dal file di inventor secondo la tiplogia richiesta e li inserisce in una DedDataPart.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvFile2DedDataPart (String, DedType)

Metodo UtilInvFile2DedDataPart (String, DedType)
Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvFile2DedDataPart(
    string filename,
    DedType refType
)
Public Shared Function InvFile2DedDataPart (
    filename As String,
    refType As DedType
) As DedDataPart
public:
static DedDataPart^ InvFile2DedDataPart(
    String^ filename,
    DedType^ refType
)
static member InvFile2DedDataPart :
        filename : string *
        refType : DedType -> DedDataPart

Parametri

filename
Tipo: SystemString
File di interesse di Inventor
refType
Tipo: DedType
Famiglia di riferimento

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvFile2DedDataPart
Namespace DedNetInv


Metodo Util.InvFile2DedDataPart (String, DedType, DedAttrList)

Metodo UtilInvFile2DedDataPart (String, DedType, DedAttrList)
Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvFile2DedDataPart(
    string filename,
    DedType refType,
    DedAttrList attrList
)
Public Shared Function InvFile2DedDataPart (
    filename As String,
    refType As DedType,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ InvFile2DedDataPart(
    String^ filename,
    DedType^ refType,
    DedAttrList^ attrList
)
static member InvFile2DedDataPart :
        filename : string *
        refType : DedType *
        attrList : DedAttrList -> DedDataPart

Parametri

filename
Tipo: SystemString
File di interesse di Inventor
refType
Tipo: DedType
Famiglia di riferimento
attrList
Tipo: DedAttrList
Elenco attributi per creare il dedDataPart.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvFile2DedDataPart
Namespace DedNetInv


Metodo Util.InvFile2DedDataPart (String, DedType, Util.DataAttrTypeEnum)

Metodo UtilInvFile2DedDataPart (String, DedType, UtilDataAttrTypeEnum)
Legge i dati dal file di inventor secondo la tiplogia richiesta e li inserisce in una DedDataPart.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvFile2DedDataPart(
    string filename,
    DedType refType,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function InvFile2DedDataPart (
    filename As String,
    refType As DedType,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ InvFile2DedDataPart(
    String^ filename,
    DedType^ refType,
    UtilDataAttrTypeEnum attrsType
)
static member InvFile2DedDataPart :
        filename : string *
        refType : DedType *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

filename
Tipo: SystemString
File di interesse di Inventor
refType
Tipo: DedType
Famiglia di riferimento
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipologia di attributi richiesti

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvFile2DedDataPart
Namespace DedNetInv


Metodo Util.InvFileAttrMatchData

Metodo UtilInvFileAttrMatchData

Controlla se gli attributi ID e REV letti nel file coincidono con quelli associati all'anagrafica passata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool InvFileAttrMatchData(
    string invFileName,
    DedData data
)
Public Shared Function InvFileAttrMatchData (
    invFileName As String,
    data As DedData
) As Boolean
public:
static bool InvFileAttrMatchData(
    String^ invFileName,
    DedData^ data
)
static member InvFileAttrMatchData :
        invFileName : string *
        data : DedData -> bool

Parametri

invFileName
Tipo: SystemString
Path del file di Inventor
data
Tipo: DedData
Anagrafica di riferimento per il confronto

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvOcc2DedDataPart

Metodo UtilInvOcc2DedDataPart

Lista degli overload
Nome | Descrizione
InvOcc2DedDataPart(ComponentOccurrence, DedAttrList) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Utilizza la lista di attributi passata
InvOcc2DedDataPart(ComponentOccurrence, UtilDataAttrTypeEnum) | Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.InvOcc2DedDataPart (ComponentOccurrence, DedAttrList)

Metodo UtilInvOcc2DedDataPart (ComponentOccurrence, DedAttrList)
Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Utilizza la lista di attributi passata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvOcc2DedDataPart(
    ComponentOccurrence invOcc,
    DedAttrList attrList
)
Public Shared Function InvOcc2DedDataPart (
    invOcc As ComponentOccurrence,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ InvOcc2DedDataPart(
    ComponentOccurrence^ invOcc,
    DedAttrList^ attrList
)
static member InvOcc2DedDataPart :
        invOcc : ComponentOccurrence *
        attrList : DedAttrList -> DedDataPart

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza di inventor dalla quale leggere i dati.
attrList
Tipo: DedAttrList
Lista attributi che si desidera leggere dall'occorrenza.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvOcc2DedDataPart
Namespace DedNetInv


Metodo Util.InvOcc2DedDataPart (ComponentOccurrence, Util.DataAttrTypeEnum)

Metodo UtilInvOcc2DedDataPart (ComponentOccurrence, UtilDataAttrTypeEnum)
Legge i dati dall'occorrenza e li inserisce in una DedDataPart. Ricava l'anagrafica di appartenenza per sapere gli attributi da leggere. Se non la trova usa la lista degli attributi di anagrafica comuni.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart InvOcc2DedDataPart(
    ComponentOccurrence invOcc,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function InvOcc2DedDataPart (
    invOcc As ComponentOccurrence,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ InvOcc2DedDataPart(
    ComponentOccurrence^ invOcc,
    UtilDataAttrTypeEnum attrsType
)
static member InvOcc2DedDataPart :
        invOcc : ComponentOccurrence *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

invOcc
Tipo: ComponentOccurrence
Occorrenza di inventor dalla quale leggere i dati.
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera leggere dall'occorrenza.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di InvOcc2DedDataPart
Namespace DedNetInv


Metodo Util.InvOcc2DedDoc

Metodo UtilInvOcc2DedDoc

Legge il percorso dell'occorrenza passata e ne resituisce il DedDoc. Se l'occorrenza non è ancora salvata o se non è nel Database o se non ha associato alcun file, restituisce null. Ignora eventuali errori.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc InvOcc2DedDoc(
    ComponentOccurrence occ
)
Public Shared Function InvOcc2DedDoc (
    occ As ComponentOccurrence
) As DedDoc
public:
static DedDoc^ InvOcc2DedDoc(
    ComponentOccurrence^ occ
)
static member InvOcc2DedDoc :
        occ : ComponentOccurrence -> DedDoc

Parametri

occ
Tipo: ComponentOccurrence
Occorrenza di inventor.

Valore di ritorno

Tipo: DedDoc
Restituisce il DedDoc associato oppure null se non lo trova.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsAnyCadReferenceName

Metodo UtilIsAnyCadReferenceName

Dato il path del riferimento padre e il path del file in oggetto ritorna vero se si tratta di un potenziale documento di anycad.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAnyCadReferenceName(
    string parentFullName,
    string refFullName
)
Public Shared Function IsAnyCadReferenceName (
    parentFullName As String,
    refFullName As String
) As Boolean
public:
static bool IsAnyCadReferenceName(
    String^ parentFullName,
    String^ refFullName
)
static member IsAnyCadReferenceName :
        parentFullName : string *
        refFullName : string -> bool

Parametri

parentFullName
Tipo: SystemString
Riferimento Padre
refFullName
Tipo: SystemString
File da esaminare

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsAssemblyFactory

Metodo UtilIsAssemblyFactory

Restituisce vero se il documento passato è una Part Factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAssemblyFactory(
    Document invDoc
)
Public Shared Function IsAssemblyFactory (
    invDoc As Document
) As Boolean
public:
static bool IsAssemblyFactory(
    Document^ invDoc
)
static member IsAssemblyFactory :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsAssemblyMember

Metodo UtilIsAssemblyMember

Restituisce vero se il documento passato è un Part Member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAssemblyMember(
    Document invDoc
)
Public Shared Function IsAssemblyMember (
    invDoc As Document
) As Boolean
public:
static bool IsAssemblyMember(
    Document^ invDoc
)
static member IsAssemblyMember :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsCableHarnessDocument

Metodo UtilIsCableHarnessDocument

Dato il documento in ingresso determina se si tratta di un documento di cavi e cablaggi.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsCableHarnessDocument(
    Document doc
)
Public Shared Function IsCableHarnessDocument (
    doc As Document
) As Boolean
public:
static bool IsCableHarnessDocument(
    Document^ doc
)
static member IsCableHarnessDocument :
        doc : Document -> bool

Parametri

doc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsDerivedDoc

Metodo UtilIsDerivedDoc

Stabilisce se il documento padre è un derivato del documento figlio

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDerivedDoc(
    Document parentDoc,
    string childFileName
)
Public Shared Function IsDerivedDoc (
    parentDoc As Document,
    childFileName As String
) As Boolean
public:
static bool IsDerivedDoc(
    Document^ parentDoc,
    String^ childFileName
)
static member IsDerivedDoc :
        parentDoc : Document *
        childFileName : string -> bool

Parametri

parentDoc
Tipo: Document
Documento padre
childFileName
Tipo: SystemString
Filename documento figlio

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsDrawing

Metodo UtilIsDrawing

Restituisce se il documento passato sia una messa in tavola.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDrawing(
    Document invDoc
)
Public Shared Function IsDrawing (
    invDoc As Document
) As Boolean
public:
static bool IsDrawing(
    Document^ invDoc
)
static member IsDrawing :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsEmbeddedDocument

Metodo UtilIsEmbeddedDocument

Restituisce se il documento passato è di modello.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsEmbeddedDocument(
    Document invDoc
)
Public Shared Function IsEmbeddedDocument (
    invDoc As Document
) As Boolean
public:
static bool IsEmbeddedDocument(
    Document^ invDoc
)
static member IsEmbeddedDocument :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsFactoryAssetInstance

Metodo UtilIsFactoryAssetInstance

Restituisce vero se si tratta di un documento rappresentante un asset della factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsFactoryAssetInstance(
    Document doc
)
Public Shared Function IsFactoryAssetInstance (
    doc As Document
) As Boolean
public:
static bool IsFactoryAssetInstance(
    Document^ doc
)
static member IsFactoryAssetInstance :
        doc : Document -> bool

Parametri

doc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsiAssemblyOccurrence

Metodo UtilIsiAssemblyOccurrence

Restituisce vero se l'occorrenza si trova nel contesto di un

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsiAssemblyOccurrence(
    ComponentOccurrence occ
)
Public Shared Function IsiAssemblyOccurrence (
    occ As ComponentOccurrence
) As Boolean
public:
static bool IsiAssemblyOccurrence(
    ComponentOccurrence^ occ
)
static member IsiAssemblyOccurrence :
        occ : ComponentOccurrence -> bool

Parametri

occ
Tipo: ComponentOccurrence

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsInventorDwg

Metodo UtilIsInventorDwg

Restituisce se il documento sia un dwg di inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsInventorDwg(
    Document invDoc
)
Public Shared Function IsInventorDwg (
    invDoc As Document
) As Boolean
public:
static bool IsInventorDwg(
    Document^ invDoc
)
static member IsInventorDwg :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsMasterModelState

Metodo UtilIsMasterModelState

Ritorna vero se il documento è in configurazione master

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMasterModelState(
    Document invDoc
)
Public Shared Function IsMasterModelState (
    invDoc As Document
) As Boolean
public:
static bool IsMasterModelState(
    Document^ invDoc
)
static member IsMasterModelState :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsModel

Metodo UtilIsModel

Restituisce se il documento passato è di modello. Se fallisce è quasi sicuramente per la corruzione del documento. L'eccezione viene comunque registrata.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsModel(
    Document invDoc
)
Public Shared Function IsModel (
    invDoc As Document
) As Boolean
public:
static bool IsModel(
    Document^ invDoc
)
static member IsModel :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsModelStateFactory

Metodo UtilIsModelStateFactory

Ritorna vero se il documento è il model state factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsModelStateFactory(
    Document invDoc
)
Public Shared Function IsModelStateFactory (
    invDoc As Document
) As Boolean
public:
static bool IsModelStateFactory(
    Document^ invDoc
)
static member IsModelStateFactory :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsModelStateMember

Metodo UtilIsModelStateMember

Ritorna vero se il documento è il model state member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsModelStateMember(
    Document invDoc
)
Public Shared Function IsModelStateMember (
    invDoc As Document
) As Boolean
public:
static bool IsModelStateMember(
    Document^ invDoc
)
static member IsModelStateMember :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsPartFactory

Metodo UtilIsPartFactory

Restituisce vero se il documento passato è una Part Factory

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsPartFactory(
    Document invDoc
)
Public Shared Function IsPartFactory (
    invDoc As Document
) As Boolean
public:
static bool IsPartFactory(
    Document^ invDoc
)
static member IsPartFactory :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsPartMember

Metodo UtilIsPartMember

Restituisce vero se il documento passato è un Part Member

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsPartMember(
    Document invDoc
)
Public Shared Function IsPartMember (
    invDoc As Document
) As Boolean
public:
static bool IsPartMember(
    Document^ invDoc
)
static member IsPartMember :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsPresentation

Metodo UtilIsPresentation

Restituisce se il documento passato sia una presentazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsPresentation(
    Document invDoc
)
Public Shared Function IsPresentation (
    invDoc As Document
) As Boolean
public:
static bool IsPresentation(
    Document^ invDoc
)
static member IsPresentation :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsRoutedSystemDocument

Metodo UtilIsRoutedSystemDocument

Dato il documento in ingresso determina se si tratta di un documento di piping.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsRoutedSystemDocument(
    Document doc
)
Public Shared Function IsRoutedSystemDocument (
    doc As Document
) As Boolean
public:
static bool IsRoutedSystemDocument(
    Document^ doc
)
static member IsRoutedSystemDocument :
        doc : Document -> bool

Parametri

doc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsSubstituteDescriptor

Metodo UtilIsSubstituteDescriptor

Identifica se il document descriptor passato rappresenta un sosituto.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSubstituteDescriptor(
    DocumentDescriptor docDescr
)
Public Shared Function IsSubstituteDescriptor (
    docDescr As DocumentDescriptor
) As Boolean
public:
static bool IsSubstituteDescriptor(
    DocumentDescriptor^ docDescr
)
static member IsSubstituteDescriptor :
        docDescr : DocumentDescriptor -> bool

Parametri

docDescr
Tipo: DocumentDescriptor

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsSubstituteModelState

Metodo UtilIsSubstituteModelState

Ritorna vero se il documento è in una configurazione sostituto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSubstituteModelState(
    Document invDoc
)
Public Shared Function IsSubstituteModelState (
    invDoc As Document
) As Boolean
public:
static bool IsSubstituteModelState(
    Document^ invDoc
)
static member IsSubstituteModelState :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsSubstitutePart

Metodo UtilIsSubstitutePart

Controlla se la parte passata è un sostituto. Dalla 2022 il comodissimo flag non è più impostato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSubstitutePart(
    PartDocument prtDoc
)
Public Shared Function IsSubstitutePart (
    prtDoc As PartDocument
) As Boolean
public:
static bool IsSubstitutePart(
    PartDocument^ prtDoc
)
static member IsSubstitutePart :
        prtDoc : PartDocument -> bool

Parametri

prtDoc
Tipo: PartDocument

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.IsUnreferencedSubstituteModelState

Metodo UtilIsUnreferencedSubstituteModelState

Ritorna vero se il documento è in una configurazione sostituto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsUnreferencedSubstituteModelState(
    Document invDoc
)
Public Shared Function IsUnreferencedSubstituteModelState (
    invDoc As Document
) As Boolean
public:
static bool IsUnreferencedSubstituteModelState(
    Document^ invDoc
)
static member IsUnreferencedSubstituteModelState :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.LogTubeAndPipeAddinActivationStatus

Metodo UtilLogTubeAndPipeAddinActivationStatus

Logga lo stato di attivazione del plugin di tubi e tubature

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogTubeAndPipeAddinActivationStatus()
Public Shared Sub LogTubeAndPipeAddinActivationStatus
public:
static void LogTubeAndPipeAddinActivationStatus()
static member LogTubeAndPipeAddinActivationStatus : unit -> unit

Valore di ritorno

Tipo:
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.MakeStructFileName

Metodo UtilMakeStructFileName

Dato il nome di partenza genera il nuovo nome da assegnare al file della struttura speciale. Verifica se il prefisso, il nome del padre di partenza ed il numero random sono presenti. In tal caso li elimina per ricrearli in base ai parametri passati.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string MakeStructFileName(
    string fullNameFrom,
    SpecialStructEnum tipoStruct,
    string destMainAssemblyFullName,
    string parentNameOnlyFrom,
    List<string> madeList
)
Public Shared Function MakeStructFileName (
    fullNameFrom As String,
    tipoStruct As SpecialStructEnum,
    destMainAssemblyFullName As String,
    parentNameOnlyFrom As String,
    madeList As List(Of String)
) As String
public:
static String^ MakeStructFileName(
    String^ fullNameFrom,
    SpecialStructEnum tipoStruct,
    String^ destMainAssemblyFullName,
    String^ parentNameOnlyFrom,
    List<String^>^ madeList
)
static member MakeStructFileName :
        fullNameFrom : string *
        tipoStruct : SpecialStructEnum *
        destMainAssemblyFullName : string *
        parentNameOnlyFrom : string *
        madeList : List<string> -> string

Parametri

fullNameFrom
Tipo: SystemString
Nome attuale completo del file del quale si vuole generare il nuovo nome di destinazione.
tipoStruct
Tipo: DedNetInvSpecialStructEnum
Tipo di struttura per la quale creare il nome.
destMainAssemblyFullName
Tipo: SystemString
Percorso completo di salvataggio del file principale.
parentNameOnlyFrom
Tipo: SystemString
Nome di partenza, senza estensione e senza percorso, dell'assieme principale che è in fase di salvataggio.
madeList
Tipo: System.Collections.GenericList String
Lista dei file che sono già stati definiti da questa funzione nelle chiamate precedenti, utilizzata per evitare di creare due elementi omonimi (non ancora esistenti).

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.MigrateFile

Metodo UtilMigrateFile

Migra il file alla release corrente di inventor. Ignora lo stato di sola lettura e lo stato del documento. E' al servizione dell'aggiornamento riferimenti nel caso di debba procedere tramite apprentice.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void MigrateFile(
    string fileName
)
Public Shared Sub MigrateFile (
    fileName As String
)
public:
static void MigrateFile(
    String^ fileName
)
static member MigrateFile :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
File da migrare
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ModelState2DedDataPart

Metodo UtilModelState2DedDataPart

Lista degli overload
Nome | Descrizione
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
ModelState2DedDataPart(ModelState, DedDoc, UtilDataAttrTypeEnum, Boolean) | Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ModelState2DedDataPart (ModelState, DedDoc, Util.DataAttrTypeEnum)

Metodo UtilModelState2DedDataPart (ModelState, DedDoc, UtilDataAttrTypeEnum)
Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ModelState2DedDataPart(
    ModelState ms,
    DedDoc dbDoc,
    UtilDataAttrTypeEnum attrsType
)
Public Shared Function ModelState2DedDataPart (
    ms As ModelState,
    dbDoc As DedDoc,
    attrsType As UtilDataAttrTypeEnum
) As DedDataPart
public:
static DedDataPart^ ModelState2DedDataPart(
    ModelState^ ms,
    DedDoc^ dbDoc,
    UtilDataAttrTypeEnum attrsType
)
static member ModelState2DedDataPart :
        ms : ModelState *
        dbDoc : DedDoc *
        attrsType : UtilDataAttrTypeEnum -> DedDataPart

Parametri

ms
Tipo: ModelState
Model state di riferimento
dbDoc
Tipo: DedDoc
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera leggere dal documento.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di ModelState2DedDataPart
Namespace DedNetInv


Metodo Util.ModelState2DedDataPart (ModelState, DedDoc, Util.DataAttrTypeEnum, Boolean)

Metodo UtilModelState2DedDataPart (ModelState, DedDoc, UtilDataAttrTypeEnum, Boolean)
Dato un model state ricava il deddatapart. Se il modelstate coincide con quello attivo utilizzerà il documento diversamente utilizzerà i dati presenti all'interno della tabella.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ModelState2DedDataPart(
    ModelState ms,
    DedDoc dbDoc,
    UtilDataAttrTypeEnum attrsType,
    bool checkDataMatching
)
Public Shared Function ModelState2DedDataPart (
    ms As ModelState,
    dbDoc As DedDoc,
    attrsType As UtilDataAttrTypeEnum,
    checkDataMatching As Boolean
) As DedDataPart
public:
static DedDataPart^ ModelState2DedDataPart(
    ModelState^ ms,
    DedDoc^ dbDoc,
    UtilDataAttrTypeEnum attrsType,
    bool checkDataMatching
)
static member ModelState2DedDataPart :
        ms : ModelState *
        dbDoc : DedDoc *
        attrsType : UtilDataAttrTypeEnum *
        checkDataMatching : bool -> DedDataPart

Parametri

ms
Tipo: ModelState
Model state di riferimento
dbDoc
Tipo: DedDoc
attrsType
Tipo: DedNetInvUtilDataAttrTypeEnum
Tipo di lista attributi che si desidera leggere dal documento.
checkDataMatching
Tipo: SystemBoolean
Indica se effettuare o meno il controllo di coerenza. Se false considera buona l'anagrafica letta dagli attributi

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di ModelState2DedDataPart
Namespace DedNetInv


Metodo Util.OnFileResolutionStruttureSpeciali

Metodo UtilOnFileResolutionStruttureSpeciali

Core delle operazioni che si devono effettuare durante l'OnFileResolution per la sostituzione delle strutture speciali.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string OnFileResolutionStruttureSpeciali(
    string RelativeFileName,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Function OnFileResolutionStruttureSpeciali (
    RelativeFileName As String,
    specStructInfos As UtilSpecialStructInfos
) As String
public:
static String^ OnFileResolutionStruttureSpeciali(
    String^ RelativeFileName,
    UtilSpecialStructInfos^ specStructInfos
)
static member OnFileResolutionStruttureSpeciali :
        RelativeFileName : string *
        specStructInfos : UtilSpecialStructInfos -> string

Parametri

RelativeFileName
Tipo: SystemString
Path relativo ottenuto dall'evento
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Struttura Informazioni delle strutture speciali

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.Open

Metodo UtilOpen

Lista degli overload
Nome | Descrizione
Open(String, Boolean, String) | Apre il file passato e ne restituisce il documento. Se la configurazione passata è nulla o vuota viene aperta la configurazione leggendo le opzioni di Inventor (Last o Master). Se viene passata la configurazione ma non esiste viene aperta sempre la Master. Solleva una eccezione se non riesce ad aprirlo.
Open(String, Boolean, DedData, DedDoc, String) |
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.Open (String, Boolean, String)

Metodo UtilOpen (String, Boolean, String)
Apre il file passato e ne restituisce il documento. Se la configurazione passata è nulla o vuota viene aperta la configurazione leggendo le opzioni di Inventor (Last o Master). Se viene passata la configurazione ma non esiste viene aperta sempre la Master. Solleva una eccezione se non riesce ad aprirlo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document Open(
    string fullFileName,
    bool visible,
    string config = null
)
Public Shared Function Open (
    fullFileName As String,
    visible As Boolean,
    Optional config As String = Nothing
) As Document
public:
static Document^ Open(
    String^ fullFileName,
    bool visible,
    String^ config = nullptr
)
static member Open :
        fullFileName : string *
        visible : bool *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> Document

Parametri

fullFileName
Tipo: SystemString
Nome completo del file da aprire.
visible
Tipo: SystemBoolean
Se aprire il documento visibile.
config (Optional)
Tipo: SystemString
Configurazione da utilizzare per l'apertura

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di Open
Namespace DedNetInv


Metodo Util.Open (String, Boolean, DedData, DedDoc, String)

Metodo UtilOpen (String, Boolean, DedData, DedDoc, String)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document Open(
    string fullFileName,
    bool visible,
    DedData anagr,
    DedDoc doc,
    string config = null
)
Public Shared Function Open (
    fullFileName As String,
    visible As Boolean,
    anagr As DedData,
    doc As DedDoc,
    Optional config As String = Nothing
) As Document
public:
static Document^ Open(
    String^ fullFileName,
    bool visible,
    DedData^ anagr,
    DedDoc^ doc,
    String^ config = nullptr
)
static member Open :
        fullFileName : string *
        visible : bool *
        anagr : DedData *
        doc : DedDoc *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> Document

Parametri

fullFileName
Tipo: SystemString
visible
Tipo: SystemBoolean
anagr
Tipo: DedData
doc
Tipo: DedDoc
config (Optional)
Tipo: SystemString

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di Open
Namespace DedNetInv


Metodo Util.OpenWithOptions

Metodo UtilOpenWithOptions

Apre il file passato e ne restituisce il documento. Se la configurazione passata non esiste o è nulla viene aperto sempre in Master.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document OpenWithOptions(
    string fullFileName,
    bool visible,
    string config = null
)
Public Shared Function OpenWithOptions (
    fullFileName As String,
    visible As Boolean,
    Optional config As String = Nothing
) As Document
public:
static Document^ OpenWithOptions(
    String^ fullFileName,
    bool visible,
    String^ config = nullptr
)
static member OpenWithOptions :
        fullFileName : string *
        visible : bool *
        ?config : string
(* Defaults:
        let _config = defaultArg config null
*)
-> Document

Parametri

fullFileName
Tipo: SystemString
Nome completo del file da aprire.
visible
Tipo: SystemBoolean
Se aprire il documento visibile.
config (Optional)
Tipo: SystemString
Configurazione da utilizzare per l'apertura

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.OrderDocumentList

Metodo UtilOrderDocumentList

Riordino il tutto in modo da ottenere il seguente ordinamento : iam/inest - ipt - ipn - idw.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OrderDocumentList(
    DedDocList docList
)
Public Shared Sub OrderDocumentList (
    docList As DedDocList
)
public:
static void OrderDocumentList(
    DedDocList^ docList
)
static member OrderDocumentList :
        docList : DedDocList -> unit

Parametri

docList
Tipo: DedDocList
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.PartBody2DedDataPart

Metodo UtilPartBody2DedDataPart

Legge i dati dal partbody e li inserisce in un DedDataPart

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart PartBody2DedDataPart(
    PartBody partBody,
    DedAttrList attrList
)
Public Shared Function PartBody2DedDataPart (
    partBody As PartBody,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ PartBody2DedDataPart(
    PartBody^ partBody,
    DedAttrList^ attrList
)
static member PartBody2DedDataPart :
        partBody : PartBody *
        attrList : DedAttrList -> DedDataPart

Parametri

partBody
Tipo: PartBody
PartBody di riferimento
attrList
Tipo: DedAttrList
Elenco attributi per creare il dedDataPart

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.PartHasMultipleSolidBodies

Metodo UtilPartHasMultipleSolidBodies

Ritorna vero se il documento di tipo 'parte' è costituito da più di un body

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PartHasMultipleSolidBodies(
    Document invDoc
)
Public Shared Function PartHasMultipleSolidBodies (
    invDoc As Document
) As Boolean
public:
static bool PartHasMultipleSolidBodies(
    Document^ invDoc
)
static member PartHasMultipleSolidBodies :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.PathIsLibrary

Metodo UtilPathIsLibrary

Verifica se il percorso sia o meno di libreria.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PathIsLibrary(
    string filePath
)
Public Shared Function PathIsLibrary (
    filePath As String
) As Boolean
public:
static bool PathIsLibrary(
    String^ filePath
)
static member PathIsLibrary :
        filePath : string -> bool

Parametri

filePath
Tipo: SystemString
Percorso completo di file oppure solo percorso da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.PathIsRootLibrary

Metodo UtilPathIsRootLibrary

Verifica se il percorso sia in una root libreria.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PathIsRootLibrary(
    string filePath
)
Public Shared Function PathIsRootLibrary (
    filePath As String
) As Boolean
public:
static bool PathIsRootLibrary(
    String^ filePath
)
static member PathIsRootLibrary :
        filePath : string -> bool

Parametri

filePath
Tipo: SystemString
Percorso completo di file oppure solo percorso da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.PrecompilaCodice

Metodo UtilPrecompilaCodice

Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void PrecompilaCodice(
    FindCodeCommand cmd
)
Public Shared Sub PrecompilaCodice (
    cmd As FindCodeCommand
)
public:
static void PrecompilaCodice(
    FindCodeCommand^ cmd
)
static member PrecompilaCodice :
        cmd : FindCodeCommand -> unit

Parametri

cmd
Tipo: FindCodeCommand
Comando di apri veloce.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadAllProperties

Metodo UtilReadAllProperties

Lista degli overload
Nome | Descrizione
ReadAllProperties(Document) | Legge tutte le proprietà del documento.
ReadAllProperties(String) | Legge tutte le proprietà del documento.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadAllProperties (Document)

Metodo UtilReadAllProperties (Document)
Legge tutte le proprietà del documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    Document invDoc
)
Public Shared Function ReadAllProperties (
    invDoc As Document
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    Document^ invDoc
)
static member ReadAllProperties :
        invDoc : Document -> Dictionary<string, Object>

Parametri

invDoc
Tipo: Document
Documento di Inventor.

Valore di ritorno

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties
Namespace DedNetInv


Metodo Util.ReadAllProperties (String)

Metodo UtilReadAllProperties (String)
Legge tutte le proprietà del documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    string invFileName
)
Public Shared Function ReadAllProperties (
    invFileName As String
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    String^ invFileName
)
static member ReadAllProperties :
        invFileName : string -> Dictionary<string, Object>

Parametri

invFileName
Tipo: SystemString
Path del documento di Inventor.

Valore di ritorno

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties
Namespace DedNetInv


Metodo Util.ReadAnagr

Metodo UtilReadAnagr

Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadAnagr(
    string dedid,
    string dedrev
)
Public Shared Function ReadAnagr (
    dedid As String,
    dedrev As String
) As DedData
public:
static DedData^ ReadAnagr(
    String^ dedid,
    String^ dedrev
)
static member ReadAnagr :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid
Tipo: SystemString
dedrev
Tipo: SystemString

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvDoc

Metodo UtilReadDataFromInvDoc

Lista degli overload
Nome | Descrizione
ReadDataFromInvDoc(Document, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
ReadDataFromInvDoc(Document, String, DedDoc, Boolean) | Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvDoc (Document, DedDoc, Boolean)

Metodo UtilReadDataFromInvDoc (Document, DedDoc, Boolean)
Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvDoc(
    Document invDoc,
    DedDoc dbDoc = null,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromInvDoc (
    invDoc As Document,
    Optional dbDoc As DedDoc = Nothing,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromInvDoc(
    Document^ invDoc,
    DedDoc^ dbDoc = nullptr,
    bool checkDataMatching = true
)
static member ReadDataFromInvDoc :
        invDoc : Document *
        ?dbDoc : DedDoc *
        ?checkDataMatching : bool
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

invDoc
Tipo: Document
Documento di Inventor dal quale leggere le informazioni.
dbDoc (Optional)
Tipo: DedDoc
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza del documento oppure null se non è codificato.
Note
Questa funzione suppone che all'apertura siano stati inseriti nel documento i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromInvDoc
Namespace DedNetInv


Metodo Util.ReadDataFromInvDoc (Document, String, DedDoc, Boolean)

Metodo UtilReadDataFromInvDoc (Document, String, DedDoc, Boolean)
Legge il dedid ed il dedrev da un documento e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvDoc(
    Document invDoc,
    string config,
    DedDoc dbDoc = null,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromInvDoc (
    invDoc As Document,
    config As String,
    Optional dbDoc As DedDoc = Nothing,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromInvDoc(
    Document^ invDoc,
    String^ config,
    DedDoc^ dbDoc = nullptr,
    bool checkDataMatching = true
)
static member ReadDataFromInvDoc :
        invDoc : Document *
        config : string *
        ?dbDoc : DedDoc *
        ?checkDataMatching : bool
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

invDoc
Tipo: Document
Documento di Inventor dal quale leggere le informazioni.
config
Tipo: SystemString
dbDoc (Optional)
Tipo: DedDoc
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza del documento oppure null se non è codificato.
Note
Questa funzione suppone che all'apertura siano stati inseriti nel documento i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util
Overload di ReadDataFromInvDoc
Namespace DedNetInv


Metodo Util.ReadDataFromInvDocOrMatchingModelState

Metodo UtilReadDataFromInvDocOrMatchingModelState

Prova prima a reperire l'anagrafica usando ReadDataFromInvDoc con configurazione specifica se non trova nulla allora fa un controllo più leggero senza usare la configurazione (serve per reperire l'anagrafica anche delle rappresentazioni che non sono direttamente associate all'anagrafica)

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvDocOrMatchingModelState(
    Document invDoc,
    DedDoc dbDoc = null
)
Public Shared Function ReadDataFromInvDocOrMatchingModelState (
    invDoc As Document,
    Optional dbDoc As DedDoc = Nothing
) As DedData
public:
static DedData^ ReadDataFromInvDocOrMatchingModelState(
    Document^ invDoc,
    DedDoc^ dbDoc = nullptr
)
static member ReadDataFromInvDocOrMatchingModelState :
        invDoc : Document *
        ?dbDoc : DedDoc
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
*)
-> DedData

Parametri

invDoc
Tipo: Document
dbDoc (Optional)
Tipo: DedDoc

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvDocProperties

Metodo UtilReadDataFromInvDocProperties

Legge l'anagrafica solamente dagli attributi del documento di Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvDocProperties(
    Document invDoc
)
Public Shared Function ReadDataFromInvDocProperties (
    invDoc As Document
) As DedData
public:
static DedData^ ReadDataFromInvDocProperties(
    Document^ invDoc
)
static member ReadDataFromInvDocProperties :
        invDoc : Document -> DedData

Parametri

invDoc
Tipo: Document
Documento di riferimento

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvFile

Metodo UtilReadDataFromInvFile

Legge il dedid ed il dedrev da un file di Inventor e ne ricava l'anagrafica. Verifica anche che il nome del documento sia di un documento collegato come primario all'anagrafica. Se il documento non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvFile(
    string invFileName,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromInvFile (
    invFileName As String,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromInvFile(
    String^ invFileName,
    bool checkDataMatching = true
)
static member ReadDataFromInvFile :
        invFileName : string *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

invFileName
Tipo: SystemString
File di Inventor dal quale leggere le informazioni.
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza del documento oppure null se non è codificato.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvFileProperties

Metodo UtilReadDataFromInvFileProperties

Legge l'anagrafica solamente dagli attributi del file

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvFileProperties(
    string invFileName
)
Public Shared Function ReadDataFromInvFileProperties (
    invFileName As String
) As DedData
public:
static DedData^ ReadDataFromInvFileProperties(
    String^ invFileName
)
static member ReadDataFromInvFileProperties :
        invFileName : string -> DedData

Parametri

invFileName
Tipo: SystemString

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvOcc

Metodo UtilReadDataFromInvOcc

Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvOcc(
    ComponentOccurrence occ,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromInvOcc (
    occ As ComponentOccurrence,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromInvOcc(
    ComponentOccurrence^ occ,
    bool checkDataMatching = true
)
static member ReadDataFromInvOcc :
        occ : ComponentOccurrence *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

occ
Tipo: ComponentOccurrence
Occorrenza di Inventor della quale leggere le informazioni.
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza dell'occorrenza oppure null se non è codificata.
Note
Questa funzione suppone che all'apertura siano stati inseriti nel documento i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvOccOrMatchingModelState

Metodo UtilReadDataFromInvOccOrMatchingModelState

Legge il dedid ed il dedrev da un'occorrenza e ne ricava l'anagrafica. Verifica anche che il nome del documento abbinato (se l'occorrenza non è virtuale), sia corrente sia di un documento collegato come primario all'anagrafica. Se l'occorrenza non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvOccOrMatchingModelState(
    ComponentOccurrence occ
)
Public Shared Function ReadDataFromInvOccOrMatchingModelState (
    occ As ComponentOccurrence
) As DedData
public:
static DedData^ ReadDataFromInvOccOrMatchingModelState(
    ComponentOccurrence^ occ
)
static member ReadDataFromInvOccOrMatchingModelState :
        occ : ComponentOccurrence -> DedData

Parametri

occ
Tipo: ComponentOccurrence
Occorrenza di Inventor della quale leggere le informazioni.

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza dell'occorrenza oppure null se non è codificata.
Note
Questa funzione suppone che all'apertura siano stati inseriti nel documento i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromInvOccProperties

Metodo UtilReadDataFromInvOccProperties

Legge l'anagrafica solamente dagli attributi dell'ocorenza di Inventor.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromInvOccProperties(
    ComponentOccurrence invOcc
)
Public Shared Function ReadDataFromInvOccProperties (
    invOcc As ComponentOccurrence
) As DedData
public:
static DedData^ ReadDataFromInvOccProperties(
    ComponentOccurrence^ invOcc
)
static member ReadDataFromInvOccProperties :
        invOcc : ComponentOccurrence -> DedData

Parametri

invOcc
Tipo: ComponentOccurrence
Occorenza di riferimento

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromModelState

Metodo UtilReadDataFromModelState

Legge l'anagrafica dal model state. Se il documento esiste, utilizza quello in modo tradizionale. Se il documento non esiste, preleva l'anagrafica associata tramite il legame documentale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromModelState(
    ModelState ms,
    DedDoc dbDoc = null,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromModelState (
    ms As ModelState,
    Optional dbDoc As DedDoc = Nothing,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromModelState(
    ModelState^ ms,
    DedDoc^ dbDoc = nullptr,
    bool checkDataMatching = true
)
static member ReadDataFromModelState :
        ms : ModelState *
        ?dbDoc : DedDoc *
        ?checkDataMatching : bool
(* Defaults:
        let _dbDoc = defaultArg dbDoc null
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

ms
Tipo: ModelState
Model state di riferimento
dbDoc (Optional)
Tipo: DedDoc
DedDoc di riferimento. Essenziale in caso di assenza del document sul model state
checkDataMatching (Optional)
Tipo: SystemBoolean
Controllo del matching. Utilizzato solo in caso di presenza di document sul model state

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadDataFromPartBodyProperties

Metodo UtilReadDataFromPartBodyProperties

Legge l'anagrafica solamente dagli attributi del documento di Inventor

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromPartBodyProperties(
    PartBody partBody
)
Public Shared Function ReadDataFromPartBodyProperties (
    partBody As PartBody
) As DedData
public:
static DedData^ ReadDataFromPartBodyProperties(
    PartBody^ partBody
)
static member ReadDataFromPartBodyProperties :
        partBody : PartBody -> DedData

Parametri

partBody
Tipo: PartBody

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReadSubstituteList

Metodo UtilReadSubstituteList

Legge il documento e se si tratta di un assieme, cerca tutti i sostituti di dettaglio presenti. Li restituisce in una lista sempre inizializzata ed eventualmente vuota. ATTENZIONE! Sulla 2022 ha senso solo per versioni inferiori alla 2022.2 diversamente non sarà nemmeno chiamata

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<FileDescriptor> ReadSubstituteList(
    Document doc
)
Public Shared Function ReadSubstituteList (
    doc As Document
) As List(Of FileDescriptor)
public:
static List<FileDescriptor^>^ ReadSubstituteList(
    Document^ doc
)
static member ReadSubstituteList :
        doc : Document -> List<FileDescriptor>

Parametri

doc
Tipo: Document
Documento da esaminare.

Valore di ritorno

Tipo: List FileDescriptor
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.RefreshAllDocuments

Metodo UtilRefreshAllDocuments

Esegue un refresh di tutti i documenti in memoria. Di default inventor è silenziato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RefreshAllDocuments(
    bool silent = true
)
Public Shared Sub RefreshAllDocuments (
    Optional silent As Boolean = true
)
public:
static void RefreshAllDocuments(
    bool silent = true
)
static member RefreshAllDocuments :
        ?silent : bool
(* Defaults:
        let _silent = defaultArg silent true
*)
-> unit

Parametri

silent (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.RemoveHiddenAttribute

Metodo UtilRemoveHiddenAttribute

Rimuove l'attributo nascosto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RemoveHiddenAttribute(
    string path
)
Public Shared Sub RemoveHiddenAttribute (
    path As String
)
public:
static void RemoveHiddenAttribute(
    String^ path
)
static member RemoveHiddenAttribute :
        path : string -> unit

Parametri

path
Tipo: SystemString
Percorso del file dal quale rimuovere l'attributo "Nascosto".
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReplaceAllDerivedDocumentReferences

Metodo UtilReplaceAllDerivedDocumentReferences

Sostituisce tutti i componenti derivati con il file passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int ReplaceAllDerivedDocumentReferences(
    Document oDoc,
    string destRefName,
    string modelStateName = null
)
Public Shared Function ReplaceAllDerivedDocumentReferences (
    oDoc As Document,
    destRefName As String,
    Optional modelStateName As String = Nothing
) As Integer
public:
static int ReplaceAllDerivedDocumentReferences(
    Document^ oDoc,
    String^ destRefName,
    String^ modelStateName = nullptr
)
static member ReplaceAllDerivedDocumentReferences :
        oDoc : Document *
        destRefName : string *
        ?modelStateName : string
(* Defaults:
        let _modelStateName = defaultArg modelStateName null
*)
-> int

Parametri

oDoc
Tipo: Document
Documento di Inventor
destRefName
Tipo: SystemString
Riferimento di destiinazione della sostituzione
modelStateName (Optional)
Tipo: SystemString

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.ReplaceDerivedDocumentReference

Metodo UtilReplaceDerivedDocumentReference

Sostituisce il componente derivato specificato con il file passato. Se il file non viene trovato non sostituisce niente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ReplaceDerivedDocumentReference(
    Document oDoc,
    Object startDerivedRef,
    string destRefName,
    string modelStateName = null
)
Public Shared Function ReplaceDerivedDocumentReference (
    oDoc As Document,
    startDerivedRef As Object,
    destRefName As String,
    Optional modelStateName As String = Nothing
) As Boolean
public:
static bool ReplaceDerivedDocumentReference(
    Document^ oDoc,
    Object^ startDerivedRef,
    String^ destRefName,
    String^ modelStateName = nullptr
)
static member ReplaceDerivedDocumentReference :
        oDoc : Document *
        startDerivedRef : Object *
        destRefName : string *
        ?modelStateName : string
(* Defaults:
        let _modelStateName = defaultArg modelStateName null
*)
-> bool

Parametri

oDoc
Tipo: Document
Documento di Inventor
startDerivedRef
Tipo: SystemObject
destRefName
Tipo: SystemString
Riferimento di destinazione della sostituzione
modelStateName (Optional)
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.RipristinaDocumentiStruttureSpeciali

Metodo UtilRipristinaDocumentiStruttureSpeciali

Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RipristinaDocumentiStruttureSpeciali(
    DocStructInfoCollection origItems,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub RipristinaDocumentiStruttureSpeciali (
    origItems As DocStructInfoCollection,
    specStructInfos As UtilSpecialStructInfos
)
public:
static void RipristinaDocumentiStruttureSpeciali(
    DocStructInfoCollection^ origItems,
    UtilSpecialStructInfos^ specStructInfos
)
static member RipristinaDocumentiStruttureSpeciali :
        origItems : DocStructInfoCollection *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

origItems
Tipo: DocStructInfoCollection
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.RipristinaOwnerShipStruttureSpeciali

Metodo UtilRipristinaOwnerShipStruttureSpeciali

Ripristina le caratteristiche di ownership dei componenti di struttura speciale

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RipristinaOwnerShipStruttureSpeciali(
    DocStructInfoCollection items,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub RipristinaOwnerShipStruttureSpeciali (
    items As DocStructInfoCollection,
    specStructInfos As UtilSpecialStructInfos
)
public:
static void RipristinaOwnerShipStruttureSpeciali(
    DocStructInfoCollection^ items,
    UtilSpecialStructInfos^ specStructInfos
)
static member RipristinaOwnerShipStruttureSpeciali :
        items : DocStructInfoCollection *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

items
Tipo: DocStructInfoCollection
Elementi dell'assieme principale del quale sostituire tutti i componenti speciali.
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.RipristinaPartNumberStruttureSpeciali

Metodo UtilRipristinaPartNumberStruttureSpeciali

Ripristina il part number degli oggetti di struttura speciale. Lavora con i member del frame generator. Quando vengono copiati il valore viene sovrascrotto col nome file. In questo modo persiste quello originale.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RipristinaPartNumberStruttureSpeciali(
    DocStructInfoCollection items,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub RipristinaPartNumberStruttureSpeciali (
    items As DocStructInfoCollection,
    specStructInfos As UtilSpecialStructInfos
)
public:
static void RipristinaPartNumberStruttureSpeciali(
    DocStructInfoCollection^ items,
    UtilSpecialStructInfos^ specStructInfos
)
static member RipristinaPartNumberStruttureSpeciali :
        items : DocStructInfoCollection *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

items
Tipo: DocStructInfoCollection
Elementi dell'assieme principale del quale sostituire tutti i componenti speciali.
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.Save

Metodo UtilSave

Salva il documento su se stesso con tutte le sue dipendenze.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Save(
    Document invDoc,
    bool askUser,
    bool saveDep
)
Public Shared Sub Save (
    invDoc As Document,
    askUser As Boolean,
    saveDep As Boolean
)
public:
static void Save(
    Document^ invDoc,
    bool askUser,
    bool saveDep
)
static member Save :
        invDoc : Document *
        askUser : bool *
        saveDep : bool -> unit

Parametri

invDoc
Tipo: Document
Documento da salvare.
askUser
Tipo: SystemBoolean
Indica se visualizzare la finestra di conferma salvataggio dipendenze all'utente.
saveDep
Tipo: SystemBoolean
Indica se salvare anche i documenti dipendenti (se askUser è true questa opzione viene ignorata).
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SaveAs

Metodo UtilSaveAs

Salva il documento passato nella posizione specificata. Effettua un SaveAs oppure un SaveCopyAs in base all'opzione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    Document invDoc,
    string fullDestName,
    bool copyAs
)
Public Shared Sub SaveAs (
    invDoc As Document,
    fullDestName As String,
    copyAs As Boolean
)
public:
static void SaveAs(
    Document^ invDoc,
    String^ fullDestName,
    bool copyAs
)
static member SaveAs :
        invDoc : Document *
        fullDestName : string *
        copyAs : bool -> unit

Parametri

invDoc
Tipo: Document
Documento da salvare.
fullDestName
Tipo: SystemString
Percorso di destinazione.
copyAs
Tipo: SystemBoolean
Indica se effettuare un salva copia con nome invece di un Salva come.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SaveDistBomStructureAllowed

Metodo UtilSaveDistBomStructureAllowed

Restituisce true se è consentito il salvataggio della distinta in base alle impostazioni utente e alla bomstructure del documento .

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SaveDistBomStructureAllowed(
    Document invDoc
)
Public Shared Function SaveDistBomStructureAllowed (
    invDoc As Document
) As Boolean
public:
static bool SaveDistBomStructureAllowed(
    Document^ invDoc
)
static member SaveDistBomStructureAllowed :
        invDoc : Document -> bool

Parametri

invDoc
Tipo: Document
Documento di Inventor

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SetDeferUpdates

Metodo UtilSetDeferUpdates

In caso di documento tavola imposta il posticipa aggiornamenti. Diversamente non fa niente

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetDeferUpdates(
    Document refDoc,
    bool status
)
Public Shared Sub SetDeferUpdates (
    refDoc As Document,
    status As Boolean
)
public:
static void SetDeferUpdates(
    Document^ refDoc,
    bool status
)
static member SetDeferUpdates :
        refDoc : Document *
        status : bool -> unit

Parametri

refDoc
Tipo: Document
Documento di riferimento
status
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SetLastDataRowVer

Metodo UtilSetLastDataRowVer

Lista degli overload
Nome | Descrizione
SetLastDataRowVer(Document, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(String, Guid) | Imposta nel file di Inventor il rowver utilizzato per aggiornare i dati nel documento. La scrittura viene eseguita solo se necessario.
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SetLastDataRowVer (Document, Guid)

Metodo UtilSetLastDataRowVer (Document, Guid)
Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    Document invDoc,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    invDoc As Document,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    Document^ invDoc,
    Guid rowver
)
static member SetLastDataRowVer :
        invDoc : Document *
        rowver : Guid -> unit

Parametri

invDoc
Tipo: Document
Documento nel quale scrivere.
rowver
Tipo: SystemGuid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer
Namespace DedNetInv


Metodo Util.SetLastDataRowVer (String, Guid)

Metodo UtilSetLastDataRowVer (String, Guid)
Imposta nel file di Inventor il rowver utilizzato per aggiornare i dati nel documento. La scrittura viene eseguita solo se necessario.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    string fullFileName,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    fullFileName As String,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    String^ fullFileName,
    Guid rowver
)
static member SetLastDataRowVer :
        fullFileName : string *
        rowver : Guid -> unit

Parametri

fullFileName
Tipo: SystemString
Nome file nel quale scrivere.
rowver
Tipo: SystemGuid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer
Namespace DedNetInv


Metodo Util.SetOnFileDirtyFlags

Metodo UtilSetOnFileDirtyFlags

Setta i semafori dell'onFileDirty in base al comportamento passato

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetOnFileDirtyFlags(
    DedNetInvAppOnFileDirtyBehaviour ofdMode
)
Public Shared Sub SetOnFileDirtyFlags (
    ofdMode As DedNetInvAppOnFileDirtyBehaviour
)
public:
static void SetOnFileDirtyFlags(
    DedNetInvAppOnFileDirtyBehaviour ofdMode
)
static member SetOnFileDirtyFlags :
        ofdMode : DedNetInvAppOnFileDirtyBehaviour -> unit

Parametri

ofdMode
Tipo: DedNetInvDedNetInvAppOnFileDirtyBehaviour
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SostituisciAssiemeInSostituto

Metodo UtilSostituisciAssiemeInSostituto

Sostituisce l'eventuale riferimento dell'assieme nelle parti dei sostituti di dettaglio dell'assieme stesso.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SostituisciAssiemeInSostituto(
    string AsmFullNameFrom,
    string AsmFullNameTo,
    DedData newData,
    DocStructInfoCollection ties
)
Public Shared Sub SostituisciAssiemeInSostituto (
    AsmFullNameFrom As String,
    AsmFullNameTo As String,
    newData As DedData,
    ties As DocStructInfoCollection
)
public:
static void SostituisciAssiemeInSostituto(
    String^ AsmFullNameFrom,
    String^ AsmFullNameTo,
    DedData^ newData,
    DocStructInfoCollection^ ties
)
static member SostituisciAssiemeInSostituto :
        AsmFullNameFrom : string *
        AsmFullNameTo : string *
        newData : DedData *
        ties : DocStructInfoCollection -> unit

Parametri

AsmFullNameFrom
Tipo: SystemString
Nome completo dell'assieme di partenza.
AsmFullNameTo
Tipo: SystemString
Nome completo dell'assieme di arrivo.
newData
Tipo: DedData
Anagrafica di destinazione del nuovo assieme.
ties
Tipo: DocStructInfoCollection
Collezione figlia delle dipendenze.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SostituisciComponentiStruttureSpeciali

Metodo UtilSostituisciComponentiStruttureSpeciali

Sostituisce tutti i sotto-componenti delle strutture speciali dal documento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SostituisciComponentiStruttureSpeciali(
    AssemblyDocument mainAssembly,
    UtilSpecialStructInfos specStructInfos
)
Public Shared Sub SostituisciComponentiStruttureSpeciali (
    mainAssembly As AssemblyDocument,
    specStructInfos As UtilSpecialStructInfos
)
public:
static void SostituisciComponentiStruttureSpeciali(
    AssemblyDocument^ mainAssembly,
    UtilSpecialStructInfos^ specStructInfos
)
static member SostituisciComponentiStruttureSpeciali :
        mainAssembly : AssemblyDocument *
        specStructInfos : UtilSpecialStructInfos -> unit

Parametri

mainAssembly
Tipo: AssemblyDocument
Assieme principale del quale sostituire tutti i componenti speciali.
specStructInfos
Tipo: DedNetInvUtilSpecialStructInfos
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SostituisciSostituti

Metodo UtilSostituisciSostituti

Sostituisce tutti i sostituti di livello di dettaglio dell'elemento passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SostituisciSostituti(
    InvDocStructInfo item
)
Public Shared Sub SostituisciSostituti (
    item As InvDocStructInfo
)
public:
static void SostituisciSostituti(
    InvDocStructInfo^ item
)
static member SostituisciSostituti :
        item : InvDocStructInfo -> unit

Parametri

item
Tipo: DedNetInvInvDocStructInfo
Elemento da elaborare.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SostituisciSostitutoSingolo

Metodo UtilSostituisciSostitutoSingolo

Sostituisce il sostituto di dettaglio nell'assieme passato.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SostituisciSostitutoSingolo(
    Document NewSavedRefDoc,
    string fromFileName,
    string toFileName
)
Public Shared Sub SostituisciSostitutoSingolo (
    NewSavedRefDoc As Document,
    fromFileName As String,
    toFileName As String
)
public:
static void SostituisciSostitutoSingolo(
    Document^ NewSavedRefDoc,
    String^ fromFileName,
    String^ toFileName
)
static member SostituisciSostitutoSingolo :
        NewSavedRefDoc : Document *
        fromFileName : string *
        toFileName : string -> unit

Parametri

NewSavedRefDoc
Tipo: Document
Documento appena salvato.
fromFileName
Tipo: SystemString
Percorso di partenza da sostituire.
toFileName
Tipo: SystemString
Percorso di destinazione pre la sostituzione.
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.SubMenuExists

Metodo UtilSubMenuExists

Metodo che ritorna 0 se il sottomenu non è presente nella CommandBar, 1 altrimenti.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int SubMenuExists(
    string internalName,
    CommandBar bar
)
Public Shared Function SubMenuExists (
    internalName As String,
    bar As CommandBar
) As Integer
public:
static int SubMenuExists(
    String^ internalName,
    CommandBar^ bar
)
static member SubMenuExists :
        internalName : string *
        bar : CommandBar -> int

Parametri

internalName
Tipo: SystemString
Nome interno del sottomenu da ricercare.
bar
Tipo: CommandBar
Barra nella quale ricercare il sottomenu.

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.UpdateProjectLibraryPaths

Metodo UtilUpdateProjectLibraryPaths

Aggiorna

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void UpdateProjectLibraryPaths(
    DesignProject activeProject
)
Public Shared Sub UpdateProjectLibraryPaths (
    activeProject As DesignProject
)
public:
static void UpdateProjectLibraryPaths(
    DesignProject^ activeProject
)
static member UpdateProjectLibraryPaths :
        activeProject : DesignProject -> unit

Parametri

activeProject
Tipo: DesignProject
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.UpdateReference

Metodo UtilUpdateReference

Scorre tutte le dipendenze di primo livello di un documento e le sostituisce con la nuova destinazione.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateReference(
    Document doc,
    DocStructInfo item,
    DocStructInfoList list
)
Public Shared Function UpdateReference (
    doc As Document,
    item As DocStructInfo,
    list As DocStructInfoList
) As Boolean
public:
static bool UpdateReference(
    Document^ doc,
    DocStructInfo^ item,
    DocStructInfoList^ list
)
static member UpdateReference :
        doc : Document *
        item : DocStructInfo *
        list : DocStructInfoList -> bool

Parametri

doc
Tipo: Document
Documento del quale aggiornare i riferimenti.
item
Tipo: DocStructInfo
Oggetto DocStructInfo relativo al documento contenente i riferimenti di primo livello.
list
Tipo: DocStructInfoList
Lista che il comando sta elaborando (si vuole aggiornare solo i riferimenti coinvolti dal comando e quindi presenti in quesa lista.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.UpdateSingleDocumentOLEReference

Metodo UtilUpdateSingleDocumentOLEReference

Funzione di aggiornamento di una reference su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateSingleDocumentOLEReference(
    Document doc,
    string startRefName,
    string destRefName
)
Public Shared Function UpdateSingleDocumentOLEReference (
    doc As Document,
    startRefName As String,
    destRefName As String
) As Boolean
public:
static bool UpdateSingleDocumentOLEReference(
    Document^ doc,
    String^ startRefName,
    String^ destRefName
)
static member UpdateSingleDocumentOLEReference :
        doc : Document *
        startRefName : string *
        destRefName : string -> bool

Parametri

doc
Tipo: Document
Documento di Inventor
startRefName
Tipo: SystemString
Riferimento di partenza
destRefName
Tipo: SystemString
Rfierimento di destiinazione della sostituzione

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.UpdateSingleDocumentReference

Metodo UtilUpdateSingleDocumentReference

Funzione di aggiornamento di una reference su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateSingleDocumentReference(
    Document doc,
    string startRefName,
    string destRefName
)
Public Shared Function UpdateSingleDocumentReference (
    doc As Document,
    startRefName As String,
    destRefName As String
) As Boolean
public:
static bool UpdateSingleDocumentReference(
    Document^ doc,
    String^ startRefName,
    String^ destRefName
)
static member UpdateSingleDocumentReference :
        doc : Document *
        startRefName : string *
        destRefName : string -> bool

Parametri

doc
Tipo: Document
Documento di Inventor
startRefName
Tipo: SystemString
Riferimento di partenza
destRefName
Tipo: SystemString
Riferimento di destiinazione della sostituzione

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.UpdateSingleFullDocumentNameReference

Metodo UtilUpdateSingleFullDocumentNameReference

Funzione di aggiornamento di una reference su singolo documento

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateSingleFullDocumentNameReference(
    Document doc,
    string startRefFullDocName,
    string destRefName
)
Public Shared Function UpdateSingleFullDocumentNameReference (
    doc As Document,
    startRefFullDocName As String,
    destRefName As String
) As Boolean
public:
static bool UpdateSingleFullDocumentNameReference(
    Document^ doc,
    String^ startRefFullDocName,
    String^ destRefName
)
static member UpdateSingleFullDocumentNameReference :
        doc : Document *
        startRefFullDocName : string *
        destRefName : string -> bool

Parametri

doc
Tipo: Document
Documento di Inventor
startRefFullDocName
Tipo: SystemString
destRefName
Tipo: SystemString
Rfierimento di destiinazione della sostituzione

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.WriteAllProperties

Metodo UtilWriteAllProperties

Lista degli overload
Nome | Descrizione
WriteAllProperties(DedDoc) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, Document) | Scrive tutte le proprietà del documento nel Database
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Metodo Util.WriteAllProperties (DedDoc)

Metodo UtilWriteAllProperties (DedDoc)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc
)
public:
static void WriteAllProperties(
    DedDoc^ doc
)
static member WriteAllProperties :
        doc : DedDoc -> unit

Parametri

doc
Tipo: DedDoc
DedDoc dal quale leggere le propretà
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties
Namespace DedNetInv


Metodo Util.WriteAllProperties (DedDoc, Document)

Metodo UtilWriteAllProperties (DedDoc, Document)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    Document invDoc
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    invDoc As Document
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    Document^ invDoc
)
static member WriteAllProperties :
        doc : DedDoc *
        invDoc : Document -> unit

Parametri

doc
Tipo: DedDoc
DedDoc dal quale leggere le propretà
invDoc
Tipo: Document
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties
Namespace DedNetInv


Metodo Util.WriteAttr

Metodo UtilWriteAttr

Scrive il valore di un attributo nel documento/occorrenza di inventor, convertendolo prima in testo in base al tipo dati dell'attributo.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAttr(
    QsInvAttr attrManager,
    DedAttr attr,
    Object valore,
    ComponentOccurrence prt
)
Public Shared Sub WriteAttr (
    attrManager As QsInvAttr,
    attr As DedAttr,
    valore As Object,
    prt As ComponentOccurrence
)
public:
static void WriteAttr(
    QsInvAttr^ attrManager,
    DedAttr^ attr,
    Object^ valore,
    ComponentOccurrence^ prt
)
static member WriteAttr :
        attrManager : QsInvAttr *
        attr : DedAttr *
        valore : Object *
        prt : ComponentOccurrence -> unit

Parametri

attrManager
Tipo: QsInvAttr
Oggetto inizializzato da utilizzare per scrivere il valore dell'attributo.
attr
Tipo: DedAttr
Attributo da scrivere.
valore
Tipo: SystemObject
Valore da scrivere.
prt
Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Campi di Util

Il tipo Util espone i seguenti membri.

Campi
Nome | Descrizione
_dataTimeMin |
ActiveProjectLibraryPaths | Cache dei percorsi di libreria del progetto
Torna su
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Campo Util._dataTimeMin

Campo Util_dataTimeMin

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DateTime _dataTimeMin
Public Shared _dataTimeMin As DateTime
public:
static DateTime _dataTimeMin
static val mutable _dataTimeMin: DateTime

Valore del campo

Tipo: DateTime
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Campo Util.ActiveProjectLibraryPaths

Campo UtilActiveProjectLibraryPaths
Cache dei percorsi di libreria del progetto

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> ActiveProjectLibraryPaths
Public Shared ActiveProjectLibraryPaths As List(Of String)
public:
static List<String^>^ ActiveProjectLibraryPaths
static val mutable ActiveProjectLibraryPaths: List<string>

Valore del campo

Tipo: List String
Vedi anche

Documentazione

Classe Util
Namespace DedNetInv


Enumerazione Util.DataAttrTypeEnum

Enumerazione UtilDataAttrTypeEnum
Tipo di attributi da leggere/scrivere nel documento.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DataAttrTypeEnum
<FlagsAttribute>
Public Enumeration DataAttrTypeEnum
[FlagsAttribute]
public enum class DataAttrTypeEnum
[<FlagsAttribute>]
type DataAttrTypeEnum
Membri
Nome | Valore | Descrizione
Anagrafica | 0 | Solo anagrafica.
Documento | 1 | Anagrafica e documento (documento principale).
Distinta | 2 | Anagrafica e distinta (occorrenze virtuali).
Occorrenza | 4 | Occorrenza.
AnagraficaOccorrenza | 8 | Aggiungo il caso specifico anagrafica e documento
AnagraficaDocumento | 16 | Aggiungo il caso specifico anagrafica e documento
AnagraficaDocumentoOccorrenza | 32 | Aggiungo il caso specifico anagrafica, documento e occorrenza
AnagraficaDistinta | 64 | Aggiungo il caso specifico anagrafica e distinta
AnagraficaDistintaOccorrenza | 128 | Aggiungo il caso specifico anagrafica, distinta e occorrenza
All | 256 | Anagrafica, documento, distinta e occorrenza (occorrenze con documento).
Vedi anche

Documentazione

Namespace DedNetInv


Delegate Util.EnumWindowProcess

Delegate UtilEnumWindowProcess

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate bool EnumWindowProcess(
    IntPtr Handle,
    IntPtr Parameter
)
Public Delegate Function EnumWindowProcess (
    Handle As IntPtr,
    Parameter As IntPtr
) As Boolean
public delegate bool EnumWindowProcess(
    IntPtr Handle,
    IntPtr Parameter
)
type EnumWindowProcess =
    delegate of
        Handle : IntPtr *
        Parameter : IntPtr -> bool

Parametri

Handle
Tipo: SystemIntPtr
Parameter
Tipo: SystemIntPtr

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Namespace DedNetInv


Classe Util.PrtDwgExporterHelper

Classe UtilPrtDwgExporterHelper
Classe gestione pubblicazioni tramite modulo TopInventor.
Gerarchia di ereditarietà
SystemObject
DedNetInvUtilPrtDwgExporterHelper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PrtDwgExporterHelper
Public Class PrtDwgExporterHelper
public ref class PrtDwgExporterHelper
type PrtDwgExporterHelper =  class end

Il tipo UtilPrtDwgExporterHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilPrtDwgExporterHelper |
Torna su
Metodi
Nome | Descrizione
ExportDwgTop | Pubblicazione in DwgTop. Vuole il document di Inventor da pubblicare ed il nome del file di output.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Util.PrtDwgExporterHelper

Costruttore UtilPrtDwgExporterHelper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PrtDwgExporterHelper()
Public Sub New
public:
PrtDwgExporterHelper()
new : unit -> PrtDwgExporterHelper
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetInv


Metodi di PrtDwgExporterHelper

Il tipo UtilPrtDwgExporterHelper espone i seguenti membri.

Metodi
Nome | Descrizione
ExportDwgTop | Pubblicazione in DwgTop. Vuole il document di Inventor da pubblicare ed il nome del file di output.
Torna su
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetInv


Metodo Util.PrtDwgExporterHelper.ExportDwgTop

Metodo UtilPrtDwgExporterHelperExportDwgTop

Pubblicazione in DwgTop. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool ExportDwgTop(
    Document _doc,
    string _fout
)
Public Shared Function ExportDwgTop (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool ExportDwgTop(
    Document^ _doc,
    String^ _fout
)
static member ExportDwgTop :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilPrtDwgExporterHelper
Namespace DedNetInv


Classe Util.QsPublisherHelper

Classe UtilQsPublisherHelper
Classe gestione pubblicazioni tramite modulo QsPublisher.
Gerarchia di ereditarietà
SystemObject
DedNetInvUtilQsPublisherHelper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsPublisherHelper
Public Class QsPublisherHelper
public ref class QsPublisherHelper
type QsPublisherHelper =  class end

Il tipo UtilQsPublisherHelper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilQsPublisherHelper |
Torna su
Metodi
Nome | Descrizione
PublishDWF | Pubblicazione in DWF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishDWG | Pubblicazione in DWG. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishDXF | Pubblicazione in DXF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishIGES | Pubblicazione in IGES. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF(Document, String) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF(Document, String, DictionaryString, Object) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF3D | Pubblicazione in PDF 3D. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSheetMetalDXF | Pubblicazione in DXF (lamiera). Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSTEP | Pubblicazione in STEP. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSTL | Pubblicazione in STL. Vuole il document di Inventor da pubblicare ed il nome del file di output.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Util.QsPublisherHelper

Costruttore UtilQsPublisherHelper

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsPublisherHelper()
Public Sub New
public:
QsPublisherHelper()
new : unit -> QsPublisherHelper
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodi di QsPublisherHelper

Il tipo UtilQsPublisherHelper espone i seguenti membri.

Metodi
Nome | Descrizione
PublishDWF | Pubblicazione in DWF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishDWG | Pubblicazione in DWG. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishDXF | Pubblicazione in DXF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishIGES | Pubblicazione in IGES. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF(Document, String) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF(Document, String, DictionaryString, Object) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF3D | Pubblicazione in PDF 3D. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSheetMetalDXF | Pubblicazione in DXF (lamiera). Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSTEP | Pubblicazione in STEP. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishSTL | Pubblicazione in STL. Vuole il document di Inventor da pubblicare ed il nome del file di output.
Torna su
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishDWF

Metodo UtilQsPublisherHelperPublishDWF

Pubblicazione in DWF. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishDWF(
    Document _doc,
    string _fout
)
Public Shared Function PublishDWF (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishDWF(
    Document^ _doc,
    String^ _fout
)
static member PublishDWF :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishDWG

Metodo UtilQsPublisherHelperPublishDWG

Pubblicazione in DWG. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishDWG(
    Document _doc,
    string _fout
)
Public Shared Function PublishDWG (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishDWG(
    Document^ _doc,
    String^ _fout
)
static member PublishDWG :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishDXF

Metodo UtilQsPublisherHelperPublishDXF

Pubblicazione in DXF. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishDXF(
    Document _doc,
    string _fout
)
Public Shared Function PublishDXF (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishDXF(
    Document^ _doc,
    String^ _fout
)
static member PublishDXF :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishIGES

Metodo UtilQsPublisherHelperPublishIGES

Pubblicazione in IGES. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishIGES(
    Document _doc,
    string _fout
)
Public Shared Function PublishIGES (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishIGES(
    Document^ _doc,
    String^ _fout
)
static member PublishIGES :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo QsPublisherHelper.PublishPDF

Metodo QsPublisherHelperPublishPDF

Lista degli overload
Nome | Descrizione
PublishPDF(Document, String) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
PublishPDF(Document, String, DictionaryString, Object) | Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.
Torna su
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishPDF (Document, String)

Metodo UtilQsPublisherHelperPublishPDF (Document, String)
Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF(
    Document _doc,
    string _fout
)
Public Shared Function PublishPDF (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishPDF(
    Document^ _doc,
    String^ _fout
)
static member PublishPDF :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Overload di PublishPDF
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishPDF (Document, String, Dictionary(String, Object))

Metodo UtilQsPublisherHelperPublishPDF (Document, String, DictionaryString, Object)
Pubblicazione in PDF. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF(
    Document _doc,
    string _fout,
    Dictionary<string, Object> options
)
Public Shared Function PublishPDF (
    _doc As Document,
    _fout As String,
    options As Dictionary(Of String, Object)
) As Boolean
public:
static bool PublishPDF(
    Document^ _doc,
    String^ _fout,
    Dictionary<String^, Object^>^ options
)
static member PublishPDF :
        _doc : Document *
        _fout : string *
        options : Dictionary<string, Object> -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString
options
Tipo: System.Collections.GenericDictionary String, Object

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Overload di PublishPDF
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishPDF3D

Metodo UtilQsPublisherHelperPublishPDF3D

Pubblicazione in PDF 3D. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishPDF3D(
    Document _doc,
    string _fout
)
Public Shared Function PublishPDF3D (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishPDF3D(
    Document^ _doc,
    String^ _fout
)
static member PublishPDF3D :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishSheetMetalDXF

Metodo UtilQsPublisherHelperPublishSheetMetalDXF

Pubblicazione in DXF (lamiera). Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSheetMetalDXF(
    Document _doc,
    string _fout
)
Public Shared Function PublishSheetMetalDXF (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishSheetMetalDXF(
    Document^ _doc,
    String^ _fout
)
static member PublishSheetMetalDXF :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishSTEP

Metodo UtilQsPublisherHelperPublishSTEP

Pubblicazione in STEP. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSTEP(
    Document _doc,
    string _fout
)
Public Shared Function PublishSTEP (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishSTEP(
    Document^ _doc,
    String^ _fout
)
static member PublishSTEP :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Metodo Util.QsPublisherHelper.PublishSTL

Metodo UtilQsPublisherHelperPublishSTL

Pubblicazione in STL. Vuole il document di Inventor da pubblicare ed il nome del file di output.

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishSTL(
    Document _doc,
    string _fout
)
Public Shared Function PublishSTL (
    _doc As Document,
    _fout As String
) As Boolean
public:
static bool PublishSTL(
    Document^ _doc,
    String^ _fout
)
static member PublishSTL :
        _doc : Document *
        _fout : string -> bool

Parametri

_doc
Tipo: Document
_fout
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UtilQsPublisherHelper
Namespace DedNetInv


Classe Util.SpecialStructInfos

Classe UtilSpecialStructInfos
Classe per la gestione dati delle strutture speciali
Gerarchia di ereditarietà
SystemObject
DedNetInvUtilSpecialStructInfos

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SpecialStructInfos
Public Class SpecialStructInfos
public ref class SpecialStructInfos
type SpecialStructInfos =  class end

Il tipo UtilSpecialStructInfos espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilSpecialStructInfos |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestAssemblyPath |
Proprietà pubblica | SpecStructFileDescriptorList |
Proprietà pubblica | SpecStructFromPathList |
Proprietà pubblica | SpecStructFromRelativePathList |
Proprietà pubblica | SpecStructOwnershipList |
Proprietà pubblica | SpecStructPartNumbers |
Proprietà pubblica | SpecStructToPathList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clear |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Util.SpecialStructInfos

Costruttore UtilSpecialStructInfos

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SpecialStructInfos()
Public Sub New
public:
SpecialStructInfos()
new : unit -> SpecialStructInfos
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà di SpecialStructInfos

Il tipo UtilSpecialStructInfos espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DestAssemblyPath |
Proprietà pubblica | SpecStructFileDescriptorList |
Proprietà pubblica | SpecStructFromPathList |
Proprietà pubblica | SpecStructFromRelativePathList |
Proprietà pubblica | SpecStructOwnershipList |
Proprietà pubblica | SpecStructPartNumbers |
Proprietà pubblica | SpecStructToPathList |
Torna su
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.DestAssemblyPath

Proprietà UtilSpecialStructInfosDestAssemblyPath

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestAssemblyPath { get; set; }
Public Property DestAssemblyPath As String
    Get
    Set
public:
property String^ DestAssemblyPath {
    String^ get ();
    void set (String^ value);
}
member DestAssemblyPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructFileDescriptorList

Proprietà UtilSpecialStructInfosSpecStructFileDescriptorList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<FileDescriptor> SpecStructFileDescriptorList { get; }
Public ReadOnly Property SpecStructFileDescriptorList As List(Of FileDescriptor)
    Get
public:
property List<FileDescriptor^>^ SpecStructFileDescriptorList {
    List<FileDescriptor^>^ get ();
}
member SpecStructFileDescriptorList : List<FileDescriptor> with get

Valore della proprietà

Tipo: List FileDescriptor
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructFromPathList

Proprietà UtilSpecialStructInfosSpecStructFromPathList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> SpecStructFromPathList { get; }
Public ReadOnly Property SpecStructFromPathList As List(Of String)
    Get
public:
property List<String^>^ SpecStructFromPathList {
    List<String^>^ get ();
}
member SpecStructFromPathList : List<string> with get

Valore della proprietà

Tipo: List String
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructFromRelativePathList

Proprietà UtilSpecialStructInfosSpecStructFromRelativePathList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> SpecStructFromRelativePathList { get; }
Public ReadOnly Property SpecStructFromRelativePathList As List(Of String)
    Get
public:
property List<String^>^ SpecStructFromRelativePathList {
    List<String^>^ get ();
}
member SpecStructFromRelativePathList : List<string> with get

Valore della proprietà

Tipo: List String
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructOwnershipList

Proprietà UtilSpecialStructInfosSpecStructOwnershipList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<FileOwnershipEnum> SpecStructOwnershipList { get; }
Public ReadOnly Property SpecStructOwnershipList As List(Of FileOwnershipEnum)
    Get
public:
property List<FileOwnershipEnum>^ SpecStructOwnershipList {
    List<FileOwnershipEnum>^ get ();
}
member SpecStructOwnershipList : List<FileOwnershipEnum> with get

Valore della proprietà

Tipo: List FileOwnershipEnum
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructPartNumbers

Proprietà UtilSpecialStructInfosSpecStructPartNumbers

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> SpecStructPartNumbers { get; }
Public ReadOnly Property SpecStructPartNumbers As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ SpecStructPartNumbers {
    Dictionary<String^, String^>^ get ();
}
member SpecStructPartNumbers : Dictionary<string, string> with get

Valore della proprietà

Tipo: Dictionary String, String
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Proprietà Util.SpecialStructInfos.SpecStructToPathList

Proprietà UtilSpecialStructInfosSpecStructToPathList

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> SpecStructToPathList { get; }
Public ReadOnly Property SpecStructToPathList As List(Of String)
    Get
public:
property List<String^>^ SpecStructToPathList {
    List<String^>^ get ();
}
member SpecStructToPathList : List<string> with get

Valore della proprietà

Tipo: List String
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Metodi di SpecialStructInfos

Il tipo UtilSpecialStructInfos espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clear |
Torna su
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Metodo Util.SpecialStructInfos.Clear

Metodo UtilSpecialStructInfosClear

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe UtilSpecialStructInfos
Namespace DedNetInv


Classe Util.SubclassHWND

Classe UtilSubclassHWND
Subclassa la finestra principale di inventor o quella di un documento per segnalarne la chiusura.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.Windows.FormsNativeWindow
DedNetInvUtilSubclassHWND

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SubclassHWND : NativeWindow
Public Class SubclassHWND
    Inherits NativeWindow
public ref class SubclassHWND : public NativeWindow
type SubclassHWND =
    class
        inherit NativeWindow
    end

Il tipo UtilSubclassHWND espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | UtilSubclassHWND |
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | WndProc | (Sovrascrive NativeWindowWndProc(Message).)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | ClosingWindowEvent |
Evento pubblico | CommandWindowEvent |
Evento pubblico | DestroyWindowEvent |
Evento pubblico | WindowActivatedEvent |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | Data |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv


Costruttore Util.SubclassHWND

Costruttore UtilSubclassHWND

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SubclassHWND()
Public Sub New
public:
SubclassHWND()
new : unit -> SubclassHWND
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Metodi di SubclassHWND

Il tipo UtilSubclassHWND espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | WndProc | (Sovrascrive NativeWindowWndProc(Message).)
Torna su
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Metodo Util.SubclassHWND.WndProc

Metodo UtilSubclassHWNDWndProc

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void WndProc(
    ref Message m
)
Protected Overrides Sub WndProc (
    ByRef m As Message
)
protected:
virtual void WndProc(
    Message% m
) override
abstract WndProc :
        m : Message byref -> unit
override WndProc :
        m : Message byref -> unit

Parametri

m
Tipo: System.Windows.FormsMessage
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Eventi di SubclassHWND

Il tipo UtilSubclassHWND espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | ClosingWindowEvent |
Evento pubblico | CommandWindowEvent |
Evento pubblico | DestroyWindowEvent |
Evento pubblico | WindowActivatedEvent |
Torna su
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Evento Util.SubclassHWND.ClosingWindowEvent

Evento UtilSubclassHWNDClosingWindowEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event UtilSubclassHWNDClosingWindowEventEventHandler ClosingWindowEvent
Public Event ClosingWindowEvent As UtilSubclassHWNDClosingWindowEventEventHandler
public:
 event UtilSubclassHWNDClosingWindowEventEventHandler^ ClosingWindowEvent {
    void add (UtilSubclassHWNDClosingWindowEventEventHandler^ value);
    void remove (UtilSubclassHWNDClosingWindowEventEventHandler^ value);
}
member ClosingWindowEvent : IEvent<UtilSubclassHWNDClosingWindowEventEventHandler,
    EventArgs>

Valore

Tipo: DedNetInvUtilSubclassHWNDClosingWindowEventEventHandler
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Evento Util.SubclassHWND.CommandWindowEvent

Evento UtilSubclassHWNDCommandWindowEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event UtilSubclassHWNDCommandWindowEventEventHandler CommandWindowEvent
Public Event CommandWindowEvent As UtilSubclassHWNDCommandWindowEventEventHandler
public:
 event UtilSubclassHWNDCommandWindowEventEventHandler^ CommandWindowEvent {
    void add (UtilSubclassHWNDCommandWindowEventEventHandler^ value);
    void remove (UtilSubclassHWNDCommandWindowEventEventHandler^ value);
}
member CommandWindowEvent : IEvent<UtilSubclassHWNDCommandWindowEventEventHandler,
    EventArgs>

Valore

Tipo: DedNetInvUtilSubclassHWNDCommandWindowEventEventHandler
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Evento Util.SubclassHWND.DestroyWindowEvent

Evento UtilSubclassHWNDDestroyWindowEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event UtilSubclassHWNDDestroyWindowEventEventHandler DestroyWindowEvent
Public Event DestroyWindowEvent As UtilSubclassHWNDDestroyWindowEventEventHandler
public:
 event UtilSubclassHWNDDestroyWindowEventEventHandler^ DestroyWindowEvent {
    void add (UtilSubclassHWNDDestroyWindowEventEventHandler^ value);
    void remove (UtilSubclassHWNDDestroyWindowEventEventHandler^ value);
}
member DestroyWindowEvent : IEvent<UtilSubclassHWNDDestroyWindowEventEventHandler,
    EventArgs>

Valore

Tipo: DedNetInvUtilSubclassHWNDDestroyWindowEventEventHandler
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Evento Util.SubclassHWND.WindowActivatedEvent

Evento UtilSubclassHWNDWindowActivatedEvent

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event UtilSubclassHWNDWindowActivatedEventEventHandler WindowActivatedEvent
Public Event WindowActivatedEvent As UtilSubclassHWNDWindowActivatedEventEventHandler
public:
 event UtilSubclassHWNDWindowActivatedEventEventHandler^ WindowActivatedEvent {
    void add (UtilSubclassHWNDWindowActivatedEventEventHandler^ value);
    void remove (UtilSubclassHWNDWindowActivatedEventEventHandler^ value);
}
member WindowActivatedEvent : IEvent<UtilSubclassHWNDWindowActivatedEventEventHandler,
    EventArgs>

Valore

Tipo: DedNetInvUtilSubclassHWNDWindowActivatedEventEventHandler
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Campi di SubclassHWND

Il tipo UtilSubclassHWND espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | Data |
Torna su
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Campo Util.SubclassHWND.Data

Campo UtilSubclassHWNDData

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Data
Public Data As Object
public:
Object^ Data
val mutable Data: Object

Valore del campo

Tipo: Object
Vedi anche

Documentazione

Classe UtilSubclassHWND
Namespace DedNetInv


Delegate Util.SubclassHWND.ClosingWindowEventEventHandler

Delegate UtilSubclassHWNDClosingWindowEventEventHandler

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void ClosingWindowEventEventHandler()
Public Delegate Sub ClosingWindowEventEventHandler
public delegate void ClosingWindowEventEventHandler()
type ClosingWindowEventEventHandler =
    delegate of unit -> unit
Vedi anche

Documentazione

Namespace DedNetInv


Delegate Util.SubclassHWND.CommandWindowEventEventHandler

Delegate UtilSubclassHWNDCommandWindowEventEventHandler

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void CommandWindowEventEventHandler(
    Message m
)
Public Delegate Sub CommandWindowEventEventHandler (
    m As Message
)
public delegate void CommandWindowEventEventHandler(
    Message m
)
type CommandWindowEventEventHandler =
    delegate of
        m : Message -> unit

Parametri

m
Tipo: System.Windows.FormsMessage
Vedi anche

Documentazione

Namespace DedNetInv


Delegate Util.SubclassHWND.DestroyWindowEventEventHandler

Delegate UtilSubclassHWNDDestroyWindowEventEventHandler

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void DestroyWindowEventEventHandler()
Public Delegate Sub DestroyWindowEventEventHandler
public delegate void DestroyWindowEventEventHandler()
type DestroyWindowEventEventHandler =
    delegate of unit -> unit
Vedi anche

Documentazione

Namespace DedNetInv


Delegate Util.SubclassHWND.WindowActivatedEventEventHandler

Delegate UtilSubclassHWNDWindowActivatedEventEventHandler

Namespace: DedNetInv
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void WindowActivatedEventEventHandler(
    IntPtr subHandle
)
Public Delegate Sub WindowActivatedEventEventHandler (
    subHandle As IntPtr
)
public delegate void WindowActivatedEventEventHandler(
    IntPtr subHandle
)
type WindowActivatedEventEventHandler =
    delegate of
        subHandle : IntPtr -> unit

Parametri

subHandle
Tipo: SystemIntPtr
Vedi anche

Documentazione

Namespace DedNetInv


DedNetInv.Commands Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AggiornaAttributiDaDB | Aggiorna attributi dal DB.
Classe pubblica | AggiornaDocumentoLocale | Comando di aggiornamento dei documenti in area locale
Classe pubblica | AlberoDocumenti | Apre / chiude la finestra per la visualizzazione delle dipendenze documentali.
Classe pubblica | AllineaAttributi | Allinea attributi.
Classe pubblica | AllineaAttributiRicorsivo | Allinea attributi ricrosivo.
Classe pubblica | AnnullaCheckOut | Comando di sblocca dell'addin
Classe pubblica | ApriconOpzioni | Comando che effettua l'apri con opzioni.
Classe pubblica | ApriFileAssociati | Apre il file associato se ne esiste soltanto uno altrimenti visualizza la finestra WhereUsed (in modalità appropriata) per far selezionare all'utente i documenti da aprire.
Classe pubblica | ApriInLettura | Apre la finestra per l'apertura in lettura di un documento.
Classe pubblica | ApriInModifica | Apre la finestra per l'apertura in modifica di un documento.
Classe pubblica | ApriInNuovaFinestra | Apre la finestra per l'apertura in lettura di un documento.
Classe pubblica | ArchiviaDoc | Apre la finestra documentale con la possibilità di scegliere una cartella di archiviazione.
Classe pubblica | AssociaPresentazione | Permette di associare una messa in tavola esistente al documento correntemente aperto.
Classe pubblica | AssociaTavola | Permette di associare una messa in tavola esistente al documento correntemente aperto.
Classe pubblica | AssociatedECO | Apre la finestra degli ECO con caricati gli ECO associati all'anagrafica/commessa del documento.
Classe pubblica | AssociatedTranslations | Apre la finestra delle traduzioni con caricate le traduzioni in lingua associate all'anagrafica del documento.
Classe pubblica | Attributi | Apre / chiude la finestra per la visualizzazione degli attributi.
Classe pubblica | CambiaPassword | Comando lanciato per eseguire il cambio di password.
Classe pubblica | CambiaStato | Comando generico cambio stato specifico dell'addin
Classe pubblica | CambiaStatoPublishingDocumentDescriptor | Descrittore documento in pubblicazione
Classe pubblica | CaricaBody | Comando che effettua il carica body del file selezionato
Classe pubblica | CaricaNewRep | Comando che effettua il carica parte di un DWG, sotto una data parte.
Classe pubblica | CaricaParte | Comando che effettua il carica parte di un DWG, sotto una data parte.
Classe pubblica | CheckIn | Comando di checkin dell'addin
Classe pubblica | CheckOut | Comando di checkout dell'addin
Classe pubblica | CompileFactoryTableAttrs | Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e tramite questi ricompila la sua tabella interna con i loro attributi.
Classe pubblica | ConfiguraDistinta | Apre il configuratore delle distinte.
Classe pubblica | ControlloCoerenzaRiferimenti | Permette di associare una messa in tavola esistente al documento correntemente aperto.
Classe pubblica | CreaComponenteAnagrafica | Apre la tabella delle revisioni.
Classe pubblica | CreaInvAssociaConf | Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | CreaInvAssociaDocument | Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | CreaInvDisconnectConf | Scollega il documento corrente dall'anagrafica alla quale è collegato come ms secondario. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | CreaNuovaRappresentazione | Crea Nuova Rappresentazione del documento
Classe pubblica | CreateSparePartsDrawing | Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Classe pubblica | DedInvCommandContext | Classe per il contesto di esecuzione comando all'interno dell'addin. Contiene le informazioni necessarie per l'esecuzione di un comando .
Classe pubblica | DistintaComponenti | Apre la distinta componenti.
Classe pubblica | DistintaEsplosa | Apre la finestra della distinta esplosa per il codice selezionato.
Classe pubblica | DistintaImplosa | Apre la finestra della distinta implosa per il codice selezionato.
Classe pubblica | DocAssocInv | Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Classe pubblica | DocRecognizer | Apre la gestione dell'area locale.
Classe pubblica | DocumentAssistant | Comando Document Assistant
Classe pubblica | DownloadProject | Permette di scarica/aggiornare il progetto di Invenotor in locale.
Classe pubblica | EditaAttributiSoloDB | Edita Attributi Solo DB
Classe pubblica | EditaCommesse | Apre l'editor delle commesse.
Classe pubblica | EditaDistinta | Apre l'editor delle distinta precompilando il codice in base alla selezione effettuata.
Classe pubblica | EditaECO | Apre l'editor degli ECO.
Classe pubblica | EseguiLua | Apre la finestra per l'esecuzione di codice LUA.
Classe pubblica | FindDoc | Apre la finestra per la ricerca dei documenti.
Classe pubblica | FindInBrowser | Comando di individuazione elementi albero dall'area grafica / browser.
Classe pubblica | FindInRicerca | Apre la finestra della ricerca con preselezionata l'anagrafica interessata.
Classe pubblica | ForceMarkerAlingment | Comando che permette di forzare l'allineamento del documento con quella presente nel Database.
Classe pubblica | FormAbout | Apre la visualizzazione del form about.
Classe pubblica | Help |
Classe pubblica | IndividuaGrafica | Comando di inviduazione elementi nell'area grafica
Classe pubblica | InvCommandBase | Classe base per la definizione di un comando dell'add-in di Inventor. Deriva da DedCommand per permettere l'esecuzione sia da pulsante di comando che da codice.
Classe pubblica | InvDataStatisticsAnalyzer | Comando di individuazione elementi albero dall'area grafica / browser.
Classe pubblica | InvUserLogin | Comando login specifico del cad
Classe pubblica | Lavorazione | Comando lavorazione ( solo in modalità STANDARD )
Classe pubblica | LinkDED | Apre le opzioni dell'applicazione.
Classe pubblica | MarkerInfo | Comando che permette di controllare lo stato di allineamento del documento.
Classe pubblica | ModificaSuperato | Comando RettificaSuperato ( solo in modalità STANDARD )
Classe pubblica | OpzioniApplicazione | Apre le opzioni dell'applicazione.
Classe pubblica | PackAndGoExport | Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
Classe pubblica | PackAndGoImport | Esegue l'importazione della struttura dall'anagrafica o dal documento attivo
Classe pubblica | PackAndGoImportingStructureInfo | Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Classe pubblica | PackAndGoNodeDescriptor | Descrittore singolo nodo di struttura
Classe pubblica | PackAndGoNodeDescriptors | Classe gestione lista nodi di struttura
Classe pubblica | PackAndGoNodeWrapper | Classe rappresentante l'oggetto nodo nel controllo treeList del form
Classe pubblica | PackAndGoStructureDescriptor | Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Classe pubblica | Pubblica | Comando di checkin dell'addin
Classe pubblica | PublishProject | Permette di salvare il progetto di Inventor presente n locale sul server.
Classe pubblica | PublishSparePartsDrawing | Comando che pubblica una tavola tecnica ricambi in formato pdf.
Classe pubblica | PwsCache | Apre la gestione dell'area locale.
Classe pubblica | Registra | Comando di registrazione del documento nel database
Classe pubblica | ReleaseFactoryMember | Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi rilascia tutti i componenti
Classe pubblica | Ricerca | Apre finestra per la ricerca.
Classe pubblica | Rilascia | Comando rilascio ( solo in modalità STANDARD )
Classe pubblica | Salva | Salva il documento attivo o l'occorrenza selezionata nel Database.
Classe pubblica | SalvaConf | Salva il documento attivo o l'occorrenza selezionata nel Database.
Classe pubblica | SalvaDist | Salva la distinta
Classe pubblica | SalvaMultiplo | Comando salvataggio multiplo elementi dell'assieme
Classe pubblica | SalvaPartBody | Salvataggio diretto di un part body nel database
Classe pubblica | SalvaRev | Salva la nuova revisione dei documenti.
Classe pubblica | SalvaSuperato | Comando SalvaSuperato ( solo in modalità STANDARD )
Classe pubblica | SaveFactoryMemberRevision | Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi salva la revisione di tutti componenti
Classe pubblica | Sblocca | Comando di sblocca dell'addin
Classe pubblica | SostituisciComponente | Esegue la sostituzione con interfaccia partendo dalla selezione dell'oggetto da sostituire e mostrando il form di opzioni.
Classe pubblica | SostituisciComponenteDerivato | Permette di sostituire il modello di base di un componente derivato
Classe pubblica | SostituisciComponenteRapido | Esegua la sostituzione in modalità di selezione dell'oggetto di sostituzione sulla selezione attiva a documento.
Classe pubblica | SostituisciMoved | Comando di registrazione del documento nel database
Classe pubblica | SostituisciRiferimenti | Permette di associare una messa in tavola esistente al documento correntemente aperto.
Classe pubblica | StatoDocumento | Comando di per visualizzare lo stato del documento attivo.
Classe pubblica | TabellaRevisioni | Apre la tabella delle revisioni.
Classe pubblica | UpdateBranchInformations | Comando che aggiorna il ramo selezionato in caso di moldalità velocizzata per VPN.
Classe pubblica | UpdateMembersFromFactory | Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi procedo all'aggiornamento di ognuno.
Classe pubblica | UpdateOldRev | Apre la finestra per aggiornare le eventuali revisioni superate.
Classe pubblica | VisualaDiagDep | Crea un nuovo comando VisualDep che mostra all'utente l'albero delle dipendenze avanzato.
Classe pubblica | WhereUsedInv | Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedInvCommandContextSourceEnum | Enumerazione delle possibili sorgneti di contesto comando
Enumerazione pubblica | PackAndGoContext | Definizione possibili contesti
Enumerazione pubblica | PackAndGoImportAttrStatus | Stato attributi in validazione importazione
Enumerazione pubblica | PackAndGoImportDedCases | Possibili casi del database in fase di importazione
Enumerazione pubblica | PackAndGoImportOperation | Definizione possibili azioni su oggetti importazione
Enumerazione pubblica | PackAndGoImportOperationStatus | Stato di validazione dell'operazione ( per ora non usata sempre Ok )


Classe AggiornaAttributiDaDB
Aggiorna attributi dal DB.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAggiornaAttributiDaDB

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AggiornaAttributiDaDB : InvCommandBase
Public Class AggiornaAttributiDaDB
    Inherits InvCommandBase
public ref class AggiornaAttributiDaDB : public InvCommandBase
type AggiornaAttributiDaDB =
    class
        inherit InvCommandBase
    end

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Parte oggetto del documento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AggiornaAttributiDaDB

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Parte oggetto del documento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Proprietà AggiornaAttributiDaDB.NeedParameters

Proprietà AggiornaAttributiDaDBNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Proprietà AggiornaAttributiDaDB.Prt

Proprietà AggiornaAttributiDaDBPrt

Parte oggetto del documento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Prt { get; set; }
Public Property Prt As Object
    Get
    Set
public:
property Object^ Prt {
    Object^ get ();
    void set (Object^ value);
}
member Prt : Object with get, set

Valore della proprietà

Tipo: Object
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Metodi di AggiornaAttributiDaDB

Il tipo AggiornaAttributiDaDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Metodo AggiornaAttributiDaDB.ClearCommand

Metodo AggiornaAttributiDaDBClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Metodo AggiornaAttributiDaDB.ExecuteCommand

Metodo AggiornaAttributiDaDBExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Metodo AggiornaAttributiDaDB.InvEnabled

Metodo AggiornaAttributiDaDBInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Metodo AggiornaAttributiDaDB.InvSetContext

Metodo AggiornaAttributiDaDBInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaAttributiDaDB
Namespace DedNetInv.Commands


Classe AggiornaDocumentoLocale
Comando di aggiornamento dei documenti in area locale
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAggiornaDocumentoLocale

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AggiornaDocumentoLocale : InvCommandBase
Public Class AggiornaDocumentoLocale
    Inherits InvCommandBase
public ref class AggiornaDocumentoLocale : public InvCommandBase
type AggiornaDocumentoLocale =
    class
        inherit InvCommandBase
    end

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AggiornaDocumentoLocale

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Proprietà AggiornaDocumentoLocale.NeedParameters

Proprietà AggiornaDocumentoLocaleNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Metodi di AggiornaDocumentoLocale

Il tipo AggiornaDocumentoLocale espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Metodo AggiornaDocumentoLocale.ClearCommand

Metodo AggiornaDocumentoLocaleClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Metodo AggiornaDocumentoLocale.ExecuteCommand

Metodo AggiornaDocumentoLocaleExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Metodo AggiornaDocumentoLocale.InvEnabled

Metodo AggiornaDocumentoLocaleInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Metodo AggiornaDocumentoLocale.InvSetContext

Metodo AggiornaDocumentoLocaleInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AggiornaDocumentoLocale
Namespace DedNetInv.Commands


Classe AlberoDocumenti
Apre / chiude la finestra per la visualizzazione delle dipendenze documentali.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAlberoDocumenti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AlberoDocumenti : InvCommandBase
Public Class AlberoDocumenti
    Inherits InvCommandBase
public ref class AlberoDocumenti : public InvCommandBase
type AlberoDocumenti =
    class
        inherit InvCommandBase
    end

Il tipo AlberoDocumenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form contenente il controllo delle dipendenze. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dockable Window sia visibile.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo pubblico | InitializeDialog | Rigenera il dialogo delle dipendenze.
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AlberoDocumenti

Il tipo AlberoDocumenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form contenente il controllo delle dipendenze. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dockable Window sia visibile.
Torna su
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Proprietà AlberoDocumenti.Form

Proprietà AlberoDocumentiForm

Restituisce il Form contenente il controllo delle dipendenze. Può essere null se il comando non è ancora stato lanciato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentsForm Form { get; }
Public ReadOnly Property Form As DocumentsForm
    Get
public:
property DocumentsForm^ Form {
    DocumentsForm^ get ();
}
member Form : DocumentsForm with get

Valore della proprietà

Tipo: DocumentsForm
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Proprietà AlberoDocumenti.Visible

Proprietà AlberoDocumentiVisible

Restituisce se la dockable Window sia visibile.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Metodi di AlberoDocumenti

Il tipo AlberoDocumenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo pubblico | InitializeDialog | Rigenera il dialogo delle dipendenze.
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Metodo AlberoDocumenti.ExecuteCommand

Metodo AlberoDocumentiExecuteCommand

Lancia il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Metodo AlberoDocumenti.InitializeDialog

Metodo AlberoDocumentiInitializeDialog

Rigenera il dialogo delle dipendenze.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void InitializeDialog()
Public Sub InitializeDialog
public:
void InitializeDialog()
member InitializeDialog : unit -> unit
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Metodo AlberoDocumenti.InvEnabled

Metodo AlberoDocumentiInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Metodo AlberoDocumenti.InvSetContext

Metodo AlberoDocumentiInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AlberoDocumenti
Namespace DedNetInv.Commands


Classe AllineaAttributi
Allinea attributi.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAllineaAttributi

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AllineaAttributi : InvCommandBase
Public Class AllineaAttributi
    Inherits InvCommandBase
public ref class AllineaAttributi : public InvCommandBase
type AllineaAttributi =
    class
        inherit InvCommandBase
    end

Il tipo AllineaAttributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AllineaAttributi

Il tipo AllineaAttributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Proprietà AllineaAttributi.NeedParameters

Proprietà AllineaAttributiNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Metodi di AllineaAttributi

Il tipo AllineaAttributi espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Metodo AllineaAttributi.ClearCommand

Metodo AllineaAttributiClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Metodo AllineaAttributi.ExecuteCommand

Metodo AllineaAttributiExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Metodo AllineaAttributi.InvEnabled

Metodo AllineaAttributiInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Metodo AllineaAttributi.InvSetContext

Metodo AllineaAttributiInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributi
Namespace DedNetInv.Commands


Classe AllineaAttributiRicorsivo
Allinea attributi ricrosivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAllineaAttributiRicorsivo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AllineaAttributiRicorsivo : InvCommandBase
Public Class AllineaAttributiRicorsivo
    Inherits InvCommandBase
public ref class AllineaAttributiRicorsivo : public InvCommandBase
type AllineaAttributiRicorsivo =
    class
        inherit InvCommandBase
    end

Il tipo AllineaAttributiRicorsivo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AllineaAttributiRicorsivo

Il tipo AllineaAttributiRicorsivo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Proprietà AllineaAttributiRicorsivo.NeedParameters

Proprietà AllineaAttributiRicorsivoNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Metodi di AllineaAttributiRicorsivo

Il tipo AllineaAttributiRicorsivo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Metodo AllineaAttributiRicorsivo.ClearCommand

Metodo AllineaAttributiRicorsivoClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Metodo AllineaAttributiRicorsivo.ExecuteCommand

Metodo AllineaAttributiRicorsivoExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Metodo AllineaAttributiRicorsivo.InvEnabled

Metodo AllineaAttributiRicorsivoInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Metodo AllineaAttributiRicorsivo.InvSetContext

Metodo AllineaAttributiRicorsivoInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AllineaAttributiRicorsivo
Namespace DedNetInv.Commands


Classe AnnullaCheckOut
Comando di sblocca dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAnnullaCheckOut

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AnnullaCheckOut : InvCommandBase
Public Class AnnullaCheckOut
    Inherits InvCommandBase
public ref class AnnullaCheckOut : public InvCommandBase
type AnnullaCheckOut =
    class
        inherit InvCommandBase
    end

Il tipo AnnullaCheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AnnullaCheckOut

Il tipo AnnullaCheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Proprietà AnnullaCheckOut.NeedParameters

Proprietà AnnullaCheckOutNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Metodi di AnnullaCheckOut

Il tipo AnnullaCheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Metodo AnnullaCheckOut.ClearCommand

Metodo AnnullaCheckOutClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Metodo AnnullaCheckOut.ExecuteCommand

Metodo AnnullaCheckOutExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Metodo AnnullaCheckOut.InvEnabled

Metodo AnnullaCheckOutInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Metodo AnnullaCheckOut.InvSetContext

Metodo AnnullaCheckOutInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AnnullaCheckOut
Namespace DedNetInv.Commands


Classe ApriconOpzioni
Comando che effettua l'apri con opzioni.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsApriconOpzioni

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriconOpzioni : InvCommandBase
Public Class ApriconOpzioni
    Inherits InvCommandBase
public ref class ApriconOpzioni : public InvCommandBase
type ApriconOpzioni =
    class
        inherit InvCommandBase
    end

Il tipo ApriconOpzioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommand.NeedDocument.)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ApriconOpzioni

Il tipo ApriconOpzioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive DedCommand.NeedDocument.)
Proprietà pubblica | NeedParameters | Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Proprietà ApriconOpzioni.DocumentInfos

Proprietà ApriconOpzioniDocumentInfos

Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList DocumentInfos { get; }
Public ReadOnly Property DocumentInfos As DedCommandDocAnagrInfoList
    Get
public:
property DedCommandDocAnagrInfoList^ DocumentInfos {
    DedCommandDocAnagrInfoList^ get ();
}
member DocumentInfos : DedCommandDocAnagrInfoList with get

Valore della proprietà

Tipo: DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Proprietà ApriconOpzioni.NeedDocument

Proprietà ApriconOpzioniNeedDocument

Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedDocument { get; }
Public Overrides ReadOnly Property NeedDocument As Boolean
    Get
public:
virtual property bool NeedDocument {
    bool get () override;
}
abstract NeedDocument : bool with get
override NeedDocument : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Proprietà ApriconOpzioni.NeedParameters

Proprietà ApriconOpzioniNeedParameters

Restituisce false se non esiste nemmeno un documento sul quale eseguire il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodi di ApriconOpzioni

Il tipo ApriconOpzioni espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.ClearCommand

Metodo ApriconOpzioniClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.Enabled

Metodo ApriconOpzioniEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.ExecuteCommand

Metodo ApriconOpzioniExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.InvEnabled

Metodo ApriconOpzioniInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.InvSetContext

Metodo ApriconOpzioniInvSetContext

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Metodo ApriconOpzioni.SetContext

Metodo ApriconOpzioniSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ApriconOpzioni
Namespace DedNetInv.Commands


Classe ApriFileAssociati
Apre il file associato se ne esiste soltanto uno altrimenti visualizza la finestra WhereUsed (in modalità appropriata) per far selezionare all'utente i documenti da aprire.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsApriFileAssociati

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriFileAssociati : InvCommandBase
Public Class ApriFileAssociati
    Inherits InvCommandBase
public ref class ApriFileAssociati : public InvCommandBase
type ApriFileAssociati =
    class
        inherit InvCommandBase
    end

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | ShowAttachFiles |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | ShowAttachFiles |
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Proprietà ApriFileAssociati.NeedParameters

Proprietà ApriFileAssociatiNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Proprietà ApriFileAssociati.ShowAttachFiles

Proprietà ApriFileAssociatiShowAttachFiles

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ShowAttachFiles { get; set; }
Public Property ShowAttachFiles As Boolean
    Get
    Set
public:
property bool ShowAttachFiles {
    bool get ();
    void set (bool value);
}
member ShowAttachFiles : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Metodi di ApriFileAssociati

Il tipo ApriFileAssociati espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Metodo ApriFileAssociati.ClearCommand

Metodo ApriFileAssociatiClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Metodo ApriFileAssociati.ExecuteCommand

Metodo ApriFileAssociatiExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Metodo ApriFileAssociati.InvEnabled

Metodo ApriFileAssociatiInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Metodo ApriFileAssociati.InvSetContext

Metodo ApriFileAssociatiInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriFileAssociati
Namespace DedNetInv.Commands


Classe ApriInLettura
Apre la finestra per l'apertura in lettura di un documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsApriInLettura

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInLettura : InvCommandBase
Public Class ApriInLettura
    Inherits InvCommandBase
public ref class ApriInLettura : public InvCommandBase
type ApriInLettura =
    class
        inherit InvCommandBase
    end

Il tipo ApriInLettura espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ApriInLettura

Il tipo ApriInLettura espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetInv.Commands


Metodi di ApriInLettura

Il tipo ApriInLettura espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetInv.Commands


Metodo ApriInLettura.ExecuteCommand

Metodo ApriInLetturaExecuteCommand

Lancia il comando di apertura in lettura.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetInv.Commands


Metodo ApriInLettura.InvEnabled

Metodo ApriInLetturaInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetInv.Commands


Metodo ApriInLettura.InvSetContext

Metodo ApriInLetturaInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInLettura
Namespace DedNetInv.Commands


Classe ApriInModifica
Apre la finestra per l'apertura in modifica di un documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsApriInModifica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInModifica : InvCommandBase
Public Class ApriInModifica
    Inherits InvCommandBase
public ref class ApriInModifica : public InvCommandBase
type ApriInModifica =
    class
        inherit InvCommandBase
    end

Il tipo ApriInModifica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in modifica. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ApriInModifica

Il tipo ApriInModifica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetInv.Commands


Metodi di ApriInModifica

Il tipo ApriInModifica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in modifica. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetInv.Commands


Metodo ApriInModifica.ExecuteCommand

Metodo ApriInModificaExecuteCommand

Lancia il comando di apertura in modifica.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetInv.Commands


Metodo ApriInModifica.InvEnabled

Metodo ApriInModificaInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetInv.Commands


Metodo ApriInModifica.InvSetContext

Metodo ApriInModificaInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInModifica
Namespace DedNetInv.Commands


Classe ApriInNuovaFinestra
Apre la finestra per l'apertura in lettura di un documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsApriInNuovaFinestra

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ApriInNuovaFinestra : InvCommandBase
Public Class ApriInNuovaFinestra
    Inherits InvCommandBase
public ref class ApriInNuovaFinestra : public InvCommandBase
type ApriInNuovaFinestra =
    class
        inherit InvCommandBase
    end

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzeramento campi del comando (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Metodi di ApriInNuovaFinestra

Il tipo ApriInNuovaFinestra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzeramento campi del comando (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di apertura in lettura. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Metodo ApriInNuovaFinestra.ClearCommand

Metodo ApriInNuovaFinestraClearCommand

Azzeramento campi del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Metodo ApriInNuovaFinestra.ExecuteCommand

Metodo ApriInNuovaFinestraExecuteCommand

Lancia il comando di apertura in lettura.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Metodo ApriInNuovaFinestra.InvEnabled

Metodo ApriInNuovaFinestraInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Metodo ApriInNuovaFinestra.InvSetContext

Metodo ApriInNuovaFinestraInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ApriInNuovaFinestra
Namespace DedNetInv.Commands


Classe ArchiviaDoc
Apre la finestra documentale con la possibilità di scegliere una cartella di archiviazione.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsArchiviaDoc

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ArchiviaDoc : InvCommandBase
Public Class ArchiviaDoc
    Inherits InvCommandBase
public ref class ArchiviaDoc : public InvCommandBase
type ArchiviaDoc =
    class
        inherit InvCommandBase
    end

Il tipo ArchiviaDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Indica se si tratti di Salva Parte e non Salva nel DB. Non viene resettata nel ClearCommand().
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ArchiviaDoc

Il tipo ArchiviaDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Indica se si tratti di Salva Parte e non Salva nel DB. Non viene resettata nel ClearCommand().
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Proprietà ArchiviaDoc.IsSavePrt

Proprietà ArchiviaDocIsSavePrt

Indica se si tratti di Salva Parte e non Salva nel DB. Non viene resettata nel ClearCommand().

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Proprietà ArchiviaDoc.NeedParameters

Proprietà ArchiviaDocNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Metodi di ArchiviaDoc

Il tipo ArchiviaDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Metodo ArchiviaDoc.ClearCommand

Metodo ArchiviaDocClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Metodo ArchiviaDoc.ExecuteCommand

Metodo ArchiviaDocExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Metodo ArchiviaDoc.InvEnabled

Metodo ArchiviaDocInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Metodo ArchiviaDoc.InvSetContext

Metodo ArchiviaDocInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ArchiviaDoc
Namespace DedNetInv.Commands


Classe AssociaPresentazione
Permette di associare una messa in tavola esistente al documento correntemente aperto.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAssociaPresentazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociaPresentazione : InvCommandBase
Public Class AssociaPresentazione
    Inherits InvCommandBase
public ref class AssociaPresentazione : public InvCommandBase
type AssociaPresentazione =
    class
        inherit InvCommandBase
    end

Il tipo AssociaPresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | EnforceOverWriteMode | Indica se sovrascrivere la destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PresentationDoc | Presentazione di riferimento.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AssociaPresentazione

Il tipo AssociaPresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | EnforceOverWriteMode | Indica se sovrascrivere la destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PresentationDoc | Presentazione di riferimento.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Proprietà AssociaPresentazione.DocInfo

Proprietà AssociaPresentazioneDocInfo

Restituisce o imposta le informazioni di selezione da ricerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Proprietà AssociaPresentazione.EnforceOverWriteMode

Proprietà AssociaPresentazioneEnforceOverWriteMode

Indica se sovrascrivere la destinazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Proprietà AssociaPresentazione.NeedParameters

Proprietà AssociaPresentazioneNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Proprietà AssociaPresentazione.PresentationDoc

Proprietà AssociaPresentazionePresentationDoc

Presentazione di riferimento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc PresentationDoc { get; set; }
Public Property PresentationDoc As DedDoc
    Get
    Set
public:
property DedDoc^ PresentationDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member PresentationDoc : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodi di AssociaPresentazione

Il tipo AssociaPresentazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.ClearCommand

Metodo AssociaPresentazioneClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.Enabled

Metodo AssociaPresentazioneEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.ExecuteCommand

Metodo AssociaPresentazioneExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.InvEnabled

Metodo AssociaPresentazioneInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.InvSetContext

Metodo AssociaPresentazioneInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Metodo AssociaPresentazione.SetContext

Metodo AssociaPresentazioneSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe AssociaPresentazione
Namespace DedNetInv.Commands


Classe AssociaTavola
Permette di associare una messa in tavola esistente al documento correntemente aperto.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAssociaTavola

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociaTavola : InvCommandBase
Public Class AssociaTavola
    Inherits InvCommandBase
public ref class AssociaTavola : public InvCommandBase
type AssociaTavola =
    class
        inherit InvCommandBase
    end

Il tipo AssociaTavola espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | DrawingDoc | Tavola di riferimento.
Proprietà pubblica | EnforceOverWriteMode | Indica se sovrascrivere la destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AssociaTavola

Il tipo AssociaTavola espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | DrawingDoc | Tavola di riferimento.
Proprietà pubblica | EnforceOverWriteMode | Indica se sovrascrivere la destinazione
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Proprietà AssociaTavola.DocInfo

Proprietà AssociaTavolaDocInfo

Restituisce o imposta le informazioni di selezione da ricerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Proprietà AssociaTavola.DrawingDoc

Proprietà AssociaTavolaDrawingDoc

Tavola di riferimento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DrawingDoc { get; set; }
Public Property DrawingDoc As DedDoc
    Get
    Set
public:
property DedDoc^ DrawingDoc {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member DrawingDoc : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Proprietà AssociaTavola.EnforceOverWriteMode

Proprietà AssociaTavolaEnforceOverWriteMode

Indica se sovrascrivere la destinazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Proprietà AssociaTavola.NeedParameters

Proprietà AssociaTavolaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodi di AssociaTavola

Il tipo AssociaTavola espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.ClearCommand

Metodo AssociaTavolaClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.Enabled

Metodo AssociaTavolaEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.ExecuteCommand

Metodo AssociaTavolaExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.InvEnabled

Metodo AssociaTavolaInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.InvSetContext

Metodo AssociaTavolaInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Metodo AssociaTavola.SetContext

Metodo AssociaTavolaSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe AssociaTavola
Namespace DedNetInv.Commands


Classe AssociatedECO
Apre la finestra degli ECO con caricati gli ECO associati all'anagrafica/commessa del documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAssociatedECO

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociatedECO : InvCommandBase
Public Class AssociatedECO
    Inherits InvCommandBase
public ref class AssociatedECO : public InvCommandBase
type AssociatedECO =
    class
        inherit InvCommandBase
    end

Il tipo AssociatedECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AssociatedECO

Il tipo AssociatedECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Proprietà AssociatedECO.NeedParameters

Proprietà AssociatedECONeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Metodi di AssociatedECO

Il tipo AssociatedECO espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Metodo AssociatedECO.ClearCommand

Metodo AssociatedECOClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Metodo AssociatedECO.ExecuteCommand

Metodo AssociatedECOExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Metodo AssociatedECO.InvEnabled

Metodo AssociatedECOInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Metodo AssociatedECO.InvSetContext

Metodo AssociatedECOInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedECO
Namespace DedNetInv.Commands


Classe AssociatedTranslations
Apre la finestra delle traduzioni con caricate le traduzioni in lingua associate all'anagrafica del documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAssociatedTranslations

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AssociatedTranslations : InvCommandBase
Public Class AssociatedTranslations
    Inherits InvCommandBase
public ref class AssociatedTranslations : public InvCommandBase
type AssociatedTranslations =
    class
        inherit InvCommandBase
    end

Il tipo AssociatedTranslations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di AssociatedTranslations

Il tipo AssociatedTranslations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Proprietà AssociatedTranslations.NeedParameters

Proprietà AssociatedTranslationsNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Metodi di AssociatedTranslations

Il tipo AssociatedTranslations espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Metodo AssociatedTranslations.ClearCommand

Metodo AssociatedTranslationsClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Metodo AssociatedTranslations.ExecuteCommand

Metodo AssociatedTranslationsExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Metodo AssociatedTranslations.InvEnabled

Metodo AssociatedTranslationsInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Metodo AssociatedTranslations.InvSetContext

Metodo AssociatedTranslationsInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe AssociatedTranslations
Namespace DedNetInv.Commands


Classe Attributi
Apre / chiude la finestra per la visualizzazione degli attributi.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAttributi

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Attributi : InvCommandBase
Public Class Attributi
    Inherits InvCommandBase
public ref class Attributi : public InvCommandBase
type Attributi =
    class
        inherit InvCommandBase
    end

Il tipo Attributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form contenente il controllo degli attributi. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dokable Window sia visibile.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AttributeUpdate | Aggiorna gli attributi con una singola chiamata mantenendo il bilanciamento dello stack
Metodo pubblico | BeginAttributeUpdate | Metodo di inizio wrapping funzionalità aggiornamento attributi
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | EndAttributeUpdate | Metodo di inizio wrapping funzionalità aggiornamento attributi
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | ResetStack | Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Attributi

Il tipo Attributi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form contenente il controllo degli attributi. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dokable Window sia visibile.
Torna su
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Proprietà Attributi.Form

Proprietà AttributiForm

Restituisce il Form contenente il controllo degli attributi. Può essere null se il comando non è ancora stato lanciato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AttributeForm Form { get; }
Public ReadOnly Property Form As AttributeForm
    Get
public:
property AttributeForm^ Form {
    AttributeForm^ get ();
}
member Form : AttributeForm with get

Valore della proprietà

Tipo: AttributeForm
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Proprietà Attributi.Visible

Proprietà AttributiVisible

Restituisce se la dokable Window sia visibile.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodi di Attributi

Il tipo Attributi espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AttributeUpdate | Aggiorna gli attributi con una singola chiamata mantenendo il bilanciamento dello stack
Metodo pubblico | BeginAttributeUpdate | Metodo di inizio wrapping funzionalità aggiornamento attributi
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | EndAttributeUpdate | Metodo di inizio wrapping funzionalità aggiornamento attributi
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | ResetStack | Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.AttributeUpdate

Metodo AttributiAttributeUpdate

Aggiorna gli attributi con una singola chiamata mantenendo il bilanciamento dello stack

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AttributeUpdate(
    bool usesLastSelectionInfo = true,
    InvCurSelInfo selInfo = null,
    bool enforceUpdate = true
)
Public Sub AttributeUpdate (
    Optional usesLastSelectionInfo As Boolean = true,
    Optional selInfo As InvCurSelInfo = Nothing,
    Optional enforceUpdate As Boolean = true
)
public:
void AttributeUpdate(
    bool usesLastSelectionInfo = true,
    InvCurSelInfo^ selInfo = nullptr,
    bool enforceUpdate = true
)
member AttributeUpdate :
        ?usesLastSelectionInfo : bool *
        ?selInfo : InvCurSelInfo *
        ?enforceUpdate : bool
(* Defaults:
        let _usesLastSelectionInfo = defaultArg usesLastSelectionInfo true
        let _selInfo = defaultArg selInfo null
        let _enforceUpdate = defaultArg enforceUpdate true
*)
-> unit

Parametri

usesLastSelectionInfo (Optional)
Tipo: SystemBoolean
selInfo (Optional)
Tipo: DedNetInvInvCurSelInfo
enforceUpdate (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.BeginAttributeUpdate

Metodo AttributiBeginAttributeUpdate

Metodo di inizio wrapping funzionalità aggiornamento attributi

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void BeginAttributeUpdate()
Public Sub BeginAttributeUpdate
public:
void BeginAttributeUpdate()
member BeginAttributeUpdate : unit -> unit
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.EndAttributeUpdate

Metodo AttributiEndAttributeUpdate

Metodo di inizio wrapping funzionalità aggiornamento attributi

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void EndAttributeUpdate(
    bool usesLastSelectionInfo = true,
    InvCurSelInfo selInfo = null,
    bool enforceUpdate = true
)
Public Sub EndAttributeUpdate (
    Optional usesLastSelectionInfo As Boolean = true,
    Optional selInfo As InvCurSelInfo = Nothing,
    Optional enforceUpdate As Boolean = true
)
public:
void EndAttributeUpdate(
    bool usesLastSelectionInfo = true,
    InvCurSelInfo^ selInfo = nullptr,
    bool enforceUpdate = true
)
member EndAttributeUpdate :
        ?usesLastSelectionInfo : bool *
        ?selInfo : InvCurSelInfo *
        ?enforceUpdate : bool
(* Defaults:
        let _usesLastSelectionInfo = defaultArg usesLastSelectionInfo true
        let _selInfo = defaultArg selInfo null
        let _enforceUpdate = defaultArg enforceUpdate true
*)
-> unit

Parametri

usesLastSelectionInfo (Optional)
Tipo: SystemBoolean
selInfo (Optional)
Tipo: DedNetInvInvCurSelInfo
enforceUpdate (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.ExecuteCommand

Metodo AttributiExecuteCommand

Lancia il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.InvEnabled

Metodo AttributiInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.InvSetContext

Metodo AttributiInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Metodo Attributi.ResetStack

Metodo AttributiResetStack

Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ResetStack()
Public Sub ResetStack
public:
void ResetStack()
member ResetStack : unit -> unit
Vedi anche

Documentazione

Classe Attributi
Namespace DedNetInv.Commands


Classe CambiaPassword
Comando lanciato per eseguire il cambio di password.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaPassword

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CambiaPassword : InvCommandBase
Public Class CambiaPassword
    Inherits InvCommandBase
public ref class CambiaPassword : public InvCommandBase
type CambiaPassword =
    class
        inherit InvCommandBase
    end

Il tipo CambiaPassword espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CambiaPassword

Il tipo CambiaPassword espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Proprietà CambiaPassword.NeedParameters

Proprietà CambiaPasswordNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Metodi di CambiaPassword

Il tipo CambiaPassword espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Metodo CambiaPassword.ClearCommand

Metodo CambiaPasswordClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Metodo CambiaPassword.ExecuteCommand

Metodo CambiaPasswordExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Metodo CambiaPassword.InvEnabled

Metodo CambiaPasswordInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Metodo CambiaPassword.InvSetContext

Metodo CambiaPasswordInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaPassword
Namespace DedNetInv.Commands


Classe CambiaStato
Comando generico cambio stato specifico dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsLavorazione
DedNetInv.CommandsModificaSuperato
DedNetInv.CommandsRilascia
DedNetInv.CommandsSalvaSuperato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CambiaStato : InvCommandBase
Public Class CambiaStato
    Inherits InvCommandBase
public ref class CambiaStato : public InvCommandBase
type CambiaStato =
    class
        inherit InvCommandBase
    end

Il tipo CambiaStato espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CambiaStato | Costruttore comando
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore CambiaStato

Costruttore comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CambiaStato(
    DedNetApplication app,
    string internalName,
    string displayName,
    DedState targetState,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    targetState As DedState,
    multiple As Boolean
)
public:
CambiaStato(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    DedState^ targetState,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        targetState : DedState *
        multiple : bool -> CambiaStato

Parametri

app
Tipo: DedNetApplication
internalName
Tipo: SystemString
displayName
Tipo: SystemString
targetState
Tipo: DedState
multiple
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Proprietà di CambiaStato

Il tipo CambiaStato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Proprietà CambiaStato.LazyMode

Proprietà CambiaStatoLazyMode

Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Proprietà CambiaStato.Multiplo

Proprietà CambiaStatoMultiplo

Restituisce e imposta se il comando deve lavorare in modalità multipla

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Multiplo { get; set; }
Public Property Multiplo As Boolean
    Get
    Set
public:
property bool Multiplo {
    bool get ();
    void set (bool value);
}
member Multiplo : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Metodi di CambiaStato

Il tipo CambiaStato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Metodo CambiaStato.ClearCommand

Metodo CambiaStatoClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Metodo CambiaStato.ExecuteCommand

Metodo CambiaStatoExecuteCommand

Esecuzione del comando di cambio stato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Metodo CambiaStato.InvEnabled

Metodo CambiaStatoInvEnabled

Abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Metodo CambiaStato.InvSetContext

Metodo CambiaStatoInvSetContext

Settaggio del contesto

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaStato
Namespace DedNetInv.Commands


Classe CambiaStato.PublishingDocumentDescriptor

Classe CambiaStatoPublishingDocumentDescriptor
Descrittore documento in pubblicazione
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsCambiaStatoPublishingDocumentDescriptor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishingDocumentDescriptor
Public Class PublishingDocumentDescriptor
public ref class PublishingDocumentDescriptor
type PublishingDocumentDescriptor =  class end

Il tipo CambiaStatoPublishingDocumentDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | CambiaStatoPublishingDocumentDescriptor |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName |
Proprietà pubblica | PublishDocNotOverwritten |
Proprietà pubblica | SourceDocument |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore CambiaStato.PublishingDocumentDescriptor

Costruttore CambiaStatoPublishingDocumentDescriptor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PublishingDocumentDescriptor(
    DedDoc src,
    string outfn,
    bool publishDocNotOverwritten = false
)
Public Sub New (
    src As DedDoc,
    outfn As String,
    Optional publishDocNotOverwritten As Boolean = false
)
public:
PublishingDocumentDescriptor(
    DedDoc^ src,
    String^ outfn,
    bool publishDocNotOverwritten = false
)
new :
        src : DedDoc *
        outfn : string *
        ?publishDocNotOverwritten : bool
(* Defaults:
        let _publishDocNotOverwritten = defaultArg publishDocNotOverwritten false
*)
-> PublishingDocumentDescriptor

Parametri

src
Tipo: DedDoc
outfn
Tipo: SystemString
publishDocNotOverwritten (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetInv.Commands


Proprietà di PublishingDocumentDescriptor

Il tipo CambiaStatoPublishingDocumentDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FullFileName |
Proprietà pubblica | PublishDocNotOverwritten |
Proprietà pubblica | SourceDocument |
Torna su
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetInv.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.FullFileName

Proprietà CambiaStatoPublishingDocumentDescriptorFullFileName

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetInv.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.PublishDocNotOverwritten

Proprietà CambiaStatoPublishingDocumentDescriptorPublishDocNotOverwritten

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PublishDocNotOverwritten { get; set; }
Public Property PublishDocNotOverwritten As Boolean
    Get
    Set
public:
property bool PublishDocNotOverwritten {
    bool get ();
    void set (bool value);
}
member PublishDocNotOverwritten : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetInv.Commands


Proprietà CambiaStato.PublishingDocumentDescriptor.SourceDocument

Proprietà CambiaStatoPublishingDocumentDescriptorSourceDocument

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc SourceDocument { get; set; }
Public Property SourceDocument As DedDoc
    Get
    Set
public:
property DedDoc^ SourceDocument {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member SourceDocument : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe CambiaStatoPublishingDocumentDescriptor
Namespace DedNetInv.Commands


Classe CaricaBody
Comando che effettua il carica body del file selezionato
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCaricaBody

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CaricaBody : InvCommandBase
Public Class CaricaBody
    Inherits InvCommandBase
public ref class CaricaBody : public InvCommandBase
type CaricaBody =
    class
        inherit InvCommandBase
    end

Il tipo CaricaBody espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CaricaBody

Il tipo CaricaBody espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Proprietà CaricaBody.DocInfo

Proprietà CaricaBodyDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Proprietà CaricaBody.DocInfos

Proprietà CaricaBodyDocInfos

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommandDocAnagrInfo> DocInfos { get; set; }
Public Property DocInfos As List(Of DedCommandDocAnagrInfo)
    Get
    Set
public:
property List<DedCommandDocAnagrInfo^>^ DocInfos {
    List<DedCommandDocAnagrInfo^>^ get ();
    void set (List<DedCommandDocAnagrInfo^>^ value);
}
member DocInfos : List<DedCommandDocAnagrInfo> with get, set

Valore della proprietà

Tipo: List DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Proprietà CaricaBody.NeedParameters

Proprietà CaricaBodyNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodi di CaricaBody

Il tipo CaricaBody espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.ClearCommand

Metodo CaricaBodyClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.Enabled

Metodo CaricaBodyEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.ExecuteCommand

Metodo CaricaBodyExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.InvEnabled

Metodo CaricaBodyInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.InvSetContext

Metodo CaricaBodyInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Metodo CaricaBody.SetContext

Metodo CaricaBodySetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CaricaBody
Namespace DedNetInv.Commands


Classe CaricaNewRep
Comando che effettua il carica parte di un DWG, sotto una data parte.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCaricaNewRep

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CaricaNewRep : InvCommandBase
Public Class CaricaNewRep
    Inherits InvCommandBase
public ref class CaricaNewRep : public InvCommandBase
type CaricaNewRep =
    class
        inherit InvCommandBase
    end

Il tipo CaricaNewRep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CaricaNewRep

Il tipo CaricaNewRep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Proprietà CaricaNewRep.Asynch

Proprietà CaricaNewRepAsynch

Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Proprietà CaricaNewRep.DocInfo

Proprietà CaricaNewRepDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Proprietà CaricaNewRep.NeedParameters

Proprietà CaricaNewRepNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodi di CaricaNewRep

Il tipo CaricaNewRep espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.ClearCommand

Metodo CaricaNewRepClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.Enabled

Metodo CaricaNewRepEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.ExecuteCommand

Metodo CaricaNewRepExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.InvEnabled

Metodo CaricaNewRepInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.InvSetContext

Metodo CaricaNewRepInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Metodo CaricaNewRep.SetContext

Metodo CaricaNewRepSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CaricaNewRep
Namespace DedNetInv.Commands


Classe CaricaParte
Comando che effettua il carica parte di un DWG, sotto una data parte.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCaricaParte

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CaricaParte : InvCommandBase
Public Class CaricaParte
    Inherits InvCommandBase
public ref class CaricaParte : public InvCommandBase
type CaricaParte =
    class
        inherit InvCommandBase
    end

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | ComponentDerived | Imposta/ Restituisce se caricare la parte come componente derivato.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | WithOptions | Restituisce o imposta se il carica parte debba mostrare la gestione delle opzioni di caricamento
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | ComponentDerived | Imposta/ Restituisce se caricare la parte come componente derivato.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | WithOptions | Restituisce o imposta se il carica parte debba mostrare la gestione delle opzioni di caricamento
Torna su
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.Asynch

Proprietà CaricaParteAsynch

Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono. Di default è true.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.ComponentDerived

Proprietà CaricaParteComponentDerived

Imposta/ Restituisce se caricare la parte come componente derivato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ComponentDerived { get; set; }
Public Property ComponentDerived As Boolean
    Get
    Set
public:
property bool ComponentDerived {
    bool get ();
    void set (bool value);
}
member ComponentDerived : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.DocInfo

Proprietà CaricaParteDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.DocInfos

Proprietà CaricaParteDocInfos

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommandDocAnagrInfo> DocInfos { get; set; }
Public Property DocInfos As List(Of DedCommandDocAnagrInfo)
    Get
    Set
public:
property List<DedCommandDocAnagrInfo^>^ DocInfos {
    List<DedCommandDocAnagrInfo^>^ get ();
    void set (List<DedCommandDocAnagrInfo^>^ value);
}
member DocInfos : List<DedCommandDocAnagrInfo> with get, set

Valore della proprietà

Tipo: List DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.NeedParameters

Proprietà CaricaParteNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Necessita di almeno un documento di modello.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Proprietà CaricaParte.WithOptions

Proprietà CaricaParteWithOptions

Restituisce o imposta se il carica parte debba mostrare la gestione delle opzioni di caricamento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool WithOptions { get; set; }
Public Property WithOptions As Boolean
    Get
    Set
public:
property bool WithOptions {
    bool get ();
    void set (bool value);
}
member WithOptions : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodi di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.ClearCommand

Metodo CaricaParteClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.Enabled

Metodo CaricaParteEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.ExecuteCommand

Metodo CaricaParteExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.InvEnabled

Metodo CaricaParteInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.InvSetContext

Metodo CaricaParteInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Metodo CaricaParte.SetContext

Metodo CaricaParteSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CaricaParte
Namespace DedNetInv.Commands


Classe CheckIn
Comando di checkin dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCheckIn

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckIn : InvCommandBase
Public Class CheckIn
    Inherits InvCommandBase
public ref class CheckIn : public InvCommandBase
type CheckIn =
    class
        inherit InvCommandBase
    end

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | AssociatedFiles | Indica se, in caso di modalità struttura, il documento deve agire anche sui file associati
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CheckIn

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | AssociatedFiles | Indica se, in caso di modalità struttura, il documento deve agire anche sui file associati
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Proprietà CheckIn.AssociatedFiles

Proprietà CheckInAssociatedFiles

Indica se, in caso di modalità struttura, il documento deve agire anche sui file associati

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssociatedFiles { get; set; }
Public Property AssociatedFiles As Boolean
    Get
    Set
public:
property bool AssociatedFiles {
    bool get ();
    void set (bool value);
}
member AssociatedFiles : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Proprietà CheckIn.NeedParameters

Proprietà CheckInNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Metodi di CheckIn

Il tipo CheckIn espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Metodo CheckIn.ClearCommand

Metodo CheckInClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Metodo CheckIn.ExecuteCommand

Metodo CheckInExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Metodo CheckIn.InvEnabled

Metodo CheckInInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Metodo CheckIn.InvSetContext

Metodo CheckInInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn
Namespace DedNetInv.Commands


Classe CheckOut
Comando di checkout dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCheckOut

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckOut : InvCommandBase
Public Class CheckOut
    Inherits InvCommandBase
public ref class CheckOut : public InvCommandBase
type CheckOut =
    class
        inherit InvCommandBase
    end

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OnlyDirty | Inidica se operare solo sui file dirty
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CheckOut

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreDataLockState | Consente di ignorare il blocco legato allo stato dell'anagrafica
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OnlyDirty | Inidica se operare solo sui file dirty
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Proprietà CheckOut.IgnoreDataLockState

Proprietà CheckOutIgnoreDataLockState

Consente di ignorare il blocco legato allo stato dell'anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreDataLockState { get; set; }
Public Property IgnoreDataLockState As Boolean
    Get
    Set
public:
property bool IgnoreDataLockState {
    bool get ();
    void set (bool value);
}
member IgnoreDataLockState : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Proprietà CheckOut.NeedParameters

Proprietà CheckOutNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Proprietà CheckOut.OnlyDirty

Proprietà CheckOutOnlyDirty

Inidica se operare solo sui file dirty

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OnlyDirty { get; set; }
Public Property OnlyDirty As Boolean
    Get
    Set
public:
property bool OnlyDirty {
    bool get ();
    void set (bool value);
}
member OnlyDirty : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Metodi di CheckOut

Il tipo CheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Metodo CheckOut.ClearCommand

Metodo CheckOutClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Metodo CheckOut.ExecuteCommand

Metodo CheckOutExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Metodo CheckOut.InvEnabled

Metodo CheckOutInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Metodo CheckOut.InvSetContext

Metodo CheckOutInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut
Namespace DedNetInv.Commands


Classe CompileFactoryTableAttrs
Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e tramite questi ricompila la sua tabella interna con i loro attributi.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCompileFactoryTableAttrs

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CompileFactoryTableAttrs : InvCommandBase
Public Class CompileFactoryTableAttrs
    Inherits InvCommandBase
public ref class CompileFactoryTableAttrs : public InvCommandBase
type CompileFactoryTableAttrs =
    class
        inherit InvCommandBase
    end

Il tipo CompileFactoryTableAttrs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CompileFactoryTableAttrs

Il tipo CompileFactoryTableAttrs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CompileFactoryTableAttrs
Namespace DedNetInv.Commands


Metodi di CompileFactoryTableAttrs

Il tipo CompileFactoryTableAttrs espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CompileFactoryTableAttrs
Namespace DedNetInv.Commands


Metodo CompileFactoryTableAttrs.ExecuteCommand

Metodo CompileFactoryTableAttrsExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CompileFactoryTableAttrs
Namespace DedNetInv.Commands


Metodo CompileFactoryTableAttrs.InvEnabled

Metodo CompileFactoryTableAttrsInvEnabled

Abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CompileFactoryTableAttrs
Namespace DedNetInv.Commands


Metodo CompileFactoryTableAttrs.InvSetContext

Metodo CompileFactoryTableAttrsInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CompileFactoryTableAttrs
Namespace DedNetInv.Commands


Classe ConfiguraDistinta
Apre il configuratore delle distinte.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsConfiguraDistinta

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ConfiguraDistinta : InvCommandBase
Public Class ConfiguraDistinta
    Inherits InvCommandBase
public ref class ConfiguraDistinta : public InvCommandBase
type ConfiguraDistinta =
    class
        inherit InvCommandBase
    end

Il tipo ConfiguraDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ConfiguraDistinta

Il tipo ConfiguraDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Proprietà ConfiguraDistinta.NeedParameters

Proprietà ConfiguraDistintaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Metodi di ConfiguraDistinta

Il tipo ConfiguraDistinta espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Metodo ConfiguraDistinta.ClearCommand

Metodo ConfiguraDistintaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Metodo ConfiguraDistinta.ExecuteCommand

Metodo ConfiguraDistintaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Metodo ConfiguraDistinta.InvEnabled

Metodo ConfiguraDistintaInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Metodo ConfiguraDistinta.InvSetContext

Metodo ConfiguraDistintaInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ConfiguraDistinta
Namespace DedNetInv.Commands


Classe ControlloCoerenzaRiferimenti
Permette di associare una messa in tavola esistente al documento correntemente aperto.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsControlloCoerenzaRiferimenti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ControlloCoerenzaRiferimenti : InvCommandBase
Public Class ControlloCoerenzaRiferimenti
    Inherits InvCommandBase
public ref class ControlloCoerenzaRiferimenti : public InvCommandBase
type ControlloCoerenzaRiferimenti =
    class
        inherit InvCommandBase
    end

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ControlloCoerenzaRiferimenti

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Proprietà ControlloCoerenzaRiferimenti.DocInfo

Proprietà ControlloCoerenzaRiferimentiDocInfo

Restituisce o imposta le informazioni di selezione da ricerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Proprietà ControlloCoerenzaRiferimenti.NeedParameters

Proprietà ControlloCoerenzaRiferimentiNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodi di ControlloCoerenzaRiferimenti

Il tipo ControlloCoerenzaRiferimenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.ClearCommand

Metodo ControlloCoerenzaRiferimentiClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.Enabled

Metodo ControlloCoerenzaRiferimentiEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.ExecuteCommand

Metodo ControlloCoerenzaRiferimentiExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.InvEnabled

Metodo ControlloCoerenzaRiferimentiInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.InvSetContext

Metodo ControlloCoerenzaRiferimentiInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Metodo ControlloCoerenzaRiferimenti.SetContext

Metodo ControlloCoerenzaRiferimentiSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ControlloCoerenzaRiferimenti
Namespace DedNetInv.Commands


Classe CreaComponenteAnagrafica
Apre la tabella delle revisioni.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreaComponenteAnagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaComponenteAnagrafica : InvCommandBase
Public Class CreaComponenteAnagrafica
    Inherits InvCommandBase
public ref class CreaComponenteAnagrafica : public InvCommandBase
type CreaComponenteAnagrafica =
    class
        inherit InvCommandBase
    end

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreaComponenteAnagrafica

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Proprietà CreaComponenteAnagrafica.NeedParameters

Proprietà CreaComponenteAnagraficaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Metodi di CreaComponenteAnagrafica

Il tipo CreaComponenteAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Metodo CreaComponenteAnagrafica.ClearCommand

Metodo CreaComponenteAnagraficaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Metodo CreaComponenteAnagrafica.ExecuteCommand

Metodo CreaComponenteAnagraficaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Metodo CreaComponenteAnagrafica.InvEnabled

Metodo CreaComponenteAnagraficaInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Metodo CreaComponenteAnagrafica.InvSetContext

Metodo CreaComponenteAnagraficaInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaComponenteAnagrafica
Namespace DedNetInv.Commands


Classe CreaInvAssociaConf
Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreaInvAssociaConf

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaInvAssociaConf : InvCommandBase
Public Class CreaInvAssociaConf
    Inherits InvCommandBase
public ref class CreaInvAssociaConf : public InvCommandBase
type CreaInvAssociaConf =
    class
        inherit InvCommandBase
    end

Il tipo CreaInvAssociaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | InvOcc | Restitusice l'occorenzza correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreaInvAssociaConf

Il tipo CreaInvAssociaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | InvOcc | Restitusice l'occorenzza correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.Data

Proprietà CreaInvAssociaConfData

Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.InvDoc

Proprietà CreaInvAssociaConfInvDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; }
Public ReadOnly Property InvDoc As Document
    Get
public:
property Document^ InvDoc {
    Document^ get ();
}
member InvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.InvOcc

Proprietà CreaInvAssociaConfInvOcc

Restitusice l'occorenzza correntemente attivo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence InvOcc { get; }
Public ReadOnly Property InvOcc As ComponentOccurrence
    Get
public:
property ComponentOccurrence^ InvOcc {
    ComponentOccurrence^ get ();
}
member InvOcc : ComponentOccurrence with get

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.IsSavePrt

Proprietà CreaInvAssociaConfIsSavePrt

Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.NeedParameters

Proprietà CreaInvAssociaConfNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.PrimaryContext

Proprietà CreaInvAssociaConfPrimaryContext

Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.TopDocument

Proprietà CreaInvAssociaConfTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaConf.UseDocValues

Proprietà CreaInvAssociaConfUseDocValues

Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Metodi di CreaInvAssociaConf

Il tipo CreaInvAssociaConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Metodo CreaInvAssociaConf.ClearCommand

Metodo CreaInvAssociaConfClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Metodo CreaInvAssociaConf.ExecuteCommand

Metodo CreaInvAssociaConfExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Metodo CreaInvAssociaConf.InvEnabled

Metodo CreaInvAssociaConfInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Metodo CreaInvAssociaConf.InvSetContext

Metodo CreaInvAssociaConfInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaConf
Namespace DedNetInv.Commands


Classe CreaInvAssociaDocument
Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreaInvAssociaDocument

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaInvAssociaDocument : InvCommandBase
Public Class CreaInvAssociaDocument
    Inherits InvCommandBase
public ref class CreaInvAssociaDocument : public InvCommandBase
type CreaInvAssociaDocument =
    class
        inherit InvCommandBase
    end

Il tipo CreaInvAssociaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | InvOcc | Restitusice l'occorenzza correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreaInvAssociaDocument

Il tipo CreaInvAssociaDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | InvOcc | Restitusice l'occorenzza correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.AlsoSubParts

Proprietà CreaInvAssociaDocumentAlsoSubParts

Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.Data

Proprietà CreaInvAssociaDocumentData

Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.EnforceOverWriteMode

Proprietà CreaInvAssociaDocumentEnforceOverWriteMode

Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.InvDoc

Proprietà CreaInvAssociaDocumentInvDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; }
Public ReadOnly Property InvDoc As Document
    Get
public:
property Document^ InvDoc {
    Document^ get ();
}
member InvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.InvOcc

Proprietà CreaInvAssociaDocumentInvOcc

Restitusice l'occorenzza correntemente attivo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence InvOcc { get; }
Public ReadOnly Property InvOcc As ComponentOccurrence
    Get
public:
property ComponentOccurrence^ InvOcc {
    ComponentOccurrence^ get ();
}
member InvOcc : ComponentOccurrence with get

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.IsSavePrt

Proprietà CreaInvAssociaDocumentIsSavePrt

Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.LinkNotCopy

Proprietà CreaInvAssociaDocumentLinkNotCopy

Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.NeedParameters

Proprietà CreaInvAssociaDocumentNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.PrimaryContext

Proprietà CreaInvAssociaDocumentPrimaryContext

Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.SparePartsContext

Proprietà CreaInvAssociaDocumentSparePartsContext

Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

Tipo: DedDocContextEnum
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.TopDocument

Proprietà CreaInvAssociaDocumentTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Proprietà CreaInvAssociaDocument.UseDocValues

Proprietà CreaInvAssociaDocumentUseDocValues

Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Metodi di CreaInvAssociaDocument

Il tipo CreaInvAssociaDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Metodo CreaInvAssociaDocument.ClearCommand

Metodo CreaInvAssociaDocumentClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Metodo CreaInvAssociaDocument.ExecuteCommand

Metodo CreaInvAssociaDocumentExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Metodo CreaInvAssociaDocument.InvEnabled

Metodo CreaInvAssociaDocumentInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Metodo CreaInvAssociaDocument.InvSetContext

Metodo CreaInvAssociaDocumentInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvAssociaDocument
Namespace DedNetInv.Commands


Classe CreaInvDisconnectConf
Scollega il documento corrente dall'anagrafica alla quale è collegato come ms secondario. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreaInvDisconnectConf

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaInvDisconnectConf : InvCommandBase
Public Class CreaInvDisconnectConf
    Inherits InvCommandBase
public ref class CreaInvDisconnectConf : public InvCommandBase
type CreaInvDisconnectConf =
    class
        inherit InvCommandBase
    end

Il tipo CreaInvDisconnectConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data |
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreaInvDisconnectConf

Il tipo CreaInvDisconnectConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data |
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Proprietà CreaInvDisconnectConf.Data

Proprietà CreaInvDisconnectConfData

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Proprietà CreaInvDisconnectConf.InvDoc

Proprietà CreaInvDisconnectConfInvDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; }
Public ReadOnly Property InvDoc As Document
    Get
public:
property Document^ InvDoc {
    Document^ get ();
}
member InvDoc : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Proprietà CreaInvDisconnectConf.NeedParameters

Proprietà CreaInvDisconnectConfNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Proprietà CreaInvDisconnectConf.TopDocument

Proprietà CreaInvDisconnectConfTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Metodi di CreaInvDisconnectConf

Il tipo CreaInvDisconnectConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Metodo CreaInvDisconnectConf.ClearCommand

Metodo CreaInvDisconnectConfClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Metodo CreaInvDisconnectConf.ExecuteCommand

Metodo CreaInvDisconnectConfExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Metodo CreaInvDisconnectConf.InvEnabled

Metodo CreaInvDisconnectConfInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Metodo CreaInvDisconnectConf.InvSetContext

Metodo CreaInvDisconnectConfInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaInvDisconnectConf
Namespace DedNetInv.Commands


Classe CreaNuovaRappresentazione
Crea Nuova Rappresentazione del documento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreaNuovaRappresentazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreaNuovaRappresentazione : InvCommandBase
Public Class CreaNuovaRappresentazione
    Inherits InvCommandBase
public ref class CreaNuovaRappresentazione : public InvCommandBase
type CreaNuovaRappresentazione =
    class
        inherit InvCommandBase
    end

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DsInfo | Oggetto docstructinfo di struttura per il completamento del comando
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InterestDoc | Documento di interesse
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsCreateRapOfPrt | Oggetto docstructinfo di struttura per il completamento del comando
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewRapDocStructInfoList | Lista dei documenti risultanti
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | RefData | Anagrafica di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | SkipCheckInNewRap | Determina se saltare il checkin sui documenti della rappresentazione
Proprietà pubblica | SkipDocumentContextCheck | Determina se skippare il controllo di esistenza di almeno un file modello con la stessa estensione
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreaNuovaRappresentazione

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DsInfo | Oggetto docstructinfo di struttura per il completamento del comando
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InterestDoc | Documento di interesse
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsCreateRapOfPrt | Oggetto docstructinfo di struttura per il completamento del comando
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewRapDocStructInfoList | Lista dei documenti risultanti
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | RefData | Anagrafica di riferimento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | SkipCheckInNewRap | Determina se saltare il checkin sui documenti della rappresentazione
Proprietà pubblica | SkipDocumentContextCheck | Determina se skippare il controllo di esistenza di almeno un file modello con la stessa estensione
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.DsInfo

Proprietà CreaNuovaRappresentazioneDsInfo

Oggetto docstructinfo di struttura per il completamento del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo DsInfo { get; set; }
Public Property DsInfo As InvDocStructInfo
    Get
    Set
public:
property InvDocStructInfo^ DsInfo {
    InvDocStructInfo^ get ();
    void set (InvDocStructInfo^ value);
}
member DsInfo : InvDocStructInfo with get, set

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.InterestDoc

Proprietà CreaNuovaRappresentazioneInterestDoc

Documento di interesse

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InterestDoc { get; set; }
Public Property InterestDoc As Document
    Get
    Set
public:
property Document^ InterestDoc {
    Document^ get ();
    void set (Document^ value);
}
member InterestDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.IsCreateRapOfPrt

Proprietà CreaNuovaRappresentazioneIsCreateRapOfPrt

Oggetto docstructinfo di struttura per il completamento del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCreateRapOfPrt { get; set; }
Public Property IsCreateRapOfPrt As Boolean
    Get
    Set
public:
property bool IsCreateRapOfPrt {
    bool get ();
    void set (bool value);
}
member IsCreateRapOfPrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.NewRapDocStructInfoList

Proprietà CreaNuovaRappresentazioneNewRapDocStructInfoList

Lista dei documenti risultanti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfoList NewRapDocStructInfoList { get; }
Public ReadOnly Property NewRapDocStructInfoList As DocStructInfoList
    Get
public:
property DocStructInfoList^ NewRapDocStructInfoList {
    DocStructInfoList^ get ();
}
member NewRapDocStructInfoList : DocStructInfoList with get

Valore della proprietà

Tipo: DocStructInfoList
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.RefData

Proprietà CreaNuovaRappresentazioneRefData

Anagrafica di riferimento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData RefData { get; set; }
Public Property RefData As DedData
    Get
    Set
public:
property DedData^ RefData {
    DedData^ get ();
    void set (DedData^ value);
}
member RefData : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.SkipCheckInNewRap

Proprietà CreaNuovaRappresentazioneSkipCheckInNewRap

Determina se saltare il checkin sui documenti della rappresentazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipCheckInNewRap { get; set; }
Public Property SkipCheckInNewRap As Boolean
    Get
    Set
public:
property bool SkipCheckInNewRap {
    bool get ();
    void set (bool value);
}
member SkipCheckInNewRap : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Proprietà CreaNuovaRappresentazione.SkipDocumentContextCheck

Proprietà CreaNuovaRappresentazioneSkipDocumentContextCheck

Determina se skippare il controllo di esistenza di almeno un file modello con la stessa estensione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipDocumentContextCheck { get; set; }
Public Property SkipDocumentContextCheck As Boolean
    Get
    Set
public:
property bool SkipDocumentContextCheck {
    bool get ();
    void set (bool value);
}
member SkipDocumentContextCheck : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Metodi di CreaNuovaRappresentazione

Il tipo CreaNuovaRappresentazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Metodo CreaNuovaRappresentazione.ClearCommand

Metodo CreaNuovaRappresentazioneClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Metodo CreaNuovaRappresentazione.ExecuteCommand

Metodo CreaNuovaRappresentazioneExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Metodo CreaNuovaRappresentazione.InvEnabled

Metodo CreaNuovaRappresentazioneInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Metodo CreaNuovaRappresentazione.InvSetContext

Metodo CreaNuovaRappresentazioneInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreaNuovaRappresentazione
Namespace DedNetInv.Commands


Classe CreateSparePartsDrawing
Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCreateSparePartsDrawing

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreateSparePartsDrawing : InvCommandBase
Public Class CreateSparePartsDrawing
    Inherits InvCommandBase
public ref class CreateSparePartsDrawing : public InvCommandBase
type CreateSparePartsDrawing =
    class
        inherit InvCommandBase
    end

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Document | Documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Document | Documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Proprietà CreateSparePartsDrawing.Document

Proprietà CreateSparePartsDrawingDocument

Documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Proprietà CreateSparePartsDrawing.NeedParameters

Proprietà CreateSparePartsDrawingNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Metodi di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Metodo CreateSparePartsDrawing.ClearCommand

Metodo CreateSparePartsDrawingClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Metodo CreateSparePartsDrawing.ExecuteCommand

Metodo CreateSparePartsDrawingExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Metodo CreateSparePartsDrawing.InvEnabled

Metodo CreateSparePartsDrawingInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Metodo CreateSparePartsDrawing.InvSetContext

Metodo CreateSparePartsDrawingInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing
Namespace DedNetInv.Commands


Classe DedInvCommandContext
Classe per il contesto di esecuzione comando all'interno dell'addin. Contiene le informazioni necessarie per l'esecuzione di un comando .
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsDedInvCommandContext

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvCommandContext
Public Class DedInvCommandContext
public ref class DedInvCommandContext
type DedInvCommandContext =  class end

Il tipo DedInvCommandContext espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvCommandContext | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce o imposta l'oggetto context associato al button dell'interfaccia
Proprietà pubblica | ContextSource | Indica se il comando è stato lanciato dall'albero delle dipendenze
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica
Proprietà pubblica | InventorCurrentSelection | Restituisce l'oggetto generale di gestione della selezione.
Proprietà pubblica | InventorDocumentList | Restituisce la lista dei documenti di Inventor sui quali eseguire il comando
Proprietà pubblica | ModelState | Restituisce o imposta il Modelstate
Proprietà pubblica | OtherDocumentList | Restituisce la lista dei documenti che non appartengono direttamente ad Inventor (riferimenti extra CAD) sui quali eseguire il comando
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore DedInvCommandContext

Costruttore unico.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvCommandContext()
Public Sub New
public:
DedInvCommandContext()
new : unit -> DedInvCommandContext
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà di DedInvCommandContext

Il tipo DedInvCommandContext espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Restituisce o imposta l'oggetto context associato al button dell'interfaccia
Proprietà pubblica | ContextSource | Indica se il comando è stato lanciato dall'albero delle dipendenze
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica
Proprietà pubblica | InventorCurrentSelection | Restituisce l'oggetto generale di gestione della selezione.
Proprietà pubblica | InventorDocumentList | Restituisce la lista dei documenti di Inventor sui quali eseguire il comando
Proprietà pubblica | ModelState | Restituisce o imposta il Modelstate
Proprietà pubblica | OtherDocumentList | Restituisce la lista dei documenti che non appartengono direttamente ad Inventor (riferimenti extra CAD) sui quali eseguire il comando
Torna su
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.Context

Proprietà DedInvCommandContextContext

Restituisce o imposta l'oggetto context associato al button dell'interfaccia

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public NameValueMap Context { get; set; }
Public Property Context As NameValueMap
    Get
    Set
public:
property NameValueMap^ Context {
    NameValueMap^ get ();
    void set (NameValueMap^ value);
}
member Context : NameValueMap with get, set

Valore della proprietà

Tipo: NameValueMap
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.ContextSource

Proprietà DedInvCommandContextContextSource

Indica se il comando è stato lanciato dall'albero delle dipendenze

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvCommandContextSourceEnum ContextSource { get; set; }
Public Property ContextSource As DedInvCommandContextSourceEnum
    Get
    Set
public:
property DedInvCommandContextSourceEnum ContextSource {
    DedInvCommandContextSourceEnum get ();
    void set (DedInvCommandContextSourceEnum value);
}
member ContextSource : DedInvCommandContextSourceEnum with get, set

Valore della proprietà

Tipo: DedInvCommandContextSourceEnum
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.Data

Proprietà DedInvCommandContextData

Restituisce o imposta l'anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.InventorCurrentSelection

Proprietà DedInvCommandContextInventorCurrentSelection

Restituisce l'oggetto generale di gestione della selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvCurSelInfo InventorCurrentSelection { get; }
Public ReadOnly Property InventorCurrentSelection As InvCurSelInfo
    Get
public:
property InvCurSelInfo^ InventorCurrentSelection {
    InvCurSelInfo^ get ();
}
member InventorCurrentSelection : InvCurSelInfo with get

Valore della proprietà

Tipo: InvCurSelInfo
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.InventorDocumentList

Proprietà DedInvCommandContextInventorDocumentList

Restituisce la lista dei documenti di Inventor sui quali eseguire il comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<Document> InventorDocumentList { get; }
Public ReadOnly Property InventorDocumentList As List(Of Document)
    Get
public:
property List<Document^>^ InventorDocumentList {
    List<Document^>^ get ();
}
member InventorDocumentList : List<Document> with get

Valore della proprietà

Tipo: List Document
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.ModelState

Proprietà DedInvCommandContextModelState

Restituisce o imposta il Modelstate

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModelState ModelState { get; set; }
Public Property ModelState As ModelState
    Get
    Set
public:
property ModelState^ ModelState {
    ModelState^ get ();
    void set (ModelState^ value);
}
member ModelState : ModelState with get, set

Valore della proprietà

Tipo: ModelState
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Proprietà DedInvCommandContext.OtherDocumentList

Proprietà DedInvCommandContextOtherDocumentList

Restituisce la lista dei documenti che non appartengono direttamente ad Inventor (riferimenti extra CAD) sui quali eseguire il comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> OtherDocumentList { get; }
Public ReadOnly Property OtherDocumentList As List(Of String)
    Get
public:
property List<String^>^ OtherDocumentList {
    List<String^>^ get ();
}
member OtherDocumentList : List<string> with get

Valore della proprietà

Tipo: List String
Vedi anche

Documentazione

Classe DedInvCommandContext
Namespace DedNetInv.Commands


Enumerazione DedInvCommandContextSourceEnum
Enumerazione delle possibili sorgneti di contesto comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum DedInvCommandContextSourceEnum
Public Enumeration DedInvCommandContextSourceEnum
public enum class DedInvCommandContextSourceEnum
type DedInvCommandContextSourceEnum
Membri
Nome | Valore | Descrizione
NotAvailable | 0 | Non disponibile
Menu | 1 | Menu princiaple
DocDepTree | 2 | Albero delle dipendenze
DocAssist | 3 | Doc Assistant
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Classe DistintaComponenti
Apre la distinta componenti.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDistintaComponenti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaComponenti : InvCommandBase
Public Class DistintaComponenti
    Inherits InvCommandBase
public ref class DistintaComponenti : public InvCommandBase
type DistintaComponenti =
    class
        inherit InvCommandBase
    end

Il tipo DistintaComponenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Show | Visualizza il form di distinta overridato per DedNetInv+
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DistintaComponenti

Il tipo DistintaComponenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Proprietà DistintaComponenti.NeedParameters

Proprietà DistintaComponentiNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodi di DistintaComponenti

Il tipo DistintaComponenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Show | Visualizza il form di distinta overridato per DedNetInv+
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodo DistintaComponenti.ClearCommand

Metodo DistintaComponentiClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodo DistintaComponenti.ExecuteCommand

Metodo DistintaComponentiExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodo DistintaComponenti.InvEnabled

Metodo DistintaComponentiInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodo DistintaComponenti.InvSetContext

Metodo DistintaComponentiInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Metodo DistintaComponenti.Show

Metodo DistintaComponentiShow

Visualizza il form di distinta overridato per DedNetInv+

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Show(
    string source
)
Public Sub Show (
    source As String
)
public:
void Show(
    String^ source
)
member Show :
        source : string -> unit

Parametri

source
Tipo: SystemString
Vedi anche

Documentazione

Classe DistintaComponenti
Namespace DedNetInv.Commands


Classe DistintaEsplosa
Apre la finestra della distinta esplosa per il codice selezionato.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDistintaEsplosa

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaEsplosa : InvCommandBase
Public Class DistintaEsplosa
    Inherits InvCommandBase
public ref class DistintaEsplosa : public InvCommandBase
type DistintaEsplosa =
    class
        inherit InvCommandBase
    end

Il tipo DistintaEsplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DistintaEsplosa

Il tipo DistintaEsplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Proprietà DistintaEsplosa.NeedParameters

Proprietà DistintaEsplosaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Metodi di DistintaEsplosa

Il tipo DistintaEsplosa espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Metodo DistintaEsplosa.ClearCommand

Metodo DistintaEsplosaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Metodo DistintaEsplosa.ExecuteCommand

Metodo DistintaEsplosaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Metodo DistintaEsplosa.InvEnabled

Metodo DistintaEsplosaInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Metodo DistintaEsplosa.InvSetContext

Metodo DistintaEsplosaInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaEsplosa
Namespace DedNetInv.Commands


Classe DistintaImplosa
Apre la finestra della distinta implosa per il codice selezionato.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDistintaImplosa

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DistintaImplosa : InvCommandBase
Public Class DistintaImplosa
    Inherits InvCommandBase
public ref class DistintaImplosa : public InvCommandBase
type DistintaImplosa =
    class
        inherit InvCommandBase
    end

Il tipo DistintaImplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DistintaImplosa

Il tipo DistintaImplosa espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Proprietà DistintaImplosa.NeedParameters

Proprietà DistintaImplosaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Metodi di DistintaImplosa

Il tipo DistintaImplosa espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Metodo DistintaImplosa.ClearCommand

Metodo DistintaImplosaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Metodo DistintaImplosa.ExecuteCommand

Metodo DistintaImplosaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Metodo DistintaImplosa.InvEnabled

Metodo DistintaImplosaInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Metodo DistintaImplosa.InvSetContext

Metodo DistintaImplosaInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DistintaImplosa
Namespace DedNetInv.Commands


Classe DocAssocInv
Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDocAssocInv

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocAssocInv : InvCommandBase
Public Class DocAssocInv
    Inherits InvCommandBase
public ref class DocAssocInv : public InvCommandBase
type DocAssocInv =
    class
        inherit InvCommandBase
    end

Il tipo DocAssocInv espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DocAssocInv

Il tipo DocAssocInv espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Proprietà DocAssocInv.NeedParameters

Proprietà DocAssocInvNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Metodi di DocAssocInv

Il tipo DocAssocInv espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Metodo DocAssocInv.ClearCommand

Metodo DocAssocInvClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Metodo DocAssocInv.ExecuteCommand

Metodo DocAssocInvExecuteCommand

Lancia il comando di "Usato in".

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Metodo DocAssocInv.InvEnabled

Metodo DocAssocInvInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Metodo DocAssocInv.InvSetContext

Metodo DocAssocInvInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocAssocInv
Namespace DedNetInv.Commands


Classe DocRecognizer
Apre la gestione dell'area locale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDocRecognizer

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocRecognizer : InvCommandBase
Public Class DocRecognizer
    Inherits InvCommandBase
public ref class DocRecognizer : public InvCommandBase
type DocRecognizer =
    class
        inherit InvCommandBase
    end

Il tipo DocRecognizer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DocRecognizer

Il tipo DocRecognizer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Proprietà DocRecognizer.NeedParameters

Proprietà DocRecognizerNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Metodi di DocRecognizer

Il tipo DocRecognizer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Metodo DocRecognizer.ClearCommand

Metodo DocRecognizerClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Metodo DocRecognizer.ExecuteCommand

Metodo DocRecognizerExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Metodo DocRecognizer.InvEnabled

Metodo DocRecognizerInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Metodo DocRecognizer.InvSetContext

Metodo DocRecognizerInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocRecognizer
Namespace DedNetInv.Commands


Classe DocumentAssistant
Comando Document Assistant
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDocumentAssistant

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentAssistant : InvCommandBase
Public Class DocumentAssistant
    Inherits InvCommandBase
public ref class DocumentAssistant : public InvCommandBase
type DocumentAssistant =
    class
        inherit InvCommandBase
    end

Il tipo DocumentAssistant espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form del document assistant Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dockable Window sia visibile.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | _userInputEvents_OnTerminateCommand | Per ogni comando che inizia nascondo la docking window del form
Metodo pubblico | BeginDocAssistantUpdate | Metodo di inizio wrapping funzionalità form
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DocAssistantUpdate | Aggiorna il form con una singola chiamata mantenendo il bilanciamento dello stack
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | EndDocAssistantUpdate | Metodo di fine wrapping funzionalità aggiornamento form
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | ResetStack | Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DocumentAssistant

Il tipo DocumentAssistant espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form del document assistant Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Proprietà pubblica | Visible | Restituisce se la dockable Window sia visibile.
Torna su
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Proprietà DocumentAssistant.Form

Proprietà DocumentAssistantForm

Restituisce il Form del document assistant Può essere null se il comando non è ancora stato lanciato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvDocAssistantForm Form { get; }
Public ReadOnly Property Form As DedInvDocAssistantForm
    Get
public:
property DedInvDocAssistantForm^ Form {
    DedInvDocAssistantForm^ get ();
}
member Form : DedInvDocAssistantForm with get

Valore della proprietà

Tipo: DedInvDocAssistantForm
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Proprietà DocumentAssistant.Visible

Proprietà DocumentAssistantVisible

Restituisce se la dockable Window sia visibile.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Visible { get; set; }
Public Property Visible As Boolean
    Get
    Set
public:
property bool Visible {
    bool get ();
    void set (bool value);
}
member Visible : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodi di DocumentAssistant

Il tipo DocumentAssistant espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | _userInputEvents_OnTerminateCommand | Per ogni comando che inizia nascondo la docking window del form
Metodo pubblico | BeginDocAssistantUpdate | Metodo di inizio wrapping funzionalità form
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DocAssistantUpdate | Aggiorna il form con una singola chiamata mantenendo il bilanciamento dello stack
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | EndDocAssistantUpdate | Metodo di fine wrapping funzionalità aggiornamento form
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | ResetStack | Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant._userInputEvents_OnTerminateCommand

Metodo DocumentAssistant_userInputEvents_OnTerminateCommand

Per ogni comando che inizia nascondo la docking window del form

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void _userInputEvents_OnTerminateCommand(
    string commandName,
    NameValueMap context
)
Public Sub _userInputEvents_OnTerminateCommand (
    commandName As String,
    context As NameValueMap
)
public:
void _userInputEvents_OnTerminateCommand(
    String^ commandName,
    NameValueMap^ context
)
member _userInputEvents_OnTerminateCommand :
        commandName : string *
        context : NameValueMap -> unit

Parametri

commandName
Tipo: SystemString
context
Tipo: NameValueMap
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.BeginDocAssistantUpdate

Metodo DocumentAssistantBeginDocAssistantUpdate

Metodo di inizio wrapping funzionalità form

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void BeginDocAssistantUpdate()
Public Sub BeginDocAssistantUpdate
public:
void BeginDocAssistantUpdate()
member BeginDocAssistantUpdate : unit -> unit
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.DocAssistantUpdate

Metodo DocumentAssistantDocAssistantUpdate

Aggiorna il form con una singola chiamata mantenendo il bilanciamento dello stack

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DocAssistantUpdate(
    bool ignoreInPartEnvironment = false
)
Public Sub DocAssistantUpdate (
    Optional ignoreInPartEnvironment As Boolean = false
)
public:
void DocAssistantUpdate(
    bool ignoreInPartEnvironment = false
)
member DocAssistantUpdate :
        ?ignoreInPartEnvironment : bool
(* Defaults:
        let _ignoreInPartEnvironment = defaultArg ignoreInPartEnvironment false
*)
-> unit

Parametri

ignoreInPartEnvironment (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.EndDocAssistantUpdate

Metodo DocumentAssistantEndDocAssistantUpdate

Metodo di fine wrapping funzionalità aggiornamento form

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void EndDocAssistantUpdate(
    bool ignoreInPartEnvironment = false,
    InvCurSelInfo selInfo = null
)
Public Sub EndDocAssistantUpdate (
    Optional ignoreInPartEnvironment As Boolean = false,
    Optional selInfo As InvCurSelInfo = Nothing
)
public:
void EndDocAssistantUpdate(
    bool ignoreInPartEnvironment = false,
    InvCurSelInfo^ selInfo = nullptr
)
member EndDocAssistantUpdate :
        ?ignoreInPartEnvironment : bool *
        ?selInfo : InvCurSelInfo
(* Defaults:
        let _ignoreInPartEnvironment = defaultArg ignoreInPartEnvironment false
        let _selInfo = defaultArg selInfo null
*)
-> unit

Parametri

ignoreInPartEnvironment (Optional)
Tipo: SystemBoolean
selInfo (Optional)
Tipo: DedNetInvInvCurSelInfo
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.ExecuteCommand

Metodo DocumentAssistantExecuteCommand

Lancia il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.InvEnabled

Metodo DocumentAssistantInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.InvSetContext

Metodo DocumentAssistantInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Metodo DocumentAssistant.ResetStack

Metodo DocumentAssistantResetStack

Metodo utilizzato per forzare un azzeramento dello stack di aggiornamento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ResetStack()
Public Sub ResetStack
public:
void ResetStack()
member ResetStack : unit -> unit
Vedi anche

Documentazione

Classe DocumentAssistant
Namespace DedNetInv.Commands


Classe DownloadProject
Permette di scarica/aggiornare il progetto di Invenotor in locale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsDownloadProject

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DownloadProject : InvCommandBase
Public Class DownloadProject
    Inherits InvCommandBase
public ref class DownloadProject : public InvCommandBase
type DownloadProject =
    class
        inherit InvCommandBase
    end

Il tipo DownloadProject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di DownloadProject

Il tipo DownloadProject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Proprietà DownloadProject.NeedParameters

Proprietà DownloadProjectNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Metodi di DownloadProject

Il tipo DownloadProject espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Metodo DownloadProject.ClearCommand

Metodo DownloadProjectClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Metodo DownloadProject.ExecuteCommand

Metodo DownloadProjectExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Metodo DownloadProject.InvEnabled

Metodo DownloadProjectInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Metodo DownloadProject.InvSetContext

Metodo DownloadProjectInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DownloadProject
Namespace DedNetInv.Commands


Classe EditaAttributiSoloDB
Edita Attributi Solo DB
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsEditaAttributiSoloDB

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaAttributiSoloDB : InvCommandBase
Public Class EditaAttributiSoloDB
    Inherits InvCommandBase
public ref class EditaAttributiSoloDB : public InvCommandBase
type EditaAttributiSoloDB =
    class
        inherit InvCommandBase
    end

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Parte oggetto del documento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di EditaAttributiSoloDB

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Parte oggetto del documento
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Proprietà EditaAttributiSoloDB.NeedParameters

Proprietà EditaAttributiSoloDBNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Proprietà EditaAttributiSoloDB.Prt

Proprietà EditaAttributiSoloDBPrt

Parte oggetto del documento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Prt { get; set; }
Public Property Prt As Object
    Get
    Set
public:
property Object^ Prt {
    Object^ get ();
    void set (Object^ value);
}
member Prt : Object with get, set

Valore della proprietà

Tipo: Object
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Metodi di EditaAttributiSoloDB

Il tipo EditaAttributiSoloDB espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Metodo EditaAttributiSoloDB.ClearCommand

Metodo EditaAttributiSoloDBClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Metodo EditaAttributiSoloDB.ExecuteCommand

Metodo EditaAttributiSoloDBExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Metodo EditaAttributiSoloDB.InvEnabled

Metodo EditaAttributiSoloDBInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Metodo EditaAttributiSoloDB.InvSetContext

Metodo EditaAttributiSoloDBInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaAttributiSoloDB
Namespace DedNetInv.Commands


Classe EditaCommesse
Apre l'editor delle commesse.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsEditaCommesse

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaCommesse : InvCommandBase
Public Class EditaCommesse
    Inherits InvCommandBase
public ref class EditaCommesse : public InvCommandBase
type EditaCommesse =
    class
        inherit InvCommandBase
    end

Il tipo EditaCommesse espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di EditaCommesse

Il tipo EditaCommesse espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Proprietà EditaCommesse.NeedParameters

Proprietà EditaCommesseNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Metodi di EditaCommesse

Il tipo EditaCommesse espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Metodo EditaCommesse.ClearCommand

Metodo EditaCommesseClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Metodo EditaCommesse.ExecuteCommand

Metodo EditaCommesseExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Metodo EditaCommesse.InvEnabled

Metodo EditaCommesseInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Metodo EditaCommesse.InvSetContext

Metodo EditaCommesseInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaCommesse
Namespace DedNetInv.Commands


Classe EditaDistinta
Apre l'editor delle distinta precompilando il codice in base alla selezione effettuata.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsEditaDistinta

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaDistinta : InvCommandBase
Public Class EditaDistinta
    Inherits InvCommandBase
public ref class EditaDistinta : public InvCommandBase
type EditaDistinta =
    class
        inherit InvCommandBase
    end

Il tipo EditaDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di EditaDistinta

Il tipo EditaDistinta espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Proprietà EditaDistinta.NeedParameters

Proprietà EditaDistintaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Metodi di EditaDistinta

Il tipo EditaDistinta espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Metodo EditaDistinta.ClearCommand

Metodo EditaDistintaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Metodo EditaDistinta.ExecuteCommand

Metodo EditaDistintaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Metodo EditaDistinta.InvEnabled

Metodo EditaDistintaInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Metodo EditaDistinta.InvSetContext

Metodo EditaDistintaInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaDistinta
Namespace DedNetInv.Commands


Classe EditaECO
Apre l'editor degli ECO.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsEditaECO

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EditaECO : InvCommandBase
Public Class EditaECO
    Inherits InvCommandBase
public ref class EditaECO : public InvCommandBase
type EditaECO =
    class
        inherit InvCommandBase
    end

Il tipo EditaECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di EditaECO

Il tipo EditaECO espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Proprietà EditaECO.NeedParameters

Proprietà EditaECONeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Metodi di EditaECO

Il tipo EditaECO espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Metodo EditaECO.ClearCommand

Metodo EditaECOClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Metodo EditaECO.ExecuteCommand

Metodo EditaECOExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Metodo EditaECO.InvEnabled

Metodo EditaECOInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Metodo EditaECO.InvSetContext

Metodo EditaECOInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EditaECO
Namespace DedNetInv.Commands


Classe EseguiLua
Apre la finestra per l'esecuzione di codice LUA.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsEseguiLua

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class EseguiLua : InvCommandBase
Public Class EseguiLua
    Inherits InvCommandBase
public ref class EseguiLua : public InvCommandBase
type EseguiLua =
    class
        inherit InvCommandBase
    end

Il tipo EseguiLua espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di EseguiLua

Il tipo EseguiLua espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Proprietà EseguiLua.NeedParameters

Proprietà EseguiLuaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Metodi di EseguiLua

Il tipo EseguiLua espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Metodo EseguiLua.ClearCommand

Metodo EseguiLuaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Metodo EseguiLua.ExecuteCommand

Metodo EseguiLuaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Metodo EseguiLua.InvEnabled

Metodo EseguiLuaInvEnabled

Restituisce sempre true perché non ha bisogno di parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Metodo EseguiLua.InvSetContext

Metodo EseguiLuaInvSetContext

Restituisce sempre true perché non ha bisogno di parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe EseguiLua
Namespace DedNetInv.Commands


Classe FindDoc
Apre la finestra per la ricerca dei documenti.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsFindDoc

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindDoc : InvCommandBase
Public Class FindDoc
    Inherits InvCommandBase
public ref class FindDoc : public InvCommandBase
type FindDoc =
    class
        inherit InvCommandBase
    end

Il tipo FindDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | AllDbDocs |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di ricerca documentale. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di FindDoc

Il tipo FindDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | AllDbDocs |
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Proprietà FindDoc.AllDbDocs

Proprietà FindDocAllDbDocs

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllDbDocs { get; set; }
Public Property AllDbDocs As Boolean
    Get
    Set
public:
property bool AllDbDocs {
    bool get ();
    void set (bool value);
}
member AllDbDocs : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Metodi di FindDoc

Il tipo FindDoc espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di ricerca documentale. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Metodo FindDoc.ExecuteCommand

Metodo FindDocExecuteCommand

Lancia il comando di ricerca documentale.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Metodo FindDoc.InvEnabled

Metodo FindDocInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Metodo FindDoc.InvSetContext

Metodo FindDocInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindDoc
Namespace DedNetInv.Commands


Classe FindInBrowser
Comando di individuazione elementi albero dall'area grafica / browser.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsFindInBrowser

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindInBrowser : InvCommandBase
Public Class FindInBrowser
    Inherits InvCommandBase
public ref class FindInBrowser : public InvCommandBase
type FindInBrowser =
    class
        inherit InvCommandBase
    end

Il tipo FindInBrowser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | ForceShowDependecies |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di FindInBrowser

Il tipo FindInBrowser espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Proprietà FindInBrowser.NeedParameters

Proprietà FindInBrowserNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Metodi di FindInBrowser

Il tipo FindInBrowser espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Metodo FindInBrowser.ClearCommand

Metodo FindInBrowserClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Metodo FindInBrowser.ExecuteCommand

Metodo FindInBrowserExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Metodo FindInBrowser.InvEnabled

Metodo FindInBrowserInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Metodo FindInBrowser.InvSetContext

Metodo FindInBrowserInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Campi di FindInBrowser

Il tipo FindInBrowser espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | ForceShowDependecies |
Torna su
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Campo FindInBrowser.ForceShowDependecies

Campo FindInBrowserForceShowDependecies

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ForceShowDependecies
Public ForceShowDependecies As Boolean
public:
bool ForceShowDependecies
val mutable ForceShowDependecies: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInBrowser
Namespace DedNetInv.Commands


Classe FindInRicerca
Apre la finestra della ricerca con preselezionata l'anagrafica interessata.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsFindInRicerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindInRicerca : InvCommandBase
Public Class FindInRicerca
    Inherits InvCommandBase
public ref class FindInRicerca : public InvCommandBase
type FindInRicerca =
    class
        inherit InvCommandBase
    end

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Proprietà FindInRicerca.NeedParameters

Proprietà FindInRicercaNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Metodi di FindInRicerca

Il tipo FindInRicerca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Metodo FindInRicerca.ClearCommand

Metodo FindInRicercaClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Metodo FindInRicerca.ExecuteCommand

Metodo FindInRicercaExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Metodo FindInRicerca.InvEnabled

Metodo FindInRicercaInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Metodo FindInRicerca.InvSetContext

Metodo FindInRicercaInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FindInRicerca
Namespace DedNetInv.Commands


Classe ForceMarkerAlingment
Comando che permette di forzare l'allineamento del documento con quella presente nel Database.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsForceMarkerAlingment

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ForceMarkerAlingment : InvCommandBase
Public Class ForceMarkerAlingment
    Inherits InvCommandBase
public ref class ForceMarkerAlingment : public InvCommandBase
type ForceMarkerAlingment =
    class
        inherit InvCommandBase
    end

Il tipo ForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ForceMarkerAlingment

Il tipo ForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Proprietà ForceMarkerAlingment.NeedParameters

Proprietà ForceMarkerAlingmentNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Metodi di ForceMarkerAlingment

Il tipo ForceMarkerAlingment espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Metodo ForceMarkerAlingment.ClearCommand

Metodo ForceMarkerAlingmentClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Metodo ForceMarkerAlingment.ExecuteCommand

Metodo ForceMarkerAlingmentExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Metodo ForceMarkerAlingment.InvEnabled

Metodo ForceMarkerAlingmentInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Metodo ForceMarkerAlingment.InvSetContext

Metodo ForceMarkerAlingmentInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ForceMarkerAlingment
Namespace DedNetInv.Commands


Classe FormAbout
Apre la visualizzazione del form about.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsFormAbout

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FormAbout : InvCommandBase
Public Class FormAbout
    Inherits InvCommandBase
public ref class FormAbout : public InvCommandBase
type FormAbout =
    class
        inherit InvCommandBase
    end

Il tipo FormAbout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di FormAbout

Il tipo FormAbout espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Proprietà FormAbout.NeedParameters

Proprietà FormAboutNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Metodi di FormAbout

Il tipo FormAbout espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Metodo FormAbout.ClearCommand

Metodo FormAboutClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Metodo FormAbout.ExecuteCommand

Metodo FormAboutExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Metodo FormAbout.InvEnabled

Metodo FormAboutInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Metodo FormAbout.InvSetContext

Metodo FormAboutInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FormAbout
Namespace DedNetInv.Commands


Classe Help
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsHelp

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Help : InvCommandBase
Public Class Help
    Inherits InvCommandBase
public ref class Help : public InvCommandBase
type Help =
    class
        inherit InvCommandBase
    end

Il tipo Help espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Help

Il tipo Help espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Proprietà Help.NeedParameters

Proprietà HelpNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Metodi di Help

Il tipo Help espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Metodo Help.ClearCommand

Metodo HelpClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Metodo Help.ExecuteCommand

Metodo HelpExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Metodo Help.InvEnabled

Metodo HelpInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Metodo Help.InvSetContext

Metodo HelpInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Help
Namespace DedNetInv.Commands


Classe IndividuaGrafica
Comando di inviduazione elementi nell'area grafica
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsIndividuaGrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class IndividuaGrafica : InvCommandBase
Public Class IndividuaGrafica
    Inherits InvCommandBase
public ref class IndividuaGrafica : public InvCommandBase
type IndividuaGrafica =
    class
        inherit InvCommandBase
    end

Il tipo IndividuaGrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | TargetOccurrence | Indica se selezionare un'occorenza specifica
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di IndividuaGrafica

Il tipo IndividuaGrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | TargetOccurrence | Indica se selezionare un'occorenza specifica
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Proprietà IndividuaGrafica.NeedParameters

Proprietà IndividuaGraficaNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Proprietà IndividuaGrafica.TargetOccurrence

Proprietà IndividuaGraficaTargetOccurrence

Indica se selezionare un'occorenza specifica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence TargetOccurrence { get; set; }
Public Property TargetOccurrence As ComponentOccurrence
    Get
    Set
public:
property ComponentOccurrence^ TargetOccurrence {
    ComponentOccurrence^ get ();
    void set (ComponentOccurrence^ value);
}
member TargetOccurrence : ComponentOccurrence with get, set

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Metodi di IndividuaGrafica

Il tipo IndividuaGrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Metodo IndividuaGrafica.ClearCommand

Metodo IndividuaGraficaClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Metodo IndividuaGrafica.ExecuteCommand

Metodo IndividuaGraficaExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Metodo IndividuaGrafica.InvEnabled

Metodo IndividuaGraficaInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Metodo IndividuaGrafica.InvSetContext

Metodo IndividuaGraficaInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe IndividuaGrafica
Namespace DedNetInv.Commands


Classe InvCommandBase
Classe base per la definizione di un comando dell'add-in di Inventor. Deriva da DedCommand per permettere l'esecuzione sia da pulsante di comando che da codice.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
Altro...

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract class InvCommandBase : DedCommand
Public MustInherit Class InvCommandBase
    Inherits DedCommand
public ref class InvCommandBase abstract : public DedCommand
[<AbstractClassAttribute>]
type InvCommandBase =
    class
        inherit DedCommand
    end

Il tipo InvCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando.
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando.
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando.
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando.
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio.
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.
Metodo pubblico | InvSetContext | Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsAggiornaAttributiDaDB
DedNetInv.CommandsAggiornaDocumentoLocale
DedNetInv.CommandsAlberoDocumenti
DedNetInv.CommandsAllineaAttributi
DedNetInv.CommandsAllineaAttributiRicorsivo
DedNetInv.CommandsAnnullaCheckOut
DedNetInv.CommandsApriconOpzioni
DedNetInv.CommandsApriFileAssociati
DedNetInv.CommandsApriInLettura
DedNetInv.CommandsApriInModifica
DedNetInv.CommandsApriInNuovaFinestra
DedNetInv.CommandsArchiviaDoc
DedNetInv.CommandsAssociaPresentazione
DedNetInv.CommandsAssociaTavola
DedNetInv.CommandsAssociatedECO
DedNetInv.CommandsAssociatedTranslations
DedNetInv.CommandsAttributi
DedNetInv.CommandsCambiaPassword
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsCaricaBody
DedNetInv.CommandsCaricaNewRep
DedNetInv.CommandsCaricaParte
DedNetInv.CommandsCheckIn
DedNetInv.CommandsCheckOut
DedNetInv.CommandsCompileFactoryTableAttrs
DedNetInv.CommandsConfiguraDistinta
DedNetInv.CommandsControlloCoerenzaRiferimenti
DedNetInv.CommandsCreaComponenteAnagrafica
DedNetInv.CommandsCreaInvAssociaConf
DedNetInv.CommandsCreaInvAssociaDocument
DedNetInv.CommandsCreaInvDisconnectConf
DedNetInv.CommandsCreaNuovaRappresentazione
DedNetInv.CommandsCreateSparePartsDrawing
DedNetInv.CommandsDistintaComponenti
DedNetInv.CommandsDistintaEsplosa
DedNetInv.CommandsDistintaImplosa
DedNetInv.CommandsDocAssocInv
DedNetInv.CommandsDocRecognizer
DedNetInv.CommandsDocumentAssistant
DedNetInv.CommandsDownloadProject
DedNetInv.CommandsEditaAttributiSoloDB
DedNetInv.CommandsEditaCommesse
DedNetInv.CommandsEditaDistinta
DedNetInv.CommandsEditaECO
DedNetInv.CommandsEseguiLua
DedNetInv.CommandsFindDoc
DedNetInv.CommandsFindInBrowser
DedNetInv.CommandsFindInRicerca
DedNetInv.CommandsForceMarkerAlingment
DedNetInv.CommandsFormAbout
DedNetInv.CommandsHelp
DedNetInv.CommandsIndividuaGrafica
DedNetInv.CommandsInvDataStatisticsAnalyzer
DedNetInv.CommandsInvUserLogin
DedNetInv.CommandsLinkDED
DedNetInv.CommandsMarkerInfo
DedNetInv.CommandsOpzioniApplicazione
DedNetInv.CommandsPackAndGoExport
DedNetInv.CommandsPackAndGoImport
DedNetInv.CommandsPubblica
DedNetInv.CommandsPublishProject
DedNetInv.CommandsPublishSparePartsDrawing
DedNetInv.CommandsPwsCache
DedNetInv.CommandsRegistra
DedNetInv.CommandsReleaseFactoryMember
DedNetInv.CommandsRicerca
DedNetInv.CommandsSalva
DedNetInv.CommandsSalvaConf
DedNetInv.CommandsSalvaDist
DedNetInv.CommandsSalvaMultiplo
DedNetInv.CommandsSalvaPartBody
DedNetInv.CommandsSalvaRev
DedNetInv.CommandsSaveFactoryMemberRevision
DedNetInv.CommandsSblocca
DedNetInv.CommandsSostituisciComponente
DedNetInv.CommandsSostituisciComponenteDerivato
DedNetInv.CommandsSostituisciComponenteRapido
DedNetInv.CommandsSostituisciMoved
DedNetInv.CommandsSostituisciRiferimenti
DedNetInv.CommandsStatoDocumento
DedNetInv.CommandsTabellaRevisioni
DedNetInv.CommandsUpdateBranchInformations
DedNetInv.CommandsUpdateMembersFromFactory
DedNetInv.CommandsUpdateOldRev
DedNetInv.CommandsVisualaDiagDep
DedNetInv.CommandsWhereUsedInv


Proprietà di InvCommandBase

Il tipo InvCommandBase espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar.
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando.
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando.
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando.
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando.
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.AddToolbar

Proprietà InvCommandBaseAddToolbar

Indica se il comando deve essere aggiunto alla toolbar.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AddToolbar { get; set; }
Public Property AddToolbar As Boolean
    Get
    Set
public:
property bool AddToolbar {
    bool get ();
    void set (bool value);
}
member AddToolbar : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.Button

Proprietà InvCommandBaseButton

Resituisce la definizione del pulsante per questo comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ButtonDefinition Button { get; }
Public ReadOnly Property Button As ButtonDefinition
    Get
public:
property ButtonDefinition^ Button {
    ButtonDefinition^ get ();
}
member Button : ButtonDefinition with get

Valore della proprietà

Tipo: ButtonDefinition
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.Classification

Proprietà InvCommandBaseClassification

Restituisce o imposta la classificazione del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CommandTypesEnum Classification { get; set; }
Public Property Classification As CommandTypesEnum
    Get
    Set
public:
property CommandTypesEnum Classification {
    CommandTypesEnum get ();
    void set (CommandTypesEnum value);
}
member Classification : CommandTypesEnum with get, set

Valore della proprietà

Tipo: CommandTypesEnum
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.DisplayMode

Proprietà InvCommandBaseDisplayMode

Restituisce o imposta il tipo di pulsante abbinato il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ButtonDisplayEnum DisplayMode { get; set; }
Public Property DisplayMode As ButtonDisplayEnum
    Get
    Set
public:
property ButtonDisplayEnum DisplayMode {
    ButtonDisplayEnum get ();
    void set (ButtonDisplayEnum value);
}
member DisplayMode : ButtonDisplayEnum with get, set

Valore della proprietà

Tipo: ButtonDisplayEnum
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.Icon16

Proprietà InvCommandBaseIcon16

Restituisce o imposta l'immagine 16*16 del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IPictureDisp Icon16 { get; set; }
Public Property Icon16 As IPictureDisp
    Get
    Set
public:
property IPictureDisp^ Icon16 {
    IPictureDisp^ get ();
    void set (IPictureDisp^ value);
}
member Icon16 : IPictureDisp with get, set

Valore della proprietà

Tipo: IPictureDisp
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.Icon32

Proprietà InvCommandBaseIcon32

Restituisce o imposta l'immagine 32*32 del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IPictureDisp Icon32 { get; set; }
Public Property Icon32 As IPictureDisp
    Get
    Set
public:
property IPictureDisp^ Icon32 {
    IPictureDisp^ get ();
    void set (IPictureDisp^ value);
}
member Icon32 : IPictureDisp with get, set

Valore della proprietà

Tipo: IPictureDisp
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.NeedParameters

Proprietà InvCommandBaseNeedParameters

Restituisce se il comando ha bisogno di parametri. Restituisce sempre false.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Proprietà InvCommandBase.Struttura

Proprietà InvCommandBaseStruttura

Restituisce la lista di documenti inventor da elaborare

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Struttura { get; set; }
Public Property Struttura As Boolean
    Get
    Set
public:
property bool Struttura {
    bool get ();
    void set (bool value);
}
member Struttura : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodi di InvCommandBase

Il tipo InvCommandBase espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando.
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando.
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio.
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.
Metodo pubblico | InvSetContext | Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.ClearCommand

Metodo InvCommandBaseClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.CreateButton

Metodo InvCommandBaseCreateButton

Crea l'istanza del pulsante associato a questo comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public virtual void CreateButton()
Public Overridable Sub CreateButton
public:
virtual void CreateButton()
abstract CreateButton : unit -> unit
override CreateButton : unit -> unit
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.DisposeButton

Metodo InvCommandBaseDisposeButton

Effettua il Dispose del pulsante associato a questo comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public virtual void DisposeButton()
Public Overridable Sub DisposeButton
public:
virtual void DisposeButton()
abstract DisposeButton : unit -> unit
override DisposeButton : unit -> unit
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.Enabled

Metodo InvCommandBaseEnabled

Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.Execute

Metodo InvCommandBaseExecute

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Execute(
    NameValueMap Context
)
Protected Overridable Sub Execute (
    Context As NameValueMap
)
protected:
virtual void Execute(
    NameValueMap^ Context
)
abstract Execute :
        Context : NameValueMap -> unit
override Execute :
        Context : NameValueMap -> unit

Parametri

Context
Tipo: NameValueMap
Contesto di esecuzione comando.
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.ExecuteCommand

Metodo InvCommandBaseExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected abstract DedCmdResult ExecuteCommand()
Protected MustOverride Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() abstract override
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.InvEnabled

Metodo InvCommandBaseInvEnabled

Restituisce se il comando sia abilitato in base al contesto di Inventor attuale.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public MustOverride Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) abstract
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext
Contesto.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.InvSetContext

Metodo InvCommandBaseInvSetContext

Inizializza il comando con il context di Inventor e restituisce true se riesce altrimenti false.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public abstract bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public MustOverride Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) abstract
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext
Selezione attuale presente in Inventor.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Metodo InvCommandBase.SetContext

Metodo InvCommandBaseSetContext

Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvCommandBase
Namespace DedNetInv.Commands


Classe InvDataStatisticsAnalyzer
Comando di individuazione elementi albero dall'area grafica / browser.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsInvDataStatisticsAnalyzer

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvDataStatisticsAnalyzer : InvCommandBase
Public Class InvDataStatisticsAnalyzer
    Inherits InvCommandBase
public ref class InvDataStatisticsAnalyzer : public InvCommandBase
type InvDataStatisticsAnalyzer =
    class
        inherit InvCommandBase
    end

Il tipo InvDataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di InvDataStatisticsAnalyzer

Il tipo InvDataStatisticsAnalyzer espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Metodi di InvDataStatisticsAnalyzer

Il tipo InvDataStatisticsAnalyzer espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Metodo InvDataStatisticsAnalyzer.ClearCommand

Metodo InvDataStatisticsAnalyzerClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Metodo InvDataStatisticsAnalyzer.ExecuteCommand

Metodo InvDataStatisticsAnalyzerExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Metodo InvDataStatisticsAnalyzer.InvEnabled

Metodo InvDataStatisticsAnalyzerInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Metodo InvDataStatisticsAnalyzer.InvSetContext

Metodo InvDataStatisticsAnalyzerInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvDataStatisticsAnalyzer
Namespace DedNetInv.Commands


Classe InvUserLogin
Comando login specifico del cad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsInvUserLogin

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InvUserLogin : InvCommandBase
Public Class InvUserLogin
    Inherits InvCommandBase
public ref class InvUserLogin : public InvCommandBase
type InvUserLogin =
    class
        inherit InvCommandBase
    end

Il tipo InvUserLogin espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il contesto del comando (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di InvUserLogin

Il tipo InvUserLogin espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvUserLogin
Namespace DedNetInv.Commands


Metodi di InvUserLogin

Il tipo InvUserLogin espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il contesto del comando (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe InvUserLogin
Namespace DedNetInv.Commands


Metodo InvUserLogin.ExecuteCommand

Metodo InvUserLoginExecuteCommand

Lancia il comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe InvUserLogin
Namespace DedNetInv.Commands


Metodo InvUserLogin.InvEnabled

Metodo InvUserLoginInvEnabled

Verifica l'abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvUserLogin
Namespace DedNetInv.Commands


Metodo InvUserLogin.InvSetContext

Metodo InvUserLoginInvSetContext

Imposta il contesto del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe InvUserLogin
Namespace DedNetInv.Commands


Classe Lavorazione
Comando lavorazione ( solo in modalità STANDARD )
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsLavorazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Lavorazione : CambiaStato
Public Class Lavorazione
    Inherits CambiaStato
public ref class Lavorazione : public CambiaStato
type Lavorazione =
    class
        inherit CambiaStato
    end

Il tipo Lavorazione espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Lavorazione | Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore Lavorazione

Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Lavorazione(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
Lavorazione(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> Lavorazione

Parametri

app
Tipo: DedNetApplication
internalName
Tipo: SystemString
displayName
Tipo: SystemString
multiple
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetInv.Commands


Proprietà di Lavorazione

Il tipo Lavorazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetInv.Commands


Metodi di Lavorazione

Il tipo Lavorazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Lavorazione
Namespace DedNetInv.Commands


Classe LinkDED
Apre le opzioni dell'applicazione.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsLinkDED

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LinkDED : InvCommandBase
Public Class LinkDED
    Inherits InvCommandBase
public ref class LinkDED : public InvCommandBase
type LinkDED =
    class
        inherit InvCommandBase
    end

Il tipo LinkDED espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | Link |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di LinkDED

Il tipo LinkDED espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | Link |
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Proprietà LinkDED.Link

Proprietà LinkDEDLink

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Link { get; set; }
Public Property Link As String
    Get
    Set
public:
property String^ Link {
    String^ get ();
    void set (String^ value);
}
member Link : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Proprietà LinkDED.NeedParameters

Proprietà LinkDEDNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Metodi di LinkDED

Il tipo LinkDED espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Metodo LinkDED.ClearCommand

Metodo LinkDEDClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Metodo LinkDED.ExecuteCommand

Metodo LinkDEDExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Metodo LinkDED.InvEnabled

Metodo LinkDEDInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext swCmdCtx
)
Public Overrides Function InvEnabled (
    swCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ swCmdCtx
) override
abstract InvEnabled :
        swCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        swCmdCtx : DedInvCommandContext -> bool

Parametri

swCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Metodo LinkDED.InvSetContext

Metodo LinkDEDInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext swCmdCtx
)
Public Overrides Function InvSetContext (
    swCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ swCmdCtx
) override
abstract InvSetContext :
        swCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        swCmdCtx : DedInvCommandContext -> bool

Parametri

swCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe LinkDED
Namespace DedNetInv.Commands


Classe MarkerInfo
Comando che permette di controllare lo stato di allineamento del documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsMarkerInfo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MarkerInfo : InvCommandBase
Public Class MarkerInfo
    Inherits InvCommandBase
public ref class MarkerInfo : public InvCommandBase
type MarkerInfo =
    class
        inherit InvCommandBase
    end

Il tipo MarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di MarkerInfo

Il tipo MarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Proprietà MarkerInfo.NeedParameters

Proprietà MarkerInfoNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Metodi di MarkerInfo

Il tipo MarkerInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Metodo MarkerInfo.ClearCommand

Metodo MarkerInfoClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Metodo MarkerInfo.ExecuteCommand

Metodo MarkerInfoExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Metodo MarkerInfo.InvEnabled

Metodo MarkerInfoInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Metodo MarkerInfo.InvSetContext

Metodo MarkerInfoInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe MarkerInfo
Namespace DedNetInv.Commands


Classe ModificaSuperato
Comando RettificaSuperato ( solo in modalità STANDARD )
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsModificaSuperato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModificaSuperato : CambiaStato
Public Class ModificaSuperato
    Inherits CambiaStato
public ref class ModificaSuperato : public CambiaStato
type ModificaSuperato =
    class
        inherit CambiaStato
    end

Il tipo ModificaSuperato espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModificaSuperato | Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore ModificaSuperato

Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModificaSuperato(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
ModificaSuperato(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> ModificaSuperato

Parametri

app
Tipo: DedNetApplication
internalName
Tipo: SystemString
displayName
Tipo: SystemString
multiple
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetInv.Commands


Proprietà di ModificaSuperato

Il tipo ModificaSuperato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetInv.Commands


Metodi di ModificaSuperato

Il tipo ModificaSuperato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ModificaSuperato
Namespace DedNetInv.Commands


Classe OpzioniApplicazione
Apre le opzioni dell'applicazione.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsOpzioniApplicazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OpzioniApplicazione : InvCommandBase
Public Class OpzioniApplicazione
    Inherits InvCommandBase
public ref class OpzioniApplicazione : public InvCommandBase
type OpzioniApplicazione =
    class
        inherit InvCommandBase
    end

Il tipo OpzioniApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di OpzioniApplicazione

Il tipo OpzioniApplicazione espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Proprietà OpzioniApplicazione.NeedParameters

Proprietà OpzioniApplicazioneNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Metodi di OpzioniApplicazione

Il tipo OpzioniApplicazione espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Metodo OpzioniApplicazione.ClearCommand

Metodo OpzioniApplicazioneClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Metodo OpzioniApplicazione.ExecuteCommand

Metodo OpzioniApplicazioneExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Metodo OpzioniApplicazione.InvEnabled

Metodo OpzioniApplicazioneInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Metodo OpzioniApplicazione.InvSetContext

Metodo OpzioniApplicazioneInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe OpzioniApplicazione
Namespace DedNetInv.Commands


Enumerazione PackAndGoContext
Definizione possibili contesti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoContext
Public Enumeration PackAndGoContext
public enum class PackAndGoContext
type PackAndGoContext
Membri
Nome | Valore | Descrizione
Import | 0 |
Export | 1 |
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Classe PackAndGoExport
Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPackAndGoExport

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoExport : InvCommandBase
Public Class PackAndGoExport
    Inherits InvCommandBase
public ref class PackAndGoExport : public InvCommandBase
type PackAndGoExport =
    class
        inherit InvCommandBase
    end

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CurSelInfo | Restitusice l'oggetto CurSelInfo associato al comando se lanciato all'interno di Inventor
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale da menu (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando all'interno del contesto di Inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto del comando all'interno del client (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CurSelInfo | Restitusice l'oggetto CurSelInfo associato al comando se lanciato all'interno di Inventor
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocumentInfos | Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Proprietà PackAndGoExport.CurSelInfo

Proprietà PackAndGoExportCurSelInfo

Restitusice l'oggetto CurSelInfo associato al comando se lanciato all'interno di Inventor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvCurSelInfo CurSelInfo { get; }
Public ReadOnly Property CurSelInfo As InvCurSelInfo
    Get
public:
property InvCurSelInfo^ CurSelInfo {
    InvCurSelInfo^ get ();
}
member CurSelInfo : InvCurSelInfo with get

Valore della proprietà

Tipo: InvCurSelInfo
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Proprietà PackAndGoExport.DocumentInfos

Proprietà PackAndGoExportDocumentInfos

Restituisce la lista dei documenti con abbinato il contesto di anagrafica di elaborazione comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfoList DocumentInfos { get; }
Public ReadOnly Property DocumentInfos As DedCommandDocAnagrInfoList
    Get
public:
property DedCommandDocAnagrInfoList^ DocumentInfos {
    DedCommandDocAnagrInfoList^ get ();
}
member DocumentInfos : DedCommandDocAnagrInfoList with get

Valore della proprietà

Tipo: DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodi di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale da menu (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando all'interno del contesto di Inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto del comando all'interno del client (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.ClearCommand

Metodo PackAndGoExportClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.Enabled

Metodo PackAndGoExportEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale da menu

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.ExecuteCommand

Metodo PackAndGoExportExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.InvEnabled

Metodo PackAndGoExportInvEnabled

Abilitazione del comando all'interno del contesto di Inventor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.InvSetContext

Metodo PackAndGoExportInvSetContext

Settaggio del contesto del comando all'interno del client

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Metodo PackAndGoExport.SetContext

Metodo PackAndGoExportSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoExport
Namespace DedNetInv.Commands


Classe PackAndGoImport
Esegue l'importazione della struttura dall'anagrafica o dal documento attivo
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPackAndGoImport

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImport : InvCommandBase
Public Class PackAndGoImport
    Inherits InvCommandBase
public ref class PackAndGoImport : public InvCommandBase
type PackAndGoImport =
    class
        inherit InvCommandBase
    end

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale da menu (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando all'interno del contesto di Inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto del comando all'interno del client (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodi di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale da menu (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando all'interno del contesto di Inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Settaggio del contesto del comando all'interno del client (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.ClearCommand

Metodo PackAndGoImportClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.Enabled

Metodo PackAndGoImportEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale da menu

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.ExecuteCommand

Metodo PackAndGoImportExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.InvEnabled

Metodo PackAndGoImportInvEnabled

Abilitazione del comando all'interno del contesto di Inventor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.InvSetContext

Metodo PackAndGoImportInvSetContext

Settaggio del contesto del comando all'interno del client

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Metodo PackAndGoImport.SetContext

Metodo PackAndGoImportSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoImport
Namespace DedNetInv.Commands


Enumerazione PackAndGoImportAttrStatus
Stato attributi in validazione importazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportAttrStatus
Public Enumeration PackAndGoImportAttrStatus
public enum class PackAndGoImportAttrStatus
type PackAndGoImportAttrStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Compare | 1 |
MandatoryMissing | 2 |
Undefined | 3 |
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Enumerazione PackAndGoImportDedCases
Possibili casi del database in fase di importazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportDedCases
Public Enumeration PackAndGoImportDedCases
public enum class PackAndGoImportDedCases
type PackAndGoImportDedCases
Membri
Nome | Valore | Descrizione
None | 0 |
NoDed | 1 |
DedRemote | 2 |
DedVpn | 3 |
InvPackAndGo | 4 |
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Classe PackAndGoImportingStructureInfo
Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsPackAndGoImportingStructureInfo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImportingStructureInfo
Public Class PackAndGoImportingStructureInfo
public ref class PackAndGoImportingStructureInfo
type PackAndGoImportingStructureInfo =  class end

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoImportingStructureInfo |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore PackAndGoImportingStructureInfo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo()
Public Sub New
public:
PackAndGoImportingStructureInfo()
new : unit -> PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Metodi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Metodo PackAndGoImportingStructureInfo.Clone

Metodo PackAndGoImportingStructureInfoClone

Clonazione dell'oggetto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo Clone()
Public Function Clone As PackAndGoImportingStructureInfo
public:
PackAndGoImportingStructureInfo^ Clone()
member Clone : unit -> PackAndGoImportingStructureInfo

Valore di ritorno

Tipo: PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.AttrStatus

Campo PackAndGoImportingStructureInfoAttrStatus

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportAttrStatus AttrStatus
Public AttrStatus As PackAndGoImportAttrStatus
public:
PackAndGoImportAttrStatus AttrStatus
val mutable AttrStatus: PackAndGoImportAttrStatus

Valore del campo

Tipo: PackAndGoImportAttrStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.AttrStatusRepresentation

Campo PackAndGoImportingStructureInfoAttrStatusRepresentation

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image AttrStatusRepresentation
Public AttrStatusRepresentation As Image
public:
Image^ AttrStatusRepresentation
val mutable AttrStatusRepresentation: Image

Valore del campo

Tipo: Image
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.Checkable

Campo PackAndGoImportingStructureInfoCheckable

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Checkable
Public Checkable As Boolean
public:
bool Checkable
val mutable Checkable: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.DocAlreadyCompared

Campo PackAndGoImportingStructureInfoDocAlreadyCompared

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocAlreadyCompared
Public DocAlreadyCompared As Boolean
public:
bool DocAlreadyCompared
val mutable DocAlreadyCompared: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.ImportNote

Campo PackAndGoImportingStructureInfoImportNote

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ImportNote
Public ImportNote As String
public:
String^ ImportNote
val mutable ImportNote: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.OperationStatus

Campo PackAndGoImportingStructureInfoOperationStatus

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperationStatus OperationStatus
Public OperationStatus As PackAndGoImportOperationStatus
public:
PackAndGoImportOperationStatus OperationStatus
val mutable OperationStatus: PackAndGoImportOperationStatus

Valore del campo

Tipo: PackAndGoImportOperationStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.PckImportOperation

Campo PackAndGoImportingStructureInfoPckImportOperation

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation PckImportOperation
Public PckImportOperation As PackAndGoImportOperation
public:
PackAndGoImportOperation PckImportOperation
val mutable PckImportOperation: PackAndGoImportOperation

Valore del campo

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Campo PackAndGoImportingStructureInfo.PckNdDescr

Campo PackAndGoImportingStructureInfoPckNdDescr

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor PckNdDescr
Public PckNdDescr As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ PckNdDescr
val mutable PckNdDescr: PackAndGoNodeDescriptor

Valore del campo

Tipo: PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo
Namespace DedNetInv.Commands


Enumerazione PackAndGoImportOperation
Definizione possibili azioni su oggetti importazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperation
Public Enumeration PackAndGoImportOperation
public enum class PackAndGoImportOperation
type PackAndGoImportOperation
Membri
Nome | Valore | Descrizione
Ignora | 0 |
Sovrascrivi | 1 |
Codifica | 2 |
Associa | 3 |
Libreria | 4 |
Clona | 5 |
Speciale | 6 |
Salta | 7 |
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Enumerazione PackAndGoImportOperationStatus
Stato di validazione dell'operazione ( per ora non usata sempre Ok )

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperationStatus
Public Enumeration PackAndGoImportOperationStatus
public enum class PackAndGoImportOperationStatus
type PackAndGoImportOperationStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Error | 1 |
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Classe PackAndGoNodeDescriptor
Descrittore singolo nodo di struttura
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsPackAndGoNodeDescriptor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptor
<SerializableAttribute>
Public Class PackAndGoNodeDescriptor
[SerializableAttribute]
public ref class PackAndGoNodeDescriptor
[<SerializableAttribute>]
type PackAndGoNodeDescriptor =  class end

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(InvDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData, String) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg | Configurazione del documento.
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Configurations | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Parent | Oggetto padre del nodo. ATTENZIONE! Non va serializzato pena la creazione di riferimenti circolari.
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore PackAndGoNodeDescriptor

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(InvDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData, String) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Costruttore PackAndGoNodeDescriptor

Costruttore senza parametri per la serializzazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor()
Public Sub New
public:
PackAndGoNodeDescriptor()
new : unit -> PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Costruttore PackAndGoNodeDescriptor (InvDocStructInfo)
Costruttore dell'oggetto

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    InvDocStructInfo ds
)
Public Sub New (
    ds As InvDocStructInfo
)
public:
PackAndGoNodeDescriptor(
    InvDocStructInfo^ ds
)
new :
        ds : InvDocStructInfo -> PackAndGoNodeDescriptor

Parametri

ds
Tipo: DedNetInvInvDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Costruttore PackAndGoNodeDescriptor (DedDoc, DedData, String)
Costruttore alternativo con informazioni documentali ed anagrafiche.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    DedDoc ddoc,
    DedData ddata,
    string config
)
Public Sub New (
    ddoc As DedDoc,
    ddata As DedData,
    config As String
)
public:
PackAndGoNodeDescriptor(
    DedDoc^ ddoc,
    DedData^ ddata,
    String^ config
)
new :
        ddoc : DedDoc *
        ddata : DedData *
        config : string -> PackAndGoNodeDescriptor

Parametri

ddoc
Tipo: DedDoc
Documento
ddata
Tipo: DedData
Anagrafica
config
Tipo: SystemString
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg | Configurazione del documento.
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Configurations | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Parent | Oggetto padre del nodo. ATTENZIONE! Non va serializzato pena la creazione di riferimenti circolari.
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Cfg

Proprietà PackAndGoNodeDescriptorCfg

Configurazione del documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Cfg { get; set; }
Public Property Cfg As String
    Get
    Set
public:
property String^ Cfg {
    String^ get ();
    void set (String^ value);
}
member Cfg : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Children

Proprietà PackAndGoNodeDescriptorChildren

Sotto struttura dei descrittori

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Children { get; set; }
Public Property Children As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Children {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Children : PackAndGoNodeDescriptors with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Configurations

Proprietà PackAndGoNodeDescriptorConfigurations

Sotto struttura dei descrittori

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Configurations { get; set; }
Public Property Configurations As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Configurations {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Configurations : PackAndGoNodeDescriptors with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Context

Proprietà PackAndGoNodeDescriptorContext

Eventuale contesto di associazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

Tipo: DedDocContextEnum
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DbPath

Proprietà PackAndGoNodeDescriptorDbPath

Path della famiglia dell'anagrafica associata

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DedId

Proprietà PackAndGoNodeDescriptorDedId

Id della angrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DedRev

Proprietà PackAndGoNodeDescriptorDedRev

Revisione anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DocId

Proprietà PackAndGoNodeDescriptorDocId

Id del documento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { get; set; }
Public Property DocId As Guid
    Get
    Set
public:
property Guid DocId {
    Guid get ();
    void set (Guid value);
}
member DocId : Guid with get, set

Valore della proprietà

Tipo: Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DocIsMovingDestination

Proprietà PackAndGoNodeDescriptorDocIsMovingDestination

Indica se il documento è stato movato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocIsMovingDestination { get; set; }
Public Property DocIsMovingDestination As Boolean
    Get
    Set
public:
property bool DocIsMovingDestination {
    bool get ();
    void set (bool value);
}
member DocIsMovingDestination : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.DocRowVer

Proprietà PackAndGoNodeDescriptorDocRowVer

Revisione del documento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocRowVer { get; set; }
Public Property DocRowVer As Guid
    Get
    Set
public:
property Guid DocRowVer {
    Guid get ();
    void set (Guid value);
}
member DocRowVer : Guid with get, set

Valore della proprietà

Tipo: Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.FullFileName

Proprietà PackAndGoNodeDescriptorFullFileName

Percorso assoluto del file

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.HasData

Proprietà PackAndGoNodeDescriptorHasData

Restituisce se il documento è collegato ad una anagrafica.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasData { get; }
Public ReadOnly Property HasData As Boolean
    Get
public:
property bool HasData {
    bool get ();
}
member HasData : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.InfoUser

Proprietà PackAndGoNodeDescriptorInfoUser

Tassello utente dell'anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.MakeAnagrObs

Proprietà PackAndGoNodeDescriptorMakeAnagrObs

Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MakeAnagrObs { get; set; }
Public Property MakeAnagrObs As Boolean
    Get
    Set
public:
property bool MakeAnagrObs {
    bool get ();
    void set (bool value);
}
member MakeAnagrObs : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.MovedByMasterAfterSend

Proprietà PackAndGoNodeDescriptorMovedByMasterAfterSend

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MovedByMasterAfterSend { get; set; }
Public Property MovedByMasterAfterSend As Boolean
    Get
    Set
public:
property bool MovedByMasterAfterSend {
    bool get ();
    void set (bool value);
}
member MovedByMasterAfterSend : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Parent

Proprietà PackAndGoNodeDescriptorParent

Oggetto padre del nodo. ATTENZIONE! Non va serializzato pena la creazione di riferimenti circolari.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Parent { get; set; }
Public Property Parent As PackAndGoNodeDescriptor
    Get
    Set
public:
property PackAndGoNodeDescriptor^ Parent {
    PackAndGoNodeDescriptor^ get ();
    void set (PackAndGoNodeDescriptor^ value);
}
member Parent : PackAndGoNodeDescriptor with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.Progr

Proprietà PackAndGoNodeDescriptorProgr

Progressivo dell'anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.RelativeFileName

Proprietà PackAndGoNodeDescriptorRelativeFileName

Percorso relativo alla root del packandgo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RelativeFileName { get; set; }
Public Property RelativeFileName As String
    Get
    Set
public:
property String^ RelativeFileName {
    String^ get ();
    void set (String^ value);
}
member RelativeFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.RootedPath

Proprietà PackAndGoNodeDescriptorRootedPath

Path rooted del documento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RootedPath { get; set; }
Public Property RootedPath As String
    Get
    Set
public:
property String^ RootedPath {
    String^ get ();
    void set (String^ value);
}
member RootedPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeDescriptor.ToBeMoved

Proprietà PackAndGoNodeDescriptorToBeMoved

Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeMoved { get; set; }
Public Property ToBeMoved As Boolean
    Get
    Set
public:
property bool ToBeMoved {
    bool get ();
    void set (bool value);
}
member ToBeMoved : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodi di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoNodeDescriptor.Equals

Metodo PackAndGoNodeDescriptorEquals

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoNodeDescriptor.GetHashCode

Metodo PackAndGoNodeDescriptorGetHashCode

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoNodeDescriptor.IsSameVersion

Metodo PackAndGoNodeDescriptorIsSameVersion

Controlla se la versione passata coincide con quella del nodo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSameVersion(
    Guid docRowVer
)
Public Function IsSameVersion (
    docRowVer As Guid
) As Boolean
public:
bool IsSameVersion(
    Guid docRowVer
)
member IsSameVersion :
        docRowVer : Guid -> bool

Parametri

docRowVer
Tipo: SystemGuid

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoNodeDescriptor.MatchRelativeFileName

Metodo PackAndGoNodeDescriptorMatchRelativeFileName

Controlla il match tra il nodo in esame ed il percorso relativo passato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MatchRelativeFileName(
    string relativePath
)
Public Function MatchRelativeFileName (
    relativePath As String
) As Boolean
public:
bool MatchRelativeFileName(
    String^ relativePath
)
member MatchRelativeFileName :
        relativePath : string -> bool

Parametri

relativePath
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoNodeDescriptor.ToString

Metodo PackAndGoNodeDescriptorToString

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Namespace DedNetInv.Commands


Classe PackAndGoNodeDescriptors
Classe gestione lista nodi di struttura
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList PackAndGoNodeDescriptor
DedNetInv.CommandsPackAndGoNodeDescriptors

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptors : List<PackAndGoNodeDescriptor>
<SerializableAttribute>
Public Class PackAndGoNodeDescriptors
    Inherits List(Of PackAndGoNodeDescriptor)
[SerializableAttribute]
public ref class PackAndGoNodeDescriptors : public List<PackAndGoNodeDescriptor^>
[<SerializableAttribute>]
type PackAndGoNodeDescriptors =
    class
        inherit List<PackAndGoNodeDescriptor>
    end

Il tipo PackAndGoNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptors |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore PackAndGoNodeDescriptors

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors()
Public Sub New
public:
PackAndGoNodeDescriptors()
new : unit -> PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptors
Namespace DedNetInv.Commands


Classe PackAndGoNodeWrapper
Classe rappresentante l'oggetto nodo nel controllo treeList del form
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsPackAndGoNodeWrapper

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoNodeWrapper
Public Class PackAndGoNodeWrapper
public ref class PackAndGoNodeWrapper
type PackAndGoNodeWrapper =  class end

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, InvDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg | Infouser impostato da pers Lua
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc | Ritorna il document associato alla struttura
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'InvDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta o Sovrascrivi ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore PackAndGoNodeWrapper

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, InvDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Costruttore PackAndGoNodeWrapper (DedDoc, PackAndGoContext)
Costrutture basato su DedDoc

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedDoc ddoc,
    PackAndGoContext context
)
Public Sub New (
    ddoc As DedDoc,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedDoc^ ddoc,
    PackAndGoContext context
)
new :
        ddoc : DedDoc *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddoc
Tipo: DedDoc
context
Tipo: DedNetInv.CommandsPackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Costruttore PackAndGoNodeWrapper (DedData, InvDocStructInfo, PackAndGoContext)
Costruttore del descrittore

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedData ddata,
    InvDocStructInfo invDsInfo,
    PackAndGoContext context
)
Public Sub New (
    ddata As DedData,
    invDsInfo As InvDocStructInfo,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedData^ ddata,
    InvDocStructInfo^ invDsInfo,
    PackAndGoContext context
)
new :
        ddata : DedData *
        invDsInfo : InvDocStructInfo *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddata
Tipo: DedData
invDsInfo
Tipo: DedNetInvInvDocStructInfo
context
Tipo: DedNetInv.CommandsPackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cfg | Infouser impostato da pers Lua
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc | Ritorna il document associato alla struttura
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'InvDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta o Sovrascrivi ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Cfg

Proprietà PackAndGoNodeWrapperCfg

Infouser impostato da pers Lua

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Cfg { get; set; }
Public Property Cfg As String
    Get
    Set
public:
property String^ Cfg {
    String^ get ();
    void set (String^ value);
}
member Cfg : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Context

Proprietà PackAndGoNodeWrapperContext

Contesto dell'operazione (import/export)

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoContext Context { get; set; }
Public Property Context As PackAndGoContext
    Get
    Set
public:
property PackAndGoContext Context {
    PackAndGoContext get ();
    void set (PackAndGoContext value);
}
member Context : PackAndGoContext with get, set

Valore della proprietà

Tipo: PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Data

Proprietà PackAndGoNodeWrapperData

Anagrafica di riferimento del nodo rappresentante una anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.DedDoc

Proprietà PackAndGoNodeWrapperDedDoc

Ritorna il document associato alla struttura

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.DedType

Proprietà PackAndGoNodeWrapperDedType

Famiglia nella quale codificare il documento (import)

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.DestRoot

Proprietà PackAndGoNodeWrapperDestRoot

Root di destinazione del file

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.DocStructInfo

Proprietà PackAndGoNodeWrapperDocStructInfo

Ritorna l'InvDocStructInfo di riferimento per il descrittore

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As InvDocStructInfo
    Get
public:
property InvDocStructInfo^ DocStructInfo {
    InvDocStructInfo^ get ();
}
member DocStructInfo : InvDocStructInfo with get

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.FullFileName

Proprietà PackAndGoNodeWrapperFullFileName

Percorso assoluto del file che identifica il nodo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.ImportStructureInfo

Proprietà PackAndGoNodeWrapperImportStructureInfo

Informazioni di importazione associabili al descrittore

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo ImportStructureInfo { get; set; }
Public Property ImportStructureInfo As PackAndGoImportingStructureInfo
    Get
    Set
public:
property PackAndGoImportingStructureInfo^ ImportStructureInfo {
    PackAndGoImportingStructureInfo^ get ();
    void set (PackAndGoImportingStructureInfo^ value);
}
member ImportStructureInfo : PackAndGoImportingStructureInfo with get, set

Valore della proprietà

Tipo: PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.InfoUser

Proprietà PackAndGoNodeWrapperInfoUser

Infouser impostato da pers Lua

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.InvolvedInImportOperations

Proprietà PackAndGoNodeWrapperInvolvedInImportOperations

Indica se l'oggetto sarà coinvolto nelle operazioni di import

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool InvolvedInImportOperations { get; set; }
Public Property InvolvedInImportOperations As Boolean
    Get
    Set
public:
property bool InvolvedInImportOperations {
    bool get ();
    void set (bool value);
}
member InvolvedInImportOperations : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.IsDataNode

Proprietà PackAndGoNodeWrapperIsDataNode

Ritorna vero se il nodo rappresenta una anagrafica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDataNode { get; }
Public ReadOnly Property IsDataNode As Boolean
    Get
public:
property bool IsDataNode {
    bool get ();
}
member IsDataNode : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.NewFullFileName

Proprietà PackAndGoNodeWrapperNewFullFileName

Indica il nuovo file da utilizzare nel caso di Salta o Sovrascrivi ( impostato solo tramite Lua )

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Node

Proprietà PackAndGoNodeWrapperNode

Ritorna/Importa l'oggetto nodo nativo corrispondente

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.NodeInfoCompleted

Proprietà PackAndGoNodeWrapperNodeInfoCompleted

Restituisce se il nodo ha tutte le informazioni necessarie

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NodeInfoCompleted { get; }
Public ReadOnly Property NodeInfoCompleted As Boolean
    Get
public:
property bool NodeInfoCompleted {
    bool get ();
}
member NodeInfoCompleted : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.OutofPackGo

Proprietà PackAndGoNodeWrapperOutofPackGo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutofPackGo { get; set; }
Public Property OutofPackGo As Boolean
    Get
    Set
public:
property bool OutofPackGo {
    bool get ();
    void set (bool value);
}
member OutofPackGo : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Progr

Proprietà PackAndGoNodeWrapperProgr

Progr impostato da pers Lua

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Proprietà PackAndGoNodeWrapper.Rev

Proprietà PackAndGoNodeWrapperRev

Rev impostato da pers Lua

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Metodi di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Metodo PackAndGoNodeWrapper.Clone

Metodo PackAndGoNodeWrapperClone

Clonazione dell'oggetto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper Clone()
Public Function Clone As PackAndGoNodeWrapper
public:
PackAndGoNodeWrapper^ Clone()
member Clone : unit -> PackAndGoNodeWrapper

Valore di ritorno

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Metodo PackAndGoNodeWrapper.SetData

Metodo PackAndGoNodeWrapperSetData

Setta i dati sul nodo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    TreeListNode node
)
Public Sub SetData (
    node As TreeListNode
)
public:
void SetData(
    TreeListNode^ node
)
member SetData :
        node : TreeListNode -> unit

Parametri

node
Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Metodo PackAndGoNodeWrapper.SetNodeIcon

Metodo PackAndGoNodeWrapperSetNodeIcon

Setta l'icona sul nodo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetNodeIcon(
    ImageList il,
    TreeListNode node
)
Public Sub SetNodeIcon (
    il As ImageList,
    node As TreeListNode
)
public:
void SetNodeIcon(
    ImageList^ il,
    TreeListNode^ node
)
member SetNodeIcon :
        il : ImageList *
        node : TreeListNode -> unit

Parametri

il
Tipo: System.Windows.FormsImageList
node
Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Namespace DedNetInv.Commands


Classe PackAndGoStructureDescriptor
Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Gerarchia di ereditarietà
SystemObject
DedNetInv.CommandsPackAndGoStructureDescriptor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoStructureDescriptor
<SerializableAttribute>
Public Class PackAndGoStructureDescriptor
[SerializableAttribute]
public ref class PackAndGoStructureDescriptor
[<SerializableAttribute>]
type PackAndGoStructureDescriptor =  class end

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoStructureDescriptor | Costrutture della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore PackAndGoStructureDescriptor

Costrutture della classe

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor()
Public Sub New
public:
PackAndGoStructureDescriptor()
new : unit -> PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.AlreadyImported

Proprietà PackAndGoStructureDescriptorAlreadyImported

Indica se il pacchetto è già stato importato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlreadyImported { get; set; }
Public Property AlreadyImported As Boolean
    Get
    Set
public:
property bool AlreadyImported {
    bool get ();
    void set (bool value);
}
member AlreadyImported : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.CorporateId

Proprietà PackAndGoStructureDescriptorCorporateId

Identificativo aziendale

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string CorporateId { get; set; }
Public Property CorporateId As String
    Get
    Set
public:
property String^ CorporateId {
    String^ get ();
    void set (String^ value);
}
member CorporateId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.DbType

Proprietà PackAndGoStructureDescriptorDbType

Ritorna il tipo di database. Può essere master o slave

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbType { get; set; }
Public Property DbType As String
    Get
    Set
public:
property String^ DbType {
    String^ get ();
    void set (String^ value);
}
member DbType : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.DescriptorFullPath

Proprietà PackAndGoStructureDescriptorDescriptorFullPath

Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DescriptorFullPath { get; set; }
Public Property DescriptorFullPath As String
    Get
    Set
public:
property String^ DescriptorFullPath {
    String^ get ();
    void set (String^ value);
}
member DescriptorFullPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.MajorVer

Proprietà PackAndGoStructureDescriptorMajorVer

Identificativo della versione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MajorVer { get; set; }
Public Property MajorVer As Integer
    Get
    Set
public:
property int MajorVer {
    int get ();
    void set (int value);
}
member MajorVer : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.MinorVer

Proprietà PackAndGoStructureDescriptorMinorVer

Identificativo della versione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MinorVer { get; set; }
Public Property MinorVer As Integer
    Get
    Set
public:
property int MinorVer {
    int get ();
    void set (int value);
}
member MinorVer : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.Structure

Proprietà PackAndGoStructureDescriptorStructure

Sotto struttura dei descrittori

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Structure { get; set; }
Public Property Structure As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Structure {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Structure : PackAndGoNodeDescriptors with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Proprietà PackAndGoStructureDescriptor.UserId

Proprietà PackAndGoStructureDescriptorUserId

Identificativo dell'utente che ha eseguito l'operazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Metodi di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoStructureDescriptor.Find

Metodo PackAndGoStructureDescriptorFind

Ritorna se esisto il descrittore nodo corrispondente al nodo passato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Find(
    string fullFileName,
    string config
)
Public Function Find (
    fullFileName As String,
    config As String
) As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ Find(
    String^ fullFileName,
    String^ config
)
member Find :
        fullFileName : string *
        config : string -> PackAndGoNodeDescriptor

Parametri

fullFileName
Tipo: SystemString
Percorso del file da utilizzare per la ricerca
config
Tipo: SystemString

Valore di ritorno

Tipo: PackAndGoNodeDescriptor
Oggetto nodo descrittore, oppure null se l'oggetto non viene trovato
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoStructureDescriptor.GetCurrentImportAction

Metodo PackAndGoStructureDescriptorGetCurrentImportAction

Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor pckNdDescr,
    string currentFullFileName,
    PackAndGoImportDedCases dedcase
)
Public Function GetCurrentImportAction (
    pckNdDescr As PackAndGoNodeDescriptor,
    currentFullFileName As String,
    dedcase As PackAndGoImportDedCases
) As PackAndGoImportOperation
public:
PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor^ pckNdDescr,
    String^ currentFullFileName,
    PackAndGoImportDedCases dedcase
)
member GetCurrentImportAction :
        pckNdDescr : PackAndGoNodeDescriptor *
        currentFullFileName : string *
        dedcase : PackAndGoImportDedCases -> PackAndGoImportOperation

Parametri

pckNdDescr
Tipo: DedNetInv.CommandsPackAndGoNodeDescriptor
currentFullFileName
Tipo: SystemString
dedcase
Tipo: DedNetInv.CommandsPackAndGoImportDedCases

Valore di ritorno

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Metodo PackAndGoStructureDescriptor.SerializeMe

Metodo PackAndGoStructureDescriptorSerializeMe

Metodo per la serializzazione dell'oggetto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SerializeMe(
    string fn
)
Public Sub SerializeMe (
    fn As String
)
public:
void SerializeMe(
    String^ fn
)
member SerializeMe :
        fn : string -> unit

Parametri

fn
Tipo: SystemString
file name da scrivere
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor
Namespace DedNetInv.Commands


Classe Pubblica
Comando di checkin dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPubblica

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Pubblica : InvCommandBase
Public Class Pubblica
    Inherits InvCommandBase
public ref class Pubblica : public InvCommandBase
type Pubblica =
    class
        inherit InvCommandBase
    end

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Pubblica

Il tipo Pubblica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Proprietà Pubblica.NeedParameters

Proprietà PubblicaNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Metodi di Pubblica

Il tipo Pubblica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Metodo Pubblica.ClearCommand

Metodo PubblicaClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Metodo Pubblica.ExecuteCommand

Metodo PubblicaExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Metodo Pubblica.InvEnabled

Metodo PubblicaInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Metodo Pubblica.InvSetContext

Metodo PubblicaInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Pubblica
Namespace DedNetInv.Commands


Classe PublishProject
Permette di salvare il progetto di Inventor presente n locale sul server.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPublishProject

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishProject : InvCommandBase
Public Class PublishProject
    Inherits InvCommandBase
public ref class PublishProject : public InvCommandBase
type PublishProject =
    class
        inherit InvCommandBase
    end

Il tipo PublishProject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di PublishProject

Il tipo PublishProject espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Proprietà PublishProject.NeedParameters

Proprietà PublishProjectNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Metodi di PublishProject

Il tipo PublishProject espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Metodo PublishProject.ClearCommand

Metodo PublishProjectClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Metodo PublishProject.ExecuteCommand

Metodo PublishProjectExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Metodo PublishProject.InvEnabled

Metodo PublishProjectInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Metodo PublishProject.InvSetContext

Metodo PublishProjectInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishProject
Namespace DedNetInv.Commands


Classe PublishSparePartsDrawing
Comando che pubblica una tavola tecnica ricambi in formato pdf.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPublishSparePartsDrawing

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishSparePartsDrawing : InvCommandBase
Public Class PublishSparePartsDrawing
    Inherits InvCommandBase
public ref class PublishSparePartsDrawing : public InvCommandBase
type PublishSparePartsDrawing =
    class
        inherit InvCommandBase
    end

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Proprietà PublishSparePartsDrawing.Data

Proprietà PublishSparePartsDrawingData

Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Proprietà PublishSparePartsDrawing.Document

Proprietà PublishSparePartsDrawingDocument

Documento che si vuole pubblicare in formato pdf.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Proprietà PublishSparePartsDrawing.NeedParameters

Proprietà PublishSparePartsDrawingNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodi di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.ClearCommand

Metodo PublishSparePartsDrawingClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.Enabled

Metodo PublishSparePartsDrawingEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.ExecuteCommand

Metodo PublishSparePartsDrawingExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.InvEnabled

Metodo PublishSparePartsDrawingInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.InvSetContext

Metodo PublishSparePartsDrawingInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Metodo PublishSparePartsDrawing.SetContext

Metodo PublishSparePartsDrawingSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing
Namespace DedNetInv.Commands


Classe PwsCache
Apre la gestione dell'area locale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsPwsCache

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PwsCache : InvCommandBase
Public Class PwsCache
    Inherits InvCommandBase
public ref class PwsCache : public InvCommandBase
type PwsCache =
    class
        inherit InvCommandBase
    end

Il tipo PwsCache espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di PwsCache

Il tipo PwsCache espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Proprietà PwsCache.NeedParameters

Proprietà PwsCacheNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Metodi di PwsCache

Il tipo PwsCache espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Metodo PwsCache.ClearCommand

Metodo PwsCacheClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Metodo PwsCache.ExecuteCommand

Metodo PwsCacheExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Metodo PwsCache.InvEnabled

Metodo PwsCacheInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Metodo PwsCache.InvSetContext

Metodo PwsCacheInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PwsCache
Namespace DedNetInv.Commands


Classe Registra
Comando di registrazione del documento nel database
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsRegistra

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Registra : InvCommandBase
Public Class Registra
    Inherits InvCommandBase
public ref class Registra : public InvCommandBase
type Registra =
    class
        inherit InvCommandBase
    end

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Registra

Il tipo Registra espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Proprietà Registra.NeedParameters

Proprietà RegistraNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Metodi di Registra

Il tipo Registra espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Metodo Registra.ClearCommand

Metodo RegistraClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Metodo Registra.ExecuteCommand

Metodo RegistraExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Metodo Registra.InvEnabled

Metodo RegistraInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Metodo Registra.InvSetContext

Metodo RegistraInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Registra
Namespace DedNetInv.Commands


Classe ReleaseFactoryMember
Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi rilascia tutti i componenti
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsReleaseFactoryMember

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ReleaseFactoryMember : InvCommandBase
Public Class ReleaseFactoryMember
    Inherits InvCommandBase
public ref class ReleaseFactoryMember : public InvCommandBase
type ReleaseFactoryMember =
    class
        inherit InvCommandBase
    end

Il tipo ReleaseFactoryMember espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di ReleaseFactoryMember

Il tipo ReleaseFactoryMember espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ReleaseFactoryMember
Namespace DedNetInv.Commands


Metodi di ReleaseFactoryMember

Il tipo ReleaseFactoryMember espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe ReleaseFactoryMember
Namespace DedNetInv.Commands


Metodo ReleaseFactoryMember.ExecuteCommand

Metodo ReleaseFactoryMemberExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe ReleaseFactoryMember
Namespace DedNetInv.Commands


Metodo ReleaseFactoryMember.InvEnabled

Metodo ReleaseFactoryMemberInvEnabled

Abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ReleaseFactoryMember
Namespace DedNetInv.Commands


Metodo ReleaseFactoryMember.InvSetContext

Metodo ReleaseFactoryMemberInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ReleaseFactoryMember
Namespace DedNetInv.Commands


Classe Ricerca
Apre finestra per la ricerca.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsRicerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Ricerca : InvCommandBase
Public Class Ricerca
    Inherits InvCommandBase
public ref class Ricerca : public InvCommandBase
type Ricerca =
    class
        inherit InvCommandBase
    end

Il tipo Ricerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CloseDialogOnQuit |
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di ricerca. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Ricerca

Il tipo Ricerca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CloseDialogOnQuit |
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Proprietà Ricerca.CloseDialogOnQuit

Proprietà RicercaCloseDialogOnQuit

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CloseDialogOnQuit { set; }
Public WriteOnly Property CloseDialogOnQuit As Boolean
    Set
public:
property bool CloseDialogOnQuit {
    void set (bool value);
}
member CloseDialogOnQuit : bool with set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Metodi di Ricerca

Il tipo Ricerca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di ricerca. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando è sempre abilitato. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Metodo Ricerca.ExecuteCommand

Metodo RicercaExecuteCommand

Lancia il comando di ricerca.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Metodo Ricerca.InvEnabled

Metodo RicercaInvEnabled

Restituisce sempre true perché il comando è sempre abilitato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Metodo Ricerca.InvSetContext

Metodo RicercaInvSetContext

Restituisce sempre true perché il comando è sempre abilitato e non necessita di inizializzazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Ricerca
Namespace DedNetInv.Commands


Classe Rilascia
Comando rilascio ( solo in modalità STANDARD )
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsRilascia

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Rilascia : CambiaStato
Public Class Rilascia
    Inherits CambiaStato
public ref class Rilascia : public CambiaStato
type Rilascia =
    class
        inherit CambiaStato
    end

Il tipo Rilascia espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Rilascia | Costruttore unico. Implementa il costruttore base con il target state del rilascio
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore Rilascia

Costruttore unico. Implementa il costruttore base con il target state del rilascio

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Rilascia(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
Rilascia(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> Rilascia

Parametri

app
Tipo: DedNetApplication
internalName
Tipo: SystemString
displayName
Tipo: SystemString
multiple
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetInv.Commands


Proprietà di Rilascia

Il tipo Rilascia espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetInv.Commands


Metodi di Rilascia

Il tipo Rilascia espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Rilascia
Namespace DedNetInv.Commands


Classe Salva
Salva il documento attivo o l'occorrenza selezionata nel Database.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalva

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Salva : InvCommandBase
Public Class Salva
    Inherits InvCommandBase
public ref class Salva : public InvCommandBase
type Salva =
    class
        inherit InvCommandBase
    end

Il tipo Salva espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocStructInfo | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Nuova anagrafica risultante dal comando
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Restituisce o imposta se, nel caso di Salva Parte nel DB, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Salva

Il tipo Salva espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocStructInfo | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Nuova anagrafica risultante dal comando
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Restituisce o imposta se, nel caso di Salva Parte nel DB, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.CreazioneVariante

Proprietà SalvaCreazioneVariante

Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.DocStructInfo

Proprietà SalvaDocStructInfo

Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo DocStructInfo { get; set; }
Public Property DocStructInfo As InvDocStructInfo
    Get
    Set
public:
property InvDocStructInfo^ DocStructInfo {
    InvDocStructInfo^ get ();
    void set (InvDocStructInfo^ value);
}
member DocStructInfo : InvDocStructInfo with get, set

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.InvDoc

Proprietà SalvaInvDoc

Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; set; }
Public Property InvDoc As Document
    Get
    Set
public:
property Document^ InvDoc {
    Document^ get ();
    void set (Document^ value);
}
member InvDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.InvOcc

Proprietà SalvaInvOcc

Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence InvOcc { get; set; }
Public Property InvOcc As ComponentOccurrence
    Get
    Set
public:
property ComponentOccurrence^ InvOcc {
    ComponentOccurrence^ get ();
    void set (ComponentOccurrence^ value);
}
member InvOcc : ComponentOccurrence with get, set

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.IsSavePrt

Proprietà SalvaIsSavePrt

Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.NeedParameters

Proprietà SalvaNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.NewData

Proprietà SalvaNewData

Nuova anagrafica risultante dal comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.ReplaceAll

Proprietà SalvaReplaceAll

Restituisce o imposta se, nel caso di Salva Parte nel DB, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.SaveCommand

Proprietà SalvaSaveCommand

Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

Tipo: SaveCommand
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Proprietà Salva.TopDocument

Proprietà SalvaTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodi di Salva

Il tipo Salva espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.ClearCommand

Metodo SalvaClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.Equals

Metodo SalvaEquals

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.ExecuteCommand

Metodo SalvaExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.GetHashCode

Metodo SalvaGetHashCode

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.InvEnabled

Metodo SalvaInvEnabled

Verifica l'abilitazione del comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.InvSetContext

Metodo SalvaInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Metodo Salva.ToString

Metodo SalvaToString

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Salva
Namespace DedNetInv.Commands


Classe SalvaConf
Salva il documento attivo o l'occorrenza selezionata nel Database.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalvaConf

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaConf : InvCommandBase
Public Class SalvaConf
    Inherits InvCommandBase
public ref class SalvaConf : public InvCommandBase
type SalvaConf =
    class
        inherit InvCommandBase
    end

Il tipo SalvaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocStructInfo | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Nuova anagrafica risultante dal comando
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SalvaConf

Il tipo SalvaConf espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocStructInfo | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Nuova anagrafica risultante dal comando
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.CreazioneVariante

Proprietà SalvaConfCreazioneVariante

Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.DocStructInfo

Proprietà SalvaConfDocStructInfo

Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo DocStructInfo { get; set; }
Public Property DocStructInfo As InvDocStructInfo
    Get
    Set
public:
property InvDocStructInfo^ DocStructInfo {
    InvDocStructInfo^ get ();
    void set (InvDocStructInfo^ value);
}
member DocStructInfo : InvDocStructInfo with get, set

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.InvDoc

Proprietà SalvaConfInvDoc

Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva nel DB. Nel caso di salva parte è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; set; }
Public Property InvDoc As Document
    Get
    Set
public:
property Document^ InvDoc {
    Document^ get ();
    void set (Document^ value);
}
member InvDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.InvOcc

Proprietà SalvaConfInvOcc

Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte nel DB. Nel caso di salva documento si deve lasciare impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence InvOcc { get; set; }
Public Property InvOcc As ComponentOccurrence
    Get
    Set
public:
property ComponentOccurrence^ InvOcc {
    ComponentOccurrence^ get ();
    void set (ComponentOccurrence^ value);
}
member InvOcc : ComponentOccurrence with get, set

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.IsSavePrt

Proprietà SalvaConfIsSavePrt

Restituisce se il comando stia lavorando come Salva Parte nel DB o come Salva nel DB. Questo comportamento è predeterminato dal metodo costruttore del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.NeedParameters

Proprietà SalvaConfNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.NewData

Proprietà SalvaConfNewData

Nuova anagrafica risultante dal comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.SaveCommand

Proprietà SalvaConfSaveCommand

Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

Tipo: SaveCommand
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Proprietà SalvaConf.TopDocument

Proprietà SalvaConfTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte oppure che coincide con l'InvDoc nel caso di salva nel Database.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodi di SalvaConf

Il tipo SalvaConf espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.ClearCommand

Metodo SalvaConfClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.Equals

Metodo SalvaConfEquals

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.ExecuteCommand

Metodo SalvaConfExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.GetHashCode

Metodo SalvaConfGetHashCode

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.InvEnabled

Metodo SalvaConfInvEnabled

Verifica l'abilitazione del comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.InvSetContext

Metodo SalvaConfInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Metodo SalvaConf.ToString

Metodo SalvaConfToString

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe SalvaConf
Namespace DedNetInv.Commands


Classe SalvaDist
Salva la distinta
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalvaDist

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaDist : InvCommandBase
Public Class SalvaDist
    Inherits InvCommandBase
public ref class SalvaDist : public InvCommandBase
type SalvaDist =
    class
        inherit InvCommandBase
    end

Il tipo SalvaDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Imposta se il comando deve funzionare in modalità lazy. In questo caso gli elementi senza anagrafica collegata e non codificabili vengono esclusi dal salvataggio senza produrre eccezioni.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | MultiLevel | Imposta se salvare la distinta multilivello o no.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveDistOnApproved | Indica se il Salva distinta è stato chiamato dal Ded in fase di approvazione
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Ovverride del (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva distinta (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SalvaDist

Il tipo SalvaDist espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Imposta se il comando deve funzionare in modalità lazy. In questo caso gli elementi senza anagrafica collegata e non codificabili vengono esclusi dal salvataggio senza produrre eccezioni.
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | MultiLevel | Imposta se salvare la distinta multilivello o no.
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | SaveDistOnApproved | Indica se il Salva distinta è stato chiamato dal Ded in fase di approvazione
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Proprietà SalvaDist.LazyMode

Proprietà SalvaDistLazyMode

Imposta se il comando deve funzionare in modalità lazy. In questo caso gli elementi senza anagrafica collegata e non codificabili vengono esclusi dal salvataggio senza produrre eccezioni.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LazyMode { get; set; }
Public Property LazyMode As Boolean
    Get
    Set
public:
property bool LazyMode {
    bool get ();
    void set (bool value);
}
member LazyMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Proprietà SalvaDist.MultiLevel

Proprietà SalvaDistMultiLevel

Imposta se salvare la distinta multilivello o no.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MultiLevel { get; set; }
Public Property MultiLevel As Boolean
    Get
    Set
public:
property bool MultiLevel {
    bool get ();
    void set (bool value);
}
member MultiLevel : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Proprietà SalvaDist.SaveDistOnApproved

Proprietà SalvaDistSaveDistOnApproved

Indica se il Salva distinta è stato chiamato dal Ded in fase di approvazione

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SaveDistOnApproved { get; set; }
Public Property SaveDistOnApproved As Boolean
    Get
    Set
public:
property bool SaveDistOnApproved {
    bool get ();
    void set (bool value);
}
member SaveDistOnApproved : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Metodi di SalvaDist

Il tipo SalvaDist espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Ovverride del (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva distinta (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Metodo SalvaDist.ClearCommand

Metodo SalvaDistClearCommand

Ovverride del

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Metodo SalvaDist.ExecuteCommand

Metodo SalvaDistExecuteCommand

Lancia il comando di salva distinta

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Metodo SalvaDist.InvEnabled

Metodo SalvaDistInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Metodo SalvaDist.InvSetContext

Metodo SalvaDistInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaDist
Namespace DedNetInv.Commands


Classe SalvaMultiplo
Comando salvataggio multiplo elementi dell'assieme
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalvaMultiplo

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaMultiplo : InvCommandBase
Public Class SalvaMultiplo
    Inherits InvCommandBase
public ref class SalvaMultiplo : public InvCommandBase
type SalvaMultiplo =
    class
        inherit InvCommandBase
    end

Il tipo SalvaMultiplo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva multiplo. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SalvaMultiplo

Il tipo SalvaMultiplo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Proprietà SalvaMultiplo.NeedParameters

Proprietà SalvaMultiploNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Metodi di SalvaMultiplo

Il tipo SalvaMultiplo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva multiplo. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Metodo SalvaMultiplo.ClearCommand

Metodo SalvaMultiploClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Metodo SalvaMultiplo.ExecuteCommand

Metodo SalvaMultiploExecuteCommand

Lancia il comando di salva multiplo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Metodo SalvaMultiplo.InvEnabled

Metodo SalvaMultiploInvEnabled

Verifica l'abilitazione del comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Metodo SalvaMultiplo.InvSetContext

Metodo SalvaMultiploInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaMultiplo
Namespace DedNetInv.Commands


Classe SalvaPartBody
Salvataggio diretto di un part body nel database
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalvaPartBody

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaPartBody : InvCommandBase
Public Class SalvaPartBody
    Inherits InvCommandBase
public ref class SalvaPartBody : public InvCommandBase
type SalvaPartBody =
    class
        inherit InvCommandBase
    end

Il tipo SalvaPartBody espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva multiplo. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SalvaPartBody

Il tipo SalvaPartBody espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Proprietà SalvaPartBody.NeedParameters

Proprietà SalvaPartBodyNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Metodi di SalvaPartBody

Il tipo SalvaPartBody espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva multiplo. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Metodo SalvaPartBody.ClearCommand

Metodo SalvaPartBodyClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Metodo SalvaPartBody.ExecuteCommand

Metodo SalvaPartBodyExecuteCommand

Lancia il comando di salva multiplo.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Metodo SalvaPartBody.InvEnabled

Metodo SalvaPartBodyInvEnabled

Verifica l'abilitazione del comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Metodo SalvaPartBody.InvSetContext

Metodo SalvaPartBodyInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaPartBody
Namespace DedNetInv.Commands


Classe SalvaRev
Salva la nuova revisione dei documenti.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSalvaRev

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaRev : InvCommandBase
Public Class SalvaRev
    Inherits InvCommandBase
public ref class SalvaRev : public InvCommandBase
type SalvaRev =
    class
        inherit InvCommandBase
    end

Il tipo SalvaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva revisione. Nel caso di salva parte revisione è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte Revisione. Nel caso di salva revisione si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte Revisione o come Salva Revisione. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Restituisce o imposta se, nel caso di Salva Parte Revisione, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RevCommand | Restituisce il comando sotteso per la creazione della revisione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte revisione oppure che coincide con l'InvDoc nel caso di salva revisione.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SalvaRev

Il tipo SalvaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | InvDoc | Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva revisione. Nel caso di salva parte revisione è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.
Proprietà pubblica | InvOcc | Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte Revisione. Nel caso di salva revisione si deve lasciare impostata a null.
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce se il comando stia lavorando come Salva Parte Revisione o come Salva Revisione. Questo comportamento è predeterminato dal metodo costruttore del comando.
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Restituisce o imposta se, nel caso di Salva Parte Revisione, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RevCommand | Restituisce il comando sotteso per la creazione della revisione.
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopDocument | Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte revisione oppure che coincide con l'InvDoc nel caso di salva revisione.
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.CurData

Proprietà SalvaRevCurData

Restituisce l'anagrafica di partenza del documento in salvataggio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData CurData { get; }
Public ReadOnly Property CurData As DedData
    Get
public:
property DedData^ CurData {
    DedData^ get ();
}
member CurData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.InvDoc

Proprietà SalvaRevInvDoc

Restituisce o imposta il documento da salvare. Da impostare solo nel caso di Salva revisione. Nel caso di salva parte revisione è il comando che vi imposta il documento sotteso all'occorrenza da salvare, quindi lasciarla impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document InvDoc { get; set; }
Public Property InvDoc As Document
    Get
    Set
public:
property Document^ InvDoc {
    Document^ get ();
    void set (Document^ value);
}
member InvDoc : Document with get, set

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.InvOcc

Proprietà SalvaRevInvOcc

Restituisce o imposta l'occorrenza da salvare. Da impostare solo nel caso di Salva Parte Revisione. Nel caso di salva revisione si deve lasciare impostata a null.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComponentOccurrence InvOcc { get; set; }
Public Property InvOcc As ComponentOccurrence
    Get
    Set
public:
property ComponentOccurrence^ InvOcc {
    ComponentOccurrence^ get ();
    void set (ComponentOccurrence^ value);
}
member InvOcc : ComponentOccurrence with get, set

Valore della proprietà

Tipo: ComponentOccurrence
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.IsSavePrt

Proprietà SalvaRevIsSavePrt

Restituisce se il comando stia lavorando come Salva Parte Revisione o come Salva Revisione. Questo comportamento è predeterminato dal metodo costruttore del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; }
Public ReadOnly Property IsSavePrt As Boolean
    Get
public:
property bool IsSavePrt {
    bool get ();
}
member IsSavePrt : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.NeedParameters

Proprietà SalvaRevNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.NewData

Proprietà SalvaRevNewData

Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.ReplaceAll

Proprietà SalvaRevReplaceAll

Restituisce o imposta se, nel caso di Salva Parte Revisione, si debba sostituire tutte le occorrenze presenti nell'assieme attivo. Di default è true, ma se il comando viene eseguito con user interface abilitata viene chiesta conferma all'utente, nel caso di presenza di più occorrenze da sostituire.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.RevCommand

Proprietà SalvaRevRevCommand

Restituisce il comando sotteso per la creazione della revisione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public RevCommand RevCommand { get; set; }
Public Property RevCommand As RevCommand
    Get
    Set
public:
property RevCommand^ RevCommand {
    RevCommand^ get ();
    void set (RevCommand^ value);
}
member RevCommand : RevCommand with get, set

Valore della proprietà

Tipo: RevCommand
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Proprietà SalvaRev.TopDocument

Proprietà SalvaRevTopDocument

Restituisce il Documento correntemente attivo che è di tipo assieme nel caso di salva parte revisione oppure che coincide con l'InvDoc nel caso di salva revisione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Document TopDocument { get; }
Public ReadOnly Property TopDocument As Document
    Get
public:
property Document^ TopDocument {
    Document^ get ();
}
member TopDocument : Document with get

Valore della proprietà

Tipo: Document
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodi di SalvaRev

Il tipo SalvaRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.ClearCommand

Metodo SalvaRevClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.Equals

Metodo SalvaRevEquals

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.ExecuteCommand

Metodo SalvaRevExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.GetHashCode

Metodo SalvaRevGetHashCode

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.InvEnabled

Metodo SalvaRevInvEnabled

Verifica l'abilitazione del comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.InvSetContext

Metodo SalvaRevInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Metodo SalvaRev.ToString

Metodo SalvaRevToString

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe SalvaRev
Namespace DedNetInv.Commands


Classe SalvaSuperato
Comando SalvaSuperato ( solo in modalità STANDARD )
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsCambiaStato
DedNetInv.CommandsSalvaSuperato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SalvaSuperato : CambiaStato
Public Class SalvaSuperato
    Inherits CambiaStato
public ref class SalvaSuperato : public CambiaStato
type SalvaSuperato =
    class
        inherit CambiaStato
    end

Il tipo SalvaSuperato espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | SalvaSuperato | Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Costruttore SalvaSuperato

Costruttore unico. Implementa il costruttore base con il target state relativo allo stato di partenza

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SalvaSuperato(
    DedNetApplication app,
    string internalName,
    string displayName,
    bool multiple
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    displayName As String,
    multiple As Boolean
)
public:
SalvaSuperato(
    DedNetApplication^ app,
    String^ internalName,
    String^ displayName,
    bool multiple
)
new :
        app : DedNetApplication *
        internalName : string *
        displayName : string *
        multiple : bool -> SalvaSuperato

Parametri

app
Tipo: DedNetApplication
internalName
Tipo: SystemString
displayName
Tipo: SystemString
multiple
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetInv.Commands


Proprietà di SalvaSuperato

Il tipo SalvaSuperato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | LazyMode | Restituisce o imposta se il comando deve lavorare in modalità più leggera ovvero senza controllare lo stato dei figli (Ereditato da CambiaStato.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Multiplo | Restituisce e imposta se il comando deve lavorare in modalità multipla (Ereditato da CambiaStato.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetInv.Commands


Metodi di SalvaSuperato

Il tipo SalvaSuperato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da CambiaStato.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando di cambio stato (Ereditato da CambiaStato.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Ereditato da CambiaStato.)
Metodo pubblico | InvSetContext | Settaggio del contesto (Ereditato da CambiaStato.)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SalvaSuperato
Namespace DedNetInv.Commands


Classe SaveFactoryMemberRevision
Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi salva la revisione di tutti componenti
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSaveFactoryMemberRevision

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SaveFactoryMemberRevision : InvCommandBase
Public Class SaveFactoryMemberRevision
    Inherits InvCommandBase
public ref class SaveFactoryMemberRevision : public InvCommandBase
type SaveFactoryMemberRevision =
    class
        inherit InvCommandBase
    end

Il tipo SaveFactoryMemberRevision espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SaveFactoryMemberRevision

Il tipo SaveFactoryMemberRevision espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SaveFactoryMemberRevision
Namespace DedNetInv.Commands


Metodi di SaveFactoryMemberRevision

Il tipo SaveFactoryMemberRevision espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SaveFactoryMemberRevision
Namespace DedNetInv.Commands


Metodo SaveFactoryMemberRevision.ExecuteCommand

Metodo SaveFactoryMemberRevisionExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SaveFactoryMemberRevision
Namespace DedNetInv.Commands


Metodo SaveFactoryMemberRevision.InvEnabled

Metodo SaveFactoryMemberRevisionInvEnabled

Abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SaveFactoryMemberRevision
Namespace DedNetInv.Commands


Metodo SaveFactoryMemberRevision.InvSetContext

Metodo SaveFactoryMemberRevisionInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SaveFactoryMemberRevision
Namespace DedNetInv.Commands


Classe Sblocca
Comando di sblocca dell'addin
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSblocca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Sblocca : InvCommandBase
Public Class Sblocca
    Inherits InvCommandBase
public ref class Sblocca : public InvCommandBase
type Sblocca =
    class
        inherit InvCommandBase
    end

Il tipo Sblocca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di Sblocca

Il tipo Sblocca espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Proprietà Sblocca.NeedParameters

Proprietà SbloccaNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Metodi di Sblocca

Il tipo Sblocca espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Metodo Sblocca.ClearCommand

Metodo SbloccaClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Metodo Sblocca.ExecuteCommand

Metodo SbloccaExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Metodo Sblocca.InvEnabled

Metodo SbloccaInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Metodo Sblocca.InvSetContext

Metodo SbloccaInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Sblocca
Namespace DedNetInv.Commands


Classe SostituisciComponente
Esegue la sostituzione con interfaccia partendo dalla selezione dell'oggetto da sostituire e mostrando il form di opzioni.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSostituisciComponente

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciComponente : InvCommandBase
Public Class SostituisciComponente
    Inherits InvCommandBase
public ref class SostituisciComponente : public InvCommandBase
type SostituisciComponente =
    class
        inherit InvCommandBase
    end

Il tipo SostituisciComponente espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form di sostituzione. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SostituisciComponente

Il tipo SostituisciComponente espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Form | Restituisce il Form di sostituzione. Può essere null se il comando non è ancora stato lanciato.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Proprietà SostituisciComponente.Form

Proprietà SostituisciComponenteForm

Restituisce il Form di sostituzione. Può essere null se il comando non è ancora stato lanciato.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvReplaceComponentForm Form { get; }
Public ReadOnly Property Form As DedInvReplaceComponentForm
    Get
public:
property DedInvReplaceComponentForm^ Form {
    DedInvReplaceComponentForm^ get ();
}
member Form : DedInvReplaceComponentForm with get

Valore della proprietà

Tipo: DedInvReplaceComponentForm
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Proprietà SostituisciComponente.NeedParameters

Proprietà SostituisciComponenteNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Metodi di SostituisciComponente

Il tipo SostituisciComponente espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Metodo SostituisciComponente.ExecuteCommand

Metodo SostituisciComponenteExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Metodo SostituisciComponente.InvEnabled

Metodo SostituisciComponenteInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Metodo SostituisciComponente.InvSetContext

Metodo SostituisciComponenteInvSetContext

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponente
Namespace DedNetInv.Commands


Classe SostituisciComponenteDerivato
Permette di sostituire il modello di base di un componente derivato
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSostituisciComponenteDerivato

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciComponenteDerivato : InvCommandBase
Public Class SostituisciComponenteDerivato
    Inherits InvCommandBase
public ref class SostituisciComponenteDerivato : public InvCommandBase
type SostituisciComponenteDerivato =
    class
        inherit InvCommandBase
    end

Il tipo SostituisciComponenteDerivato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SostituisciComponenteDerivato

Il tipo SostituisciComponenteDerivato espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteDerivato.DocInfo

Proprietà SostituisciComponenteDerivatoDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteDerivato.NeedParameters

Proprietà SostituisciComponenteDerivatoNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Metodi di SostituisciComponenteDerivato

Il tipo SostituisciComponenteDerivato espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Metodo SostituisciComponenteDerivato.ClearCommand

Metodo SostituisciComponenteDerivatoClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Metodo SostituisciComponenteDerivato.ExecuteCommand

Metodo SostituisciComponenteDerivatoExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Metodo SostituisciComponenteDerivato.InvEnabled

Metodo SostituisciComponenteDerivatoInvEnabled

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Metodo SostituisciComponenteDerivato.InvSetContext

Metodo SostituisciComponenteDerivatoInvSetContext

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteDerivato
Namespace DedNetInv.Commands


Classe SostituisciComponenteRapido
Esegua la sostituzione in modalità di selezione dell'oggetto di sostituzione sulla selezione attiva a documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSostituisciComponenteRapido

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciComponenteRapido : InvCommandBase
Public Class SostituisciComponenteRapido
    Inherits InvCommandBase
public ref class SostituisciComponenteRapido : public InvCommandBase
type SostituisciComponenteRapido =
    class
        inherit InvCommandBase
    end

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.
Proprietà pubblica | ReplaceAllSameParent | Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione comando inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Set context di inventor (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SostituisciComponenteRapido

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | ReplaceAll | Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.
Proprietà pubblica | ReplaceAllSameParent | Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteRapido.DocInfo

Proprietà SostituisciComponenteRapidoDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteRapido.NeedParameters

Proprietà SostituisciComponenteRapidoNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteRapido.ReplaceAll

Proprietà SostituisciComponenteRapidoReplaceAll

Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAll { get; set; }
Public Property ReplaceAll As Boolean
    Get
    Set
public:
property bool ReplaceAll {
    bool get ();
    void set (bool value);
}
member ReplaceAll : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Proprietà SostituisciComponenteRapido.ReplaceAllSameParent

Proprietà SostituisciComponenteRapidoReplaceAllSameParent

Imposta/ Restituisce se si tratta di un comando di sostituzione selezione o tutti.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReplaceAllSameParent { get; set; }
Public Property ReplaceAllSameParent As Boolean
    Get
    Set
public:
property bool ReplaceAllSameParent {
    bool get ();
    void set (bool value);
}
member ReplaceAllSameParent : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodi di SostituisciComponenteRapido

Il tipo SostituisciComponenteRapido espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione comando inventor (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Set context di inventor (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.ClearCommand

Metodo SostituisciComponenteRapidoClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.Enabled

Metodo SostituisciComponenteRapidoEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.ExecuteCommand

Metodo SostituisciComponenteRapidoExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.InvEnabled

Metodo SostituisciComponenteRapidoInvEnabled

Abilitazione comando inventor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.InvSetContext

Metodo SostituisciComponenteRapidoInvSetContext

Set context di inventor

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Metodo SostituisciComponenteRapido.SetContext

Metodo SostituisciComponenteRapidoSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciComponenteRapido
Namespace DedNetInv.Commands


Classe SostituisciMoved
Comando di registrazione del documento nel database
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSostituisciMoved

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciMoved : InvCommandBase
Public Class SostituisciMoved
    Inherits InvCommandBase
public ref class SostituisciMoved : public InvCommandBase
type SostituisciMoved =
    class
        inherit InvCommandBase
    end

Il tipo SostituisciMoved espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SostituisciMoved

Il tipo SostituisciMoved espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Proprietà SostituisciMoved.NeedParameters

Proprietà SostituisciMovedNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Metodi di SostituisciMoved

Il tipo SostituisciMoved espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Metodo SostituisciMoved.ClearCommand

Metodo SostituisciMovedClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Metodo SostituisciMoved.ExecuteCommand

Metodo SostituisciMovedExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Metodo SostituisciMoved.InvEnabled

Metodo SostituisciMovedInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Metodo SostituisciMoved.InvSetContext

Metodo SostituisciMovedInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciMoved
Namespace DedNetInv.Commands


Classe SostituisciRiferimenti
Permette di associare una messa in tavola esistente al documento correntemente aperto.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsSostituisciRiferimenti

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class SostituisciRiferimenti : InvCommandBase
Public Class SostituisciRiferimenti
    Inherits InvCommandBase
public ref class SostituisciRiferimenti : public InvCommandBase
type SostituisciRiferimenti =
    class
        inherit InvCommandBase
    end

Il tipo SostituisciRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di SostituisciRiferimenti

Il tipo SostituisciRiferimenti espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni di selezione da ricerca
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Proprietà SostituisciRiferimenti.DocInfo

Proprietà SostituisciRiferimentiDocInfo

Restituisce o imposta le informazioni di selezione da ricerca

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Proprietà SostituisciRiferimenti.NeedParameters

Proprietà SostituisciRiferimentiNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodi di SostituisciRiferimenti

Il tipo SostituisciRiferimenti espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive InvCommandBaseEnabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esecuzione del comando (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive InvCommandBaseSetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.ClearCommand

Metodo SostituisciRiferimentiClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.Enabled

Metodo SostituisciRiferimentiEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.ExecuteCommand

Metodo SostituisciRiferimentiExecuteCommand

Esecuzione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.InvEnabled

Metodo SostituisciRiferimentiInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.InvSetContext

Metodo SostituisciRiferimentiInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Metodo SostituisciRiferimenti.SetContext

Metodo SostituisciRiferimentiSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe SostituisciRiferimenti
Namespace DedNetInv.Commands


Classe StatoDocumento
Comando di per visualizzare lo stato del documento attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsStatoDocumento

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class StatoDocumento : InvCommandBase
Public Class StatoDocumento
    Inherits InvCommandBase
public ref class StatoDocumento : public InvCommandBase
type StatoDocumento =
    class
        inherit InvCommandBase
    end

Il tipo StatoDocumento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di StatoDocumento

Il tipo StatoDocumento espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Metodi di StatoDocumento

Il tipo StatoDocumento espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Metodo StatoDocumento.ClearCommand

Metodo StatoDocumentoClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Metodo StatoDocumento.ExecuteCommand

Metodo StatoDocumentoExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Metodo StatoDocumento.InvEnabled

Metodo StatoDocumentoInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Metodo StatoDocumento.InvSetContext

Metodo StatoDocumentoInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe StatoDocumento
Namespace DedNetInv.Commands


Classe TabellaRevisioni
Apre la tabella delle revisioni.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsTabellaRevisioni

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class TabellaRevisioni : InvCommandBase
Public Class TabellaRevisioni
    Inherits InvCommandBase
public ref class TabellaRevisioni : public InvCommandBase
type TabellaRevisioni =
    class
        inherit InvCommandBase
    end

Il tipo TabellaRevisioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di TabellaRevisioni

Il tipo TabellaRevisioni espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Proprietà TabellaRevisioni.NeedParameters

Proprietà TabellaRevisioniNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Metodi di TabellaRevisioni

Il tipo TabellaRevisioni espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce sempre true perché il comando funziona anche senza parametri. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Metodo TabellaRevisioni.ClearCommand

Metodo TabellaRevisioniClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Metodo TabellaRevisioni.ExecuteCommand

Metodo TabellaRevisioniExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Metodo TabellaRevisioni.InvEnabled

Metodo TabellaRevisioniInvEnabled

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Metodo TabellaRevisioni.InvSetContext

Metodo TabellaRevisioniInvSetContext

Restituisce sempre true perché il comando funziona anche senza parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe TabellaRevisioni
Namespace DedNetInv.Commands


Classe UpdateBranchInformations
Comando che aggiorna il ramo selezionato in caso di moldalità velocizzata per VPN.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsUpdateBranchInformations

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateBranchInformations : InvCommandBase
Public Class UpdateBranchInformations
    Inherits InvCommandBase
public ref class UpdateBranchInformations : public InvCommandBase
type UpdateBranchInformations =
    class
        inherit InvCommandBase
    end

Il tipo UpdateBranchInformations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di UpdateBranchInformations

Il tipo UpdateBranchInformations espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetInv.Commands


Metodi di UpdateBranchInformations

Il tipo UpdateBranchInformations espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetInv.Commands


Metodo UpdateBranchInformations.ExecuteCommand

Metodo UpdateBranchInformationsExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetInv.Commands


Metodo UpdateBranchInformations.InvEnabled

Metodo UpdateBranchInformationsInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetInv.Commands


Metodo UpdateBranchInformations.InvSetContext

Metodo UpdateBranchInformationsInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateBranchInformations
Namespace DedNetInv.Commands


Classe UpdateMembersFromFactory
Data una iPartFactory registrata, estrapola tutti i collegamenti con i member tramite where used e quindi procedo all'aggiornamento di ognuno.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsUpdateMembersFromFactory

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateMembersFromFactory : InvCommandBase
Public Class UpdateMembersFromFactory
    Inherits InvCommandBase
public ref class UpdateMembersFromFactory : public InvCommandBase
type UpdateMembersFromFactory =
    class
        inherit InvCommandBase
    end

Il tipo UpdateMembersFromFactory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di UpdateMembersFromFactory

Il tipo UpdateMembersFromFactory espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando ha bisogno di parametri. Restituisce sempre false. (Ereditato da InvCommandBase.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateMembersFromFactory
Namespace DedNetInv.Commands


Metodi di UpdateMembersFromFactory

Il tipo UpdateMembersFromFactory espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Ereditato da InvCommandBase.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Abilitazione del comando (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateMembersFromFactory
Namespace DedNetInv.Commands


Metodo UpdateMembersFromFactory.ExecuteCommand

Metodo UpdateMembersFromFactoryExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe UpdateMembersFromFactory
Namespace DedNetInv.Commands


Metodo UpdateMembersFromFactory.InvEnabled

Metodo UpdateMembersFromFactoryInvEnabled

Abilitazione del comando

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateMembersFromFactory
Namespace DedNetInv.Commands


Metodo UpdateMembersFromFactory.InvSetContext

Metodo UpdateMembersFromFactoryInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateMembersFromFactory
Namespace DedNetInv.Commands


Classe UpdateOldRev
Apre la finestra per aggiornare le eventuali revisioni superate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsUpdateOldRev

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateOldRev : InvCommandBase
Public Class UpdateOldRev
    Inherits InvCommandBase
public ref class UpdateOldRev : public InvCommandBase
type UpdateOldRev =
    class
        inherit InvCommandBase
    end

Il tipo UpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Proprietà UpdateOldRev.NeedParameters

Proprietà UpdateOldRevNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Metodi di UpdateOldRev

Il tipo UpdateOldRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Metodo UpdateOldRev.ClearCommand

Metodo UpdateOldRevClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Metodo UpdateOldRev.ExecuteCommand

Metodo UpdateOldRevExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Metodo UpdateOldRev.InvEnabled

Metodo UpdateOldRevInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Metodo UpdateOldRev.InvSetContext

Metodo UpdateOldRevInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe UpdateOldRev
Namespace DedNetInv.Commands


Classe VisualaDiagDep
Crea un nuovo comando VisualDep che mostra all'utente l'albero delle dipendenze avanzato.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsVisualaDiagDep

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class VisualaDiagDep : InvCommandBase
Public Class VisualaDiagDep
    Inherits InvCommandBase
public ref class VisualaDiagDep : public InvCommandBase
type VisualaDiagDep =
    class
        inherit InvCommandBase
    end

Il tipo VisualaDiagDep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di VisualaDiagDep

Il tipo VisualaDiagDep espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando sia stato inizializzato o meno. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Proprietà VisualaDiagDep.NeedParameters

Proprietà VisualaDiagDepNeedParameters

Restituisce se il comando sia stato inizializzato o meno.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Metodi di VisualaDiagDep

Il tipo VisualaDiagDep espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera e rigenera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando vero e proprio. (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Restituisce se il comando sia abilitato in base alla selezione. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Restituisce se il comando sia inizializzato correttamente con la selezione corrente. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Metodo VisualaDiagDep.ClearCommand

Metodo VisualaDiagDepClearCommand

Azzera e rigenera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Metodo VisualaDiagDep.ExecuteCommand

Metodo VisualaDiagDepExecuteCommand

Lancia il comando vero e proprio.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Metodo VisualaDiagDep.InvEnabled

Metodo VisualaDiagDepInvEnabled

Restituisce se il comando sia abilitato in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Metodo VisualaDiagDep.InvSetContext

Metodo VisualaDiagDepInvSetContext

Restituisce se il comando sia inizializzato correttamente con la selezione corrente.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe VisualaDiagDep
Namespace DedNetInv.Commands


Classe WhereUsedInv
Comando per visualizzare all'interno di quali documenti è usato un determinato documento
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetInv.CommandsInvCommandBase
DedNetInv.CommandsWhereUsedInv

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class WhereUsedInv : InvCommandBase
Public Class WhereUsedInv
    Inherits InvCommandBase
public ref class WhereUsedInv : public InvCommandBase
type WhereUsedInv =
    class
        inherit InvCommandBase
    end

Il tipo WhereUsedInv espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Commands


Proprietà di WhereUsedInv

Il tipo WhereUsedInv espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AddToolbar | Indica se il comando deve essere aggiunto alla toolbar. (Ereditato da InvCommandBase.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo oggetto appartiene. (Ereditato da DedCommand.)
Proprietà pubblica | Button | Resituisce la definizione del pulsante per questo comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Classification | Restituisce o imposta la classificazione del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Client | Restituisce o imposta le applicazioni client per le quali questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | Restituisce o imposta il Contesto nel quale questo comando è disponibile. (Ereditato da DedCommand.)
Proprietà pubblica | DisplayMode | Restituisce o imposta il tipo di pulsante abbinato il comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | GlobalName | Restituisce o imposta il nome globale da utilizzare per il comando quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è null, in questo caso viene utilizzato il valore di Name. (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | Restituisce o imposta l'indice di ordinamento di questo comando, quando utilizzato come comando globale (es.: DedWin, DedWiew, ecc.). Di default è inizializzato a 1000. (Ereditato da DedCommand.)
Proprietà pubblica | HasTopic | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | Icon16 | Restituisce o imposta l'immagine 16*16 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | Icon32 | Restituisce o imposta l'immagine 32*32 del comando. (Ereditato da InvCommandBase.)
Proprietà pubblica | IgnoreUserPerm | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | Restituisce o imposta l'immagine 16x16 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | Restituisce o imposta l'immagine 32x32 abbinata al comando. (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | Restituisce il nome interno del comando che non varia in base alla lingua locale. (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | Restituisce o imposta se si tratti di una operazione di importazione (eseguita per esempio dal programma Importer.exe). In tal caso il comando si comporta in modo da non effettuare i controlli in modo stretto. (Ereditato da DedCommand.)
Proprietà pubblica | LastException | Restituisce l'ultima eccezione che si è verificata durante l'esecuzione. Restituisce null se non sono avvenuti errori. (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | Restituisce o imposta il permesso minimo necessario per eseguire il comando. (Ereditato da DedCommand.)
Proprietà pubblica | Name | Restituisce il nome visualizzato del comando. (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | Restituisce se questo comando è un comando che lavora sul documento. Questa propritetà viene interrogata nella finestra di dialogo di ricerca codice per sapere se deve espandersi e far selezionare all'utente anche un documento. (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive InvCommandBaseNeedParameters.)
Proprietà pubblica | NeedRefresh | Restituisce se il comando ha modificato l'oggetto sul quale agisce e può esserci necessità di refresh. (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | Restituisce o imposta se ignorare il parent form, per questo comando, nel visualizzare qualsiasi finestra. Viene utilizzato per forzare la non parentela. (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | Restituisce o imposta l'handle del form principale dal quale è stato lanciato il comando. Viene utilizzato come parent delle finestre secondarie e di errore eventualmente visualizzate. (Ereditato da DedCommand.)
Proprietà pubblica | Result | Restituisce il risultato dell'ultima esecuzione. (Ereditato da DedCommand.)
Proprietà pubblica | RunningContext | Indica di ignorare i permessi utente. (Ereditato da DedCommand.)
Proprietà pubblica | Silent | Restituisce o imposta se il comando debba visualizzare o meno i messaggi di conferma o di errore all'utente. Di default è false. (Ereditato da DedCommand.)
Proprietà pubblica | Struttura | Restituisce la lista di documenti inventor da elaborare (Ereditato da InvCommandBase.)
Proprietà pubblica | SubMenuName | Restituisce o imposta il nome del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | Restituisce o imposta il testo del Sottomenu nel quale inserire questo comando. (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | Restituisce o imposta il Tooltip descrittivo del comando. (Ereditato da DedCommand.)
Proprietà pubblica | TopicHelp | Restituisce o imposta il Topic per individuare il comando nell'Help. (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | Restituisce o imposta se, in mancanza di informazioni per l'esecuzione del comando, si debba chiedere all'utente attraverso le apposite finestre di dialogo. Di default è true. (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Proprietà WhereUsedInv.NeedParameters

Proprietà WhereUsedInvNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Metodi di WhereUsedInv

Il tipo WhereUsedInv espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive InvCommandBaseClearCommand.)
Metodo pubblico | CreateButton | Crea l'istanza del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | DisposeButton | Effettua il Dispose del pulsante associato a questo comando. (Ereditato da InvCommandBase.)
Metodo pubblico | Enabled | Restituisce se il comando sia abilitato in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | Execute | Esegue il comando vero e proprio. (Ereditato da InvCommandBase.)
Metodo protetto | ExecuteCommand | Lancia il comando di "Usato in". (Sovrascrive InvCommandBaseExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | Inizializza un sotto-comando con le impostazioni generali presenti in questo. (Ereditato da DedCommand.)
Metodo pubblico | InvEnabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive InvCommandBaseInvEnabled(DedInvCommandContext).)
Metodo pubblico | InvSetContext | Imposta il comando in base alla selezione. (Sovrascrive InvCommandBaseInvSetContext(DedInvCommandContext).)
Metodo pubblico | Run | Esegue il comando. (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | Esegue il comando come sotto-comando ovvero non gestisce la visualizzazione degli errori ma "fa passare" le eccezioni in modo che siano gestite dal chiamante cioè il comando principale. /// (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Restituisce se il comando sia impostabile in base al contesto. Restituisce sempre false perché non è incluso nell'interfaccia utente. (Ereditato da InvCommandBase.)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Metodo WhereUsedInv.ClearCommand

Metodo WhereUsedInvClearCommand

Azzera il comando.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Metodo WhereUsedInv.ExecuteCommand

Metodo WhereUsedInvExecuteCommand

Lancia il comando di "Usato in".

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Metodo WhereUsedInv.InvEnabled

Metodo WhereUsedInvInvEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvEnabled(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvEnabled (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvEnabled(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool
override InvEnabled :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


Metodo WhereUsedInv.InvSetContext

Metodo WhereUsedInvInvSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetInv.Commands
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool InvSetContext(
    DedInvCommandContext invCmdCtx
)
Public Overrides Function InvSetContext (
    invCmdCtx As DedInvCommandContext
) As Boolean
public:
virtual bool InvSetContext(
    DedInvCommandContext^ invCmdCtx
) override
abstract InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool
override InvSetContext :
        invCmdCtx : DedInvCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedNetInv.CommandsDedInvCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe WhereUsedInv
Namespace DedNetInv.Commands


DedNetInv.Forms Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AttributeForm | Form utilizzato per la DockableWindow per editare gli attributi.
Classe pubblica | DedInvDistForm |
Classe pubblica | DedInvDocAssistantForm |
Classe pubblica | DedInvFileResolutorForm |
Classe pubblica | DedInvPackAndGoExportForm |
Classe pubblica | DedInvPackAndGoImportForm |
Classe pubblica | DedInvReplaceComponentForm | Form utilizzato per la DockableWindow per la sostituzione dei componenti
Classe pubblica | DedInvSaveMulipleForm |
Classe pubblica | DedInvSaveMulipleFormMultiSaverModeCriteria | Classe che rappresenta il singolo criterio di salvataggio multipla.
Classe pubblica | DedInvSaveMulipleFormMultiSaverModeCriteriaList | Oggetto insieme di criteri di salvataggio multiplo
Classe pubblica | DedInvSaveMulipleFormMultiSaverNodeDescriptor | Classe rappresentante il descrittore del nodo
Classe pubblica | DedInvSaveMulipleFormMultiSaverNodeDescriptors | Lista dei descrittori del nodo
Classe pubblica | DedInvSubstModelForm |
Classe pubblica | DedInvSubstModelFormReferenceChangeDescriptor | Descrittore della potenziale modifica dei riferimenti
Classe pubblica | DedInvSubstModelFormReferenceChangeDescriptors | Lista dei riferimenti
Classe pubblica | DocumentsForm | Form utilizzato per la DockableWindow per le dipendenze del documento.
Classe pubblica | DocumentsFormFileStateElementNodeWrapper | Tipo wrapper per la gestione del binding dei dati
Classe pubblica | FindNodesOperation |
Classe pubblica | ModifyingDocumentsForm |
Classe pubblica | MultipleStateOperation |
Delegate
 | Delegate | Descrizione
Delegate pubblico | DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate | Delegate per la definizione interna del criterio di abilitazione del tasto ok
Delegate pubblico | DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate | Delegate per la definizione interna del controllo di checkabilità del nodo
Delegate pubblico | MultipleStateOperationOperationDelagateHandler |


Classe AttributeForm
Form utilizzato per la DockableWindow per editare gli attributi.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsAttributeForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AttributeForm : BaseForm
Public Class AttributeForm
    Inherits BaseForm
public ref class AttributeForm : public BaseForm
type AttributeForm =
    class
        inherit BaseForm
    end

Il tipo AttributeForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | IgnoreUpdateAttr | Indica se ignorare l'aggiornamento della finestra degli attributi.
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | LastSelInfo | Ultima selezione usata per inizializzare la griglia.
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SvuotaGriglia | Svuota la griglia.
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Proprietà di AttributeForm

Il tipo AttributeForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | IgnoreUpdateAttr | Indica se ignorare l'aggiornamento della finestra degli attributi.
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | LastSelInfo | Ultima selezione usata per inizializzare la griglia.
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Proprietà AttributeForm.DockableWindow

Proprietà AttributeFormDockableWindow

Restituisce la window dockabile di questo form.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DockableWindow DockableWindow { get; }
Public ReadOnly Property DockableWindow As DockableWindow
    Get
public:
property DockableWindow^ DockableWindow {
    DockableWindow^ get ();
}
member DockableWindow : DockableWindow with get

Valore della proprietà

Tipo: DockableWindow
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Proprietà AttributeForm.IgnoreUpdateAttr

Proprietà AttributeFormIgnoreUpdateAttr

Indica se ignorare l'aggiornamento della finestra degli attributi.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IgnoreUpdateAttr { get; set; }
Public Property IgnoreUpdateAttr As Boolean
    Get
    Set
public:
property bool IgnoreUpdateAttr {
    bool get ();
    void set (bool value);
}
member IgnoreUpdateAttr : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Proprietà AttributeForm.LastSelInfo

Proprietà AttributeFormLastSelInfo

Ultima selezione usata per inizializzare la griglia.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvCurSelInfo LastSelInfo { get; set; }
Public Property LastSelInfo As InvCurSelInfo
    Get
    Set
public:
property InvCurSelInfo^ LastSelInfo {
    InvCurSelInfo^ get ();
    void set (InvCurSelInfo^ value);
}
member LastSelInfo : InvCurSelInfo with get, set

Valore della proprietà

Tipo: InvCurSelInfo
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Metodi di AttributeForm

Il tipo AttributeForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SvuotaGriglia | Svuota la griglia.
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Metodo AttributeForm.Dispose

Metodo AttributeFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Metodo AttributeForm.RestoreLayoutFromRegistry

Metodo AttributeFormRestoreLayoutFromRegistry

Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Metodo AttributeForm.SaveLayoutToRegistry

Metodo AttributeFormSaveLayoutToRegistry

Salva il layout del controllo nel registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Metodo AttributeForm.SvuotaGriglia

Metodo AttributeFormSvuotaGriglia

Svuota la griglia.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SvuotaGriglia(
    bool titleUpdate = true
)
Public Sub SvuotaGriglia (
    Optional titleUpdate As Boolean = true
)
public:
void SvuotaGriglia(
    bool titleUpdate = true
)
member SvuotaGriglia :
        ?titleUpdate : bool
(* Defaults:
        let _titleUpdate = defaultArg titleUpdate true
*)
-> unit

Parametri

titleUpdate (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Eventi di AttributeForm

Il tipo AttributeForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Campi di AttributeForm

Il tipo AttributeForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe AttributeForm
Namespace DedNetInv.Forms


Classe DedInvDistForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvDistForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvDistForm : BaseForm
Public Class DedInvDistForm
    Inherits BaseForm
public ref class DedInvDistForm : public BaseForm
type DedInvDistForm =
    class
        inherit BaseForm
    end

Il tipo DedInvDistForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvDistForm | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | ExtraCadSource | Inidica se la data source proviene da ded anzichè dal documento
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsStillOpened | Inidica se il form è ancora aperto
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvDistForm

Costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvDistForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedInvDistForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedInvDistForm

Parametri

app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Proprietà di DedInvDistForm

Il tipo DedInvDistForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | ExtraCadSource | Inidica se la data source proviene da ded anzichè dal documento
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsStillOpened | Inidica se il form è ancora aperto
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Proprietà DedInvDistForm.ExtraCadSource

Proprietà DedInvDistFormExtraCadSource

Inidica se la data source proviene da ded anzichè dal documento

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExtraCadSource { get; set; }
Public Property ExtraCadSource As Boolean
    Get
    Set
public:
property bool ExtraCadSource {
    bool get ();
    void set (bool value);
}
member ExtraCadSource : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Proprietà DedInvDistForm.IsStillOpened

Proprietà DedInvDistFormIsStillOpened

Inidica se il form è ancora aperto

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsStillOpened { get; set; }
Public Property IsStillOpened As Boolean
    Get
    Set
public:
property bool IsStillOpened {
    bool get ();
    void set (bool value);
}
member IsStillOpened : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Metodi di DedInvDistForm

Il tipo DedInvDistForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Metodo DedInvDistForm.Dispose

Metodo DedInvDistFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Metodo DedInvDistForm.LoadRegistrySettings

Metodo DedInvDistFormLoadRegistrySettings

Carica dal registro lo stato di visualizzazione livelli dell'albero

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings()
Public Sub LoadRegistrySettings
public:
void LoadRegistrySettings()
member LoadRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Metodo DedInvDistForm.SaveRegistrySettings

Metodo DedInvDistFormSaveRegistrySettings

Salva nel registro lo stato di visualizzazione livelli dell'albero.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Eventi di DedInvDistForm

Il tipo DedInvDistForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Campi di DedInvDistForm

Il tipo DedInvDistForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDistForm
Namespace DedNetInv.Forms


Classe DedInvDocAssistantForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvDocAssistantForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvDocAssistantForm : BaseForm
Public Class DedInvDocAssistantForm
    Inherits BaseForm
public ref class DedInvDocAssistantForm : public BaseForm
type DedInvDocAssistantForm =
    class
        inherit BaseForm
    end

Il tipo DedInvDocAssistantForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvDocAssistantForm | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Ritorna la docking Window Associata
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | Clear | Metodo di pulizia del form
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive BaseForm.OnVisibleChanged(EventArgs).)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | Update | Metodo di aggiornamento del contenuto delle griglie sulla nuova selezione
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvDocAssistantForm

Costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvDocAssistantForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedInvDocAssistantForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedInvDocAssistantForm

Parametri

app
Tipo: DedNetApplication
Oggetto application DED
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Proprietà di DedInvDocAssistantForm

Il tipo DedInvDocAssistantForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Ritorna la docking Window Associata
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Proprietà DedInvDocAssistantForm.DockableWindow

Proprietà DedInvDocAssistantFormDockableWindow

Ritorna la docking Window Associata

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DockableWindow DockableWindow { get; }
Public ReadOnly Property DockableWindow As DockableWindow
    Get
public:
property DockableWindow^ DockableWindow {
    DockableWindow^ get ();
}
member DockableWindow : DockableWindow with get

Valore della proprietà

Tipo: DockableWindow
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodi di DedInvDocAssistantForm

Il tipo DedInvDocAssistantForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | Clear | Metodo di pulizia del form
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive BaseForm.OnVisibleChanged(EventArgs).)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | Update | Metodo di aggiornamento del contenuto delle griglie sulla nuova selezione
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.Clear

Metodo DedInvDocAssistantFormClear

Metodo di pulizia del form

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.Dispose

Metodo DedInvDocAssistantFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.OnVisibleChanged

Metodo DedInvDocAssistantFormOnVisibleChanged

Su ritorno a visibilità, aggiorno la visualizzazione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e
Tipo: SystemEventArgs
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.RestoreLayoutFromRegistry

Metodo DedInvDocAssistantFormRestoreLayoutFromRegistry

Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.SaveLayoutToRegistry

Metodo DedInvDocAssistantFormSaveLayoutToRegistry

Salva il layout del controllo nel registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Metodo DedInvDocAssistantForm.Update

Metodo DedInvDocAssistantFormUpdate

Metodo di aggiornamento del contenuto delle griglie sulla nuova selezione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    InvCurSelInfo invCurSelInfo
)
Public Sub Update (
    invCurSelInfo As InvCurSelInfo
)
public:
void Update(
    InvCurSelInfo^ invCurSelInfo
)
member Update :
        invCurSelInfo : InvCurSelInfo -> unit

Parametri

invCurSelInfo
Tipo: DedNetInvInvCurSelInfo
Oggetto contenente lo stato di selezione corrente
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Eventi di DedInvDocAssistantForm

Il tipo DedInvDocAssistantForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Campi di DedInvDocAssistantForm

Il tipo DedInvDocAssistantForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvDocAssistantForm
Namespace DedNetInv.Forms


Classe DedInvFileResolutorForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvFileResolutorForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvFileResolutorForm : BaseForm
Public Class DedInvFileResolutorForm
    Inherits BaseForm
public ref class DedInvFileResolutorForm : public BaseForm
type DedInvFileResolutorForm =
    class
        inherit BaseForm
    end

Il tipo DedInvFileResolutorForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Proprietà di DedInvFileResolutorForm

Il tipo DedInvFileResolutorForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvFileResolutorForm
Namespace DedNetInv.Forms


Metodi di DedInvFileResolutorForm

Il tipo DedInvFileResolutorForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvFileResolutorForm
Namespace DedNetInv.Forms


Metodo DedInvFileResolutorForm.Dispose

Metodo DedInvFileResolutorFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvFileResolutorForm
Namespace DedNetInv.Forms


Eventi di DedInvFileResolutorForm

Il tipo DedInvFileResolutorForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvFileResolutorForm
Namespace DedNetInv.Forms


Campi di DedInvFileResolutorForm

Il tipo DedInvFileResolutorForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvFileResolutorForm
Namespace DedNetInv.Forms


Classe DedInvPackAndGoExportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvPackAndGoExportForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvPackAndGoExportForm : BaseForm
Public Class DedInvPackAndGoExportForm
    Inherits BaseForm
public ref class DedInvPackAndGoExportForm : public BaseForm
type DedInvPackAndGoExportForm =
    class
        inherit BaseForm
    end

Il tipo DedInvPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Proprietà di DedInvPackAndGoExportForm

Il tipo DedInvPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoExportForm
Namespace DedNetInv.Forms


Metodi di DedInvPackAndGoExportForm

Il tipo DedInvPackAndGoExportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoExportForm
Namespace DedNetInv.Forms


Metodo DedInvPackAndGoExportForm.Dispose

Metodo DedInvPackAndGoExportFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvPackAndGoExportForm
Namespace DedNetInv.Forms


Eventi di DedInvPackAndGoExportForm

Il tipo DedInvPackAndGoExportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoExportForm
Namespace DedNetInv.Forms


Campi di DedInvPackAndGoExportForm

Il tipo DedInvPackAndGoExportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoExportForm
Namespace DedNetInv.Forms


Classe DedInvPackAndGoImportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvPackAndGoImportForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvPackAndGoImportForm : BaseForm
Public Class DedInvPackAndGoImportForm
    Inherits BaseForm
public ref class DedInvPackAndGoImportForm : public BaseForm
type DedInvPackAndGoImportForm =
    class
        inherit BaseForm
    end

Il tipo DedInvPackAndGoImportForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvPackAndGoImportForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvPackAndGoImportForm

Costruttore unico.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvPackAndGoImportForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedInvPackAndGoImportForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedInvPackAndGoImportForm

Parametri

app
Tipo: DedNetApplication
Applicazione
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Proprietà di DedInvPackAndGoImportForm

Il tipo DedInvPackAndGoImportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Metodi di DedInvPackAndGoImportForm

Il tipo DedInvPackAndGoImportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Metodo DedInvPackAndGoImportForm.DeSerializeXml

Metodo DedInvPackAndGoImportFormDeSerializeXml

Deserializza il file .xml

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor DeSerializeXml(
    string fn
)
Public Function DeSerializeXml (
    fn As String
) As PackAndGoStructureDescriptor
public:
PackAndGoStructureDescriptor^ DeSerializeXml(
    String^ fn
)
member DeSerializeXml :
        fn : string -> PackAndGoStructureDescriptor

Parametri

fn
Tipo: SystemString
File da deserializzare.

Valore di ritorno

Tipo: PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Metodo DedInvPackAndGoImportForm.Dispose

Metodo DedInvPackAndGoImportFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Eventi di DedInvPackAndGoImportForm

Il tipo DedInvPackAndGoImportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Campi di DedInvPackAndGoImportForm

Il tipo DedInvPackAndGoImportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvPackAndGoImportForm
Namespace DedNetInv.Forms


Classe DedInvReplaceComponentForm
Form utilizzato per la DockableWindow per la sostituzione dei componenti
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvReplaceComponentForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvReplaceComponentForm : BaseForm
Public Class DedInvReplaceComponentForm
    Inherits BaseForm
public ref class DedInvReplaceComponentForm : public BaseForm
type DedInvReplaceComponentForm =
    class
        inherit BaseForm
    end

Il tipo DedInvReplaceComponentForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvReplaceComponentForm | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectionInfo | Informazioni di selezione corrente
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | AskForOccurrencesToReplaceSelection | Richiedo all'utente la selezione delle occorrenze oggetto della sostituzione
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo pubblico | Hide | Nasconde la finestra dockabile sulla quale poggia il form di fatto nascondendolo
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetFormControls | Permette di impostare un selection info da parte del chiamante
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvReplaceComponentForm

Costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvReplaceComponentForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedInvReplaceComponentForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedInvReplaceComponentForm

Parametri

app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Proprietà di DedInvReplaceComponentForm

Il tipo DedInvReplaceComponentForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectionInfo | Informazioni di selezione corrente
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Proprietà DedInvReplaceComponentForm.DockableWindow

Proprietà DedInvReplaceComponentFormDockableWindow

Restituisce la window dockabile di questo form.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DockableWindow DockableWindow { get; }
Public ReadOnly Property DockableWindow As DockableWindow
    Get
public:
property DockableWindow^ DockableWindow {
    DockableWindow^ get ();
}
member DockableWindow : DockableWindow with get

Valore della proprietà

Tipo: DockableWindow
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Proprietà DedInvReplaceComponentForm.SelectionInfo

Proprietà DedInvReplaceComponentFormSelectionInfo

Informazioni di selezione corrente

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvCurSelInfo SelectionInfo { get; }
Public ReadOnly Property SelectionInfo As InvCurSelInfo
    Get
public:
property InvCurSelInfo^ SelectionInfo {
    InvCurSelInfo^ get ();
}
member SelectionInfo : InvCurSelInfo with get

Valore della proprietà

Tipo: InvCurSelInfo
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodi di DedInvReplaceComponentForm

Il tipo DedInvReplaceComponentForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | AskForOccurrencesToReplaceSelection | Richiedo all'utente la selezione delle occorrenze oggetto della sostituzione
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo pubblico | Hide | Nasconde la finestra dockabile sulla quale poggia il form di fatto nascondendolo
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetFormControls | Permette di impostare un selection info da parte del chiamante
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.AskForOccurrencesToReplaceSelection

Metodo DedInvReplaceComponentFormAskForOccurrencesToReplaceSelection

Richiedo all'utente la selezione delle occorrenze oggetto della sostituzione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AskForOccurrencesToReplaceSelection()
Public Sub AskForOccurrencesToReplaceSelection
public:
void AskForOccurrencesToReplaceSelection()
member AskForOccurrencesToReplaceSelection : unit -> unit
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.Dispose

Metodo DedInvReplaceComponentFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.Hide

Metodo DedInvReplaceComponentFormHide

Nasconde la finestra dockabile sulla quale poggia il form di fatto nascondendolo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Hide()
Public Sub Hide
public:
void Hide()
member Hide : unit -> unit
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.ResetFormControls

Metodo DedInvReplaceComponentFormResetFormControls

Permette di impostare un selection info da parte del chiamante

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ResetFormControls(
    InvCurSelInfo selInfo = null
)
Public Sub ResetFormControls (
    Optional selInfo As InvCurSelInfo = Nothing
)
public:
void ResetFormControls(
    InvCurSelInfo^ selInfo = nullptr
)
member ResetFormControls :
        ?selInfo : InvCurSelInfo
(* Defaults:
        let _selInfo = defaultArg selInfo null
*)
-> unit

Parametri

selInfo (Optional)
Tipo: DedNetInvInvCurSelInfo
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.RestoreLayoutFromRegistry

Metodo DedInvReplaceComponentFormRestoreLayoutFromRegistry

Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Metodo DedInvReplaceComponentForm.SaveLayoutToRegistry

Metodo DedInvReplaceComponentFormSaveLayoutToRegistry

Salva il layout del controllo nel registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Eventi di DedInvReplaceComponentForm

Il tipo DedInvReplaceComponentForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Campi di DedInvReplaceComponentForm

Il tipo DedInvReplaceComponentForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvReplaceComponentForm
Namespace DedNetInv.Forms


Classe DedInvSaveMulipleForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvSaveMulipleForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvSaveMulipleForm : BaseForm
Public Class DedInvSaveMulipleForm
    Inherits BaseForm
public ref class DedInvSaveMulipleForm : public BaseForm
type DedInvSaveMulipleForm =
    class
        inherit BaseForm
    end

Il tipo DedInvSaveMulipleForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleForm | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà pubblica | CommandException | Eccezione generata dal form che vede essere ritornata al comando principale
Proprietà pubblica | CommandResult | Risultato del comando
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà pubblica | CriteriaList | Lista criteri di salvataggio multiplo
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo pubblico | SetCheckNodeForSameStructInfo | Setto lo stesso valore del check per tutti i nodi che hanno lo stesso docstructinfo associato
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm

Costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleForm(
    DedNetApplication app,
    DocStructInfoList dsList,
    InvCurSelInfo invSelInfo
)
Public Sub New (
    app As DedNetApplication,
    dsList As DocStructInfoList,
    invSelInfo As InvCurSelInfo
)
public:
DedInvSaveMulipleForm(
    DedNetApplication^ app,
    DocStructInfoList^ dsList,
    InvCurSelInfo^ invSelInfo
)
new :
        app : DedNetApplication *
        dsList : DocStructInfoList *
        invSelInfo : InvCurSelInfo -> DedInvSaveMulipleForm

Parametri

app
Tipo: DedNetApplication
Applicazione DedNet
dsList
Tipo: DocStructInfoList
Lista descrittori struttura documenti di testa
invSelInfo
Tipo: DedNetInvInvCurSelInfo
Selezione corrente in inventor
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Proprietà di DedInvSaveMulipleForm

Il tipo DedInvSaveMulipleForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà pubblica | CommandException | Eccezione generata dal form che vede essere ritornata al comando principale
Proprietà pubblica | CommandResult | Risultato del comando
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà pubblica | CriteriaList | Lista criteri di salvataggio multiplo
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.CommandException

Proprietà DedInvSaveMulipleFormCommandException

Eccezione generata dal form che vede essere ritornata al comando principale

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception CommandException { get; }
Public ReadOnly Property CommandException As Exception
    Get
public:
property Exception^ CommandException {
    Exception^ get ();
}
member CommandException : Exception with get

Valore della proprietà

Tipo: Exception
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.CommandResult

Proprietà DedInvSaveMulipleFormCommandResult

Risultato del comando

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult CommandResult { get; }
Public ReadOnly Property CommandResult As DedCmdResult
    Get
public:
property DedCmdResult CommandResult {
    DedCmdResult get ();
}
member CommandResult : DedCmdResult with get

Valore della proprietà

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.CriteriaList

Proprietà DedInvSaveMulipleFormCriteriaList

Lista criteri di salvataggio multiplo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteriaList CriteriaList { get; }
Public ReadOnly Property CriteriaList As DedInvSaveMulipleFormMultiSaverModeCriteriaList
    Get
public:
property DedInvSaveMulipleFormMultiSaverModeCriteriaList^ CriteriaList {
    DedInvSaveMulipleFormMultiSaverModeCriteriaList^ get ();
}
member CriteriaList : DedInvSaveMulipleFormMultiSaverModeCriteriaList with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteriaList
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Metodi di DedInvSaveMulipleForm

Il tipo DedInvSaveMulipleForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo pubblico | SetCheckNodeForSameStructInfo | Setto lo stesso valore del check per tutti i nodi che hanno lo stesso docstructinfo associato
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.Dispose

Metodo DedInvSaveMulipleFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.SetCheckNodeForSameStructInfo

Metodo DedInvSaveMulipleFormSetCheckNodeForSameStructInfo

Setto lo stesso valore del check per tutti i nodi che hanno lo stesso docstructinfo associato

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckNodeForSameStructInfo(
    bool value,
    InvDocStructInfo invDsInfo,
    TreeListNodes nodes
)
Public Sub SetCheckNodeForSameStructInfo (
    value As Boolean,
    invDsInfo As InvDocStructInfo,
    nodes As TreeListNodes
)
public:
void SetCheckNodeForSameStructInfo(
    bool value,
    InvDocStructInfo^ invDsInfo,
    TreeListNodes^ nodes
)
member SetCheckNodeForSameStructInfo :
        value : bool *
        invDsInfo : InvDocStructInfo *
        nodes : TreeListNodes -> unit

Parametri

value
Tipo: SystemBoolean
Valore da impostare
invDsInfo
Tipo: DedNetInvInvDocStructInfo
Oggetto docStructInfo di riferimento
nodes
Tipo: TreeListNodes
Insieme di nodi da considerare
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Eventi di DedInvSaveMulipleForm

Il tipo DedInvSaveMulipleForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Campi di DedInvSaveMulipleForm

Il tipo DedInvSaveMulipleForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleForm
Namespace DedNetInv.Forms


Classe DedInvSaveMulipleForm.MultiSaverModeCriteria

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Classe che rappresenta il singolo criterio di salvataggio multipla.
Gerarchia di ereditarietà
SystemObject
DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverModeCriteria
Public Class MultiSaverModeCriteria
public ref class MultiSaverModeCriteria
type MultiSaverModeCriteria =  class end

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleFormMultiSaverModeCriteria | Costruttore del criterio
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActionCheckableControl | Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore
Proprietà pubblica | CustomFormControl | Controllo custom addizionale
Proprietà pubblica | CustomLuaActionCheckableControl | Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore
Proprietà pubblica | CustomUncheckedOnLoadControl | Funzione lua personalizzabile dall'esterno per stabilire se il nodo è checked o meno in fase di load del form
Proprietà pubblica | Description | Descrizione della modalità
Proprietà pubblica | EnableOkButtonRules | Delegate per la definizione interna della checkabilità del nodo in base al criterio
Proprietà pubblica | Name | Nome della modalità
Proprietà pubblica | RequireGenericDbType | Definisce se necessita della selezione della famiglia generica per la ricodifica generale
Proprietà pubblica | RequireSpecificDbType | Definisce se necessita della selezione famiglia specifica per ogni elemento
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsCheckable | Definisce la checkabilità del descrittore in base al criterio
Metodo pubblico | ToString | Ridefinizione conversione a stringa (Sovrascrive ObjectToString.)
Metodo pubblico | UncheckedOnLoad | Definisce la checkabilità del descrittore in base al criterio
Torna su
Operatori
Nome | Descrizione
Equality | Ridefinizione dell'operatore ==.
Inequality | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm.MultiSaverModeCriteria

Costruttore DedInvSaveMulipleFormMultiSaverModeCriteria

Costruttore del criterio

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverModeCriteria(
    string name
)
Public Sub New (
    name As String
)
public:
MultiSaverModeCriteria(
    String^ name
)
new :
        name : string -> MultiSaverModeCriteria

Parametri

name
Tipo: SystemString
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà di MultiSaverModeCriteria

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ActionCheckableControl | Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore
Proprietà pubblica | CustomFormControl | Controllo custom addizionale
Proprietà pubblica | CustomLuaActionCheckableControl | Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore
Proprietà pubblica | CustomUncheckedOnLoadControl | Funzione lua personalizzabile dall'esterno per stabilire se il nodo è checked o meno in fase di load del form
Proprietà pubblica | Description | Descrizione della modalità
Proprietà pubblica | EnableOkButtonRules | Delegate per la definizione interna della checkabilità del nodo in base al criterio
Proprietà pubblica | Name | Nome della modalità
Proprietà pubblica | RequireGenericDbType | Definisce se necessita della selezione della famiglia generica per la ricodifica generale
Proprietà pubblica | RequireSpecificDbType | Definisce se necessita della selezione famiglia specifica per ogni elemento
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.ActionCheckableControl

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaActionCheckableControl

Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate ActionCheckableControl { get; set; }
Public Property ActionCheckableControl As DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate
    Get
    Set
public:
property DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ ActionCheckableControl {
    DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ get ();
    void set (DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate^ value);
}
member ActionCheckableControl : DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate with get, set

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.CustomFormControl

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaCustomFormControl

Controllo custom addizionale

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Control CustomFormControl { get; set; }
Public Property CustomFormControl As Control
    Get
    Set
public:
property Control^ CustomFormControl {
    Control^ get ();
    void set (Control^ value);
}
member CustomFormControl : Control with get, set

Valore della proprietà

Tipo: Control
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.CustomLuaActionCheckableControl

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaCustomLuaActionCheckableControl

Funzione lua personalizzabile dall'esterno per stabilire la checkabilità di un descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaFunction CustomLuaActionCheckableControl { get; set; }
Public Property CustomLuaActionCheckableControl As LuaFunction
    Get
    Set
public:
property LuaFunction^ CustomLuaActionCheckableControl {
    LuaFunction^ get ();
    void set (LuaFunction^ value);
}
member CustomLuaActionCheckableControl : LuaFunction with get, set

Valore della proprietà

Tipo: LuaFunction
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.CustomUncheckedOnLoadControl

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaCustomUncheckedOnLoadControl

Funzione lua personalizzabile dall'esterno per stabilire se il nodo è checked o meno in fase di load del form

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaFunction CustomUncheckedOnLoadControl { get; set; }
Public Property CustomUncheckedOnLoadControl As LuaFunction
    Get
    Set
public:
property LuaFunction^ CustomUncheckedOnLoadControl {
    LuaFunction^ get ();
    void set (LuaFunction^ value);
}
member CustomUncheckedOnLoadControl : LuaFunction with get, set

Valore della proprietà

Tipo: LuaFunction
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.Description

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaDescription

Descrizione della modalità

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.EnableOkButtonRules

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonRules

Delegate per la definizione interna della checkabilità del nodo in base al criterio

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate EnableOkButtonRules { get; set; }
Public Property EnableOkButtonRules As DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate
    Get
    Set
public:
property DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ EnableOkButtonRules {
    DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ get ();
    void set (DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate^ value);
}
member EnableOkButtonRules : DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate with get, set

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.Name

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaName

Nome della modalità

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.RequireGenericDbType

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaRequireGenericDbType

Definisce se necessita della selezione della famiglia generica per la ricodifica generale

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RequireGenericDbType { get; set; }
Public Property RequireGenericDbType As Boolean
    Get
    Set
public:
property bool RequireGenericDbType {
    bool get ();
    void set (bool value);
}
member RequireGenericDbType : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverModeCriteria.RequireSpecificDbType

Proprietà DedInvSaveMulipleFormMultiSaverModeCriteriaRequireSpecificDbType

Definisce se necessita della selezione famiglia specifica per ogni elemento

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RequireSpecificDbType { get; set; }
Public Property RequireSpecificDbType As Boolean
    Get
    Set
public:
property bool RequireSpecificDbType {
    bool get ();
    void set (bool value);
}
member RequireSpecificDbType : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodi di MultiSaverModeCriteria

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | Restituisce l'HashCode di questo oggetto. (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsCheckable | Definisce la checkabilità del descrittore in base al criterio
Metodo pubblico | ToString | Ridefinizione conversione a stringa (Sovrascrive ObjectToString.)
Metodo pubblico | UncheckedOnLoad | Definisce la checkabilità del descrittore in base al criterio
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteria.Equals

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaEquals

Ridefinizione di uguaglianza.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject
Oggetto da confrontare.

Valore di ritorno

Tipo: Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteria.GetHashCode

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaGetHashCode

Restituisce l'HashCode di questo oggetto.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteria.IsCheckable

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckable

Definisce la checkabilità del descrittore in base al criterio

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckable(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Function IsCheckable (
    msNd As DedInvSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public:
bool IsCheckable(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
member IsCheckable :
        msNd : DedInvSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteria.ToString

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaToString

Ridefinizione conversione a stringa

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteria.UncheckedOnLoad

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaUncheckedOnLoad

Definisce la checkabilità del descrittore in base al criterio

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UncheckedOnLoad(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Function UncheckedOnLoad (
    msNd As DedInvSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public:
bool UncheckedOnLoad(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
member UncheckedOnLoad :
        msNd : DedInvSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


MultiSaverModeCriteria Operators

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteria espone i seguenti membri.

Operatori
Nome | Descrizione
Equality | Ridefinizione dell'operatore ==.
Inequality | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


DedInvSaveMulipleForm.MultiSaverModeCriteria.Equality Operatore

DedInvSaveMulipleFormMultiSaverModeCriteriaEquality Operatore

Ridefinizione dell'operatore ==.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    DedInvSaveMulipleFormMultiSaverModeCriteria a,
    DedInvSaveMulipleFormMultiSaverModeCriteria b
)
Public Shared Operator = (
    a As DedInvSaveMulipleFormMultiSaverModeCriteria,
    b As DedInvSaveMulipleFormMultiSaverModeCriteria
) As Boolean
public:
static bool operator ==(
    DedInvSaveMulipleFormMultiSaverModeCriteria^ a,
    DedInvSaveMulipleFormMultiSaverModeCriteria^ b
)
static let inline (=)
        a : DedInvSaveMulipleFormMultiSaverModeCriteria *
        b : DedInvSaveMulipleFormMultiSaverModeCriteria  : bool

Parametri

a
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria
b
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


DedInvSaveMulipleForm.MultiSaverModeCriteria.Inequality Operatore

DedInvSaveMulipleFormMultiSaverModeCriteriaInequality Operatore

Ridefinizione dell'operatore !=.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    DedInvSaveMulipleFormMultiSaverModeCriteria a,
    DedInvSaveMulipleFormMultiSaverModeCriteria b
)
Public Shared Operator <> (
    a As DedInvSaveMulipleFormMultiSaverModeCriteria,
    b As DedInvSaveMulipleFormMultiSaverModeCriteria
) As Boolean
public:
static bool operator !=(
    DedInvSaveMulipleFormMultiSaverModeCriteria^ a,
    DedInvSaveMulipleFormMultiSaverModeCriteria^ b
)
static let inline (<>)
        a : DedInvSaveMulipleFormMultiSaverModeCriteria *
        b : DedInvSaveMulipleFormMultiSaverModeCriteria  : bool

Parametri

a
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria
b
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteria

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteria
Namespace DedNetInv.Forms


Delegate DedInvSaveMulipleForm.MultiSaverModeCriteria.EnableOkButtonDelegate

Delegate DedInvSaveMulipleFormMultiSaverModeCriteriaEnableOkButtonDelegate
Delegate per la definizione interna del criterio di abilitazione del tasto ok

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate bool EnableOkButtonDelegate(
    TreeListNodes refNodes
)
Public Delegate Function EnableOkButtonDelegate (
    refNodes As TreeListNodes
) As Boolean
public delegate bool EnableOkButtonDelegate(
    TreeListNodes^ refNodes
)
type EnableOkButtonDelegate =
    delegate of
        refNodes : TreeListNodes -> bool

Parametri

refNodes
Tipo: TreeListNodes

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Delegate DedInvSaveMulipleForm.MultiSaverModeCriteria.IsCheckableDelegate

Delegate DedInvSaveMulipleFormMultiSaverModeCriteriaIsCheckableDelegate
Delegate per la definizione interna del controllo di checkabilità del nodo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate bool IsCheckableDelegate(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor msNd
)
Public Delegate Function IsCheckableDelegate (
    msNd As DedInvSaveMulipleFormMultiSaverNodeDescriptor
) As Boolean
public delegate bool IsCheckableDelegate(
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ msNd
)
type IsCheckableDelegate =
    delegate of
        msNd : DedInvSaveMulipleFormMultiSaverNodeDescriptor -> bool

Parametri

msNd
Tipo: DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Classe DedInvSaveMulipleForm.MultiSaverModeCriteriaList

Classe DedInvSaveMulipleFormMultiSaverModeCriteriaList
Oggetto insieme di criteri di salvataggio multiplo
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedInvSaveMulipleFormMultiSaverModeCriteria
DedNetInv.FormsDedInvSaveMulipleFormMultiSaverModeCriteriaList

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverModeCriteriaList : List<DedInvSaveMulipleFormMultiSaverModeCriteria>
Public Class MultiSaverModeCriteriaList
    Inherits List(Of DedInvSaveMulipleFormMultiSaverModeCriteria)
public ref class MultiSaverModeCriteriaList : public List<DedInvSaveMulipleFormMultiSaverModeCriteria^>
type MultiSaverModeCriteriaList =
    class
        inherit List<DedInvSaveMulipleFormMultiSaverModeCriteria>
    end

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteriaList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleFormMultiSaverModeCriteriaList |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CreateMultiSaverModeCriteria | Metodo che permette di creare il criterio senza utilizzare direttamente il costruttore
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm.MultiSaverModeCriteriaList

Costruttore DedInvSaveMulipleFormMultiSaverModeCriteriaList

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverModeCriteriaList()
Public Sub New
public:
MultiSaverModeCriteriaList()
new : unit -> MultiSaverModeCriteriaList
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetInv.Forms


Metodi di MultiSaverModeCriteriaList

Il tipo DedInvSaveMulipleFormMultiSaverModeCriteriaList espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CreateMultiSaverModeCriteria | Metodo che permette di creare il criterio senza utilizzare direttamente il costruttore
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverModeCriteriaList.CreateMultiSaverModeCriteria

Metodo DedInvSaveMulipleFormMultiSaverModeCriteriaListCreateMultiSaverModeCriteria

Metodo che permette di creare il criterio senza utilizzare direttamente il costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverModeCriteria CreateMultiSaverModeCriteria(
    string name
)
Public Function CreateMultiSaverModeCriteria (
    name As String
) As DedInvSaveMulipleFormMultiSaverModeCriteria
public:
DedInvSaveMulipleFormMultiSaverModeCriteria^ CreateMultiSaverModeCriteria(
    String^ name
)
member CreateMultiSaverModeCriteria :
        name : string -> DedInvSaveMulipleFormMultiSaverModeCriteria

Parametri

name
Tipo: SystemString
Nuovo nome del criterio

Valore di ritorno

Tipo: DedInvSaveMulipleFormMultiSaverModeCriteria
Oggetto criterio
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverModeCriteriaList
Namespace DedNetInv.Forms


Classe DedInvSaveMulipleForm.MultiSaverNodeDescriptor

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Classe rappresentante il descrittore del nodo
Gerarchia di ereditarietà
SystemObject
DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptor

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverNodeDescriptor
Public Class MultiSaverNodeDescriptor
public ref class MultiSaverNodeDescriptor
type MultiSaverNodeDescriptor =  class end

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleFormMultiSaverNodeDescriptor(PartBody, DedInvSaveMulipleForm, TreeListNode) | Costruttore del descrittore tramite PartBody
Metodo pubblico | DedInvSaveMulipleFormMultiSaverNodeDescriptor(InvDocStructInfo, DedInvSaveMulipleForm, TreeListNode) | Costruttore del descrittore tramite DocStructInfo
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrEdited | Attributi editati in fase di elaborazione
Proprietà pubblica | DocStructInfo | Ritorna l'InvDocStructInfo di riferimento per il descrittore
Proprietà pubblica | Elaborated | Permette di capire se il nodo è già stato elaborato
Proprietà pubblica | ElaborationIsGood | Permette di capire se il nodo è già stato elaborato
Proprietà pubblica | HasParentDescriptor | Ritorna vero se esiste un nodo descrittore padre.
Proprietà pubblica | IsCheckable | Ritorna un flag che rappresenta la possibilità di eseguire il check del nodo
Proprietà pubblica | IsMultiBodyDocument | Ritorna vero se il descrittore rappresenta un documento multibody
Proprietà pubblica | IsPartBody | Ritorna vero se il descrittore rappresenta un part body
Proprietà pubblica | Node | Ritorna l'oggetto nodo nativo corrispondente
Proprietà pubblica | OccurredParentErrors | Indica se si sono verificati degli errori nella catena di elaborazione dei padri
Proprietà pubblica | Parent | Ritorna l'oggetto nodo nativo corrispondente all'oggetto padre. Potrebbe essere null per un documento di testa
Proprietà pubblica | ParentDescriptor | Ritorna vero se esiste un nodo descrittore padre.
Proprietà pubblica | PartBody | Ritorna l'oggetto partbody
Proprietà pubblica | SelectedDbType | Tipo selezionato sul form per il descrittore
Proprietà pubblica | SkipChildren | Imposta/Restituisce se elaborare o meno i nodi figli.
Proprietà pubblica | StatusMessage | Messaggio di stato in caso di errori
Proprietà pubblica | UncheckedOnLoad | Ritorna un flag che indica se il nodo deve essere checkato al caricamento
Proprietà pubblica | UserUnchecked | Ritorna vero se il nodo è stato uncheckato manualmente dall'utente. Questo flag impedisce la forzatura della selezione dell'oggetto in caso di cambio criterio
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | LoadExceptionIfExists | Metodo che carica a schermo il messaggio dell'eccezione (se esiste) avvenuta durante l'elaborazione iniziale del nodo.
Metodo pubblico | RecomputeCheckability | Metodo che resetta il flag di gestione calcolo della checkabilità del nodo
Metodo pubblico | SetAttrEdited | Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document
Metodo pubblico | SetCheckedStatus | Setta lo stato checked a seconda del tipo di operazione
Metodo pubblico | SetOverridedDbType | Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document
Metodo pubblico | UpdateElaborationStatus | Metodo per l'aggiornamento dello stato di elaborazione del descrittore
Torna su
Eventi
Nome | Descrizione
UserUncheckedChanged | Evento per la gestione del camio di stato dell'impostazione UserUnchecked
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore MultiSaverNodeDescriptor

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleFormMultiSaverNodeDescriptor(PartBody, DedInvSaveMulipleForm, TreeListNode) | Costruttore del descrittore tramite PartBody
Metodo pubblico | DedInvSaveMulipleFormMultiSaverNodeDescriptor(InvDocStructInfo, DedInvSaveMulipleForm, TreeListNode) | Costruttore del descrittore tramite DocStructInfo
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm.MultiSaverNodeDescriptor (PartBody, DedInvSaveMulipleForm, TreeListNode)

Costruttore DedInvSaveMulipleFormMultiSaverNodeDescriptor (PartBody, DedInvSaveMulipleForm, TreeListNode)
Costruttore del descrittore tramite PartBody

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverNodeDescriptor(
    PartBody pb,
    DedInvSaveMulipleForm commandForm,
    TreeListNode parentNode
)
Public Sub New (
    pb As PartBody,
    commandForm As DedInvSaveMulipleForm,
    parentNode As TreeListNode
)
public:
MultiSaverNodeDescriptor(
    PartBody^ pb,
    DedInvSaveMulipleForm^ commandForm,
    TreeListNode^ parentNode
)
new :
        pb : PartBody *
        commandForm : DedInvSaveMulipleForm *
        parentNode : TreeListNode -> MultiSaverNodeDescriptor

Parametri

pb
Tipo: PartBody
commandForm
Tipo: DedNetInv.FormsDedInvSaveMulipleForm
parentNode
Tipo: TreeListNode
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Overload di DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm.MultiSaverNodeDescriptor (InvDocStructInfo, DedInvSaveMulipleForm, TreeListNode)

Costruttore DedInvSaveMulipleFormMultiSaverNodeDescriptor (InvDocStructInfo, DedInvSaveMulipleForm, TreeListNode)
Costruttore del descrittore tramite DocStructInfo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverNodeDescriptor(
    InvDocStructInfo ds,
    DedInvSaveMulipleForm commandForm,
    TreeListNode parentNode
)
Public Sub New (
    ds As InvDocStructInfo,
    commandForm As DedInvSaveMulipleForm,
    parentNode As TreeListNode
)
public:
MultiSaverNodeDescriptor(
    InvDocStructInfo^ ds,
    DedInvSaveMulipleForm^ commandForm,
    TreeListNode^ parentNode
)
new :
        ds : InvDocStructInfo *
        commandForm : DedInvSaveMulipleForm *
        parentNode : TreeListNode -> MultiSaverNodeDescriptor

Parametri

ds
Tipo: DedNetInvInvDocStructInfo
commandForm
Tipo: DedNetInv.FormsDedInvSaveMulipleForm
parentNode
Tipo: TreeListNode
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Overload di DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà di MultiSaverNodeDescriptor

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AttrEdited | Attributi editati in fase di elaborazione
Proprietà pubblica | DocStructInfo | Ritorna l'InvDocStructInfo di riferimento per il descrittore
Proprietà pubblica | Elaborated | Permette di capire se il nodo è già stato elaborato
Proprietà pubblica | ElaborationIsGood | Permette di capire se il nodo è già stato elaborato
Proprietà pubblica | HasParentDescriptor | Ritorna vero se esiste un nodo descrittore padre.
Proprietà pubblica | IsCheckable | Ritorna un flag che rappresenta la possibilità di eseguire il check del nodo
Proprietà pubblica | IsMultiBodyDocument | Ritorna vero se il descrittore rappresenta un documento multibody
Proprietà pubblica | IsPartBody | Ritorna vero se il descrittore rappresenta un part body
Proprietà pubblica | Node | Ritorna l'oggetto nodo nativo corrispondente
Proprietà pubblica | OccurredParentErrors | Indica se si sono verificati degli errori nella catena di elaborazione dei padri
Proprietà pubblica | Parent | Ritorna l'oggetto nodo nativo corrispondente all'oggetto padre. Potrebbe essere null per un documento di testa
Proprietà pubblica | ParentDescriptor | Ritorna vero se esiste un nodo descrittore padre.
Proprietà pubblica | PartBody | Ritorna l'oggetto partbody
Proprietà pubblica | SelectedDbType | Tipo selezionato sul form per il descrittore
Proprietà pubblica | SkipChildren | Imposta/Restituisce se elaborare o meno i nodi figli.
Proprietà pubblica | StatusMessage | Messaggio di stato in caso di errori
Proprietà pubblica | UncheckedOnLoad | Ritorna un flag che indica se il nodo deve essere checkato al caricamento
Proprietà pubblica | UserUnchecked | Ritorna vero se il nodo è stato uncheckato manualmente dall'utente. Questo flag impedisce la forzatura della selezione dell'oggetto in caso di cambio criterio
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.AttrEdited

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorAttrEdited

Attributi editati in fase di elaborazione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart AttrEdited { get; set; }
Public Property AttrEdited As DedDataPart
    Get
    Set
public:
property DedDataPart^ AttrEdited {
    DedDataPart^ get ();
    void set (DedDataPart^ value);
}
member AttrEdited : DedDataPart with get, set

Valore della proprietà

Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.DocStructInfo

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorDocStructInfo

Ritorna l'InvDocStructInfo di riferimento per il descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InvDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As InvDocStructInfo
    Get
public:
property InvDocStructInfo^ DocStructInfo {
    InvDocStructInfo^ get ();
}
member DocStructInfo : InvDocStructInfo with get

Valore della proprietà

Tipo: InvDocStructInfo
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.Elaborated

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorElaborated

Permette di capire se il nodo è già stato elaborato

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Elaborated { get; set; }
Public Property Elaborated As Boolean
    Get
    Set
public:
property bool Elaborated {
    bool get ();
    void set (bool value);
}
member Elaborated : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.ElaborationIsGood

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorElaborationIsGood

Permette di capire se il nodo è già stato elaborato

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ElaborationIsGood { get; set; }
Public Property ElaborationIsGood As Boolean
    Get
    Set
public:
property bool ElaborationIsGood {
    bool get ();
    void set (bool value);
}
member ElaborationIsGood : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.HasParentDescriptor

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorHasParentDescriptor

Ritorna vero se esiste un nodo descrittore padre.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasParentDescriptor { get; }
Public ReadOnly Property HasParentDescriptor As Boolean
    Get
public:
property bool HasParentDescriptor {
    bool get ();
}
member HasParentDescriptor : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.IsCheckable

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorIsCheckable

Ritorna un flag che rappresenta la possibilità di eseguire il check del nodo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsCheckable { get; }
Public ReadOnly Property IsCheckable As Boolean
    Get
public:
property bool IsCheckable {
    bool get ();
}
member IsCheckable : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.IsMultiBodyDocument

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorIsMultiBodyDocument

Ritorna vero se il descrittore rappresenta un documento multibody

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsMultiBodyDocument { get; set; }
Public Property IsMultiBodyDocument As Boolean
    Get
    Set
public:
property bool IsMultiBodyDocument {
    bool get ();
    void set (bool value);
}
member IsMultiBodyDocument : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.IsPartBody

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorIsPartBody

Ritorna vero se il descrittore rappresenta un part body

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsPartBody { get; }
Public ReadOnly Property IsPartBody As Boolean
    Get
public:
property bool IsPartBody {
    bool get ();
}
member IsPartBody : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.Node

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorNode

Ritorna l'oggetto nodo nativo corrispondente

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; }
Public ReadOnly Property Node As TreeListNode
    Get
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
}
member Node : TreeListNode with get

Valore della proprietà

Tipo: TreeListNode
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.OccurredParentErrors

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorOccurredParentErrors

Indica se si sono verificati degli errori nella catena di elaborazione dei padri

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OccurredParentErrors { get; }
Public ReadOnly Property OccurredParentErrors As Boolean
    Get
public:
property bool OccurredParentErrors {
    bool get ();
}
member OccurredParentErrors : bool with get

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.Parent

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorParent

Ritorna l'oggetto nodo nativo corrispondente all'oggetto padre. Potrebbe essere null per un documento di testa

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Parent { get; }
Public ReadOnly Property Parent As TreeListNode
    Get
public:
property TreeListNode^ Parent {
    TreeListNode^ get ();
}
member Parent : TreeListNode with get

Valore della proprietà

Tipo: TreeListNode
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.ParentDescriptor

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorParentDescriptor

Ritorna vero se esiste un nodo descrittore padre.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSaveMulipleFormMultiSaverNodeDescriptor ParentDescriptor { get; }
Public ReadOnly Property ParentDescriptor As DedInvSaveMulipleFormMultiSaverNodeDescriptor
    Get
public:
property DedInvSaveMulipleFormMultiSaverNodeDescriptor^ ParentDescriptor {
    DedInvSaveMulipleFormMultiSaverNodeDescriptor^ get ();
}
member ParentDescriptor : DedInvSaveMulipleFormMultiSaverNodeDescriptor with get

Valore della proprietà

Tipo: DedInvSaveMulipleFormMultiSaverNodeDescriptor
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.PartBody

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorPartBody

Ritorna l'oggetto partbody

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartBody PartBody { get; }
Public ReadOnly Property PartBody As PartBody
    Get
public:
property PartBody^ PartBody {
    PartBody^ get ();
}
member PartBody : PartBody with get

Valore della proprietà

Tipo: PartBody
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.SelectedDbType

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorSelectedDbType

Tipo selezionato sul form per il descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType SelectedDbType { get; set; }
Public Property SelectedDbType As DedType
    Get
    Set
public:
property DedType^ SelectedDbType {
    DedType^ get ();
    void set (DedType^ value);
}
member SelectedDbType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.SkipChildren

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorSkipChildren

Imposta/Restituisce se elaborare o meno i nodi figli.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SkipChildren { get; set; }
Public Property SkipChildren As Boolean
    Get
    Set
public:
property bool SkipChildren {
    bool get ();
    void set (bool value);
}
member SkipChildren : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.StatusMessage

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorStatusMessage

Messaggio di stato in caso di errori

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string StatusMessage { get; set; }
Public Property StatusMessage As String
    Get
    Set
public:
property String^ StatusMessage {
    String^ get ();
    void set (String^ value);
}
member StatusMessage : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.UncheckedOnLoad

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorUncheckedOnLoad

Ritorna un flag che indica se il nodo deve essere checkato al caricamento

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UncheckedOnLoad { get; }
Public ReadOnly Property UncheckedOnLoad As Boolean
    Get
public:
property bool UncheckedOnLoad {
    bool get ();
}
member UncheckedOnLoad : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSaveMulipleForm.MultiSaverNodeDescriptor.UserUnchecked

Proprietà DedInvSaveMulipleFormMultiSaverNodeDescriptorUserUnchecked

Ritorna vero se il nodo è stato uncheckato manualmente dall'utente. Questo flag impedisce la forzatura della selezione dell'oggetto in caso di cambio criterio

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UserUnchecked { get; set; }
Public Property UserUnchecked As Boolean
    Get
    Set
public:
property bool UserUnchecked {
    bool get ();
    void set (bool value);
}
member UserUnchecked : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodi di MultiSaverNodeDescriptor

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | LoadExceptionIfExists | Metodo che carica a schermo il messaggio dell'eccezione (se esiste) avvenuta durante l'elaborazione iniziale del nodo.
Metodo pubblico | RecomputeCheckability | Metodo che resetta il flag di gestione calcolo della checkabilità del nodo
Metodo pubblico | SetAttrEdited | Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document
Metodo pubblico | SetCheckedStatus | Setta lo stato checked a seconda del tipo di operazione
Metodo pubblico | SetOverridedDbType | Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document
Metodo pubblico | UpdateElaborationStatus | Metodo per l'aggiornamento dello stato di elaborazione del descrittore
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.LoadExceptionIfExists

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorLoadExceptionIfExists

Metodo che carica a schermo il messaggio dell'eccezione (se esiste) avvenuta durante l'elaborazione iniziale del nodo.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadExceptionIfExists()
Public Sub LoadExceptionIfExists
public:
void LoadExceptionIfExists()
member LoadExceptionIfExists : unit -> unit
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.RecomputeCheckability

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorRecomputeCheckability

Metodo che resetta il flag di gestione calcolo della checkabilità del nodo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RecomputeCheckability()
Public Sub RecomputeCheckability
public:
void RecomputeCheckability()
member RecomputeCheckability : unit -> unit
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.SetAttrEdited

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorSetAttrEdited

Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetAttrEdited(
    DedDataPart attrEdited,
    bool evaluateSameStructInfo = true
)
Public Sub SetAttrEdited (
    attrEdited As DedDataPart,
    Optional evaluateSameStructInfo As Boolean = true
)
public:
void SetAttrEdited(
    DedDataPart^ attrEdited,
    bool evaluateSameStructInfo = true
)
member SetAttrEdited :
        attrEdited : DedDataPart *
        ?evaluateSameStructInfo : bool
(* Defaults:
        let _evaluateSameStructInfo = defaultArg evaluateSameStructInfo true
*)
-> unit

Parametri

attrEdited
Tipo: DedDataPart
evaluateSameStructInfo (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.SetCheckedStatus

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorSetCheckedStatus

Setta lo stato checked a seconda del tipo di operazione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetCheckedStatus(
    bool value
)
Public Sub SetCheckedStatus (
    value As Boolean
)
public:
void SetCheckedStatus(
    bool value
)
member SetCheckedStatus :
        value : bool -> unit

Parametri

value
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.SetOverridedDbType

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorSetOverridedDbType

Setta il tipo override selezionato dal form per il nodo corrente ed eventualmente quelli con stesso document

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetOverridedDbType(
    DedType dbType,
    bool evaluateSameStructInfo = true
)
Public Sub SetOverridedDbType (
    dbType As DedType,
    Optional evaluateSameStructInfo As Boolean = true
)
public:
void SetOverridedDbType(
    DedType^ dbType,
    bool evaluateSameStructInfo = true
)
member SetOverridedDbType :
        dbType : DedType *
        ?evaluateSameStructInfo : bool
(* Defaults:
        let _evaluateSameStructInfo = defaultArg evaluateSameStructInfo true
*)
-> unit

Parametri

dbType
Tipo: DedType
evaluateSameStructInfo (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptor.UpdateElaborationStatus

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorUpdateElaborationStatus

Metodo per l'aggiornamento dello stato di elaborazione del descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void UpdateElaborationStatus(
    string msg,
    bool elaborationIsGood = true
)
Public Sub UpdateElaborationStatus (
    msg As String,
    Optional elaborationIsGood As Boolean = true
)
public:
void UpdateElaborationStatus(
    String^ msg,
    bool elaborationIsGood = true
)
member UpdateElaborationStatus :
        msg : string *
        ?elaborationIsGood : bool
(* Defaults:
        let _elaborationIsGood = defaultArg elaborationIsGood true
*)
-> unit

Parametri

msg
Tipo: SystemString
elaborationIsGood (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Eventi di MultiSaverNodeDescriptor

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptor espone i seguenti membri.

Eventi
Nome | Descrizione
UserUncheckedChanged | Evento per la gestione del camio di stato dell'impostazione UserUnchecked
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Evento DedInvSaveMulipleForm.MultiSaverNodeDescriptor.UserUncheckedChanged

Evento DedInvSaveMulipleFormMultiSaverNodeDescriptorUserUncheckedChanged
Evento per la gestione del camio di stato dell'impostazione UserUnchecked

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler UserUncheckedChanged
Public Shared Event UserUncheckedChanged As EventHandler
public:
static  event EventHandler^ UserUncheckedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member UserUncheckedChanged : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptor
Namespace DedNetInv.Forms


Classe DedInvSaveMulipleForm.MultiSaverNodeDescriptors

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptors
Lista dei descrittori del nodo
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedInvSaveMulipleFormMultiSaverNodeDescriptor
DedNetInv.FormsDedInvSaveMulipleFormMultiSaverNodeDescriptors

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultiSaverNodeDescriptors : List<DedInvSaveMulipleFormMultiSaverNodeDescriptor>
Public Class MultiSaverNodeDescriptors
    Inherits List(Of DedInvSaveMulipleFormMultiSaverNodeDescriptor)
public ref class MultiSaverNodeDescriptors : public List<DedInvSaveMulipleFormMultiSaverNodeDescriptor^>
type MultiSaverNodeDescriptors =
    class
        inherit List<DedInvSaveMulipleFormMultiSaverNodeDescriptor>
    end

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSaveMulipleFormMultiSaverNodeDescriptors |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Sort | Esegue il sort della lista suddividendo gli elementi per livello e per nome file
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSaveMulipleForm.MultiSaverNodeDescriptors

Costruttore DedInvSaveMulipleFormMultiSaverNodeDescriptors

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultiSaverNodeDescriptors()
Public Sub New
public:
MultiSaverNodeDescriptors()
new : unit -> MultiSaverNodeDescriptors
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetInv.Forms


Metodi di MultiSaverNodeDescriptors

Il tipo DedInvSaveMulipleFormMultiSaverNodeDescriptors espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Sort | Esegue il sort della lista suddividendo gli elementi per livello e per nome file
Torna su
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetInv.Forms


Metodo DedInvSaveMulipleForm.MultiSaverNodeDescriptors.Sort

Metodo DedInvSaveMulipleFormMultiSaverNodeDescriptorsSort

Esegue il sort della lista suddividendo gli elementi per livello e per nome file

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Sort()
Public Sub Sort
public:
void Sort()
member Sort : unit -> unit
Vedi anche

Documentazione

Classe DedInvSaveMulipleFormMultiSaverNodeDescriptors
Namespace DedNetInv.Forms


Classe DedInvSubstModelForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDedInvSubstModelForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedInvSubstModelForm : BaseForm
Public Class DedInvSubstModelForm
    Inherits BaseForm
public ref class DedInvSubstModelForm : public BaseForm
type DedInvSubstModelForm =
    class
        inherit BaseForm
    end

Il tipo DedInvSubstModelForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSubstModelForm | Costruttore del form
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | References | Restituisce il dizionario dei riferimenti modificati
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSubstModelForm

Costruttore del form

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSubstModelForm(
    DedNetApplication app,
    InvDocStructInfo invDsInfo
)
Public Sub New (
    app As DedNetApplication,
    invDsInfo As InvDocStructInfo
)
public:
DedInvSubstModelForm(
    DedNetApplication^ app,
    InvDocStructInfo^ invDsInfo
)
new :
        app : DedNetApplication *
        invDsInfo : InvDocStructInfo -> DedInvSubstModelForm

Parametri

app
Tipo: DedNetApplication
Applicatione
invDsInfo
Tipo: DedNetInvInvDocStructInfo
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Proprietà di DedInvSubstModelForm

Il tipo DedInvSubstModelForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | References | Restituisce il dizionario dei riferimenti modificati
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.References

Proprietà DedInvSubstModelFormReferences

Restituisce il dizionario dei riferimenti modificati

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedInvSubstModelFormReferenceChangeDescriptors References { get; }
Public ReadOnly Property References As DedInvSubstModelFormReferenceChangeDescriptors
    Get
public:
property DedInvSubstModelFormReferenceChangeDescriptors^ References {
    DedInvSubstModelFormReferenceChangeDescriptors^ get ();
}
member References : DedInvSubstModelFormReferenceChangeDescriptors with get

Valore della proprietà

Tipo: DedInvSubstModelFormReferenceChangeDescriptors
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Metodi di DedInvSubstModelForm

Il tipo DedInvSubstModelForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Metodo DedInvSubstModelForm.Dispose

Metodo DedInvSubstModelFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Eventi di DedInvSubstModelForm

Il tipo DedInvSubstModelForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Campi di DedInvSubstModelForm

Il tipo DedInvSubstModelForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelForm
Namespace DedNetInv.Forms


Classe DedInvSubstModelForm.ReferenceChangeDescriptor

Classe DedInvSubstModelFormReferenceChangeDescriptor
Descrittore della potenziale modifica dei riferimenti
Gerarchia di ereditarietà
SystemObject
DedNetInv.FormsDedInvSubstModelFormReferenceChangeDescriptor

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ReferenceChangeDescriptor
Public Class ReferenceChangeDescriptor
public ref class ReferenceChangeDescriptor
type ReferenceChangeDescriptor =  class end

Il tipo DedInvSubstModelFormReferenceChangeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSubstModelFormReferenceChangeDescriptor | Costruttore descrittore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigChanged | True se la configurazione è stata modificata dall'utente
Proprietà pubblica | NewConfig | Configurazione di destinazione
Proprietà pubblica | NewPath | Path di destinazione
Proprietà pubblica | OriginalConfig | Configurazione originale
Proprietà pubblica | OriginalPath | Path originale
Proprietà pubblica | PathChanged | True se il path è stato modificato dall'utente
Proprietà pubblica | ReferenceChanged | True se la configurazione è stata modificata dall'utente
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSubstModelForm.ReferenceChangeDescriptor

Costruttore DedInvSubstModelFormReferenceChangeDescriptor

Costruttore descrittore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ReferenceChangeDescriptor(
    string origPath,
    string origConfig,
    string newPath,
    string newConfig
)
Public Sub New (
    origPath As String,
    origConfig As String,
    newPath As String,
    newConfig As String
)
public:
ReferenceChangeDescriptor(
    String^ origPath,
    String^ origConfig,
    String^ newPath,
    String^ newConfig
)
new :
        origPath : string *
        origConfig : string *
        newPath : string *
        newConfig : string -> ReferenceChangeDescriptor

Parametri

origPath
Tipo: SystemString
origConfig
Tipo: SystemString
newPath
Tipo: SystemString
newConfig
Tipo: SystemString
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà di ReferenceChangeDescriptor

Il tipo DedInvSubstModelFormReferenceChangeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ConfigChanged | True se la configurazione è stata modificata dall'utente
Proprietà pubblica | NewConfig | Configurazione di destinazione
Proprietà pubblica | NewPath | Path di destinazione
Proprietà pubblica | OriginalConfig | Configurazione originale
Proprietà pubblica | OriginalPath | Path originale
Proprietà pubblica | PathChanged | True se il path è stato modificato dall'utente
Proprietà pubblica | ReferenceChanged | True se la configurazione è stata modificata dall'utente
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.ConfigChanged

Proprietà DedInvSubstModelFormReferenceChangeDescriptorConfigChanged

True se la configurazione è stata modificata dall'utente

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ConfigChanged { get; }
Public ReadOnly Property ConfigChanged As Boolean
    Get
public:
property bool ConfigChanged {
    bool get ();
}
member ConfigChanged : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.NewConfig

Proprietà DedInvSubstModelFormReferenceChangeDescriptorNewConfig

Configurazione di destinazione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewConfig { get; set; }
Public Property NewConfig As String
    Get
    Set
public:
property String^ NewConfig {
    String^ get ();
    void set (String^ value);
}
member NewConfig : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.NewPath

Proprietà DedInvSubstModelFormReferenceChangeDescriptorNewPath

Path di destinazione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewPath { get; set; }
Public Property NewPath As String
    Get
    Set
public:
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}
member NewPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.OriginalConfig

Proprietà DedInvSubstModelFormReferenceChangeDescriptorOriginalConfig

Configurazione originale

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string OriginalConfig { get; set; }
Public Property OriginalConfig As String
    Get
    Set
public:
property String^ OriginalConfig {
    String^ get ();
    void set (String^ value);
}
member OriginalConfig : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.OriginalPath

Proprietà DedInvSubstModelFormReferenceChangeDescriptorOriginalPath

Path originale

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.PathChanged

Proprietà DedInvSubstModelFormReferenceChangeDescriptorPathChanged

True se il path è stato modificato dall'utente

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PathChanged { get; }
Public ReadOnly Property PathChanged As Boolean
    Get
public:
property bool PathChanged {
    bool get ();
}
member PathChanged : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptor.ReferenceChanged

Proprietà DedInvSubstModelFormReferenceChangeDescriptorReferenceChanged

True se la configurazione è stata modificata dall'utente

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReferenceChanged { get; }
Public ReadOnly Property ReferenceChanged As Boolean
    Get
public:
property bool ReferenceChanged {
    bool get ();
}
member ReferenceChanged : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptor
Namespace DedNetInv.Forms


Classe DedInvSubstModelForm.ReferenceChangeDescriptors

Classe DedInvSubstModelFormReferenceChangeDescriptors
Lista dei riferimenti
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedInvSubstModelFormReferenceChangeDescriptor
DedNetInv.FormsDedInvSubstModelFormReferenceChangeDescriptors

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ReferenceChangeDescriptors : List<DedInvSubstModelFormReferenceChangeDescriptor>
Public Class ReferenceChangeDescriptors
    Inherits List(Of DedInvSubstModelFormReferenceChangeDescriptor)
public ref class ReferenceChangeDescriptors : public List<DedInvSubstModelFormReferenceChangeDescriptor^>
type ReferenceChangeDescriptors =
    class
        inherit List<DedInvSubstModelFormReferenceChangeDescriptor>
    end

Il tipo DedInvSubstModelFormReferenceChangeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedInvSubstModelFormReferenceChangeDescriptors |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasPendingChanges | Controlla se almeno uno dei riferimenti ha subito delle modifiche
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DedInvSubstModelForm.ReferenceChangeDescriptors

Costruttore DedInvSubstModelFormReferenceChangeDescriptors

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ReferenceChangeDescriptors()
Public Sub New
public:
ReferenceChangeDescriptors()
new : unit -> ReferenceChangeDescriptors
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptors
Namespace DedNetInv.Forms


Proprietà di ReferenceChangeDescriptors

Il tipo DedInvSubstModelFormReferenceChangeDescriptors espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasPendingChanges | Controlla se almeno uno dei riferimenti ha subito delle modifiche
Torna su
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptors
Namespace DedNetInv.Forms


Proprietà DedInvSubstModelForm.ReferenceChangeDescriptors.HasPendingChanges

Proprietà DedInvSubstModelFormReferenceChangeDescriptorsHasPendingChanges

Controlla se almeno uno dei riferimenti ha subito delle modifiche

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasPendingChanges { get; }
Public ReadOnly Property HasPendingChanges As Boolean
    Get
public:
property bool HasPendingChanges {
    bool get ();
}
member HasPendingChanges : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedInvSubstModelFormReferenceChangeDescriptors
Namespace DedNetInv.Forms


Classe DocumentsForm
Form utilizzato per la DockableWindow per le dipendenze del documento.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsDocumentsForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentsForm : BaseForm
Public Class DocumentsForm
    Inherits BaseForm
public ref class DocumentsForm : public BaseForm
type DocumentsForm =
    class
        inherit BaseForm
    end

Il tipo DocumentsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentsForm | Costruttore del form ovvero della finestra dockabile.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectionImageSize | Restituisce o imposta le dimensioni delle immagini di Selezione.
Proprietà pubblica | SelectionTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà pubblica | StateImageSize | Restituisce o imposta le dimensioni delle immagini di Stato.
Proprietà pubblica | StateTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Stato.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | AddSelectionImage | Aggiunge una immagine alla lista delle immagini di Selezione.
Metodo pubblico | AddStateImage | Aggiunge una immagine alla lista delle immagini di Stato.
Metodo pubblico | Aggiorna | Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | ClearSelection | Pulisce la selezione dell'albero
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo pubblico | ContainsSelectionImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.
Metodo pubblico | ContainsStateImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo pubblico | HighLight | Evidenzia l'elemento nell'albero
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVirtualNodeGetValues | Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive BaseForm.OnVisibleChanged(EventArgs).)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ReloadStateInformations | Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | Svuota | Svuota l'albero.
Metodo pubblico | Update | Aggiorna il nodo e tutti i suoi figli (se presente).
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DocumentsForm

Costruttore del form ovvero della finestra dockabile.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentsForm(
    FileStateManager stateMan,
    DedNetApplication app
)
Public Sub New (
    stateMan As FileStateManager,
    app As DedNetApplication
)
public:
DocumentsForm(
    FileStateManager^ stateMan,
    DedNetApplication^ app
)
new :
        stateMan : FileStateManager *
        app : DedNetApplication -> DocumentsForm

Parametri

stateMan
Tipo: DedNetInvFileStateManager
Oggetto che permette all'albero di ricevere informazioni sullo stato dei file/documenti dipendenti.
app
Tipo: DedNetApplication
DedNet Application.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | DockableWindow | Restituisce la window dockabile di questo form.
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectionImageSize | Restituisce o imposta le dimensioni delle immagini di Selezione.
Proprietà pubblica | SelectionTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Selezione.
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà pubblica | StateImageSize | Restituisce o imposta le dimensioni delle immagini di Stato.
Proprietà pubblica | StateTrasparentColor | Restituisce o imposta il colore di trasparenza delle immagini di Stato.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà DocumentsForm.DockableWindow

Proprietà DocumentsFormDockableWindow

Restituisce la window dockabile di questo form.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DockableWindow DockableWindow { get; }
Public ReadOnly Property DockableWindow As DockableWindow
    Get
public:
property DockableWindow^ DockableWindow {
    DockableWindow^ get ();
}
member DockableWindow : DockableWindow with get

Valore della proprietà

Tipo: DockableWindow
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà DocumentsForm.SelectionImageSize

Proprietà DocumentsFormSelectionImageSize

Restituisce o imposta le dimensioni delle immagini di Selezione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Size SelectionImageSize { get; set; }
Public Property SelectionImageSize As Size
    Get
    Set
public:
property Size SelectionImageSize {
    Size get ();
    void set (Size value);
}
member SelectionImageSize : Size with get, set

Valore della proprietà

Tipo: Size
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà DocumentsForm.SelectionTrasparentColor

Proprietà DocumentsFormSelectionTrasparentColor

Restituisce o imposta il colore di trasparenza delle immagini di Selezione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Color SelectionTrasparentColor { get; set; }
Public Property SelectionTrasparentColor As Color
    Get
    Set
public:
property Color SelectionTrasparentColor {
    Color get ();
    void set (Color value);
}
member SelectionTrasparentColor : Color with get, set

Valore della proprietà

Tipo: Color
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà DocumentsForm.StateImageSize

Proprietà DocumentsFormStateImageSize

Restituisce o imposta le dimensioni delle immagini di Stato.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Size StateImageSize { get; set; }
Public Property StateImageSize As Size
    Get
    Set
public:
property Size StateImageSize {
    Size get ();
    void set (Size value);
}
member StateImageSize : Size with get, set

Valore della proprietà

Tipo: Size
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Proprietà DocumentsForm.StateTrasparentColor

Proprietà DocumentsFormStateTrasparentColor

Restituisce o imposta il colore di trasparenza delle immagini di Stato.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Color StateTrasparentColor { get; set; }
Public Property StateTrasparentColor As Color
    Get
    Set
public:
property Color StateTrasparentColor {
    Color get ();
    void set (Color value);
}
member StateTrasparentColor : Color with get, set

Valore della proprietà

Tipo: Color
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | AddSelectionImage | Aggiunge una immagine alla lista delle immagini di Selezione.
Metodo pubblico | AddStateImage | Aggiunge una immagine alla lista delle immagini di Stato.
Metodo pubblico | Aggiorna | Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | ClearSelection | Pulisce la selezione dell'albero
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo pubblico | ContainsSelectionImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.
Metodo pubblico | ContainsStateImage | Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo pubblico | HighLight | Evidenzia l'elemento nell'albero
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVirtualNodeGetValues | Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo
Metodo protetto | OnVisibleChanged | Su ritorno a visibilità, aggiorno la visualizzazione. (Sovrascrive BaseForm.OnVisibleChanged(EventArgs).)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ReloadStateInformations | Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | RestoreLayoutFromRegistry | Ripristina il layout del controllo leggendolo dal registro di sistema.
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveLayoutToRegistry | Salva il layout del controllo nel registro di sistema.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo pubblico | Svuota | Svuota l'albero.
Metodo pubblico | Update | Aggiorna il nodo e tutti i suoi figli (se presente).
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.AddSelectionImage

Metodo DocumentsFormAddSelectionImage

Aggiunge una immagine alla lista delle immagini di Selezione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AddSelectionImage(
    Image img,
    string name
)
Public Sub AddSelectionImage (
    img As Image,
    name As String
)
public:
void AddSelectionImage(
    Image^ img,
    String^ name
)
member AddSelectionImage :
        img : Image *
        name : string -> unit

Parametri

img
Tipo: System.DrawingImage
Immagine da aggiungere.
name
Tipo: SystemString
Nome dell'immagine.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.AddStateImage

Metodo DocumentsFormAddStateImage

Aggiunge una immagine alla lista delle immagini di Stato.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AddStateImage(
    Image img,
    string name
)
Public Sub AddStateImage (
    img As Image,
    name As String
)
public:
void AddStateImage(
    Image^ img,
    String^ name
)
member AddStateImage :
        img : Image *
        name : string -> unit

Parametri

img
Tipo: System.DrawingImage
Immagine da aggiungere.
name
Tipo: SystemString
Nome dell'immagine.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.Aggiorna

Metodo DocumentsFormAggiorna

Aggiorna l'albero in modo che siano ricreati i nodi, dal documento attivo (in editazione) fino all'ultimo.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Aggiorna(
    bool restoreStatus
)
Public Sub Aggiorna (
    restoreStatus As Boolean
)
public:
void Aggiorna(
    bool restoreStatus
)
member Aggiorna :
        restoreStatus : bool -> unit

Parametri

restoreStatus
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.ClearSelection

Metodo DocumentsFormClearSelection

Pulisce la selezione dell'albero

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ClearSelection()
Public Sub ClearSelection
public:
void ClearSelection()
member ClearSelection : unit -> unit
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.ContainsSelectionImage

Metodo DocumentsFormContainsSelectionImage

Verifica l'esistenza di una perticolare chiave nella lista delle immagini di selezione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsSelectionImage(
    string name
)
Public Function ContainsSelectionImage (
    name As String
) As Boolean
public:
bool ContainsSelectionImage(
    String^ name
)
member ContainsSelectionImage :
        name : string -> bool

Parametri

name
Tipo: SystemString
Nome dell'immagine da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.ContainsStateImage

Metodo DocumentsFormContainsStateImage

Verifica l'esistenza di una perticolare chiave nella lista delle immagini di stato.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ContainsStateImage(
    string name
)
Public Function ContainsStateImage (
    name As String
) As Boolean
public:
bool ContainsStateImage(
    String^ name
)
member ContainsStateImage :
        name : string -> bool

Parametri

name
Tipo: SystemString
Nome dell'immagine da verificare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.Dispose

Metodo DocumentsFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.HighLight

Metodo DocumentsFormHighLight

Evidenzia l'elemento nell'albero

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void HighLight(
    FileStateElementList fsePath
)
Public Sub HighLight (
    fsePath As FileStateElementList
)
public:
void HighLight(
    FileStateElementList^ fsePath
)
member HighLight :
        fsePath : FileStateElementList -> unit

Parametri

fsePath
Tipo: DedNetInvFileStateElementList
Path degli elementi che identificano il nodo
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.OnVirtualNodeGetValues

Metodo DocumentsFormOnVirtualNodeGetValues

Evento per l'aggiunta operazioni sull'aggiornamento del singolo nodo

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnVirtualNodeGetValues(
    Object node
)
Protected Friend Sub OnVirtualNodeGetValues (
    node As Object
)
protected public:
void OnVirtualNodeGetValues(
    Object^ node
)
member OnVirtualNodeGetValues :
        node : Object -> unit

Parametri

node
Tipo: SystemObject
Nodo di riferimento
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.OnVisibleChanged

Metodo DocumentsFormOnVisibleChanged

Su ritorno a visibilità, aggiorno la visualizzazione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void OnVisibleChanged(
    EventArgs e
)
Protected Overrides Sub OnVisibleChanged (
    e As EventArgs
)
protected:
virtual void OnVisibleChanged(
    EventArgs^ e
) override
abstract OnVisibleChanged :
        e : EventArgs -> unit
override OnVisibleChanged :
        e : EventArgs -> unit

Parametri

e
Tipo: SystemEventArgs
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.ReloadStateInformations

Metodo DocumentsFormReloadStateInformations

Aggiorna le informazioni di stato del nodo selezionato e di tutti i figli

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
Public Sub ReloadStateInformations (
    refreshChildren As Boolean,
    reloadMoved As Boolean
)
public:
void ReloadStateInformations(
    bool refreshChildren,
    bool reloadMoved
)
member ReloadStateInformations :
        refreshChildren : bool *
        reloadMoved : bool -> unit

Parametri

refreshChildren
Tipo: SystemBoolean
reloadMoved
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.RestoreLayoutFromRegistry

Metodo DocumentsFormRestoreLayoutFromRegistry

Ripristina il layout del controllo leggendolo dal registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RestoreLayoutFromRegistry(
    string regKey
)
Public Sub RestoreLayoutFromRegistry (
    regKey As String
)
public:
void RestoreLayoutFromRegistry(
    String^ regKey
)
member RestoreLayoutFromRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave da cui leggere il layout.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.SaveLayoutToRegistry

Metodo DocumentsFormSaveLayoutToRegistry

Salva il layout del controllo nel registro di sistema.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveLayoutToRegistry(
    string regKey
)
Public Sub SaveLayoutToRegistry (
    regKey As String
)
public:
void SaveLayoutToRegistry(
    String^ regKey
)
member SaveLayoutToRegistry :
        regKey : string -> unit

Parametri

regKey
Tipo: SystemString
Path della chiave dove salvare il layout.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.Svuota

Metodo DocumentsFormSvuota

Svuota l'albero.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Svuota()
Public Sub Svuota
public:
void Svuota()
member Svuota : unit -> unit
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Metodo DocumentsForm.Update

Metodo DocumentsFormUpdate

Aggiorna il nodo e tutti i suoi figli (se presente).

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Update(
    FileStateElement el
)
Public Sub Update (
    el As FileStateElement
)
public:
void Update(
    FileStateElement^ el
)
member Update :
        el : FileStateElement -> unit

Parametri

el
Tipo: DedNetInvFileStateElement
Elemento da aggiornare.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Eventi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Campi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetInv.Forms


Classe DocumentsForm.FileStateElementNodeWrapper

Classe DocumentsFormFileStateElementNodeWrapper
Tipo wrapper per la gestione del binding dei dati
Gerarchia di ereditarietà
SystemObject
DedNetInv.FormsDocumentsFormFileStateElementNodeWrapper

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FileStateElementNodeWrapper
Public Class FileStateElementNodeWrapper
public ref class FileStateElementNodeWrapper
type FileStateElementNodeWrapper =  class end

Il tipo DocumentsFormFileStateElementNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentsFormFileStateElementNodeWrapper |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element |
Proprietà pubblica | Expanded |
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore DocumentsForm.FileStateElementNodeWrapper

Costruttore DocumentsFormFileStateElementNodeWrapper

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElementNodeWrapper()
Public Sub New
public:
FileStateElementNodeWrapper()
new : unit -> FileStateElementNodeWrapper
Vedi anche

Documentazione

Classe DocumentsFormFileStateElementNodeWrapper
Namespace DedNetInv.Forms


Proprietà di FileStateElementNodeWrapper

Il tipo DocumentsFormFileStateElementNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Element |
Proprietà pubblica | Expanded |
Torna su
Vedi anche

Documentazione

Classe DocumentsFormFileStateElementNodeWrapper
Namespace DedNetInv.Forms


Proprietà DocumentsForm.FileStateElementNodeWrapper.Element

Proprietà DocumentsFormFileStateElementNodeWrapperElement

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FileStateElement Element { get; set; }
Public Property Element As FileStateElement
    Get
    Set
public:
property FileStateElement^ Element {
    FileStateElement^ get ();
    void set (FileStateElement^ value);
}
member Element : FileStateElement with get, set

Valore della proprietà

Tipo: FileStateElement
Vedi anche

Documentazione

Classe DocumentsFormFileStateElementNodeWrapper
Namespace DedNetInv.Forms


Proprietà DocumentsForm.FileStateElementNodeWrapper.Expanded

Proprietà DocumentsFormFileStateElementNodeWrapperExpanded

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Expanded { get; set; }
Public Property Expanded As Boolean
    Get
    Set
public:
property bool Expanded {
    bool get ();
    void set (bool value);
}
member Expanded : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DocumentsFormFileStateElementNodeWrapper
Namespace DedNetInv.Forms


Classe FindNodesOperation
Gerarchia di ereditarietà
SystemObject
TreeListOperation
DedNetInv.FormsFindNodesOperation

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FindNodesOperation : TreeListOperation
Public Class FindNodesOperation
    Inherits TreeListOperation
public ref class FindNodesOperation : public TreeListOperation
type FindNodesOperation =
    class
        inherit TreeListOperation
    end

Il tipo FindNodesOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FindNodesOperation |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation.)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation.)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode).)
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation.)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation.)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation.)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation.)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore FindNodesOperation

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FindNodesOperation(
    TreeListColumn column,
    Object value
)
Public Sub New (
    column As TreeListColumn,
    value As Object
)
public:
FindNodesOperation(
    TreeListColumn^ column,
    Object^ value
)
new :
        column : TreeListColumn *
        value : Object -> FindNodesOperation

Parametri

column
Tipo: TreeListColumn
value
Tipo: SystemObject
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetInv.Forms


Proprietà di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FoundNodes |
Proprietà pubblica | NeedsFullIteration | (Ereditato da TreeListOperation.)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetInv.Forms


Proprietà FindNodesOperation.FoundNodes

Proprietà FindNodesOperationFoundNodes

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ArrayList FoundNodes { get; }
Public ReadOnly Property FoundNodes As ArrayList
    Get
public:
property ArrayList^ FoundNodes {
    ArrayList^ get ();
}
member FoundNodes : ArrayList with get

Valore della proprietà

Tipo: ArrayList
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetInv.Forms


Metodi di FindNodesOperation

Il tipo FindNodesOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | CanContinueIteration | (Ereditato da TreeListOperation.)
Metodo pubblico | CanExecute | (Ereditato da TreeListOperation.)
Metodo pubblico | Execute | (Sovrascrive TreeListOperation.Execute(TreeListNode).)
Metodo pubblico | FinalizeOperation | (Ereditato da TreeListOperation.)
Metodo protetto | HasChildren | (Ereditato da TreeListOperation.)
Metodo pubblico | NeedsVisitChildren | (Ereditato da TreeListOperation.)
Metodo protetto | OnAfterNodesOperation | (Ereditato da TreeListOperation.)
Metodo protetto | OnNodesOperation | (Ereditato da TreeListOperation.)
Torna su
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetInv.Forms


Metodo FindNodesOperation.Execute

Metodo FindNodesOperationExecute

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void Execute(
    TreeListNode node
)
Public Overrides Sub Execute (
    node As TreeListNode
)
public:
virtual void Execute(
    TreeListNode^ node
) override
abstract Execute :
        node : TreeListNode -> unit
override Execute :
        node : TreeListNode -> unit

Parametri

node
Tipo: TreeListNode
Vedi anche

Documentazione

Classe FindNodesOperation
Namespace DedNetInv.Forms


Classe ModifyingDocumentsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsModifyingDocumentsForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ModifyingDocumentsForm : BaseForm
Public Class ModifyingDocumentsForm
    Inherits BaseForm
public ref class ModifyingDocumentsForm : public BaseForm
type ModifyingDocumentsForm =
    class
        inherit BaseForm
    end

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ModifyingDocumentsForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | Ask | Restituisce o imposta se la finestra sia da aprire in modalità richiesta di conferma o sola visualizzasione.
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | Editable | Restituisce o imposta se la finestra è editabile. Ovvero se in caso di checkin è possibile controllare la riservazione dei documenti
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | Label | Restituisce o imposta l'etichetta da visualizzare per l'operazione
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà pubblica | ModList | Restituisce o imposta la lista degli elementi da visualizzare.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ReloadDocMode | Specifica se il dialogo è in modalità di richiesta ricarimento dei documenti
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo pubblico | CanSelectRow | Controlla se un nodo è selezionabile
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | ClearSelection | Rimuove la selezione da tutti i nodi
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawCheckBox | Gestire il disegno della checkbox nella colonna Checkout.
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo pubblico | SelectAll | Seleziona tutti i nodi selezionabili
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore ModifyingDocumentsForm

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentsForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
ModifyingDocumentsForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> ModifyingDocumentsForm

Parametri

app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | Ask | Restituisce o imposta se la finestra sia da aprire in modalità richiesta di conferma o sola visualizzasione.
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | Editable | Restituisce o imposta se la finestra è editabile. Ovvero se in caso di checkin è possibile controllare la riservazione dei documenti
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | Label | Restituisce o imposta l'etichetta da visualizzare per l'operazione
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà pubblica | ModList | Restituisce o imposta la lista degli elementi da visualizzare.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ReloadDocMode | Specifica se il dialogo è in modalità di richiesta ricarimento dei documenti
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà ModifyingDocumentsForm.Ask

Proprietà ModifyingDocumentsFormAsk

Restituisce o imposta se la finestra sia da aprire in modalità richiesta di conferma o sola visualizzasione.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Ask { get; set; }
Public Property Ask As Boolean
    Get
    Set
public:
property bool Ask {
    bool get ();
    void set (bool value);
}
member Ask : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà ModifyingDocumentsForm.Editable

Proprietà ModifyingDocumentsFormEditable

Restituisce o imposta se la finestra è editabile. Ovvero se in caso di checkin è possibile controllare la riservazione dei documenti

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Editable { get; set; }
Public Property Editable As Boolean
    Get
    Set
public:
property bool Editable {
    bool get ();
    void set (bool value);
}
member Editable : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà ModifyingDocumentsForm.Label

Proprietà ModifyingDocumentsFormLabel

Restituisce o imposta l'etichetta da visualizzare per l'operazione

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà ModifyingDocumentsForm.ModList

Proprietà ModifyingDocumentsFormModList

Restituisce o imposta la lista degli elementi da visualizzare.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ModifyingDocumentInfoList ModList { get; set; }
Public Property ModList As ModifyingDocumentInfoList
    Get
    Set
public:
property ModifyingDocumentInfoList^ ModList {
    ModifyingDocumentInfoList^ get ();
    void set (ModifyingDocumentInfoList^ value);
}
member ModList : ModifyingDocumentInfoList with get, set

Valore della proprietà

Tipo: ModifyingDocumentInfoList
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Proprietà ModifyingDocumentsForm.ReloadDocMode

Proprietà ModifyingDocumentsFormReloadDocMode

Specifica se il dialogo è in modalità di richiesta ricarimento dei documenti

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ReloadDocMode { get; set; }
Public Property ReloadDocMode As Boolean
    Get
    Set
public:
property bool ReloadDocMode {
    bool get ();
    void set (bool value);
}
member ReloadDocMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo pubblico | CanSelectRow | Controlla se un nodo è selezionabile
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo pubblico | ClearSelection | Rimuove la selezione da tutti i nodi
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawCheckBox | Gestire il disegno della checkbox nella colonna Checkout.
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo pubblico | SelectAll | Seleziona tutti i nodi selezionabili
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodo ModifyingDocumentsForm.CanSelectRow

Metodo ModifyingDocumentsFormCanSelectRow

Controlla se un nodo è selezionabile

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CanSelectRow(
    int rowHandle
)
Public Function CanSelectRow (
    rowHandle As Integer
) As Boolean
public:
bool CanSelectRow(
    int rowHandle
)
member CanSelectRow :
        rowHandle : int -> bool

Parametri

rowHandle
Tipo: SystemInt32

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodo ModifyingDocumentsForm.ClearSelection

Metodo ModifyingDocumentsFormClearSelection

Rimuove la selezione da tutti i nodi

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ClearSelection()
Public Sub ClearSelection
public:
void ClearSelection()
member ClearSelection : unit -> unit
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodo ModifyingDocumentsForm.Dispose

Metodo ModifyingDocumentsFormDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodo ModifyingDocumentsForm.DrawCheckBox

Metodo ModifyingDocumentsFormDrawCheckBox

Gestire il disegno della checkbox nella colonna Checkout.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void DrawCheckBox(
    Graphics g,
    Rectangle r,
    bool Checked
)
Protected Sub DrawCheckBox (
    g As Graphics,
    r As Rectangle,
    Checked As Boolean
)
protected:
void DrawCheckBox(
    Graphics^ g,
    Rectangle r,
    bool Checked
)
member DrawCheckBox :
        g : Graphics *
        r : Rectangle *
        Checked : bool -> unit

Parametri

g
Tipo: System.DrawingGraphics
r
Tipo: System.DrawingRectangle
Checked
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Metodo ModifyingDocumentsForm.SelectAll

Metodo ModifyingDocumentsFormSelectAll

Seleziona tutti i nodi selezionabili

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SelectAll()
Public Sub SelectAll
public:
void SelectAll()
member SelectAll : unit -> unit
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Eventi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Campi di ModifyingDocumentsForm

Il tipo ModifyingDocumentsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ModifyingDocumentsForm
Namespace DedNetInv.Forms


Classe MultipleStateOperation
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetInv.FormsMultipleStateOperation

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultipleStateOperation : BaseForm
Public Class MultipleStateOperation
    Inherits BaseForm
public ref class MultipleStateOperation : public BaseForm
type MultipleStateOperation =
    class
        inherit BaseForm
    end

Il tipo MultipleStateOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperation | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
 | _stateIndex | Dizionario contenete lo stato e il relativo indice nella ImageCollection.
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetInv.Forms


Costruttore MultipleStateOperation

Costruttore

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperation(
    DedNetApplication app,
    DedState operation,
    InvDocStructInfo ds,
    Icon cmdIcon
)
Public Sub New (
    app As DedNetApplication,
    operation As DedState,
    ds As InvDocStructInfo,
    cmdIcon As Icon
)
public:
MultipleStateOperation(
    DedNetApplication^ app,
    DedState^ operation,
    InvDocStructInfo^ ds,
    Icon^ cmdIcon
)
new :
        app : DedNetApplication *
        operation : DedState *
        ds : InvDocStructInfo *
        cmdIcon : Icon -> MultipleStateOperation

Parametri

app
Tipo: DedNetApplication
Applicazione DedNet
operation
Tipo: DedState
Tipo di operazione da applicare
ds
Tipo: DedNetInvInvDocStructInfo
Descrittore Struttura del Documento di Testa
cmdIcon
Tipo: System.DrawingIcon
Icona del comando. Dipende dal tipo di operazione da attuare.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Proprietà di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | Restituisce l'applicazione alla quale questo Form appartiene. (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Chiave di registro in cui scrivere le impostazioni di layout. (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldCheckDpiScaleFactorBeforeFormShown | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Proprietà MultipleStateOperation.ChangeStateNote

Proprietà MultipleStateOperationChangeStateNote

Note di cambio stato

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ChangeStateNote { get; set; }
Public Property ChangeStateNote As String
    Get
    Set
public:
property String^ ChangeStateNote {
    String^ get ();
    void set (String^ value);
}
member ChangeStateNote : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Proprietà MultipleStateOperation.OperationDelegate

Proprietà MultipleStateOperationOperationDelegate

Proprietà per impostare il delegate dell'operazione sul singolo oggetto

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperationOperationDelagateHandler OperationDelegate { get; set; }
Public Property OperationDelegate As MultipleStateOperationOperationDelagateHandler
    Get
    Set
public:
property MultipleStateOperationOperationDelagateHandler^ OperationDelegate {
    MultipleStateOperationOperationDelagateHandler^ get ();
    void set (MultipleStateOperationOperationDelagateHandler^ value);
}
member OperationDelegate : MultipleStateOperationOperationDelagateHandler with get, set

Valore della proprietà

Tipo: MultipleStateOperationOperationDelagateHandler
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Proprietà MultipleStateOperation.Res

Proprietà MultipleStateOperationRes

Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult Res { get; }
Public ReadOnly Property Res As DedCmdResult
    Get
public:
property DedCmdResult Res {
    DedCmdResult get ();
}
member Res : DedCmdResult with get

Valore della proprietà

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Metodi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | Aggiunge alla barra specificata in ingresso le funzionalità di utilità generale (aggiunta del menu "?" e l'impossibilità di lasciare le barra flottante). (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | Inizializza la variabile contenente la root di salvataggio impostazioni in modo che contenga il nome del form derivato. (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | Se viene impostato visible a false scrive le impostazioni di posizione e dimensione nel registro. (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Metodo MultipleStateOperation.Dispose

Metodo MultipleStateOperationDispose

Clean up any resources being used.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Metodo MultipleStateOperation.LoadRegistrySettings

Metodo MultipleStateOperationLoadRegistrySettings

Carica dal registro lo stato di visualizzazione livelli dell'albero

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings()
Public Sub LoadRegistrySettings
public:
void LoadRegistrySettings()
member LoadRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Metodo MultipleStateOperation.SaveRegistrySettings

Metodo MultipleStateOperationSaveRegistrySettings

Salva nel registro lo stato di visualizzazione livelli dell'albero.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Eventi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Campi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Campi
 | Nome | Descrizione
 | _stateIndex | Dizionario contenete lo stato e il relativo indice nella ImageCollection.
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Campo MultipleStateOperation._stateIndex

Campo MultipleStateOperation_stateIndex
Dizionario contenete lo stato e il relativo indice nella ImageCollection.

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, int> _stateIndex
Public Shared _stateIndex As Dictionary(Of String, Integer)
public:
static Dictionary<String^, int>^ _stateIndex
static val mutable _stateIndex: Dictionary<string, int>

Valore del campo

Tipo: Dictionary String, Int32
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetInv.Forms


Delegate MultipleStateOperation.OperationDelagateHandler

Delegate MultipleStateOperationOperationDelagateHandler

Namespace: DedNetInv.Forms
Assembly: DedNetInv (in DedNetInv.dll) Versione: 24.6.0.0 (24.6.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate DedCmdResult OperationDelagateHandler(
    DedState targetState,
    string changeNote,
    InvDocStructInfo mltMainInvDsInfo,
    InvDocStructInfo invDsInfo,
    bool isChildOperation,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Delegate Function OperationDelagateHandler (
    targetState As DedState,
    changeNote As String,
    mltMainInvDsInfo As InvDocStructInfo,
    invDsInfo As InvDocStructInfo,
    isChildOperation As Boolean,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public delegate DedCmdResult OperationDelagateHandler(
    DedState^ targetState,
    String^ changeNote,
    InvDocStructInfo^ mltMainInvDsInfo,
    InvDocStructInfo^ invDsInfo,
    bool isChildOperation,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
type OperationDelagateHandler =
    delegate of
        targetState : DedState *
        changeNote : string *
        mltMainInvDsInfo : InvDocStructInfo *
        invDsInfo : InvDocStructInfo *
        isChildOperation : bool *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState
Tipo: DedState
changeNote
Tipo: SystemString
mltMainInvDsInfo
Tipo: DedNetInvInvDocStructInfo
invDsInfo
Tipo: DedNetInvInvDocStructInfo
isChildOperation
Tipo: SystemBoolean
multiplo
Tipo: SystemBoolean
message
Tipo: SystemString
pubExtList
Tipo: System.Collections.GenericList Exception

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Namespace DedNetInv.Forms