QsUI Namespace
Classi
 | Classe | Descrizione
Classe pubblica | ElaborationReport |
Classe pubblica | ElaborationReportResultDescriptor | Oggetto descrittore del risultato dell'elaborazione
Classe pubblica | FormBarProg | Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Classe pubblica | FormException | Finestra di dialogo per visualizzare le eccezioni nel codice.
Classe pubblica | InputBox | The InputBox class is used to show a prompt in a dialog box using the static method Show().
Classe pubblica | InputBoxResult | Class used to store the result of an InputBox.Show message.
Classe pubblica | InputBoxValidatingArgs | EventArgs used to Validate an InputBox
Classe pubblica | ListChoice | Classe che permette di visualizzare un form per scegliere gli elementi da una lista.
Classe pubblica | OkCancelControl | Classe che implementa il controllo di due bottoni ( ok , cancel )
Classe pubblica | QsBaseForm |
Classe pubblica | QsException | Classe base per la gestione delle eccezioni.
Classe pubblica | QsExceptionList | Eccezione contenente una lista di eccezioni.
Classe pubblica | QsUI |
Classe pubblica | QuestionForm | Finestra per mostrare un form con la possibilità di scegliere tra [Si-Si Tutti-No-No Tutti].
Classe pubblica | ThumbnailControl | Classe usata per ricavare l'anteprima di un file.
Classe pubblica | TreeListChoice |
Classe pubblica | TreeListChoiceCheckNodeEventArgs | Argomento contenente le informazioni relative al comando in esecuzione.
Classe pubblica | WindowsThumbnailProvider |
Strutture
 | Struttura | Descrizione
Struttura pubblica | WindowsThumbnailProviderRGBQUAD |
Delegate
 | Delegate | Descrizione
Delegate pubblico | ElaborationReportBoundDataOperationDelegate | Delegate per la personalizzazione del comportamento del form
Delegate pubblico | ElaborationReportExecuteOperationDelegate |
Delegate pubblico | ElaborationReportGetIdObjectDelegate |
Delegate pubblico | InputBoxValidatingHandler | Delegate used to Validate an InputBox
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | ElaborationReportOperationStatus | Enumerazione dei possibili stati del risultato
Enumerazione pubblica | QuestionFormQuestionButtonSet | Enumerazione dei pulsanti da visualizzare all'utente.
Enumerazione pubblica | QuestionFormQuestionResult | Enumerazione per la gestione dei risultati multipli.
Enumerazione pubblica | ThumbnailOptions |

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ElaborationReport
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIElaborationReport

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ElaborationReport : QsBaseForm
Public Class ElaborationReport
    Inherits QsBaseForm
public ref class ElaborationReport : public QsBaseForm
type ElaborationReport =
    class
        inherit QsBaseForm
    end

Il tipo ElaborationReport espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ElaborationReport | Costruttore pubblico
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowCancel | Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | AutoClose | Determina se chiudere automaticamente il dialogo al termine dell'elaborazione
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundWorkingMode | Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.
Proprietà pubblica | BoundDataDelegate | Delegate binding dei dati nelle colonne
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà pubblica | CustomFields | Dizionario dei campi custom
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | ElaborationExceptions | Lista eccezioni di elaborazione
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | ExecutorDelegate | Delegate di esecuzione
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà pubblica | GetIdDelegate | Delegate per l'identificazione dell'oggetto
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ObjList | Lista di oggetti ai quali aplicare l'elaborazione
Proprietà pubblica | RunOnLoad | Determina se l'elaborazione deve scattare all'avvio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI


Costruttore ElaborationReport

Costruttore pubblico

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReport()
Public Sub New
public:
ElaborationReport()
new : unit -> ElaborationReport
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowCancel | Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | AutoClose | Determina se chiudere automaticamente il dialogo al termine dell'elaborazione
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundWorkingMode | Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.
Proprietà pubblica | BoundDataDelegate | Delegate binding dei dati nelle colonne
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà pubblica | CustomFields | Dizionario dei campi custom
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | ElaborationExceptions | Lista eccezioni di elaborazione
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | ExecutorDelegate | Delegate di esecuzione
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà pubblica | GetIdDelegate | Delegate per l'identificazione dell'oggetto
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | ObjList | Lista di oggetti ai quali aplicare l'elaborazione
Proprietà pubblica | RunOnLoad | Determina se l'elaborazione deve scattare all'avvio
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.AllowCancel

Libreria interfaccie

Proprietà ElaborationReportAllowCancel

Se attivo permette l'annullamento dell'operazione attivando il tasto con la x rossa

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllowCancel { get; set; }
Public Property AllowCancel As Boolean
    Get
    Set
public:
property bool AllowCancel {
    bool get ();
    void set (bool value);
}
member AllowCancel : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.AutoClose

Proprietà ElaborationReportAutoClose

Determina se chiudere automaticamente il dialogo al termine dell'elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AutoClose { get; set; }
Public Property AutoClose As Boolean
    Get
    Set
public:
property bool AutoClose {
    bool get ();
    void set (bool value);
}
member AutoClose : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.BackgroundWorkingMode

Proprietà ElaborationReportBackgroundWorkingMode

Determina se deve girare in modalità background working. ATTENZIONE! Fondamentale settarlo a false per l'utilizzo in ambiente lua.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool BackgroundWorkingMode { get; set; }
Public Property BackgroundWorkingMode As Boolean
    Get
    Set
public:
property bool BackgroundWorkingMode {
    bool get ();
    void set (bool value);
}
member BackgroundWorkingMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.BoundDataDelegate

Proprietà ElaborationReportBoundDataDelegate

Delegate binding dei dati nelle colonne

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportBoundDataOperationDelegate BoundDataDelegate { get; set; }
Public Property BoundDataDelegate As ElaborationReportBoundDataOperationDelegate
    Get
    Set
public:
property ElaborationReportBoundDataOperationDelegate^ BoundDataDelegate {
    ElaborationReportBoundDataOperationDelegate^ get ();
    void set (ElaborationReportBoundDataOperationDelegate^ value);
}
member BoundDataDelegate : ElaborationReportBoundDataOperationDelegate with get, set

Valore della proprietà

Tipo: ElaborationReportBoundDataOperationDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.CustomFields

Proprietà ElaborationReportCustomFields

Dizionario dei campi custom

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> CustomFields { get; set; }
Public Property CustomFields As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ CustomFields {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
member CustomFields : Dictionary<string, string> with get, set

Valore della proprietà

Tipo: Dictionary String, String
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ElaborationExceptions

Proprietà ElaborationReportElaborationExceptions

Lista eccezioni di elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> ElaborationExceptions { get; }
Public ReadOnly Property ElaborationExceptions As List(Of Exception)
    Get
public:
property List<Exception^>^ ElaborationExceptions {
    List<Exception^>^ get ();
}
member ElaborationExceptions : List<Exception> with get

Valore della proprietà

Tipo: List Exception
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ExecutorDelegate

Proprietà ElaborationReportExecutorDelegate

Delegate di esecuzione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportExecuteOperationDelegate ExecutorDelegate { get; set; }
Public Property ExecutorDelegate As ElaborationReportExecuteOperationDelegate
    Get
    Set
public:
property ElaborationReportExecuteOperationDelegate^ ExecutorDelegate {
    ElaborationReportExecuteOperationDelegate^ get ();
    void set (ElaborationReportExecuteOperationDelegate^ value);
}
member ExecutorDelegate : ElaborationReportExecuteOperationDelegate with get, set

Valore della proprietà

Tipo: ElaborationReportExecuteOperationDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.GetIdDelegate

Proprietà ElaborationReportGetIdDelegate

Delegate per l'identificazione dell'oggetto

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportGetIdObjectDelegate GetIdDelegate { get; set; }
Public Property GetIdDelegate As ElaborationReportGetIdObjectDelegate
    Get
    Set
public:
property ElaborationReportGetIdObjectDelegate^ GetIdDelegate {
    ElaborationReportGetIdObjectDelegate^ get ();
    void set (ElaborationReportGetIdObjectDelegate^ value);
}
member GetIdDelegate : ElaborationReportGetIdObjectDelegate with get, set

Valore della proprietà

Tipo: ElaborationReportGetIdObjectDelegate
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.ObjList

Proprietà ElaborationReportObjList

Lista di oggetti ai quali aplicare l'elaborazione

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public IEnumerable ObjList { get; set; }
Public Property ObjList As IEnumerable
    Get
    Set
public:
property IEnumerable^ ObjList {
    IEnumerable^ get ();
    void set (IEnumerable^ value);
}
member ObjList : IEnumerable with get, set

Valore della proprietà

Tipo: IEnumerable
Vedi anche

Documentazione

Classe ElaborationReport


Proprietà ElaborationReport.RunOnLoad

Proprietà ElaborationReportRunOnLoad

Determina se l'elaborazione deve scattare all'avvio

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RunOnLoad { get; set; }
Public Property RunOnLoad As Boolean
    Get
    Set
public:
property bool RunOnLoad {
    bool get ();
    void set (bool value);
}
member RunOnLoad : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ElaborationReport


Metodi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Metodo ElaborationReport.Dispose

Metodo ElaborationReportDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ElaborationReport


Eventi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Campi di ElaborationReport

Il tipo ElaborationReport espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ElaborationReport


Delegate ElaborationReport.BoundDataOperationDelegate

Delegate ElaborationReportBoundDataOperationDelegate
Delegate per la personalizzazione del comportamento del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate Object BoundDataOperationDelegate(
    string fieldname,
    Object argument
)
Public Delegate Function BoundDataOperationDelegate (
    fieldname As String,
    argument As Object
) As Object
public delegate Object^ BoundDataOperationDelegate(
    String^ fieldname,
    Object^ argument
)
type BoundDataOperationDelegate =
    delegate of
        fieldname : string *
        argument : Object -> Object

Parametri

fieldname
Tipo: SystemString
argument
Tipo: SystemObject

Valore di ritorno

Tipo: Object
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Delegate ElaborationReport.ExecuteOperationDelegate

Delegate ElaborationReportExecuteOperationDelegate

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate ElaborationReportResultDescriptor ExecuteOperationDelegate(
    Object argument
)
Public Delegate Function ExecuteOperationDelegate (
    argument As Object
) As ElaborationReportResultDescriptor
public delegate ElaborationReportResultDescriptor^ ExecuteOperationDelegate(
    Object^ argument
)
type ExecuteOperationDelegate =
    delegate of
        argument : Object -> ElaborationReportResultDescriptor

Parametri

argument
Tipo: SystemObject

Valore di ritorno

Tipo: ElaborationReportResultDescriptor
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Delegate ElaborationReport.GetIdObjectDelegate

Delegate ElaborationReportGetIdObjectDelegate

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate Object GetIdObjectDelegate(
    Object argument
)
Public Delegate Function GetIdObjectDelegate (
    argument As Object
) As Object
public delegate Object^ GetIdObjectDelegate(
    Object^ argument
)
type GetIdObjectDelegate =
    delegate of
        argument : Object -> Object

Parametri

argument
Tipo: SystemObject

Valore di ritorno

Tipo: Object
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione ElaborationReport.OperationStatus

Enumerazione ElaborationReportOperationStatus
Enumerazione dei possibili stati del risultato

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum OperationStatus
Public Enumeration OperationStatus
public enum class OperationStatus
type OperationStatus
Membri
Nome | Valore | Descrizione
ok | 0 |
warning | 1 |
error | 2 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ElaborationReport.ResultDescriptor

Classe ElaborationReportResultDescriptor
Oggetto descrittore del risultato dell'elaborazione
Gerarchia di ereditarietà
SystemObject
QsUIElaborationReportResultDescriptor

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResultDescriptor
Public Class ResultDescriptor
public ref class ResultDescriptor
type ResultDescriptor =  class end

Il tipo ElaborationReportResultDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ElaborationReportResultDescriptor | Inizializza una nuova istanza della classe ElaborationReportResultDescriptor.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | message |
Campo pubblico | status |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ElaborationReport.ResultDescriptor

Costruttore ElaborationReportResultDescriptor

Inizializza una nuova istanza della classe ElaborationReportResultDescriptor.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ResultDescriptor(
    ElaborationReportOperationStatus isOk,
    Object msg
)
Public Sub New (
    isOk As ElaborationReportOperationStatus,
    msg As Object
)
public:
ResultDescriptor(
    ElaborationReportOperationStatus isOk,
    Object^ msg
)
new :
        isOk : ElaborationReportOperationStatus *
        msg : Object -> ResultDescriptor

Parametri

isOk
Tipo: QsUIElaborationReportOperationStatus
msg
Tipo: SystemObject
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campi di ResultDescriptor

Il tipo ElaborationReportResultDescriptor espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | message |
Campo pubblico | status |
Torna su
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campo ElaborationReport.ResultDescriptor.message

Campo ElaborationReportResultDescriptormessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object message
Public message As Object
public:
Object^ message
val mutable message: Object

Valore del campo

Tipo: Object
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Campo ElaborationReport.ResultDescriptor.status

Campo ElaborationReportResultDescriptorstatus

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ElaborationReportOperationStatus status
Public status As ElaborationReportOperationStatus
public:
ElaborationReportOperationStatus status
val mutable status: ElaborationReportOperationStatus

Valore del campo

Tipo: ElaborationReportOperationStatus
Vedi anche

Documentazione

Classe ElaborationReportResultDescriptor


Classe FormBarProg
Classe per visualizzare una progress bar di avanzamento. Costruire il form e poi chiamare i vari metodi ( ci pensa lui a visualizzarsi e chiudersi quando parte e termina )
Gerarchia di ereditarietà
SystemObject
QsUIFormBarProg

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FormBarProg
Public Class FormBarProg
public ref class FormBarProg
type FormBarProg =  class end

Il tipo FormBarProg espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FormBarProg | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà pubblica | Location | Imposta la posizione del form
Proprietà pubblica | Size | Ritorna la dimensione del form
Proprietà pubblica | Text | Imposta il testo del form.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiusura Form.
Metodo pubblico | Decrement | Decrementa la progress bar con il valore passato.
Metodo pubblico | Increment | Incrementa la progress bar con il valore passato.
Metodo pubblico | IncrementStep | Incermenta la progress bar del valore dello step.
Metodo pubblico | IsOpen | Ritorna True se il form è visibile, False altrimenti.
Metodo pubblico | SetMax | Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.
Metodo pubblico | SetMessage | Imposta il testo del form.
Metodo pubblico | SetText | Imposta il testo del form.
Metodo pubblico | Show | Visualizza il Form.
Metodo pubblico | ShowDialog | Visualizza il Form.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FormBarProg

Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormBarProg(
    int minValue,
    int maxValue,
    int stepValue,
    bool autoShow = true,
    bool autoClose = true,
    bool topMost = true,
    bool disableCancelButton = true,
    bool hasProgr = true
)
Public Sub New (
    minValue As Integer,
    maxValue As Integer,
    stepValue As Integer,
    Optional autoShow As Boolean = true,
    Optional autoClose As Boolean = true,
    Optional topMost As Boolean = true,
    Optional disableCancelButton As Boolean = true,
    Optional hasProgr As Boolean = true
)
public:
FormBarProg(
    int minValue,
    int maxValue,
    int stepValue,
    bool autoShow = true,
    bool autoClose = true,
    bool topMost = true,
    bool disableCancelButton = true,
    bool hasProgr = true
)
new :
        minValue : int *
        maxValue : int *
        stepValue : int *
        ?autoShow : bool *
        ?autoClose : bool *
        ?topMost : bool *
        ?disableCancelButton : bool *
        ?hasProgr : bool
(* Defaults:
        let _autoShow = defaultArg autoShow true
        let _autoClose = defaultArg autoClose true
        let _topMost = defaultArg topMost true
        let _disableCancelButton = defaultArg disableCancelButton true
        let _hasProgr = defaultArg hasProgr true
*)
-> FormBarProg

Parametri

minValue
Tipo: SystemInt32
Valore di partenza.
maxValue
Tipo: SystemInt32
Valore di arrivo.
stepValue
Tipo: SystemInt32
Valore di incremento.
autoShow (Optional)
Tipo: SystemBoolean
Indica se mostrare il form in automatico (nel caso di marquee deve per forza essere visualizzato dall'utente)
autoClose (Optional)
Tipo: SystemBoolean
Indica se chiudere il form in automatico (nel caso di marquee deve per forza essere chiuso dall'utente)
topMost (Optional)
Tipo: SystemBoolean
Indica se il form deve essere in primo piano
disableCancelButton (Optional)
Tipo: SystemBoolean
Indica se disabilitare il pulsante di cancel
hasProgr (Optional)
Tipo: SystemBoolean
Indica se mostrare la barra di progressione o se è marquee
Vedi anche

Documentazione

Classe FormBarProg


Proprietà di FormBarProg

Il tipo FormBarProg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | HasProg | Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.
Proprietà pubblica | Location | Imposta la posizione del form
Proprietà pubblica | Size | Ritorna la dimensione del form
Proprietà pubblica | Text | Imposta il testo del form.
Torna su
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.HasProg

Proprietà FormBarProgHasProg

Se impostato a True, visualizza la progressbar con l'avanzamento incrementale, altrimenti la progressbar a ciclo infinito.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasProg { set; }
Public WriteOnly Property HasProg As Boolean
    Set
public:
property bool HasProg {
    void set (bool value);
}
member HasProg : bool with set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Location

Proprietà FormBarProgLocation

Imposta la posizione del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Point Location { set; }
Public WriteOnly Property Location As Point
    Set
public:
property Point Location {
    void set (Point value);
}
member Location : Point with set

Valore della proprietà

Tipo: Point
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Size

Proprietà FormBarProgSize

Ritorna la dimensione del form

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Size Size { get; }
Public ReadOnly Property Size As Size
    Get
public:
property Size Size {
    Size get ();
}
member Size : Size with get

Valore della proprietà

Tipo: Size
Vedi anche

Documentazione

Classe FormBarProg


Proprietà FormBarProg.Text

Proprietà FormBarProgText

Imposta il testo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Text { set; }
Public WriteOnly Property Text As String
    Set
public:
property String^ Text {
    void set (String^ value);
}
member Text : string with set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FormBarProg


Metodi di FormBarProg

Il tipo FormBarProg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiusura Form.
Metodo pubblico | Decrement | Decrementa la progress bar con il valore passato.
Metodo pubblico | Increment | Incrementa la progress bar con il valore passato.
Metodo pubblico | IncrementStep | Incermenta la progress bar del valore dello step.
Metodo pubblico | IsOpen | Ritorna True se il form è visibile, False altrimenti.
Metodo pubblico | SetMax | Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.
Metodo pubblico | SetMessage | Imposta il testo del form.
Metodo pubblico | SetText | Imposta il testo del form.
Metodo pubblico | Show | Visualizza il Form.
Metodo pubblico | ShowDialog | Visualizza il Form.
Torna su
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Close

Metodo FormBarProgClose

Chiusura Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Decrement

Metodo FormBarProgDecrement

Decrementa la progress bar con il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Decrement(
    int value
)
Public Sub Decrement (
    value As Integer
)
public:
void Decrement(
    int value
)
member Decrement :
        value : int -> unit

Parametri

value
Tipo: SystemInt32
Valore di decremento della progress bar.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Increment

Metodo FormBarProgIncrement

Incrementa la progress bar con il valore passato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Increment(
    int value
)
Public Sub Increment (
    value As Integer
)
public:
void Increment(
    int value
)
member Increment :
        value : int -> unit

Parametri

value
Tipo: SystemInt32
Valore di incremento della progress bar.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.IncrementStep

Metodo FormBarProgIncrementStep

Incermenta la progress bar del valore dello step.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void IncrementStep()
Public Sub IncrementStep
public:
void IncrementStep()
member IncrementStep : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.IsOpen

Metodo FormBarProgIsOpen

Ritorna True se il form è visibile, False altrimenti.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsOpen()
Public Function IsOpen As Boolean
public:
bool IsOpen()
member IsOpen : unit -> bool

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetMax

Metodo FormBarProgSetMax

Reimposta il valore massimo della progressbar. Attenzione però! dopo che il valore massimo è stato reimpostato, lo step della progressbar viene impostato a 1 e l'indicatore di avanzamento viene resettato a 0.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetMax(
    int value
)
Public Sub SetMax (
    value As Integer
)
public:
void SetMax(
    int value
)
member SetMax :
        value : int -> unit

Parametri

value
Tipo: SystemInt32
Nuovo valore massimo che la progressbar può raggiungere.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetMessage

Metodo FormBarProgSetMessage

Imposta il testo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetMessage(
    string message
)
Public Sub SetMessage (
    message As String
)
public:
void SetMessage(
    String^ message
)
member SetMessage :
        message : string -> unit

Parametri

message
Tipo: SystemString
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.SetText

Metodo FormBarProgSetText

Imposta il testo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetText(
    string text
)
Public Sub SetText (
    text As String
)
public:
void SetText(
    String^ text
)
member SetText :
        text : string -> unit

Parametri

text
Tipo: SystemString
Testo da visualizzare.
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.Show

Metodo FormBarProgShow

Visualizza il Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Show()
Public Sub Show
public:
void Show()
member Show : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Metodo FormBarProg.ShowDialog

Metodo FormBarProgShowDialog

Visualizza il Form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowDialog()
Public Sub ShowDialog
public:
void ShowDialog()
member ShowDialog : unit -> unit
Vedi anche

Documentazione

Classe FormBarProg


Classe FormException
Finestra di dialogo per visualizzare le eccezioni nel codice.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIFormException

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class FormException : QsBaseForm
Public Class FormException
    Inherits QsBaseForm
public ref class FormException : public QsBaseForm
type FormException =
    class
        inherit QsBaseForm
    end

Il tipo FormException espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | FormException | Costruttore di con tutti i valori di default.
Metodo pubblico | FormException(ListException, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Exception, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, ListException) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, Exception) | Cotruttore della classe.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Exceptions | Permette di impostare l'eccezione da visualizzare
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | NotShowAgain | Indica se la spunta "Non mostrare più" è nascosta o meno.
Proprietà pubblica | RowImage | Permette di impostare l'icona della finestra
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | Title | Restituisce o imposta il titolo della finestra.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore FormException

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | FormException | Costruttore di con tutti i valori di default.
Metodo pubblico | FormException(ListException, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Exception, Boolean) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, ListException) | Cotruttore della classe.
Metodo pubblico | FormException(Image, String, Exception) | Cotruttore della classe.
Torna su
Vedi anche

Documentazione

Classe FormException


Costruttore FormException

Costruttore di con tutti i valori di default.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormException()
Public Sub New
public:
FormException()
new : unit -> FormException
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException (List(Exception), Boolean)

Costruttore FormException (ListException, Boolean)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    List<Exception> exceptions,
    bool notShowAgain = false
)
Public Sub New (
    exceptions As List(Of Exception),
    Optional notShowAgain As Boolean = false
)
public:
FormException(
    List<Exception^>^ exceptions,
    bool notShowAgain = false
)
new :
        exceptions : List<Exception> *
        ?notShowAgain : bool
(* Defaults:
        let _notShowAgain = defaultArg notShowAgain false
*)
-> FormException

Parametri

exceptions
Tipo: System.Collections.GenericList Exception
Lista di eccezioni da visulaizzare
notShowAgain (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException (Exception, Boolean)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Exception exception,
    bool notShowAgain = false
)
Public Sub New (
    exception As Exception,
    Optional notShowAgain As Boolean = false
)
public:
FormException(
    Exception^ exception,
    bool notShowAgain = false
)
new :
        exception : Exception *
        ?notShowAgain : bool
(* Defaults:
        let _notShowAgain = defaultArg notShowAgain false
*)
-> FormException

Parametri

exception
Tipo: SystemException
Eccezione da visualizzare.
notShowAgain (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException (Image, String, List(Exception))

Costruttore FormException (Image, String, ListException)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Image image,
    string text,
    List<Exception> exceptions
)
Public Sub New (
    image As Image,
    text As String,
    exceptions As List(Of Exception)
)
public:
FormException(
    Image^ image,
    String^ text,
    List<Exception^>^ exceptions
)
new :
        image : Image *
        text : string *
        exceptions : List<Exception> -> FormException

Parametri

image
Tipo: System.DrawingImage
Icona da visualizzare nel form e nei vari nodi.
text
Tipo: SystemString
Titolo del form (se null imposta quello di default: "Errore")
exceptions
Tipo: System.Collections.GenericList Exception
Lista di eccezioni da visulaizzare
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Costruttore FormException (Image, String, Exception)
Cotruttore della classe.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public FormException(
    Image image,
    string text,
    Exception exception
)
Public Sub New (
    image As Image,
    text As String,
    exception As Exception
)
public:
FormException(
    Image^ image,
    String^ text,
    Exception^ exception
)
new :
        image : Image *
        text : string *
        exception : Exception -> FormException

Parametri

image
Tipo: System.DrawingImage
Icona da visualizzare nel form e nei vari nodi.
text
Tipo: SystemString
Titolo del form (se null imposta quello di default: "Errore").
exception
Tipo: SystemException
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe FormException
Overload di FormException


Proprietà di FormException

Il tipo FormException espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Exceptions | Permette di impostare l'eccezione da visualizzare
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | NotShowAgain | Indica se la spunta "Non mostrare più" è nascosta o meno.
Proprietà pubblica | RowImage | Permette di impostare l'icona della finestra
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | Title | Restituisce o imposta il titolo della finestra.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.Exceptions

Proprietà FormExceptionExceptions

Permette di impostare l'eccezione da visualizzare

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> Exceptions { set; }
Public WriteOnly Property Exceptions As List(Of Exception)
    Set
public:
property List<Exception^>^ Exceptions {
    void set (List<Exception^>^ value);
}
member Exceptions : List<Exception> with set

Valore della proprietà

Tipo: List Exception
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.NotShowAgain

Proprietà FormExceptionNotShowAgain

Indica se la spunta "Non mostrare più" è nascosta o meno.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NotShowAgain { get; }
Public ReadOnly Property NotShowAgain As Boolean
    Get
public:
property bool NotShowAgain {
    bool get ();
}
member NotShowAgain : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.RowImage

Proprietà FormExceptionRowImage

Permette di impostare l'icona della finestra

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image RowImage { set; }
Public WriteOnly Property RowImage As Image
    Set
public:
property Image^ RowImage {
    void set (Image^ value);
}
member RowImage : Image with set

Valore della proprietà

Tipo: Image
Vedi anche

Documentazione

Classe FormException


Proprietà FormException.Title

Proprietà FormExceptionTitle

Restituisce o imposta il titolo della finestra.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
member Title : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe FormException


Metodi di FormException

Il tipo FormException espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe FormException


Metodo FormException.Dispose

Metodo FormExceptionDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe FormException


Eventi di FormException

Il tipo FormException espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe FormException


Campi di FormException

Il tipo FormException espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe FormException


Classe InputBox
The InputBox class is used to show a prompt in a dialog box using the static method Show().
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIInputBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InputBox : QsBaseForm
Public Class InputBox
    Inherits QsBaseForm
public ref class InputBox : public QsBaseForm
type InputBox =
    class
        inherit QsBaseForm
    end

Il tipo InputBox espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBox | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà pubblica | ComboBox |
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | LabelPrompt |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextBoxText |
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | TxtMemoEdit |
Proprietà pubblica | Validator | Restituisce o imposta il validatore dei dati.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBox

Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InputBox()
Public Sub New
public:
InputBox()
new : unit -> InputBox
Vedi anche

Documentazione

Classe InputBox


Proprietà di InputBox

Il tipo InputBox espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà pubblica | ComboBox |
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà pubblica | LabelPrompt |
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextBoxText |
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | TxtMemoEdit |
Proprietà pubblica | Validator | Restituisce o imposta il validatore dei dati.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.ComboBox

Proprietà InputBoxComboBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ComboBoxEdit ComboBox { get; set; }
Public Property ComboBox As ComboBoxEdit
    Get
    Set
public:
property ComboBoxEdit^ ComboBox {
    ComboBoxEdit^ get ();
    void set (ComboBoxEdit^ value);
}
member ComboBox : ComboBoxEdit with get, set

Valore della proprietà

Tipo: ComboBoxEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.LabelPrompt

Proprietà InputBoxLabelPrompt

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LabelControl LabelPrompt { get; set; }
Public Property LabelPrompt As LabelControl
    Get
    Set
public:
property LabelControl^ LabelPrompt {
    LabelControl^ get ();
    void set (LabelControl^ value);
}
member LabelPrompt : LabelControl with get, set

Valore della proprietà

Tipo: LabelControl
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.TextBoxText

Proprietà InputBoxTextBoxText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TextEdit TextBoxText { get; set; }
Public Property TextBoxText As TextEdit
    Get
    Set
public:
property TextEdit^ TextBoxText {
    TextEdit^ get ();
    void set (TextEdit^ value);
}
member TextBoxText : TextEdit with get, set

Valore della proprietà

Tipo: TextEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.TxtMemoEdit

Proprietà InputBoxTxtMemoEdit

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MemoEdit TxtMemoEdit { get; set; }
Public Property TxtMemoEdit As MemoEdit
    Get
    Set
public:
property MemoEdit^ TxtMemoEdit {
    MemoEdit^ get ();
    void set (MemoEdit^ value);
}
member TxtMemoEdit : MemoEdit with get, set

Valore della proprietà

Tipo: MemoEdit
Vedi anche

Documentazione

Classe InputBox


Proprietà InputBox.Validator

Proprietà InputBoxValidator

Restituisce o imposta il validatore dei dati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InputBoxValidatingHandler Validator { get; set; }
Public Property Validator As InputBoxValidatingHandler
    Get
    Set
public:
property InputBoxValidatingHandler^ Validator {
    InputBoxValidatingHandler^ get ();
    void set (InputBoxValidatingHandler^ value);
}
member Validator : InputBoxValidatingHandler with get, set

Valore della proprietà

Tipo: InputBoxValidatingHandler
Vedi anche

Documentazione

Classe InputBox


Metodi di InputBox

Il tipo InputBox espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe InputBox


Metodo InputBox.Dispose

Metodo InputBoxDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
True per rilasciare sia le risorse managed che quelle unmanaged; false per rilasciare solo quelle unmanaged.
Vedi anche

Documentazione

Classe InputBox


Eventi di InputBox

Il tipo InputBox espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe InputBox


Campi di InputBox

Il tipo InputBox espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe InputBox


Classe InputBoxResult
Class used to store the result of an InputBox.Show message.
Gerarchia di ereditarietà
SystemObject
QsUIInputBoxResult

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InputBoxResult
Public Class InputBoxResult
public ref class InputBoxResult
type InputBoxResult =  class end

Il tipo InputBoxResult espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBoxResult | Inizializza una nuova istanza della classe InputBoxResult.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | OK |
Campo pubblico | Text |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBoxResult

Inizializza una nuova istanza della classe InputBoxResult.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InputBoxResult()
Public Sub New
public:
InputBoxResult()
new : unit -> InputBoxResult
Vedi anche

Documentazione

Classe InputBoxResult


Campi di InputBoxResult

Il tipo InputBoxResult espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | OK |
Campo pubblico | Text |
Torna su
Vedi anche

Documentazione

Classe InputBoxResult


Campo InputBoxResult.OK

Campo InputBoxResultOK

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OK
Public OK As Boolean
public:
bool OK
val mutable OK: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InputBoxResult


Campo InputBoxResult.Text

Campo InputBoxResultText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Text
Public Text As String
public:
String^ Text
val mutable Text: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe InputBoxResult


Classe InputBoxValidatingArgs
EventArgs used to Validate an InputBox
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUIInputBoxValidatingArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class InputBoxValidatingArgs : EventArgs
Public Class InputBoxValidatingArgs
    Inherits EventArgs
public ref class InputBoxValidatingArgs : public EventArgs
type InputBoxValidatingArgs =
    class
        inherit EventArgs
    end

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | InputBoxValidatingArgs | Inizializza una nuova istanza della classe InputBoxValidatingArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel |
Proprietà pubblica | Message |
Proprietà pubblica | Text |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _cancel |
Campo pubblico | _message |
Campo pubblico | _text |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore InputBoxValidatingArgs

Inizializza una nuova istanza della classe InputBoxValidatingArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public InputBoxValidatingArgs()
Public Sub New
public:
InputBoxValidatingArgs()
new : unit -> InputBoxValidatingArgs
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà di InputBoxValidatingArgs

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Cancel |
Proprietà pubblica | Message |
Proprietà pubblica | Text |
Torna su
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Cancel

Proprietà InputBoxValidatingArgsCancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
member Cancel : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Message

Proprietà InputBoxValidatingArgsMessage

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Proprietà InputBoxValidatingArgs.Text

Proprietà InputBoxValidatingArgsText

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campi di InputBoxValidatingArgs

Il tipo InputBoxValidatingArgs espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _cancel |
Campo pubblico | _message |
Campo pubblico | _text |
Torna su
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._cancel

Campo InputBoxValidatingArgs_cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool _cancel
Public _cancel As Boolean
public:
bool _cancel
val mutable _cancel: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._message

Campo InputBoxValidatingArgs_message

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string _message
Public _message As String
public:
String^ _message
val mutable _message: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Campo InputBoxValidatingArgs._text

Campo InputBoxValidatingArgs_text

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string _text
Public _text As String
public:
String^ _text
val mutable _text: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe InputBoxValidatingArgs


Delegate InputBoxValidatingHandler
Delegate used to Validate an InputBox

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate void InputBoxValidatingHandler(
    Object sender,
    InputBoxValidatingArgs e
)
Public Delegate Sub InputBoxValidatingHandler (
    sender As Object,
    e As InputBoxValidatingArgs
)
public delegate void InputBoxValidatingHandler(
    Object^ sender,
    InputBoxValidatingArgs^ e
)
type InputBoxValidatingHandler =
    delegate of
        sender : Object *
        e : InputBoxValidatingArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: QsUIInputBoxValidatingArgs
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ListChoice
Classe che permette di visualizzare un form per scegliere gli elementi da una lista.
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIListChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ListChoice : QsBaseForm
Public Class ListChoice
    Inherits QsBaseForm
public ref class ListChoice : public QsBaseForm
type ListChoice =
    class
        inherit QsBaseForm
    end

Il tipo ListChoice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ListChoice | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | Selected | Restiutisce l'oggetto selezionato.
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ListChoice

Costruttore.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ListChoice(
    string title,
    Object datasource,
    int width = 193,
    int height = 305
)
Public Sub New (
    title As String,
    datasource As Object,
    Optional width As Integer = 193,
    Optional height As Integer = 305
)
public:
ListChoice(
    String^ title,
    Object^ datasource,
    int width = 193,
    int height = 305
)
new :
        title : string *
        datasource : Object *
        ?width : int *
        ?height : int
(* Defaults:
        let _width = defaultArg width 193
        let _height = defaultArg height 305
*)
-> ListChoice

Parametri

title
Tipo: SystemString
Titolo della finestra.
datasource
Tipo: SystemObject
Lista da bindare alla griglia.
width (Optional)
Tipo: SystemInt32
Larghezza della finestra.
height (Optional)
Tipo: SystemInt32
Altezza della finestra.
Vedi anche

Documentazione

Classe ListChoice


Proprietà di ListChoice

Il tipo ListChoice espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | Selected | Restiutisce l'oggetto selezionato.
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Proprietà ListChoice.Selected

Proprietà ListChoiceSelected

Restiutisce l'oggetto selezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object Selected { get; set; }
Public Property Selected As Object
    Get
    Set
public:
property Object^ Selected {
    Object^ get ();
    void set (Object^ value);
}
member Selected : Object with get, set

Valore della proprietà

Tipo: Object
Vedi anche

Documentazione

Classe ListChoice


Metodi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Metodo ListChoice.Dispose

Metodo ListChoiceDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ListChoice


Eventi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Campi di ListChoice

Il tipo ListChoice espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ListChoice


Classe OkCancelControl
Classe che implementa il controllo di due bottoni ( ok , cancel )
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
XtraUserControl
QsUIOkCancelControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OkCancelControl : XtraUserControl
Public Class OkCancelControl
    Inherits XtraUserControl
public ref class OkCancelControl : public XtraUserControl
type OkCancelControl =
    class
        inherit XtraUserControl
    end

Il tipo OkCancelControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | OkCancelControl | Costruttore della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl.)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl.)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl.)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl.)
Proprietà pubblica | Font | (Ereditato da XtraUserControl.)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl.)
Proprietà protetta | Helper | (Ereditato da XtraUserControl.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl.)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl.)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl.)
Proprietà pubblica | Site | (Ereditato da XtraUserControl.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl.)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl.)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl.)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl.)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl.)
Metodo protetto | GetService | (Ereditato da XtraUserControl.)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl.)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl.)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl.)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl.)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl.)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl.)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl.)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl.)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl.)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl.)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl.)
Metodo protetto | WndProc | (Ereditato da XtraUserControl.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#Changed | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#ISupportAppearanceObjectPropertiesFilter#FilterPropertyDescriptorCollection | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#IsCaptionVisible | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#MaxSize | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#MinSize | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraUserControl.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore OkCancelControl

Costruttore della classe

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OkCancelControl()
Public Sub New
public:
OkCancelControl()
new : unit -> OkCancelControl
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Appearance | (Ereditato da XtraUserControl.)
Proprietà pubblica | BackColor | (Ereditato da XtraUserControl.)
Proprietà pubblica | CancelButton | Ritorna il bottone Cancel
Proprietà protetta | CheckDoubleScaling | (Ereditato da XtraUserControl.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraUserControl.)
Proprietà pubblica | EnableIXtraResizeableControlInterfaceProxy | (Ereditato da XtraUserControl.)
Proprietà pubblica | Font | (Ereditato da XtraUserControl.)
Proprietà pubblica | ForeColor | (Ereditato da XtraUserControl.)
Proprietà protetta | Helper | (Ereditato da XtraUserControl.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraUserControl.)
Proprietà pubblica | OkButton | Ritorna il bottone Ok
Proprietà protetta | Painter | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleChildren | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraUserControl.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraUserControl.)
Proprietà protetta | ShouldCheckDpiScaleFactorOnParentChanged | (Ereditato da XtraUserControl.)
Proprietà pubblica | Site | (Ereditato da XtraUserControl.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#IsCaptionVisible | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#MaxSize | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#MinSize | (Ereditato da XtraUserControl.)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà OkCancelControl.CancelButton

Proprietà OkCancelControlCancelButton

Ritorna il bottone Cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton CancelButton { get; }
Public ReadOnly Property CancelButton As SimpleButton
    Get
public:
property SimpleButton^ CancelButton {
    SimpleButton^ get ();
}
member CancelButton : SimpleButton with get

Valore della proprietà

Tipo: SimpleButton
Vedi anche

Documentazione

Classe OkCancelControl


Proprietà OkCancelControl.OkButton

Proprietà OkCancelControlOkButton

Ritorna il bottone Ok

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SimpleButton OkButton { get; }
Public ReadOnly Property OkButton As SimpleButton
    Get
public:
property SimpleButton^ OkButton {
    SimpleButton^ get ();
}
member OkButton : SimpleButton with get

Valore della proprietà

Tipo: SimpleButton
Vedi anche

Documentazione

Classe OkCancelControl


Metodi di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | BaseWndProc | (Ereditato da XtraUserControl.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraUserControl.)
Metodo protetto | CreatePainter | (Ereditato da XtraUserControl.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraUserControl.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraUserControl.)
Metodo protetto | DoDpiChangeAfterParent | (Ereditato da XtraUserControl.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraUserControl.)
Metodo protetto | GetBackColor | (Ereditato da XtraUserControl.)
Metodo protetto | GetInnerIXtraResizableControl | (Ereditato da XtraUserControl.)
Metodo protetto | GetService | (Ereditato da XtraUserControl.)
Metodo protetto | IsChildControlsRequiredScalingEnabled | (Ereditato da XtraUserControl.)
Metodo protetto | IsParentHandleCreatedRecursive | (Ereditato da XtraUserControl.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraUserControl.)
Metodo protetto | OnBackColorChanged | (Ereditato da XtraUserControl.)
Metodo protetto | onClickCancel |
Metodo protetto | onClickOk |
Metodo protetto | OnControlAdded | (Ereditato da XtraUserControl.)
Metodo protetto | OnControlRemoved | (Ereditato da XtraUserControl.)
Metodo protetto | OnFirstLoad | (Ereditato da XtraUserControl.)
Metodo protetto | OnForeColorChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraUserControl.)
Metodo protetto | OnLoad | (Ereditato da XtraUserControl.)
Metodo protetto | OnLookAndFeelChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnPaint | (Ereditato da XtraUserControl.)
Metodo protetto | OnParentChanged | (Ereditato da XtraUserControl.)
Metodo protetto | OnScaleControl | (Ereditato da XtraUserControl.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraUserControl.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraUserControl.)
Metodo protetto | ScaleControl | (Ereditato da XtraUserControl.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraUserControl.)
Metodo protetto | WndProc | (Ereditato da XtraUserControl.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#Utils#ISupportAppearanceObjectPropertiesFilter#FilterPropertyDescriptorCollection | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraUserControl.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraUserControl.)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.Dispose

Metodo OkCancelControlDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.onClickCancel

Metodo OkCancelControlonClickCancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void onClickCancel(
    Object sender,
    EventArgs e
)
Protected Sub onClickCancel (
    sender As Object,
    e As EventArgs
)
protected:
void onClickCancel(
    Object^ sender,
    EventArgs^ e
)
member onClickCancel :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: SystemEventArgs
Vedi anche

Documentazione

Classe OkCancelControl


Metodo OkCancelControl.onClickOk

Metodo OkCancelControlonClickOk

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void onClickOk(
    Object sender,
    EventArgs e
)
Protected Sub onClickOk (
    sender As Object,
    e As EventArgs
)
protected:
void onClickOk(
    Object^ sender,
    EventArgs^ e
)
member onClickOk :
        sender : Object *
        e : EventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: SystemEventArgs
Vedi anche

Documentazione

Classe OkCancelControl


Eventi di OkCancelControl

Il tipo OkCancelControl espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CancelClick | Evento associato al click del bottone Cancel
Evento pubblico | OKClick | Evento associato al click del bottone Ok
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Controls#IXtraResizableControl#Changed | (Ereditato da XtraUserControl.)
Torna su
Vedi anche

Documentazione

Classe OkCancelControl


Evento OkCancelControl.CancelClick

Evento OkCancelControlCancelClick
Evento associato al click del bottone Cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler CancelClick
Public Event CancelClick As EventHandler
public:
 event EventHandler^ CancelClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CancelClick : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe OkCancelControl


Evento OkCancelControl.OKClick

Evento OkCancelControlOKClick
Evento associato al click del bottone Ok

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler OKClick
Public Event OKClick As EventHandler
public:
 event EventHandler^ OKClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OKClick : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe OkCancelControl


Classe QsBaseForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIElaborationReport
QsUIFormException
QsUIInputBox
QsUIListChoice
QsUIQuestionForm

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsBaseForm : XtraForm
Public Class QsBaseForm
    Inherits XtraForm
public ref class QsBaseForm : public XtraForm
type QsBaseForm =
    class
        inherit XtraForm
    end

Il tipo QsBaseForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsBaseForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsBaseForm

Costruttore unico.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsBaseForm()
Public Sub New
public:
QsBaseForm()
new : unit -> QsBaseForm
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True.
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà QsBaseForm.LoadSize

Proprietà QsBaseFormLoadSize

Indica se ripristinare la dimensione della sessione precedente. (Default True.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LoadSize { get; set; }
Public Property LoadSize As Boolean
    Get
    Set
public:
property bool LoadSize {
    bool get ();
    void set (bool value);
}
member LoadSize : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe QsBaseForm


Proprietà QsBaseForm.MainRegistryKey

Proprietà QsBaseFormMainRegistryKey

Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver;

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string MainRegistryKey { get; }
Public ReadOnly Property MainRegistryKey As String
    Get
public:
property String^ MainRegistryKey {
    String^ get ();
}
member MainRegistryKey : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe QsBaseForm


Metodi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.Dispose

Metodo QsBaseFormDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.GetPixelSizeForCurrentDpiSettings

Metodo QsBaseFormGetPixelSizeForCurrentDpiSettings

Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
Protected Function GetPixelSizeForCurrentDpiSettings (
    pixel As Integer
) As Integer
protected:
int GetPixelSizeForCurrentDpiSettings(
    int pixel
)
member GetPixelSizeForCurrentDpiSettings :
        pixel : int -> int

Parametri

pixel
Tipo: SystemInt32

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.LoadSizeAndPosition

Metodo QsBaseFormLoadSizeAndPosition

Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void LoadSizeAndPosition()
Protected Sub LoadSizeAndPosition
protected:
void LoadSizeAndPosition()
member LoadSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe QsBaseForm


Metodo QsBaseForm.SaveSizeAndPosition

Metodo QsBaseFormSaveSizeAndPosition

Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void SaveSizeAndPosition()
Protected Sub SaveSizeAndPosition
protected:
void SaveSizeAndPosition()
member SaveSizeAndPosition : unit -> unit
Vedi anche

Documentazione

Classe QsBaseForm


Eventi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Campi di QsBaseForm

Il tipo QsBaseForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QsBaseForm


Campo QsBaseForm.DpiBasedMinimumSize

Campo QsBaseFormDpiBasedMinimumSize
Dimensioni minime calcolate sull'impostazione dei dpi correnti

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected Size DpiBasedMinimumSize
Protected DpiBasedMinimumSize As Size
protected:
Size DpiBasedMinimumSize
val mutable DpiBasedMinimumSize: Size

Valore del campo

Tipo: Size
Vedi anche

Documentazione

Classe QsBaseForm


Classe QsException
Classe base per la gestione delle eccezioni.
Gerarchia di ereditarietà
SystemObject
SystemException
SystemApplicationException
QsUIQsException
QsUIQsExceptionList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsException : ApplicationException
Public Class QsException
    Inherits ApplicationException
public ref class QsException : public ApplicationException
type QsException =
    class
        inherit ApplicationException
    end
Costruttori
 | Nome | Descrizione
Metodo pubblico | QsException | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String, Exception) | Inizializza una nuova istanza della classe QsException.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsException

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QsException | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsException.
Metodo pubblico | QsException(String, Exception) | Inizializza una nuova istanza della classe QsException.
Torna su
Vedi anche

Documentazione

Classe QsException


Costruttore QsException

Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsException()
Public Sub New
public:
QsException()
new : unit -> QsException
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException (String)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    string message
)
Public Sub New (
    message As String
)
public:
QsException(
    String^ message
)
new :
        message : string -> QsException

Parametri

message
Tipo: SystemString
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException (SerializationInfo, StreamingContext)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
QsException(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QsException

Parametri

info
Tipo: System.Runtime.SerializationSerializationInfo
context
Tipo: System.Runtime.SerializationStreamingContext
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Costruttore QsException (String, Exception)
Inizializza una nuova istanza della classe QsException.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
public:
QsException(
    String^ message,
    Exception^ innerException
)
new :
        message : string *
        innerException : Exception -> QsException

Parametri

message
Tipo: SystemString
innerException
Tipo: SystemException
Vedi anche

Documentazione

Classe QsException
Overload di QsException


Classe QsExceptionList
Eccezione contenente una lista di eccezioni.
Gerarchia di ereditarietà
SystemObject
SystemException
SystemApplicationException
QsUIQsException
QsUIQsExceptionList

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsExceptionList : QsException
Public Class QsExceptionList
    Inherits QsException
public ref class QsExceptionList : public QsException
type QsExceptionList =
    class
        inherit QsException
    end

Il tipo QsExceptionList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsExceptionList(ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, Exception, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExceptionList | Restituisce la lista delle eccezioni.
Proprietà pubblica | MessageList | Restituisce la lista dei messaggi concatenati con "\r\n".
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsExceptionList

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | QsExceptionList(ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(SerializationInfo, StreamingContext) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Metodo pubblico | QsExceptionList(String, Exception, ListException) | Inizializza una nuova istanza della classe QsExceptionList.
Torna su
Vedi anche

Documentazione

Classe QsExceptionList


Costruttore QsExceptionList (List(Exception))

Costruttore QsExceptionList (ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    List<Exception> exceptionList
)
Public Sub New (
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    List<Exception^>^ exceptionList
)
new :
        exceptionList : List<Exception> -> QsExceptionList

Parametri

exceptionList
Tipo: System.Collections.GenericList Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList (SerializationInfo, StreamingContext)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
public:
QsExceptionList(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> QsExceptionList

Parametri

info
Tipo: System.Runtime.SerializationSerializationInfo
context
Tipo: System.Runtime.SerializationStreamingContext
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList (String, List(Exception))

Costruttore QsExceptionList (String, ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    string msg,
    List<Exception> exceptionList
)
Public Sub New (
    msg As String,
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    String^ msg,
    List<Exception^>^ exceptionList
)
new :
        msg : string *
        exceptionList : List<Exception> -> QsExceptionList

Parametri

msg
Tipo: SystemString
exceptionList
Tipo: System.Collections.GenericList Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Costruttore QsExceptionList (String, Exception, List(Exception))

Costruttore QsExceptionList (String, Exception, ListException)
Inizializza una nuova istanza della classe QsExceptionList.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsExceptionList(
    string msg,
    Exception ex,
    List<Exception> exceptionList
)
Public Sub New (
    msg As String,
    ex As Exception,
    exceptionList As List(Of Exception)
)
public:
QsExceptionList(
    String^ msg,
    Exception^ ex,
    List<Exception^>^ exceptionList
)
new :
        msg : string *
        ex : Exception *
        exceptionList : List<Exception> -> QsExceptionList

Parametri

msg
Tipo: SystemString
ex
Tipo: SystemException
exceptionList
Tipo: System.Collections.GenericList Exception
Vedi anche

Documentazione

Classe QsExceptionList
Overload di QsExceptionList


Proprietà di QsExceptionList

Il tipo QsExceptionList espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | ExceptionList | Restituisce la lista delle eccezioni.
Proprietà pubblica | MessageList | Restituisce la lista dei messaggi concatenati con "\r\n".
Torna su
Vedi anche

Documentazione

Classe QsExceptionList


Proprietà QsExceptionList.ExceptionList

Proprietà QsExceptionListExceptionList

Restituisce la lista delle eccezioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<Exception> ExceptionList { get; }
Public ReadOnly Property ExceptionList As List(Of Exception)
    Get
public:
property List<Exception^>^ ExceptionList {
    List<Exception^>^ get ();
}
member ExceptionList : List<Exception> with get

Valore della proprietà

Tipo: List Exception
Vedi anche

Documentazione

Classe QsExceptionList


Proprietà QsExceptionList.MessageList

Proprietà QsExceptionListMessageList

Restituisce la lista dei messaggi concatenati con "\r\n".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string MessageList { get; }
Public ReadOnly Property MessageList As String
    Get
public:
property String^ MessageList {
    String^ get ();
}
member MessageList : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe QsExceptionList


Classe QsUI
Gerarchia di ereditarietà
SystemObject
QsUIQsUI

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class QsUI
Public NotInheritable Class QsUI
public ref class QsUI abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QsUI =  class end

Il tipo QsUI espone i seguenti membri.

Metodi
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
LogInfo | Registra il messaggio nei file di Log.
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowListChoice | Visualizza il form per selezionare un elmento da una lista.
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di QsUI

Il tipo QsUI espone i seguenti membri.

Metodi
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
LogInfo | Registra il messaggio nei file di Log.
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowListChoice | Visualizza il form per selezionare un elmento da una lista.
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.Log

Metodo QsUILog

Lista degli overload
Nome | Descrizione
Log(Exception) | Registra il messaggio nel file di Log dell'applicazione.
Log(String) | Registra il messaggio nei file di Log.
Log(String, String) | Registra il messaggio nei file di Log.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.Log (Exception)

Metodo QsUILog (Exception)
Registra il messaggio nel file di Log dell'applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex
)
Public Shared Sub Log (
    ex As Exception
)
public:
static void Log(
    Exception^ ex
)
static member Log :
        ex : Exception -> unit

Parametri

ex
Tipo: SystemException
Eccezione da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.Log (String)

Metodo QsUILog (String)
Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string message
)
Public Shared Sub Log (
    message As String
)
public:
static void Log(
    String^ message
)
static member Log :
        message : string -> unit

Parametri

message
Tipo: SystemString
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.Log (String, String)

Metodo QsUILog (String, String)
Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    string modulename,
    string message
)
Public Shared Sub Log (
    modulename As String,
    message As String
)
public:
static void Log(
    String^ modulename,
    String^ message
)
static member Log :
        modulename : string *
        message : string -> unit

Parametri

modulename
Tipo: SystemString
Nome del modulo dal quale proviene la registrazione.
message
Tipo: SystemString
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI
Overload di Log


Metodo QsUI.LogInfo

Metodo QsUILogInfo

Registra il messaggio nei file di Log.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string message
)
Public Shared Sub LogInfo (
    message As String
)
public:
static void LogInfo(
    String^ message
)
static member LogInfo :
        message : string -> unit

Parametri

message
Tipo: SystemString
Messaggio da registrare nel file di Log.
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBox

Metodo QsUIShowInputBox

Lista degli overload
Nome | Descrizione
ShowInputBox(String, String, String) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBox(String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBox (String, String, String)

Metodo QsUIShowInputBox (String, String, String)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultText
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultText As String
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultText
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultText : string -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: SystemString

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox (String, String, String, InputBoxValidatingHandler)

Metodo QsUIShowInputBox (String, String, String, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultText,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultText As String,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultText,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultText : string *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: SystemString
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox (String, String, List(String), String, InputBoxValidatingHandler)

Metodo QsUIShowInputBox (String, String, ListString, String, InputBoxValidatingHandler)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultText,
    string selectedText,
    InputBoxValidatingHandler validator
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultText As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultText,
    String^ selectedText,
    InputBoxValidatingHandler^ validator
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultText : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: System.Collections.GenericList String
selectedText
Tipo: SystemString
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox (String, String, String, InputBoxValidatingHandler, Int32, Int32)

Metodo QsUIShowInputBox (String, String, String, InputBoxValidatingHandler, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultResponse
Tipo: SystemString
String expression displayed in the text box as the default response
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
xpos
Tipo: SystemInt32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos
Tipo: SystemInt32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox (String, String, List(String), String, InputBoxValidatingHandler, Int32, Int32)

Metodo QsUIShowInputBox (String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultText,
    string selectedText,
    InputBoxValidatingHandler validator,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultText As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultText,
    String^ selectedText,
    InputBoxValidatingHandler^ validator,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultText : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: System.Collections.GenericList String
selectedText
Tipo: SystemString
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
width
Tipo: SystemInt32
height
Tipo: SystemInt32

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBox (String, String, List(String), String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)

Metodo QsUIShowInputBox (String, String, ListString, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBox(
    string prompt,
    string title,
    List<string> defaultResponse,
    string selectedText,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int width,
    int height
)
Public Shared Function ShowInputBox (
    prompt As String,
    title As String,
    defaultResponse As List(Of String),
    selectedText As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    width As Integer,
    height As Integer
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBox(
    String^ prompt,
    String^ title,
    List<String^>^ defaultResponse,
    String^ selectedText,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int width,
    int height
)
static member ShowInputBox :
        prompt : string *
        title : string *
        defaultResponse : List<string> *
        selectedText : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        width : int *
        height : int -> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultResponse
Tipo: System.Collections.GenericList String
String expression displayed in the text box as the default response
selectedText
Tipo: SystemString
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
xpos
Tipo: SystemInt32
Numeric expression that specifies the distance of the left edge of the dialog box from the left edge of the screen.
ypos
Tipo: SystemInt32
Numeric expression that specifies the distance of the upper edge of the dialog box from the top of the screen
width
Tipo: SystemInt32
Width of the form
height
Tipo: SystemInt32
Height of the form

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBox


Metodo QsUI.ShowInputBoxAsMultiLine

Metodo QsUIShowInputBoxAsMultiLine

Lista degli overload
Nome | Descrizione
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
ShowInputBoxAsMultiLine(String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32) | Displays a prompt in a dialog box, waits for the user to input text or click a button.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.ShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32)

Metodo QsUIShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultText,
    InputBoxValidatingHandler validator,
    int maxLenght = 0
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultText As String,
    validator As InputBoxValidatingHandler,
    Optional maxLenght As Integer = 0
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultText,
    InputBoxValidatingHandler^ validator,
    int maxLenght = 0
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultText : string *
        validator : InputBoxValidatingHandler *
        ?maxLenght : int
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
*)
-> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: SystemString
String expression displayed in the text box as the default response
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
maxLenght (Optional)
Tipo: SystemInt32
Limit number of characters.

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32)

Metodo QsUIShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultText,
    InputBoxValidatingHandler validator,
    int width,
    int height,
    int maxLenght = 0
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultText As String,
    validator As InputBoxValidatingHandler,
    width As Integer,
    height As Integer,
    Optional maxLenght As Integer = 0
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultText,
    InputBoxValidatingHandler^ validator,
    int width,
    int height,
    int maxLenght = 0
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultText : string *
        validator : InputBoxValidatingHandler *
        width : int *
        height : int *
        ?maxLenght : int
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
*)
-> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultText
Tipo: SystemString
String expression displayed in the text box as the default response
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
width
Tipo: SystemInt32
Larghezza della finestra (-1) default
height
Tipo: SystemInt32
Altezza della finestra (-1) default
maxLenght (Optional)
Tipo: SystemInt32
Limit number of characters.

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32)

Metodo QsUIShowInputBoxAsMultiLine (String, String, String, InputBoxValidatingHandler, Int32, Int32, Int32, Int32, Int32)
Displays a prompt in a dialog box, waits for the user to input text or click a button.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static InputBoxResult ShowInputBoxAsMultiLine(
    string prompt,
    string title,
    string defaultResponse,
    InputBoxValidatingHandler validator,
    int xpos,
    int ypos,
    int width,
    int height,
    int maxLenght = 0
)
Public Shared Function ShowInputBoxAsMultiLine (
    prompt As String,
    title As String,
    defaultResponse As String,
    validator As InputBoxValidatingHandler,
    xpos As Integer,
    ypos As Integer,
    width As Integer,
    height As Integer,
    Optional maxLenght As Integer = 0
) As InputBoxResult
public:
static InputBoxResult^ ShowInputBoxAsMultiLine(
    String^ prompt,
    String^ title,
    String^ defaultResponse,
    InputBoxValidatingHandler^ validator,
    int xpos,
    int ypos,
    int width,
    int height,
    int maxLenght = 0
)
static member ShowInputBoxAsMultiLine :
        prompt : string *
        title : string *
        defaultResponse : string *
        validator : InputBoxValidatingHandler *
        xpos : int *
        ypos : int *
        width : int *
        height : int *
        ?maxLenght : int
(* Defaults:
        let _maxLenght = defaultArg maxLenght 0
*)
-> InputBoxResult

Parametri

prompt
Tipo: SystemString
String expression displayed as the message in the dialog box
title
Tipo: SystemString
String expression displayed in the title bar of the dialog box
defaultResponse
Tipo: SystemString
String expression displayed in the text box as the default response
validator
Tipo: QsUIInputBoxValidatingHandler
Delegate used to validate the text
xpos
Tipo: SystemInt32
ypos
Tipo: SystemInt32
width
Tipo: SystemInt32
Width of the form
height
Tipo: SystemInt32
Height of the form
maxLenght (Optional)
Tipo: SystemInt32
Limit number of characters

Valore di ritorno

Tipo: InputBoxResult
An InputBoxResult object with the Text and the OK property set to true when OK was clicked.
Vedi anche

Documentazione

Classe QsUI
Overload di ShowInputBoxAsMultiLine


Metodo QsUI.ShowListChoice

Metodo QsUIShowListChoice

Visualizza il form per selezionare un elmento da una lista.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Object ShowListChoice(
    string title,
    Object datasource,
    int width = 193,
    int height = 305
)
Public Shared Function ShowListChoice (
    title As String,
    datasource As Object,
    Optional width As Integer = 193,
    Optional height As Integer = 305
) As Object
public:
static Object^ ShowListChoice(
    String^ title,
    Object^ datasource,
    int width = 193,
    int height = 305
)
static member ShowListChoice :
        title : string *
        datasource : Object *
        ?width : int *
        ?height : int
(* Defaults:
        let _width = defaultArg width 193
        let _height = defaultArg height 305
*)
-> Object

Parametri

title
Tipo: SystemString
Titolo del form
datasource
Tipo: SystemObject
Lista da visualizzare
width (Optional)
Tipo: SystemInt32
larghezza finestra (193 default)
height (Optional)
Tipo: SystemInt32
altezza finestra (305 default)

Valore di ritorno

Tipo: Object
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.VisMsg

Metodo QsUIVisMsg

Lista degli overload
Nome | Descrizione
VisMsg(IWin32Window, ListException) | Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception) | Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".
VisMsg(IWin32Window, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, ListException, Boolean) | Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, Exception, Boolean) | Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".
VisMsg(IWin32Window, String, String) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.
VisMsg(IWin32Window, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
VisMsg(IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon) | Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.
Torna su
Vedi anche

Documentazione

Classe QsUI


Metodo QsUI.VisMsg (IWin32Window, List(Exception))

Metodo QsUIVisMsg (IWin32Window, ListException)
Visualizza la finestra di dialogo per le liste di eccezioni. Nasconde l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    List<Exception> exList
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    exList As List(Of Exception)
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    List<Exception^>^ exList
)
static member VisMsg :
        ownerForm : IWin32Window *
        exList : List<Exception> -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
exList
Tipo: System.Collections.GenericList Exception
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, Exception)

Metodo QsUIVisMsg (IWin32Window, Exception)
Visualizza la finestra di dialogo per le eccezioni. Nasconde l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
ex
Tipo: SystemException
Eccezione da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String)

Metodo QsUIVisMsg (IWin32Window, String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
msg
Tipo: SystemString
Stringa da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, List(Exception), Boolean)

Metodo QsUIVisMsg (IWin32Window, ListException, Boolean)
Visualizza la finestra di dialogo per le liste di eccezioni. Rende visibile l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    List<Exception> exList,
    out bool notShowAgain
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    exList As List(Of Exception),
    <OutAttribute> ByRef notShowAgain As Boolean
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    List<Exception^>^ exList,
    [OutAttribute] bool% notShowAgain
)
static member VisMsg :
        ownerForm : IWin32Window *
        exList : List<Exception> *
        notShowAgain : bool byref -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
exList
Tipo: System.Collections.GenericList Exception
notShowAgain
Tipo: SystemBoolean
Indica se alla chiusura del dialogo la checkbox "non mostrare più" è stata spuntata o meno.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, Exception, Boolean)

Metodo QsUIVisMsg (IWin32Window, Exception, Boolean)
Visualizza la finestra di dialogo per le eccezioni. Rende visibile l'opzione "Non mostrare più".

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    Exception ex,
    out bool notShowAgain
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    ex As Exception,
    <OutAttribute> ByRef notShowAgain As Boolean
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    Exception^ ex,
    [OutAttribute] bool% notShowAgain
)
static member VisMsg :
        ownerForm : IWin32Window *
        ex : Exception *
        notShowAgain : bool byref -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
ex
Tipo: SystemException
Eccezione da visualizzare.
notShowAgain
Tipo: SystemBoolean
Indica se alla chiusura del dialogo la checkbox "non mostrare più" è stata spuntata o meno.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String, String)

Metodo QsUIVisMsg (IWin32Window, String, String)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona Information.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
title
Tipo: SystemString
Titolo del form.
msg
Tipo: SystemString
Stringa da visualizzare.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String, MessageBoxIcon)

Metodo QsUIVisMsg (IWin32Window, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
msg
Tipo: SystemString
Stringa da visualizzare.
iconType
Tipo: System.Windows.FormsMessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String, String, MessageBoxIcon)

Metodo QsUIVisMsg (IWin32Window, String, String, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxIcon iconType
)
Public Shared Sub VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    iconType As MessageBoxIcon
)
public:
static void VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        iconType : MessageBoxIcon -> unit

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
title
Tipo: SystemString
Titolo della finestra.
msg
Tipo: SystemString
Stringa da visualizzare.
iconType
Tipo: System.Windows.FormsMessageBoxIcon
Tipo di icona da utilizzare per il messaggio.
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String, MessageBoxButtons, MessageBoxIcon)

Metodo QsUIVisMsg (IWin32Window, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
msg
Tipo: SystemString
Stringa da visualizzare.
buttons
Tipo: System.Windows.FormsMessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType
Tipo: System.Windows.FormsMessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

Tipo: DialogResult
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Metodo QsUI.VisMsg (IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)

Metodo QsUIVisMsg (IWin32Window, String, String, MessageBoxButtons, MessageBoxIcon)
Visualizza un messaggio semplice con solo il pulsante OK e l'icona specificata.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DialogResult VisMsg(
    IWin32Window ownerForm,
    string title,
    string msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
Public Shared Function VisMsg (
    ownerForm As IWin32Window,
    title As String,
    msg As String,
    buttons As MessageBoxButtons,
    iconType As MessageBoxIcon
) As DialogResult
public:
static DialogResult VisMsg(
    IWin32Window^ ownerForm,
    String^ title,
    String^ msg,
    MessageBoxButtons buttons,
    MessageBoxIcon iconType
)
static member VisMsg :
        ownerForm : IWin32Window *
        title : string *
        msg : string *
        buttons : MessageBoxButtons *
        iconType : MessageBoxIcon -> DialogResult

Parametri

ownerForm
Tipo: System.Windows.FormsIWin32Window
Parent Form.
title
Tipo: SystemString
Titolo della finestra.
msg
Tipo: SystemString
Stringa da visualizzare.
buttons
Tipo: System.Windows.FormsMessageBoxButtons
Bottoni da visualizzare nel messaggio.
iconType
Tipo: System.Windows.FormsMessageBoxIcon
Tipo di icona da utilizzare per il messaggio.

Valore di ritorno

Tipo: DialogResult
Vedi anche

Documentazione

Classe QsUI
Overload di VisMsg


Classe QuestionForm
Finestra per mostrare un form con la possibilità di scegliere tra [Si-Si Tutti-No-No Tutti].
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUIQsBaseForm
QsUIQuestionForm

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QuestionForm : QsBaseForm
Public Class QuestionForm
    Inherits QsBaseForm
public ref class QuestionForm : public QsBaseForm
type QuestionForm =
    class
        inherit QsBaseForm
    end

Il tipo QuestionForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà pubblica | ButtonSet | Restituisce i pulsanti visualizzati.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà pubblica | DefaultButton | Restituisce il pulsante di default preselezionato.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | Result | Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
 | Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
 | Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà pubblica | ButtonSet | Restituisce i pulsanti visualizzati.
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà pubblica | DefaultButton | Restituisce il pulsante di default preselezionato.
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LoadSize | Indica se ripristinare la dimensione della sessione precedente. (Default True. (Ereditato da QsBaseForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | Restituisce la chiave di salvataggio impostazioni per questo Form. È disponibile solo dopo aver chiamato ReadSizeAndPosition() oppure dopo aver; (Ereditato da QsBaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | Result | Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.ButtonSet

Proprietà QuestionFormButtonSet

Restituisce i pulsanti visualizzati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionButtonSet ButtonSet { get; }
Public ReadOnly Property ButtonSet As QuestionFormQuestionButtonSet
    Get
public:
property QuestionFormQuestionButtonSet ButtonSet {
    QuestionFormQuestionButtonSet get ();
}
member ButtonSet : QuestionFormQuestionButtonSet with get

Valore della proprietà

Tipo: QuestionFormQuestionButtonSet
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.DefaultButton

Proprietà QuestionFormDefaultButton

Restituisce il pulsante di default preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionResult DefaultButton { get; }
Public ReadOnly Property DefaultButton As QuestionFormQuestionResult
    Get
public:
property QuestionFormQuestionResult DefaultButton {
    QuestionFormQuestionResult get ();
}
member DefaultButton : QuestionFormQuestionResult with get

Valore della proprietà

Tipo: QuestionFormQuestionResult
Vedi anche

Documentazione

Classe QuestionForm


Proprietà QuestionForm.Result

Proprietà QuestionFormResult

Restituisce la scelta effettuata dall'utente oppure None se non ha effettuato scelte.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QuestionFormQuestionResult Result { get; }
Public ReadOnly Property Result As QuestionFormQuestionResult
    Get
public:
property QuestionFormQuestionResult Result {
    QuestionFormQuestionResult get ();
}
member Result : QuestionFormQuestionResult with get

Valore della proprietà

Tipo: QuestionFormQuestionResult
Vedi anche

Documentazione

Classe QuestionForm


Metodi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive QsBaseFormDispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | Dato un valore nominale in pixel lo adatta alle impostazioni dpi attive (Ereditato da QsBaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | Legge dal registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | Scrive nel registro la posizione e le dimensioni del form. Chiamare questo metodo solo dopo aver impostato il nome del form. (Ereditato da QsBaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
 | Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
 | Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
 | Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Dispose

Metodo QuestionFormDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Show

Metodo QuestionFormShow

Lista degli overload
Nome | Descrizione
Show(String, String) | Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.
Show(String, String, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.
Show(IWin32Window, String, String, QuestionFormQuestionResult) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet) | Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.
Show(IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon) | Visualizza il Form passando tutte le opzioni.
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Metodo QuestionForm.Show (String, String)

Metodo QuestionFormShow (String, String)
Visualizza il form con i 4 pulsanti utilizzando l'icona di applicazione, senza owner form e con il pulsante No preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    string title,
    string message
)
Public Shared Function Show (
    title As String,
    message As String
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    String^ title,
    String^ message
)
static member Show :
        title : string *
        message : string -> QuestionFormQuestionResult

Parametri

title
Tipo: SystemString
Titolo della finestra.
message
Tipo: SystemString
Messaggio da visualizzare.

Valore di ritorno

Tipo: QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show (String, String, QuestionForm.QuestionButtonSet)

Metodo QuestionFormShow (String, String, QuestionFormQuestionButtonSet)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione senza owner form con il pulsante No preselezionato.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    string title,
    string message,
    QuestionFormQuestionButtonSet buttonSet
)
Public Shared Function Show (
    title As String,
    message As String,
    buttonSet As QuestionFormQuestionButtonSet
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    String^ title,
    String^ message,
    QuestionFormQuestionButtonSet buttonSet
)
static member Show :
        title : string *
        message : string *
        buttonSet : QuestionFormQuestionButtonSet -> QuestionFormQuestionResult

Parametri

title
Tipo: SystemString
Titolo della finestra
message
Tipo: SystemString
Messaggio da visualizzare
buttonSet
Tipo: QsUIQuestionFormQuestionButtonSet

Valore di ritorno

Tipo: QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show (IWin32Window, String, String, QuestionForm.QuestionResult)

Metodo QuestionFormShow (IWin32Window, String, String, QuestionFormQuestionResult)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult -> QuestionFormQuestionResult

Parametri

owner
Tipo: System.Windows.FormsIWin32Window
Finestra genitore.
title
Tipo: SystemString
Titolo della finestra.
message
Tipo: SystemString
Messaggio da visualizzare.
defaultButton
Tipo: QsUIQuestionFormQuestionResult
Imposta il bottone usato di default.

Valore di ritorno

Tipo: QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show (IWin32Window, String, String, QuestionForm.QuestionResult, QuestionForm.QuestionButtonSet)

Metodo QuestionFormShow (IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet)
Visualizza il Form passando varie opzioni. Utilizza l'icona di applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult,
    buttonSet As QuestionFormQuestionButtonSet
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult *
        buttonSet : QuestionFormQuestionButtonSet -> QuestionFormQuestionResult

Parametri

owner
Tipo: System.Windows.FormsIWin32Window
Finestra genitore.
title
Tipo: SystemString
Titolo della finestra.
message
Tipo: SystemString
Messaggio da visualizzare.
defaultButton
Tipo: QsUIQuestionFormQuestionResult
Imposta il bottone usato di default.
buttonSet
Tipo: QsUIQuestionFormQuestionButtonSet

Valore di ritorno

Tipo: QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Metodo QuestionForm.Show (IWin32Window, String, String, QuestionForm.QuestionResult, QuestionForm.QuestionButtonSet, MessageBoxIcon)

Metodo QuestionFormShow (IWin32Window, String, String, QuestionFormQuestionResult, QuestionFormQuestionButtonSet, MessageBoxIcon)
Visualizza il Form passando tutte le opzioni.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QuestionFormQuestionResult Show(
    IWin32Window owner,
    string title,
    string message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet,
    MessageBoxIcon iconType
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    message As String,
    defaultButton As QuestionFormQuestionResult,
    buttonSet As QuestionFormQuestionButtonSet,
    iconType As MessageBoxIcon
) As QuestionFormQuestionResult
public:
static QuestionFormQuestionResult Show(
    IWin32Window^ owner,
    String^ title,
    String^ message,
    QuestionFormQuestionResult defaultButton,
    QuestionFormQuestionButtonSet buttonSet,
    MessageBoxIcon iconType
)
static member Show :
        owner : IWin32Window *
        title : string *
        message : string *
        defaultButton : QuestionFormQuestionResult *
        buttonSet : QuestionFormQuestionButtonSet *
        iconType : MessageBoxIcon -> QuestionFormQuestionResult

Parametri

owner
Tipo: System.Windows.FormsIWin32Window
Finestra genitore.
title
Tipo: SystemString
Titolo della finestra.
message
Tipo: SystemString
Messaggio da visualizzare.
defaultButton
Tipo: QsUIQuestionFormQuestionResult
Imposta il bottone usato di default.
buttonSet
Tipo: QsUIQuestionFormQuestionButtonSet
Indica i pulsanti da visualizzare.
iconType
Tipo: System.Windows.FormsMessageBoxIcon
Icona da visualizzare.

Valore di ritorno

Tipo: QuestionFormQuestionResult
Risultato della scelta dell'utente oppure None se chiude la finestra senza scegliere.
Vedi anche

Documentazione

Classe QuestionForm
Overload di Show


Eventi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Campi di QuestionForm

Il tipo QuestionForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | DpiBasedMinimumSize | Dimensioni minime calcolate sull'impostazione dei dpi correnti (Ereditato da QsBaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe QuestionForm


Enumerazione QuestionForm.QuestionButtonSet

Enumerazione QuestionFormQuestionButtonSet
Enumerazione dei pulsanti da visualizzare all'utente.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum QuestionButtonSet
Public Enumeration QuestionButtonSet
public enum class QuestionButtonSet
type QuestionButtonSet
Membri
Nome | Valore | Descrizione
Ok | 0 | Solo il pulsante ok.
YesNo | 1 | Sì/No.
YesNoAll | 2 | Sì, No, Sì tutti, No tutti
YesNoCancel | 3 | Sì, No, Annulla.
OkCancel | 4 | Ok, Annulla
RetryCancel | 5 | Riprova, Cancella
AbortRetryIgnore | 6 | Cancella, Riprova, Ignora
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione QuestionForm.QuestionResult

Enumerazione QuestionFormQuestionResult
Enumerazione per la gestione dei risultati multipli.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum QuestionResult
Public Enumeration QuestionResult
public enum class QuestionResult
type QuestionResult
Membri
Nome | Valore | Descrizione
None | 0 |
Yes | 1 |
YesAll | 2 |
No | 3 |
NoAll | 4 |
Ok | 5 |
Cancel | 6 |
Retry | 7 |
Abort | 8 |
Ignore | 9 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe ThumbnailControl
Classe usata per ricavare l'anteprima di un file.
Gerarchia di ereditarietà
SystemObject
QsUIThumbnailControl

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ThumbnailControl
Public Class ThumbnailControl
public ref class ThumbnailControl
type ThumbnailControl =  class end

Il tipo ThumbnailControl espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | ThumbnailControl | Costruttore. Copyright 2017 QsInformatica.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Thumb | Ritorna un clone dell'immagine rappresentante l'anterpima del file.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore ThumbnailControl

Costruttore. Copyright 2017 QsInformatica.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ThumbnailControl(
    string file,
    int width,
    int height
)
Public Sub New (
    file As String,
    width As Integer,
    height As Integer
)
public:
ThumbnailControl(
    String^ file,
    int width,
    int height
)
new :
        file : string *
        width : int *
        height : int -> ThumbnailControl

Parametri

file
Tipo: SystemString
File di cui ricavare l'anteprima.
width
Tipo: SystemInt32
Larghezza desiderata del preview.
height
Tipo: SystemInt32
Altezza desiderata del preview.
Vedi anche

Documentazione

Classe ThumbnailControl


Proprietà di ThumbnailControl

Il tipo ThumbnailControl espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Thumb | Ritorna un clone dell'immagine rappresentante l'anterpima del file.
Torna su
Vedi anche

Documentazione

Classe ThumbnailControl


Proprietà ThumbnailControl.Thumb

Proprietà ThumbnailControlThumb

Ritorna un clone dell'immagine rappresentante l'anterpima del file.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Bitmap Thumb { get; }
Public ReadOnly Property Thumb As Bitmap
    Get
public:
property Bitmap^ Thumb {
    Bitmap^ get ();
}
member Thumb : Bitmap with get

Valore della proprietà

Tipo: Bitmap
Vedi anche

Documentazione

Classe ThumbnailControl


Enumerazione ThumbnailOptions

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ThumbnailOptions
<FlagsAttribute>
Public Enumeration ThumbnailOptions
[FlagsAttribute]
public enum class ThumbnailOptions
[<FlagsAttribute>]
type ThumbnailOptions
Membri
Nome | Valore | Descrizione
None | 0 |
BiggerSizeOk | 1 |
InMemoryOnly | 2 |
IconOnly | 4 |
ThumbnailOnly | 8 |
InCacheOnly | 16 |
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe TreeListChoice
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
QsUITreeListChoice

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class TreeListChoice : XtraForm
Public Class TreeListChoice
    Inherits XtraForm
public ref class TreeListChoice : public XtraForm
type TreeListChoice =
    class
        inherit XtraForm
    end

Il tipo TreeListChoice espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TreeListChoice | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | FieldNameColumnFullFileName | FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà pubblica | FormTitle | Imposta il titolo del form.
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà pubblica | Multilev | Indica se la visualizzazione di default deve essere multilivello.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | Res | Restituisce se è stao premuto ok o cancel
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectedNodes | Restiruisce la lista dei nodi selezionati.
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowFileIcon | Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowPreview | Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà pubblica | StateImageList | Lista di immagini da usare per disegnare icona.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | TreeList | Restituiece l'albero.
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | AddColumn | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnChecNode | Chiama l'evento ShowSaveForm.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CheckNodeEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore TreeListChoice

Costruttore

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListChoice()
Public Sub New
public:
TreeListChoice()
new : unit -> TreeListChoice
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | FieldNameColumnFullFileName | FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà pubblica | FormTitle | Imposta il titolo del form.
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà pubblica | Multilev | Indica se la visualizzazione di default deve essere multilivello.
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | Res | Restituisce se è stao premuto ok o cancel
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SelectedNodes | Restiruisce la lista dei nodi selezionati.
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowFileIcon | Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowPreview | Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà pubblica | StateImageList | Lista di immagini da usare per disegnare icona.
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Proprietà pubblica | TreeList | Restituiece l'albero.
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.FieldNameColumnFullFileName

Proprietà TreeListChoiceFieldNameColumnFullFileName

FielName della colonna che contiene il fullfilename del file. (Create tale colonna tramite metodo AddColumn)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FieldNameColumnFullFileName { get; set; }
Public Property FieldNameColumnFullFileName As String
    Get
    Set
public:
property String^ FieldNameColumnFullFileName {
    String^ get ();
    void set (String^ value);
}
member FieldNameColumnFullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.FormTitle

Proprietà TreeListChoiceFormTitle

Imposta il titolo del form.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FormTitle { set; }
Public WriteOnly Property FormTitle As String
    Set
public:
property String^ FormTitle {
    void set (String^ value);
}
member FormTitle : string with set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.Multilev

Proprietà TreeListChoiceMultilev

Indica se la visualizzazione di default deve essere multilivello.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Multilev { get; set; }
Public Property Multilev As Boolean
    Get
    Set
public:
property bool Multilev {
    bool get ();
    void set (bool value);
}
member Multilev : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.Res

Proprietà TreeListChoiceRes

Restituisce se è stao premuto ok o cancel

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DialogResult Res { get; }
Public ReadOnly Property Res As DialogResult
    Get
public:
property DialogResult Res {
    DialogResult get ();
}
member Res : DialogResult with get

Valore della proprietà

Tipo: DialogResult
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.SelectedNodes

Proprietà TreeListChoiceSelectedNodes

Restiruisce la lista dei nodi selezionati.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<TreeListNode> SelectedNodes { get; }
Public ReadOnly Property SelectedNodes As List(Of TreeListNode)
    Get
public:
property List<TreeListNode^>^ SelectedNodes {
    List<TreeListNode^>^ get ();
}
member SelectedNodes : List<TreeListNode> with get

Valore della proprietà

Tipo: List TreeListNode
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowFileIcon

Proprietà TreeListChoiceShowFileIcon

Indica se visualizzare o meno l'icona dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ShowFileIcon { get; set; }
Public Property ShowFileIcon As Boolean
    Get
    Set
public:
property bool ShowFileIcon {
    bool get ();
    void set (bool value);
}
member ShowFileIcon : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.ShowPreview

Proprietà TreeListChoiceShowPreview

Indica se visualizzare o meno l'anteprima dei file. Se si impostare anche la proprietà FieldNameColumnFullFileName che contiene il nome della colonna con il fullfilename.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ShowPreview { get; set; }
Public Property ShowPreview As Boolean
    Get
    Set
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}
member ShowPreview : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.StateImageList

Proprietà TreeListChoiceStateImageList

Lista di immagini da usare per disegnare icona.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImageCollection StateImageList { get; set; }
Public Property StateImageList As ImageCollection
    Get
    Set
public:
property ImageCollection^ StateImageList {
    ImageCollection^ get ();
    void set (ImageCollection^ value);
}
member StateImageList : ImageCollection with get, set

Valore della proprietà

Tipo: ImageCollection
Vedi anche

Documentazione

Classe TreeListChoice


Proprietà TreeListChoice.TreeList

Proprietà TreeListChoiceTreeList

Restituiece l'albero.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeList TreeList { get; }
Public ReadOnly Property TreeList As TreeList
    Get
public:
property TreeList^ TreeList {
    TreeList^ get ();
}
member TreeList : TreeList with get

Valore della proprietà

Tipo: TreeList
Vedi anche

Documentazione

Classe TreeListChoice


Metodi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | AddColumn | Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive XtraForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnChecNode | Chiama l'evento ShowSaveForm.
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | Show | Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.AddColumn

Metodo TreeListChoiceAddColumn

Aggiunge le colonne all'albero (è bene fare TreeList.BeginUpdate prima di inserire la prima e TreeList.EndUpdate dopo aver inserito l'ultima)

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AddColumn(
    string caption,
    string fieldname,
    bool visible
)
Public Sub AddColumn (
    caption As String,
    fieldname As String,
    visible As Boolean
)
public:
void AddColumn(
    String^ caption,
    String^ fieldname,
    bool visible
)
member AddColumn :
        caption : string *
        fieldname : string *
        visible : bool -> unit

Parametri

caption
Tipo: SystemString
Caption della colonna
fieldname
Tipo: SystemString
Nome interno della colonna
visible
Tipo: SystemBoolean
Indica se la colonna deve essere visibile o meno
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.Dispose

Metodo TreeListChoiceDispose

Clean up any resources being used.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.OnChecNode

Metodo TreeListChoiceOnChecNode

Chiama l'evento ShowSaveForm.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected internal void OnChecNode(
    TreeListChoiceCheckNodeEventArgs ev
)
Protected Friend Sub OnChecNode (
    ev As TreeListChoiceCheckNodeEventArgs
)
protected public:
void OnChecNode(
    TreeListChoiceCheckNodeEventArgs^ ev
)
member OnChecNode :
        ev : TreeListChoiceCheckNodeEventArgs -> unit

Parametri

ev
Tipo: QsUITreeListChoiceCheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoice


Metodo TreeListChoice.Show

Metodo TreeListChoiceShow

Mostra l'anteprima di un file. Se la gestione dell'anteprima viene fatta dall'utente imposta l'immagine scelta dall'utente, altrimenti usa la gestione standard.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Show(
    string fileName
)
Public Sub Show (
    fileName As String
)
public:
void Show(
    String^ fileName
)
member Show :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
Percorso del file da visualizzare.
Vedi anche

Documentazione

Classe TreeListChoice


Eventi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CheckNodeEvent | Evento chiamato alla fine dell'inizializzazione dell'applicazione.
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Evento TreeListChoice.CheckNodeEvent

Evento TreeListChoiceCheckNodeEvent
Evento chiamato alla fine dell'inizializzazione dell'applicazione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<TreeListChoiceCheckNodeEventArgs> CheckNodeEvent
Public Event CheckNodeEvent As EventHandler(Of TreeListChoiceCheckNodeEventArgs)
public:
 event EventHandler<TreeListChoiceCheckNodeEventArgs^>^ CheckNodeEvent {
    void add (EventHandler<TreeListChoiceCheckNodeEventArgs^>^ value);
    void remove (EventHandler<TreeListChoiceCheckNodeEventArgs^>^ value);
}
member CheckNodeEvent : IEvent<EventHandler<TreeListChoiceCheckNodeEventArgs>,
    TreeListChoiceCheckNodeEventArgs>

Valore

Tipo: SystemEventHandler TreeListChoiceCheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoice


Campi di TreeListChoice

Il tipo TreeListChoice espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe TreeListChoice


Classe TreeListChoice.CheckNodeEventArgs

Classe TreeListChoiceCheckNodeEventArgs
Argomento contenente le informazioni relative al comando in esecuzione.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
QsUITreeListChoiceCheckNodeEventArgs

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckNodeEventArgs : EventArgs
Public Class CheckNodeEventArgs
    Inherits EventArgs
public ref class CheckNodeEventArgs : public EventArgs
type CheckNodeEventArgs =
    class
        inherit EventArgs
    end

Il tipo TreeListChoiceCheckNodeEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | TreeListChoiceCheckNodeEventArgs | Inizializza una nuova istanza della classe TreeListChoiceCheckNodeEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanCheck |
Proprietà pubblica | Node | Restituisce il comando in esecuzione.
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore TreeListChoice.CheckNodeEventArgs

Costruttore TreeListChoiceCheckNodeEventArgs

Inizializza una nuova istanza della classe TreeListChoiceCheckNodeEventArgs.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public CheckNodeEventArgs()
Public Sub New
public:
CheckNodeEventArgs()
new : unit -> CheckNodeEventArgs
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà di CheckNodeEventArgs

Il tipo TreeListChoiceCheckNodeEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | CanCheck |
Proprietà pubblica | Node | Restituisce il comando in esecuzione.
Torna su
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.CanCheck

Proprietà TreeListChoiceCheckNodeEventArgsCanCheck

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CanCheck { get; }
Public ReadOnly Property CanCheck As Boolean
    Get
public:
property bool CanCheck {
    bool get ();
}
member CanCheck : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Proprietà TreeListChoice.CheckNodeEventArgs.Node

Proprietà TreeListChoiceCheckNodeEventArgsNode

Restituisce il comando in esecuzione.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; }
Public ReadOnly Property Node As TreeListNode
    Get
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
}
member Node : TreeListNode with get

Valore della proprietà

Tipo: TreeListNode
Vedi anche

Documentazione

Classe TreeListChoiceCheckNodeEventArgs


Classe WindowsThumbnailProvider
Gerarchia di ereditarietà
SystemObject
QsUIWindowsThumbnailProvider

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class WindowsThumbnailProvider
Public Class WindowsThumbnailProvider
public ref class WindowsThumbnailProvider
type WindowsThumbnailProvider =  class end

Il tipo WindowsThumbnailProvider espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | WindowsThumbnailProvider | Inizializza una nuova istanza della classe WindowsThumbnailProvider.
Torna su
Metodi
Nome | Descrizione
CreateAlphaBitmap |
GetBitmapFromHBitmap |
GetThumbnail |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore WindowsThumbnailProvider

Inizializza una nuova istanza della classe WindowsThumbnailProvider.

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public WindowsThumbnailProvider()
Public Sub New
public:
WindowsThumbnailProvider()
new : unit -> WindowsThumbnailProvider
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodi di WindowsThumbnailProvider

Il tipo WindowsThumbnailProvider espone i seguenti membri.

Metodi
Nome | Descrizione
CreateAlphaBitmap |
GetBitmapFromHBitmap |
GetThumbnail |
Torna su
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.CreateAlphaBitmap

Metodo WindowsThumbnailProviderCreateAlphaBitmap

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap CreateAlphaBitmap(
    Bitmap srcBitmap,
    PixelFormat targetPixelFormat
)
Public Shared Function CreateAlphaBitmap (
    srcBitmap As Bitmap,
    targetPixelFormat As PixelFormat
) As Bitmap
public:
static Bitmap^ CreateAlphaBitmap(
    Bitmap^ srcBitmap,
    PixelFormat targetPixelFormat
)
static member CreateAlphaBitmap :
        srcBitmap : Bitmap *
        targetPixelFormat : PixelFormat -> Bitmap

Parametri

srcBitmap
Tipo: System.DrawingBitmap
targetPixelFormat
Tipo: System.Drawing.ImagingPixelFormat

Valore di ritorno

Tipo: Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.GetBitmapFromHBitmap

Metodo WindowsThumbnailProviderGetBitmapFromHBitmap

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap GetBitmapFromHBitmap(
    IntPtr nativeHBitmap
)
Public Shared Function GetBitmapFromHBitmap (
    nativeHBitmap As IntPtr
) As Bitmap
public:
static Bitmap^ GetBitmapFromHBitmap(
    IntPtr nativeHBitmap
)
static member GetBitmapFromHBitmap :
        nativeHBitmap : IntPtr -> Bitmap

Parametri

nativeHBitmap
Tipo: SystemIntPtr

Valore di ritorno

Tipo: Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Metodo WindowsThumbnailProvider.GetThumbnail

Metodo WindowsThumbnailProviderGetThumbnail

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Bitmap GetThumbnail(
    string fileName,
    int width,
    int height,
    ThumbnailOptions options
)
Public Shared Function GetThumbnail (
    fileName As String,
    width As Integer,
    height As Integer,
    options As ThumbnailOptions
) As Bitmap
public:
static Bitmap^ GetThumbnail(
    String^ fileName,
    int width,
    int height,
    ThumbnailOptions options
)
static member GetThumbnail :
        fileName : string *
        width : int *
        height : int *
        options : ThumbnailOptions -> Bitmap

Parametri

fileName
Tipo: SystemString
width
Tipo: SystemInt32
height
Tipo: SystemInt32
options
Tipo: QsUIThumbnailOptions

Valore di ritorno

Tipo: Bitmap
Vedi anche

Documentazione

Classe WindowsThumbnailProvider


Struttura WindowsThumbnailProvider.RGBQUAD

Struttura WindowsThumbnailProviderRGBQUAD

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public struct RGBQUAD
Public Structure RGBQUAD
public value class RGBQUAD
[<SealedAttribute>]
type RGBQUAD =  struct end

Il tipo WindowsThumbnailProviderRGBQUAD espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | rgbBlue |
Campo pubblico | rgbGreen |
Campo pubblico | rgbRed |
Campo pubblico | rgbReserved |
Torna su
Vedi anche

Documentazione

Namespace QsUI

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Campi di RGBQUAD

Il tipo WindowsThumbnailProviderRGBQUAD espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | rgbBlue |
Campo pubblico | rgbGreen |
Campo pubblico | rgbRed |
Campo pubblico | rgbReserved |
Torna su
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbBlue

Campo WindowsThumbnailProviderRGBQUADrgbBlue

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public byte rgbBlue
Public rgbBlue As Byte
public:
unsigned char rgbBlue
val mutable rgbBlue: byte

Valore del campo

Tipo: Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbGreen

Campo WindowsThumbnailProviderRGBQUADrgbGreen

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public byte rgbGreen
Public rgbGreen As Byte
public:
unsigned char rgbGreen
val mutable rgbGreen: byte

Valore del campo

Tipo: Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbRed

Campo WindowsThumbnailProviderRGBQUADrgbRed

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public byte rgbRed
Public rgbRed As Byte
public:
unsigned char rgbRed
val mutable rgbRed: byte

Valore del campo

Tipo: Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD


Campo WindowsThumbnailProvider.RGBQUAD.rgbReserved

Campo WindowsThumbnailProviderRGBQUADrgbReserved

Namespace: QsUI
Assembly: QsUI (in QsUI.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public byte rgbReserved
Public rgbReserved As Byte
public:
unsigned char rgbReserved
val mutable rgbReserved: byte

Valore del campo

Tipo: Byte
Vedi anche

Documentazione

Struttura WindowsThumbnailProviderRGBQUAD