DedNetAcad Namespace
Classi
 | Classe | Descrizione
Classe pubblica | AcadDocStructInfo |
Classe pubblica | AcadDocStructInfoEventHandlers | Classe gestione eventi client del DoscStructInfo
Classe pubblica | CaricaParte | Comando che effettua il carica parte di un DWG, sotto una data parte.
Classe pubblica | CheckIn | Mette in check-in il documento correntemente attivo.
Classe pubblica | CheckOut | Mette in check-out il documento correntemente attivo.
Classe pubblica | CompilaParteDaAnagrafica | Compila gli attributi della parte correntemente attiva con l'anagrafica selezionata nella finestra di Ricerca.
Classe pubblica | CreateSparePartsDrawing | Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Classe pubblica | DedAcadArchiviaDwg | Archivia il documento corrente in una root specifica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadAssociaDwg | Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadChangeState | Comando che effettua il rilascio dell'anagrafica associata
Classe pubblica | DedAcadCreaAnagrafica | Effettua il salvataggio del documento corrente o della parte selezionata nel Database con un nuovo codice. Da utilizzare anche nelle procedure personalizzate. Per personalizzare la creazione dell'anagrafica, impostare nella proprietà SaveCommand un comando inizializzato con già tutte le informazioni preimpostate. Diversamente il comando sarà inizializzato in base agli attributi del documento corrente.
Classe pubblica | DedAcadCreaRev | Effettua il Salva Revisione del documento attivo. Da utilizzare anche nelle procedure personalizzate.
Classe pubblica | DedAcadForceMarkerAlingment | Comando che permette di forzare la allineamento del documento con quella presente nel Database.
Classe pubblica | DedAcadMarkerInfo | Comando che permette di controllare lo stato di allineamento del documento.
Classe pubblica | DedApiAcad | NOTA : Da Lua usare DEDACADAPI per accedere ai metodi.
Classe pubblica | DedNetAcadApp | Classe principale dell'add-in per Autocad di DedNet. Viene pubblicata l'istanza di questo oggetto attraverso la variabile globale LUA DEDACAD.
Classe pubblica | DedNetAcadAppAcadRilPublishEventArgs | Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Classe pubblica | DedNetAcadAppImportPackAndGoAfterLoadEventArgs | Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Classe pubblica | DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs | Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Classe pubblica | DedNetAcadAppImportPackAndGoMappingRootEventArgs |
Classe pubblica | DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs |
Classe pubblica | DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs |
Classe pubblica | DedNetAcadAppResolutionEventArgs | Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Classe pubblica | DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | DedNetAcadAppUpdateCartOnOpenEventArgs | Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Classe pubblica | DedNetAcadCommands | Classe di definizione dei comandi.
Classe pubblica | DedNetAcadFileResolution |
Classe pubblica | DedNetAcadFileResolutionOnFileResolutionSostItem |
Classe pubblica | DedNetAcadFileResolutionOnFileResolutionSostItemList |
Classe pubblica | Lua | Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Classe pubblica | PackAndGoExport | Esportazione packAndgo Autocad
Classe pubblica | PackAndGoImport | Esportazione packAndgo Autocad
Classe pubblica | PackAndGoImportingStructureInfo | Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Classe pubblica | PackAndGoNodeDescriptor | Descrittore singolo nodo di struttura
Classe pubblica | PackAndGoNodeDescriptors | Classe gestione lista nodi di struttura
Classe pubblica | PackAndGoNodeWrapper | Classe rappresentante l'oggetto nodo nel controllo treeList del form
Classe pubblica | PackAndGoStructureDescriptor | Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Classe pubblica | PartInfo | Classe utilizzata per ottenere informazioni, chiamando metodi, sulla parte correntemente selezionata, sulla parte Top del disegno oppure su di una parte utilizzata nella creazione dell'oggetto.
Classe pubblica | PartInfoArray | Classe utilizzata per ottenere informazioni su di un oggetto PrtArray LUA. Chiama i metodi dell'oggetto via LUA come l'oggetto PartInfo. Questo oggetto è creabile solo via LUA.
Classe pubblica | PrtArraySelectStatusInfo | Classe che verifica lo stato di un array di parti e restituisce informazioni utili per la disponibilità e l'esecuzione dei comandi.
Classe pubblica | Pubblish |
Classe pubblica | PublishSparePartsDrawing | Comando che pubblica una tavola tecnica ricambi in formato pdf.
Classe pubblica | QsDocument |
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | ResolveFileForm |
Classe pubblica | Resolver | Classe di inizializzazione add-in. Viene utilizzata per registrare l'evento di risuluzione assembly in modo che nell'inizializzazione vera e propria dell'oggetto DedNetAcadApp si possa liberamente dichiarare i vari tipi di dato senza compromettere il caricamento dell'add-in.
Classe pubblica | Util | Utility con gli assert e varie altre funzioni di utilizzo frequente.
Enumerazioni
 | Enumerazione | Descrizione
Enumerazione pubblica | DedNetAcadFileResolutionRispostaUtenteSost |
Enumerazione pubblica | PackAndGoContext | Definizione possibili contesti
Enumerazione pubblica | PackAndGoImportAttrStatus | Stato attributi in validazione importazione
Enumerazione pubblica | PackAndGoImportDedCases | Possibili casi del database in fase di importazione
Enumerazione pubblica | PackAndGoImportOperation | Definizione possibili azioni su oggetti importazione
Enumerazione pubblica | PackAndGoImportOperationStatus | Stato di validazione dell'operazione ( per ora non usata sempre Ok )

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe AcadDocStructInfo
Gerarchia di ereditarietà
SystemObject
DocStructInfo
DedNetAcadAcadDocStructInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AcadDocStructInfo : DocStructInfo
Public Class AcadDocStructInfo
    Inherits DocStructInfo
public ref class AcadDocStructInfo : public DocStructInfo
type AcadDocStructInfo =
    class
        inherit DocStructInfo
    end

Il tipo AcadDocStructInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo protetto | AcadDocStructInfo | Passa la costruzione alla classe base.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DocStructInfo.)
Proprietà pubblica | ChildrenMade | (Ereditato da DocStructInfo.)
Proprietà pubblica | CloneFullName | (Ereditato da DocStructInfo.)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | (Ereditato da DocStructInfo.)
Proprietà pubblica | DelToMake | (Ereditato da DocStructInfo.)
Proprietà pubblica | DepType | (Ereditato da DocStructInfo.)
Proprietà pubblica | Description | (Ereditato da DocStructInfo.)
Proprietà pubblica | DocRowVer | (Ereditato da DocStructInfo.)
Proprietà pubblica | DoNotMoveOrDelete | (Ereditato da DocStructInfo.)
Proprietà pubblica | FileDescriptor | (Ereditato da DocStructInfo.)
Proprietà pubblica | FileOperationExecuted | (Ereditato da DocStructInfo.)
Proprietà pubblica | FirstOperation | (Ereditato da DocStructInfo.)
Proprietà pubblica | Folder | (Ereditato da DocStructInfo.)
Proprietà pubblica | FullFileName | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasChildren | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasSubstitutes | (Ereditato da DocStructInfo.)
Proprietà pubblica | InternalName | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsElaborated | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsiModelMember | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsLayoutAsset | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsParentSubstitute | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSpecialStructContainer | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSpecialStructElement | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSubstitute | (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperation | (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperationEnum | (Ereditato da DocStructInfo.)
Proprietà pubblica | MakeChildrenOutOfMemory | (Ereditato da DocStructInfo.)
Proprietà pubblica | MoveInsteadOfCopy | (Ereditato da DocStructInfo.)
Proprietà pubblica | OperationList | (Ereditato da DocStructInfo.)
Proprietà pubblica | Parent | (Ereditato da DocStructInfo.)
Proprietà pubblica | ReferenceUpdated | (Ereditato da DocStructInfo.)
Proprietà pubblica | SavingTypeDoc | (Ereditato da DocStructInfo.)
Proprietà pubblica | SkipReferenceUpdate | (Ereditato da DocStructInfo.)
Proprietà pubblica | Ties | (Ereditato da DocStructInfo.)
Proprietà pubblica | ToClone | (Ereditato da DocStructInfo.)
Proprietà pubblica | UserData | (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInDb | (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInLibraryPath | (Ereditato da DocStructInfo.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedEco) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedEco) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRemovingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddSbloccaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddUpdatingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | BottomUpCall | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String).)
Metodo pubblico | Equals | (Ereditato da DocStructInfo.)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo.)
Metodo pubblico | GetAllSpecialChildren | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo.)
Metodo pubblico | GetLastQueuedOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | GetOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | HasOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAutoByDocDep | (Ereditato da DocStructInfo.)
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | Rebuild | (Ereditato da DocStructInfo.)
Metodo pubblico | SetNotToClone | (Ereditato da DocStructInfo.)
Metodo pubblico | SetToClone | (Ereditato da DocStructInfo.)
Metodo pubblico | ToString | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean).)
Metodo pubblico | UpdateDocumentData | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateParentReferences | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | Elements | (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad


Costruttore AcadDocStructInfo

Passa la costruzione alla classe base.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected AcadDocStructInfo(
    DedNetApplication app,
    DocStructInfoCollection parent,
    DocStructInfoDictionary elements,
    DocStructInfoFileDescriptor fileDescr,
    DocDepEnum depType
)
Protected Sub New (
    app As DedNetApplication,
    parent As DocStructInfoCollection,
    elements As DocStructInfoDictionary,
    fileDescr As DocStructInfoFileDescriptor,
    depType As DocDepEnum
)
protected:
AcadDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoCollection^ parent,
    DocStructInfoDictionary^ elements,
    DocStructInfoFileDescriptor^ fileDescr,
    DocDepEnum depType
)
new :
        app : DedNetApplication *
        parent : DocStructInfoCollection *
        elements : DocStructInfoDictionary *
        fileDescr : DocStructInfoFileDescriptor *
        depType : DocDepEnum -> AcadDocStructInfo

Parametri

app
Tipo: DedNetApplication
parent
Tipo: DocStructInfoCollection
elements
Tipo: DocStructInfoDictionary
fileDescr
Tipo: DocStructInfoFileDescriptor
depType
Tipo: DocDepEnum
Vedi anche

Documentazione

Classe AcadDocStructInfo


Proprietà di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DocStructInfo.)
Proprietà pubblica | ChildrenMade | (Ereditato da DocStructInfo.)
Proprietà pubblica | CloneFullName | (Ereditato da DocStructInfo.)
Proprietà pubblica | Data | Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.
Proprietà pubblica | DataUpdated | (Ereditato da DocStructInfo.)
Proprietà pubblica | DelToMake | (Ereditato da DocStructInfo.)
Proprietà pubblica | DepType | (Ereditato da DocStructInfo.)
Proprietà pubblica | Description | (Ereditato da DocStructInfo.)
Proprietà pubblica | DocRowVer | (Ereditato da DocStructInfo.)
Proprietà pubblica | DoNotMoveOrDelete | (Ereditato da DocStructInfo.)
Proprietà pubblica | FileDescriptor | (Ereditato da DocStructInfo.)
Proprietà pubblica | FileOperationExecuted | (Ereditato da DocStructInfo.)
Proprietà pubblica | FirstOperation | (Ereditato da DocStructInfo.)
Proprietà pubblica | Folder | (Ereditato da DocStructInfo.)
Proprietà pubblica | FullFileName | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasChildren | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasParent | (Ereditato da DocStructInfo.)
Proprietà pubblica | HasSubstitutes | (Ereditato da DocStructInfo.)
Proprietà pubblica | InternalName | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsElaborated | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsiModelMember | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsLayoutAsset | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsParentSubstitute | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSpecialStructContainer | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSpecialStructElement | (Ereditato da DocStructInfo.)
Proprietà pubblica | IsSubstitute | (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperation | (Ereditato da DocStructInfo.)
Proprietà pubblica | LastOperationEnum | (Ereditato da DocStructInfo.)
Proprietà pubblica | MakeChildrenOutOfMemory | (Ereditato da DocStructInfo.)
Proprietà pubblica | MoveInsteadOfCopy | (Ereditato da DocStructInfo.)
Proprietà pubblica | OperationList | (Ereditato da DocStructInfo.)
Proprietà pubblica | Parent | (Ereditato da DocStructInfo.)
Proprietà pubblica | ReferenceUpdated | (Ereditato da DocStructInfo.)
Proprietà pubblica | SavingTypeDoc | (Ereditato da DocStructInfo.)
Proprietà pubblica | SkipReferenceUpdate | (Ereditato da DocStructInfo.)
Proprietà pubblica | Ties | (Ereditato da DocStructInfo.)
Proprietà pubblica | ToClone | (Ereditato da DocStructInfo.)
Proprietà pubblica | UserData | (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInDb | (Ereditato da DocStructInfo.)
Proprietà pubblica | WasInLibraryPath | (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Proprietà AcadDocStructInfo.Data

Libreria DedNetAcad

Proprietà AcadDocStructInfoData

Restituisce l'anagrafica al quale l'elemento è associato come file primario oppure null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodi di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AddAnnullaCheckOutOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckInStrutturaOperation(Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCheckOutStrutturaOperation(PredicateDedDoc, Boolean, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCopyingOperation(String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddCreatingOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddDisconnectingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddEnsureLocalOperation(PredicateDedDoc, Boolean, ListException, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingOperation(Boolean, String, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddExportingStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddForzaCheckInStrutturaOperation(Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedEco) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, String, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, DedDocContextEnum, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddImportingOperation(DedData, Boolean, Boolean, String, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedEco) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, Boolean, DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddLinkingOperation(DedData, DedDocContextEnum, DedData) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddMovingOperation(String, MovReasonEnum, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddPubblicaStrutturaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedComm) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRecogniseOperation(DedData, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRelocateOperation(DedDoc, Boolean, Boolean) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddRemovingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddReplaceOperation(DocStructInfo) | (Ereditato da DocStructInfo.)
Metodo pubblico | AddSbloccaOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | AddUpdatingOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | BottomUpCall | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Metodo pubblico | EnforcedMakeChildrenAuto | La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad (Sovrascrive DocStructInfo.EnforcedMakeChildrenAuto(String).)
Metodo pubblico | Equals | (Ereditato da DocStructInfo.)
Metodo pubblico | FindAllLevels | (Ereditato da DocStructInfo.)
Metodo pubblico | GetAllSpecialChildren | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashCode | (Ereditato da DocStructInfo.)
Metodo pubblico | GetHashString | (Ereditato da DocStructInfo.)
Metodo pubblico | GetLastQueuedOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | GetOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | HasOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | (Ereditato da DocStructInfo.)
Metodo pubblico | MakeChildrenAutoByDocDep | (Ereditato da DocStructInfo.)
 | MakeFromFileList | Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.
Metodo pubblico | PerformFileOperation | (Ereditato da DocStructInfo.)
Metodo pubblico | Rebuild | (Ereditato da DocStructInfo.)
Metodo pubblico | SetNotToClone | (Ereditato da DocStructInfo.)
Metodo pubblico | SetToClone | (Ereditato da DocStructInfo.)
Metodo pubblico | ToString | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateData | Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true (Sovrascrive DocStructInfo.UpdateData(Boolean).)
Metodo pubblico | UpdateDocumentData | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateParentReferences | (Ereditato da DocStructInfo.)
Metodo pubblico | UpdateReferences | Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true. (Sovrascrive DocStructInfo.UpdateReferences.)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo

Metodo AcadDocStructInfoCreateDocStructInfo

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(String) | (Ereditato da DocStructInfo.)
Metodo pubblico | CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo) | Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice. (Sovrascrive DocStructInfo.CreateDocStructInfo(DocStructInfoFileDescriptor, DocStructInfo).)
 | CreateDocStructInfo(DedNetApplication, DocStructInfoFileDescriptor) | Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo (DocStructInfoFileDescriptor, DocStructInfo)

Metodo AcadDocStructInfoCreateDocStructInfo (DocStructInfoFileDescriptor, DocStructInfo)
Crea e restituisce un nuovo oggetto evitando i duplicati, infatti cerca prima negli elementi interni e se lo trova restituisce l'elemento trovato, altrimenti crea un nuovo oggetto che comunque condivide gli elementi di questo oggetto. È indispensabile chiamare questo metodo per creare un oggetto dopo la chiamata all'omonimo metodo statico per la creazione del primo elemento. Il nuovo elemento viene impostato come figlio di questa istanza. NOTA: Non crea la sotto struttura!! Chiamare MakeChildrenAuto() per ottenerla tramite apprentice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override DocStructInfo CreateDocStructInfo(
    DocStructInfoFileDescriptor fileDescr,
    DocStructInfo parent
)
Public Overrides Function CreateDocStructInfo (
    fileDescr As DocStructInfoFileDescriptor,
    parent As DocStructInfo
) As DocStructInfo
public:
virtual DocStructInfo^ CreateDocStructInfo(
    DocStructInfoFileDescriptor^ fileDescr,
    DocStructInfo^ parent
) override
abstract CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo
override CreateDocStructInfo :
        fileDescr : DocStructInfoFileDescriptor *
        parent : DocStructInfo -> DocStructInfo

Parametri

fileDescr
Tipo: DocStructInfoFileDescriptor
Descrittore file del quale ricavere le informazioni
parent
Tipo: DocStructInfo
Padre dell'elemento.

Valore di ritorno

Tipo: DocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di CreateDocStructInfo


Metodo AcadDocStructInfo.CreateDocStructInfo (DedNetApplication, DocStructInfoFileDescriptor)

Metodo AcadDocStructInfoCreateDocStructInfo (DedNetApplication, DocStructInfoFileDescriptor)
Crea e restituisce un nuovo oggetto AcadDocStructInfo. Questo metodo è da utilizzare per la creazione del primo elemento, dopo si deve utilizzare la versione omonima d'istanza per creare gli oggetti successivi, in modo da evitare duplicati nella struttura dei documenti.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AcadDocStructInfo CreateDocStructInfo(
    DedNetApplication app,
    DocStructInfoFileDescriptor fileDescr
)
Public Shared Function CreateDocStructInfo (
    app As DedNetApplication,
    fileDescr As DocStructInfoFileDescriptor
) As AcadDocStructInfo
public:
static AcadDocStructInfo^ CreateDocStructInfo(
    DedNetApplication^ app,
    DocStructInfoFileDescriptor^ fileDescr
)
static member CreateDocStructInfo :
        app : DedNetApplication *
        fileDescr : DocStructInfoFileDescriptor -> AcadDocStructInfo

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileDescr
Tipo: DocStructInfoFileDescriptor
File del quale ricavere le informazioni.

Valore di ritorno

Tipo: AcadDocStructInfo
Restituisce un nuovo oggetto inizializzato.
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di CreateDocStructInfo


Metodo AcadDocStructInfo.EnforcedMakeChildrenAuto

Metodo AcadDocStructInfoEnforcedMakeChildrenAuto

La logica è la stessa del MakeChildrenAuto solo che legge le dipendenze in base alla varibile di Autocad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void EnforcedMakeChildrenAuto(
    string fileName
)
Public Overrides Sub EnforcedMakeChildrenAuto (
    fileName As String
)
public:
virtual void EnforcedMakeChildrenAuto(
    String^ fileName
) override
abstract EnforcedMakeChildrenAuto :
        fileName : string -> unit
override EnforcedMakeChildrenAuto :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.MakeChildrenAuto

Metodo AcadDocStructInfoMakeChildrenAuto

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | MakeChildrenAuto | Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria. (Sovrascrive DocStructInfo.MakeChildrenAuto.)
Metodo pubblico | MakeChildrenAuto(DocStructInfoList) | (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.MakeChildrenAuto

Metodo AcadDocStructInfoMakeChildrenAuto

Se la collezione di elementi figli è vuota crea automaticamente le dipendenze sfruttando le deduzioni sul dwg/prt oppure i legami già presenti nel Database. Sovrascrive il metodo originale nella classe base per espanderne le funzionalità utilizzando le dipendenze dei documenti in memoria.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void MakeChildrenAuto()
Public Overrides Sub MakeChildrenAuto
public:
virtual void MakeChildrenAuto() override
abstract MakeChildrenAuto : unit -> unit
override MakeChildrenAuto : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfo
Overload di MakeChildrenAuto


Metodo AcadDocStructInfo.MakeFromFileList

Metodo AcadDocStructInfoMakeFromFileList

Crea e restituisce una lista di struttura documento, data una lista di file, auto-creando i figli. Questa funzione si preoccupa di non duplicare elementi nella lista resitituita.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList MakeFromFileList(
    DedNetApplication app,
    string[] fileList
)
Public Shared Function MakeFromFileList (
    app As DedNetApplication,
    fileList As String()
) As DocStructInfoList
public:
static DocStructInfoList^ MakeFromFileList(
    DedNetApplication^ app,
    array<String^>^ fileList
)
static member MakeFromFileList :
        app : DedNetApplication *
        fileList : string[] -> DocStructInfoList

Parametri

app
Tipo: DedNetApplication
Applicazione di appartenenza.
fileList
Tipo: SystemString
Lista di file da elaborare.

Valore di ritorno

Tipo: DocStructInfoList
Restituisce sempre una lista inizializzata.
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.UpdateData

Metodo AcadDocStructInfoUpdateData

Aggiorno le anagrafiche collegate ai riferimenti elaborati. Imposta la proprietà dataUpdated a true

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateData(
    bool updateRowVer = true
)
Public Overrides Sub UpdateData (
    Optional updateRowVer As Boolean = true
)
public:
virtual void UpdateData(
    bool updateRowVer = true
) override
abstract UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit
override UpdateData :
        ?updateRowVer : bool
(* Defaults:
        let _updateRowVer = defaultArg updateRowVer true
*)
-> unit

Parametri

updateRowVer (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe AcadDocStructInfo


Metodo AcadDocStructInfo.UpdateReferences

Metodo AcadDocStructInfoUpdateReferences

Aggiorna i riferimenti fisici dei file di primo livello per questo elemento e poi chiama l'aggiornamento sui figli. Imposta la proprietà ReferenceUpdated dell'elemento a true.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void UpdateReferences()
Public Overrides Sub UpdateReferences
public:
virtual void UpdateReferences() override
abstract UpdateReferences : unit -> unit
override UpdateReferences : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfo


Campi di AcadDocStructInfo

Il tipo AcadDocStructInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | Elements | (Ereditato da DocStructInfo.)
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfo


Classe AcadDocStructInfoEventHandlers
Classe gestione eventi client del DoscStructInfo
Gerarchia di ereditarietà
SystemObject
DedNetAcadAcadDocStructInfoEventHandlers

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AcadDocStructInfoEventHandlers
Public Class AcadDocStructInfoEventHandlers
public ref class AcadDocStructInfoEventHandlers
type AcadDocStructInfoEventHandlers =  class end

Il tipo AcadDocStructInfoEventHandlers espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | AcadDocStructInfoEventHandlers |
Torna su
Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore AcadDocStructInfoEventHandlers

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AcadDocStructInfoEventHandlers()
Public Sub New
public:
AcadDocStructInfoEventHandlers()
new : unit -> AcadDocStructInfoEventHandlers
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodi di AcadDocStructInfoEventHandlers

Il tipo AcadDocStructInfoEventHandlers espone i seguenti membri.

Metodi
Nome | Descrizione
InitializeDocStructInfoEvents | Metodo che inizializza gli eventi
OnDocStructInfoCreated | Evento chiamato al termine della creazione di un nuovo struct info
Torna su
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodo AcadDocStructInfoEventHandlers.InitializeDocStructInfoEvents

Metodo AcadDocStructInfoEventHandlersInitializeDocStructInfoEvents

Metodo che inizializza gli eventi

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void InitializeDocStructInfoEvents()
Public Shared Sub InitializeDocStructInfoEvents
public:
static void InitializeDocStructInfoEvents()
static member InitializeDocStructInfoEvents : unit -> unit
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Metodo AcadDocStructInfoEventHandlers.OnDocStructInfoCreated

Metodo AcadDocStructInfoEventHandlersOnDocStructInfoCreated

Evento chiamato al termine della creazione di un nuovo struct info

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnDocStructInfoCreated(
    Object sender,
    ResolveDocStructInfoEventArgs args
)
Public Shared Sub OnDocStructInfoCreated (
    sender As Object,
    args As ResolveDocStructInfoEventArgs
)
public:
static void OnDocStructInfoCreated(
    Object^ sender,
    ResolveDocStructInfoEventArgs^ args
)
static member OnDocStructInfoCreated :
        sender : Object *
        args : ResolveDocStructInfoEventArgs -> unit

Parametri

sender
Tipo: SystemObject
args
Tipo: ResolveDocStructInfoEventArgs
Vedi anche

Documentazione

Classe AcadDocStructInfoEventHandlers


Classe CaricaParte
Comando che effettua il carica parte di un DWG, sotto una data parte.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCaricaParte

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CaricaParte : DedCommand
Public Class CaricaParte
    Inherits DedCommand
public ref class CaricaParte : public DedCommand
type CaricaParte =
    class
        inherit DedCommand
    end

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LoadAsBlock | Restituisce o imposta se bisogna inserire il documento come blocco o meno.
Proprietà pubblica | LoadAsPrtExt | Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".
Proprietà pubblica | LoadAsXref | Restituisce o imposta se bisogna inserire il documento come xRef o meno.
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrtNew | Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.
Proprietà pubblica | PrtPadre | Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | DocInfo | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | DocInfos | Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LoadAsBlock | Restituisce o imposta se bisogna inserire il documento come blocco o meno.
Proprietà pubblica | LoadAsPrtExt | Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".
Proprietà pubblica | LoadAsXref | Restituisce o imposta se bisogna inserire il documento come xRef o meno.
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrtNew | Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.
Proprietà pubblica | PrtPadre | Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.Asynch

Proprietà CaricaParteAsynch

Restituisce o imposta se il carica parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è true.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.DocInfo

Proprietà CaricaParteDocInfo

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandDocAnagrInfo DocInfo { get; set; }
Public Property DocInfo As DedCommandDocAnagrInfo
    Get
    Set
public:
property DedCommandDocAnagrInfo^ DocInfo {
    DedCommandDocAnagrInfo^ get ();
    void set (DedCommandDocAnagrInfo^ value);
}
member DocInfo : DedCommandDocAnagrInfo with get, set

Valore della proprietà

Tipo: DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.DocInfos

Proprietà CaricaParteDocInfos

Restituisce o imposta le informazioni necessarie per individuare il documento da caricare e l'anagrafica da utilizzare per impostare i dati nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<DedCommandDocAnagrInfo> DocInfos { get; set; }
Public Property DocInfos As List(Of DedCommandDocAnagrInfo)
    Get
    Set
public:
property List<DedCommandDocAnagrInfo^>^ DocInfos {
    List<DedCommandDocAnagrInfo^>^ get ();
    void set (List<DedCommandDocAnagrInfo^>^ value);
}
member DocInfos : List<DedCommandDocAnagrInfo> with get, set

Valore della proprietà

Tipo: List DedCommandDocAnagrInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsBlock

Proprietà CaricaParteLoadAsBlock

Restituisce o imposta se bisogna inserire il documento come blocco o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsBlock { get; set; }
Public Property LoadAsBlock As Boolean
    Get
    Set
public:
property bool LoadAsBlock {
    bool get ();
    void set (bool value);
}
member LoadAsBlock : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsPrtExt

Proprietà CaricaParteLoadAsPrtExt

Restituisce o imposta se bisogna utilizzare il comando "Carica parte esterna".

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsPrtExt { get; set; }
Public Property LoadAsPrtExt As Boolean
    Get
    Set
public:
property bool LoadAsPrtExt {
    bool get ();
    void set (bool value);
}
member LoadAsPrtExt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.LoadAsXref

Proprietà CaricaParteLoadAsXref

Restituisce o imposta se bisogna inserire il documento come xRef o meno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LoadAsXref { get; set; }
Public Property LoadAsXref As Boolean
    Get
    Set
public:
property bool LoadAsXref {
    bool get ();
    void set (bool value);
}
member LoadAsXref : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.NeedParameters

Proprietà CaricaParteNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.PrtNew

Proprietà CaricaPartePrtNew

Restituisce la parte caricata. Disponibile solo alla fine del comando. Non è detto che il comando riesca a reperire la parte, soprattutto se lanciato dalla ricerca in modo asincrono.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtNew { get; }
Public ReadOnly Property PrtNew As PartInfo
    Get
public:
property PartInfo^ PrtNew {
    PartInfo^ get ();
}
member PrtNew : PartInfo with get

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe CaricaParte


Proprietà CaricaParte.PrtPadre

Proprietà CaricaPartePrtPadre

Restituisce o imposta la parte sotto la quale caricare il documento. Se non specificata viene utilizzata la parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtPadre { get; set; }
Public Property PrtPadre As PartInfo
    Get
    Set
public:
property PartInfo^ PrtPadre {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtPadre : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe CaricaParte


Metodi di CaricaParte

Il tipo CaricaParte espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.ClearCommand

Metodo CaricaParteClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.Enabled

Metodo CaricaParteEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.ExecuteCommand

Metodo CaricaParteExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CaricaParte


Metodo CaricaParte.SetContext

Metodo CaricaParteSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CaricaParte


Classe CheckIn
Mette in check-in il documento correntemente attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCheckIn

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckIn : DedCommand
Public Class CheckIn
    Inherits DedCommand
public ref class CheckIn : public DedCommand
type CheckIn =
    class
        inherit DedCommand
    end

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CheckIn

Il tipo CheckIn espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | EraseFromPws | Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.EraseFromPws

Proprietà CheckInEraseFromPws

Restituisce o imposta se eliminare il documento dall'area locale. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EraseFromPws { get; set; }
Public Property EraseFromPws As Boolean
    Get
    Set
public:
property bool EraseFromPws {
    bool get ();
    void set (bool value);
}
member EraseFromPws : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn


Proprietà CheckIn.NeedParameters

Proprietà CheckInNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckIn


Metodi di CheckIn

Il tipo CheckIn espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.ClearCommand

Metodo CheckInClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.Enabled

Metodo CheckInEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.ExecuteCommand

Metodo CheckInExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CheckIn


Metodo CheckIn.SetContext

Metodo CheckInSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CheckIn


Classe CheckOut
Mette in check-out il documento correntemente attivo.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCheckOut

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CheckOut : DedCommand
Public Class CheckOut
    Inherits DedCommand
public ref class CheckOut : public DedCommand
type CheckOut =
    class
        inherit DedCommand
    end

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CheckOut

Il tipo CheckOut espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckOut


Proprietà CheckOut.NeedParameters

Proprietà CheckOutNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CheckOut


Metodi di CheckOut

Il tipo CheckOut espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.ClearCommand

Metodo CheckOutClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.Enabled

Metodo CheckOutEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.ExecuteCommand

Metodo CheckOutExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CheckOut


Metodo CheckOut.SetContext

Metodo CheckOutSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CheckOut


Classe CompilaParteDaAnagrafica
Compila gli attributi della parte correntemente attiva con l'anagrafica selezionata nella finestra di Ricerca.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCompilaParteDaAnagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CompilaParteDaAnagrafica : DedCommand
Public Class CompilaParteDaAnagrafica
    Inherits DedCommand
public ref class CompilaParteDaAnagrafica : public DedCommand
type CompilaParteDaAnagrafica =
    class
        inherit DedCommand
    end

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da compilare nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restitusice o imposta la parte da compilare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CompilaParteDaAnagrafica

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica da compilare nella parte.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restitusice o imposta la parte da compilare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.Data

Proprietà CompilaParteDaAnagraficaData

Restituisce o imposta l'anagrafica da compilare nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.NeedParameters

Proprietà CompilaParteDaAnagraficaNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere sia l'anagrafica che la parte attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Proprietà CompilaParteDaAnagrafica.Prt

Proprietà CompilaParteDaAnagraficaPrt

Restitusice o imposta la parte da compilare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodi di CompilaParteDaAnagrafica

Il tipo CompilaParteDaAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.ClearCommand

Metodo CompilaParteDaAnagraficaClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.Enabled

Metodo CompilaParteDaAnagraficaEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.ExecuteCommand

Metodo CompilaParteDaAnagraficaExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Metodo CompilaParteDaAnagrafica.SetContext

Metodo CompilaParteDaAnagraficaSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CompilaParteDaAnagrafica


Classe CreateSparePartsDrawing
Comando che, partendo dal disegno correntemente aperto, crea il documento tecnico dei ricambi da inserire nel manuale.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadCreateSparePartsDrawing

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class CreateSparePartsDrawing : DedCommand
Public Class CreateSparePartsDrawing
    Inherits DedCommand
public ref class CreateSparePartsDrawing : public DedCommand
type CreateSparePartsDrawing =
    class
        inherit DedCommand
    end

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Proprietà CreateSparePartsDrawing.NeedParameters

Proprietà CreateSparePartsDrawingNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodi di CreateSparePartsDrawing

Il tipo CreateSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.ClearCommand

Metodo CreateSparePartsDrawingClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.Enabled

Metodo CreateSparePartsDrawingEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.ExecuteCommand

Metodo CreateSparePartsDrawingExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Metodo CreateSparePartsDrawing.SetContext

Metodo CreateSparePartsDrawingSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe CreateSparePartsDrawing


Classe DedAcadArchiviaDwg
Archivia il documento corrente in una root specifica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadArchiviaDwg

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadArchiviaDwg : DedCommand
Public Class DedAcadArchiviaDwg
    Inherits DedCommand
public ref class DedAcadArchiviaDwg : public DedCommand
type DedAcadArchiviaDwg =
    class
        inherit DedCommand
    end

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadArchiviaDwg

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.AcadDoc

Proprietà DedAcadArchiviaDwgAcadDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

Tipo: QsDocument
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.AlsoSubParts

Proprietà DedAcadArchiviaDwgAlsoSubParts

Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.Data

Proprietà DedAcadArchiviaDwgData

Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.EnforceOverWriteMode

Proprietà DedAcadArchiviaDwgEnforceOverWriteMode

Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.InfoItem

Proprietà DedAcadArchiviaDwgInfoItem

Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
member InfoItem : DocStructInfo with get

Valore della proprietà

Tipo: DocStructInfo
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.IsSavePrt

Proprietà DedAcadArchiviaDwgIsSavePrt

Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.LinkNotCopy

Proprietà DedAcadArchiviaDwgLinkNotCopy

Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.NeedParameters

Proprietà DedAcadArchiviaDwgNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.PrimaryContext

Proprietà DedAcadArchiviaDwgPrimaryContext

Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.Prt

Proprietà DedAcadArchiviaDwgPrt

Restituisce la parte da associare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Proprietà DedAcadArchiviaDwg.UseDocValues

Proprietà DedAcadArchiviaDwgUseDocValues

Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodi di DedAcadArchiviaDwg

Il tipo DedAcadArchiviaDwg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.ClearCommand

Metodo DedAcadArchiviaDwgClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.Enabled

Metodo DedAcadArchiviaDwgEnabled

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.ExecuteCommand

Metodo DedAcadArchiviaDwgExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Metodo DedAcadArchiviaDwg.SetContext

Metodo DedAcadArchiviaDwgSetContext

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadArchiviaDwg


Classe DedAcadAssociaDwg
Associa il documento corrente ad un'anagrafica. Può lavorare anche come associa parte. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadAssociaDwg

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadAssociaDwg : DedCommand
Public Class DedAcadAssociaDwg
    Inherits DedCommand
public ref class DedAcadAssociaDwg : public DedCommand
type DedAcadAssociaDwg =
    class
        inherit DedCommand
    end

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadAssociaDwg

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Restituisce o imposta l'anagrafica nella quale importare il documento.
Proprietà pubblica | EnforceOverWriteMode | Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InfoItem | Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | LinkNotCopy | Restituisce o imposta se il documento debba essere collegato e non importato (false di default).
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | PrimaryContext | Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.
Proprietà pubblica | Prt | Restituisce la parte da associare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SparePartsContext | Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseDocValues | Imposta/restituisce se utilizzare gli attributi di documento.
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.AcadDoc

Proprietà DedAcadAssociaDwgAcadDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

Tipo: QsDocument
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.AlsoSubParts

Proprietà DedAcadAssociaDwgAlsoSubParts

Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nell'associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.Data

Proprietà DedAcadAssociaDwgData

Restituisce o imposta l'anagrafica nella quale importare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.EnforceOverWriteMode

Proprietà DedAcadAssociaDwgEnforceOverWriteMode

Imposta/Restituisce se è nel caso sovrascrivere o creare una rappresentazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnforceOverWriteMode { get; set; }
Public Property EnforceOverWriteMode As Boolean
    Get
    Set
public:
property bool EnforceOverWriteMode {
    bool get ();
    void set (bool value);
}
member EnforceOverWriteMode : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.InfoItem

Proprietà DedAcadAssociaDwgInfoItem

Restituisce le informazioni del file correntemente attivo oppure del file vuoto nel caso di associa parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocStructInfo InfoItem { get; }
Public ReadOnly Property InfoItem As DocStructInfo
    Get
public:
property DocStructInfo^ InfoItem {
    DocStructInfo^ get ();
}
member InfoItem : DocStructInfo with get

Valore della proprietà

Tipo: DocStructInfo
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.IsSavePrt

Proprietà DedAcadAssociaDwgIsSavePrt

Restituisce o imposta se sia da eseguire l'associa parte e non l'associa documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.LinkNotCopy

Proprietà DedAcadAssociaDwgLinkNotCopy

Restituisce o imposta se il documento debba essere collegato e non importato (false di default).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LinkNotCopy { get; set; }
Public Property LinkNotCopy As Boolean
    Get
    Set
public:
property bool LinkNotCopy {
    bool get ();
    void set (bool value);
}
member LinkNotCopy : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.NeedParameters

Proprietà DedAcadAssociaDwgNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.PrimaryContext

Proprietà DedAcadAssociaDwgPrimaryContext

Restituisce o imposta il contesto con il quale importare i documenti. Di default è true ed i documenti vengono importati come primari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool PrimaryContext { get; set; }
Public Property PrimaryContext As Boolean
    Get
    Set
public:
property bool PrimaryContext {
    bool get ();
    void set (bool value);
}
member PrimaryContext : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.Prt

Proprietà DedAcadAssociaDwgPrt

Restituisce la parte da associare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; set; }
Public Property Prt As PartInfo
    Get
    Set
public:
property PartInfo^ Prt {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member Prt : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.SparePartsContext

Proprietà DedAcadAssociaDwgSparePartsContext

Indica se importare il documento associandolo all'anagrafica con contesto 'PubblicazioneRicambio' o 'TavolaRicambio'.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum SparePartsContext { get; set; }
Public Property SparePartsContext As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum SparePartsContext {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member SparePartsContext : DedDocContextEnum with get, set

Valore della proprietà

Tipo: DedDocContextEnum
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Proprietà DedAcadAssociaDwg.UseDocValues

Proprietà DedAcadAssociaDwgUseDocValues

Imposta/restituisce se utilizzare gli attributi di documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UseDocValues { get; set; }
Public Property UseDocValues As Boolean
    Get
    Set
public:
property bool UseDocValues {
    bool get ();
    void set (bool value);
}
member UseDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodi di DedAcadAssociaDwg

Il tipo DedAcadAssociaDwg espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.ClearCommand

Metodo DedAcadAssociaDwgClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.Enabled

Metodo DedAcadAssociaDwgEnabled

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.ExecuteCommand

Metodo DedAcadAssociaDwgExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Metodo DedAcadAssociaDwg.SetContext

Metodo DedAcadAssociaDwgSetContext

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadAssociaDwg


Classe DedAcadChangeState
Comando che effettua il rilascio dell'anagrafica associata
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadChangeState

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadChangeState : DedCommand
Public Class DedAcadChangeState
    Inherits DedCommand
public ref class DedAcadChangeState : public DedCommand
type DedAcadChangeState =
    class
        inherit DedCommand
    end

Il tipo DedAcadChangeState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non i parametri non sono sufficienti (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | MultipleChangeState | Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | SingleChangeState |
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadChangeState

Il tipo DedAcadChangeState espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non i parametri non sono sufficienti (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadChangeState


Proprietà DedAcadChangeState.NeedParameters

Proprietà DedAcadChangeStateNeedParameters

Restituisce true se non i parametri non sono sufficienti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodi di DedAcadChangeState

Il tipo DedAcadChangeState espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di associazione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | MultipleChangeState | Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | SingleChangeState |
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.ClearCommand

Metodo DedAcadChangeStateClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.Enabled

Metodo DedAcadChangeStateEnabled

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.ExecuteCommand

Metodo DedAcadChangeStateExecuteCommand

Esegue il comando di associazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.MultipleChangeState

Metodo DedAcadChangeStateMultipleChangeState

Operazione di rilascio multiplo. Visualizza il form di selezione dei codici e quindi esegue ciclicamente le operazioni.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult MultipleChangeState(
    AcadDocStructInfo acadDsInfo
)
Public Function MultipleChangeState (
    acadDsInfo As AcadDocStructInfo
) As DedCmdResult
public:
DedCmdResult MultipleChangeState(
    AcadDocStructInfo^ acadDsInfo
)
member MultipleChangeState :
        acadDsInfo : AcadDocStructInfo -> DedCmdResult

Parametri

acadDsInfo
Tipo: DedNetAcadAcadDocStructInfo
DocStructInfo di Inventor di partenza. Rappresenta il topDocument in questo caso.

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.SetContext

Metodo DedAcadChangeStateSetContext

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadChangeState


Metodo DedAcadChangeState.SingleChangeState

Metodo DedAcadChangeStateSingleChangeState

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult SingleChangeState(
    DedState targetState,
    string changeNote,
    MultipleStateOperationPartInfoDoc docInfo,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Function SingleChangeState (
    targetState As DedState,
    changeNote As String,
    docInfo As MultipleStateOperationPartInfoDoc,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public:
DedCmdResult SingleChangeState(
    DedState^ targetState,
    String^ changeNote,
    MultipleStateOperationPartInfoDoc^ docInfo,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
member SingleChangeState :
        targetState : DedState *
        changeNote : string *
        docInfo : MultipleStateOperationPartInfoDoc *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState
Tipo: DedState
changeNote
Tipo: SystemString
docInfo
Tipo: DedNetAcad.FormsMultipleStateOperationPartInfoDoc
multiplo
Tipo: SystemBoolean
message
Tipo: SystemString
pubExtList
Tipo: System.Collections.GenericList Exception

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadChangeState


Classe DedAcadCreaAnagrafica
Effettua il salvataggio del documento corrente o della parte selezionata nel Database con un nuovo codice. Da utilizzare anche nelle procedure personalizzate. Per personalizzare la creazione dell'anagrafica, impostare nella proprietà SaveCommand un comando inizializzato con già tutte le informazioni preimpostate. Diversamente il comando sarà inizializzato in base agli attributi del documento corrente.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadCreaAnagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadCreaAnagrafica : DedCommand
Public Class DedAcadCreaAnagrafica
    Inherits DedCommand
public ref class DedAcadCreaAnagrafica : public DedCommand
type DedAcadCreaAnagrafica =
    class
        inherit DedCommand
    end

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da salvare nel Database.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | ExecuteCommand | Esegue il comando di salvataggio del documento nel Database. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadCreaAnagrafica

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento correntemente attivo.
Proprietà pubblica | AlsoSubParts | Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Asynch | Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | CreazioneVariante | Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | IsSavePrt | Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da salvare nel Database.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | SaveCommand | Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.AcadDoc

Proprietà DedAcadCreaAnagraficaAcadDoc

Restitusice il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

Tipo: QsDocument
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.AlsoSubParts

Proprietà DedAcadCreaAnagraficaAlsoSubParts

Restitusice o imposta se salvare anche le sotto-parti della parte in salvataggio (di default è true). Viene utilizzato solo nel salva parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlsoSubParts { get; set; }
Public Property AlsoSubParts As Boolean
    Get
    Set
public:
property bool AlsoSubParts {
    bool get ();
    void set (bool value);
}
member AlsoSubParts : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.Asynch

Proprietà DedAcadCreaAnagraficaAsynch

Restituisce o imposta se il salva parte debba essere eseguito in modo asincrono, inviando alla riga di comando di autocad la stringa di comando. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Asynch { get; set; }
Public Property Asynch As Boolean
    Get
    Set
public:
property bool Asynch {
    bool get ();
    void set (bool value);
}
member Asynch : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.CreazioneVariante

Proprietà DedAcadCreaAnagraficaCreazioneVariante

Restituisce se il comando sia utilizzato per creare la variante di un codice. Se non viene passato il comando da utilizzare per il salva, e questa proprietà è impostata a true, viene creato un comando di creazione variante al posto di un comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreazioneVariante { get; set; }
Public Property CreazioneVariante As Boolean
    Get
    Set
public:
property bool CreazioneVariante {
    bool get ();
    void set (bool value);
}
member CreazioneVariante : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.IsSavePrt

Proprietà DedAcadCreaAnagraficaIsSavePrt

Restituisce o imposta se sia da eseguire il salva parte e non il salva documento. Di default è false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSavePrt { get; set; }
Public Property IsSavePrt As Boolean
    Get
    Set
public:
property bool IsSavePrt {
    bool get ();
    void set (bool value);
}
member IsSavePrt : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.NeedParameters

Proprietà DedAcadCreaAnagraficaNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.Prt

Proprietà DedAcadCreaAnagraficaPrt

Restituisce la parte Top del documento attivo che è da salvare nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; }
Public ReadOnly Property Prt As PartInfo
    Get
public:
property PartInfo^ Prt {
    PartInfo^ get ();
}
member Prt : PartInfo with get

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Proprietà DedAcadCreaAnagrafica.SaveCommand

Proprietà DedAcadCreaAnagraficaSaveCommand

Restituisce o imposta il comando da utilizzare per la creazione dell'anagrafica. Da utilizzare per personalizzare il salvataggio, altrimenti viene inizializzato con i dati presenti nel documento corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public SaveCommand SaveCommand { get; set; }
Public Property SaveCommand As SaveCommand
    Get
    Set
public:
property SaveCommand^ SaveCommand {
    SaveCommand^ get ();
    void set (SaveCommand^ value);
}
member SaveCommand : SaveCommand with get, set

Valore della proprietà

Tipo: SaveCommand
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodi di DedAcadCreaAnagrafica

Il tipo DedAcadCreaAnagrafica espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Sovrascrive DedCommand.Equals(Object).)
Metodo protetto | ExecuteCommand | Esegue il comando di salvataggio del documento nel Database. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Sovrascrive DedCommand.GetHashCode.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Sovrascrive DedCommand.ToString.)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ClearCommand

Metodo DedAcadCreaAnagraficaClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.Enabled

Metodo DedAcadCreaAnagraficaEnabled

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.Equals

Metodo DedAcadCreaAnagraficaEquals

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ExecuteCommand

Metodo DedAcadCreaAnagraficaExecuteCommand

Esegue il comando di salvataggio del documento nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.GetHashCode

Metodo DedAcadCreaAnagraficaGetHashCode

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.SetContext

Metodo DedAcadCreaAnagraficaSetContext

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Metodo DedAcadCreaAnagrafica.ToString

Metodo DedAcadCreaAnagraficaToString

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe DedAcadCreaAnagrafica


Classe DedAcadCreaRev
Effettua il Salva Revisione del documento attivo. Da utilizzare anche nelle procedure personalizzate.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadCreaRev

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadCreaRev : DedCommand
Public Class DedAcadCreaRev
    Inherits DedCommand
public ref class DedAcadCreaRev : public DedCommand
type DedAcadCreaRev =
    class
        inherit DedCommand
    end

Il tipo DedAcadCreaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento appena salvato.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | CurDoc | Restituisce il documento di partenza in salvataggio.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file correntemente attivo e da Revisionare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NewDoc | Restituisce il documento associato alla nuova revisione.
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da Revisionare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di salva revisione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadCreaRev

Il tipo DedAcadCreaRev espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcadDoc | Restitusice il documento appena salvato.
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | CurData | Restituisce l'anagrafica di partenza del documento in salvataggio.
Proprietà pubblica | CurDoc | Restituisce il documento di partenza in salvataggio.
Proprietà pubblica | FullFileName | Restituisce il nome completo del file correntemente attivo e da Revisionare.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se non ha a disposizione una parte da salvare. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NewData | Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.
Proprietà pubblica | NewDoc | Restituisce il documento associato alla nuova revisione.
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Prt | Restituisce la parte Top del documento attivo che è da Revisionare.
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.AcadDoc

Proprietà DedAcadCreaRevAcadDoc

Restitusice il documento appena salvato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument AcadDoc { get; }
Public ReadOnly Property AcadDoc As QsDocument
    Get
public:
property QsDocument^ AcadDoc {
    QsDocument^ get ();
}
member AcadDoc : QsDocument with get

Valore della proprietà

Tipo: QsDocument
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.CurData

Proprietà DedAcadCreaRevCurData

Restituisce l'anagrafica di partenza del documento in salvataggio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData CurData { get; }
Public ReadOnly Property CurData As DedData
    Get
public:
property DedData^ CurData {
    DedData^ get ();
}
member CurData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.CurDoc

Proprietà DedAcadCreaRevCurDoc

Restituisce il documento di partenza in salvataggio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc CurDoc { get; }
Public ReadOnly Property CurDoc As DedDoc
    Get
public:
property DedDoc^ CurDoc {
    DedDoc^ get ();
}
member CurDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.FullFileName

Proprietà DedAcadCreaRevFullFileName

Restituisce il nome completo del file correntemente attivo e da Revisionare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NeedParameters

Proprietà DedAcadCreaRevNeedParameters

Restituisce true se non ha a disposizione una parte da salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NewData

Proprietà DedAcadCreaRevNewData

Restituisce l'anagrafica della nuova revisione creata nel salvatagio. E' diversa da null solo dopo l'esecuzione del comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData NewData { get; }
Public ReadOnly Property NewData As DedData
    Get
public:
property DedData^ NewData {
    DedData^ get ();
}
member NewData : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.NewDoc

Proprietà DedAcadCreaRevNewDoc

Restituisce il documento associato alla nuova revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc NewDoc { get; }
Public ReadOnly Property NewDoc As DedDoc
    Get
public:
property DedDoc^ NewDoc {
    DedDoc^ get ();
}
member NewDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe DedAcadCreaRev


Proprietà DedAcadCreaRev.Prt

Proprietà DedAcadCreaRevPrt

Restituisce la parte Top del documento attivo che è da Revisionare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Prt { get; }
Public ReadOnly Property Prt As PartInfo
    Get
public:
property PartInfo^ Prt {
    PartInfo^ get ();
}
member Prt : PartInfo with get

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodi di DedAcadCreaRev

Il tipo DedAcadCreaRev espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulisce il comando re-inizializzandolo. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando di salva revisione. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Non è un comando da aggiungere all'iterfaccia (restituisce sempre false). (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.ClearCommand

Metodo DedAcadCreaRevClearCommand

Pulisce il comando re-inizializzandolo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.Enabled

Metodo DedAcadCreaRevEnabled

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.ExecuteCommand

Metodo DedAcadCreaRevExecuteCommand

Esegue il comando di salva revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadCreaRev


Metodo DedAcadCreaRev.SetContext

Metodo DedAcadCreaRevSetContext

Non è un comando da aggiungere all'iterfaccia (restituisce sempre false).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadCreaRev


Classe DedAcadForceMarkerAlingment
Comando che permette di forzare la allineamento del documento con quella presente nel Database.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadForceMarkerAlingment

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadForceMarkerAlingment : DedCommand
Public Class DedAcadForceMarkerAlingment
    Inherits DedCommand
public ref class DedAcadForceMarkerAlingment : public DedCommand
type DedAcadForceMarkerAlingment =
    class
        inherit DedCommand
    end

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadForceMarkerAlingment

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Proprietà DedAcadForceMarkerAlingment.NeedParameters

Proprietà DedAcadForceMarkerAlingmentNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodi di DedAcadForceMarkerAlingment

Il tipo DedAcadForceMarkerAlingment espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.ClearCommand

Metodo DedAcadForceMarkerAlingmentClearCommand

Pulizia del comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.Enabled

Metodo DedAcadForceMarkerAlingmentEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext invCmdCtx
)
Public Overrides Function Enabled (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ invCmdCtx
) override
abstract Enabled :
        invCmdCtx : DedCommandContext -> bool
override Enabled :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.ExecuteCommand

Metodo DedAcadForceMarkerAlingmentExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Metodo DedAcadForceMarkerAlingment.SetContext

Metodo DedAcadForceMarkerAlingmentSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext invCmdCtx
)
Public Overrides Function SetContext (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ invCmdCtx
) override
abstract SetContext :
        invCmdCtx : DedCommandContext -> bool
override SetContext :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadForceMarkerAlingment


Classe DedAcadMarkerInfo
Comando che permette di controllare lo stato di allineamento del documento.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadDedAcadMarkerInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadMarkerInfo : DedCommand
Public Class DedAcadMarkerInfo
    Inherits DedCommand
public ref class DedAcadMarkerInfo : public DedCommand
type DedAcadMarkerInfo =
    class
        inherit DedCommand
    end

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedAcadMarkerInfo

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce se il comando necessiti o meno di ulteriori parametri. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Proprietà DedAcadMarkerInfo.NeedParameters

Proprietà DedAcadMarkerInfoNeedParameters

Restituisce se il comando necessiti o meno di ulteriori parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodi di DedAcadMarkerInfo

Il tipo DedAcadMarkerInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia del comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Verifica l'abilitazione del comando in base alla lista documenti impostata. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Lancia il comando di salva nel db. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Imposta il comando in base alla selezione. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.ClearCommand

Metodo DedAcadMarkerInfoClearCommand

Pulizia del comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.Enabled

Metodo DedAcadMarkerInfoEnabled

Verifica l'abilitazione del comando in base alla lista documenti impostata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext invCmdCtx
)
Public Overrides Function Enabled (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ invCmdCtx
) override
abstract Enabled :
        invCmdCtx : DedCommandContext -> bool
override Enabled :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.ExecuteCommand

Metodo DedAcadMarkerInfoExecuteCommand

Lancia il comando di salva nel db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Metodo DedAcadMarkerInfo.SetContext

Metodo DedAcadMarkerInfoSetContext

Imposta il comando in base alla selezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext invCmdCtx
)
Public Overrides Function SetContext (
    invCmdCtx As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ invCmdCtx
) override
abstract SetContext :
        invCmdCtx : DedCommandContext -> bool
override SetContext :
        invCmdCtx : DedCommandContext -> bool

Parametri

invCmdCtx
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedAcadMarkerInfo


Classe DedApiAcad
NOTA : Da Lua usare DEDACADAPI per accedere ai metodi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedApiAcad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedApiAcad
Public Class DedApiAcad
public ref class DedApiAcad
type DedApiAcad =  class end

Il tipo DedApiAcad espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApiAcad |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRuleOnPrt | Applica le regole di autocomposizione sulla parte passata.
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | CheckOldRevisions | Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.
Metodo pubblico | DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedApiAcad

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedApiAcad(
    DedNetApplication app,
    DedLuaApplication luaApp
)
Public Sub New (
    app As DedNetApplication,
    luaApp As DedLuaApplication
)
public:
DedApiAcad(
    DedNetApplication^ app,
    DedLuaApplication^ luaApp
)
new :
        app : DedNetApplication *
        luaApp : DedLuaApplication -> DedApiAcad

Parametri

app
Tipo: DedNetApplication
luaApp
Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedApiAcad


Proprietà di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Proprietà DedApiAcad.LastException

Proprietà DedApiAcadLastException

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Tipo: Exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodi di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ApplyRuleOnPrt | Applica le regole di autocomposizione sulla parte passata.
Metodo pubblico | AssociaDoc | Associa documento. Riceve in ingresso una table di parametri.
Metodo pubblico | CheckOldRevisions | Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.
Metodo pubblico | DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
Metodo pubblico | Rilascia | Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando
Metodo pubblico | SalvaNelDb | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | ShowLastException |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.ApplyRuleOnPrt

Metodo DedApiAcadApplyRuleOnPrt

Applica le regole di autocomposizione sulla parte passata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ApplyRuleOnPrt(
    PartInfo prt
)
Public Sub ApplyRuleOnPrt (
    prt As PartInfo
)
public:
void ApplyRuleOnPrt(
    PartInfo^ prt
)
member ApplyRuleOnPrt :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte sulla quale applicare le regole.
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.AssociaDoc

Metodo DedApiAcadAssociaDoc

Associa documento. Riceve in ingresso una table di parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AssociaDoc(
    LuaTable args
)
Public Function AssociaDoc (
    args As LuaTable
) As Boolean
public:
bool AssociaDoc(
    LuaTable^ args
)
member AssociaDoc :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
id : id anagrafica (obbligatorio) rev : revisione dell'anagrafica (obbligatorio) silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil enforceOverwriteMode : indica se deve essere sovrascritto o creare una rappresentazione - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Tipo: Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.CheckOldRevisions

Metodo DedApiAcadCheckOldRevisions

Esegue il controllo delle revisioni superate. Permette di controllare gli stati di visibilità del comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CheckOldRevisions(
    LuaTable args
)
Public Function CheckOldRevisions (
    args As LuaTable
) As Boolean
public:
bool CheckOldRevisions(
    LuaTable^ args
)
member CheckOldRevisions :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
Argomenti del Rilascio

Valore di ritorno

Tipo: Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.DedDistSave

Metodo DedApiAcadDedDistSave

Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DedDistSave(
    LuaTable args
)
Public Function DedDistSave (
    args As LuaTable
) As Boolean
public:
bool DedDistSave(
    LuaTable^ args
)
member DedDistSave :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
Argomenti del salva distinta "silent"

Valore di ritorno

Tipo: Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.Rilascia

Metodo DedApiAcadRilascia

Esegue il rilascio dell'anagrafica utilizzando il documento corrente come fosse lanciata dal comando

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Rilascia(
    LuaTable args
)
Public Function Rilascia (
    args As LuaTable
) As Boolean
public:
bool Rilascia(
    LuaTable^ args
)
member Rilascia :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
Argomenti del Rilascio

Valore di ritorno

Tipo: Boolean
Ritorna true se riesce altrimenti false ed imposta il last exception
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.SalvaNelDb

Metodo DedApiAcadSalvaNelDb

Creazione dell'anagrafica. Riceve in ingresso una table di parametri.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool SalvaNelDb(
    LuaTable args
)
Public Function SalvaNelDb (
    args As LuaTable
) As Boolean
public:
bool SalvaNelDb(
    LuaTable^ args
)
member SalvaNelDb :
        args : LuaTable -> bool

Parametri

args
Tipo: LuaTable
dbpath : path di salvataggio dell'anagrafica (obbligatorio) progr : progressivo (obbligatorio) rev : revisione dell'anagrafica infoUser : eventuale tassello utente format : informazione sul formato silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil useDocValues : indica se nell'associa usare gli attributi di documento 1/nil attrs : LuaTable contenente prompt e valori degli attributi da preimpostare nell'anagrafica in creazione validateAttrs : indica se validare gli attributi 1/nil forcedata : Indica se utilizzare gli attributi passati invece di calcolarli - 1/nil primaryContext : indica se deve essere associato come file primario - 1/nil savePrt : indica se è un salva parte - 1/nil

Valore di ritorno

Tipo: Boolean
Restituisce true se riesce altimenti false
Vedi anche

Documentazione

Classe DedApiAcad


Metodo DedApiAcad.ShowLastException

Metodo DedApiAcadShowLastException

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowLastException()
Public Sub ShowLastException
public:
void ShowLastException()
member ShowLastException : unit -> unit
Vedi anche

Documentazione

Classe DedApiAcad


Campi di DedApiAcad

Il tipo DedApiAcad espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _app |
Campo pubblico | _luaApp |
Torna su
Vedi anche

Documentazione

Classe DedApiAcad


Campo DedApiAcad._app

Campo DedApiAcad_app

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedApiAcad


Campo DedApiAcad._luaApp

Campo DedApiAcad_luaApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication _luaApp
Public _luaApp As DedLuaApplication
public:
DedLuaApplication^ _luaApp
val mutable _luaApp: DedLuaApplication

Valore del campo

Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedApiAcad


Classe DedNetAcadApp
Classe principale dell'add-in per Autocad di DedNet. Viene pubblicata l'istanza di questo oggetto attraverso la variabile globale LUA DEDACAD.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetAcadApp
Public Class DedNetAcadApp
public ref class DedNetAcadApp
type DedNetAcadApp =  class end

Il tipo DedNetAcadApp espone i seguenti membri.

Proprietà
Nome | Descrizione
AssemblyAcadPath | Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.
CheckInChiusuraRunning |
ComApp |
CommandRunFromLua | Indica se il comando è stato lanciato da lua.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreCheckInOnClose |
IsDedAcadOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsMechanicalLoaded | Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )
IsProgramaticalQsaveRunning |
IsSDIOperation | Restituisce true se la variabile SDI è impostata a 1.
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
NavigatorArgsArray | Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().
NavigatorArgsLastRev | Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().
NavigatorArgsReadOnly | Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().
Ricerca | Restituisce il comando per effettuare la ricerca.
RicercaDocs | Restituisce il comando per effettuare la ricerca.
SalvaNelDbRunning |
VisAnagr | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
Torna su
Metodi
 | Nome | Descrizione
 | AggiornaAttributiDaDb | Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.
 | CaricaParteDaDb | Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.
 | CheckMechanicalLoaded |
 | CreateArchiviaDwg | Crea e restituisce il comando Associa documento.
 | CreateAssociaDwg | Crea e restituisce il comando Associa documento.
 | CreateCaricaBlocco | Crea e restituisce il comando di carica blocco.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteEsterno | Crea e restituisce il comando di carica blocco.
 | CreateCaricaXref | Crea e restituisce il comando di carica xref.
 | CreateChangeState | Crea e restituisce il comando di rilascio
 | CreateCheckIn | Crea e restituisce il comando di CheckIn per il documento correntemente attivo.
 | CreateCheckOut | Crea e restituisce il comando di CheckOut per il documento correntemente attivo.
 | CreateCompilaParteDaAnagrafica | Crea e restituisce il comando di compila parte da anagrafica.
 | CreateCreaAnagrafica | Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.
 | CreateCreaRev | Crea e restituisce il comando di creazione revisione.
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di carica parte.
 | CreateCreaVariante | Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.
 | CreateForceMarkerAlignment | Crea e restituisce il comando di rilascio
 | CreateMarkerInfo | Crea e restituisce il comando di rilascio
 | CreatePackAngGoExport | Crea e restituisce il comando di creazione revisione.
 | CreatePackAngGoImport | Crea e restituisce il comando di creazione revisione.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | EditaAttributi | Lancia l'edita attributi sulla parte o sulle parti passate. Se è readOnly viene aperta la finestra non modale, altrimenti quella modale.
 | FindOpenDocument | Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.
 | IndividuaNellaRicerca | Apre la ricerca nei recenti individuando l'anagrafica di una parte.
Metodo pubblico | Initialize | Inizializzazione dell'add-in.
 | Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | LogInfo | Registra l'eccezione nel file di log dell'applicazione.
 | OnAcadRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
 | OnFileResolutionEvent | Lancia l'evento di FileResolutionEvent
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
Metodo pubblico | OnTopPrtCreated | Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.
 | OnUpdateAttribFromDbOnOpenEvent | Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.
 | OnUpdateCartOnOpenEvent | Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.
 | PostNavigatorArgs | Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.
 | StatoDocAcad | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | Terminate | Termine dell'add-in.
Metodo pubblico | TopPrtActivated | Chiamato su attivazione di una parte, per aggiornare la finestra di visualizzazione attributi.
Torna su
Eventi
Nome | Descrizione
AcadRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
FileResolutionEvent | Evento di risoluzione file nel caso non vengano trovati.
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
UpdateAttribFromDbOnOpenEvent | Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.
UpdateCartOnOpenEvent | Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.
Torna su
Campi
Nome | Descrizione
DedNetAcadDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DedNetAcadDocRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Proprietà
Nome | Descrizione
AssemblyAcadPath | Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.
CheckInChiusuraRunning |
ComApp |
CommandRunFromLua | Indica se il comando è stato lanciato da lua.
DedNetApp | Restituisce l'applicazione DedNetApplication sottostante.
DedNetInstallPath | Restituisce il percorso di installazione del DedNet.
HideCompareDialogOnSavingDwg | Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.
HideWarningMessageOnModDocCheckout | Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.
IgnoreCheckInOnClose |
IsDedAcadOpenDocRunning | Indica se è in esecuzione il comando di apertura documenti di Inventor.
IsMechanicalLoaded | Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )
IsProgramaticalQsaveRunning |
IsSDIOperation | Restituisce true se la variabile SDI è impostata a 1.
LuaApp | Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.
NavigatorArgsArray | Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().
NavigatorArgsLastRev | Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().
NavigatorArgsReadOnly | Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().
Ricerca | Restituisce il comando per effettuare la ricerca.
RicercaDocs | Restituisce il comando per effettuare la ricerca.
SalvaNelDbRunning |
VisAnagr | Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.
Xmx | Restitusice l'oggetto per la traduzione dei messaggi.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.AssemblyAcadPath

Proprietà DedNetAcadAppAssemblyAcadPath

Restituisce il percorso della cartella DED nella quale si trova l'assembly. Es.: C:\Programmi\QS_Informatica\QSMech15_A2012\DED.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string AssemblyAcadPath { get; }
Public Shared ReadOnly Property AssemblyAcadPath As String
    Get
public:
static property String^ AssemblyAcadPath {
    String^ get ();
}
static member AssemblyAcadPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.CheckInChiusuraRunning

Proprietà DedNetAcadAppCheckInChiusuraRunning

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CheckInChiusuraRunning { get; set; }
Public Shared Property CheckInChiusuraRunning As Boolean
    Get
    Set
public:
static property bool CheckInChiusuraRunning {
    bool get ();
    void set (bool value);
}
static member CheckInChiusuraRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.ComApp

Proprietà DedNetAcadAppComApp

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static AcadApplication ComApp { get; }
Public Shared ReadOnly Property ComApp As AcadApplication
    Get
public:
static property AcadApplication^ ComApp {
    AcadApplication^ get ();
}
static member ComApp : AcadApplication with get

Valore della proprietà

Tipo: AcadApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.CommandRunFromLua

Proprietà DedNetAcadAppCommandRunFromLua

Indica se il comando è stato lanciato da lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool CommandRunFromLua { get; set; }
Public Shared Property CommandRunFromLua As Boolean
    Get
    Set
public:
static property bool CommandRunFromLua {
    bool get ();
    void set (bool value);
}
static member CommandRunFromLua : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.DedNetApp

Proprietà DedNetAcadAppDedNetApp

Restituisce l'applicazione DedNetApplication sottostante.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication DedNetApp { get; }
Public Shared ReadOnly Property DedNetApp As DedNetApplication
    Get
public:
static property DedNetApplication^ DedNetApp {
    DedNetApplication^ get ();
}
static member DedNetApp : DedNetApplication with get

Valore della proprietà

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.DedNetInstallPath

Proprietà DedNetAcadAppDedNetInstallPath

Restituisce il percorso di installazione del DedNet.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string DedNetInstallPath { get; }
Public Shared ReadOnly Property DedNetInstallPath As String
    Get
public:
static property String^ DedNetInstallPath {
    String^ get ();
}
static member DedNetInstallPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.HideCompareDialogOnSavingDwg

Proprietà DedNetAcadAppHideCompareDialogOnSavingDwg

Restituisce o imposta se nascondere la finestra di comparazione attributi in fase di salvataggio. Di default è false. Impostandola a true i documenti in salvataggio che non sono allineati con l'anagrafica, non produrranno l'aggiornamento di quest'ultima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HideCompareDialogOnSavingDwg { get; set; }
Public Shared Property HideCompareDialogOnSavingDwg As Boolean
    Get
    Set
public:
static property bool HideCompareDialogOnSavingDwg {
    bool get ();
    void set (bool value);
}
static member HideCompareDialogOnSavingDwg : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.HideWarningMessageOnModDocCheckout

Proprietà DedNetAcadAppHideWarningMessageOnModDocCheckout

Restituisce o imposta se nascondere la finestra che chiede all'utente di mettere in check-out il documento nel caso di area locale attiva ed il documento non sia in check-out dall'utente. La richiesta viene effettuata alla fine di ogni comando che rende dirty il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool HideWarningMessageOnModDocCheckout { get; set; }
Public Shared Property HideWarningMessageOnModDocCheckout As Boolean
    Get
    Set
public:
static property bool HideWarningMessageOnModDocCheckout {
    bool get ();
    void set (bool value);
}
static member HideWarningMessageOnModDocCheckout : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IgnoreCheckInOnClose

Proprietà DedNetAcadAppIgnoreCheckInOnClose

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IgnoreCheckInOnClose { get; set; }
Public Shared Property IgnoreCheckInOnClose As Boolean
    Get
    Set
public:
static property bool IgnoreCheckInOnClose {
    bool get ();
    void set (bool value);
}
static member IgnoreCheckInOnClose : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsDedAcadOpenDocRunning

Proprietà DedNetAcadAppIsDedAcadOpenDocRunning

Indica se è in esecuzione il comando di apertura documenti di Inventor.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsDedAcadOpenDocRunning { get; set; }
Public Shared Property IsDedAcadOpenDocRunning As Boolean
    Get
    Set
public:
static property bool IsDedAcadOpenDocRunning {
    bool get ();
    void set (bool value);
}
static member IsDedAcadOpenDocRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsMechanicalLoaded

Proprietà DedNetAcadAppIsMechanicalLoaded

Indica se è caricato il mechanical ( viene valutato all'avvio di Autocad )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsMechanicalLoaded { get; }
Public Shared ReadOnly Property IsMechanicalLoaded As Boolean
    Get
public:
static property bool IsMechanicalLoaded {
    bool get ();
}
static member IsMechanicalLoaded : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsProgramaticalQsaveRunning

Proprietà DedNetAcadAppIsProgramaticalQsaveRunning

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsProgramaticalQsaveRunning { get; set; }
Public Shared Property IsProgramaticalQsaveRunning As Boolean
    Get
    Set
public:
static property bool IsProgramaticalQsaveRunning {
    bool get ();
    void set (bool value);
}
static member IsProgramaticalQsaveRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.IsSDIOperation

Proprietà DedNetAcadAppIsSDIOperation

Restituisce true se la variabile SDI è impostata a 1.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsSDIOperation { get; }
Public Shared ReadOnly Property IsSDIOperation As Boolean
    Get
public:
static property bool IsSDIOperation {
    bool get ();
}
static member IsSDIOperation : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.LuaApp

Proprietà DedNetAcadAppLuaApp

Restituisce l'applicazione lua, wrapper dell'oggetto DedNetApplication.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedLuaApplication LuaApp { get; }
Public Shared ReadOnly Property LuaApp As DedLuaApplication
    Get
public:
static property DedLuaApplication^ LuaApp {
    DedLuaApplication^ get ();
}
static member LuaApp : DedLuaApplication with get

Valore della proprietà

Tipo: DedLuaApplication
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsArray

Proprietà DedNetAcadAppNavigatorArgsArray

Restituisce l'array di parti sulle quali il comando ApriDwgDaDb deve lavorare. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray NavigatorArgsArray { get; }
Public Shared ReadOnly Property NavigatorArgsArray As PartInfoArray
    Get
public:
static property PartInfoArray^ NavigatorArgsArray {
    PartInfoArray^ get ();
}
static member NavigatorArgsArray : PartInfoArray with get

Valore della proprietà

Tipo: PartInfoArray
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsLastRev

Proprietà DedNetAcadAppNavigatorArgsLastRev

Restituisce se il comando ApriDwgDaDb debba aprire l'ultima revisione. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool NavigatorArgsLastRev { get; }
Public Shared ReadOnly Property NavigatorArgsLastRev As Boolean
    Get
public:
static property bool NavigatorArgsLastRev {
    bool get ();
}
static member NavigatorArgsLastRev : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.NavigatorArgsReadOnly

Proprietà DedNetAcadAppNavigatorArgsReadOnly

Restituisce se il comando ApriDwgDaDb debba aprire in read-only. Vedi PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool NavigatorArgsReadOnly { get; }
Public Shared ReadOnly Property NavigatorArgsReadOnly As Boolean
    Get
public:
static property bool NavigatorArgsReadOnly {
    bool get ();
}
static member NavigatorArgsReadOnly : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.Ricerca

Proprietà DedNetAcadAppRicerca

Restituisce il comando per effettuare la ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindCommand Ricerca { get; }
Public Shared ReadOnly Property Ricerca As FindCommand
    Get
public:
static property FindCommand^ Ricerca {
    FindCommand^ get ();
}
static member Ricerca : FindCommand with get

Valore della proprietà

Tipo: FindCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.RicercaDocs

Proprietà DedNetAcadAppRicercaDocs

Restituisce il comando per effettuare la ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static FindDocCommand RicercaDocs { get; }
Public Shared ReadOnly Property RicercaDocs As FindDocCommand
    Get
public:
static property FindDocCommand^ RicercaDocs {
    FindDocCommand^ get ();
}
static member RicercaDocs : FindDocCommand with get

Valore della proprietà

Tipo: FindDocCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.SalvaNelDbRunning

Proprietà DedNetAcadAppSalvaNelDbRunning

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SalvaNelDbRunning { get; set; }
Public Shared Property SalvaNelDbRunning As Boolean
    Get
    Set
public:
static property bool SalvaNelDbRunning {
    bool get ();
    void set (bool value);
}
static member SalvaNelDbRunning : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.VisAnagr

Proprietà DedNetAcadAppVisAnagr

Restituisce il comando di visualizzazione attributi utilizzato dall'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static ShowAnagrCommand VisAnagr { get; }
Public Shared ReadOnly Property VisAnagr As ShowAnagrCommand
    Get
public:
static property ShowAnagrCommand^ VisAnagr {
    ShowAnagrCommand^ get ();
}
static member VisAnagr : ShowAnagrCommand with get

Valore della proprietà

Tipo: ShowAnagrCommand
Vedi anche

Documentazione

Classe DedNetAcadApp


Proprietà DedNetAcadApp.Xmx

Proprietà DedNetAcadAppXmx

Restitusice l'oggetto per la traduzione dei messaggi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static XMX Xmx { get; }
Public Shared ReadOnly Property Xmx As XMX
    Get
public:
static property XMX^ Xmx {
    XMX^ get ();
}
static member Xmx : XMX with get

Valore della proprietà

Tipo: XMX
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Metodi
 | Nome | Descrizione
 | AggiornaAttributiDaDb | Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.
 | CaricaParteDaDb | Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.
 | CheckMechanicalLoaded |
 | CreateArchiviaDwg | Crea e restituisce il comando Associa documento.
 | CreateAssociaDwg | Crea e restituisce il comando Associa documento.
 | CreateCaricaBlocco | Crea e restituisce il comando di carica blocco.
 | CreateCaricaParte | Crea e restituisce il comando di carica parte.
 | CreateCaricaParteEsterno | Crea e restituisce il comando di carica blocco.
 | CreateCaricaXref | Crea e restituisce il comando di carica xref.
 | CreateChangeState | Crea e restituisce il comando di rilascio
 | CreateCheckIn | Crea e restituisce il comando di CheckIn per il documento correntemente attivo.
 | CreateCheckOut | Crea e restituisce il comando di CheckOut per il documento correntemente attivo.
 | CreateCompilaParteDaAnagrafica | Crea e restituisce il comando di compila parte da anagrafica.
 | CreateCreaAnagrafica | Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.
 | CreateCreaRev | Crea e restituisce il comando di creazione revisione.
 | CreateCreateSparePartsDrawing | Crea e restituisce il comando di carica parte.
 | CreateCreaVariante | Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.
 | CreateForceMarkerAlignment | Crea e restituisce il comando di rilascio
 | CreateMarkerInfo | Crea e restituisce il comando di rilascio
 | CreatePackAngGoExport | Crea e restituisce il comando di creazione revisione.
 | CreatePackAngGoImport | Crea e restituisce il comando di creazione revisione.
 | CreatePublishSparePartsDrawing | Crea e restituisce il comando di Pubblic tavola ricambi.
 | EditaAttributi | Lancia l'edita attributi sulla parte o sulle parti passate. Se è readOnly viene aperta la finestra non modale, altrimenti quella modale.
 | FindOpenDocument | Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.
 | IndividuaNellaRicerca | Apre la ricerca nei recenti individuando l'anagrafica di una parte.
Metodo pubblico | Initialize | Inizializzazione dell'add-in.
 | Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
 | LogInfo | Registra l'eccezione nel file di log dell'applicazione.
 | OnAcadRilPublishEvent | Lancia evento di pubblicazione formati al rilascio in Inventor
 | OnFileResolutionEvent | Lancia l'evento di FileResolutionEvent
 | OnImportPackAndGoAfterLoadEvent | Lancia l'evento di ImportPackAndGoAfterLoadEvent
 | OnImportPackAndGoDocAttrCompareEvent | Lancia l'evento di ImportPackAndGoDocAttrCompareEvent
 | OnImportPackAndGoMappingRootEvent | Lancia l'evento di ImportPackAndGoMappingRootEvent
 | OnImportPackAndGoOverrideCheckOverwriteOperationEvent | Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent
 | OnImportPackAndGoPresetCodingOperationEvent | Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent
Metodo pubblico | OnTopPrtCreated | Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.
 | OnUpdateAttribFromDbOnOpenEvent | Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.
 | OnUpdateCartOnOpenEvent | Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.
 | PostNavigatorArgs | Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.
 | StatoDocAcad | Metodo che restituisce una stringa con lo stato attuale del doccumento.
Metodo pubblico | Terminate | Termine dell'add-in.
Metodo pubblico | TopPrtActivated | Chiamato su attivazione di una parte, per aggiornare la finestra di visualizzazione attributi.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.AggiornaAttributiDaDb

Metodo DedNetAcadAppAggiornaAttributiDaDb

Aggiorna gli attributi delle parti passate dal Database. Se c'é la parte Top aggiorna solo se il documento attivo è coerente con l'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AggiornaAttributiDaDb(
    PartInfoArray prtArray,
    int iLlastRev
)
Public Shared Sub AggiornaAttributiDaDb (
    prtArray As PartInfoArray,
    iLlastRev As Integer
)
public:
static void AggiornaAttributiDaDb(
    PartInfoArray^ prtArray,
    int iLlastRev
)
static member AggiornaAttributiDaDb :
        prtArray : PartInfoArray *
        iLlastRev : int -> unit

Parametri

prtArray
Tipo: DedNetAcadPartInfoArray
Parti da aggiornare.
iLlastRev
Tipo: SystemInt32
Se a 1 aggiorna all'ultima revisione altrimenti alla revisione corrente.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CaricaParteDaDb

Metodo DedNetAcadAppCaricaParteDaDb

Carica una seconda volta la parte dal Database, se a questa vi è associato un Dwg.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CaricaParteDaDb(
    PartInfo prt
)
Public Shared Sub CaricaParteDaDb (
    prt As PartInfo
)
public:
static void CaricaParteDaDb(
    PartInfo^ prt
)
static member CaricaParteDaDb :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte da ricaricare.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CheckMechanicalLoaded

Metodo DedNetAcadAppCheckMechanicalLoaded

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CheckMechanicalLoaded()
Public Shared Sub CheckMechanicalLoaded
public:
static void CheckMechanicalLoaded()
static member CheckMechanicalLoaded : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateArchiviaDwg

Metodo DedNetAcadAppCreateArchiviaDwg

Crea e restituisce il comando Associa documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadArchiviaDwg CreateArchiviaDwg()
Public Shared Function CreateArchiviaDwg As DedAcadArchiviaDwg
public:
static DedAcadArchiviaDwg^ CreateArchiviaDwg()
static member CreateArchiviaDwg : unit -> DedAcadArchiviaDwg

Valore di ritorno

Tipo: DedAcadArchiviaDwg
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateAssociaDwg

Metodo DedNetAcadAppCreateAssociaDwg

Crea e restituisce il comando Associa documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadAssociaDwg CreateAssociaDwg()
Public Shared Function CreateAssociaDwg As DedAcadAssociaDwg
public:
static DedAcadAssociaDwg^ CreateAssociaDwg()
static member CreateAssociaDwg : unit -> DedAcadAssociaDwg

Valore di ritorno

Tipo: DedAcadAssociaDwg
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaBlocco

Metodo DedNetAcadAppCreateCaricaBlocco

Crea e restituisce il comando di carica blocco.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaBlocco()
Public Shared Function CreateCaricaBlocco As CaricaParte
public:
static CaricaParte^ CreateCaricaBlocco()
static member CreateCaricaBlocco : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaParte

Metodo DedNetAcadAppCreateCaricaParte

Crea e restituisce il comando di carica parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParte()
Public Shared Function CreateCaricaParte As CaricaParte
public:
static CaricaParte^ CreateCaricaParte()
static member CreateCaricaParte : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaParteEsterno

Metodo DedNetAcadAppCreateCaricaParteEsterno

Crea e restituisce il comando di carica blocco.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaParteEsterno()
Public Shared Function CreateCaricaParteEsterno As CaricaParte
public:
static CaricaParte^ CreateCaricaParteEsterno()
static member CreateCaricaParteEsterno : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCaricaXref

Metodo DedNetAcadAppCreateCaricaXref

Crea e restituisce il comando di carica xref.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CaricaParte CreateCaricaXref()
Public Shared Function CreateCaricaXref As CaricaParte
public:
static CaricaParte^ CreateCaricaXref()
static member CreateCaricaXref : unit -> CaricaParte

Valore di ritorno

Tipo: CaricaParte
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateChangeState

Metodo DedNetAcadAppCreateChangeState

Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadChangeState CreateChangeState(
    string internalname,
    string name,
    string tooltip,
    DedState targetState,
    bool multiple
)
Public Shared Function CreateChangeState (
    internalname As String,
    name As String,
    tooltip As String,
    targetState As DedState,
    multiple As Boolean
) As DedAcadChangeState
public:
static DedAcadChangeState^ CreateChangeState(
    String^ internalname,
    String^ name,
    String^ tooltip,
    DedState^ targetState,
    bool multiple
)
static member CreateChangeState :
        internalname : string *
        name : string *
        tooltip : string *
        targetState : DedState *
        multiple : bool -> DedAcadChangeState

Parametri

internalname
Tipo: SystemString
name
Tipo: SystemString
tooltip
Tipo: SystemString
targetState
Tipo: DedState
multiple
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedAcadChangeState
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckIn

Metodo DedNetAcadAppCreateCheckIn

Crea e restituisce il comando di CheckIn per il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckIn CreateCheckIn()
Public Shared Function CreateCheckIn As CheckIn
public:
static CheckIn^ CreateCheckIn()
static member CreateCheckIn : unit -> CheckIn

Valore di ritorno

Tipo: CheckIn
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCheckOut

Metodo DedNetAcadAppCreateCheckOut

Crea e restituisce il comando di CheckOut per il documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CheckOut CreateCheckOut()
Public Shared Function CreateCheckOut As CheckOut
public:
static CheckOut^ CreateCheckOut()
static member CreateCheckOut : unit -> CheckOut

Valore di ritorno

Tipo: CheckOut
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCompilaParteDaAnagrafica

Metodo DedNetAcadAppCreateCompilaParteDaAnagrafica

Crea e restituisce il comando di compila parte da anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CompilaParteDaAnagrafica CreateCompilaParteDaAnagrafica()
Public Shared Function CreateCompilaParteDaAnagrafica As CompilaParteDaAnagrafica
public:
static CompilaParteDaAnagrafica^ CreateCompilaParteDaAnagrafica()
static member CreateCompilaParteDaAnagrafica : unit -> CompilaParteDaAnagrafica

Valore di ritorno

Tipo: CompilaParteDaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaAnagrafica

Metodo DedNetAcadAppCreateCreaAnagrafica

Crea e restituisce il comando di creazione anagrafica ovvero di Salva nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaAnagrafica CreateCreaAnagrafica()
Public Shared Function CreateCreaAnagrafica As DedAcadCreaAnagrafica
public:
static DedAcadCreaAnagrafica^ CreateCreaAnagrafica()
static member CreateCreaAnagrafica : unit -> DedAcadCreaAnagrafica

Valore di ritorno

Tipo: DedAcadCreaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaRev

Metodo DedNetAcadAppCreateCreaRev

Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaRev CreateCreaRev()
Public Shared Function CreateCreaRev As DedAcadCreaRev
public:
static DedAcadCreaRev^ CreateCreaRev()
static member CreateCreaRev : unit -> DedAcadCreaRev

Valore di ritorno

Tipo: DedAcadCreaRev
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreateSparePartsDrawing

Metodo DedNetAcadAppCreateCreateSparePartsDrawing

Crea e restituisce il comando di carica parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static CreateSparePartsDrawing CreateCreateSparePartsDrawing()
Public Shared Function CreateCreateSparePartsDrawing As CreateSparePartsDrawing
public:
static CreateSparePartsDrawing^ CreateCreateSparePartsDrawing()
static member CreateCreateSparePartsDrawing : unit -> CreateSparePartsDrawing

Valore di ritorno

Tipo: CreateSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateCreaVariante

Metodo DedNetAcadAppCreateCreaVariante

Crea e restituisce il comando di creazione variante ovvero di Salva nel Database con tassello utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadCreaAnagrafica CreateCreaVariante()
Public Shared Function CreateCreaVariante As DedAcadCreaAnagrafica
public:
static DedAcadCreaAnagrafica^ CreateCreaVariante()
static member CreateCreaVariante : unit -> DedAcadCreaAnagrafica

Valore di ritorno

Tipo: DedAcadCreaAnagrafica
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateForceMarkerAlignment

Metodo DedNetAcadAppCreateForceMarkerAlignment

Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadForceMarkerAlingment CreateForceMarkerAlignment()
Public Shared Function CreateForceMarkerAlignment As DedAcadForceMarkerAlingment
public:
static DedAcadForceMarkerAlingment^ CreateForceMarkerAlignment()
static member CreateForceMarkerAlignment : unit -> DedAcadForceMarkerAlingment

Valore di ritorno

Tipo: DedAcadForceMarkerAlingment
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreateMarkerInfo

Metodo DedNetAcadAppCreateMarkerInfo

Crea e restituisce il comando di rilascio

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAcadMarkerInfo CreateMarkerInfo()
Public Shared Function CreateMarkerInfo As DedAcadMarkerInfo
public:
static DedAcadMarkerInfo^ CreateMarkerInfo()
static member CreateMarkerInfo : unit -> DedAcadMarkerInfo

Valore di ritorno

Tipo: DedAcadMarkerInfo
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePackAngGoExport

Metodo DedNetAcadAppCreatePackAngGoExport

Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoExport CreatePackAngGoExport()
Public Shared Function CreatePackAngGoExport As PackAndGoExport
public:
static PackAndGoExport^ CreatePackAngGoExport()
static member CreatePackAngGoExport : unit -> PackAndGoExport

Valore di ritorno

Tipo: PackAndGoExport
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePackAngGoImport

Metodo DedNetAcadAppCreatePackAngGoImport

Crea e restituisce il comando di creazione revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PackAndGoImport CreatePackAngGoImport()
Public Shared Function CreatePackAngGoImport As PackAndGoImport
public:
static PackAndGoImport^ CreatePackAngGoImport()
static member CreatePackAngGoImport : unit -> PackAndGoImport

Valore di ritorno

Tipo: PackAndGoImport
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.CreatePublishSparePartsDrawing

Metodo DedNetAcadAppCreatePublishSparePartsDrawing

Crea e restituisce il comando di Pubblic tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PublishSparePartsDrawing CreatePublishSparePartsDrawing()
Public Shared Function CreatePublishSparePartsDrawing As PublishSparePartsDrawing
public:
static PublishSparePartsDrawing^ CreatePublishSparePartsDrawing()
static member CreatePublishSparePartsDrawing : unit -> PublishSparePartsDrawing

Valore di ritorno

Tipo: PublishSparePartsDrawing
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.EditaAttributi

Metodo DedNetAcadAppEditaAttributi

Lancia l'edita attributi sulla parte o sulle parti passate. Se è readOnly viene aperta la finestra non modale, altrimenti quella modale.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void EditaAttributi(
    PartInfoArray selParts,
    int readOnly
)
Public Shared Sub EditaAttributi (
    selParts As PartInfoArray,
    readOnly As Integer
)
public:
static void EditaAttributi(
    PartInfoArray^ selParts,
    int readOnly
)
static member EditaAttributi :
        selParts : PartInfoArray *
        readOnly : int -> unit

Parametri

selParts
Tipo: DedNetAcadPartInfoArray
Array di parti.
readOnly
Tipo: SystemInt32
Se visualizzare in sola lettura.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.FindOpenDocument

Metodo DedNetAcadAppFindOpenDocument

Cerca un documento tra quelli correntemente aperti. Se lo trova lo restituisce altrimenti restituisce null. Normalizza i nomi prima di effettuare il confronto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument FindOpenDocument(
    string fullFileName
)
Public Shared Function FindOpenDocument (
    fullFileName As String
) As QsDocument
public:
static QsDocument^ FindOpenDocument(
    String^ fullFileName
)
static member FindOpenDocument :
        fullFileName : string -> QsDocument

Parametri

fullFileName
Tipo: SystemString
File da cercare.

Valore di ritorno

Tipo: QsDocument
Restituisce il documento trovato oppure null se non lo trova.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.IndividuaNellaRicerca

Metodo DedNetAcadAppIndividuaNellaRicerca

Apre la ricerca nei recenti individuando l'anagrafica di una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void IndividuaNellaRicerca(
    PartInfo prt
)
Public Shared Sub IndividuaNellaRicerca (
    prt As PartInfo
)
public:
static void IndividuaNellaRicerca(
    PartInfo^ prt
)
static member IndividuaNellaRicerca :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte da individuare.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Initialize

Metodo DedNetAcadAppInitialize

Inizializzazione dell'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
void Initialize()
member Initialize : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Log

Metodo DedNetAcadAppLog

Lista degli overload
Nome | Descrizione
Log(ListException, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
Log(Exception, Boolean) | Registra l'eccezione nel file di log dell'applicazione.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Log (List(Exception), Boolean)

Metodo DedNetAcadAppLog (ListException, Boolean)
Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    List<Exception> ex,
    bool silent
)
Public Shared Sub Log (
    ex As List(Of Exception),
    silent As Boolean
)
public:
static void Log(
    List<Exception^>^ ex,
    bool silent
)
static member Log :
        ex : List<Exception> *
        silent : bool -> unit

Parametri

ex
Tipo: System.Collections.GenericList Exception
Eccezione da registrare.
silent
Tipo: SystemBoolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp
Overload di Log


Metodo DedNetAcadApp.Log (Exception, Boolean)

Metodo DedNetAcadAppLog (Exception, Boolean)
Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Log(
    Exception ex,
    bool silent
)
Public Shared Sub Log (
    ex As Exception,
    silent As Boolean
)
public:
static void Log(
    Exception^ ex,
    bool silent
)
static member Log :
        ex : Exception *
        silent : bool -> unit

Parametri

ex
Tipo: SystemException
Eccezione da registrare.
silent
Tipo: SystemBoolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp
Overload di Log


Metodo DedNetAcadApp.LogInfo

Metodo DedNetAcadAppLogInfo

Registra l'eccezione nel file di log dell'applicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LogInfo(
    string msg,
    bool silent
)
Public Shared Sub LogInfo (
    msg As String,
    silent As Boolean
)
public:
static void LogInfo(
    String^ msg,
    bool silent
)
static member LogInfo :
        msg : string *
        silent : bool -> unit

Parametri

msg
Tipo: SystemString
Messaggio da locggare
silent
Tipo: SystemBoolean
Indica se visualizzare il message box con l'errore.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnAcadRilPublishEvent

Metodo DedNetAcadAppOnAcadRilPublishEvent

Lancia evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnAcadRilPublishEvent(
    Object sender,
    DedNetAcadAppAcadRilPublishEventArgs e
)
Public Shared Sub OnAcadRilPublishEvent (
    sender As Object,
    e As DedNetAcadAppAcadRilPublishEventArgs
)
public:
static void OnAcadRilPublishEvent(
    Object^ sender,
    DedNetAcadAppAcadRilPublishEventArgs^ e
)
static member OnAcadRilPublishEvent :
        sender : Object *
        e : DedNetAcadAppAcadRilPublishEventArgs -> unit

Parametri

sender
Tipo: SystemObject
Applicazione di Ded per Inventor
e
Tipo: DedNetAcadDedNetAcadAppAcadRilPublishEventArgs
Argomenti specifici dell'evento
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnFileResolutionEvent

Metodo DedNetAcadAppOnFileResolutionEvent

Lancia l'evento di FileResolutionEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnFileResolutionEvent(
    Object sender,
    DedNetAcadAppResolutionEventArgs e
)
Public Shared Sub OnFileResolutionEvent (
    sender As Object,
    e As DedNetAcadAppResolutionEventArgs
)
public:
static void OnFileResolutionEvent(
    Object^ sender,
    DedNetAcadAppResolutionEventArgs^ e
)
static member OnFileResolutionEvent :
        sender : Object *
        e : DedNetAcadAppResolutionEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoAfterLoadEvent

Metodo DedNetAcadAppOnImportPackAndGoAfterLoadEvent

Lancia l'evento di ImportPackAndGoAfterLoadEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoAfterLoadEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs e
)
Public Shared Sub OnImportPackAndGoAfterLoadEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoAfterLoadEventArgs
)
public:
static void OnImportPackAndGoAfterLoadEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs^ e
)
static member OnImportPackAndGoAfterLoadEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoAfterLoadEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoDocAttrCompareEvent

Metodo DedNetAcadAppOnImportPackAndGoDocAttrCompareEvent

Lancia l'evento di ImportPackAndGoDocAttrCompareEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoDocAttrCompareEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs e
)
Public Shared Sub OnImportPackAndGoDocAttrCompareEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
)
public:
static void OnImportPackAndGoDocAttrCompareEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^ e
)
static member OnImportPackAndGoDocAttrCompareEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoMappingRootEvent

Metodo DedNetAcadAppOnImportPackAndGoMappingRootEvent

Lancia l'evento di ImportPackAndGoMappingRootEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoMappingRootEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs e
)
Public Shared Sub OnImportPackAndGoMappingRootEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoMappingRootEventArgs
)
public:
static void OnImportPackAndGoMappingRootEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs^ e
)
static member OnImportPackAndGoMappingRootEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoMappingRootEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoOverrideCheckOverwriteOperationEvent

Metodo DedNetAcadAppOnImportPackAndGoOverrideCheckOverwriteOperationEvent

Lancia l'evento di ImportPackAndGoOverrideCheckOverwriteOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoOverrideCheckOverwriteOperationEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
)
public:
static void OnImportPackAndGoOverrideCheckOverwriteOperationEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^ e
)
static member OnImportPackAndGoOverrideCheckOverwriteOperationEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnImportPackAndGoPresetCodingOperationEvent

Metodo DedNetAcadAppOnImportPackAndGoPresetCodingOperationEvent

Lancia l'evento di ImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnImportPackAndGoPresetCodingOperationEvent(
    Object sender,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs e
)
Public Shared Sub OnImportPackAndGoPresetCodingOperationEvent (
    sender As Object,
    e As DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
)
public:
static void OnImportPackAndGoPresetCodingOperationEvent(
    Object^ sender,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^ e
)
static member OnImportPackAndGoPresetCodingOperationEvent :
        sender : Object *
        e : DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnTopPrtCreated

Metodo DedNetAcadAppOnTopPrtCreated

Evento di creazione albero parti, chiamato dal LUA dopo la creazione del documento. Viene utilizzato per aggiornare la parte Top con gli attributi presenti nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void OnTopPrtCreated(
    string fileName
)
Public Sub OnTopPrtCreated (
    fileName As String
)
public:
void OnTopPrtCreated(
    String^ fileName
)
member OnTopPrtCreated :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
Nome completo del file in apertura.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnUpdateAttribFromDbOnOpenEvent

Metodo DedNetAcadAppOnUpdateAttribFromDbOnOpenEvent

Lancia evento per la gestione dell'aggiornamento degli attributi dal Db in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnUpdateAttribFromDbOnOpenEvent(
    Object sender,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs e
)
Public Shared Sub OnUpdateAttribFromDbOnOpenEvent (
    sender As Object,
    e As DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
)
public:
static void OnUpdateAttribFromDbOnOpenEvent(
    Object^ sender,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^ e
)
static member OnUpdateAttribFromDbOnOpenEvent :
        sender : Object *
        e : DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.OnUpdateCartOnOpenEvent

Metodo DedNetAcadAppOnUpdateCartOnOpenEvent

Lancia evento per la gestione dell'aggiornamento del cartiglio in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void OnUpdateCartOnOpenEvent(
    Object sender,
    DedNetAcadAppUpdateCartOnOpenEventArgs e
)
Public Shared Sub OnUpdateCartOnOpenEvent (
    sender As Object,
    e As DedNetAcadAppUpdateCartOnOpenEventArgs
)
public:
static void OnUpdateCartOnOpenEvent(
    Object^ sender,
    DedNetAcadAppUpdateCartOnOpenEventArgs^ e
)
static member OnUpdateCartOnOpenEvent :
        sender : Object *
        e : DedNetAcadAppUpdateCartOnOpenEventArgs -> unit

Parametri

sender
Tipo: SystemObject
e
Tipo: DedNetAcadDedNetAcadAppUpdateCartOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.PostNavigatorArgs

Metodo DedNetAcadAppPostNavigatorArgs

Imposta in una variabile globale l'array di parti da utilizzare poi nei comandi che saranno invocati tramite invio di una stringa alla riga di comando di autocad. Viene utilizzato subito prima di chiamare un comando in contesto application.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void PostNavigatorArgs(
    PartInfoArray prtArray,
    bool readOnly,
    bool lastRev
)
Public Shared Sub PostNavigatorArgs (
    prtArray As PartInfoArray,
    readOnly As Boolean,
    lastRev As Boolean
)
public:
static void PostNavigatorArgs(
    PartInfoArray^ prtArray,
    bool readOnly,
    bool lastRev
)
static member PostNavigatorArgs :
        prtArray : PartInfoArray *
        readOnly : bool *
        lastRev : bool -> unit

Parametri

prtArray
Tipo: DedNetAcadPartInfoArray
Array di parti.
readOnly
Tipo: SystemBoolean
Indica se aprire in sola lettura i documenti.
lastRev
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.StatoDocAcad

Metodo DedNetAcadAppStatoDocAcad

Metodo che restituisce una stringa con lo stato attuale del doccumento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string StatoDocAcad(
    QsDocument acadDoc,
    DedDoc doc,
    bool isMyPwsDocEqualsToVaultDoc
)
Public Shared Function StatoDocAcad (
    acadDoc As QsDocument,
    doc As DedDoc,
    isMyPwsDocEqualsToVaultDoc As Boolean
) As String
public:
static String^ StatoDocAcad(
    QsDocument^ acadDoc,
    DedDoc^ doc,
    bool isMyPwsDocEqualsToVaultDoc
)
static member StatoDocAcad :
        acadDoc : QsDocument *
        doc : DedDoc *
        isMyPwsDocEqualsToVaultDoc : bool -> string

Parametri

acadDoc
Tipo: DedNetAcadQsDocument
doc
Tipo: DedDoc
isMyPwsDocEqualsToVaultDoc
Tipo: SystemBoolean

Valore di ritorno

Tipo: String
Stringa con lo stato attuale del documento.
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.Terminate

Metodo DedNetAcadAppTerminate

Termine dell'add-in.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Terminate()
Public Sub Terminate
public:
void Terminate()
member Terminate : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadApp


Metodo DedNetAcadApp.TopPrtActivated

Metodo DedNetAcadAppTopPrtActivated

Chiamato su attivazione di una parte, per aggiornare la finestra di visualizzazione attributi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void TopPrtActivated(
    LuaUserData prtUserData
)
Public Sub TopPrtActivated (
    prtUserData As LuaUserData
)
public:
void TopPrtActivated(
    LuaUserData^ prtUserData
)
member TopPrtActivated :
        prtUserData : LuaUserData -> unit

Parametri

prtUserData
Tipo: LuaUserData
Parte attivata.
Vedi anche

Documentazione

Classe DedNetAcadApp


Eventi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Eventi
Nome | Descrizione
AcadRilPublishEvent | Evento di pubblicazione formati al rilascio in Inventor
FileResolutionEvent | Evento di risoluzione file nel caso non vengano trovati.
ImportPackAndGoAfterLoadEvent | Evento per effettuare modifiche al form dopo il caricamento dei dati.
ImportPackAndGoDocAttrCompareEvent | Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.
ImportPackAndGoMappingRootEvent |
ImportPackAndGoOverrideCheckOverwriteOperationEvent | Evento di override del settaggio del check in caso di operazione di codifica
ImportPackAndGoPresetCodingOperationEvent |
UpdateAttribFromDbOnOpenEvent | Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.
UpdateCartOnOpenEvent | Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.AcadRilPublishEvent

Evento DedNetAcadAppAcadRilPublishEvent
Evento di pubblicazione formati al rilascio in Inventor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppAcadRilPublishEventArgs> AcadRilPublishEvent
Public Shared Event AcadRilPublishEvent As EventHandler(Of DedNetAcadAppAcadRilPublishEventArgs)
public:
static  event EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ AcadRilPublishEvent {
    void add (EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppAcadRilPublishEventArgs^>^ value);
}
member AcadRilPublishEvent : IEvent<EventHandler<DedNetAcadAppAcadRilPublishEventArgs>,
    DedNetAcadAppAcadRilPublishEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppAcadRilPublishEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.FileResolutionEvent

Evento DedNetAcadAppFileResolutionEvent
Evento di risoluzione file nel caso non vengano trovati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppResolutionEventArgs> FileResolutionEvent
Public Shared Event FileResolutionEvent As EventHandler(Of DedNetAcadAppResolutionEventArgs)
public:
static  event EventHandler<DedNetAcadAppResolutionEventArgs^>^ FileResolutionEvent {
    void add (EventHandler<DedNetAcadAppResolutionEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppResolutionEventArgs^>^ value);
}
member FileResolutionEvent : IEvent<EventHandler<DedNetAcadAppResolutionEventArgs>,
    DedNetAcadAppResolutionEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppResolutionEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoAfterLoadEvent

Evento DedNetAcadAppImportPackAndGoAfterLoadEvent
Evento per effettuare modifiche al form dopo il caricamento dei dati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs> ImportPackAndGoAfterLoadEvent
Public Shared Event ImportPackAndGoAfterLoadEvent As EventHandler(Of DedNetAcadAppImportPackAndGoAfterLoadEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ ImportPackAndGoAfterLoadEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs^>^ value);
}
member ImportPackAndGoAfterLoadEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoAfterLoadEventArgs>,
    DedNetAcadAppImportPackAndGoAfterLoadEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppImportPackAndGoAfterLoadEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoDocAttrCompareEvent

Evento DedNetAcadAppImportPackAndGoDocAttrCompareEvent
Evento di automatizzazione comparazione attributi nelle operazioni che lo richiedono in modo che l'utente non debba interagire.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs> ImportPackAndGoDocAttrCompareEvent
Public Shared Event ImportPackAndGoDocAttrCompareEvent As EventHandler(Of DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ ImportPackAndGoDocAttrCompareEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs^>^ value);
}
member ImportPackAndGoDocAttrCompareEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs>,
    DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoMappingRootEvent

Evento DedNetAcadAppImportPackAndGoMappingRootEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs> ImportPackAndGoMappingRootEvent
Public Shared Event ImportPackAndGoMappingRootEvent As EventHandler(Of DedNetAcadAppImportPackAndGoMappingRootEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ ImportPackAndGoMappingRootEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs^>^ value);
}
member ImportPackAndGoMappingRootEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoMappingRootEventArgs>,
    DedNetAcadAppImportPackAndGoMappingRootEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppImportPackAndGoMappingRootEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEvent

Evento DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEvent
Evento di override del settaggio del check in caso di operazione di codifica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs> ImportPackAndGoOverrideCheckOverwriteOperationEvent
Public Shared Event ImportPackAndGoOverrideCheckOverwriteOperationEvent As EventHandler(Of DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ ImportPackAndGoOverrideCheckOverwriteOperationEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs^>^ value);
}
member ImportPackAndGoOverrideCheckOverwriteOperationEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>,
    DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.ImportPackAndGoPresetCodingOperationEvent

Evento DedNetAcadAppImportPackAndGoPresetCodingOperationEvent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs> ImportPackAndGoPresetCodingOperationEvent
Public Shared Event ImportPackAndGoPresetCodingOperationEvent As EventHandler(Of DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs)
public:
static  event EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ ImportPackAndGoPresetCodingOperationEvent {
    void add (EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs^>^ value);
}
member ImportPackAndGoPresetCodingOperationEvent : IEvent<EventHandler<DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs>,
    DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.UpdateAttribFromDbOnOpenEvent

Evento DedNetAcadAppUpdateAttribFromDbOnOpenEvent
Evento per la decidere se fare l'aggiornamento degli attributi dal Db in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs> UpdateAttribFromDbOnOpenEvent
Public Shared Event UpdateAttribFromDbOnOpenEvent As EventHandler(Of DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs)
public:
static  event EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ UpdateAttribFromDbOnOpenEvent {
    void add (EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs^>^ value);
}
member UpdateAttribFromDbOnOpenEvent : IEvent<EventHandler<DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs>,
    DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Evento DedNetAcadApp.UpdateCartOnOpenEvent

Evento DedNetAcadAppUpdateCartOnOpenEvent
Evento per la decidere se fare l'aggiornamento del cartiglio in apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static event EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs> UpdateCartOnOpenEvent
Public Shared Event UpdateCartOnOpenEvent As EventHandler(Of DedNetAcadAppUpdateCartOnOpenEventArgs)
public:
static  event EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ UpdateCartOnOpenEvent {
    void add (EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ value);
    void remove (EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs^>^ value);
}
member UpdateCartOnOpenEvent : IEvent<EventHandler<DedNetAcadAppUpdateCartOnOpenEventArgs>,
    DedNetAcadAppUpdateCartOnOpenEventArgs>

Valore

Tipo: SystemEventHandler DedNetAcadAppUpdateCartOnOpenEventArgs
Vedi anche

Documentazione

Classe DedNetAcadApp


Campi di DedNetAcadApp

Il tipo DedNetAcadApp espone i seguenti membri.

Campi
Nome | Descrizione
DedNetAcadDataRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.
DedNetAcadDocRowVerString | Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadApp


Campo DedNetAcadApp.DedNetAcadDataRowVerString

Campo DedNetAcadAppDedNetAcadDataRowVerString
Nome della chiave del dizionario documento nella quale è presente il rowver dell'anagrafica utilizzata per aggiornare i dati del documento quando è stato aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetAcadDataRowVerString = "DedNetAcadDataRowVer"
Public Const DedNetAcadDataRowVerString As String = "DedNetAcadDataRowVer"
public:
literal String^ DedNetAcadDataRowVerString = "DedNetAcadDataRowVer"
static val mutable DedNetAcadDataRowVerString: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadApp


Campo DedNetAcadApp.DedNetAcadDocRowVerString

Campo DedNetAcadAppDedNetAcadDocRowVerString
Nome della chiave del dizionario documento nella quale è presente il rowver del documento stesso utilizzata per conoscere la versione del documento in modalità detached.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string DedNetAcadDocRowVerString = "DedNetAcadDocRowVer"
Public Const DedNetAcadDocRowVerString As String = "DedNetAcadDocRowVer"
public:
literal String^ DedNetAcadDocRowVerString = "DedNetAcadDocRowVer"
static val mutable DedNetAcadDocRowVerString: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadApp


Classe DedNetAcadApp.AcadRilPublishEventArgs

Classe DedNetAcadAppAcadRilPublishEventArgs
Argomento utilizzato per l'evento di gestione delle pubblicazioni al rilascio
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetAcadDedNetAcadAppAcadRilPublishEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AcadRilPublishEventArgs : DedEventArgs
Public Class AcadRilPublishEventArgs
    Inherits DedEventArgs
public ref class AcadRilPublishEventArgs : public DedEventArgs
type AcadRilPublishEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetAcadAppAcadRilPublishEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppAcadRilPublishEventArgs | Costruttore. Salva gli argomenti nei campi
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Autocad oggetto di pubblicazione
Proprietà pubblica | PublishingAcadDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.AcadRilPublishEventArgs

Costruttore DedNetAcadAppAcadRilPublishEventArgs

Costruttore. Salva gli argomenti nei campi

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AcadRilPublishEventArgs(
    StateCommandEventArgs stateCmdArgs,
    QsDocument pubDoc,
    DedPublicationManager pubMan
)
Public Sub New (
    stateCmdArgs As StateCommandEventArgs,
    pubDoc As QsDocument,
    pubMan As DedPublicationManager
)
public:
AcadRilPublishEventArgs(
    StateCommandEventArgs^ stateCmdArgs,
    QsDocument^ pubDoc,
    DedPublicationManager^ pubMan
)
new :
        stateCmdArgs : StateCommandEventArgs *
        pubDoc : QsDocument *
        pubMan : DedPublicationManager -> AcadRilPublishEventArgs

Parametri

stateCmdArgs
Tipo: StateCommandEventArgs
pubDoc
Tipo: DedNetAcadQsDocument
pubMan
Tipo: DedPublicationManager
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà di AcadRilPublishEventArgs

Il tipo DedNetAcadAppAcadRilPublishEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Restituisce l'anagrafica associata al documento in elaborazione.
Proprietà pubblica | Document | Restituisce il documento in elaborazione dal comando.
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs.)
Proprietà pubblica | PublicationManager | Restituisce il documento di Autocad oggetto di pubblicazione
Proprietà pubblica | PublishingAcadDoc | Restituisce il documento di Inventor oggetto di pubblicazione
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.Data

Proprietà DedNetAcadAppAcadRilPublishEventArgsData

Restituisce l'anagrafica associata al documento in elaborazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.Document

Proprietà DedNetAcadAppAcadRilPublishEventArgsDocument

Restituisce il documento in elaborazione dal comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; }
Public ReadOnly Property Document As DedDoc
    Get
public:
property DedDoc^ Document {
    DedDoc^ get ();
}
member Document : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.PublicationManager

Proprietà DedNetAcadAppAcadRilPublishEventArgsPublicationManager

Restituisce il documento di Autocad oggetto di pubblicazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedPublicationManager PublicationManager { get; }
Public ReadOnly Property PublicationManager As DedPublicationManager
    Get
public:
property DedPublicationManager^ PublicationManager {
    DedPublicationManager^ get ();
}
member PublicationManager : DedPublicationManager with get

Valore della proprietà

Tipo: DedPublicationManager
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Proprietà DedNetAcadApp.AcadRilPublishEventArgs.PublishingAcadDoc

Proprietà DedNetAcadAppAcadRilPublishEventArgsPublishingAcadDoc

Restituisce il documento di Inventor oggetto di pubblicazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument PublishingAcadDoc { get; }
Public ReadOnly Property PublishingAcadDoc As QsDocument
    Get
public:
property QsDocument^ PublishingAcadDoc {
    QsDocument^ get ();
}
member PublishingAcadDoc : QsDocument with get

Valore della proprietà

Tipo: QsDocument
Vedi anche

Documentazione

Classe DedNetAcadAppAcadRilPublishEventArgs


Classe DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs
Argomento usato per effettuare modifiche al form dopo caricamento nodi.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoAfterLoadEventArgs : EventArgs
Public Class ImportPackAndGoAfterLoadEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoAfterLoadEventArgs : public EventArgs
type ImportPackAndGoAfterLoadEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoAfterLoadEventArgs |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs

Costruttore DedNetAcadAppImportPackAndGoAfterLoadEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoAfterLoadEventArgs(
    DedAcadPackAndGoImportForm frm
)
Public Sub New (
    frm As DedAcadPackAndGoImportForm
)
public:
ImportPackAndGoAfterLoadEventArgs(
    DedAcadPackAndGoImportForm^ frm
)
new :
        frm : DedAcadPackAndGoImportForm -> ImportPackAndGoAfterLoadEventArgs

Parametri

frm
Tipo: DedNetAcad.FormsDedAcadPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Proprietà di ImportPackAndGoAfterLoadEventArgs

Il tipo DedNetAcadAppImportPackAndGoAfterLoadEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Frm |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoAfterLoadEventArgs.Frm

Proprietà DedNetAcadAppImportPackAndGoAfterLoadEventArgsFrm

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedAcadPackAndGoImportForm Frm { get; set; }
Public Property Frm As DedAcadPackAndGoImportForm
    Get
    Set
public:
property DedAcadPackAndGoImportForm^ Frm {
    DedAcadPackAndGoImportForm^ get ();
    void set (DedAcadPackAndGoImportForm^ value);
}
member Frm : DedAcadPackAndGoImportForm with get, set

Valore della proprietà

Tipo: DedAcadPackAndGoImportForm
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoAfterLoadEventArgs


Classe DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs
Argomento usato per gestire la comparazione degli attributi nelle azioni che lo richiedono
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
System.ComponentModelCancelEventArgs
DedBeforeOrAfterEventArgs
DedEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoDocAttrCompareEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoDocAttrCompareEventArgs : DedEventArgs
Public Class ImportPackAndGoDocAttrCompareEventArgs
    Inherits DedEventArgs
public ref class ImportPackAndGoDocAttrCompareEventArgs : public DedEventArgs
type ImportPackAndGoDocAttrCompareEventArgs =
    class
        inherit DedEventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs.)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs

Costruttore DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs

Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp,
    DedData data,
    DedDataPart dataDoc
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper,
    data As DedData,
    dataDoc As DedDataPart
)
public:
ImportPackAndGoDocAttrCompareEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp,
    DedData^ data,
    DedDataPart^ dataDoc
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper *
        data : DedData *
        dataDoc : DedDataPart -> ImportPackAndGoDocAttrCompareEventArgs

Parametri

dedcase
Tipo: DedNetAcadPackAndGoImportDedCases
dbMaster
Tipo: SystemBoolean
pckNodeWrp
Tipo: DedNetAcadPackAndGoNodeWrapper
data
Tipo: DedData
dataDoc
Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà di ImportPackAndGoDocAttrCompareEventArgs

Il tipo DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | BeforeOrAfter | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | CommandResult | (Ereditato da DedEventArgs.)
Proprietà pubblica | Data | Ritorna l'anagrafica associata al nodo
Proprietà pubblica | DataDoc | Ritorna il DedDataPart associato al documento
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | Exception | (Ereditato da DedBeforeOrAfterEventArgs.)
Proprietà pubblica | HandlingCode | (Ereditato da DedEventArgs.)
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Proprietà pubblica | UsesDocValues | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.Data

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsData

Ritorna l'anagrafica associata al nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DataDoc

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDataDoc

Ritorna il DedDataPart associato al documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataPart DataDoc { get; }
Public ReadOnly Property DataDoc As DedDataPart
    Get
public:
property DedDataPart^ DataDoc {
    DedDataPart^ get ();
}
member DataDoc : DedDataPart with get

Valore della proprietà

Tipo: DedDataPart
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DbMaster

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDbMaster

Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsDedCase

Ritorna la tipologia di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.PackAndGoNodeWrapper

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsPackAndGoNodeWrapper

Wrapper associato all'evento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoDocAttrCompareEventArgs.UsesDocValues

Proprietà DedNetAcadAppImportPackAndGoDocAttrCompareEventArgsUsesDocValues

Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UsesDocValues { get; set; }
Public Property UsesDocValues As Boolean
    Get
    Set
public:
property bool UsesDocValues {
    bool get ();
    void set (bool value);
}
member UsesDocValues : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoDocAttrCompareEventArgs


Classe DedNetAcadApp.ImportPackAndGoMappingRootEventArgs

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoMappingRootEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoMappingRootEventArgs : EventArgs
Public Class ImportPackAndGoMappingRootEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoMappingRootEventArgs : public EventArgs
type ImportPackAndGoMappingRootEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoMappingRootEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoMappingRootEventArgs

Costruttore DedNetAcadAppImportPackAndGoMappingRootEventArgs

Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject> ipjPaths
)
Public Sub New (
    ipjPaths As List(Of MappingRootObject)
)
public:
ImportPackAndGoMappingRootEventArgs(
    List<MappingRootObject^>^ ipjPaths
)
new :
        ipjPaths : List<MappingRootObject> -> ImportPackAndGoMappingRootEventArgs

Parametri

ipjPaths
Tipo: System.Collections.GenericList MappingRootObject
Mappatura root.
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Proprietà di ImportPackAndGoMappingRootEventArgs

Il tipo DedNetAcadAppImportPackAndGoMappingRootEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | IpjPaths |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoMappingRootEventArgs.IpjPaths

Proprietà DedNetAcadAppImportPackAndGoMappingRootEventArgsIpjPaths

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<MappingRootObject> IpjPaths { get; set; }
Public Property IpjPaths As List(Of MappingRootObject)
    Get
    Set
public:
property List<MappingRootObject^>^ IpjPaths {
    List<MappingRootObject^>^ get ();
    void set (List<MappingRootObject^>^ value);
}
member IpjPaths : List<MappingRootObject> with get, set

Valore della proprietà

Tipo: List MappingRootObject
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoMappingRootEventArgs


Classe DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : EventArgs
Public Class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoOverrideCheckOverwriteOperationEventArgs : public EventArgs
type ImportPackAndGoOverrideCheckOverwriteOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper pckNodeWrp
)
Public Sub New (
    dedcase As PackAndGoImportDedCases,
    dbMaster As Boolean,
    pckNodeWrp As PackAndGoNodeWrapper
)
public:
ImportPackAndGoOverrideCheckOverwriteOperationEventArgs(
    PackAndGoImportDedCases dedcase,
    bool dbMaster,
    PackAndGoNodeWrapper^ pckNodeWrp
)
new :
        dedcase : PackAndGoImportDedCases *
        dbMaster : bool *
        pckNodeWrp : PackAndGoNodeWrapper -> ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Parametri

dedcase
Tipo: DedNetAcadPackAndGoImportDedCases
dbMaster
Tipo: SystemBoolean
pckNodeWrp
Tipo: DedNetAcadPackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà di ImportPackAndGoOverrideCheckOverwriteOperationEventArgs

Il tipo DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbMaster | Ritorna verso se il db è master nel contesto dell'importazione
Proprietà pubblica | DedCase | Ritorna la tipologia di importazione
Proprietà pubblica | OverrideCheck | Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto
Proprietà pubblica | PackAndGoNodeWrapper | Wrapper associato all'evento
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DbMaster

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDbMaster

Ritorna verso se il db è master nel contesto dell'importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DbMaster { get; }
Public ReadOnly Property DbMaster As Boolean
    Get
public:
property bool DbMaster {
    bool get ();
}
member DbMaster : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsDedCase

Ritorna la tipologia di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.OverrideCheck

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsOverrideCheck

Restituisce ed imposta il valore che deve assumere il check del nodo in base al contesto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OverrideCheck { get; set; }
Public Property OverrideCheck As Boolean
    Get
    Set
public:
property bool OverrideCheck {
    bool get ();
    void set (bool value);
}
member OverrideCheck : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoOverrideCheckOverwriteOperationEventArgs.PackAndGoNodeWrapper

Proprietà DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgsPackAndGoNodeWrapper

Wrapper associato all'evento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper PackAndGoNodeWrapper { get; }
Public ReadOnly Property PackAndGoNodeWrapper As PackAndGoNodeWrapper
    Get
public:
property PackAndGoNodeWrapper^ PackAndGoNodeWrapper {
    PackAndGoNodeWrapper^ get ();
}
member PackAndGoNodeWrapper : PackAndGoNodeWrapper with get

Valore della proprietà

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoOverrideCheckOverwriteOperationEventArgs


Classe DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ImportPackAndGoPresetCodingOperationEventArgs : EventArgs
Public Class ImportPackAndGoPresetCodingOperationEventArgs
    Inherits EventArgs
public ref class ImportPackAndGoPresetCodingOperationEventArgs : public EventArgs
type ImportPackAndGoPresetCodingOperationEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs

Costruttore DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs

Costruttore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ImportPackAndGoPresetCodingOperationEventArgs(
    string fullfilename,
    Dictionary<string, Object> dizAttr
)
Public Sub New (
    fullfilename As String,
    dizAttr As Dictionary(Of String, Object)
)
public:
ImportPackAndGoPresetCodingOperationEventArgs(
    String^ fullfilename,
    Dictionary<String^, Object^>^ dizAttr
)
new :
        fullfilename : string *
        dizAttr : Dictionary<string, Object> -> ImportPackAndGoPresetCodingOperationEventArgs

Parametri

fullfilename
Tipo: SystemString
Filename del documento in importazione.
dizAttr
Tipo: System.Collections.GenericDictionary String, Object
Dizionario contenete attributi documento.
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà di ImportPackAndGoPresetCodingOperationEventArgs

Il tipo DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Anagrafica da associare al documento in importazione.
Proprietà pubblica | DedCase | Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )
Proprietà pubblica | DedType | Famiglia nel quale codificare il documento.
Proprietà pubblica | DestRoot | Nome della root nella quale posizionare il file ( nel caso clona o libreria )
Proprietà pubblica | DizAttr | Dizionario con attributi ( prompt,valore )
Proprietà pubblica | Fullfilename | Nome del file in importazione
Proprietà pubblica | InfoUser | Tassello utente da utilizzare.
Proprietà pubblica | NewFullFileName | Nuovo file da utilizzare nel caso di operazione di Salta.
Proprietà pubblica | Operation | Operazione da effettuare sul file
Proprietà pubblica | Progr | Progressivo da utilizzare.
Proprietà pubblica | Rev | Revisione da utilizzare.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Data

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsData

Anagrafica da associare al documento in importazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DedCase

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDedCase

Sistuazione di importazione ( DedVpn, NoDed, DedRemote, PackAndGoInv )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportDedCases DedCase { get; }
Public ReadOnly Property DedCase As PackAndGoImportDedCases
    Get
public:
property PackAndGoImportDedCases DedCase {
    PackAndGoImportDedCases get ();
}
member DedCase : PackAndGoImportDedCases with get

Valore della proprietà

Tipo: PackAndGoImportDedCases
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DedType

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDedType

Famiglia nel quale codificare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DestRoot

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDestRoot

Nome della root nella quale posizionare il file ( nel caso clona o libreria )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.DizAttr

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsDizAttr

Dizionario con attributi ( prompt,valore )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, Object> DizAttr { get; }
Public ReadOnly Property DizAttr As Dictionary(Of String, Object)
    Get
public:
property Dictionary<String^, Object^>^ DizAttr {
    Dictionary<String^, Object^>^ get ();
}
member DizAttr : Dictionary<string, Object> with get

Valore della proprietà

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Fullfilename

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsFullfilename

Nome del file in importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Fullfilename { get; }
Public ReadOnly Property Fullfilename As String
    Get
public:
property String^ Fullfilename {
    String^ get ();
}
member Fullfilename : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.InfoUser

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsInfoUser

Tassello utente da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.NewFullFileName

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsNewFullFileName

Nuovo file da utilizzare nel caso di operazione di Salta.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Operation

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsOperation

Operazione da effettuare sul file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation Operation { get; set; }
Public Property Operation As PackAndGoImportOperation
    Get
    Set
public:
property PackAndGoImportOperation Operation {
    PackAndGoImportOperation get ();
    void set (PackAndGoImportOperation value);
}
member Operation : PackAndGoImportOperation with get, set

Valore della proprietà

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Progr

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsProgr

Progressivo da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Proprietà DedNetAcadApp.ImportPackAndGoPresetCodingOperationEventArgs.Rev

Proprietà DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgsRev

Revisione da utilizzare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppImportPackAndGoPresetCodingOperationEventArgs


Classe DedNetAcadApp.ResolutionEventArgs

Classe DedNetAcadAppResolutionEventArgs
Argomento utilizzato per l'evento di override della famiglia in caso di salvataggio multiplo
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppResolutionEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolutionEventArgs : EventArgs
Public Class ResolutionEventArgs
    Inherits EventArgs
public ref class ResolutionEventArgs : public EventArgs
type ResolutionEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppResolutionEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppResolutionEventArgs | Costruttore.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.ResolutionEventArgs

Costruttore DedNetAcadAppResolutionEventArgs

Costruttore.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public ResolutionEventArgs(
    string fileName
)
Public Sub New (
    fileName As String
)
public:
ResolutionEventArgs(
    String^ fileName
)
new :
        fileName : string -> ResolutionEventArgs

Parametri

fileName
Tipo: SystemString
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà di ResolutionEventArgs

Il tipo DedNetAcadAppResolutionEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | FileName | Nome del file non trovato
Proprietà pubblica | SostFileName | Nuovo file da sostituire
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà DedNetAcadApp.ResolutionEventArgs.FileName

Proprietà DedNetAcadAppResolutionEventArgsFileName

Nome del file non trovato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Proprietà DedNetAcadApp.ResolutionEventArgs.SostFileName

Proprietà DedNetAcadAppResolutionEventArgsSostFileName

Nuovo file da sostituire

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SostFileName { get; set; }
Public Property SostFileName As String
    Get
    Set
public:
property String^ SostFileName {
    String^ get ();
    void set (String^ value);
}
member SostFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadAppResolutionEventArgs


Classe DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppUpdateAttribFromDbOnOpenEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateAttribFromDbOnOpenEventArgs : EventArgs
Public Class UpdateAttribFromDbOnOpenEventArgs
    Inherits EventArgs
public ref class UpdateAttribFromDbOnOpenEventArgs : public EventArgs
type UpdateAttribFromDbOnOpenEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs

Costruttore DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs

Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateAttribFromDbOnOpenEventArgs(
    DedData data,
    PartInfo prt
)
Public Sub New (
    data As DedData,
    prt As PartInfo
)
public:
UpdateAttribFromDbOnOpenEventArgs(
    DedData^ data,
    PartInfo^ prt
)
new :
        data : DedData *
        prt : PartInfo -> UpdateAttribFromDbOnOpenEventArgs

Parametri

data
Tipo: DedData
prt
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà di UpdateAttribFromDbOnOpenEventArgs

Il tipo DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.DedData

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsDedData

Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; set; }
Public Property DedData As DedData
    Get
    Set
public:
property DedData^ DedData {
    DedData^ get ();
    void set (DedData^ value);
}
member DedData : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.HandlingCode

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsHandlingCode

Restituisce o imposta la gestione dell'evento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

Tipo: DedEventHandlerEnum
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateAttribFromDbOnOpenEventArgs.PrtInfo

Proprietà DedNetAcadAppUpdateAttribFromDbOnOpenEventArgsPrtInfo

Restituisce l'estensione del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateAttribFromDbOnOpenEventArgs


Classe DedNetAcadApp.UpdateCartOnOpenEventArgs

Classe DedNetAcadAppUpdateCartOnOpenEventArgs
Racchiude le informazioni che riguardano la visualizzazione del preview di un file.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
DedNetAcadDedNetAcadAppUpdateCartOnOpenEventArgs

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class UpdateCartOnOpenEventArgs : EventArgs
Public Class UpdateCartOnOpenEventArgs
    Inherits EventArgs
public ref class UpdateCartOnOpenEventArgs : public EventArgs
type UpdateCartOnOpenEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedNetAcadAppUpdateCartOnOpenEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadAppUpdateCartOnOpenEventArgs | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadApp.UpdateCartOnOpenEventArgs

Costruttore DedNetAcadAppUpdateCartOnOpenEventArgs

Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public UpdateCartOnOpenEventArgs(
    DedData data,
    PartInfo prt
)
Public Sub New (
    data As DedData,
    prt As PartInfo
)
public:
UpdateCartOnOpenEventArgs(
    DedData^ data,
    PartInfo^ prt
)
new :
        data : DedData *
        prt : PartInfo -> UpdateCartOnOpenEventArgs

Parametri

data
Tipo: DedData
prt
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà di UpdateCartOnOpenEventArgs

Il tipo DedNetAcadAppUpdateCartOnOpenEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DedData | Restituisce il percorso del file del quale visualizzare l'anteprima.
Proprietà pubblica | HandlingCode | Restituisce o imposta la gestione dell'evento.
Proprietà pubblica | PrtInfo | Restituisce l'estensione del file.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.DedData

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsDedData

Restituisce il percorso del file del quale visualizzare l'anteprima.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData DedData { get; set; }
Public Property DedData As DedData
    Get
    Set
public:
property DedData^ DedData {
    DedData^ get ();
    void set (DedData^ value);
}
member DedData : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.HandlingCode

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsHandlingCode

Restituisce o imposta la gestione dell'evento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedEventHandlerEnum HandlingCode { get; set; }
Public Property HandlingCode As DedEventHandlerEnum
    Get
    Set
public:
property DedEventHandlerEnum HandlingCode {
    DedEventHandlerEnum get ();
    void set (DedEventHandlerEnum value);
}
member HandlingCode : DedEventHandlerEnum with get, set

Valore della proprietà

Tipo: DedEventHandlerEnum
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Proprietà DedNetAcadApp.UpdateCartOnOpenEventArgs.PrtInfo

Proprietà DedNetAcadAppUpdateCartOnOpenEventArgsPrtInfo

Restituisce l'estensione del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe DedNetAcadAppUpdateCartOnOpenEventArgs


Classe DedNetAcadCommands
Classe di definizione dei comandi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadCommands

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedNetAcadCommands
Public Class DedNetAcadCommands
public ref class DedNetAcadCommands
type DedNetAcadCommands =  class end

Il tipo DedNetAcadCommands espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadCommands |
Torna su
Metodi
Nome | Descrizione
ApriDwgDaDb | Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().
DedAbout | Apre la finestra di help.
DedAcadChangeState | Comando di cambio stato.
DedAcadChangeStateMultiple | Comando di cambio stato multiplo.
DedAcadCreateSparePartDrawing | Crea tavola ricambi.
DedAcadForceMarker | Forza l'allineamento del marker
DedAcadMarkerInfo | Visualizza lo stato del marker
DedAcadPublishSparePartDrawing | Pubblica tavola ricambi.
DedAnnullaCheckOut |
DedApriAllegati | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedApriAssociati | Apre il file associato oppure visualizza la finestra di selezione file associati.
DedApriLettura | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.
DedApriModifica | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.
DedArchiviaDoc | Archivia il documento correntemente aperto nel percorso selezionato dall'utente.
DedArchiviaDocPrt | Archivia la parte correntemente attiva nel percorso selezionato dall'utente.
DedAssociaDoc | Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.
DedAssociaDocPrt | Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.
DedCambiaPwd | Finestra che permette di modificare la password dell'utente connesso.
DedCheckIn |
DedCheckOldRev | Controlla e permette di aggiornare le revisioni superate.
DedCheckOut | Mette in check-out il documento attivo.
DedComm | Lancia l'editor delle commesse.
DedCreaAnagr | Salva il documento correntemente aperto nel Database con un nuovo codice.
DedCreaAnagrPrt | Salva la parte correntemente attiva nel Database con un nuovo codice.
DedCreaRev | Salva il documento correntemente aperto con nuova revisione.
DedCreaVariante | Salva una variante del documento correntemente aperto.
DedCreaVariantePrt | Salva una variante della parte correntemente attiva.
DedDistEdit | Lancia l'editor della distinta con l'eventuale codice in editazione.
DedDistEspl | Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistImpl | Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDocRecognizer | Lancia il riconoscitore massivo di documenti
DedDocRegister | Lancia il comando per registrare il documento attivo
DedECO | Lancia l'editor degli ECO.
DedEditAttrLettura | Apre la finestra di dialogo per la visualizzazione degli attributi della parte correntemente attiva.
DedEditAttrModifica | Apre la finestra di dialogo per la modifica degli attributi della parte correntemente attiva.
DedEseguiLua | Apre la finestra di esecuzione codice LUA.
DedHelp | Apre la finestra di help.
DedIntroduction | Apre la finestra principale della ricerca.
DedLavMulti | Effettua la lavorazione multipla del documento attivo.
DedLogIn | Comando che permette di cambiare utente all'interno del CAD.
DedModificaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedPackAndGoExport | Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
DedPackAndGoImport | Esegue l'importazione di un pacchetto di file
DedPubblica |
DedPwsCache |
DedRicerca | Apre la finestra principale della ricerca.
DedRicercaDocumentale | Apre la finestra della ricerca documentale.
DedRicercaNew | Apre la finestra principale della ricerca.
DedRil | Rilascia l'anagrafica associata al documento correntemente attivo.
DedRilMulti | Effettua il rilascio multiplo del documento attivo.
DedSalvaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedSblocca |
DedStatoDoc | Visualizza lo stato dell'anagrafica e del documento correntemente attivo.
DedUnRil | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadCommands

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetAcadCommands()
Public Sub New
public:
DedNetAcadCommands()
new : unit -> DedNetAcadCommands
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodi di DedNetAcadCommands

Il tipo DedNetAcadCommands espone i seguenti membri.

Metodi
Nome | Descrizione
ApriDwgDaDb | Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().
DedAbout | Apre la finestra di help.
DedAcadChangeState | Comando di cambio stato.
DedAcadChangeStateMultiple | Comando di cambio stato multiplo.
DedAcadCreateSparePartDrawing | Crea tavola ricambi.
DedAcadForceMarker | Forza l'allineamento del marker
DedAcadMarkerInfo | Visualizza lo stato del marker
DedAcadPublishSparePartDrawing | Pubblica tavola ricambi.
DedAnnullaCheckOut |
DedApriAllegati | Apre il file allegato oppure visualizza la finestra di selezione file allegati.
DedApriAssociati | Apre il file associato oppure visualizza la finestra di selezione file associati.
DedApriLettura | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.
DedApriModifica | Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.
DedArchiviaDoc | Archivia il documento correntemente aperto nel percorso selezionato dall'utente.
DedArchiviaDocPrt | Archivia la parte correntemente attiva nel percorso selezionato dall'utente.
DedAssociaDoc | Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.
DedAssociaDocPrt | Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.
DedCambiaPwd | Finestra che permette di modificare la password dell'utente connesso.
DedCheckIn |
DedCheckOldRev | Controlla e permette di aggiornare le revisioni superate.
DedCheckOut | Mette in check-out il documento attivo.
DedComm | Lancia l'editor delle commesse.
DedCreaAnagr | Salva il documento correntemente aperto nel Database con un nuovo codice.
DedCreaAnagrPrt | Salva la parte correntemente attiva nel Database con un nuovo codice.
DedCreaRev | Salva il documento correntemente aperto con nuova revisione.
DedCreaVariante | Salva una variante del documento correntemente aperto.
DedCreaVariantePrt | Salva una variante della parte correntemente attiva.
DedDistEdit | Lancia l'editor della distinta con l'eventuale codice in editazione.
DedDistEspl | Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistImpl | Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDocRecognizer | Lancia il riconoscitore massivo di documenti
DedDocRegister | Lancia il comando per registrare il documento attivo
DedECO | Lancia l'editor degli ECO.
DedEditAttrLettura | Apre la finestra di dialogo per la visualizzazione degli attributi della parte correntemente attiva.
DedEditAttrModifica | Apre la finestra di dialogo per la modifica degli attributi della parte correntemente attiva.
DedEseguiLua | Apre la finestra di esecuzione codice LUA.
DedHelp | Apre la finestra di help.
DedIntroduction | Apre la finestra principale della ricerca.
DedLavMulti | Effettua la lavorazione multipla del documento attivo.
DedLogIn | Comando che permette di cambiare utente all'interno del CAD.
DedModificaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedPackAndGoExport | Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo
DedPackAndGoImport | Esegue l'importazione di un pacchetto di file
DedPubblica |
DedPwsCache |
DedRicerca | Apre la finestra principale della ricerca.
DedRicercaDocumentale | Apre la finestra della ricerca documentale.
DedRicercaNew | Apre la finestra principale della ricerca.
DedRil | Rilascia l'anagrafica associata al documento correntemente attivo.
DedRilMulti | Effettua il rilascio multiplo del documento attivo.
DedSalvaSup | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
DedSblocca |
DedStatoDoc | Visualizza lo stato dell'anagrafica e del documento correntemente attivo.
DedUnRil | Toglie il rilascio all'anagrafica associata al documento correntemente attivo.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.ApriDwgDaDb

Metodo DedNetAcadCommandsApriDwgDaDb

Apre tutti i DWG delle parti selezionate nel Navigator. Presuppone che siano stati impostati i parametri con la funzione PostNavigatorArgs().

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void ApriDwgDaDb()
Public Shared Sub ApriDwgDaDb
public:
static void ApriDwgDaDb()
static member ApriDwgDaDb : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAbout

Metodo DedNetAcadCommandsDedAbout

Apre la finestra di help.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAbout()
Public Shared Sub DedAbout
public:
static void DedAbout()
static member DedAbout : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadChangeState

Metodo DedNetAcadCommandsDedAcadChangeState

Comando di cambio stato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadChangeState()
Public Shared Sub DedAcadChangeState
public:
static void DedAcadChangeState()
static member DedAcadChangeState : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadChangeStateMultiple

Metodo DedNetAcadCommandsDedAcadChangeStateMultiple

Comando di cambio stato multiplo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadChangeStateMultiple()
Public Shared Sub DedAcadChangeStateMultiple
public:
static void DedAcadChangeStateMultiple()
static member DedAcadChangeStateMultiple : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadCreateSparePartDrawing

Metodo DedNetAcadCommandsDedAcadCreateSparePartDrawing

Crea tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadCreateSparePartDrawing()
Public Shared Sub DedAcadCreateSparePartDrawing
public:
static void DedAcadCreateSparePartDrawing()
static member DedAcadCreateSparePartDrawing : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadForceMarker

Metodo DedNetAcadCommandsDedAcadForceMarker

Forza l'allineamento del marker

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadForceMarker()
Public Shared Sub DedAcadForceMarker
public:
static void DedAcadForceMarker()
static member DedAcadForceMarker : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadMarkerInfo

Metodo DedNetAcadCommandsDedAcadMarkerInfo

Visualizza lo stato del marker

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadMarkerInfo()
Public Shared Sub DedAcadMarkerInfo
public:
static void DedAcadMarkerInfo()
static member DedAcadMarkerInfo : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAcadPublishSparePartDrawing

Metodo DedNetAcadCommandsDedAcadPublishSparePartDrawing

Pubblica tavola ricambi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadPublishSparePartDrawing()
Public Shared Sub DedAcadPublishSparePartDrawing
public:
static void DedAcadPublishSparePartDrawing()
static member DedAcadPublishSparePartDrawing : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAnnullaCheckOut

Metodo DedNetAcadCommandsDedAnnullaCheckOut

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAnnullaCheckOut()
Public Shared Sub DedAnnullaCheckOut
public:
static void DedAnnullaCheckOut()
static member DedAnnullaCheckOut : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriAllegati

Metodo DedNetAcadCommandsDedApriAllegati

Apre il file allegato oppure visualizza la finestra di selezione file allegati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriAllegati()
Public Shared Sub DedApriAllegati
public:
static void DedApriAllegati()
static member DedApriAllegati : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriAssociati

Metodo DedNetAcadCommandsDedApriAssociati

Apre il file associato oppure visualizza la finestra di selezione file associati.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriAssociati()
Public Shared Sub DedApriAssociati
public:
static void DedApriAssociati()
static member DedApriAssociati : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriLettura

Metodo DedNetAcadCommandsDedApriLettura

Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in lettura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriLettura()
Public Shared Sub DedApriLettura
public:
static void DedApriLettura()
static member DedApriLettura : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedApriModifica

Metodo DedNetAcadCommandsDedApriModifica

Visualizza la finestra di dialogo di richiesta codice per effettuare l'apri in modifica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedApriModifica()
Public Shared Sub DedApriModifica
public:
static void DedApriModifica()
static member DedApriModifica : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedArchiviaDoc

Metodo DedNetAcadCommandsDedArchiviaDoc

Archivia il documento correntemente aperto nel percorso selezionato dall'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedArchiviaDoc()
Public Shared Sub DedArchiviaDoc
public:
static void DedArchiviaDoc()
static member DedArchiviaDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedArchiviaDocPrt

Metodo DedNetAcadCommandsDedArchiviaDocPrt

Archivia la parte correntemente attiva nel percorso selezionato dall'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedArchiviaDocPrt()
Public Shared Sub DedArchiviaDocPrt
public:
static void DedArchiviaDocPrt()
static member DedArchiviaDocPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAssociaDoc

Metodo DedNetAcadCommandsDedAssociaDoc

Salva il documento correntemente aperto associandolo ad un'anagrafica già presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAssociaDoc()
Public Shared Sub DedAssociaDoc
public:
static void DedAssociaDoc()
static member DedAssociaDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedAssociaDocPrt

Metodo DedNetAcadCommandsDedAssociaDocPrt

Associa la parte correntemente attiva ad un'anagrafica già presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAssociaDocPrt()
Public Shared Sub DedAssociaDocPrt
public:
static void DedAssociaDocPrt()
static member DedAssociaDocPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCambiaPwd

Metodo DedNetAcadCommandsDedCambiaPwd

Finestra che permette di modificare la password dell'utente connesso.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCambiaPwd()
Public Shared Sub DedCambiaPwd
public:
static void DedCambiaPwd()
static member DedCambiaPwd : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckIn

Metodo DedNetAcadCommandsDedCheckIn

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckIn()
Public Shared Sub DedCheckIn
public:
static void DedCheckIn()
static member DedCheckIn : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckOldRev

Metodo DedNetAcadCommandsDedCheckOldRev

Controlla e permette di aggiornare le revisioni superate.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckOldRev()
Public Shared Sub DedCheckOldRev
public:
static void DedCheckOldRev()
static member DedCheckOldRev : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCheckOut

Metodo DedNetAcadCommandsDedCheckOut

Mette in check-out il documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCheckOut()
Public Shared Sub DedCheckOut
public:
static void DedCheckOut()
static member DedCheckOut : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedComm

Metodo DedNetAcadCommandsDedComm

Lancia l'editor delle commesse.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedComm()
Public Shared Sub DedComm
public:
static void DedComm()
static member DedComm : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaAnagr

Metodo DedNetAcadCommandsDedCreaAnagr

Salva il documento correntemente aperto nel Database con un nuovo codice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaAnagr()
Public Shared Sub DedCreaAnagr
public:
static void DedCreaAnagr()
static member DedCreaAnagr : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaAnagrPrt

Metodo DedNetAcadCommandsDedCreaAnagrPrt

Salva la parte correntemente attiva nel Database con un nuovo codice.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaAnagrPrt()
Public Shared Sub DedCreaAnagrPrt
public:
static void DedCreaAnagrPrt()
static member DedCreaAnagrPrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaRev

Metodo DedNetAcadCommandsDedCreaRev

Salva il documento correntemente aperto con nuova revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaRev()
Public Shared Sub DedCreaRev
public:
static void DedCreaRev()
static member DedCreaRev : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaVariante

Metodo DedNetAcadCommandsDedCreaVariante

Salva una variante del documento correntemente aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaVariante()
Public Shared Sub DedCreaVariante
public:
static void DedCreaVariante()
static member DedCreaVariante : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedCreaVariantePrt

Metodo DedNetAcadCommandsDedCreaVariantePrt

Salva una variante della parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedCreaVariantePrt()
Public Shared Sub DedCreaVariantePrt
public:
static void DedCreaVariantePrt()
static member DedCreaVariantePrt : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistEdit

Metodo DedNetAcadCommandsDedDistEdit

Lancia l'editor della distinta con l'eventuale codice in editazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistEdit()
Public Shared Sub DedDistEdit
public:
static void DedDistEdit()
static member DedDistEdit : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistEspl

Metodo DedNetAcadCommandsDedDistEspl

Visualizza la distinta esplosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistEspl()
Public Shared Sub DedDistEspl
public:
static void DedDistEspl()
static member DedDistEspl : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistImpl

Metodo DedNetAcadCommandsDedDistImpl

Visualizza la distinta implosa del codice della parte selezionata. Se non è presente il codice o non è nel Database viene chiesto all'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistImpl()
Public Shared Sub DedDistImpl
public:
static void DedDistImpl()
static member DedDistImpl : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistSave

Metodo DedNetAcadCommandsDedDistSave

Lista degli overload
Nome | Descrizione
DedDistSave | Salva la distinta del documento correntemente aperto, nel Datbase.
DedDistSave(LuaTable) | Salva la distinta del documento correntemente aperto, nel Datbase.
Torna su
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDistSave

Metodo DedNetAcadCommandsDedDistSave

Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistSave()
Public Shared Sub DedDistSave
public:
static void DedDistSave()
static member DedDistSave : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands
Overload di DedDistSave


Metodo DedNetAcadCommands.DedDistSave (LuaTable)

Metodo DedNetAcadCommandsDedDistSave (LuaTable)
Salva la distinta del documento correntemente aperto, nel Datbase.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDistSave(
    LuaTable args
)
Public Shared Sub DedDistSave (
    args As LuaTable
)
public:
static void DedDistSave(
    LuaTable^ args
)
static member DedDistSave :
        args : LuaTable -> unit

Parametri

args
Tipo: LuaTable
Vedi anche

Documentazione

Classe DedNetAcadCommands
Overload di DedDistSave


Metodo DedNetAcadCommands.DedDocRecognizer

Metodo DedNetAcadCommandsDedDocRecognizer

Lancia il riconoscitore massivo di documenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDocRecognizer()
Public Shared Sub DedDocRecognizer
public:
static void DedDocRecognizer()
static member DedDocRecognizer : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedDocRegister

Metodo DedNetAcadCommandsDedDocRegister

Lancia il comando per registrare il documento attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedDocRegister()
Public Shared Sub DedDocRegister
public:
static void DedDocRegister()
static member DedDocRegister : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedECO

Metodo DedNetAcadCommandsDedECO

Lancia l'editor degli ECO.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedECO()
Public Shared Sub DedECO
public:
static void DedECO()
static member DedECO : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedEditAttrLettura

Metodo DedNetAcadCommandsDedEditAttrLettura

Apre la finestra di dialogo per la visualizzazione degli attributi della parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedEditAttrLettura()
Public Shared Sub DedEditAttrLettura
public:
static void DedEditAttrLettura()
static member DedEditAttrLettura : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedEditAttrModifica

Metodo DedNetAcadCommandsDedEditAttrModifica

Apre la finestra di dialogo per la modifica degli attributi della parte correntemente attiva.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedEditAttrModifica()
Public Shared Sub DedEditAttrModifica
public:
static void DedEditAttrModifica()
static member DedEditAttrModifica : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedEseguiLua

Metodo DedNetAcadCommandsDedEseguiLua

Apre la finestra di esecuzione codice LUA.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedEseguiLua()
Public Shared Sub DedEseguiLua
public:
static void DedEseguiLua()
static member DedEseguiLua : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedHelp

Metodo DedNetAcadCommandsDedHelp

Apre la finestra di help.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedHelp()
Public Shared Sub DedHelp
public:
static void DedHelp()
static member DedHelp : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedIntroduction

Metodo DedNetAcadCommandsDedIntroduction

Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedIntroduction()
Public Shared Sub DedIntroduction
public:
static void DedIntroduction()
static member DedIntroduction : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedLavMulti

Metodo DedNetAcadCommandsDedLavMulti

Effettua la lavorazione multipla del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedLavMulti()
Public Shared Sub DedLavMulti
public:
static void DedLavMulti()
static member DedLavMulti : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedLogIn

Metodo DedNetAcadCommandsDedLogIn

Comando che permette di cambiare utente all'interno del CAD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedLogIn()
Public Shared Sub DedLogIn
public:
static void DedLogIn()
static member DedLogIn : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedModificaSup

Metodo DedNetAcadCommandsDedModificaSup

Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedModificaSup()
Public Shared Sub DedModificaSup
public:
static void DedModificaSup()
static member DedModificaSup : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPackAndGoExport

Metodo DedNetAcadCommandsDedPackAndGoExport

Esegue l'esportazione della struttura dall'anagrafica o dal documento attivo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedPackAndGoExport()
Public Shared Sub DedPackAndGoExport
public:
static void DedPackAndGoExport()
static member DedPackAndGoExport : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPackAndGoImport

Metodo DedNetAcadCommandsDedPackAndGoImport

Esegue l'importazione di un pacchetto di file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedPackAndGoImport()
Public Shared Sub DedPackAndGoImport
public:
static void DedPackAndGoImport()
static member DedPackAndGoImport : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPubblica

Metodo DedNetAcadCommandsDedPubblica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedPubblica()
Public Shared Sub DedPubblica
public:
static void DedPubblica()
static member DedPubblica : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedPwsCache

Metodo DedNetAcadCommandsDedPwsCache

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedPwsCache()
Public Shared Sub DedPwsCache
public:
static void DedPwsCache()
static member DedPwsCache : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicerca

Metodo DedNetAcadCommandsDedRicerca

Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicerca()
Public Shared Sub DedRicerca
public:
static void DedRicerca()
static member DedRicerca : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicercaDocumentale

Metodo DedNetAcadCommandsDedRicercaDocumentale

Apre la finestra della ricerca documentale.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicercaDocumentale()
Public Shared Sub DedRicercaDocumentale
public:
static void DedRicercaDocumentale()
static member DedRicercaDocumentale : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRicercaNew

Metodo DedNetAcadCommandsDedRicercaNew

Apre la finestra principale della ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedRicercaNew()
Public Shared Sub DedRicercaNew
public:
static void DedRicercaNew()
static member DedRicercaNew : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRil

Metodo DedNetAcadCommandsDedRil

Rilascia l'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedRil()
Public Shared Sub DedRil
public:
static void DedRil()
static member DedRil : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedRilMulti

Metodo DedNetAcadCommandsDedRilMulti

Effettua il rilascio multiplo del documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedRilMulti()
Public Shared Sub DedRilMulti
public:
static void DedRilMulti()
static member DedRilMulti : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedSalvaSup

Metodo DedNetAcadCommandsDedSalvaSup

Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedSalvaSup()
Public Shared Sub DedSalvaSup
public:
static void DedSalvaSup()
static member DedSalvaSup : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedSblocca

Metodo DedNetAcadCommandsDedSblocca

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedSblocca()
Public Shared Sub DedSblocca
public:
static void DedSblocca()
static member DedSblocca : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedStatoDoc

Metodo DedNetAcadCommandsDedStatoDoc

Visualizza lo stato dell'anagrafica e del documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedStatoDoc()
Public Shared Sub DedStatoDoc
public:
static void DedStatoDoc()
static member DedStatoDoc : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Metodo DedNetAcadCommands.DedUnRil

Metodo DedNetAcadCommandsDedUnRil

Toglie il rilascio all'anagrafica associata al documento correntemente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedUnRil()
Public Shared Sub DedUnRil
public:
static void DedUnRil()
static member DedUnRil : unit -> unit
Vedi anche

Documentazione

Classe DedNetAcadCommands


Classe DedNetAcadFileResolution
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadFileResolution

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class DedNetAcadFileResolution
Public NotInheritable Class DedNetAcadFileResolution
public ref class DedNetAcadFileResolution abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DedNetAcadFileResolution =  class end
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe DedNetAcadFileResolution.OnFileResolutionSostItem

Classe DedNetAcadFileResolutionOnFileResolutionSostItem
Gerarchia di ereditarietà
SystemObject
DedNetAcadDedNetAcadFileResolutionOnFileResolutionSostItem

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItem
Public Class OnFileResolutionSostItem
public ref class OnFileResolutionSostItem
type OnFileResolutionSostItem =  class end

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadFileResolutionOnFileResolutionSostItem |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Proprietà pubblica | PreviewFile |
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadFileResolution.OnFileResolutionSostItem

Costruttore DedNetAcadFileResolutionOnFileResolutionSostItem

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItem()
Public Sub New
public:
OnFileResolutionSostItem()
new : unit -> OnFileResolutionSostItem
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà di OnFileResolutionSostItem

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | DbFile |
Proprietà pubblica | OldFile |
Proprietà pubblica | PreviewFile |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.DbFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemDbFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbFile { get; set; }
Public Property DbFile As String
    Get
    Set
public:
property String^ DbFile {
    String^ get ();
    void set (String^ value);
}
member DbFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.OldFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemOldFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string OldFile { get; set; }
Public Property OldFile As String
    Get
    Set
public:
property String^ OldFile {
    String^ get ();
    void set (String^ value);
}
member OldFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Proprietà DedNetAcadFileResolution.OnFileResolutionSostItem.PreviewFile

Proprietà DedNetAcadFileResolutionOnFileResolutionSostItemPreviewFile

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string PreviewFile { get; set; }
Public Property PreviewFile As String
    Get
    Set
public:
property String^ PreviewFile {
    String^ get ();
    void set (String^ value);
}
member PreviewFile : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Campi di OnFileResolutionSostItem

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItem espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | DocGuid |
Torna su
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Campo DedNetAcadFileResolution.OnFileResolutionSostItem.DocGuid

Campo DedNetAcadFileResolutionOnFileResolutionSostItemDocGuid

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocGuid
Public DocGuid As Guid
public:
Guid DocGuid
val mutable DocGuid: Guid

Valore del campo

Tipo: Guid
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItem


Classe DedNetAcadFileResolution.OnFileResolutionSostItemList

Classe DedNetAcadFileResolutionOnFileResolutionSostItemList
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList DedNetAcadFileResolutionOnFileResolutionSostItem
DedNetAcadDedNetAcadFileResolutionOnFileResolutionSostItemList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class OnFileResolutionSostItemList : List<DedNetAcadFileResolutionOnFileResolutionSostItem>
Public Class OnFileResolutionSostItemList
    Inherits List(Of DedNetAcadFileResolutionOnFileResolutionSostItem)
public ref class OnFileResolutionSostItemList : public List<DedNetAcadFileResolutionOnFileResolutionSostItem^>
type OnFileResolutionSostItemList =
    class
        inherit List<DedNetAcadFileResolutionOnFileResolutionSostItem>
    end

Il tipo DedNetAcadFileResolutionOnFileResolutionSostItemList espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedNetAcadFileResolutionOnFileResolutionSostItemList |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedNetAcadFileResolution.OnFileResolutionSostItemList

Costruttore DedNetAcadFileResolutionOnFileResolutionSostItemList

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public OnFileResolutionSostItemList()
Public Sub New
public:
OnFileResolutionSostItemList()
new : unit -> OnFileResolutionSostItemList
Vedi anche

Documentazione

Classe DedNetAcadFileResolutionOnFileResolutionSostItemList


Enumerazione DedNetAcadFileResolution.RispostaUtenteSost

Enumerazione DedNetAcadFileResolutionRispostaUtenteSost

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum RispostaUtenteSost
Public Enumeration RispostaUtenteSost
public enum class RispostaUtenteSost
type RispostaUtenteSost
Membri
Nome | Valore | Descrizione
Si | 0 |
No | 1 |
SiTutti | 2 |
NoTutti | 3 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe Lua
Utilizzata per chiamare direttamente, in modo trasparente al .NET, funzioni LUA definite sia dai vari file lua del DedNetAcad che native di Top/Top_prt.
Gerarchia di ereditarietà
SystemObject
DedNetAcadLua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Lua =  class end

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
Torna su
Metodi
Nome | Descrizione
CreateEmptyLuaTable | Crea e restituisce una nuova table lua vuota, e vrappata.
CreateEmptyPrtArray | Crea e restituisce un nuovo array di parti vuoto.
CreateStructureForPackAndGoExport | Chiama l'omonima funzione lua.
CreateStructureForRilLavMulti | Chiama l'omonima funzione lua.
DbModPop | Ripristina il valore della variabile DBMOD.
DbModPush | Salva il valore della variabile DBMOD.
DedAcadGetDedIdDedRevFromPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DumpStack |
LNavRefreshPartIcon | Chiama l'omonima funzione lua.
LNavRefreshPartLabel | Chiama l'omonima funzione lua.
LNavSetDedIcon | Chiama l'omonima funzione lua.
SetAssemblyOldRevCodes | Chiama l'omonima funzione lua.
setfunhelp | Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.
top_aggtab | Chiama l'omonima funzione lua di aggiornamento generale della tabella
top_updcart | Chiama l'omonima funzione lua.
top_updtab | Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.
top_updtabrev | Chiama la funzione lua qsUpdateTabRev.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
TopSavePost | Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di Lua

Il tipo Lua espone i seguenti membri.

Proprietà
Nome | Descrizione
SilentUpdateDedDisOnOpen | Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.
Torna su
Vedi anche

Documentazione

Classe Lua


Proprietà Lua.SilentUpdateDedDisOnOpen

Proprietà LuaSilentUpdateDedDisOnOpen

Restituisce se è non nil la variabile globale lua SilentUpdateDedDisOnOpen per non visualizzare messaggi all'utente durante l'apertura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool SilentUpdateDedDisOnOpen { get; }
Public Shared ReadOnly Property SilentUpdateDedDisOnOpen As Boolean
    Get
public:
static property bool SilentUpdateDedDisOnOpen {
    bool get ();
}
static member SilentUpdateDedDisOnOpen : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe Lua


Metodi di Lua

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CreateEmptyLuaTable | Crea e restituisce una nuova table lua vuota, e vrappata.
CreateEmptyPrtArray | Crea e restituisce un nuovo array di parti vuoto.
CreateStructureForPackAndGoExport | Chiama l'omonima funzione lua.
CreateStructureForRilLavMulti | Chiama l'omonima funzione lua.
DbModPop | Ripristina il valore della variabile DBMOD.
DbModPush | Salva il valore della variabile DBMOD.
DedAcadGetDedIdDedRevFromPart | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.
DedAcadGetLolForDistSave | Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.
DumpStack |
LNavRefreshPartIcon | Chiama l'omonima funzione lua.
LNavRefreshPartLabel | Chiama l'omonima funzione lua.
LNavSetDedIcon | Chiama l'omonima funzione lua.
SetAssemblyOldRevCodes | Chiama l'omonima funzione lua.
setfunhelp | Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.
top_aggtab | Chiama l'omonima funzione lua di aggiornamento generale della tabella
top_updcart | Chiama l'omonima funzione lua.
top_updtab | Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.
top_updtabrev | Chiama la funzione lua qsUpdateTabRev.
TopEditAttrPost | Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.
TopSavePost | Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.
Torna su
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateEmptyLuaTable

Metodo LuaCreateEmptyLuaTable

Crea e restituisce una nuova table lua vuota, e vrappata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable CreateEmptyLuaTable()
Public Shared Function CreateEmptyLuaTable As LuaTable
public:
static LuaTable^ CreateEmptyLuaTable()
static member CreateEmptyLuaTable : unit -> LuaTable

Valore di ritorno

Tipo: LuaTable
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateEmptyPrtArray

Metodo LuaCreateEmptyPrtArray

Crea e restituisce un nuovo array di parti vuoto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray CreateEmptyPrtArray()
Public Shared Function CreateEmptyPrtArray As PartInfoArray
public:
static PartInfoArray^ CreateEmptyPrtArray()
static member CreateEmptyPrtArray : unit -> PartInfoArray

Valore di ritorno

Tipo: PartInfoArray
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateStructureForPackAndGoExport

Metodo LuaCreateStructureForPackAndGoExport

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CreateStructureForPackAndGoExport(
    DedCommandDocAnagrInfoList elementList
)
Public Shared Sub CreateStructureForPackAndGoExport (
    elementList As DedCommandDocAnagrInfoList
)
public:
static void CreateStructureForPackAndGoExport(
    DedCommandDocAnagrInfoList^ elementList
)
static member CreateStructureForPackAndGoExport :
        elementList : DedCommandDocAnagrInfoList -> unit

Parametri

elementList
Tipo: DedCommandDocAnagrInfoList
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CreateStructureForRilLavMulti

Metodo LuaCreateStructureForRilLavMulti

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CreateStructureForRilLavMulti(
    List<MultipleStateOperationPartInfoDoc> elementList
)
Public Shared Sub CreateStructureForRilLavMulti (
    elementList As List(Of MultipleStateOperationPartInfoDoc)
)
public:
static void CreateStructureForRilLavMulti(
    List<MultipleStateOperationPartInfoDoc^>^ elementList
)
static member CreateStructureForRilLavMulti :
        elementList : List<MultipleStateOperationPartInfoDoc> -> unit

Parametri

elementList
Tipo: System.Collections.GenericList MultipleStateOperationPartInfoDoc
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DbModPop

Metodo LuaDbModPop

Ripristina il valore della variabile DBMOD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DbModPop()
Public Shared Sub DbModPop
public:
static void DbModPop()
static member DbModPop : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DbModPush

Metodo LuaDbModPush

Salva il valore della variabile DBMOD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DbModPush()
Public Shared Sub DbModPush
public:
static void DbModPush()
static member DbModPush : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetDedIdDedRevFromPart

Metodo LuaDedAcadGetDedIdDedRevFromPart

Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere il dedid ed il dedrev data una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DedAcadGetDedIdDedRevFromPart(
    PartInfo prt,
    out string dedid,
    out string dedrev
)
Public Shared Sub DedAcadGetDedIdDedRevFromPart (
    prt As PartInfo,
    <OutAttribute> ByRef dedid As String,
    <OutAttribute> ByRef dedrev As String
)
public:
static void DedAcadGetDedIdDedRevFromPart(
    PartInfo^ prt,
    [OutAttribute] String^% dedid,
    [OutAttribute] String^% dedrev
)
static member DedAcadGetDedIdDedRevFromPart :
        prt : PartInfo *
        dedid : string byref *
        dedrev : string byref -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
dedid
Tipo: SystemString
dedrev
Tipo: SystemString
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DedAcadGetLolForDistSave

Metodo LuaDedAcadGetLolForDistSave

Chiama l'omonima funzione e ne restituisce il risultato. Serve per avere la lol per il salvataggio della distinta nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static LuaTable DedAcadGetLolForDistSave(
    LuaTable arg
)
Public Shared Function DedAcadGetLolForDistSave (
    arg As LuaTable
) As LuaTable
public:
static LuaTable^ DedAcadGetLolForDistSave(
    LuaTable^ arg
)
static member DedAcadGetLolForDistSave :
        arg : LuaTable -> LuaTable

Parametri

arg
Tipo: LuaTable

Valore di ritorno

Tipo: LuaTable
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DumpStack

Metodo LuaDumpStack

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DumpStack()
Public Shared Sub DumpStack
public:
static void DumpStack()
static member DumpStack : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavRefreshPartIcon

Metodo LuaLNavRefreshPartIcon

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LNavRefreshPartIcon(
    PartInfo prt
)
Public Shared Sub LNavRefreshPartIcon (
    prt As PartInfo
)
public:
static void LNavRefreshPartIcon(
    PartInfo^ prt
)
static member LNavRefreshPartIcon :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavRefreshPartLabel

Metodo LuaLNavRefreshPartLabel

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LNavRefreshPartLabel(
    PartInfo prt
)
Public Shared Sub LNavRefreshPartLabel (
    prt As PartInfo
)
public:
static void LNavRefreshPartLabel(
    PartInfo^ prt
)
static member LNavRefreshPartLabel :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.LNavSetDedIcon

Metodo LuaLNavSetDedIcon

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void LNavSetDedIcon(
    PartInfo prt,
    int dwgstatus,
    int anagrStatus
)
Public Shared Sub LNavSetDedIcon (
    prt As PartInfo,
    dwgstatus As Integer,
    anagrStatus As Integer
)
public:
static void LNavSetDedIcon(
    PartInfo^ prt,
    int dwgstatus,
    int anagrStatus
)
static member LNavSetDedIcon :
        prt : PartInfo *
        dwgstatus : int *
        anagrStatus : int -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
dwgstatus
Tipo: SystemInt32
anagrStatus
Tipo: SystemInt32
Vedi anche

Documentazione

Classe Lua


Metodo Lua.SetAssemblyOldRevCodes

Metodo LuaSetAssemblyOldRevCodes

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetAssemblyOldRevCodes(
    ListObjToUpdate elementList
)
Public Shared Sub SetAssemblyOldRevCodes (
    elementList As ListObjToUpdate
)
public:
static void SetAssemblyOldRevCodes(
    ListObjToUpdate^ elementList
)
static member SetAssemblyOldRevCodes :
        elementList : ListObjToUpdate -> unit

Parametri

elementList
Tipo: ListObjToUpdate
Vedi anche

Documentazione

Classe Lua


Metodo Lua.setfunhelp

Metodo Luasetfunhelp

Chiama l'omonima funzione per la registrazione dell'help per i vari comandi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void setfunhelp(
    string cmdName,
    string helpFullFileName,
    string topicName
)
Public Shared Sub setfunhelp (
    cmdName As String,
    helpFullFileName As String,
    topicName As String
)
public:
static void setfunhelp(
    String^ cmdName,
    String^ helpFullFileName,
    String^ topicName
)
static member setfunhelp :
        cmdName : string *
        helpFullFileName : string *
        topicName : string -> unit

Parametri

cmdName
Tipo: SystemString
Nome del comando.
helpFullFileName
Tipo: SystemString
Nome completo del file di help.
topicName
Tipo: SystemString
Nome univoco argomento.
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_aggtab

Metodo Luatop_aggtab

Chiama l'omonima funzione lua di aggiornamento generale della tabella

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void top_aggtab()
Public Shared Sub top_aggtab
public:
static void top_aggtab()
static member top_aggtab : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updcart

Metodo Luatop_updcart

Chiama l'omonima funzione lua.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void top_updcart()
Public Shared Sub top_updcart
public:
static void top_updcart()
static member top_updcart : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updtab

Metodo Luatop_updtab

Chiama l'omonima funzione lua. Se prt è null viene aggiornata tutta la tabella di pallinatura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void top_updtab(
    PartInfo prt
)
Public Shared Sub top_updtab (
    prt As PartInfo
)
public:
static void top_updtab(
    PartInfo^ prt
)
static member top_updtab :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe Lua


Metodo Lua.top_updtabrev

Metodo Luatop_updtabrev

Chiama la funzione lua qsUpdateTabRev.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void top_updtabrev()
Public Shared Sub top_updtabrev
public:
static void top_updtabrev()
static member top_updtabrev : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.TopEditAttrPost

Metodo LuaTopEditAttrPost

Lancia LuaStartEvent() con l'evento TopEditAttrPost passandogli la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void TopEditAttrPost(
    PartInfo prt
)
Public Shared Sub TopEditAttrPost (
    prt As PartInfo
)
public:
static void TopEditAttrPost(
    PartInfo^ prt
)
static member TopEditAttrPost :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte da passare all'evento.
Vedi anche

Documentazione

Classe Lua


Metodo Lua.TopSavePost

Metodo LuaTopSavePost

Lancia LuaStartEvent() con l'evento TopSavePost passandogli la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void TopSavePost(
    PartInfo prt
)
Public Shared Sub TopSavePost (
    prt As PartInfo
)
public:
static void TopSavePost(
    PartInfo^ prt
)
static member TopSavePost :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte da passare all'evento.
Vedi anche

Documentazione

Classe Lua


Enumerazione PackAndGoContext
Definizione possibili contesti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoContext
Public Enumeration PackAndGoContext
public enum class PackAndGoContext
type PackAndGoContext
Membri
Nome | Valore | Descrizione
Import | 0 |
Export | 1 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoExport
Esportazione packAndgo Autocad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedDocumentCommand
DedNetAcadPackAndGoExport

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoExport : DedDocumentCommand
Public Class PackAndGoExport
    Inherits DedDocumentCommand
public ref class PackAndGoExport : public DedDocumentCommand
type PackAndGoExport =
    class
        inherit DedDocumentCommand
    end

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | DocumentInfos | (Ereditato da DedDocumentCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedDocumentCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | RunFromAcad | Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedDocumentCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedDocumentCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | DocumentInfos | (Ereditato da DedDocumentCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedDocumentCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | RunFromAcad | Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport


Proprietà PackAndGoExport.NeedParameters

Proprietà PackAndGoExportNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoExport


Proprietà PackAndGoExport.RunFromAcad

Proprietà PackAndGoExportRunFromAcad

Imposta/Restituisce se il comando è stato lanciato dalle icone di Autocad o no

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RunFromAcad { get; set; }
Public Property RunFromAcad As Boolean
    Get
    Set
public:
property bool RunFromAcad {
    bool get ();
    void set (bool value);
}
member RunFromAcad : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoExport


Metodi di PackAndGoExport

Il tipo PackAndGoExport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedDocumentCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedDocumentCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedDocumentCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedDocumentCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedDocumentCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.ClearCommand

Metodo PackAndGoExportClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.Enabled

Metodo PackAndGoExportEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.ExecuteCommand

Metodo PackAndGoExportExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PackAndGoExport


Metodo PackAndGoExport.SetContext

Metodo PackAndGoExportSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoExport


Classe PackAndGoImport
Esportazione packAndgo Autocad
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadPackAndGoImport

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImport : DedCommand
Public Class PackAndGoImport
    Inherits DedCommand
public ref class PackAndGoImport : public DedCommand
type PackAndGoImport =
    class
        inherit DedCommand
    end

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport


Proprietà PackAndGoImport.NeedParameters

Proprietà PackAndGoImportNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Deve avere un documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImport


Metodi di PackAndGoImport

Il tipo PackAndGoImport espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.ClearCommand

Metodo PackAndGoImportClearCommand

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.Enabled

Metodo PackAndGoImportEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.ExecuteCommand

Metodo PackAndGoImportExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PackAndGoImport


Metodo PackAndGoImport.SetContext

Metodo PackAndGoImportSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PackAndGoImport


Enumerazione PackAndGoImportAttrStatus
Stato attributi in validazione importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportAttrStatus
Public Enumeration PackAndGoImportAttrStatus
public enum class PackAndGoImportAttrStatus
type PackAndGoImportAttrStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Compare | 1 |
MandatoryMissing | 2 |
Undefined | 3 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione PackAndGoImportDedCases
Possibili casi del database in fase di importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportDedCases
Public Enumeration PackAndGoImportDedCases
public enum class PackAndGoImportDedCases
type PackAndGoImportDedCases
Membri
Nome | Valore | Descrizione
None | 0 |
NoDed | 1 |
DedRemote | 2 |
DedVpn | 3 |
UserFolder | 4 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoImportingStructureInfo
Oggetto di servizio per l'impostazione delle informazioni di descrittore e operazione
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoImportingStructureInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoImportingStructureInfo
Public Class PackAndGoImportingStructureInfo
public ref class PackAndGoImportingStructureInfo
type PackAndGoImportingStructureInfo =  class end

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoImportingStructureInfo |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoImportingStructureInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo()
Public Sub New
public:
PackAndGoImportingStructureInfo()
new : unit -> PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Metodi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Metodo PackAndGoImportingStructureInfo.Clone

Metodo PackAndGoImportingStructureInfoClone

Clonazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo Clone()
Public Function Clone As PackAndGoImportingStructureInfo
public:
PackAndGoImportingStructureInfo^ Clone()
member Clone : unit -> PackAndGoImportingStructureInfo

Valore di ritorno

Tipo: PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campi di PackAndGoImportingStructureInfo

Il tipo PackAndGoImportingStructureInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AttrStatus |
Campo pubblico | AttrStatusRepresentation |
Campo pubblico | Checkable |
Campo pubblico | DocAlreadyCompared |
Campo pubblico | ImportNote |
Campo pubblico | OperationStatus |
Campo pubblico | PckImportOperation |
Campo pubblico | PckNdDescr |
Torna su
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.AttrStatus

Campo PackAndGoImportingStructureInfoAttrStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportAttrStatus AttrStatus
Public AttrStatus As PackAndGoImportAttrStatus
public:
PackAndGoImportAttrStatus AttrStatus
val mutable AttrStatus: PackAndGoImportAttrStatus

Valore del campo

Tipo: PackAndGoImportAttrStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.AttrStatusRepresentation

Campo PackAndGoImportingStructureInfoAttrStatusRepresentation

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Image AttrStatusRepresentation
Public AttrStatusRepresentation As Image
public:
Image^ AttrStatusRepresentation
val mutable AttrStatusRepresentation: Image

Valore del campo

Tipo: Image
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.Checkable

Campo PackAndGoImportingStructureInfoCheckable

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Checkable
Public Checkable As Boolean
public:
bool Checkable
val mutable Checkable: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.DocAlreadyCompared

Campo PackAndGoImportingStructureInfoDocAlreadyCompared

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocAlreadyCompared
Public DocAlreadyCompared As Boolean
public:
bool DocAlreadyCompared
val mutable DocAlreadyCompared: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.ImportNote

Campo PackAndGoImportingStructureInfoImportNote

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ImportNote
Public ImportNote As String
public:
String^ ImportNote
val mutable ImportNote: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.OperationStatus

Campo PackAndGoImportingStructureInfoOperationStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperationStatus OperationStatus
Public OperationStatus As PackAndGoImportOperationStatus
public:
PackAndGoImportOperationStatus OperationStatus
val mutable OperationStatus: PackAndGoImportOperationStatus

Valore del campo

Tipo: PackAndGoImportOperationStatus
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.PckImportOperation

Campo PackAndGoImportingStructureInfoPckImportOperation

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation PckImportOperation
Public PckImportOperation As PackAndGoImportOperation
public:
PackAndGoImportOperation PckImportOperation
val mutable PckImportOperation: PackAndGoImportOperation

Valore del campo

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Campo PackAndGoImportingStructureInfo.PckNdDescr

Campo PackAndGoImportingStructureInfoPckNdDescr

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor PckNdDescr
Public PckNdDescr As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ PckNdDescr
val mutable PckNdDescr: PackAndGoNodeDescriptor

Valore del campo

Tipo: PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoImportingStructureInfo


Enumerazione PackAndGoImportOperation
Definizione possibili azioni su oggetti importazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperation
Public Enumeration PackAndGoImportOperation
public enum class PackAndGoImportOperation
type PackAndGoImportOperation
Membri
Nome | Valore | Descrizione
Ignora | 0 |
Sovrascrivi | 1 |
Codifica | 2 |
Associa | 3 |
Clona | 4 |
Salta | 5 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Enumerazione PackAndGoImportOperationStatus
Stato di validazione dell'operazione ( per ora non usata sempre Ok )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public enum PackAndGoImportOperationStatus
Public Enumeration PackAndGoImportOperationStatus
public enum class PackAndGoImportOperationStatus
type PackAndGoImportOperationStatus
Membri
Nome | Valore | Descrizione
Ok | 0 |
Error | 1 |
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe PackAndGoNodeDescriptor
Descrittore singolo nodo di struttura
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoNodeDescriptor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptor
<SerializableAttribute>
Public Class PackAndGoNodeDescriptor
[SerializableAttribute]
public ref class PackAndGoNodeDescriptor
[<SerializableAttribute>]
type PackAndGoNodeDescriptor =  class end

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(AcadDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeDescriptor

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptor | Costruttore senza parametri per la serializzazione
Metodo pubblico | PackAndGoNodeDescriptor(AcadDocStructInfo) | Costruttore dell'oggetto
Metodo pubblico | PackAndGoNodeDescriptor(DedDoc, DedData) | Costruttore alternativo con informazioni documentali ed anagrafiche.
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor

Costruttore senza parametri per la serializzazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor()
Public Sub New
public:
PackAndGoNodeDescriptor()
new : unit -> PackAndGoNodeDescriptor
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor (AcadDocStructInfo)
Costruttore dell'oggetto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    AcadDocStructInfo ds
)
Public Sub New (
    ds As AcadDocStructInfo
)
public:
PackAndGoNodeDescriptor(
    AcadDocStructInfo^ ds
)
new :
        ds : AcadDocStructInfo -> PackAndGoNodeDescriptor

Parametri

ds
Tipo: DedNetAcadAcadDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Costruttore PackAndGoNodeDescriptor (DedDoc, DedData)
Costruttore alternativo con informazioni documentali ed anagrafiche.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor(
    DedDoc ddoc,
    DedData ddata
)
Public Sub New (
    ddoc As DedDoc,
    ddata As DedData
)
public:
PackAndGoNodeDescriptor(
    DedDoc^ ddoc,
    DedData^ ddata
)
new :
        ddoc : DedDoc *
        ddata : DedData -> PackAndGoNodeDescriptor

Parametri

ddoc
Tipo: DedDoc
Documento
ddata
Tipo: DedData
Anagrafica
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor
Overload di PackAndGoNodeDescriptor


Proprietà di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Children | Sotto struttura dei descrittori
Proprietà pubblica | Context | Eventuale contesto di associazione
Proprietà pubblica | DbPath | Path della famiglia dell'anagrafica associata
Proprietà pubblica | DedId | Id della angrafica
Proprietà pubblica | DedRev | Revisione anagrafica
Proprietà pubblica | DocId | Id del documento
Proprietà pubblica | DocIsMovingDestination | Indica se il documento è stato movato.
Proprietà pubblica | DocRowVer | Revisione del documento
Proprietà pubblica | FullFileName | Percorso assoluto del file
Proprietà pubblica | HasData | Restituisce se il documento è collegato ad una anagrafica.
Proprietà pubblica | InfoUser | Tassello utente dell'anagrafica
Proprietà pubblica | MakeAnagrObs | Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )
Proprietà pubblica | MovedByMasterAfterSend |
Proprietà pubblica | Progr | Progressivo dell'anagrafica
Proprietà pubblica | RelativeFileName | Percorso relativo alla root del packandgo
Proprietà pubblica | RootedPath | Path rooted del documento
Proprietà pubblica | ToBeMoved | Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Children

Proprietà PackAndGoNodeDescriptorChildren

Sotto struttura dei descrittori

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Children { get; set; }
Public Property Children As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Children {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Children : PackAndGoNodeDescriptors with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Context

Proprietà PackAndGoNodeDescriptorContext

Eventuale contesto di associazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocContextEnum Context { get; set; }
Public Property Context As DedDocContextEnum
    Get
    Set
public:
property DedDocContextEnum Context {
    DedDocContextEnum get ();
    void set (DedDocContextEnum value);
}
member Context : DedDocContextEnum with get, set

Valore della proprietà

Tipo: DedDocContextEnum
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DbPath

Proprietà PackAndGoNodeDescriptorDbPath

Path della famiglia dell'anagrafica associata

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbPath { get; set; }
Public Property DbPath As String
    Get
    Set
public:
property String^ DbPath {
    String^ get ();
    void set (String^ value);
}
member DbPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DedId

Proprietà PackAndGoNodeDescriptorDedId

Id della angrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedId { get; set; }
Public Property DedId As String
    Get
    Set
public:
property String^ DedId {
    String^ get ();
    void set (String^ value);
}
member DedId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DedRev

Proprietà PackAndGoNodeDescriptorDedRev

Revisione anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedRev { get; set; }
Public Property DedRev As String
    Get
    Set
public:
property String^ DedRev {
    String^ get ();
    void set (String^ value);
}
member DedRev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocId

Proprietà PackAndGoNodeDescriptorDocId

Id del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocId { get; set; }
Public Property DocId As Guid
    Get
    Set
public:
property Guid DocId {
    Guid get ();
    void set (Guid value);
}
member DocId : Guid with get, set

Valore della proprietà

Tipo: Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocIsMovingDestination

Proprietà PackAndGoNodeDescriptorDocIsMovingDestination

Indica se il documento è stato movato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool DocIsMovingDestination { get; set; }
Public Property DocIsMovingDestination As Boolean
    Get
    Set
public:
property bool DocIsMovingDestination {
    bool get ();
    void set (bool value);
}
member DocIsMovingDestination : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.DocRowVer

Proprietà PackAndGoNodeDescriptorDocRowVer

Revisione del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Guid DocRowVer { get; set; }
Public Property DocRowVer As Guid
    Get
    Set
public:
property Guid DocRowVer {
    Guid get ();
    void set (Guid value);
}
member DocRowVer : Guid with get, set

Valore della proprietà

Tipo: Guid
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.FullFileName

Proprietà PackAndGoNodeDescriptorFullFileName

Percorso assoluto del file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; set; }
Public Property FullFileName As String
    Get
    Set
public:
property String^ FullFileName {
    String^ get ();
    void set (String^ value);
}
member FullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.HasData

Proprietà PackAndGoNodeDescriptorHasData

Restituisce se il documento è collegato ad una anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool HasData { get; }
Public ReadOnly Property HasData As Boolean
    Get
public:
property bool HasData {
    bool get ();
}
member HasData : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.InfoUser

Proprietà PackAndGoNodeDescriptorInfoUser

Tassello utente dell'anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.MakeAnagrObs

Proprietà PackAndGoNodeDescriptorMakeAnagrObs

Restituisce/Imposta se deve impostare l'anagrafica obsoleta e scollegare il documento ( usato nel caso Master/Slave )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MakeAnagrObs { get; set; }
Public Property MakeAnagrObs As Boolean
    Get
    Set
public:
property bool MakeAnagrObs {
    bool get ();
    void set (bool value);
}
member MakeAnagrObs : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.MovedByMasterAfterSend

Proprietà PackAndGoNodeDescriptorMovedByMasterAfterSend

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MovedByMasterAfterSend { get; set; }
Public Property MovedByMasterAfterSend As Boolean
    Get
    Set
public:
property bool MovedByMasterAfterSend {
    bool get ();
    void set (bool value);
}
member MovedByMasterAfterSend : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.Progr

Proprietà PackAndGoNodeDescriptorProgr

Progressivo dell'anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.RelativeFileName

Proprietà PackAndGoNodeDescriptorRelativeFileName

Percorso relativo alla root del packandgo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RelativeFileName { get; set; }
Public Property RelativeFileName As String
    Get
    Set
public:
property String^ RelativeFileName {
    String^ get ();
    void set (String^ value);
}
member RelativeFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.RootedPath

Proprietà PackAndGoNodeDescriptorRootedPath

Path rooted del documento

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string RootedPath { get; set; }
Public Property RootedPath As String
    Get
    Set
public:
property String^ RootedPath {
    String^ get ();
    void set (String^ value);
}
member RootedPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Proprietà PackAndGoNodeDescriptor.ToBeMoved

Proprietà PackAndGoNodeDescriptorToBeMoved

Restituisce/Imposta se deve creare il .moved ( usato nel caso Master/Slave )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ToBeMoved { get; set; }
Public Property ToBeMoved As Boolean
    Get
    Set
public:
property bool ToBeMoved {
    bool get ();
    void set (bool value);
}
member ToBeMoved : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodi di PackAndGoNodeDescriptor

Il tipo PackAndGoNodeDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Equals | (Sovrascrive ObjectEquals(Object).)
Metodo pubblico | GetHashCode | (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | IsSameVersion | Controlla se la versione passata coincide con quella del nodo.
Metodo pubblico | MatchRelativeFileName | Controlla il match tra il nodo in esame ed il percorso relativo passato
Metodo pubblico | ToString | (Sovrascrive ObjectToString.)
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.Equals

Metodo PackAndGoNodeDescriptorEquals

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.GetHashCode

Metodo PackAndGoNodeDescriptorGetHashCode

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.IsSameVersion

Metodo PackAndGoNodeDescriptorIsSameVersion

Controlla se la versione passata coincide con quella del nodo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsSameVersion(
    Guid docRowVer
)
Public Function IsSameVersion (
    docRowVer As Guid
) As Boolean
public:
bool IsSameVersion(
    Guid docRowVer
)
member IsSameVersion :
        docRowVer : Guid -> bool

Parametri

docRowVer
Tipo: SystemGuid

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.MatchRelativeFileName

Metodo PackAndGoNodeDescriptorMatchRelativeFileName

Controlla il match tra il nodo in esame ed il percorso relativo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool MatchRelativeFileName(
    string relativePath
)
Public Function MatchRelativeFileName (
    relativePath As String
) As Boolean
public:
bool MatchRelativeFileName(
    String^ relativePath
)
member MatchRelativeFileName :
        relativePath : string -> bool

Parametri

relativePath
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Metodo PackAndGoNodeDescriptor.ToString

Metodo PackAndGoNodeDescriptorToString

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptor


Classe PackAndGoNodeDescriptors
Classe gestione lista nodi di struttura
Gerarchia di ereditarietà
SystemObject
System.Collections.GenericList PackAndGoNodeDescriptor
DedNetAcadPackAndGoNodeDescriptors

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoNodeDescriptors : List<PackAndGoNodeDescriptor>
<SerializableAttribute>
Public Class PackAndGoNodeDescriptors
    Inherits List(Of PackAndGoNodeDescriptor)
[SerializableAttribute]
public ref class PackAndGoNodeDescriptors : public List<PackAndGoNodeDescriptor^>
[<SerializableAttribute>]
type PackAndGoNodeDescriptors =
    class
        inherit List<PackAndGoNodeDescriptor>
    end

Il tipo PackAndGoNodeDescriptors espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeDescriptors |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeDescriptors

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors()
Public Sub New
public:
PackAndGoNodeDescriptors()
new : unit -> PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoNodeDescriptors


Classe PackAndGoNodeWrapper
Classe rappresentante l'oggetto nodo nel controllo treeList del form
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoNodeWrapper

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PackAndGoNodeWrapper
Public Class PackAndGoNodeWrapper
public ref class PackAndGoNodeWrapper
type PackAndGoNodeWrapper =  class end

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, AcadDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'AcadDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoNodeWrapper

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | PackAndGoNodeWrapper(DedDoc, PackAndGoContext) | Costrutture basato su DedDoc
Metodo pubblico | PackAndGoNodeWrapper(DedData, AcadDocStructInfo, PackAndGoContext) | Costruttore del descrittore
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Costruttore PackAndGoNodeWrapper (DedDoc, PackAndGoContext)
Costrutture basato su DedDoc

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedDoc ddoc,
    PackAndGoContext context
)
Public Sub New (
    ddoc As DedDoc,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedDoc^ ddoc,
    PackAndGoContext context
)
new :
        ddoc : DedDoc *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddoc
Tipo: DedDoc
context
Tipo: DedNetAcadPackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper


Costruttore PackAndGoNodeWrapper (DedData, AcadDocStructInfo, PackAndGoContext)
Costruttore del descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper(
    DedData ddata,
    AcadDocStructInfo acadDsInfo,
    PackAndGoContext context
)
Public Sub New (
    ddata As DedData,
    acadDsInfo As AcadDocStructInfo,
    context As PackAndGoContext
)
public:
PackAndGoNodeWrapper(
    DedData^ ddata,
    AcadDocStructInfo^ acadDsInfo,
    PackAndGoContext context
)
new :
        ddata : DedData *
        acadDsInfo : AcadDocStructInfo *
        context : PackAndGoContext -> PackAndGoNodeWrapper

Parametri

ddata
Tipo: DedData
acadDsInfo
Tipo: DedNetAcadAcadDocStructInfo
context
Tipo: DedNetAcadPackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper
Overload di PackAndGoNodeWrapper


Proprietà di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Context | Contesto dell'operazione (import/export)
Proprietà pubblica | Data | Anagrafica di riferimento del nodo rappresentante una anagrafica
Proprietà pubblica | DedDoc |
Proprietà pubblica | DedType | Famiglia nella quale codificare il documento (import)
Proprietà pubblica | DestRoot | Root di destinazione del file
Proprietà pubblica | DocStructInfo | Ritorna l'AcadDocStructInfo di riferimento per il descrittore
Proprietà pubblica | FullFileName | Percorso assoluto del file che identifica il nodo
Proprietà pubblica | ImportStructureInfo | Informazioni di importazione associabili al descrittore
Proprietà pubblica | InfoUser | Infouser impostato da pers Lua
Proprietà pubblica | InvolvedInImportOperations | Indica se l'oggetto sarà coinvolto nelle operazioni di import
Proprietà pubblica | IsDataNode | Ritorna vero se il nodo rappresenta una anagrafica
Proprietà pubblica | NewFullFileName | Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )
Proprietà pubblica | Node | Ritorna/Importa l'oggetto nodo nativo corrispondente
Proprietà pubblica | NodeInfoCompleted | Restituisce se il nodo ha tutte le informazioni necessarie
Proprietà pubblica | OutofPackGo |
Proprietà pubblica | Progr | Progr impostato da pers Lua
Proprietà pubblica | Rev | Rev impostato da pers Lua
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Context

Proprietà PackAndGoNodeWrapperContext

Contesto dell'operazione (import/export)

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoContext Context { get; set; }
Public Property Context As PackAndGoContext
    Get
    Set
public:
property PackAndGoContext Context {
    PackAndGoContext get ();
    void set (PackAndGoContext value);
}
member Context : PackAndGoContext with get, set

Valore della proprietà

Tipo: PackAndGoContext
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Data

Proprietà PackAndGoNodeWrapperData

Anagrafica di riferimento del nodo rappresentante una anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DedDoc

Proprietà PackAndGoNodeWrapperDedDoc

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc DedDoc { get; }
Public ReadOnly Property DedDoc As DedDoc
    Get
public:
property DedDoc^ DedDoc {
    DedDoc^ get ();
}
member DedDoc : DedDoc with get

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DedType

Proprietà PackAndGoNodeWrapperDedType

Famiglia nella quale codificare il documento (import)

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedType DedType { get; set; }
Public Property DedType As DedType
    Get
    Set
public:
property DedType^ DedType {
    DedType^ get ();
    void set (DedType^ value);
}
member DedType : DedType with get, set

Valore della proprietà

Tipo: DedType
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DestRoot

Proprietà PackAndGoNodeWrapperDestRoot

Root di destinazione del file

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DestRoot { get; set; }
Public Property DestRoot As String
    Get
    Set
public:
property String^ DestRoot {
    String^ get ();
    void set (String^ value);
}
member DestRoot : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.DocStructInfo

Proprietà PackAndGoNodeWrapperDocStructInfo

Ritorna l'AcadDocStructInfo di riferimento per il descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AcadDocStructInfo DocStructInfo { get; }
Public ReadOnly Property DocStructInfo As AcadDocStructInfo
    Get
public:
property AcadDocStructInfo^ DocStructInfo {
    AcadDocStructInfo^ get ();
}
member DocStructInfo : AcadDocStructInfo with get

Valore della proprietà

Tipo: AcadDocStructInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.FullFileName

Proprietà PackAndGoNodeWrapperFullFileName

Percorso assoluto del file che identifica il nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string FullFileName { get; }
Public ReadOnly Property FullFileName As String
    Get
public:
property String^ FullFileName {
    String^ get ();
}
member FullFileName : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.ImportStructureInfo

Proprietà PackAndGoNodeWrapperImportStructureInfo

Informazioni di importazione associabili al descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportingStructureInfo ImportStructureInfo { get; set; }
Public Property ImportStructureInfo As PackAndGoImportingStructureInfo
    Get
    Set
public:
property PackAndGoImportingStructureInfo^ ImportStructureInfo {
    PackAndGoImportingStructureInfo^ get ();
    void set (PackAndGoImportingStructureInfo^ value);
}
member ImportStructureInfo : PackAndGoImportingStructureInfo with get, set

Valore della proprietà

Tipo: PackAndGoImportingStructureInfo
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.InfoUser

Proprietà PackAndGoNodeWrapperInfoUser

Infouser impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string InfoUser { get; set; }
Public Property InfoUser As String
    Get
    Set
public:
property String^ InfoUser {
    String^ get ();
    void set (String^ value);
}
member InfoUser : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.InvolvedInImportOperations

Proprietà PackAndGoNodeWrapperInvolvedInImportOperations

Indica se l'oggetto sarà coinvolto nelle operazioni di import

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool InvolvedInImportOperations { get; set; }
Public Property InvolvedInImportOperations As Boolean
    Get
    Set
public:
property bool InvolvedInImportOperations {
    bool get ();
    void set (bool value);
}
member InvolvedInImportOperations : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.IsDataNode

Proprietà PackAndGoNodeWrapperIsDataNode

Ritorna vero se il nodo rappresenta una anagrafica

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsDataNode { get; }
Public ReadOnly Property IsDataNode As Boolean
    Get
public:
property bool IsDataNode {
    bool get ();
}
member IsDataNode : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.NewFullFileName

Proprietà PackAndGoNodeWrapperNewFullFileName

Indica il nuovo file da utilizzare nel caso di Salta ( impostato solo tramite Lua )

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string NewFullFileName { get; set; }
Public Property NewFullFileName As String
    Get
    Set
public:
property String^ NewFullFileName {
    String^ get ();
    void set (String^ value);
}
member NewFullFileName : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Node

Proprietà PackAndGoNodeWrapperNode

Ritorna/Importa l'oggetto nodo nativo corrispondente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public TreeListNode Node { get; set; }
Public Property Node As TreeListNode
    Get
    Set
public:
property TreeListNode^ Node {
    TreeListNode^ get ();
    void set (TreeListNode^ value);
}
member Node : TreeListNode with get, set

Valore della proprietà

Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.NodeInfoCompleted

Proprietà PackAndGoNodeWrapperNodeInfoCompleted

Restituisce se il nodo ha tutte le informazioni necessarie

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool NodeInfoCompleted { get; }
Public ReadOnly Property NodeInfoCompleted As Boolean
    Get
public:
property bool NodeInfoCompleted {
    bool get ();
}
member NodeInfoCompleted : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.OutofPackGo

Proprietà PackAndGoNodeWrapperOutofPackGo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool OutofPackGo { get; set; }
Public Property OutofPackGo As Boolean
    Get
    Set
public:
property bool OutofPackGo {
    bool get ();
    void set (bool value);
}
member OutofPackGo : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Progr

Proprietà PackAndGoNodeWrapperProgr

Progr impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Progr { get; set; }
Public Property Progr As String
    Get
    Set
public:
property String^ Progr {
    String^ get ();
    void set (String^ value);
}
member Progr : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Proprietà PackAndGoNodeWrapper.Rev

Proprietà PackAndGoNodeWrapperRev

Rev impostato da pers Lua

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Rev { get; set; }
Public Property Rev As String
    Get
    Set
public:
property String^ Rev {
    String^ get ();
    void set (String^ value);
}
member Rev : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodi di PackAndGoNodeWrapper

Il tipo PackAndGoNodeWrapper espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Clone | Clonazione dell'oggetto.
Metodo pubblico | SetData | Setta i dati sul nodo
Metodo pubblico | SetNodeIcon | Setta l'icona sul nodo
Torna su
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.Clone

Metodo PackAndGoNodeWrapperClone

Clonazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeWrapper Clone()
Public Function Clone As PackAndGoNodeWrapper
public:
PackAndGoNodeWrapper^ Clone()
member Clone : unit -> PackAndGoNodeWrapper

Valore di ritorno

Tipo: PackAndGoNodeWrapper
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.SetData

Metodo PackAndGoNodeWrapperSetData

Setta i dati sul nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetData(
    TreeListNode node
)
Public Sub SetData (
    node As TreeListNode
)
public:
void SetData(
    TreeListNode^ node
)
member SetData :
        node : TreeListNode -> unit

Parametri

node
Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Metodo PackAndGoNodeWrapper.SetNodeIcon

Metodo PackAndGoNodeWrapperSetNodeIcon

Setta l'icona sul nodo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetNodeIcon(
    ImageList il,
    TreeListNode node
)
Public Sub SetNodeIcon (
    il As ImageList,
    node As TreeListNode
)
public:
void SetNodeIcon(
    ImageList^ il,
    TreeListNode^ node
)
member SetNodeIcon :
        il : ImageList *
        node : TreeListNode -> unit

Parametri

il
Tipo: System.Windows.FormsImageList
node
Tipo: TreeListNode
Vedi anche

Documentazione

Classe PackAndGoNodeWrapper


Classe PackAndGoStructureDescriptor
Descrittore di tutta la struttura che viene serializzato. Contiene informazioni sul database e sulla struttura esportata
Gerarchia di ereditarietà
SystemObject
DedNetAcadPackAndGoStructureDescriptor

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class PackAndGoStructureDescriptor
<SerializableAttribute>
Public Class PackAndGoStructureDescriptor
[SerializableAttribute]
public ref class PackAndGoStructureDescriptor
[<SerializableAttribute>]
type PackAndGoStructureDescriptor =  class end

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PackAndGoStructureDescriptor | Costrutture della classe
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PackAndGoStructureDescriptor

Costrutture della classe

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor()
Public Sub New
public:
PackAndGoStructureDescriptor()
new : unit -> PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AlreadyImported | Indica se il pacchetto è già stato importato.
Proprietà pubblica | CorporateId | Identificativo aziendale
Proprietà pubblica | DbType | Ritorna il tipo di database. Può essere master o slave
Proprietà pubblica | DescriptorFullPath | Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore
Proprietà pubblica | MajorVer | Identificativo della versione
Proprietà pubblica | MinorVer | Identificativo della versione
Proprietà pubblica | Structure | Sotto struttura dei descrittori
Proprietà pubblica | UserId | Identificativo dell'utente che ha eseguito l'operazione
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.AlreadyImported

Proprietà PackAndGoStructureDescriptorAlreadyImported

Indica se il pacchetto è già stato importato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AlreadyImported { get; set; }
Public Property AlreadyImported As Boolean
    Get
    Set
public:
property bool AlreadyImported {
    bool get ();
    void set (bool value);
}
member AlreadyImported : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.CorporateId

Proprietà PackAndGoStructureDescriptorCorporateId

Identificativo aziendale

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string CorporateId { get; set; }
Public Property CorporateId As String
    Get
    Set
public:
property String^ CorporateId {
    String^ get ();
    void set (String^ value);
}
member CorporateId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.DbType

Proprietà PackAndGoStructureDescriptorDbType

Ritorna il tipo di database. Può essere master o slave

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DbType { get; set; }
Public Property DbType As String
    Get
    Set
public:
property String^ DbType {
    String^ get ();
    void set (String^ value);
}
member DbType : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.DescriptorFullPath

Proprietà PackAndGoStructureDescriptorDescriptorFullPath

Percorso assoluto del xml. Serve per calcolare i percorsi relativi dato il percorso del descrittore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DescriptorFullPath { get; set; }
Public Property DescriptorFullPath As String
    Get
    Set
public:
property String^ DescriptorFullPath {
    String^ get ();
    void set (String^ value);
}
member DescriptorFullPath : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.MajorVer

Proprietà PackAndGoStructureDescriptorMajorVer

Identificativo della versione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MajorVer { get; set; }
Public Property MajorVer As Integer
    Get
    Set
public:
property int MajorVer {
    int get ();
    void set (int value);
}
member MajorVer : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.MinorVer

Proprietà PackAndGoStructureDescriptorMinorVer

Identificativo della versione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int MinorVer { get; set; }
Public Property MinorVer As Integer
    Get
    Set
public:
property int MinorVer {
    int get ();
    void set (int value);
}
member MinorVer : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.Structure

Proprietà PackAndGoStructureDescriptorStructure

Sotto struttura dei descrittori

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptors Structure { get; set; }
Public Property Structure As PackAndGoNodeDescriptors
    Get
    Set
public:
property PackAndGoNodeDescriptors^ Structure {
    PackAndGoNodeDescriptors^ get ();
    void set (PackAndGoNodeDescriptors^ value);
}
member Structure : PackAndGoNodeDescriptors with get, set

Valore della proprietà

Tipo: PackAndGoNodeDescriptors
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Proprietà PackAndGoStructureDescriptor.UserId

Proprietà PackAndGoStructureDescriptorUserId

Identificativo dell'utente che ha eseguito l'operazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string UserId { get; set; }
Public Property UserId As String
    Get
    Set
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
member UserId : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodi di PackAndGoStructureDescriptor

Il tipo PackAndGoStructureDescriptor espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Find | Ritorna se esisto il descrittore nodo corrispondente al nodo passato
Metodo pubblico | GetCurrentImportAction | Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.
Metodo pubblico | SerializeMe | Metodo per la serializzazione dell'oggetto.
Torna su
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.Find

Metodo PackAndGoStructureDescriptorFind

Ritorna se esisto il descrittore nodo corrispondente al nodo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoNodeDescriptor Find(
    string fullFileName
)
Public Function Find (
    fullFileName As String
) As PackAndGoNodeDescriptor
public:
PackAndGoNodeDescriptor^ Find(
    String^ fullFileName
)
member Find :
        fullFileName : string -> PackAndGoNodeDescriptor

Parametri

fullFileName
Tipo: SystemString
Percorso del file da utilizzare per la ricerca

Valore di ritorno

Tipo: PackAndGoNodeDescriptor
Oggetto nodo descrittore, oppure null se l'oggetto non viene trovato
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.GetCurrentImportAction

Metodo PackAndGoStructureDescriptorGetCurrentImportAction

Dato il nodo passato ed il corrispondente percorso corrente, ritorna l'azione da intraprendere in fase di importazione. Se il nodo non presenta un match col percorso passato solleva una eccezione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor pckNdDescr,
    string currentFullFileName,
    PackAndGoImportDedCases dedcase
)
Public Function GetCurrentImportAction (
    pckNdDescr As PackAndGoNodeDescriptor,
    currentFullFileName As String,
    dedcase As PackAndGoImportDedCases
) As PackAndGoImportOperation
public:
PackAndGoImportOperation GetCurrentImportAction(
    PackAndGoNodeDescriptor^ pckNdDescr,
    String^ currentFullFileName,
    PackAndGoImportDedCases dedcase
)
member GetCurrentImportAction :
        pckNdDescr : PackAndGoNodeDescriptor *
        currentFullFileName : string *
        dedcase : PackAndGoImportDedCases -> PackAndGoImportOperation

Parametri

pckNdDescr
Tipo: DedNetAcadPackAndGoNodeDescriptor
currentFullFileName
Tipo: SystemString
dedcase
Tipo: DedNetAcadPackAndGoImportDedCases

Valore di ritorno

Tipo: PackAndGoImportOperation
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Metodo PackAndGoStructureDescriptor.SerializeMe

Metodo PackAndGoStructureDescriptorSerializeMe

Metodo per la serializzazione dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SerializeMe(
    string fn
)
Public Sub SerializeMe (
    fn As String
)
public:
void SerializeMe(
    String^ fn
)
member SerializeMe :
        fn : string -> unit

Parametri

fn
Tipo: SystemString
file name da scrivere
Vedi anche

Documentazione

Classe PackAndGoStructureDescriptor


Classe PartInfo
Classe utilizzata per ottenere informazioni, chiamando metodi, sulla parte correntemente selezionata, sulla parte Top del disegno oppure su di una parte utilizzata nella creazione dell'oggetto.
Gerarchia di ereditarietà
SystemObject
DedNetAcadPartInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PartInfo : IDisposable
Public Class PartInfo
    Implements IDisposable
public ref class PartInfo : IDisposable
type PartInfo =
    class
        interface IDisposable
    end

Il tipo PartInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.
Proprietà pubblica | IsInDb | Restituisce se questa parte sia salvata nel Database.
Proprietà pubblica | IsLocked | Restituisce se si tratti ddi una parte bloccata.
Proprietà pubblica | IsLockedRec | Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.
Proprietà pubblica | isTop |
Proprietà pubblica | IsTop | Restituisce se si tratti della parte Top.
Proprietà pubblica | Name | Restituisce il nome della parte.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | activate |
Metodo pubblico | Activate | Attiva la parte.
Metodo pubblico | Close | Chiude l'oggetto effettuando il dispose.
 | CreatePartInfo | Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoFromLuaStack | Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.
 | CreatePartInfoParteCorrente | Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.
 | CreatePartInfoTop | Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.
Metodo pubblico | DelAllAttr | Elimina tutti gli attributi attualmente presenti nella parte.
Metodo pubblico | DelAttr | Elimina l'attributo passato, se esiste.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo pubblico | GetAllAttr | Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.
Metodo pubblico | getAttr | Rimappate le funzioni con le iniziali minuscole per compatibilità con Inventor e con il passato.
Metodo pubblico | GetAttr | Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.
Metodo pubblico | GetBasePoint | Restituisce il punto di inserimento della parte.
Metodo pubblico | GetDwgStatus |
Metodo pubblico | getName |
Metodo pubblico | getParent |
 | GetPrtFromPartInfo | Restituisce la parte lua dal PartInfo passato
Metodo pubblico | GetStateStatus |
Metodo pubblico | Load | Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | LoadAsinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | LoadSinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() attraverso il suo command mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | New | Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | Push | Effettua il push nello stack del LUA del riferimento.
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(DedData) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | save |
Metodo pubblico | Save | Effettua il salva parte creando un nuovo file.
Metodo pubblico | SaveAsinch | Effettua il salva parte creando un nuovo file, in modo asincrono.
Metodo pubblico | SetAllAttr | Imposta tutti gli attributi nella parte.
Metodo pubblico | setAttr |
Metodo pubblico | SetAttr | Imposta il valore di un attributo.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PartInfo

Il tipo PartInfo espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data | Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.
Proprietà pubblica | IsInDb | Restituisce se questa parte sia salvata nel Database.
Proprietà pubblica | IsLocked | Restituisce se si tratti ddi una parte bloccata.
Proprietà pubblica | IsLockedRec | Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.
Proprietà pubblica | isTop |
Proprietà pubblica | IsTop | Restituisce se si tratti della parte Top.
Proprietà pubblica | Name | Restituisce il nome della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.Data

Proprietà PartInfoData

Restituisce l'anagrafica letta da questa parte, oppure null se on è una parte codificata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsInDb

Proprietà PartInfoIsInDb

Restituisce se questa parte sia salvata nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsInDb { get; }
Public ReadOnly Property IsInDb As Boolean
    Get
public:
property bool IsInDb {
    bool get ();
}
member IsInDb : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsLocked

Proprietà PartInfoIsLocked

Restituisce se si tratti ddi una parte bloccata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsLocked { get; }
Public ReadOnly Property IsLocked As Boolean
    Get
public:
property bool IsLocked {
    bool get ();
}
member IsLocked : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsLockedRec

Proprietà PartInfoIsLockedRec

Restituisce vero se la parte e' bloccata oppure lo e' una ad un livello superiore.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsLockedRec { get; }
Public ReadOnly Property IsLockedRec As Boolean
    Get
public:
property bool IsLockedRec {
    bool get ();
}
member IsLockedRec : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.IsTop

Proprietà PartInfoIsTop

Restituisce se si tratti della parte Top.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsTop { get; }
Public ReadOnly Property IsTop As Boolean
    Get
public:
property bool IsTop {
    bool get ();
}
member IsTop : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PartInfo


Proprietà PartInfo.Name

Proprietà PartInfoName

Restituisce il nome della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe PartInfo


Metodi di PartInfo

Il tipo PartInfo espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | activate |
Metodo pubblico | Activate | Attiva la parte.
Metodo pubblico | Close | Chiude l'oggetto effettuando il dispose.
 | CreatePartInfo | Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoFromLuaStack | Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.
 | CreatePartInfoParteCorrente | Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.
 | CreatePartInfoTop | Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.
Metodo pubblico | DelAllAttr | Elimina tutti gli attributi attualmente presenti nella parte.
Metodo pubblico | DelAttr | Elimina l'attributo passato, se esiste.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo pubblico | GetAllAttr | Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.
Metodo pubblico | getAttr | Rimappate le funzioni con le iniziali minuscole per compatibilità con Inventor e con il passato.
Metodo pubblico | GetAttr | Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.
Metodo pubblico | GetBasePoint | Restituisce il punto di inserimento della parte.
Metodo pubblico | GetDwgStatus |
Metodo pubblico | getName |
Metodo pubblico | getParent |
 | GetPrtFromPartInfo | Restituisce la parte lua dal PartInfo passato
Metodo pubblico | GetStateStatus |
Metodo pubblico | Load | Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | LoadAsinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | LoadSinch | Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() attraverso il suo command mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.
Metodo pubblico | New | Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.
Metodo pubblico | Push | Effettua il push nello stack del LUA del riferimento.
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(DedData) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | save |
Metodo pubblico | Save | Effettua il salva parte creando un nuovo file.
Metodo pubblico | SaveAsinch | Effettua il salva parte creando un nuovo file, in modo asincrono.
Metodo pubblico | SetAllAttr | Imposta tutti gli attributi nella parte.
Metodo pubblico | setAttr |
Metodo pubblico | SetAttr | Imposta il valore di un attributo.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Activate

Metodo PartInfoActivate

Attiva la parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Activate()
Public Sub Activate
public:
void Activate()
member Activate : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Close

Metodo PartInfoClose

Chiude l'oggetto effettuando il dispose.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfo

Metodo PartInfoCreatePartInfo

Crea un oggetto PartInfo leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfo(
    int stackIdx
)
Public Shared Function CreatePartInfo (
    stackIdx As Integer
) As PartInfo
public:
static PartInfo^ CreatePartInfo(
    int stackIdx
)
static member CreatePartInfo :
        stackIdx : int -> PartInfo

Parametri

stackIdx
Tipo: SystemInt32
Indice dello stack dal quale leggere la parte.

Valore di ritorno

Tipo: PartInfo
Restituisce l'oggetto PartInfo oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoFromLuaStack

Metodo PartInfoCreatePartInfoFromLuaStack

Crea un oggetto .net PartInfo wrappando la perte passata come argomento nello stack del lua e la restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int CreatePartInfoFromLuaStack()
Public Shared Function CreatePartInfoFromLuaStack As Integer
public:
static int CreatePartInfoFromLuaStack()
static member CreatePartInfoFromLuaStack : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoParteCorrente

Metodo PartInfoCreatePartInfoParteCorrente

Crea un oggetto PartInfo della parte correntemente attiva e lo restituisce. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfoParteCorrente()
Public Shared Function CreatePartInfoParteCorrente As PartInfo
public:
static PartInfo^ CreatePartInfoParteCorrente()
static member CreatePartInfoParteCorrente : unit -> PartInfo

Valore di ritorno

Tipo: PartInfo
Restituisce l'oggetto PartInfo della parte corrente oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.CreatePartInfoTop

Metodo PartInfoCreatePartInfoTop

Crea un oggetto PartInfo della parte Top e lo restituisce. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfo CreatePartInfoTop()
Public Shared Function CreatePartInfoTop As PartInfo
public:
static PartInfo^ CreatePartInfoTop()
static member CreatePartInfoTop : unit -> PartInfo

Valore di ritorno

Tipo: PartInfo
Restituisce l'oggetto PartInfo della parte Top oppure null.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.DelAllAttr

Metodo PartInfoDelAllAttr

Elimina tutti gli attributi attualmente presenti nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DelAllAttr()
Public Sub DelAllAttr
public:
void DelAllAttr()
member DelAllAttr : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.DelAttr

Metodo PartInfoDelAttr

Elimina l'attributo passato, se esiste.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DelAttr(
    string attrName
)
Public Sub DelAttr (
    attrName As String
)
public:
void DelAttr(
    String^ attrName
)
member DelAttr :
        attrName : string -> unit

Parametri

attrName
Tipo: SystemString
Attributo da eliminare nella parte.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Dispose

Metodo PartInfoDispose

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Dispose

Metodo PartInfoDispose

Effettua il dispose dell'oggetto liberando il riferimento alla parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe PartInfo
Overload di Dispose


Metodo PartInfo.Dispose (Boolean)

Metodo PartInfoDispose (Boolean)
Effettua la liberazione delle risorese gestite e non.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
Indica se viene chiamto dal dispose oppure dal distruttore.
Vedi anche

Documentazione

Classe PartInfo
Overload di Dispose


Metodo PartInfo.GetAllAttr

Metodo PartInfoGetAllAttr

Restituisce un dizionario con tutti gli attributi presenti nella parte. Restituisce sempre un dizionario inizializzato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetAllAttr()
Public Function GetAllAttr As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetAllAttr()
member GetAllAttr : unit -> Dictionary<string, string>

Valore di ritorno

Tipo: Dictionary String, String
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetAttr

Metodo PartInfoGetAttr

Legge il valore di un attributo della parte. Non è case sensitive. Restituisce comunque stringa vuota anche se non riesce a leggere l'attributo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string GetAttr(
    string attrName
)
Public Function GetAttr (
    attrName As String
) As String
public:
String^ GetAttr(
    String^ attrName
)
member GetAttr :
        attrName : string -> string

Parametri

attrName
Tipo: SystemString
Nome dell'attributo da leggere.

Valore di ritorno

Tipo: String
Restituisce l'attributo letto oppure stringa vuota.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetBasePoint

Metodo PartInfoGetBasePoint

Restituisce il punto di inserimento della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Point3d GetBasePoint()
Public Function GetBasePoint As Point3d
public:
Point3d GetBasePoint()
member GetBasePoint : unit -> Point3d

Valore di ritorno

Tipo: Point3d
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetDwgStatus

Metodo PartInfoGetDwgStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int GetDwgStatus(
    DedDoc doc
)
Public Function GetDwgStatus (
    doc As DedDoc
) As Integer
public:
int GetDwgStatus(
    DedDoc^ doc
)
member GetDwgStatus :
        doc : DedDoc -> int

Parametri

doc
Tipo: DedDoc

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.getName

Metodo PartInfogetName

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string getName()
Public Function getName As String
public:
String^ getName()
member getName : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.getParent

Metodo PartInfogetParent

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo getParent()
Public Function getParent As PartInfo
public:
PartInfo^ getParent()
member getParent : unit -> PartInfo

Valore di ritorno

Tipo: PartInfo
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetPrtFromPartInfo

Metodo PartInfoGetPrtFromPartInfo

Restituisce la parte lua dal PartInfo passato

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int GetPrtFromPartInfo()
Public Shared Function GetPrtFromPartInfo As Integer
public:
static int GetPrtFromPartInfo()
static member GetPrtFromPartInfo : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.GetStateStatus

Metodo PartInfoGetStateStatus

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int GetStateStatus(
    DedState state
)
Public Function GetStateStatus (
    state As DedState
) As Integer
public:
int GetStateStatus(
    DedState^ state
)
member GetStateStatus :
        state : DedState -> int

Parametri

state
Tipo: DedState

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Load

Metodo PartInfoLoad

Carica un DWG come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo Load(
    string dwgName
)
Public Function Load (
    dwgName As String
) As PartInfo
public:
PartInfo^ Load(
    String^ dwgName
)
member Load :
        dwgName : string -> PartInfo

Parametri

dwgName
Tipo: SystemString
Nome completo del file da caricare.

Valore di ritorno

Tipo: PartInfo
Restituisce la parte caricata oppure null se avvengono errori.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.LoadAsinch

Metodo PartInfoLoadAsinch

Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadAsinch(
    string dwgName,
    DedAttrList attrList,
    DedData anagr,
    bool isInDb
)
Public Sub LoadAsinch (
    dwgName As String,
    attrList As DedAttrList,
    anagr As DedData,
    isInDb As Boolean
)
public:
void LoadAsinch(
    String^ dwgName,
    DedAttrList^ attrList,
    DedData^ anagr,
    bool isInDb
)
member LoadAsinch :
        dwgName : string *
        attrList : DedAttrList *
        anagr : DedData *
        isInDb : bool -> unit

Parametri

dwgName
Tipo: SystemString
Nome completo del file da caricare.
attrList
Tipo: DedAttrList
Lista degli attributi da impostare nella parte.
anagr
Tipo: DedData
Anagrafica.
isInDb
Tipo: SystemBoolean
Indica se la parte sia o meno nel Database.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.LoadSinch

Metodo PartInfoLoadSinch

Carica un DWG come sotto-parte di questa parte. Chiama la funzione LUA DedAcadCaricaParte() attraverso il suo command mettendo nella tabella DedAcadCaricaParteParams i parametri necessari.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadSinch(
    string dwgName,
    DedAttrList attrList,
    DedData anagr,
    bool isInDb
)
Public Sub LoadSinch (
    dwgName As String,
    attrList As DedAttrList,
    anagr As DedData,
    isInDb As Boolean
)
public:
void LoadSinch(
    String^ dwgName,
    DedAttrList^ attrList,
    DedData^ anagr,
    bool isInDb
)
member LoadSinch :
        dwgName : string *
        attrList : DedAttrList *
        anagr : DedData *
        isInDb : bool -> unit

Parametri

dwgName
Tipo: SystemString
Nome completo del file da caricare.
attrList
Tipo: DedAttrList
Lista degli attributi da impostare nella parte.
anagr
Tipo: DedData
Anagrafica.
isInDb
Tipo: SystemBoolean
Indica se la parte sia o meno nel Database.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.New

Metodo PartInfoNew

Crea una parte come sotto-parte di questa parte. Restituisce la parte caricata oppure null se avvengono errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo New()
Public Function New As PartInfo
public:
PartInfo^ New()
member New : unit -> PartInfo

Valore di ritorno

Tipo: PartInfo
Restituisce la parte caricata oppure null se avvengono errori.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.Push

Metodo PartInfoPush

Effettua il push nello stack del LUA del riferimento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Push()
Public Sub Push
public:
void Push()
member Push : unit -> unit
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshColor

Metodo PartInfoRefreshColor

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RefreshColor | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshColor(Boolean) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshColor

Metodo PartInfoRefreshColor

Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshColor()
Public Sub RefreshColor
public:
void RefreshColor()
member RefreshColor : unit -> unit
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshColor


Metodo PartInfo.RefreshColor (Boolean)

Metodo PartInfoRefreshColor (Boolean)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshColor(
    bool isInDb
)
Public Sub RefreshColor (
    isInDb As Boolean
)
public:
void RefreshColor(
    bool isInDb
)
member RefreshColor :
        isInDb : bool -> unit

Parametri

isInDb
Tipo: SystemBoolean
Indica se la parte sia o meno nel Database.
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshColor


Metodo PartInfo.RefreshDedIcon

Metodo PartInfoRefreshDedIcon

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | RefreshDedIcon(DedData) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Metodo pubblico | RefreshDedIcon(Int32, Int32) | Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.
Torna su
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.RefreshDedIcon (DedData)

Metodo PartInfoRefreshDedIcon (DedData)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshDedIcon(
    DedData anagr
)
Public Sub RefreshDedIcon (
    anagr As DedData
)
public:
void RefreshDedIcon(
    DedData^ anagr
)
member RefreshDedIcon :
        anagr : DedData -> unit

Parametri

anagr
Tipo: DedData
Anagrafica di riferimento.
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshDedIcon


Metodo PartInfo.RefreshDedIcon (Int32, Int32)

Metodo PartInfoRefreshDedIcon (Int32, Int32)
Aggiorna il colore della parte chiamando la funzione LUA DedAcadGetPartColor() per ottenere il corretto colore della parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void RefreshDedIcon(
    int dwgStatus,
    int anagrStatus
)
Public Sub RefreshDedIcon (
    dwgStatus As Integer,
    anagrStatus As Integer
)
public:
void RefreshDedIcon(
    int dwgStatus,
    int anagrStatus
)
member RefreshDedIcon :
        dwgStatus : int *
        anagrStatus : int -> unit

Parametri

dwgStatus
Tipo: SystemInt32
anagrStatus
Tipo: SystemInt32
Vedi anche

Documentazione

Classe PartInfo
Overload di RefreshDedIcon


Metodo PartInfo.Save

Metodo PartInfoSave

Effettua il salva parte creando un nuovo file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public double Save(
    string fileName,
    bool alsoSubParts
)
Public Function Save (
    fileName As String,
    alsoSubParts As Boolean
) As Double
public:
double Save(
    String^ fileName,
    bool alsoSubParts
)
member Save :
        fileName : string *
        alsoSubParts : bool -> float

Parametri

fileName
Tipo: SystemString
File .dwg sul quale esportare la parte.
alsoSubParts
Tipo: SystemBoolean
Indica se esportare anche le sottoparti o solo la parte in salvataggio.

Valore di ritorno

Tipo: Double
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SaveAsinch

Metodo PartInfoSaveAsinch

Effettua il salva parte creando un nuovo file, in modo asincrono.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveAsinch(
    string fileName,
    bool alsoSubParts
)
Public Sub SaveAsinch (
    fileName As String,
    alsoSubParts As Boolean
)
public:
void SaveAsinch(
    String^ fileName,
    bool alsoSubParts
)
member SaveAsinch :
        fileName : string *
        alsoSubParts : bool -> unit

Parametri

fileName
Tipo: SystemString
File .dwg sul quale esportare la parte.
alsoSubParts
Tipo: SystemBoolean
Indica se esportare anche le sottoparti o solo la parte in salvataggio.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SetAllAttr

Metodo PartInfoSetAllAttr

Imposta tutti gli attributi nella parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetAllAttr(
    Dictionary<string, string> attrs
)
Public Sub SetAllAttr (
    attrs As Dictionary(Of String, String)
)
public:
void SetAllAttr(
    Dictionary<String^, String^>^ attrs
)
member SetAllAttr :
        attrs : Dictionary<string, string> -> unit

Parametri

attrs
Tipo: System.Collections.GenericDictionary String, String
Dizionario di attributi da impostare.
Vedi anche

Documentazione

Classe PartInfo


Metodo PartInfo.SetAttr

Metodo PartInfoSetAttr

Imposta il valore di un attributo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetAttr(
    string attrName,
    string attrVal
)
Public Sub SetAttr (
    attrName As String,
    attrVal As String
)
public:
void SetAttr(
    String^ attrName,
    String^ attrVal
)
member SetAttr :
        attrName : string *
        attrVal : string -> unit

Parametri

attrName
Tipo: SystemString
Nome dell'attributo da impostare.
attrVal
Tipo: SystemString
Valore da impostare.
Vedi anche

Documentazione

Classe PartInfo


Classe PartInfoArray
Classe utilizzata per ottenere informazioni su di un oggetto PrtArray LUA. Chiama i metodi dell'oggetto via LUA come l'oggetto PartInfo. Questo oggetto è creabile solo via LUA.
Gerarchia di ereditarietà
SystemObject
DedNetAcadPartInfoArray

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PartInfoArray : IDisposable
Public Class PartInfoArray
    Implements IDisposable
public ref class PartInfoArray : IDisposable
type PartInfoArray =
    class
        interface IDisposable
    end

Il tipo PartInfoArray espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nell'array.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge la parte passata all'array.
Metodo pubblico | Close | Chiude l'oggetto effettuando il dispose.
 | CreatePartInfoArray | Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoArrayFromLuaStack | Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo pubblico | GetAt | Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.
 | GetNavSelectedParts | Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).
 | GetTreeSelectedParts | Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PartInfoArray

Il tipo PartInfoArray espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Count | Restituisce il numero di elementi presenti nell'array.
Torna su
Vedi anche

Documentazione

Classe PartInfoArray


Proprietà PartInfoArray.Count

Proprietà PartInfoArrayCount

Restituisce il numero di elementi presenti nell'array.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfoArray


Metodi di PartInfoArray

Il tipo PartInfoArray espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Add | Aggiunge la parte passata all'array.
Metodo pubblico | Close | Chiude l'oggetto effettuando il dispose.
 | CreatePartInfoArray | Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.
 | CreatePartInfoArrayFromLuaStack | Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Metodo pubblico | GetAt | Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.
 | GetNavSelectedParts | Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).
 | GetTreeSelectedParts | Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).
Torna su
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.Add

Metodo PartInfoArrayAdd

Aggiunge la parte passata all'array.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Add(
    PartInfo prt
)
Public Sub Add (
    prt As PartInfo
)
public:
void Add(
    PartInfo^ prt
)
member Add :
        prt : PartInfo -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte da aggiungere.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.Close

Metodo PartInfoArrayClose

Chiude l'oggetto effettuando il dispose.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.CreatePartInfoArray

Metodo PartInfoArrayCreatePartInfoArray

Crea un oggetto PartInfoArray leggendo il primo argomento dallo stack del LUA. Restituisce null se non riesce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray CreatePartInfoArray(
    int stackIdx
)
Public Shared Function CreatePartInfoArray (
    stackIdx As Integer
) As PartInfoArray
public:
static PartInfoArray^ CreatePartInfoArray(
    int stackIdx
)
static member CreatePartInfoArray :
        stackIdx : int -> PartInfoArray

Parametri

stackIdx
Tipo: SystemInt32
Indice dello stack dal quale leggere l'array.

Valore di ritorno

Tipo: PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.CreatePartInfoArrayFromLuaStack

Metodo PartInfoArrayCreatePartInfoArrayFromLuaStack

Crea un oggetto .net PartInfoArray wrappando l'array passato come argomento nello stack del lua e lo restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static int CreatePartInfoArrayFromLuaStack()
Public Shared Function CreatePartInfoArrayFromLuaStack As Integer
public:
static int CreatePartInfoArrayFromLuaStack()
static member CreatePartInfoArrayFromLuaStack : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.Dispose

Metodo PartInfoArrayDispose

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | Dispose | Effettua il dispose dell'oggetto liberando il riferimento alla parte.
Metodo protetto | Dispose(Boolean) | Effettua la liberazione delle risorese gestite e non.
Torna su
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.Dispose

Metodo PartInfoArrayDispose

Effettua il dispose dell'oggetto liberando il riferimento alla parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implementa

IDisposableDispose
Vedi anche

Documentazione

Classe PartInfoArray
Overload di Dispose


Metodo PartInfoArray.Dispose (Boolean)

Metodo PartInfoArrayDispose (Boolean)
Effettua la liberazione delle risorese gestite e non.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
Indica se viene chiamto dal dispose oppure dal distruttore.
Vedi anche

Documentazione

Classe PartInfoArray
Overload di Dispose


Metodo PartInfoArray.GetAt

Metodo PartInfoArrayGetAt

Restituisce la parte iesima dell'array (zero based index). Restituisce null se si specifica un numero non compreso nell'intervallo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo GetAt(
    int idx
)
Public Function GetAt (
    idx As Integer
) As PartInfo
public:
PartInfo^ GetAt(
    int idx
)
member GetAt :
        idx : int -> PartInfo

Parametri

idx
Tipo: SystemInt32
Indice dell'elemento da restituire.

Valore di ritorno

Tipo: PartInfo
Restituisce la parte letto oppure null se non è presente.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.GetNavSelectedParts

Metodo PartInfoArrayGetNavSelectedParts

Restituisce le parti correntemente selezionate nell'area grafica (chiama LNavGetNavSelectedItems()).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray GetNavSelectedParts()
Public Shared Function GetNavSelectedParts As PartInfoArray
public:
static PartInfoArray^ GetNavSelectedParts()
static member GetNavSelectedParts : unit -> PartInfoArray

Valore di ritorno

Tipo: PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Metodo PartInfoArray.GetTreeSelectedParts

Metodo PartInfoArrayGetTreeSelectedParts

Restituisce le parti correntemente selezionate (chiama LNavGetTreeSelectedItems()).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartInfoArray GetTreeSelectedParts(
    bool subParts
)
Public Shared Function GetTreeSelectedParts (
    subParts As Boolean
) As PartInfoArray
public:
static PartInfoArray^ GetTreeSelectedParts(
    bool subParts
)
static member GetTreeSelectedParts :
        subParts : bool -> PartInfoArray

Parametri

subParts
Tipo: SystemBoolean
Indica se selezionare anche le sottoparti nel caso di ramo chiuso.

Valore di ritorno

Tipo: PartInfoArray
Restituisce l'oggetto PartInfoArray oppure null.
Vedi anche

Documentazione

Classe PartInfoArray


Classe PrtArraySelectStatusInfo
Classe che verifica lo stato di un array di parti e restituisce informazioni utili per la disponibilità e l'esecuzione dei comandi.
Gerarchia di ereditarietà
SystemObject
DedNetAcadPrtArraySelectStatusInfo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PrtArraySelectStatusInfo
Public Class PrtArraySelectStatusInfo
public ref class PrtArraySelectStatusInfo
type PrtArraySelectStatusInfo =  class end

Il tipo PrtArraySelectStatusInfo espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | PrtArraySelectStatusInfo | Costruttore unico che inizializza le proprietà dell'oggetto.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | AllInDb | Tutte le parti selezionate sono nel Database.
Campo pubblico | AlmenoUnaInDb | Indica se c'é almeno una parte codficata.
Campo pubblico | AlmenoUnaSubPrtInDb | Indica se c'é almeno una parte figlia (non Top) codificata nel Db.
Campo pubblico | AlmenoUnaSubPrtNotLastRev | Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.
Campo pubblico | IsTopInDb | La parte Top è selezionata ed è presente nel Database.
Campo pubblico | IsTopSelected | La parte Top è selezionata.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore PrtArraySelectStatusInfo

Costruttore unico che inizializza le proprietà dell'oggetto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PrtArraySelectStatusInfo(
    PartInfoArray prtArray
)
Public Sub New (
    prtArray As PartInfoArray
)
public:
PrtArraySelectStatusInfo(
    PartInfoArray^ prtArray
)
new :
        prtArray : PartInfoArray -> PrtArraySelectStatusInfo

Parametri

prtArray
Tipo: DedNetAcadPartInfoArray
Array del quale restituire le informazioni.
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campi di PrtArraySelectStatusInfo

Il tipo PrtArraySelectStatusInfo espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | AllInDb | Tutte le parti selezionate sono nel Database.
Campo pubblico | AlmenoUnaInDb | Indica se c'é almeno una parte codficata.
Campo pubblico | AlmenoUnaSubPrtInDb | Indica se c'é almeno una parte figlia (non Top) codificata nel Db.
Campo pubblico | AlmenoUnaSubPrtNotLastRev | Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.
Campo pubblico | IsTopInDb | La parte Top è selezionata ed è presente nel Database.
Campo pubblico | IsTopSelected | La parte Top è selezionata.
Torna su
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AllInDb

Campo PrtArraySelectStatusInfoAllInDb
Tutte le parti selezionate sono nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AllInDb
Public ReadOnly AllInDb As Boolean
public:
initonly bool AllInDb
val AllInDb: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaInDb

Campo PrtArraySelectStatusInfoAlmenoUnaInDb
Indica se c'é almeno una parte codficata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaInDb
Public ReadOnly AlmenoUnaInDb As Boolean
public:
initonly bool AlmenoUnaInDb
val AlmenoUnaInDb: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaSubPrtInDb

Campo PrtArraySelectStatusInfoAlmenoUnaSubPrtInDb
Indica se c'é almeno una parte figlia (non Top) codificata nel Db.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaSubPrtInDb
Public ReadOnly AlmenoUnaSubPrtInDb As Boolean
public:
initonly bool AlmenoUnaSubPrtInDb
val AlmenoUnaSubPrtInDb: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.AlmenoUnaSubPrtNotLastRev

Campo PrtArraySelectStatusInfoAlmenoUnaSubPrtNotLastRev
Indica se c'é almeno una parte figlia (non Top) codificata nel Db che non sia all'ultima revisione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool AlmenoUnaSubPrtNotLastRev
Public ReadOnly AlmenoUnaSubPrtNotLastRev As Boolean
public:
initonly bool AlmenoUnaSubPrtNotLastRev
val AlmenoUnaSubPrtNotLastRev: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.IsTopInDb

Campo PrtArraySelectStatusInfoIsTopInDb
La parte Top è selezionata ed è presente nel Database.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool IsTopInDb
Public ReadOnly IsTopInDb As Boolean
public:
initonly bool IsTopInDb
val IsTopInDb: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Campo PrtArraySelectStatusInfo.IsTopSelected

Campo PrtArraySelectStatusInfoIsTopSelected
La parte Top è selezionata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public readonly bool IsTopSelected
Public ReadOnly IsTopSelected As Boolean
public:
initonly bool IsTopSelected
val IsTopSelected: bool

Valore del campo

Tipo: Boolean
Vedi anche

Documentazione

Classe PrtArraySelectStatusInfo


Classe Pubblish
Gerarchia di ereditarietà
SystemObject
DedNetAcadPubblish

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Pubblish
Public NotInheritable Class Pubblish
public ref class Pubblish abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Pubblish =  class end

Il tipo Pubblish espone i seguenti membri.

Metodi
Nome | Descrizione
PublishAcad | Effettua la pubbilcazione del documento.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di Pubblish

Il tipo Pubblish espone i seguenti membri.

Metodi
Nome | Descrizione
PublishAcad | Effettua la pubbilcazione del documento.
Torna su
Vedi anche

Documentazione

Classe Pubblish


Metodo Pubblish.PublishAcad

Metodo PubblishPublishAcad

Effettua la pubbilcazione del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PublishAcad(
    LuaTable printInfo
)
Public Shared Function PublishAcad (
    printInfo As LuaTable
) As Boolean
public:
static bool PublishAcad(
    LuaTable^ printInfo
)
static member PublishAcad :
        printInfo : LuaTable -> bool

Parametri

printInfo
Tipo: LuaTable

Valore di ritorno

Tipo: Boolean
Restituisce true se riesce false altrimenti
Vedi anche

Documentazione

Classe Pubblish


Classe PublishSparePartsDrawing
Comando che pubblica una tavola tecnica ricambi in formato pdf.
Gerarchia di ereditarietà
SystemObject
DedCommand
DedNetAcadPublishSparePartsDrawing

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PublishSparePartsDrawing : DedCommand
Public Class PublishSparePartsDrawing
    Inherits DedCommand
public ref class PublishSparePartsDrawing : public DedCommand
type PublishSparePartsDrawing =
    class
        inherit DedCommand
    end

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Application | (Ereditato da DedCommand.)
Proprietà pubblica | Client | (Ereditato da DedCommand.)
Proprietà pubblica | CommandContext | (Ereditato da DedCommand.)
Proprietà pubblica | Data | Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..
Proprietà pubblica | Document | Documento che si vuole pubblicare in formato pdf.
Proprietà pubblica | GlobalName | (Ereditato da DedCommand.)
Proprietà pubblica | GlobalOrder | (Ereditato da DedCommand.)
Proprietà pubblica | IgnoreUserPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Img16 | (Ereditato da DedCommand.)
Proprietà pubblica | Img32 | (Ereditato da DedCommand.)
Proprietà pubblica | InternalName | (Ereditato da DedCommand.)
Proprietà pubblica | IsImportingOperation | (Ereditato da DedCommand.)
Proprietà pubblica | LastException | (Ereditato da DedCommand.)
Proprietà pubblica | MinimumPerm | (Ereditato da DedCommand.)
Proprietà pubblica | Name | (Ereditato da DedCommand.)
Proprietà pubblica | NeedDocument | (Ereditato da DedCommand.)
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. (Sovrascrive DedCommand.NeedParameters.)
Proprietà pubblica | NeedRefresh | (Ereditato da DedCommand.)
Proprietà pubblica | NoOwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | OwnerForm | (Ereditato da DedCommand.)
Proprietà pubblica | Result | (Ereditato da DedCommand.)
Proprietà pubblica | Silent | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuName | (Ereditato da DedCommand.)
Proprietà pubblica | SubMenuText | (Ereditato da DedCommand.)
Proprietà pubblica | Tooltip | (Ereditato da DedCommand.)
Proprietà pubblica | UseUI | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.Data

Proprietà PublishSparePartsDrawingData

Anagrafica a cui appartiene il documento di partenza da cui creare il documento tecnico del ricambio da inserire nel manuale..

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; set; }
Public Property Data As DedData
    Get
    Set
public:
property DedData^ Data {
    DedData^ get ();
    void set (DedData^ value);
}
member Data : DedData with get, set

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.Document

Proprietà PublishSparePartsDrawingDocument

Documento che si vuole pubblicare in formato pdf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Proprietà PublishSparePartsDrawing.NeedParameters

Proprietà PublishSparePartsDrawingNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodi di PublishSparePartsDrawing

Il tipo PublishSparePartsDrawing espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo pubblico | Equals | (Ereditato da DedCommand.)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | GetHashCode | (Ereditato da DedCommand.)
Metodo protetto | InitSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | Run | (Ereditato da DedCommand.)
Metodo pubblico | RunSubCommand | (Ereditato da DedCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | ToString | (Ereditato da DedCommand.)
Torna su
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.ClearCommand

Metodo PublishSparePartsDrawingClearCommand

Azzera i dati del comando per renderlo pronto ad una nuova inizializzazione ed esecuzione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.Enabled

Metodo PublishSparePartsDrawingEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.ExecuteCommand

Metodo PublishSparePartsDrawingExecuteCommand

Esegue il comando vero e proprio.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Metodo PublishSparePartsDrawing.SetContext

Metodo PublishSparePartsDrawingSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe PublishSparePartsDrawing


Classe QsDocument
Gerarchia di ereditarietà
SystemObject
DedNetAcadQsDocument

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsDocument
Public Class QsDocument
public ref class QsDocument
type QsDocument =  class end

Il tipo QsDocument espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsDocument | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Database | Restituisce il Database del documento.
Proprietà pubblica | Editor | Restituisce l'Editor del documento.
Proprietà pubblica | IsReadOnly | Restituisce se il documento è read only.
Proprietà pubblica | Name | Restituisce il percorso completo del documento.
Proprietà pubblica | UserData | Restituisce l'UserData.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Permette di attivare il documento.
 | ActiveDocument | Restituisce il docuumento attualmente attivo.
 | AssertActiveDocument | Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
 | AssertDataDocument | Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.
Metodo pubblico | CloseAndDiscard | Chiude il documento senza salvare.
Metodo pubblico | CloseAndSave | Chiude e salva il documento.
 | CurrentDocument | Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.
 | DefaultFormatForSave | Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format
 | DocIsDirty | Restituisce true se il documento passato è dirty altrimenti false.
Metodo pubblico | DowngradeDocOpen | Effettua il downgrade del documento.
 | EnsureActiveDocumentReadableWritable | Si assicura che il documento attivo sia scrivibile o in sola lettura.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object).)
 | FileIsActiveDocument | Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.
 | GetDataDocument | Ritorna l'anagrafica associata al documento. Ritorna null se non la trova
Metodo pubblico | GetHashCode | Ridefinizione HashCode. (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | LockDocument | Effettua il Lock del documento.
 | OpenDocument | Apre un documento verificando che non sia già aperto.
Metodo pubblico | PopDbmod | Effettua il pop del DbMod.
Metodo pubblico | PushDbmod | Effettua il push del DbMod.
 | Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
 | Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
 | SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveCopyAs | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Metodo pubblico | SendStringToExecute | Esegue il comando.
Metodo pubblico | UpgradeDocOpen | Effettua l'upgrade del documento.
Torna su
Operatori
Nome | Descrizione
Equality | Ridefinizione dell'operatore ==.
Inequality | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsDocument

Costruttore unico.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsDocument(
    Document doc
)
Public Sub New (
    doc As Document
)
public:
QsDocument(
    Document^ doc
)
new :
        doc : Document -> QsDocument

Parametri

doc
Tipo: Document
Documento di Autocad.
Vedi anche

Documentazione

Classe QsDocument


Proprietà di QsDocument

Il tipo QsDocument espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Database | Restituisce il Database del documento.
Proprietà pubblica | Editor | Restituisce l'Editor del documento.
Proprietà pubblica | IsReadOnly | Restituisce se il documento è read only.
Proprietà pubblica | Name | Restituisce il percorso completo del documento.
Proprietà pubblica | UserData | Restituisce l'UserData.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Database

Proprietà QsDocumentDatabase

Restituisce il Database del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Database Database { get; }
Public ReadOnly Property Database As Database
    Get
public:
property Database^ Database {
    Database^ get ();
}
member Database : Database with get

Valore della proprietà

Tipo: Database
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Editor

Proprietà QsDocumentEditor

Restituisce l'Editor del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Editor Editor { get; }
Public ReadOnly Property Editor As Editor
    Get
public:
property Editor^ Editor {
    Editor^ get ();
}
member Editor : Editor with get

Valore della proprietà

Tipo: Editor
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.IsReadOnly

Proprietà QsDocumentIsReadOnly

Restituisce se il documento è read only.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
public:
property bool IsReadOnly {
    bool get ();
}
member IsReadOnly : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.Name

Proprietà QsDocumentName

Restituisce il percorso completo del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe QsDocument


Proprietà QsDocument.UserData

Proprietà QsDocumentUserData

Restituisce l'UserData.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Hashtable UserData { get; }
Public ReadOnly Property UserData As Hashtable
    Get
public:
property Hashtable^ UserData {
    Hashtable^ get ();
}
member UserData : Hashtable with get

Valore della proprietà

Tipo: Hashtable
Vedi anche

Documentazione

Classe QsDocument


Metodi di QsDocument

Il tipo QsDocument espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Activate | Permette di attivare il documento.
 | ActiveDocument | Restituisce il docuumento attualmente attivo.
 | AssertActiveDocument | Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.
 | AssertDataDocument | Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.
Metodo pubblico | CloseAndDiscard | Chiude il documento senza salvare.
Metodo pubblico | CloseAndSave | Chiude e salva il documento.
 | CurrentDocument | Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.
 | DefaultFormatForSave | Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format
 | DocIsDirty | Restituisce true se il documento passato è dirty altrimenti false.
Metodo pubblico | DowngradeDocOpen | Effettua il downgrade del documento.
 | EnsureActiveDocumentReadableWritable | Si assicura che il documento attivo sia scrivibile o in sola lettura.
Metodo pubblico | Equals | Ridefinizione di uguaglianza. (Sovrascrive ObjectEquals(Object).)
 | FileIsActiveDocument | Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.
 | GetDataDocument | Ritorna l'anagrafica associata al documento. Ritorna null se non la trova
Metodo pubblico | GetHashCode | Ridefinizione HashCode. (Sovrascrive ObjectGetHashCode.)
Metodo pubblico | LockDocument | Effettua il Lock del documento.
 | OpenDocument | Apre un documento verificando che non sia già aperto.
Metodo pubblico | PopDbmod | Effettua il pop del DbMod.
Metodo pubblico | PushDbmod | Effettua il push del DbMod.
 | Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
 | Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
 | SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
 | SaveCopyAs | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Metodo pubblico | SendStringToExecute | Esegue il comando.
Metodo pubblico | UpgradeDocOpen | Effettua l'upgrade del documento.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Activate

Metodo QsDocumentActivate

Permette di attivare il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Activate()
Public Sub Activate
public:
void Activate()
member Activate : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.ActiveDocument

Metodo QsDocumentActiveDocument

Restituisce il docuumento attualmente attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument ActiveDocument()
Public Shared Function ActiveDocument As QsDocument
public:
static QsDocument^ ActiveDocument()
static member ActiveDocument : unit -> QsDocument

Valore di ritorno

Tipo: QsDocument
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.AssertActiveDocument

Metodo QsDocumentAssertActiveDocument

Verifica che sia presente un documento attivo in Autocad e lo restituisce. Solleva una eccezione se non ci sono documenti attivi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument AssertActiveDocument()
Public Shared Function AssertActiveDocument As QsDocument
public:
static QsDocument^ AssertActiveDocument()
static member AssertActiveDocument : unit -> QsDocument

Valore di ritorno

Tipo: QsDocument
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.AssertDataDocument

Metodo QsDocumentAssertDataDocument

Verifica che il documento specificato in ingresso sia associato ad una anagrafica. Genera una eccezione se non la trova, altrimenti la restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertDataDocument()
Public Shared Function AssertDataDocument As DedData
public:
static DedData^ AssertDataDocument()
static member AssertDataDocument : unit -> DedData

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CloseAndDiscard

Metodo QsDocumentCloseAndDiscard

Chiude il documento senza salvare.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CloseAndDiscard()
Public Sub CloseAndDiscard
public:
void CloseAndDiscard()
member CloseAndDiscard : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CloseAndSave

Metodo QsDocumentCloseAndSave

Chiude e salva il documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CloseAndSave(
    string fileName
)
Public Sub CloseAndSave (
    fileName As String
)
public:
void CloseAndSave(
    String^ fileName
)
member CloseAndSave :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
Nome del documento.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.CurrentDocument

Metodo QsDocumentCurrentDocument

Legge il percorso del documento correntemente attivo e ne resituisce il DedDoc. Se il documento non è ancora selvato o se non è nel Database restituisce null. Ignora eventuali errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc CurrentDocument()
Public Shared Function CurrentDocument As DedDoc
public:
static DedDoc^ CurrentDocument()
static member CurrentDocument : unit -> DedDoc

Valore di ritorno

Tipo: DedDoc
Restituisce il DedDoc associato al documento attivo oppure null se non lo trova.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DefaultFormatForSave

Metodo QsDocumentDefaultFormatForSave

Legge dal registro il valore del formato di default di salvataggio. Da notare che il valore scritto nel rigistro è da interpretare nel seguente modo: 48 - AutoCAD 2010 DWG format 36 - AutoCAD 2007 DWG format 24 - AutoCAD 2004 DWG format 12 - AutoCAD 2000 DWG format 8 - AutoCAD 14 DWG format

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DwgVersion DefaultFormatForSave()
Public Shared Function DefaultFormatForSave As DwgVersion
public:
static DwgVersion DefaultFormatForSave()
static member DefaultFormatForSave : unit -> DwgVersion

Valore di ritorno

Tipo: DwgVersion
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DocIsDirty

Metodo QsDocumentDocIsDirty

Restituisce true se il documento passato è dirty altrimenti false.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool DocIsDirty()
Public Shared Function DocIsDirty As Boolean
public:
static bool DocIsDirty()
static member DocIsDirty : unit -> bool

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.DowngradeDocOpen

Metodo QsDocumentDowngradeDocOpen

Effettua il downgrade del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void DowngradeDocOpen(
    bool bPromptForSave
)
Public Sub DowngradeDocOpen (
    bPromptForSave As Boolean
)
public:
void DowngradeDocOpen(
    bool bPromptForSave
)
member DowngradeDocOpen :
        bPromptForSave : bool -> unit

Parametri

bPromptForSave
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.EnsureActiveDocumentReadableWritable

Metodo QsDocumentEnsureActiveDocumentReadableWritable

Si assicura che il documento attivo sia scrivibile o in sola lettura.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void EnsureActiveDocumentReadableWritable(
    bool readOnly
)
Public Shared Sub EnsureActiveDocumentReadableWritable (
    readOnly As Boolean
)
public:
static void EnsureActiveDocumentReadableWritable(
    bool readOnly
)
static member EnsureActiveDocumentReadableWritable :
        readOnly : bool -> unit

Parametri

readOnly
Tipo: SystemBoolean
Se true si assicura che sia in sola lettura altrimenti che sia scrivibile.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Equals

Metodo QsDocumentEquals

Ridefinizione di uguaglianza.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parametri

obj
Tipo: SystemObject
Oggetto da confrontare.

Valore di ritorno

Tipo: Boolean
Restituisce true se l'oggetto è uguale a questo.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.FileIsActiveDocument

Metodo QsDocumentFileIsActiveDocument

Verifica se il nome file completo passato coincida con il documento correntemente attivo. Perché questa funzione dia un risultato attendibile il documento attivo deve essere salvato e non deve essere nuovo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsActiveDocument(
    string fileName
)
Public Shared Function FileIsActiveDocument (
    fileName As String
) As Boolean
public:
static bool FileIsActiveDocument(
    String^ fileName
)
static member FileIsActiveDocument :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
Nome file da comparare.

Valore di ritorno

Tipo: Boolean
Restituisce true se combacia col documento attivo altrimenti false.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.GetDataDocument

Metodo QsDocumentGetDataDocument

Ritorna l'anagrafica associata al documento. Ritorna null se non la trova

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData GetDataDocument()
Public Shared Function GetDataDocument As DedData
public:
static DedData^ GetDataDocument()
static member GetDataDocument : unit -> DedData

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.GetHashCode

Metodo QsDocumentGetHashCode

Ridefinizione HashCode.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Valore di ritorno

Tipo: Int32
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.LockDocument

Metodo QsDocumentLockDocument

Effettua il Lock del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentLock LockDocument()
Public Function LockDocument As DocumentLock
public:
DocumentLock^ LockDocument()
member LockDocument : unit -> DocumentLock

Valore di ritorno

Tipo: DocumentLock
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.OpenDocument

Metodo QsDocumentOpenDocument

Apre un documento verificando che non sia già aperto.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument OpenDocument(
    string fullFileName,
    bool readOnly
)
Public Shared Function OpenDocument (
    fullFileName As String,
    readOnly As Boolean
) As QsDocument
public:
static QsDocument^ OpenDocument(
    String^ fullFileName,
    bool readOnly
)
static member OpenDocument :
        fullFileName : string *
        readOnly : bool -> QsDocument

Parametri

fullFileName
Tipo: SystemString
File da aprire.
readOnly
Tipo: SystemBoolean
Modalità di apertura (usata solo nel caso il documento sia da aprire).

Valore di ritorno

Tipo: QsDocument
Restituisce il documento aperto o attivato.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.PopDbmod

Metodo QsDocumentPopDbmod

Effettua il pop del DbMod.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void PopDbmod()
Public Sub PopDbmod
public:
void PopDbmod()
member PopDbmod : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.PushDbmod

Metodo QsDocumentPushDbmod

Effettua il push del DbMod.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void PushDbmod()
Public Sub PushDbmod
public:
void PushDbmod()
member PushDbmod : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Save

Metodo QsDocumentSave

Lista degli overload
Nome | Descrizione
Save | Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.
Save(QsDocument) | Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.Save

Metodo QsDocumentSave

Salva veloce il documento correntemente attivo, solo se questo è già salvato su disco altrimenti non fa niente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Save()
Public Shared Sub Save
public:
static void Save()
static member Save : unit -> unit
Vedi anche

Documentazione

Classe QsDocument
Overload di Save


Metodo QsDocument.Save (QsDocument)

Metodo QsDocumentSave (QsDocument)
Salva veloce il documento passato come argomento, solo se questo è già salvato su disco altrimenti non fa niente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void Save(
    QsDocument doc
)
Public Shared Sub Save (
    doc As QsDocument
)
public:
static void Save(
    QsDocument^ doc
)
static member Save :
        doc : QsDocument -> unit

Parametri

doc
Tipo: DedNetAcadQsDocument
Vedi anche

Documentazione

Classe QsDocument
Overload di Save


Metodo QsDocument.SaveAs

Metodo QsDocumentSaveAs

Lista degli overload
Nome | Descrizione
SaveAs(String) | Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
SaveAs(QsDocument, String, Boolean) | Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.
Torna su
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.SaveAs (String)

Metodo QsDocumentSaveAs (String)
Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    string destFileName
)
Public Shared Sub SaveAs (
    destFileName As String
)
public:
static void SaveAs(
    String^ destFileName
)
static member SaveAs :
        destFileName : string -> unit

Parametri

destFileName
Tipo: SystemString
File di destinazione.
Vedi anche

Documentazione

Classe QsDocument
Overload di SaveAs


Metodo QsDocument.SaveAs (QsDocument, String, Boolean)

Metodo QsDocumentSaveAs (QsDocument, String, Boolean)
Effettua un Salva con nome del documento passato. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SaveAs(
    QsDocument doc,
    string destFileName,
    bool copyAs = false
)
Public Shared Sub SaveAs (
    doc As QsDocument,
    destFileName As String,
    Optional copyAs As Boolean = false
)
public:
static void SaveAs(
    QsDocument^ doc,
    String^ destFileName,
    bool copyAs = false
)
static member SaveAs :
        doc : QsDocument *
        destFileName : string *
        ?copyAs : bool
(* Defaults:
        let _copyAs = defaultArg copyAs false
*)
-> unit

Parametri

doc
Tipo: DedNetAcadQsDocument
Documento da salvare.
destFileName
Tipo: SystemString
File di destinazione.
copyAs (Optional)
Tipo: SystemBoolean
Indica se fare un CopyAs ovvero mantiene il file attuale com'è e lo salva con nome.
Vedi anche

Documentazione

Classe QsDocument
Overload di SaveAs


Metodo QsDocument.SaveCopyAs

Metodo QsDocumentSaveCopyAs

Effettua un Salva con nome del documento correntemente attivo. NOTA: sovrascrive il file di destinazione senza chiedere conferma.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SaveCopyAs(
    string destFileName
)
Public Shared Sub SaveCopyAs (
    destFileName As String
)
public:
static void SaveCopyAs(
    String^ destFileName
)
static member SaveCopyAs :
        destFileName : string -> unit

Parametri

destFileName
Tipo: SystemString
File di destinazione.
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.SendStringToExecute

Metodo QsDocumentSendStringToExecute

Esegue il comando.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SendStringToExecute(
    string command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
Public Sub SendStringToExecute (
    command As String,
    activate As Boolean,
    wrapUpInactiveDoc As Boolean,
    echoCommand As Boolean
)
public:
void SendStringToExecute(
    String^ command,
    bool activate,
    bool wrapUpInactiveDoc,
    bool echoCommand
)
member SendStringToExecute :
        command : string *
        activate : bool *
        wrapUpInactiveDoc : bool *
        echoCommand : bool -> unit

Parametri

command
Tipo: SystemString
activate
Tipo: SystemBoolean
wrapUpInactiveDoc
Tipo: SystemBoolean
echoCommand
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe QsDocument


Metodo QsDocument.UpgradeDocOpen

Metodo QsDocumentUpgradeDocOpen

Effettua l'upgrade del documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void UpgradeDocOpen()
Public Sub UpgradeDocOpen
public:
void UpgradeDocOpen()
member UpgradeDocOpen : unit -> unit
Vedi anche

Documentazione

Classe QsDocument


QsDocument Operators

Il tipo QsDocument espone i seguenti membri.

Operatori
Nome | Descrizione
Equality | Ridefinizione dell'operatore ==.
Inequality | Ridefinizione dell'operatore !=.
Torna su
Vedi anche

Documentazione

Classe QsDocument


QsDocument.Equality Operatore

QsDocumentEquality Operatore

Ridefinizione dell'operatore ==.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator ==(
    QsDocument a,
    QsDocument b
)
Public Shared Operator = (
    a As QsDocument,
    b As QsDocument
) As Boolean
public:
static bool operator ==(
    QsDocument^ a,
    QsDocument^ b
)
static let inline (=)
        a : QsDocument *
        b : QsDocument  : bool

Parametri

a
Tipo: DedNetAcadQsDocument
b
Tipo: DedNetAcadQsDocument

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe QsDocument


QsDocument.Inequality Operatore

QsDocumentInequality Operatore

Ridefinizione dell'operatore !=.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool operator !=(
    QsDocument a,
    QsDocument b
)
Public Shared Operator <> (
    a As QsDocument,
    b As QsDocument
) As Boolean
public:
static bool operator !=(
    QsDocument^ a,
    QsDocument^ b
)
static let inline (<>)
        a : QsDocument *
        b : QsDocument  : bool

Parametri

a
Tipo: DedNetAcadQsDocument
b
Tipo: DedNetAcadQsDocument

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe QsDocument


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
DedNetAcadQsResources

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsResources

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s
Tipo: SystemString
a
Tipo: System.ReflectionAssembly
Vedi anche

Documentazione

Classe QsResources


Metodi di QsResources
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString

Metodo QsResourcesGetString

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString (String)

Metodo QsResourcesGetString (String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Metodo QsResources.GetString (String, CultureInfo)

Metodo QsResourcesGetString (String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name
Tipo: SystemString
culture
Tipo: System.GlobalizationCultureInfo

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Classe ResolveFileForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcadResolveFileForm

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ResolveFileForm : BaseForm
Public Class ResolveFileForm
    Inherits BaseForm
public ref class ResolveFileForm : public BaseForm
type ResolveFileForm =
    class
        inherit BaseForm
    end

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà pubblica | SetText |
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm


Proprietà ResolveFileForm.SetText

Proprietà ResolveFileFormSetText

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string SetText { get; set; }
Public Property SetText As String
    Get
    Set
public:
property String^ SetText {
    String^ get ();
    void set (String^ value);
}
member SetText : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe ResolveFileForm


Metodi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm


Metodo ResolveFileForm.Dispose

Metodo ResolveFileFormDispose

Clean up any resources being used.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe ResolveFileForm


Eventi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm


Campi di ResolveFileForm

Il tipo ResolveFileForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe ResolveFileForm


Classe Resolver
Classe di inizializzazione add-in. Viene utilizzata per registrare l'evento di risuluzione assembly in modo che nell'inizializzazione vera e propria dell'oggetto DedNetAcadApp si possa liberamente dichiarare i vari tipi di dato senza compromettere il caricamento dell'add-in.
Gerarchia di ereditarietà
SystemObject
DedNetAcadResolver

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class Resolver : IExtensionApplication
Public Class Resolver
    Implements IExtensionApplication
public ref class Resolver : IExtensionApplication
type Resolver =
    class
        interface IExtensionApplication
    end

Il tipo Resolver espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | Resolver |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Initialize | Metodo di inizializzazione chiamato da Autocad.
Metodo pubblico | Terminate | Metodo di chiusura chiamato da Autocad.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore Resolver

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Resolver()
Public Sub New
public:
Resolver()
new : unit -> Resolver
Vedi anche

Documentazione

Classe Resolver


Metodi di Resolver

Il tipo Resolver espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Initialize | Metodo di inizializzazione chiamato da Autocad.
Metodo pubblico | Terminate | Metodo di chiusura chiamato da Autocad.
Torna su
Vedi anche

Documentazione

Classe Resolver


Metodo Resolver.Initialize

Metodo ResolverInitialize

Metodo di inizializzazione chiamato da Autocad.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Initialize()
Public Sub Initialize
public:
virtual void Initialize() sealed
abstract Initialize : unit -> unit
override Initialize : unit -> unit

Implementa

IExtensionApplication.Initialize
Vedi anche

Documentazione

Classe Resolver


Metodo Resolver.Terminate

Metodo ResolverTerminate

Metodo di chiusura chiamato da Autocad.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Terminate()
Public Sub Terminate
public:
virtual void Terminate() sealed
abstract Terminate : unit -> unit
override Terminate : unit -> unit

Implementa

IExtensionApplication.Terminate
Vedi anche

Documentazione

Classe Resolver


Classe Util
Utility con gli assert e varie altre funzioni di utilizzo frequente.
Gerarchia di ereditarietà
SystemObject
DedNetAcadUtil

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Util
Public NotInheritable Class Util
public ref class Util abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util =  class end

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AcadFile2DedDataPart | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertReadDataFromPart | Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
AttrListEnabler | Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.
CreatePartManager | Crea e restiruisce il part manager leggendo le opzioni dal top_arx.
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
FileAttrMatchData |
FileIsDwg | Restituisce se il file passato sia o meno un DWG di AutoCAD.
FileIsNew | Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.
FileIsOpen | Restituisce vero se il file risulta aperto
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
GetAllAutocadFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetDedIdDedRevFromPartFile | Legge e restituisce i valori di dedid e dedrev dal file dwg.
GetDwgVerEnumFromString | Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.
GetDxfOutVers | Restituisce le versioni di salvataggio supportate per i Dxf.
GetDxfOutVersWithDescr | Restituisce le versioni di salvataggio supportate per i Dxf.
GetEnvFullPath | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathBase | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathUser | Ritorna la posizione dell'ambiente corrente.
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetOpenedDocumentFromFile | Controlla se il documento identificato dal file passato è aperto nella sessione corrente
GetOtherRef | Aggiunge alla lista con gli xref tutti gli altri tipi di riferimenti : PDF, DWF, DGN, IMMAGINI RASTER.
GetPrinterStyleSheetDir | Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.
GetRVerFromVersion | Restiruisce la versione R? in base all'anno.
GetXrefList | Ritorna l'elenco di tutti gli xref del disegno
IsAutocad2016SP1 | Restituisce True se è installato Autocad 2016 con SP1
OpenDoc | Metodo di apertura che chiama anche l'evento di TopPrtCreated al posto del top_prt.arx
PartAttrMatchData |
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllAttr | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromFile | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFileProperties | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPartProperties | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.
ReadFileProperties |
RelativizeXrefPath |
RelocateReferences | Riloca le dipendenze dal file si partenza al file di destinazione
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
UpdateDocumentReference | Aggiorna i riferimenti
WriteAllAttr(IDedData, Part, DedAttrList) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteDataToFile | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteDataToPart | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteUserProperties | Scrive le proprietà presenti nel dizionario all'interno del file.
Torna su
Campi
Nome | Descrizione
_dataTimeMin |
RILPDF | Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di Util

Il tipo Util espone i seguenti membri.

Metodi
Nome | Descrizione
AcadFile2DedDataPart | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
AssertAllDocumentsClose | Controlla che non ci siano dei documenti aperti
AssertCurrentDocument | Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.
AssertReadDataFromPart | Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
AttrListEnabler | Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.
CreatePartManager | Crea e restiruisce il part manager leggendo le opzioni dal top_arx.
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
FileAttrMatchData |
FileIsDwg | Restituisce se il file passato sia o meno un DWG di AutoCAD.
FileIsNew | Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.
FileIsOpen | Restituisce vero se il file risulta aperto
FillWithAssociatedFiles | Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.
GetAllAutocadFiles | Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti
GetDedIdDedRevFromPartFile | Legge e restituisce i valori di dedid e dedrev dal file dwg.
GetDwgVerEnumFromString | Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.
GetDxfOutVers | Restituisce le versioni di salvataggio supportate per i Dxf.
GetDxfOutVersWithDescr | Restituisce le versioni di salvataggio supportate per i Dxf.
GetEnvFullPath | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathBase | Ritorna la posizione dell'ambiente corrente.
GetEnvFullPathUser | Ritorna la posizione dell'ambiente corrente.
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetOpenedDocumentFromFile | Controlla se il documento identificato dal file passato è aperto nella sessione corrente
GetOtherRef | Aggiunge alla lista con gli xref tutti gli altri tipi di riferimenti : PDF, DWF, DGN, IMMAGINI RASTER.
GetPrinterStyleSheetDir | Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.
GetRVerFromVersion | Restiruisce la versione R? in base all'anno.
GetXrefList | Ritorna l'elenco di tutti gli xref del disegno
IsAutocad2016SP1 | Restituisce True se è installato Autocad 2016 con SP1
OpenDoc | Metodo di apertura che chiama anche l'evento di TopPrtCreated al posto del top_prt.arx
PartAttrMatchData |
PrecompilaCodice | Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.
ReadAllAttr | Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAnagr | Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.
ReadDataFromFile | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromFileProperties | Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPart | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.
ReadDataFromPartProperties | Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.
ReadFileProperties |
RelativizeXrefPath |
RelocateReferences | Riloca le dipendenze dal file si partenza al file di destinazione
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
UpdateDocumentReference | Aggiorna i riferimenti
WriteAllAttr(IDedData, Part, DedAttrList) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteDataToFile | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteDataToPart | Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.
WriteUserProperties | Scrive le proprietà presenti nel dizionario all'interno del file.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.AcadFile2DedDataPart

Metodo UtilAcadFile2DedDataPart

Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart AcadFile2DedDataPart(
    string filename,
    DedType refType
)
Public Shared Function AcadFile2DedDataPart (
    filename As String,
    refType As DedType
) As DedDataPart
public:
static DedDataPart^ AcadFile2DedDataPart(
    String^ filename,
    DedType^ refType
)
static member AcadFile2DedDataPart :
        filename : string *
        refType : DedType -> DedDataPart

Parametri

filename
Tipo: SystemString
File di interesse di Inventor
refType
Tipo: DedType
Famiglia di riferimento

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertAllDocumentsClose

Metodo UtilAssertAllDocumentsClose

Controlla che non ci siano dei documenti aperti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void AssertAllDocumentsClose()
Public Shared Sub AssertAllDocumentsClose
public:
static void AssertAllDocumentsClose()
static member AssertAllDocumentsClose : unit -> unit
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertCurrentDocument

Metodo UtilAssertCurrentDocument

Chiama la funzione CurrentDocument() per avere il DedDoc corrente e lo restituisce. Se il DedDoc è null solleva una eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDoc AssertCurrentDocument()
Public Shared Function AssertCurrentDocument As DedDoc
public:
static DedDoc^ AssertCurrentDocument()
static member AssertCurrentDocument : unit -> DedDoc

Valore di ritorno

Tipo: DedDoc
Vedi anche

Documentazione

Classe Util


Metodo Util.AssertReadDataFromPart

Metodo UtilAssertReadDataFromPart

Viene utilizzata la funzione ReadDataFromPart() per avere l'anagrafica della parte passata. Restituisce l'anagrafica oppure solleva una eccezione per avvisare l'utente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData AssertReadDataFromPart(
    PartInfo prt
)
Public Shared Function AssertReadDataFromPart (
    prt As PartInfo
) As DedData
public:
static DedData^ AssertReadDataFromPart(
    PartInfo^ prt
)
static member AssertReadDataFromPart :
        prt : PartInfo -> DedData

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte dalla quale leggere l'anagrafica.

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util


Metodo Util.AttrListDisabler

Metodo UtilAttrListDisabler

Lista degli overload
Nome | Descrizione
AttrListDisabler(DedAttrList) | Disabilita tutti gli attributi.
AttrListDisabler(DedAttrList, DedAttrEnvDestEnum) | Disabilita gli attributi del tipo passato.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.AttrListDisabler (DedAttrList)

Metodo UtilAttrListDisabler (DedAttrList)
Disabilita tutti gli attributi.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList
)
static member AttrListDisabler :
        inList : DedAttrList -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale

Valore di ritorno

Tipo: DedAttrList
Lista modificat
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler


Metodo Util.AttrListDisabler (DedAttrList, DedAttrEnvDestEnum)

Metodo UtilAttrListDisabler (DedAttrList, DedAttrEnvDestEnum)
Disabilita gli attributi del tipo passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListDisabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListDisabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListDisabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListDisabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale
attrEnvDestType
Tipo: DedAttrEnvDestEnum

Valore di ritorno

Tipo: DedAttrList
Lista modificat
Vedi anche

Documentazione

Classe Util
Overload di AttrListDisabler


Metodo Util.AttrListEnabler

Metodo UtilAttrListEnabler

Data la attrlist passata abilita solo gli attributi che sono corrispondenti al tipo di EnvDest passato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedAttrList AttrListEnabler(
    DedAttrList inList,
    DedAttrEnvDestEnum attrEnvDestType
)
Public Shared Function AttrListEnabler (
    inList As DedAttrList,
    attrEnvDestType As DedAttrEnvDestEnum
) As DedAttrList
public:
static DedAttrList^ AttrListEnabler(
    DedAttrList^ inList,
    DedAttrEnvDestEnum attrEnvDestType
)
static member AttrListEnabler :
        inList : DedAttrList *
        attrEnvDestType : DedAttrEnvDestEnum -> DedAttrList

Parametri

inList
Tipo: DedAttrList
Lista orginale
attrEnvDestType
Tipo: DedAttrEnvDestEnum
Tipo di attributi di riferimento

Valore di ritorno

Tipo: DedAttrList
Lista modificata
Vedi anche

Documentazione

Classe Util


Metodo Util.CreatePartManager

Metodo UtilCreatePartManager

Crea e restiruisce il part manager leggendo le opzioni dal top_arx.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static PartManager CreatePartManager(
    OdaManager odaManager,
    string acadFileName
)
Public Shared Function CreatePartManager (
    odaManager As OdaManager,
    acadFileName As String
) As PartManager
public:
static PartManager^ CreatePartManager(
    OdaManager^ odaManager,
    String^ acadFileName
)
static member CreatePartManager :
        odaManager : OdaManager *
        acadFileName : string -> PartManager

Parametri

odaManager
Tipo: OdaManager
acadFileName
Tipo: SystemString
File del quale creare il PartManager.

Valore di ritorno

Tipo: PartManager
Vedi anche

Documentazione

Classe Util


Metodo Util.File2DedDataPart

Metodo UtilFile2DedDataPart

Lista degli overload
Nome | Descrizione
File2DedDataPart(PartManager, DedType) | Legge i dati dal file di inventor e li inserisce in una DedDataPart.
File2DedDataPart(PartManager, DedType, DedAttrList) | Legge i dati dal file di autocad e li inserisce in una DedDataPart.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.File2DedDataPart (PartManager, DedType)

Metodo UtilFile2DedDataPart (PartManager, DedType)
Legge i dati dal file di inventor e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart File2DedDataPart(
    PartManager partManager,
    DedType refType
)
Public Shared Function File2DedDataPart (
    partManager As PartManager,
    refType As DedType
) As DedDataPart
public:
static DedDataPart^ File2DedDataPart(
    PartManager^ partManager,
    DedType^ refType
)
static member File2DedDataPart :
        partManager : PartManager *
        refType : DedType -> DedDataPart

Parametri

partManager
Tipo: PartManager
refType
Tipo: DedType
Famiglia di riferimento

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di File2DedDataPart


Metodo Util.File2DedDataPart (PartManager, DedType, DedAttrList)

Metodo UtilFile2DedDataPart (PartManager, DedType, DedAttrList)
Legge i dati dal file di autocad e li inserisce in una DedDataPart.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart File2DedDataPart(
    PartManager partManager,
    DedType refType,
    DedAttrList attrList
)
Public Shared Function File2DedDataPart (
    partManager As PartManager,
    refType As DedType,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ File2DedDataPart(
    PartManager^ partManager,
    DedType^ refType,
    DedAttrList^ attrList
)
static member File2DedDataPart :
        partManager : PartManager *
        refType : DedType *
        attrList : DedAttrList -> DedDataPart

Parametri

partManager
Tipo: PartManager
refType
Tipo: DedType
Famiglia di riferimento
attrList
Tipo: DedAttrList
Elenco attributi per creare il dedDataPart.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util
Overload di File2DedDataPart


Metodo Util.FileAttrMatchData

Metodo UtilFileAttrMatchData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileAttrMatchData(
    PartManager partManager,
    DedData data
)
Public Shared Function FileAttrMatchData (
    partManager As PartManager,
    data As DedData
) As Boolean
public:
static bool FileAttrMatchData(
    PartManager^ partManager,
    DedData^ data
)
static member FileAttrMatchData :
        partManager : PartManager *
        data : DedData -> bool

Parametri

partManager
Tipo: PartManager
data
Tipo: DedData

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsDwg

Metodo UtilFileIsDwg

Restituisce se il file passato sia o meno un DWG di AutoCAD.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsDwg(
    string fileName
)
Public Shared Function FileIsDwg (
    fileName As String
) As Boolean
public:
static bool FileIsDwg(
    String^ fileName
)
static member FileIsDwg :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da analizzare.

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsNew

Metodo UtilFileIsNew

Verifica se il file passato, letto da Document.Name, sia o meno un file nuovo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsNew(
    string fileName
)
Public Shared Function FileIsNew (
    fileName As String
) As Boolean
public:
static bool FileIsNew(
    String^ fileName
)
static member FileIsNew :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da verificare, letto dalla proprietà Document.Name.

Valore di ritorno

Tipo: Boolean
Restituisce true se è nuovo altrimenti false.
Vedi anche

Documentazione

Classe Util


Metodo Util.FileIsOpen

Metodo UtilFileIsOpen

Restituisce vero se il file risulta aperto

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool FileIsOpen(
    string fileName
)
Public Shared Function FileIsOpen (
    fileName As String
) As Boolean
public:
static bool FileIsOpen(
    String^ fileName
)
static member FileIsOpen :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File da analizzare

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.FillWithAssociatedFiles

Metodo UtilFillWithAssociatedFiles

Restituisce una lista contenente l'oggetto DocStructInfo passato più gli eventuali file associati presenti su disco. Restituisce sempre una lista inizializzata.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DocStructInfoList FillWithAssociatedFiles(
    AcadDocStructInfo infoItem
)
Public Shared Function FillWithAssociatedFiles (
    infoItem As AcadDocStructInfo
) As DocStructInfoList
public:
static DocStructInfoList^ FillWithAssociatedFiles(
    AcadDocStructInfo^ infoItem
)
static member FillWithAssociatedFiles :
        infoItem : AcadDocStructInfo -> DocStructInfoList

Parametri

infoItem
Tipo: DedNetAcadAcadDocStructInfo
Elemento del quale trovare i file associati.

Valore di ritorno

Tipo: DocStructInfoList
Vedi anche

Documentazione

Classe Util


Metodo Util.GetAllAutocadFiles

Metodo UtilGetAllAutocadFiles

Data la cartella o il file di riferimento ritorna tutti i file di Inventor contenuti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetAllAutocadFiles(
    string refPath
)
Public Shared Function GetAllAutocadFiles (
    refPath As String
) As List(Of String)
public:
static List<String^>^ GetAllAutocadFiles(
    String^ refPath
)
static member GetAllAutocadFiles :
        refPath : string -> List<string>

Parametri

refPath
Tipo: SystemString

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDedIdDedRevFromPartFile

Metodo UtilGetDedIdDedRevFromPartFile

Legge e restituisce i valori di dedid e dedrev dal file dwg.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void GetDedIdDedRevFromPartFile(
    PartManager prtManager,
    out string dedid,
    out string dedrev
)
Public Shared Sub GetDedIdDedRevFromPartFile (
    prtManager As PartManager,
    <OutAttribute> ByRef dedid As String,
    <OutAttribute> ByRef dedrev As String
)
public:
static void GetDedIdDedRevFromPartFile(
    PartManager^ prtManager,
    [OutAttribute] String^% dedid,
    [OutAttribute] String^% dedrev
)
static member GetDedIdDedRevFromPartFile :
        prtManager : PartManager *
        dedid : string byref *
        dedrev : string byref -> unit

Parametri

prtManager
Tipo: PartManager
Oggetto PartManager
dedid
Tipo: SystemString
Valore del campo DEDID
dedrev
Tipo: SystemString
Valore del campo DEDREV
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDwgVerEnumFromString

Metodo UtilGetDwgVerEnumFromString

Dato il nome di una versione di salvataggio ne restituisce il rispettivo Enum.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DwgVersion GetDwgVerEnumFromString(
    string val
)
Public Shared Function GetDwgVerEnumFromString (
    val As String
) As DwgVersion
public:
static DwgVersion GetDwgVerEnumFromString(
    String^ val
)
static member GetDwgVerEnumFromString :
        val : string -> DwgVersion

Parametri

val
Tipo: SystemString
Versione di salvataggio

Valore di ritorno

Tipo: DwgVersion
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDxfOutVers

Metodo UtilGetDxfOutVers

Restituisce le versioni di salvataggio supportate per i Dxf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<DwgVersion> GetDxfOutVers()
Public Shared Function GetDxfOutVers As List(Of DwgVersion)
public:
static List<DwgVersion>^ GetDxfOutVers()
static member GetDxfOutVers : unit -> List<DwgVersion>

Valore di ritorno

Tipo: List DwgVersion
Vedi anche

Documentazione

Classe Util


Metodo Util.GetDxfOutVersWithDescr

Metodo UtilGetDxfOutVersWithDescr

Restituisce le versioni di salvataggio supportate per i Dxf.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetDxfOutVersWithDescr()
Public Shared Function GetDxfOutVersWithDescr As List(Of String)
public:
static List<String^>^ GetDxfOutVersWithDescr()
static member GetDxfOutVersWithDescr : unit -> List<string>

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPath

Metodo UtilGetEnvFullPath

Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPath()
Public Shared Function GetEnvFullPath As String
public:
static String^ GetEnvFullPath()
static member GetEnvFullPath : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPathBase

Metodo UtilGetEnvFullPathBase

Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPathBase()
Public Shared Function GetEnvFullPathBase As String
public:
static String^ GetEnvFullPathBase()
static member GetEnvFullPathBase : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetEnvFullPathUser

Metodo UtilGetEnvFullPathUser

Ritorna la posizione dell'ambiente corrente.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetEnvFullPathUser()
Public Shared Function GetEnvFullPathUser As String
public:
static String^ GetEnvFullPathUser()
static member GetEnvFullPathUser : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetLastDataRowVer

Metodo UtilGetLastDataRowVer

Lista degli overload
Nome | Descrizione
GetLastDataRowVer(PartManager) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
GetLastDataRowVer(PartInfo) | Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.GetLastDataRowVer (PartManager)

Metodo UtilGetLastDataRowVer (PartManager)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    PartManager partManager
)
Public Shared Function GetLastDataRowVer (
    partManager As PartManager
) As Guid
public:
static Guid GetLastDataRowVer(
    PartManager^ partManager
)
static member GetLastDataRowVer :
        partManager : PartManager -> Guid

Parametri

partManager
Tipo: PartManager

Valore di ritorno

Tipo: Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer


Metodo Util.GetLastDataRowVer (PartInfo)

Metodo UtilGetLastDataRowVer (PartInfo)
Restituisce il ROWVER utilizzato per aggiornare l'anagrafica nel documento passato alla sua apertura. Restituisce un guid Empty se non viene trovato.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Guid GetLastDataRowVer(
    PartInfo prtInfo
)
Public Shared Function GetLastDataRowVer (
    prtInfo As PartInfo
) As Guid
public:
static Guid GetLastDataRowVer(
    PartInfo^ prtInfo
)
static member GetLastDataRowVer :
        prtInfo : PartInfo -> Guid

Parametri

prtInfo
Tipo: DedNetAcadPartInfo
PartInfo del disegno.

Valore di ritorno

Tipo: Guid
Vedi anche

Documentazione

Classe Util
Overload di GetLastDataRowVer


Metodo Util.GetOpenedDocumentFromFile

Metodo UtilGetOpenedDocumentFromFile

Controlla se il documento identificato dal file passato è aperto nella sessione corrente

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Document GetOpenedDocumentFromFile(
    string fileName
)
Public Shared Function GetOpenedDocumentFromFile (
    fileName As String
) As Document
public:
static Document^ GetOpenedDocumentFromFile(
    String^ fileName
)
static member GetOpenedDocumentFromFile :
        fileName : string -> Document

Parametri

fileName
Tipo: SystemString
File da analizzare

Valore di ritorno

Tipo: Document
Vedi anche

Documentazione

Classe Util


Metodo Util.GetOtherRef

Metodo UtilGetOtherRef

Aggiunge alla lista con gli xref tutti gli altri tipi di riferimenti : PDF, DWF, DGN, IMMAGINI RASTER.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void GetOtherRef(
    string filename,
    Transaction tran,
    Database db,
    List<string> xRefList
)
Public Shared Sub GetOtherRef (
    filename As String,
    tran As Transaction,
    db As Database,
    xRefList As List(Of String)
)
public:
static void GetOtherRef(
    String^ filename,
    Transaction^ tran,
    Database^ db,
    List<String^>^ xRefList
)
static member GetOtherRef :
        filename : string *
        tran : Transaction *
        db : Database *
        xRefList : List<string> -> unit

Parametri

filename
Tipo: SystemString
tran
Tipo: Transaction
Transazione
db
Tipo: Database
Database
xRefList
Tipo: System.Collections.GenericList String
Lista dei riferimenti da ampliare
Vedi anche

Documentazione

Classe Util


Metodo Util.GetPrinterStyleSheetDir

Metodo UtilGetPrinterStyleSheetDir

Restituisce il percorso dove sono presenti i fogli di stile, usato dalla pubblicazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetPrinterStyleSheetDir()
Public Shared Function GetPrinterStyleSheetDir As String
public:
static String^ GetPrinterStyleSheetDir()
static member GetPrinterStyleSheetDir : unit -> string

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetRVerFromVersion

Metodo UtilGetRVerFromVersion

Restiruisce la versione R? in base all'anno.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static string GetRVerFromVersion(
    string ver
)
Public Shared Function GetRVerFromVersion (
    ver As String
) As String
public:
static String^ GetRVerFromVersion(
    String^ ver
)
static member GetRVerFromVersion :
        ver : string -> string

Parametri

ver
Tipo: SystemString
Anno di AutocadLT

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe Util


Metodo Util.GetXrefList

Metodo UtilGetXrefList

Ritorna l'elenco di tutti gli xref del disegno

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static List<string> GetXrefList(
    string filename,
    bool allLevels = false
)
Public Shared Function GetXrefList (
    filename As String,
    Optional allLevels As Boolean = false
) As List(Of String)
public:
static List<String^>^ GetXrefList(
    String^ filename,
    bool allLevels = false
)
static member GetXrefList :
        filename : string *
        ?allLevels : bool
(* Defaults:
        let _allLevels = defaultArg allLevels false
*)
-> List<string>

Parametri

filename
Tipo: SystemString
FileName di riferimento del documento
allLevels (Optional)
Tipo: SystemBoolean
Indica se ritornare un elenco di tutti i livelli

Valore di ritorno

Tipo: List String
Vedi anche

Documentazione

Classe Util


Metodo Util.IsAutocad2016SP1

Metodo UtilIsAutocad2016SP1

Restituisce True se è installato Autocad 2016 con SP1

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool IsAutocad2016SP1()
Public Shared Function IsAutocad2016SP1 As Boolean
public:
static bool IsAutocad2016SP1()
static member IsAutocad2016SP1 : unit -> bool

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.OpenDoc

Metodo UtilOpenDoc

Metodo di apertura che chiama anche l'evento di TopPrtCreated al posto del top_prt.arx

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static QsDocument OpenDoc(
    string fullFileName,
    bool readOnly
)
Public Shared Function OpenDoc (
    fullFileName As String,
    readOnly As Boolean
) As QsDocument
public:
static QsDocument^ OpenDoc(
    String^ fullFileName,
    bool readOnly
)
static member OpenDoc :
        fullFileName : string *
        readOnly : bool -> QsDocument

Parametri

fullFileName
Tipo: SystemString
fullfilename
readOnly
Tipo: SystemBoolean
sola lettura

Valore di ritorno

Tipo: QsDocument
Vedi anche

Documentazione

Classe Util


Metodo Util.PartAttrMatchData

Metodo UtilPartAttrMatchData

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool PartAttrMatchData(
    PartInfo pInfo,
    DedData data
)
Public Shared Function PartAttrMatchData (
    pInfo As PartInfo,
    data As DedData
) As Boolean
public:
static bool PartAttrMatchData(
    PartInfo^ pInfo,
    DedData^ data
)
static member PartAttrMatchData :
        pInfo : PartInfo *
        data : DedData -> bool

Parametri

pInfo
Tipo: DedNetAcadPartInfo
data
Tipo: DedData

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.PrecompilaCodice

Metodo UtilPrecompilaCodice

Precompila il codice dell'apri veloce in base alla selezione attiva e al campo di ricerca.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void PrecompilaCodice(
    FindCodeCommand cmd
)
Public Shared Sub PrecompilaCodice (
    cmd As FindCodeCommand
)
public:
static void PrecompilaCodice(
    FindCodeCommand^ cmd
)
static member PrecompilaCodice :
        cmd : FindCodeCommand -> unit

Parametri

cmd
Tipo: FindCodeCommand
Comando di apri veloce.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllAttr

Metodo UtilReadAllAttr

Legge tutti gli attributi dalla parte e li restituisce sotto forma di DedDataPart. Gli attributi nella parte sono salvati come stringhe quindi tenta di convertire il valore stringa nel tipo di dato presente nel Db. Se non ci riesce salta lasciando vuoto il valore

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedDataPart ReadAllAttr(
    PartInfo prt,
    DedAttrList attrList
)
Public Shared Function ReadAllAttr (
    prt As PartInfo,
    attrList As DedAttrList
) As DedDataPart
public:
static DedDataPart^ ReadAllAttr(
    PartInfo^ prt,
    DedAttrList^ attrList
)
static member ReadAllAttr :
        prt : PartInfo *
        attrList : DedAttrList -> DedDataPart

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte dalla quale leggere le informazioni.
attrList
Tipo: DedAttrList
Lista degli attributi da leggere dalla parte.

Valore di ritorno

Tipo: DedDataPart
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllProperties

Metodo UtilReadAllProperties

Lista degli overload
Nome | Descrizione
ReadAllProperties(PartManager) | Legge le proprietà presenti all'interno del file e li restituisce.
ReadAllProperties(PartInfo) | Legge le proprietà presenti all'interno del file e li restituisce.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadAllProperties (PartManager)

Metodo UtilReadAllProperties (PartManager)
Legge le proprietà presenti all'interno del file e li restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    PartManager partManager
)
Public Shared Function ReadAllProperties (
    partManager As PartManager
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    PartManager^ partManager
)
static member ReadAllProperties :
        partManager : PartManager -> Dictionary<string, Object>

Parametri

partManager
Tipo: PartManager

Valore di ritorno

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties


Metodo Util.ReadAllProperties (PartInfo)

Metodo UtilReadAllProperties (PartInfo)
Legge le proprietà presenti all'interno del file e li restituisce.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadAllProperties(
    PartInfo prtInfo
)
Public Shared Function ReadAllProperties (
    prtInfo As PartInfo
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadAllProperties(
    PartInfo^ prtInfo
)
static member ReadAllProperties :
        prtInfo : PartInfo -> Dictionary<string, Object>

Parametri

prtInfo
Tipo: DedNetAcadPartInfo

Valore di ritorno

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe Util
Overload di ReadAllProperties


Metodo Util.ReadAnagr

Metodo UtilReadAnagr

Legge e restituisce l'anagrafica dal Database. Restituisce null se non è presente. Ignora eventuali errori.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadAnagr(
    string dedid,
    string dedrev
)
Public Shared Function ReadAnagr (
    dedid As String,
    dedrev As String
) As DedData
public:
static DedData^ ReadAnagr(
    String^ dedid,
    String^ dedrev
)
static member ReadAnagr :
        dedid : string *
        dedrev : string -> DedData

Parametri

dedid
Tipo: SystemString
dedrev
Tipo: SystemString

Valore di ritorno

Tipo: DedData
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromFile

Metodo UtilReadDataFromFile

Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromFile(
    PartManager partManager,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromFile (
    partManager As PartManager,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromFile(
    PartManager^ partManager,
    bool checkDataMatching = true
)
static member ReadDataFromFile :
        partManager : PartManager *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

partManager
Tipo: PartManager
PartManager del file dal quale leggere le informazioni.
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza del file oppure null se non è codificata.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromFileProperties

Metodo UtilReadDataFromFileProperties

Legge il dedid ed il dedrev da una file e ne ricava l'anagrafica. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromFileProperties(
    PartManager partManager
)
Public Shared Function ReadDataFromFileProperties (
    partManager As PartManager
) As DedData
public:
static DedData^ ReadDataFromFileProperties(
    PartManager^ partManager
)
static member ReadDataFromFileProperties :
        partManager : PartManager -> DedData

Parametri

partManager
Tipo: PartManager
PartManager del file dal quale leggere le informazioni.

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza del file oppure null se non è codificata.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromPart

Metodo UtilReadDataFromPart

Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica. Se si tratta della parte Top verifica anche che il nome del documento corrente sia di un documento collegato come primario all'anagrafia. Se la parte non ha codice corrispondente nel Database restituisce null.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromPart(
    PartInfo prt,
    bool checkDataMatching = true
)
Public Shared Function ReadDataFromPart (
    prt As PartInfo,
    Optional checkDataMatching As Boolean = true
) As DedData
public:
static DedData^ ReadDataFromPart(
    PartInfo^ prt,
    bool checkDataMatching = true
)
static member ReadDataFromPart :
        prt : PartInfo *
        ?checkDataMatching : bool
(* Defaults:
        let _checkDataMatching = defaultArg checkDataMatching true
*)
-> DedData

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte dalla quale leggere le informazioni.
checkDataMatching (Optional)
Tipo: SystemBoolean

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza della parte oppure null se non è codificata.
Note
Questa funzione suppone che all'apertura siano stati inseriti nella parte Top i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Ne verifica la coerenza con il percorso del file ma non ne ricalcola i valori.
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadDataFromPartProperties

Metodo UtilReadDataFromPartProperties

Legge il dedid ed il dedrev da una parte e ne ricava l'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedData ReadDataFromPartProperties(
    PartInfo prt
)
Public Shared Function ReadDataFromPartProperties (
    prt As PartInfo
) As DedData
public:
static DedData^ ReadDataFromPartProperties(
    PartInfo^ prt
)
static member ReadDataFromPartProperties :
        prt : PartInfo -> DedData

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte dalla quale leggere le informazioni.

Valore di ritorno

Tipo: DedData
Restituisce l'anagrafica di appartenenza della parte oppure null se non è codificata.
Note
Attenzione! Questa funzione suppone che all'apertura siano stati inseriti nella parte Top i corretti attributi DEDID e DEDREV dell'anagrafica alla quale il documento è associato. Non ne verifica la coerenza!!
Vedi anche

Documentazione

Classe Util


Metodo Util.ReadFileProperties

Metodo UtilReadFileProperties

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ReadFileProperties(
    PartManager partManager
)
Public Shared Function ReadFileProperties (
    partManager As PartManager
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ReadFileProperties(
    PartManager^ partManager
)
static member ReadFileProperties :
        partManager : PartManager -> Dictionary<string, Object>

Parametri

partManager
Tipo: PartManager

Valore di ritorno

Tipo: Dictionary String, Object
Vedi anche

Documentazione

Classe Util


Metodo Util.RelativizeXrefPath

Metodo UtilRelativizeXrefPath

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RelativizeXrefPath(
    string filename,
    string destFileName,
    bool allLevels = false
)
Public Shared Sub RelativizeXrefPath (
    filename As String,
    destFileName As String,
    Optional allLevels As Boolean = false
)
public:
static void RelativizeXrefPath(
    String^ filename,
    String^ destFileName,
    bool allLevels = false
)
static member RelativizeXrefPath :
        filename : string *
        destFileName : string *
        ?allLevels : bool
(* Defaults:
        let _allLevels = defaultArg allLevels false
*)
-> unit

Parametri

filename
Tipo: SystemString
destFileName
Tipo: SystemString
allLevels (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util


Metodo Util.RelocateReferences

Metodo UtilRelocateReferences

Riloca le dipendenze dal file si partenza al file di destinazione

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void RelocateReferences(
    string startFileName,
    string fileName
)
Public Shared Sub RelocateReferences (
    startFileName As String,
    fileName As String
)
public:
static void RelocateReferences(
    String^ startFileName,
    String^ fileName
)
static member RelocateReferences :
        startFileName : string *
        fileName : string -> unit

Parametri

startFileName
Tipo: SystemString
fileName
Tipo: SystemString
Vedi anche

Documentazione

Classe Util


Metodo Util.SetLastDataRowVer

Metodo UtilSetLastDataRowVer

Lista degli overload
Nome | Descrizione
SetLastDataRowVer(PartManager, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.
SetLastDataRowVer(PartInfo, Guid) | Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.SetLastDataRowVer (PartManager, Guid)

Metodo UtilSetLastDataRowVer (PartManager, Guid)
Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    PartManager partManager,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    partManager As PartManager,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    PartManager^ partManager,
    Guid rowver
)
static member SetLastDataRowVer :
        partManager : PartManager *
        rowver : Guid -> unit

Parametri

partManager
Tipo: PartManager
rowver
Tipo: SystemGuid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer


Metodo Util.SetLastDataRowVer (PartInfo, Guid)

Metodo UtilSetLastDataRowVer (PartInfo, Guid)
Imposta nel documento il rowver utilizzato per aggiornare i dati nel documento. NB : Necessario salvare il PartInfo dopo questa operazione.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void SetLastDataRowVer(
    PartInfo prtInfo,
    Guid rowver
)
Public Shared Sub SetLastDataRowVer (
    prtInfo As PartInfo,
    rowver As Guid
)
public:
static void SetLastDataRowVer(
    PartInfo^ prtInfo,
    Guid rowver
)
static member SetLastDataRowVer :
        prtInfo : PartInfo *
        rowver : Guid -> unit

Parametri

prtInfo
Tipo: DedNetAcadPartInfo
PartInfo del disegno..
rowver
Tipo: SystemGuid
Rowver da impostare nel documento.
Vedi anche

Documentazione

Classe Util
Overload di SetLastDataRowVer


Metodo Util.UpdateDocumentReference

Metodo UtilUpdateDocumentReference

Aggiorna i riferimenti

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static bool UpdateDocumentReference(
    string fileName,
    string startRefName,
    string destRefName
)
Public Shared Function UpdateDocumentReference (
    fileName As String,
    startRefName As String,
    destRefName As String
) As Boolean
public:
static bool UpdateDocumentReference(
    String^ fileName,
    String^ startRefName,
    String^ destRefName
)
static member UpdateDocumentReference :
        fileName : string *
        startRefName : string *
        destRefName : string -> bool

Parametri

fileName
Tipo: SystemString
File del quale aggiornare i riferimenti
startRefName
Tipo: SystemString
Riferimento di partenza
destRefName
Tipo: SystemString
Riferimento di destinazione

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllAttr

Metodo UtilWriteAllAttr

Lista degli overload
Nome | Descrizione
WriteAllAttr(IDedData, Part, DedAttrList) | Scrive tutti gli attributi nel file leggendoli dall'anagrafica.
WriteAllAttr(IDedData, PartInfo, DedAttrList, Boolean) | Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllAttr (IDedData, Part, DedAttrList)

Metodo UtilWriteAllAttr (IDedData, Part, DedAttrList)
Scrive tutti gli attributi nel file leggendoli dall'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllAttr(
    IDedData data,
    Part part,
    DedAttrList attrList
)
Public Shared Sub WriteAllAttr (
    data As IDedData,
    part As Part,
    attrList As DedAttrList
)
public:
static void WriteAllAttr(
    IDedData^ data,
    Part^ part,
    DedAttrList^ attrList
)
static member WriteAllAttr :
        data : IDedData *
        part : Part *
        attrList : DedAttrList -> unit

Parametri

data
Tipo: IDedData
Anagrafica dalla quale prendere gli attributi.
part
Tipo: Part
attrList
Tipo: DedAttrList
Lista degli attributi da scrivere nella parte.
Vedi anche

Documentazione

Classe Util
Overload di WriteAllAttr


Metodo Util.WriteAllAttr (IDedData, PartInfo, DedAttrList, Boolean)

Metodo UtilWriteAllAttr (IDedData, PartInfo, DedAttrList, Boolean)
Scrive tutti gli attributi nella parte leggendoli dall'anagrafica.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllAttr(
    IDedData data,
    PartInfo prt,
    DedAttrList attrList,
    bool ignoreEsclAttrList = false
)
Public Shared Sub WriteAllAttr (
    data As IDedData,
    prt As PartInfo,
    attrList As DedAttrList,
    Optional ignoreEsclAttrList As Boolean = false
)
public:
static void WriteAllAttr(
    IDedData^ data,
    PartInfo^ prt,
    DedAttrList^ attrList,
    bool ignoreEsclAttrList = false
)
static member WriteAllAttr :
        data : IDedData *
        prt : PartInfo *
        attrList : DedAttrList *
        ?ignoreEsclAttrList : bool
(* Defaults:
        let _ignoreEsclAttrList = defaultArg ignoreEsclAttrList false
*)
-> unit

Parametri

data
Tipo: IDedData
Anagrafica dalla quale prendere gli attributi.
prt
Tipo: DedNetAcadPartInfo
Parte nella quale scrivere gli attributi.
attrList
Tipo: DedAttrList
Lista degli attributi da scrivere nella parte.
ignoreEsclAttrList (Optional)
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe Util
Overload di WriteAllAttr


Metodo Util.WriteAllProperties

Metodo UtilWriteAllProperties

Lista degli overload
Nome | Descrizione
WriteAllProperties(DedDoc, PartInfo) | Scrive tutte le proprietà del documento nel Database
WriteAllProperties(DedDoc, PartManager) | Scrive tutte le proprietà del documento nel Database
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAllProperties (DedDoc, PartInfo)

Metodo UtilWriteAllProperties (DedDoc, PartInfo)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    PartInfo prtInfo
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    prtInfo As PartInfo
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    PartInfo^ prtInfo
)
static member WriteAllProperties :
        doc : DedDoc *
        prtInfo : PartInfo -> unit

Parametri

doc
Tipo: DedDoc
DedDoc dal quale leggere le propretà
prtInfo
Tipo: DedNetAcadPartInfo
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties


Metodo Util.WriteAllProperties (DedDoc, PartManager)

Metodo UtilWriteAllProperties (DedDoc, PartManager)
Scrive tutte le proprietà del documento nel Database

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAllProperties(
    DedDoc doc,
    PartManager partManager
)
Public Shared Sub WriteAllProperties (
    doc As DedDoc,
    partManager As PartManager
)
public:
static void WriteAllProperties(
    DedDoc^ doc,
    PartManager^ partManager
)
static member WriteAllProperties :
        doc : DedDoc *
        partManager : PartManager -> unit

Parametri

doc
Tipo: DedDoc
DedDoc dal quale leggere le propretà
partManager
Tipo: PartManager
Vedi anche

Documentazione

Classe Util
Overload di WriteAllProperties


Metodo Util.WriteAttr

Metodo UtilWriteAttr

Lista degli overload
Nome | Descrizione
WriteAttr(Part, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
WriteAttr(PartInfo, DedAttr, Object) | Scrive il valore di un attributo, proveniente dal Database, in una parte.
Torna su
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteAttr (Part, DedAttr, Object)

Metodo UtilWriteAttr (Part, DedAttr, Object)
Scrive il valore di un attributo, proveniente dal Database, in una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAttr(
    Part prt,
    DedAttr attr,
    Object val
)
Public Shared Sub WriteAttr (
    prt As Part,
    attr As DedAttr,
    val As Object
)
public:
static void WriteAttr(
    Part^ prt,
    DedAttr^ attr,
    Object^ val
)
static member WriteAttr :
        prt : Part *
        attr : DedAttr *
        val : Object -> unit

Parametri

prt
Tipo: Part
Parte nella quale scrivere il valore.
attr
Tipo: DedAttr
Attributo da compilare.
val
Tipo: SystemObject
Valore presente nel Database.
Vedi anche

Documentazione

Classe Util
Overload di WriteAttr


Metodo Util.WriteAttr (PartInfo, DedAttr, Object)

Metodo UtilWriteAttr (PartInfo, DedAttr, Object)
Scrive il valore di un attributo, proveniente dal Database, in una parte.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteAttr(
    PartInfo prt,
    DedAttr attr,
    Object val
)
Public Shared Sub WriteAttr (
    prt As PartInfo,
    attr As DedAttr,
    val As Object
)
public:
static void WriteAttr(
    PartInfo^ prt,
    DedAttr^ attr,
    Object^ val
)
static member WriteAttr :
        prt : PartInfo *
        attr : DedAttr *
        val : Object -> unit

Parametri

prt
Tipo: DedNetAcadPartInfo
Parte nella quale scrivere il valore.
attr
Tipo: DedAttr
Attributo da compilare.
val
Tipo: SystemObject
Valore presente nel Database.
Vedi anche

Documentazione

Classe Util
Overload di WriteAttr


Metodo Util.WriteDataToFile

Metodo UtilWriteDataToFile

Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteDataToFile(
    DedData data,
    PartManager partManager
)
Public Shared Sub WriteDataToFile (
    data As DedData,
    partManager As PartManager
)
public:
static void WriteDataToFile(
    DedData^ data,
    PartManager^ partManager
)
static member WriteDataToFile :
        data : DedData *
        partManager : PartManager -> unit

Parametri

data
Tipo: DedData
Anagrafica da scrivere nella parte e proveniente dal Database.
partManager
Tipo: PartManager
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteDataToPart

Metodo UtilWriteDataToPart

Aggiorna gli attributi dal database ad una parte. Se si tratta della parte Top controlla che l'anagrafica sia coerente con il documento attivo ed imposta anche il DEDROWVER nel documento attivo.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteDataToPart(
    DedData data,
    PartInfo prt,
    bool enforceOperation = false
)
Public Shared Sub WriteDataToPart (
    data As DedData,
    prt As PartInfo,
    Optional enforceOperation As Boolean = false
)
public:
static void WriteDataToPart(
    DedData^ data,
    PartInfo^ prt,
    bool enforceOperation = false
)
static member WriteDataToPart :
        data : DedData *
        prt : PartInfo *
        ?enforceOperation : bool
(* Defaults:
        let _enforceOperation = defaultArg enforceOperation false
*)
-> unit

Parametri

data
Tipo: DedData
Anagrafica da scrivere nella parte e proveniente dal Database.
prt
Tipo: DedNetAcadPartInfo
Parte nella quale aggiornare gli attributi.
enforceOperation (Optional)
Tipo: SystemBoolean
Se attivo forzo l'operazione. Copia anche se il documento non corrisponde al deddata passato.
Vedi anche

Documentazione

Classe Util


Metodo Util.WriteUserProperties

Metodo UtilWriteUserProperties

Scrive le proprietà presenti nel dizionario all'interno del file.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void WriteUserProperties(
    string fullFileName,
    Dictionary<string, Object> attrs
)
Public Shared Sub WriteUserProperties (
    fullFileName As String,
    attrs As Dictionary(Of String, Object)
)
public:
static void WriteUserProperties(
    String^ fullFileName,
    Dictionary<String^, Object^>^ attrs
)
static member WriteUserProperties :
        fullFileName : string *
        attrs : Dictionary<string, Object> -> unit

Parametri

fullFileName
Tipo: SystemString
File nel quale scrivere
attrs
Tipo: System.Collections.GenericDictionary String, Object
Vedi anche

Documentazione

Classe Util


Campi di Util

Il tipo Util espone i seguenti membri.

Campi
Nome | Descrizione
_dataTimeMin |
RILPDF | Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.
Torna su
Vedi anche

Documentazione

Classe Util


Campo Util._dataTimeMin

Campo Util_dataTimeMin

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DateTime _dataTimeMin
Public Shared _dataTimeMin As DateTime
public:
static DateTime _dataTimeMin
static val mutable _dataTimeMin: DateTime

Valore del campo

Tipo: DateTime
Vedi anche

Documentazione

Classe Util


Campo Util.RILPDF

Campo UtilRILPDF
Ritorna il nome della configurazione da utilizzare per esportare il documento in PDF.

Namespace: DedNetAcad
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public const string RILPDF = "RILPDF"
Public Const RILPDF As String = "RILPDF"
public:
literal String^ RILPDF = "RILPDF"
static val mutable RILPDF: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe Util


DedNetAcad.Forms Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedAcadPackAndGoExportForm |
Classe pubblica | DedAcadPackAndGoImportForm |
Classe pubblica | DocumentsForm |
Classe pubblica | MultipleStateOperation |
Classe pubblica | MultipleStateOperationPartInfoDoc |
Delegate
 | Delegate | Descrizione
Delegate pubblico | MultipleStateOperationOperationDelagateHandler |


Classe DedAcadPackAndGoExportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDedAcadPackAndGoExportForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadPackAndGoExportForm : BaseForm
Public Class DedAcadPackAndGoExportForm
    Inherits BaseForm
public ref class DedAcadPackAndGoExportForm : public BaseForm
type DedAcadPackAndGoExportForm =
    class
        inherit BaseForm
    end

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Proprietà di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Metodi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoExportForm.Dispose

Metodo DedAcadPackAndGoExportFormDispose

Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Eventi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Campi di DedAcadPackAndGoExportForm

Il tipo DedAcadPackAndGoExportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoExportForm
Namespace DedNetAcad.Forms


Classe DedAcadPackAndGoImportForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDedAcadPackAndGoImportForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedAcadPackAndGoImportForm : BaseForm
Public Class DedAcadPackAndGoImportForm
    Inherits BaseForm
public ref class DedAcadPackAndGoImportForm : public BaseForm
type DedAcadPackAndGoImportForm =
    class
        inherit BaseForm
    end

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedAcadPackAndGoImportForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore DedAcadPackAndGoImportForm

Costruttore unico.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedAcadPackAndGoImportForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedAcadPackAndGoImportForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedAcadPackAndGoImportForm

Parametri

app
Tipo: DedNetApplication
Applicazione
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Proprietà di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo pubblico | DeSerializeXml | Deserializza il file .xml
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoImportForm.DeSerializeXml

Metodo DedAcadPackAndGoImportFormDeSerializeXml

Deserializza il file .xml

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PackAndGoStructureDescriptor DeSerializeXml(
    string fn
)
Public Function DeSerializeXml (
    fn As String
) As PackAndGoStructureDescriptor
public:
PackAndGoStructureDescriptor^ DeSerializeXml(
    String^ fn
)
member DeSerializeXml :
        fn : string -> PackAndGoStructureDescriptor

Parametri

fn
Tipo: SystemString
File da deserializzare.

Valore di ritorno

Tipo: PackAndGoStructureDescriptor
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Metodo DedAcadPackAndGoImportForm.Dispose

Metodo DedAcadPackAndGoImportFormDispose

Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Eventi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Campi di DedAcadPackAndGoImportForm

Il tipo DedAcadPackAndGoImportForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DedAcadPackAndGoImportForm
Namespace DedNetAcad.Forms


Classe DocumentsForm
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsDocumentsForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DocumentsForm : BaseForm
Public Class DocumentsForm
    Inherits BaseForm
public ref class DocumentsForm : public BaseForm
type DocumentsForm =
    class
        inherit BaseForm
    end

Il tipo DocumentsForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DocumentsForm |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | ctrDoc |
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore DocumentsForm

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DocumentsForm(
    DedNetApplication _app
)
Public Sub New (
    _app As DedNetApplication
)
public:
DocumentsForm(
    DedNetApplication^ _app
)
new :
        _app : DedNetApplication -> DocumentsForm

Parametri

_app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Proprietà di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Metodi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Metodo DocumentsForm.Dispose

Metodo DocumentsFormDispose

Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Eventi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Campi di DocumentsForm

Il tipo DocumentsForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | ctrDoc |
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Campo DocumentsForm.ctrDoc

Campo DocumentsFormctrDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDocControl ctrDoc
Public ctrDoc As DedDocControl
public:
DedDocControl^ ctrDoc
val mutable ctrDoc: DedDocControl

Valore del campo

Tipo: DedDocControl
Vedi anche

Documentazione

Classe DocumentsForm
Namespace DedNetAcad.Forms


Classe MultipleStateOperation
Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
DedNetAcad.FormsMultipleStateOperation

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class MultipleStateOperation : BaseForm
Public Class MultipleStateOperation
    Inherits BaseForm
public ref class MultipleStateOperation : public BaseForm
type MultipleStateOperation =
    class
        inherit BaseForm
    end

Il tipo MultipleStateOperation espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperation | Costruttore
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore MultipleStateOperation

Costruttore

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperation(
    DedNetApplication app,
    DedState operation,
    List<MultipleStateOperationPartInfoDoc> dl,
    Bitmap cmdImg
)
Public Sub New (
    app As DedNetApplication,
    operation As DedState,
    dl As List(Of MultipleStateOperationPartInfoDoc),
    cmdImg As Bitmap
)
public:
MultipleStateOperation(
    DedNetApplication^ app,
    DedState^ operation,
    List<MultipleStateOperationPartInfoDoc^>^ dl,
    Bitmap^ cmdImg
)
new :
        app : DedNetApplication *
        operation : DedState *
        dl : List<MultipleStateOperationPartInfoDoc> *
        cmdImg : Bitmap -> MultipleStateOperation

Parametri

app
Tipo: DedNetApplication
Applicazione DedNet
operation
Tipo: DedState
Tipo di operazione da applicare
dl
Tipo: System.Collections.GenericList MultipleStateOperationPartInfoDoc
Descrittore Struttura del Documento di Testa
cmdImg
Tipo: System.DrawingBitmap
Icona del comando. Dipende dal tipo di operazione da attuare.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | Application | (Ereditato da BaseForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà pubblica | ChangeStateNote | Note di cambio stato
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MainRegistryKey | (Ereditato da BaseForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà pubblica | OperationDelegate | Proprietà per impostare il delegate dell'operazione sul singolo oggetto
Proprietà pubblica | Res | Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.ChangeStateNote

Proprietà MultipleStateOperationChangeStateNote

Note di cambio stato

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ChangeStateNote { get; set; }
Public Property ChangeStateNote As String
    Get
    Set
public:
property String^ ChangeStateNote {
    String^ get ();
    void set (String^ value);
}
member ChangeStateNote : string with get, set

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.OperationDelegate

Proprietà MultipleStateOperationOperationDelegate

Proprietà per impostare il delegate dell'operazione sul singolo oggetto

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public MultipleStateOperationOperationDelagateHandler OperationDelegate { get; set; }
Public Property OperationDelegate As MultipleStateOperationOperationDelagateHandler
    Get
    Set
public:
property MultipleStateOperationOperationDelagateHandler^ OperationDelegate {
    MultipleStateOperationOperationDelagateHandler^ get ();
    void set (MultipleStateOperationOperationDelagateHandler^ value);
}
member OperationDelegate : MultipleStateOperationOperationDelagateHandler with get, set

Valore della proprietà

Tipo: MultipleStateOperationOperationDelagateHandler
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.Res

Proprietà MultipleStateOperationRes

Restituisce il risultato del comando. Restituisce Success se sè stato premuto Ok almeno una volta altrimenti UserCancelled.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCmdResult Res { get; }
Public ReadOnly Property Res As DedCmdResult
    Get
public:
property DedCmdResult Res {
    DedCmdResult get ();
}
member Res : DedCmdResult with get

Valore della proprietà

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | AddGeneralUtilities(Bar, String) | (Ereditato da BaseForm.)
Metodo protetto | AddGeneralUtilities(Bar, DockManager, String) | (Ereditato da BaseForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetPixelSizeForCurrentDpiSettings | (Ereditato da BaseForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo pubblico | LoadRegistrySettings | Carica dal registro lo stato di visualizzazione livelli dell'albero
Metodo protetto | LoadSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | MakeRegistryKey | (Ereditato da BaseForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | OnVisibleChanged | (Ereditato da BaseForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo pubblico | SaveRegistrySettings | Salva nel registro lo stato di visualizzazione livelli dell'albero.
Metodo protetto | SaveSizeAndPosition | (Ereditato da BaseForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.Dispose

Metodo MultipleStateOperationDispose

Clean up any resources being used.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.LoadRegistrySettings

Metodo MultipleStateOperationLoadRegistrySettings

Carica dal registro lo stato di visualizzazione livelli dell'albero

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void LoadRegistrySettings()
Public Sub LoadRegistrySettings
public:
void LoadRegistrySettings()
member LoadRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Metodo MultipleStateOperation.SaveRegistrySettings

Metodo MultipleStateOperationSaveRegistrySettings

Salva nel registro lo stato di visualizzazione livelli dell'albero.

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SaveRegistrySettings()
Public Sub SaveRegistrySettings
public:
void SaveRegistrySettings()
member SaveRegistrySettings : unit -> unit
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Eventi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Campi di MultipleStateOperation

Il tipo MultipleStateOperation espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo pubblico | defaultLookAndFeel1 | (Ereditato da BaseForm.)
Campo protetto | DpiBasedMinimumSize | (Ereditato da BaseForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperation
Namespace DedNetAcad.Forms


Delegate MultipleStateOperation.OperationDelagateHandler

Delegate MultipleStateOperationOperationDelagateHandler

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public delegate DedCmdResult OperationDelagateHandler(
    DedState targetState,
    string changeNote,
    MultipleStateOperationPartInfoDoc docInfo,
    bool multiplo,
    out string message,
    out List<Exception> pubExtList
)
Public Delegate Function OperationDelagateHandler (
    targetState As DedState,
    changeNote As String,
    docInfo As MultipleStateOperationPartInfoDoc,
    multiplo As Boolean,
    <OutAttribute> ByRef message As String,
    <OutAttribute> ByRef pubExtList As List(Of Exception)
) As DedCmdResult
public delegate DedCmdResult OperationDelagateHandler(
    DedState^ targetState,
    String^ changeNote,
    MultipleStateOperationPartInfoDoc^ docInfo,
    bool multiplo,
    [OutAttribute] String^% message,
    [OutAttribute] List<Exception^>^% pubExtList
)
type OperationDelagateHandler =
    delegate of
        targetState : DedState *
        changeNote : string *
        docInfo : MultipleStateOperationPartInfoDoc *
        multiplo : bool *
        message : string byref *
        pubExtList : List<Exception> byref -> DedCmdResult

Parametri

targetState
Tipo: DedState
changeNote
Tipo: SystemString
docInfo
Tipo: DedNetAcad.FormsMultipleStateOperationPartInfoDoc
multiplo
Tipo: SystemBoolean
message
Tipo: SystemString
pubExtList
Tipo: System.Collections.GenericList Exception

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Classe MultipleStateOperation.PartInfoDoc

Classe MultipleStateOperationPartInfoDoc
Gerarchia di ereditarietà
SystemObject
DedNetAcad.FormsMultipleStateOperationPartInfoDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class PartInfoDoc
Public Class PartInfoDoc
public ref class PartInfoDoc
type PartInfoDoc =  class end

Il tipo MultipleStateOperationPartInfoDoc espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | MultipleStateOperationPartInfoDoc |
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Lev |
Proprietà pubblica | PrtInfo |
Proprietà pubblica | UserData |
Torna su
Vedi anche

Documentazione

Namespace DedNetAcad.Forms


Costruttore MultipleStateOperation.PartInfoDoc

Costruttore MultipleStateOperationPartInfoDoc

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfoDoc(
    PartInfo prt,
    DedDoc doc
)
Public Sub New (
    prt As PartInfo,
    doc As DedDoc
)
public:
PartInfoDoc(
    PartInfo^ prt,
    DedDoc^ doc
)
new :
        prt : PartInfo *
        doc : DedDoc -> PartInfoDoc

Parametri

prt
Tipo: DedNetAcadPartInfo
doc
Tipo: DedDoc
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà di PartInfoDoc

Il tipo MultipleStateOperationPartInfoDoc espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Data |
Proprietà pubblica | Document |
Proprietà pubblica | Lev |
Proprietà pubblica | PrtInfo |
Proprietà pubblica | UserData |
Torna su
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Data

Proprietà MultipleStateOperationPartInfoDocData

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData Data { get; }
Public ReadOnly Property Data As DedData
    Get
public:
property DedData^ Data {
    DedData^ get ();
}
member Data : DedData with get

Valore della proprietà

Tipo: DedData
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Document

Proprietà MultipleStateOperationPartInfoDocDocument

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc Document { get; set; }
Public Property Document As DedDoc
    Get
    Set
public:
property DedDoc^ Document {
    DedDoc^ get ();
    void set (DedDoc^ value);
}
member Document : DedDoc with get, set

Valore della proprietà

Tipo: DedDoc
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.Lev

Proprietà MultipleStateOperationPartInfoDocLev

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public int Lev { get; set; }
Public Property Lev As Integer
    Get
    Set
public:
property int Lev {
    int get ();
    void set (int value);
}
member Lev : int with get, set

Valore della proprietà

Tipo: Int32
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.PrtInfo

Proprietà MultipleStateOperationPartInfoDocPrtInfo

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public PartInfo PrtInfo { get; set; }
Public Property PrtInfo As PartInfo
    Get
    Set
public:
property PartInfo^ PrtInfo {
    PartInfo^ get ();
    void set (PartInfo^ value);
}
member PrtInfo : PartInfo with get, set

Valore della proprietà

Tipo: PartInfo
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms


Proprietà MultipleStateOperation.PartInfoDoc.UserData

Proprietà MultipleStateOperationPartInfoDocUserData

Namespace: DedNetAcad.Forms
Assembly: DedNetAcad (in DedNetAcad.dll) Versione: 23.3.0.0 (23.3.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object UserData { get; set; }
Public Property UserData As Object
    Get
    Set
public:
property Object^ UserData {
    Object^ get ();
    void set (Object^ value);
}
member UserData : Object with get, set

Valore della proprietà

Tipo: Object
Vedi anche

Documentazione

Classe MultipleStateOperationPartInfoDoc
Namespace DedNetAcad.Forms