LuaApplication Namespace
Classi
 | Classe | Descrizione
Classe pubblica | DedApi | Classe statica per la gestione delle api DED ad alto livello
Classe pubblica | DedApiAttrModify | Classe utilizzata per sistemare gli attributi nel DB.
Classe pubblica | DedLuaApplication | Questa classe fa da tramite alle funzionalità DedNet e l'ambiente LUA.
Classe pubblica | DedLuaCommand | Classe utilizzata per implementare un comando personalizzato in LUA.
Classe pubblica | DedLuaCommandDedLuaCommandEventArgs | Argomento utilizzato per impostare la risposta all'evento.
Classe pubblica | Lua | Classe contenente metodi di utilità comune generale nell'ambito LUA.
Classe pubblica | LuaExecuteForm |
Classe pubblica | LuaRunCommand | Implementa un comando per l'esecuzione di codice LUA. Visualizza un form per l'immisione di codice LUA e per il caricamento di file.
Classe pubblica | QsResources | Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Classe pubblica | ShowBaseBom | Apre il visualizzatore della distinta per un'anagrafica.

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Classe DedApi
Classe statica per la gestione delle api DED ad alto livello
Gerarchia di ereditarietà
SystemObject
LuaApplicationDedApi

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedApi
Public Class DedApi
public ref class DedApi
type DedApi =  class end

Il tipo DedApi espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApi | Inizializza una nuova istanza della classe DedApi.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | AllAttrPrompts | Ritorna l'elenco di tutti i prompt degli attributi. Mantenuta per compatibilità col passato.
Metodo pubblico | AllDataHaveSameDedid | Ritorna vero se tutte le anagrafiche in lista hanno lo stesso dedid
Metodo pubblico | AssociateDocument(DedComm, String, LuaTable) | Funzione di associa documento. Data la commessa. In base al filename in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Metodo pubblico | AssociateDocument(String, String, String, LuaTable) | Funzione di associa documento. Dati id e rev individua l'anagrafica. In base al filename e al context del documento individua il nome del documento ed in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Metodo pubblico | AssociateDocumentsCheckedoutByMeToThisHost | Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato
Metodo pubblico | ChangeContexRapModel | Cambia il contesto dei modelli che dovrebbero essere impostati come rappresentazioni e viceversa. Se vengono passati dedid e dedrev lo cambia solo dell'anagrafica passata altrimenti di tutto il DB.
Metodo pubblico | ChangeContext | Cambia il contesto di associazione tra Anagrafica e Documento. Permette di modificare solo da Modello a Pubblicazione o viceversa.
Metodo pubblico | CheckInDocument | Esegue il checkin del documento individuato dal file passato
Metodo pubblico | CheckOutDocument | Esegue il checkout del documento individuato dal file passato
Metodo pubblico | CloneDist | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
Metodo pubblico | cod2Files | Ritorna un LuaTable che contiene tutti i nomi file associati all'anagrafica identificata dai valori passati
Metodo pubblico | CompactDedData | Compatta gli attributi per ridurne il numero.
Metodo pubblico | CompileNewECOPerm | Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.
Metodo pubblico | CompileNewPerm | Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.
Metodo pubblico | CreateData | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | CreateDocument | Comando per la registrazione di un documento.
Metodo pubblico | CreateMovingLink |
Metodo pubblico | dbIsRil | Controlla se l'anagrafica passata è rilasciata
Metodo pubblico | doc2Files | Ritorna una tabella di file path che rappresentano i documenti individuati nel database
Metodo pubblico | EnsureLocal | Esegue il comando di ensureLocal del file passato
Metodo pubblico | ExportDocument | Esporta i documenti associati all'anagrafica di riferimento in un path esterno al database.
Metodo pubblico | file2Code | Dato un fileName ritorna la prima anagrafica associata in base al contesto indicato
Metodo pubblico | file2Codes | Dato un fileName ritorna la lista delle anagrafiche associate
Metodo pubblico | findLastData | Dato il valore ed il campo di riferimento ritorna l'ultima anagrafica disponibile.
Metodo pubblico | FixAttributesName | Sistemate le varie casistiche di stesso nome interno con prompt diverso.
Metodo pubblico | FixAttributesPrompt | Sistema le varie casistiche di attributi figli con stesso prompt ma nome interno differente.
Metodo pubblico | FixDocDuplicated | Controlla se ci sono documenti doppi registrati nella stessa posizione e li elimina.
Metodo pubblico | ForceAlignmentForAllCorporatesDetached | Controlla i documenti che risultano disallineati per tutte le corporate. Vengono allineati sulla corporate corrente
Metodo pubblico | FormatAttrForDb | Restituisce il valore di un attributo, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo. Nel caso di stringa se è troppo lungo lo tronca.
Metodo pubblico | getDedDisPrompt | Ritorna il prompt di DED_DIS. Mantenuta per compatibilità col passato.
Metodo pubblico | ImportProgFromMaster | API da eseguire sugli slave per importare i progressivi esportati dal master dopo aggioranmento rel 22.
Metodo pubblico | isDocInDb | Controllo se il file passato è associato all'anagrafica individuata da id e rev.
Metodo pubblico | LinkDocument | Collega il documento passato tramite filename alla anagrafica. Il documento deve essere già registrato nel database.
Metodo pubblico | RemoveDocument | Elimina il documento identificato dal fileName passato
Metodo pubblico | ReplaceInvalidFileNameChars | Restituisce una stringa con i caratteri non validi sostituiti con _.
Metodo pubblico | ShowLastException |
Metodo pubblico | ShowMigrationStatusInfo | Visualizza lo stao di migrazione dei documenti del database
Metodo pubblico | UpdataDataAttrs | Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica
Metodo pubblico | UpdateAttListOrder | Aggiorna tutti gli indici degali attributi.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _app |
Torna su
Vedi anche

Documentazione

Namespace LuaApplication


Costruttore DedApi

Inizializza una nuova istanza della classe DedApi.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedApi(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedApi(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedApi

Parametri

app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedApi


Proprietà di DedApi

Il tipo DedApi espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | LastException |
Torna su
Vedi anche

Documentazione

Classe DedApi


Proprietà DedApi.LastException

Libreria DedApiLua

Proprietà DedApiLastException

[Manca la documentazione <summary> per "P:LuaApplication.DedApi.LastException"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Exception LastException { get; }
Public ReadOnly Property LastException As Exception
    Get
public:
property Exception^ LastException {
    Exception^ get ();
}
member LastException : Exception with get

Valore della proprietà

Tipo: Exception
Vedi anche

Documentazione

Classe DedApi


Metodi di DedApi

Il tipo DedApi espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | AllAttrPrompts | Ritorna l'elenco di tutti i prompt degli attributi. Mantenuta per compatibilità col passato.
Metodo pubblico | AllDataHaveSameDedid | Ritorna vero se tutte le anagrafiche in lista hanno lo stesso dedid
Metodo pubblico | AssociateDocument(DedComm, String, LuaTable) | Funzione di associa documento. Data la commessa. In base al filename in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Metodo pubblico | AssociateDocument(String, String, String, LuaTable) | Funzione di associa documento. Dati id e rev individua l'anagrafica. In base al filename e al context del documento individua il nome del documento ed in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Metodo pubblico | AssociateDocumentsCheckedoutByMeToThisHost | Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato
Metodo pubblico | ChangeContexRapModel | Cambia il contesto dei modelli che dovrebbero essere impostati come rappresentazioni e viceversa. Se vengono passati dedid e dedrev lo cambia solo dell'anagrafica passata altrimenti di tutto il DB.
Metodo pubblico | ChangeContext | Cambia il contesto di associazione tra Anagrafica e Documento. Permette di modificare solo da Modello a Pubblicazione o viceversa.
Metodo pubblico | CheckInDocument | Esegue il checkin del documento individuato dal file passato
Metodo pubblico | CheckOutDocument | Esegue il checkout del documento individuato dal file passato
Metodo pubblico | CloneDist | Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.
Metodo pubblico | cod2Files | Ritorna un LuaTable che contiene tutti i nomi file associati all'anagrafica identificata dai valori passati
Metodo pubblico | CompactDedData | Compatta gli attributi per ridurne il numero.
Metodo pubblico | CompileNewECOPerm | Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.
Metodo pubblico | CompileNewPerm | Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.
Metodo pubblico | CreateData | Creazione dell'anagrafica. Riceve in ingresso una table di parametri.
Metodo pubblico | CreateDocument | Comando per la registrazione di un documento.
Metodo pubblico | CreateMovingLink |
Metodo pubblico | dbIsRil | Controlla se l'anagrafica passata è rilasciata
Metodo pubblico | doc2Files | Ritorna una tabella di file path che rappresentano i documenti individuati nel database
Metodo pubblico | EnsureLocal | Esegue il comando di ensureLocal del file passato
Metodo pubblico | ExportDocument | Esporta i documenti associati all'anagrafica di riferimento in un path esterno al database.
Metodo pubblico | file2Code | Dato un fileName ritorna la prima anagrafica associata in base al contesto indicato
Metodo pubblico | file2Codes | Dato un fileName ritorna la lista delle anagrafiche associate
Metodo pubblico | findLastData | Dato il valore ed il campo di riferimento ritorna l'ultima anagrafica disponibile.
Metodo pubblico | FixAttributesName | Sistemate le varie casistiche di stesso nome interno con prompt diverso.
Metodo pubblico | FixAttributesPrompt | Sistema le varie casistiche di attributi figli con stesso prompt ma nome interno differente.
Metodo pubblico | FixDocDuplicated | Controlla se ci sono documenti doppi registrati nella stessa posizione e li elimina.
Metodo pubblico | ForceAlignmentForAllCorporatesDetached | Controlla i documenti che risultano disallineati per tutte le corporate. Vengono allineati sulla corporate corrente
Metodo pubblico | FormatAttrForDb | Restituisce il valore di un attributo, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo. Nel caso di stringa se è troppo lungo lo tronca.
Metodo pubblico | getDedDisPrompt | Ritorna il prompt di DED_DIS. Mantenuta per compatibilità col passato.
Metodo pubblico | ImportProgFromMaster | API da eseguire sugli slave per importare i progressivi esportati dal master dopo aggioranmento rel 22.
Metodo pubblico | isDocInDb | Controllo se il file passato è associato all'anagrafica individuata da id e rev.
Metodo pubblico | LinkDocument | Collega il documento passato tramite filename alla anagrafica. Il documento deve essere già registrato nel database.
Metodo pubblico | RemoveDocument | Elimina il documento identificato dal fileName passato
Metodo pubblico | ReplaceInvalidFileNameChars | Restituisce una stringa con i caratteri non validi sostituiti con _.
Metodo pubblico | ShowLastException |
Metodo pubblico | ShowMigrationStatusInfo | Visualizza lo stao di migrazione dei documenti del database
Metodo pubblico | UpdataDataAttrs | Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica
Metodo pubblico | UpdateAttListOrder | Aggiorna tutti gli indici degali attributi.
Torna su
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.AllAttrPrompts

Metodo DedApiAllAttrPrompts

Ritorna l'elenco di tutti i prompt degli attributi. Mantenuta per compatibilità col passato.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public List<string> AllAttrPrompts()
Public Function AllAttrPrompts As List(Of String)
public:
List<String^>^ AllAttrPrompts()
member AllAttrPrompts : unit -> List<string>

Valore di ritorno

Tipo: List String
Lista dei valori
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.AllDataHaveSameDedid

Metodo DedApiAllDataHaveSameDedid

Ritorna vero se tutte le anagrafiche in lista hanno lo stesso dedid

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool AllDataHaveSameDedid(
    DedDataList ddlist
)
Public Function AllDataHaveSameDedid (
    ddlist As DedDataList
) As Boolean
public:
bool AllDataHaveSameDedid(
    DedDataList^ ddlist
)
member AllDataHaveSameDedid :
        ddlist : DedDataList -> bool

Parametri

ddlist
Tipo: DedDataList
Lista di anagrafiche

Valore di ritorno

Tipo: Boolean
Valore booleano di risultato
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.AssociateDocument

Metodo DedApiAssociateDocument

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | AssociateDocument(DedComm, String, LuaTable) | Funzione di associa documento. Data la commessa. In base al filename in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Metodo pubblico | AssociateDocument(String, String, String, LuaTable) | Funzione di associa documento. Dati id e rev individua l'anagrafica. In base al filename e al context del documento individua il nome del documento ed in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.
Torna su
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.AssociateDocument (DedComm, String, LuaTable)

Metodo DedApiAssociateDocument (DedComm, String, LuaTable)
Funzione di associa documento. Data la commessa. In base al filename in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AssociateDocument(
    DedComm comm,
    string fn,
    LuaTable optionalParams = null
)
Public Function AssociateDocument (
    comm As DedComm,
    fn As String,
    Optional optionalParams As LuaTable = Nothing
) As DedDoc
public:
DedDoc^ AssociateDocument(
    DedComm^ comm,
    String^ fn,
    LuaTable^ optionalParams = nullptr
)
member AssociateDocument :
        comm : DedComm *
        fn : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> DedDoc

Parametri

comm
Tipo: DedComm
Commessa
fn
Tipo: SystemString
Nome del file di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - docHasToBeCheckedIn : Indica se dopo l'importazione il documento deve essere posto in checkin - 1 / nil - noDelNoMoved : Indica se creare o meno il .del o .moved - 1 / nil - isRecognize : Indica se il documento è già nel posto giusto - 1 / nil

Valore di ritorno

Tipo: DedDoc
Se riesce ritorna il documento associato oppure null. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi
Overload di AssociateDocument


Metodo DedApi.AssociateDocument (String, String, String, LuaTable)

Metodo DedApiAssociateDocument (String, String, String, LuaTable)
Funzione di associa documento. Dati id e rev individua l'anagrafica. In base al filename e al context del documento individua il nome del documento ed in caso sia già presente lo elimina. Infine viene eseguito un nuovo import del documento individuato dal file passato.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDoc AssociateDocument(
    string id,
    string rev,
    string fn,
    LuaTable optionalParams = null
)
Public Function AssociateDocument (
    id As String,
    rev As String,
    fn As String,
    Optional optionalParams As LuaTable = Nothing
) As DedDoc
public:
DedDoc^ AssociateDocument(
    String^ id,
    String^ rev,
    String^ fn,
    LuaTable^ optionalParams = nullptr
)
member AssociateDocument :
        id : string *
        rev : string *
        fn : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> DedDoc

Parametri

id
Tipo: SystemString
ID dell'anagrafica
rev
Tipo: SystemString
Revisione dell'anagrafica
fn
Tipo: SystemString
Nome del file di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - isPrimaryContext : Contesto di associazione - 1 / nil - docHasToBeCheckedIn : Indica se dopo l'importazione il documento deve essere posto in checkin - 1 / nil - ignoreState : Indica se ignorare lo stato dell'anagrafica alla quale associare il documento. Diversamente deve essere in lavorazione - 1 / nil - noDelNoMoved : Indica se creare o meno il .del o .moved - 1 / nil - isRecognize : Indica se il documento è già nel posto giusto - 1 / nil

Valore di ritorno

Tipo: DedDoc
Se riesce ritorna il documento associato oppure null. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi
Overload di AssociateDocument


Metodo DedApi.AssociateDocumentsCheckedoutByMeToThisHost

Metodo DedApiAssociateDocumentsCheckedoutByMeToThisHost

Aggiorna l'internalname di tutti i documenti del database che ancora non l'hanno impostato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void AssociateDocumentsCheckedoutByMeToThisHost()
Public Sub AssociateDocumentsCheckedoutByMeToThisHost
public:
void AssociateDocumentsCheckedoutByMeToThisHost()
member AssociateDocumentsCheckedoutByMeToThisHost : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ChangeContexRapModel

Metodo DedApiChangeContexRapModel

Cambia il contesto dei modelli che dovrebbero essere impostati come rappresentazioni e viceversa. Se vengono passati dedid e dedrev lo cambia solo dell'anagrafica passata altrimenti di tutto il DB.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ChangeContexRapModel(
    string dedid,
    string dedrev,
    bool silent
)
Public Sub ChangeContexRapModel (
    dedid As String,
    dedrev As String,
    silent As Boolean
)
public:
void ChangeContexRapModel(
    String^ dedid,
    String^ dedrev,
    bool silent
)
member ChangeContexRapModel :
        dedid : string *
        dedrev : string *
        silent : bool -> unit

Parametri

dedid
Tipo: SystemString
dedrev
Tipo: SystemString
silent
Tipo: SystemBoolean
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ChangeContext

Metodo DedApiChangeContext

Cambia il contesto di associazione tra Anagrafica e Documento. Permette di modificare solo da Modello a Pubblicazione o viceversa.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ChangeContext(
    string dedid,
    string dedrev,
    Guid docid,
    DedDocContextEnum newcontext
)
Public Function ChangeContext (
    dedid As String,
    dedrev As String,
    docid As Guid,
    newcontext As DedDocContextEnum
) As Boolean
public:
bool ChangeContext(
    String^ dedid,
    String^ dedrev,
    Guid docid,
    DedDocContextEnum newcontext
)
member ChangeContext :
        dedid : string *
        dedrev : string *
        docid : Guid *
        newcontext : DedDocContextEnum -> bool

Parametri

dedid
Tipo: SystemString
dedrev
Tipo: SystemString
docid
Tipo: SystemGuid
newcontext
Tipo: DedDocContextEnum

Valore di ritorno

Tipo: Boolean
Se riesce ritorna un valore positivo. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CheckInDocument

Metodo DedApiCheckInDocument

Esegue il checkin del documento individuato dal file passato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CheckInDocument(
    string fileName,
    LuaTable optionalParams = null
)
Public Function CheckInDocument (
    fileName As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool CheckInDocument(
    String^ fileName,
    LuaTable^ optionalParams = nullptr
)
member CheckInDocument :
        fileName : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

fileName
Tipo: SystemString
File di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - structure : indica se eseguire un checkin struttura - 1 / nil - eraseFromPws : consente di eliminare il doc dall'area locale una volta eseguito il checkin - 1 / nil - silent : se vero indica di lavorare in modalità silent - 1 / nil

Valore di ritorno

Tipo: Boolean
Esito dell'operazione come booleano. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CheckOutDocument

Metodo DedApiCheckOutDocument

Esegue il checkout del documento individuato dal file passato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CheckOutDocument(
    string fileName,
    LuaTable optionalParams = null
)
Public Function CheckOutDocument (
    fileName As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool CheckOutDocument(
    String^ fileName,
    LuaTable^ optionalParams = nullptr
)
member CheckOutDocument :
        fileName : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

fileName
Tipo: SystemString
File di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - structure : indica se eseguire un checkout struttura - 1 / nil - silent : se vero indica di lavorare in modalità silent - 1 / nil - ignoreDataLockState : se vero indica di non effettuare controlli sullo stato dell'anagrafica - 1 / nil

Valore di ritorno

Tipo: Boolean
Esito dell'operazione come booleano. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CloneDist

Metodo DedApiCloneDist

Copia la distinta dell'anagrafica di partenza in quella di destinazione. Chiama l'evento DistCloneData nella quale è possibile cambiare i dati e annullare l'inserimento.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CloneDist(
    DedData dataFrom,
    DedData dataTo
)
Public Function CloneDist (
    dataFrom As DedData,
    dataTo As DedData
) As Boolean
public:
bool CloneDist(
    DedData^ dataFrom,
    DedData^ dataTo
)
member CloneDist :
        dataFrom : DedData *
        dataTo : DedData -> bool

Parametri

dataFrom
Tipo: DedData
Anagrafica di partenza
dataTo
Tipo: DedData
Anagrafica di destinazione

Valore di ritorno

Tipo: Boolean
True se riesce altrimenti False
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.cod2Files

Metodo DedApicod2Files

Ritorna un LuaTable che contiene tutti i nomi file associati all'anagrafica identificata dai valori passati

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaTable cod2Files(
    Object value,
    string fieldName,
    LuaTable optionalParams = null
)
Public Function cod2Files (
    value As Object,
    fieldName As String,
    Optional optionalParams As LuaTable = Nothing
) As LuaTable
public:
LuaTable^ cod2Files(
    Object^ value,
    String^ fieldName,
    LuaTable^ optionalParams = nullptr
)
member cod2Files :
        value : Object *
        fieldName : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> LuaTable

Parametri

value
Tipo: SystemObject
Valore di riferimento per la ricerca dell'anagrafica
fieldName
Tipo: SystemString
Nome del campo di ricerca
optionalParams (Optional)
Tipo: LuaTable
Parametri opzionali : - extList : Lista delle estensioni (in minuscolo e con punto) di filtraggio per i file in esportazione - isAttachContext : Determina se il contesto di ricerca dei file è primario o allegati - 1 / nil

Valore di ritorno

Tipo: LuaTable
Tabella con il risultato della funzione
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CompactDedData

Metodo DedApiCompactDedData

Compatta gli attributi per ridurne il numero.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CompactDedData(
    List<string> dbpathskip
)
Public Sub CompactDedData (
    dbpathskip As List(Of String)
)
public:
void CompactDedData(
    List<String^>^ dbpathskip
)
member CompactDedData :
        dbpathskip : List<string> -> unit

Parametri

dbpathskip
Tipo: System.Collections.GenericList String
Lista di dbpath i cui attributi non vanno modificati
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CompileNewECOPerm

Metodo DedApiCompileNewECOPerm

Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CompileNewECOPerm()
Public Sub CompileNewECOPerm
public:
void CompileNewECOPerm()
member CompileNewECOPerm : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CompileNewPerm

Metodo DedApiCompileNewPerm

Compila i nuovi permessi nelle tabelle DED_PU e DED_PERM_OBJ in base ai valori già presenti.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void CompileNewPerm()
Public Sub CompileNewPerm
public:
void CompileNewPerm()
member CompileNewPerm : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CreateData

Metodo DedApiCreateData

Creazione dell'anagrafica. Riceve in ingresso una table di parametri.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData CreateData(
    LuaTable args
)
Public Function CreateData (
    args As LuaTable
) As DedData
public:
DedData^ CreateData(
    LuaTable^ args
)
member CreateData :
        args : LuaTable -> DedData

Parametri

args
Tipo: LuaTable
dbpath : path di salvataggio dell'anagrafica (obbligatorio) progr : progressivo rev : revisione dell'anagrafica infoUser : eventuale tassello utente format : informazione sul formato silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil validateAttrs : indica se validare gli attributi 1/nil attrs : LuaTable contenente prompt e valori degli attributi forcedata : Indica se utilizzare gli attributi passati invece di calcolarli - 1 / nil isVar : Indica se è un salva variante - 1 / nil notIncreaseProgr : Indica di non incrementare il progressivo - 1 / nil

Valore di ritorno

Tipo: DedData
Nuova anagrafica oppure null se non riesce. Imposta il LastException se fallisce.
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CreateDocument

Metodo DedApiCreateDocument

Comando per la registrazione di un documento.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreateDocument(
    string fn,
    LuaTable optionalParams = null
)
Public Function CreateDocument (
    fn As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool CreateDocument(
    String^ fn,
    LuaTable^ optionalParams = nullptr
)
member CreateDocument :
        fn : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

fn
Tipo: SystemString
Nome del file del documento di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : silent : comando lanciato silent 1/nil useui : comando lanciato con interfaccia grafica 1/nil

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.CreateMovingLink

Metodo DedApiCreateMovingLink

[Manca la documentazione <summary> per "M:LuaApplication.DedApi.CreateMovingLink(System.String,System.String)"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool CreateMovingLink(
    string fromDocFullFileName,
    string toDocFullFileName
)
Public Function CreateMovingLink (
    fromDocFullFileName As String,
    toDocFullFileName As String
) As Boolean
public:
bool CreateMovingLink(
    String^ fromDocFullFileName,
    String^ toDocFullFileName
)
member CreateMovingLink :
        fromDocFullFileName : string *
        toDocFullFileName : string -> bool

Parametri

fromDocFullFileName
Tipo: SystemString
toDocFullFileName
Tipo: SystemString

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.dbIsRil

Metodo DedApidbIsRil

Controlla se l'anagrafica passata è rilasciata

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool dbIsRil(
    string id,
    string rev
)
Public Function dbIsRil (
    id As String,
    rev As String
) As Boolean
public:
bool dbIsRil(
    String^ id,
    String^ rev
)
member dbIsRil :
        id : string *
        rev : string -> bool

Parametri

id
Tipo: SystemString
ID dell'anagrafica
rev
Tipo: SystemString
Revisione

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.doc2Files

Metodo DedApidoc2Files

Ritorna una tabella di file path che rappresentano i documenti individuati nel database

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaTable doc2Files(
    string nameNoExt,
    string path,
    LuaTable optionalParams = null
)
Public Function doc2Files (
    nameNoExt As String,
    path As String,
    Optional optionalParams As LuaTable = Nothing
) As LuaTable
public:
LuaTable^ doc2Files(
    String^ nameNoExt,
    String^ path,
    LuaTable^ optionalParams = nullptr
)
member doc2Files :
        nameNoExt : string *
        path : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> LuaTable

Parametri

nameNoExt
Tipo: SystemString
Nome file senza estensione per la ricerca documtale
path
Tipo: SystemString
Eventuale path per la restrizione della ricerca
optionalParams (Optional)
Tipo: LuaTable
Parametri opzionali : - extList : Lista delle estensioni (in minuscolo e con punto) di filtraggio per i file in esportazione

Valore di ritorno

Tipo: LuaTable
Tabella con il risultato della funzione
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.EnsureLocal

Metodo DedApiEnsureLocal

Esegue il comando di ensureLocal del file passato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool EnsureLocal(
    string fileName
)
Public Function EnsureLocal (
    fileName As String
) As Boolean
public:
bool EnsureLocal(
    String^ fileName
)
member EnsureLocal :
        fileName : string -> bool

Parametri

fileName
Tipo: SystemString
File di riferimente

Valore di ritorno

Tipo: Boolean
Esito dell'operazione come booleano. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ExportDocument

Metodo DedApiExportDocument

Esporta i documenti associati all'anagrafica di riferimento in un path esterno al database.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool ExportDocument(
    string id,
    string rev,
    string path,
    LuaTable optionalParams = null
)
Public Function ExportDocument (
    id As String,
    rev As String,
    path As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool ExportDocument(
    String^ id,
    String^ rev,
    String^ path,
    LuaTable^ optionalParams = nullptr
)
member ExportDocument :
        id : string *
        rev : string *
        path : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

id
Tipo: SystemString
ID dell'anagrafica
rev
Tipo: SystemString
Revisione dell'anagrafica
path
Tipo: SystemString
Path di destinazione dell'esportazione
optionalParams (Optional)
Tipo: LuaTable
Parametri opzionali : - extList : Lista delle estensioni (in minuscolo e con punto) di filtraggio per i file in esportazione - tabella lua - isAttachContext : Determina se il contesto di ricerca dei file è primario o allegati - 1 / nil - excpIfExtNotExists : Genera eccezione se una delle estensioni da esportare non esiste - 1/nil - ignoreVarRenameNgrFileOnExport : Indica se ignorare la variabile RENAME_NGRFILE_ONEXPORT - 1/nil - overwriteDestination : Indica se sovrascrivere il file di destinazione se già presente - 1/nil

Valore di ritorno

Tipo: Boolean
Se riesce ritorna un valore positivo. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.file2Code

Metodo DedApifile2Code

Dato un fileName ritorna la prima anagrafica associata in base al contesto indicato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData file2Code(
    string fileName,
    bool isAttachContext
)
Public Function file2Code (
    fileName As String,
    isAttachContext As Boolean
) As DedData
public:
DedData^ file2Code(
    String^ fileName,
    bool isAttachContext
)
member file2Code :
        fileName : string *
        isAttachContext : bool -> DedData

Parametri

fileName
Tipo: SystemString
Nome di file
isAttachContext
Tipo: SystemBoolean
Identifica il contesto del documento rispetto all'anagrafica

Valore di ritorno

Tipo: DedData
Ritorna l'anagrafica trovata. Se si verificano errori ritorna null ed imposta il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.file2Codes

Metodo DedApifile2Codes

Dato un fileName ritorna la lista delle anagrafiche associate

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedDataList file2Codes(
    string fileName,
    bool isAttachContext
)
Public Function file2Codes (
    fileName As String,
    isAttachContext As Boolean
) As DedDataList
public:
DedDataList^ file2Codes(
    String^ fileName,
    bool isAttachContext
)
member file2Codes :
        fileName : string *
        isAttachContext : bool -> DedDataList

Parametri

fileName
Tipo: SystemString
Nome di file
isAttachContext
Tipo: SystemBoolean
Identifica il contesto del documento rispetto all'anagrafica

Valore di ritorno

Tipo: DedDataList
Ritorna la lista di anagrafiche. Se si verificano errori ritorna null ed imposta il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.findLastData

Metodo DedApifindLastData

Dato il valore ed il campo di riferimento ritorna l'ultima anagrafica disponibile.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedData findLastData(
    Object value,
    string fieldName,
    LuaTable optionalParams = null
)
Public Function findLastData (
    value As Object,
    fieldName As String,
    Optional optionalParams As LuaTable = Nothing
) As DedData
public:
DedData^ findLastData(
    Object^ value,
    String^ fieldName,
    LuaTable^ optionalParams = nullptr
)
member findLastData :
        value : Object *
        fieldName : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> DedData

Parametri

value
Tipo: SystemObject
Valore di ricerca
fieldName
Tipo: SystemString
Campo di riferimento
optionalParams (Optional)
Tipo: LuaTable
Parametri opzionali : - dbPathExcluded : Lista dei dbpath esclusi (eg {"!ZZ","!3D!SML"}). Saranno utilizzati in modalità 'like', ovvero saranno esclusi anche i path figli.

Valore di ritorno

Tipo: DedData
Anagrafica o null se non trova niente
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.FixAttributesName

Metodo DedApiFixAttributesName

Sistemate le varie casistiche di stesso nome interno con prompt diverso.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FixAttributesName()
Public Sub FixAttributesName
public:
void FixAttributesName()
member FixAttributesName : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.FixAttributesPrompt

Metodo DedApiFixAttributesPrompt

Sistema le varie casistiche di attributi figli con stesso prompt ma nome interno differente.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FixAttributesPrompt()
Public Sub FixAttributesPrompt
public:
void FixAttributesPrompt()
member FixAttributesPrompt : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.FixDocDuplicated

Metodo DedApiFixDocDuplicated

Controlla se ci sono documenti doppi registrati nella stessa posizione e li elimina.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void FixDocDuplicated()
Public Sub FixDocDuplicated
public:
void FixDocDuplicated()
member FixDocDuplicated : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ForceAlignmentForAllCorporatesDetached

Metodo DedApiForceAlignmentForAllCorporatesDetached

Controlla i documenti che risultano disallineati per tutte le corporate. Vengono allineati sulla corporate corrente

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ForceAlignmentForAllCorporatesDetached()
Public Sub ForceAlignmentForAllCorporatesDetached
public:
void ForceAlignmentForAllCorporatesDetached()
member ForceAlignmentForAllCorporatesDetached : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.FormatAttrForDb

Metodo DedApiFormatAttrForDb

Restituisce il valore di un attributo, convertendolo però nel tipo dati coerente con il tipo di dati dell'attributo. Nel caso di stringa se è troppo lungo lo tronca.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public Object FormatAttrForDb(
    DedAttr attr,
    string value
)
Public Function FormatAttrForDb (
    attr As DedAttr,
    value As String
) As Object
public:
Object^ FormatAttrForDb(
    DedAttr^ attr,
    String^ value
)
member FormatAttrForDb :
        attr : DedAttr *
        value : string -> Object

Parametri

attr
Tipo: DedAttr
Attributo da impostare.
value
Tipo: SystemString
Valore dell'attributo

Valore di ritorno

Tipo: Object
Restituisce il valore da impostare nel Db.
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.getDedDisPrompt

Metodo DedApigetDedDisPrompt

Ritorna il prompt di DED_DIS. Mantenuta per compatibilità col passato.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string getDedDisPrompt()
Public Function getDedDisPrompt As String
public:
String^ getDedDisPrompt()
member getDedDisPrompt : unit -> string

Valore di ritorno

Tipo: String
Valore del prompt di DED_DIS
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ImportProgFromMaster

Metodo DedApiImportProgFromMaster

API da eseguire sugli slave per importare i progressivi esportati dal master dopo aggioranmento rel 22.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ImportProgFromMaster()
Public Sub ImportProgFromMaster
public:
void ImportProgFromMaster()
member ImportProgFromMaster : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.isDocInDb

Metodo DedApiisDocInDb

Controllo se il file passato è associato all'anagrafica individuata da id e rev.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool isDocInDb(
    string id,
    string rev,
    string fileName
)
Public Function isDocInDb (
    id As String,
    rev As String,
    fileName As String
) As Boolean
public:
bool isDocInDb(
    String^ id,
    String^ rev,
    String^ fileName
)
member isDocInDb :
        id : string *
        rev : string *
        fileName : string -> bool

Parametri

id
Tipo: SystemString
ID dell'anagrafica
rev
Tipo: SystemString
Revisione
fileName
Tipo: SystemString
Nome file di riferimento

Valore di ritorno

Tipo: Boolean
Valore booleano di controllo. In caso di errori imposta il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.LinkDocument

Metodo DedApiLinkDocument

Collega il documento passato tramite filename alla anagrafica. Il documento deve essere già registrato nel database.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool LinkDocument(
    string id,
    string rev,
    string fn,
    LuaTable optionalParams = null
)
Public Function LinkDocument (
    id As String,
    rev As String,
    fn As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool LinkDocument(
    String^ id,
    String^ rev,
    String^ fn,
    LuaTable^ optionalParams = nullptr
)
member LinkDocument :
        id : string *
        rev : string *
        fn : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

id
Tipo: SystemString
ID dell'anagrafica
rev
Tipo: SystemString
Revisione dell'anagrafica
fn
Tipo: SystemString
Nome del file del documento di riferimento
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - isPrimaryContext : Contesto di associazione - 1 / nil - ignoreState : Indica se ignorare lo stato dell'anagrafica alla quale associare il documento. Diversamente deve essere in lavorazione - 1 / nil

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.RemoveDocument

Metodo DedApiRemoveDocument

Elimina il documento identificato dal fileName passato

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool RemoveDocument(
    string fileName,
    LuaTable optionalParams = null
)
Public Function RemoveDocument (
    fileName As String,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool RemoveDocument(
    String^ fileName,
    LuaTable^ optionalParams = nullptr
)
member RemoveDocument :
        fileName : string *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

fileName
Tipo: SystemString
Nome file di riferimento
optionalParams (Optional)
Tipo: LuaTable
Parametri opzional i : - ignoreState : Se attivo (default) ignora lo stato del documento e relativa anagrafica collegata

Valore di ritorno

Tipo: Boolean
Se riesce ritorna un valore positivo. Imposta eventualmente il LastException
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ReplaceInvalidFileNameChars

Metodo DedApiReplaceInvalidFileNameChars

Restituisce una stringa con i caratteri non validi sostituiti con _.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string ReplaceInvalidFileNameChars(
    string str
)
Public Function ReplaceInvalidFileNameChars (
    str As String
) As String
public:
String^ ReplaceInvalidFileNameChars(
    String^ str
)
member ReplaceInvalidFileNameChars :
        str : string -> string

Parametri

str
Tipo: SystemString
Stringa della quale controllare eventuali caratteri non validi.

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ShowLastException

Metodo DedApiShowLastException

[Manca la documentazione <summary> per "M:LuaApplication.DedApi.ShowLastException"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowLastException()
Public Sub ShowLastException
public:
void ShowLastException()
member ShowLastException : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.ShowMigrationStatusInfo

Metodo DedApiShowMigrationStatusInfo

Visualizza lo stao di migrazione dei documenti del database

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void ShowMigrationStatusInfo(
    int addinversion,
    string platform,
    bool includeInventorDwg
)
Public Sub ShowMigrationStatusInfo (
    addinversion As Integer,
    platform As String,
    includeInventorDwg As Boolean
)
public:
void ShowMigrationStatusInfo(
    int addinversion,
    String^ platform,
    bool includeInventorDwg
)
member ShowMigrationStatusInfo :
        addinversion : int *
        platform : string *
        includeInventorDwg : bool -> unit

Parametri

addinversion
Tipo: SystemInt32
Versione di riferimento dell'applicazione
platform
Tipo: SystemString
Piattaforma di riferimento per il check (inventor\solidworks)
includeInventorDwg
Tipo: SystemBoolean
In caso di analisi di inventor, indica se considerare i dwg come documenti di Inventor
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.UpdataDataAttrs

Metodo DedApiUpdataDataAttrs

Aggiorna gli attributi di anagrafica. La funzione filtra l'eventuale settaggio di dedid, dedrev. In caso di qualsiasi errore non appporta modifiche all'anagrafica

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool UpdataDataAttrs(
    DedData data,
    LuaTable attrs,
    LuaTable optionalParams = null
)
Public Function UpdataDataAttrs (
    data As DedData,
    attrs As LuaTable,
    Optional optionalParams As LuaTable = Nothing
) As Boolean
public:
bool UpdataDataAttrs(
    DedData^ data,
    LuaTable^ attrs,
    LuaTable^ optionalParams = nullptr
)
member UpdataDataAttrs :
        data : DedData *
        attrs : LuaTable *
        ?optionalParams : LuaTable
(* Defaults:
        let _optionalParams = defaultArg optionalParams null
*)
-> bool

Parametri

data
Tipo: DedData
Anagrafica da aggiornare
attrs
Tipo: LuaTable
LuaTable contenente prompt e valori degli attributi
optionalParams (Optional)
Tipo: LuaTable
Tabella di parametri opzionali : - ignoreState : Indica se ignorare lo stato dell'anagrafica alla quale associare il documento. Diversamente deve essere in lavorazione - 1 / nil - ignoreDocStatus : Indica se ignorare lo stato dei documenti PRIMARI associati all'anagrafica. Diversamente tutti i documenti devono essere in checkin o in checkout dall'utente corrente - 1 / nil - updateLight : Se vero indica di non aggiornare il rowver dell'anagrafica in fase di update - 1 / nil

Valore di ritorno

Tipo: Boolean
Ritorna true se riesce. In caso contrario imposta il LastException.
Vedi anche

Documentazione

Classe DedApi


Metodo DedApi.UpdateAttListOrder

Metodo DedApiUpdateAttListOrder

Aggiorna tutti gli indici degali attributi.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void UpdateAttListOrder()
Public Sub UpdateAttListOrder
public:
void UpdateAttListOrder()
member UpdateAttListOrder : unit -> unit
Vedi anche

Documentazione

Classe DedApi


Campi di DedApi

Il tipo DedApi espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _app |
Torna su
Vedi anche

Documentazione

Classe DedApi


Campo DedApi._app

Campo DedApi_app

[Manca la documentazione <summary> per "F:LuaApplication.DedApi._app"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedNetApplication _app
Public _app As DedNetApplication
public:
DedNetApplication^ _app
val mutable _app: DedNetApplication

Valore del campo

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedApi


Classe DedApi.AttrModify

Classe DedApiAttrModify
Classe utilizzata per sistemare gli attributi nel DB.
Gerarchia di ereditarietà
SystemObject
LuaApplicationDedApiAttrModify

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class AttrModify
Public Class AttrModify
public ref class AttrModify
type AttrModify =  class end

Il tipo DedApiAttrModify espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedApiAttrModify | Inizializza una nuova istanza della classe DedApiAttrModify.
Torna su
Campi
 | Nome | Descrizione
Campo pubblico | _dbpath |
Campo pubblico | _newname |
Campo pubblico | _oldname |
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedApi.AttrModify

Costruttore DedApiAttrModify

Inizializza una nuova istanza della classe DedApiAttrModify.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public AttrModify(
    string dbpath,
    string oldname,
    string newname
)
Public Sub New (
    dbpath As String,
    oldname As String,
    newname As String
)
public:
AttrModify(
    String^ dbpath,
    String^ oldname,
    String^ newname
)
new :
        dbpath : string *
        oldname : string *
        newname : string -> AttrModify

Parametri

dbpath
Tipo: SystemString
oldname
Tipo: SystemString
newname
Tipo: SystemString
Vedi anche

Documentazione

Classe DedApiAttrModify


Campi di AttrModify

Il tipo DedApiAttrModify espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo pubblico | _dbpath |
Campo pubblico | _newname |
Campo pubblico | _oldname |
Torna su
Vedi anche

Documentazione

Classe DedApiAttrModify


Campo DedApi.AttrModify._dbpath

Campo DedApiAttrModify_dbpath

[Manca la documentazione <summary> per "F:LuaApplication.DedApi.AttrModify._dbpath"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string _dbpath
Public _dbpath As String
public:
String^ _dbpath
val mutable _dbpath: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedApiAttrModify


Campo DedApi.AttrModify._newname

Campo DedApiAttrModify_newname

[Manca la documentazione <summary> per "F:LuaApplication.DedApi.AttrModify._newname"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string _newname
Public _newname As String
public:
String^ _newname
val mutable _newname: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedApiAttrModify


Campo DedApi.AttrModify._oldname

Campo DedApiAttrModify_oldname

[Manca la documentazione <summary> per "F:LuaApplication.DedApi.AttrModify._oldname"]

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string _oldname
Public _oldname As String
public:
String^ _oldname
val mutable _oldname: string

Valore del campo

Tipo: String
Vedi anche

Documentazione

Classe DedApiAttrModify


Classe DedLuaApplication
Questa classe fa da tramite alle funzionalità DedNet e l'ambiente LUA.
Gerarchia di ereditarietà
SystemObject
LuaApplicationDedLuaApplication

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedLuaApplication
Public Class DedLuaApplication
public ref class DedLuaApplication
type DedLuaApplication =  class end

Il tipo DedLuaApplication espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedLuaApplication | Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).
Metodo pubblico | DedLuaApplication(DedNetApplication) | Inizializza l'oggetto con l'applicazione da wrappare.
Metodo pubblico | DedLuaApplication(String) | Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).
Metodo pubblico | DedLuaApplication(DedNetApplication, Boolean) | Inizializza l'oggetto con l'applicazione da wrappare. Passa un flag che permette di evitare il caricamento degli script
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dedapi | Restituisce l'oggetto DEDAPI.
 | DedNetApp | Proprietà statica che ritorna l'applicazione ded se già definita
Proprietà pubblica | DedNetInstallPath | Restituisce la cartella principale d'installazione del DedNet.
Proprietà pubblica | LuaAppPath | Restituisce o imposta il percorso dal quale caricare i file .lua di applicazione.
Proprietà pubblica | LuaPersPath | Restituisce o imposta il percorso dal quale caricare i file .lua di personalizzazione.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiude l'ambiente LUA correntemente attivo.
Metodo pubblico | CreateLuaRunCommand | Crea e restituisce l'omonimo comando.
Metodo pubblico | CreateShowBaseBom | Crea e restituisce il comando di visualizzazione della distinta
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedLuaApplication

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | DedLuaApplication | Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).
Metodo pubblico | DedLuaApplication(DedNetApplication) | Inizializza l'oggetto con l'applicazione da wrappare.
Metodo pubblico | DedLuaApplication(String) | Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).
Metodo pubblico | DedLuaApplication(DedNetApplication, Boolean) | Inizializza l'oggetto con l'applicazione da wrappare. Passa un flag che permette di evitare il caricamento degli script
Torna su
Vedi anche

Documentazione

Classe DedLuaApplication


Costruttore DedLuaApplication

Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication()
Public Sub New
public:
DedLuaApplication()
new : unit -> DedLuaApplication
Vedi anche

Documentazione

Classe DedLuaApplication
Overload di DedLuaApplication


Costruttore DedLuaApplication (DedNetApplication)
Inizializza l'oggetto con l'applicazione da wrappare.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
DedLuaApplication(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> DedLuaApplication

Parametri

app
Tipo: DedNetApplication
Applicazione per la quale questo oggetto effettuerà il wrapper.
Vedi anche

Documentazione

Classe DedLuaApplication
Overload di DedLuaApplication


Costruttore DedLuaApplication (String)
Inizializza l'oggetto con l'applicazione da wrappare ( USARE DA LUA ).

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication(
    string userName
)
Public Sub New (
    userName As String
)
public:
DedLuaApplication(
    String^ userName
)
new :
        userName : string -> DedLuaApplication

Parametri

userName
Tipo: SystemString
Vedi anche

Documentazione

Classe DedLuaApplication
Overload di DedLuaApplication


Costruttore DedLuaApplication (DedNetApplication, Boolean)
Inizializza l'oggetto con l'applicazione da wrappare. Passa un flag che permette di evitare il caricamento degli script

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaApplication(
    DedNetApplication app,
    bool loadAllScript
)
Public Sub New (
    app As DedNetApplication,
    loadAllScript As Boolean
)
public:
DedLuaApplication(
    DedNetApplication^ app,
    bool loadAllScript
)
new :
        app : DedNetApplication *
        loadAllScript : bool -> DedLuaApplication

Parametri

app
Tipo: DedNetApplication
Applicazione per la quale questo oggetto effettuerà il wrapper.
loadAllScript
Tipo: SystemBoolean
Determina se eseguire o meno il
Vedi anche

Documentazione

Classe DedLuaApplication
Overload di DedLuaApplication


Proprietà di DedLuaApplication

Il tipo DedLuaApplication espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Dedapi | Restituisce l'oggetto DEDAPI.
 | DedNetApp | Proprietà statica che ritorna l'applicazione ded se già definita
Proprietà pubblica | DedNetInstallPath | Restituisce la cartella principale d'installazione del DedNet.
Proprietà pubblica | LuaAppPath | Restituisce o imposta il percorso dal quale caricare i file .lua di applicazione.
Proprietà pubblica | LuaPersPath | Restituisce o imposta il percorso dal quale caricare i file .lua di personalizzazione.
Torna su
Vedi anche

Documentazione

Classe DedLuaApplication


Proprietà DedLuaApplication.Dedapi

Proprietà DedLuaApplicationDedapi

Restituisce l'oggetto DEDAPI.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedApi Dedapi { get; }
Public ReadOnly Property Dedapi As DedApi
    Get
public:
property DedApi^ Dedapi {
    DedApi^ get ();
}
member Dedapi : DedApi with get

Valore della proprietà

Tipo: DedApi
Vedi anche

Documentazione

Classe DedLuaApplication


Proprietà DedLuaApplication.DedNetApp

Proprietà DedLuaApplicationDedNetApp

Proprietà statica che ritorna l'applicazione ded se già definita

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static DedNetApplication DedNetApp { get; }
Public Shared ReadOnly Property DedNetApp As DedNetApplication
    Get
public:
static property DedNetApplication^ DedNetApp {
    DedNetApplication^ get ();
}
static member DedNetApp : DedNetApplication with get

Valore della proprietà

Tipo: DedNetApplication
Vedi anche

Documentazione

Classe DedLuaApplication


Proprietà DedLuaApplication.DedNetInstallPath

Proprietà DedLuaApplicationDedNetInstallPath

Restituisce la cartella principale d'installazione del DedNet.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string DedNetInstallPath { get; }
Public ReadOnly Property DedNetInstallPath As String
    Get
public:
property String^ DedNetInstallPath {
    String^ get ();
}
member DedNetInstallPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedLuaApplication


Proprietà DedLuaApplication.LuaAppPath

Proprietà DedLuaApplicationLuaAppPath

Restituisce o imposta il percorso dal quale caricare i file .lua di applicazione.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string LuaAppPath { get; }
Public ReadOnly Property LuaAppPath As String
    Get
public:
property String^ LuaAppPath {
    String^ get ();
}
member LuaAppPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedLuaApplication


Proprietà DedLuaApplication.LuaPersPath

Proprietà DedLuaApplicationLuaPersPath

Restituisce o imposta il percorso dal quale caricare i file .lua di personalizzazione.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public string LuaPersPath { get; }
Public ReadOnly Property LuaPersPath As String
    Get
public:
property String^ LuaPersPath {
    String^ get ();
}
member LuaPersPath : string with get

Valore della proprietà

Tipo: String
Vedi anche

Documentazione

Classe DedLuaApplication


Metodi di DedLuaApplication

Il tipo DedLuaApplication espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | Close | Chiude l'ambiente LUA correntemente attivo.
Metodo pubblico | CreateLuaRunCommand | Crea e restituisce l'omonimo comando.
Metodo pubblico | CreateShowBaseBom | Crea e restituisce il comando di visualizzazione della distinta
Torna su
Vedi anche

Documentazione

Classe DedLuaApplication


Metodo DedLuaApplication.Close

Metodo DedLuaApplicationClose

Chiude l'ambiente LUA correntemente attivo.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
Vedi anche

Documentazione

Classe DedLuaApplication


Metodo DedLuaApplication.CreateLuaRunCommand

Metodo DedLuaApplicationCreateLuaRunCommand

Crea e restituisce l'omonimo comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaRunCommand CreateLuaRunCommand()
Public Function CreateLuaRunCommand As LuaRunCommand
public:
LuaRunCommand^ CreateLuaRunCommand()
member CreateLuaRunCommand : unit -> LuaRunCommand

Valore di ritorno

Tipo: LuaRunCommand
Vedi anche

Documentazione

Classe DedLuaApplication


Metodo DedLuaApplication.CreateShowBaseBom

Metodo DedLuaApplicationCreateShowBaseBom

Crea e restituisce il comando di visualizzazione della distinta

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommand CreateShowBaseBom()
Public Function CreateShowBaseBom As DedCommand
public:
DedCommand^ CreateShowBaseBom()
member CreateShowBaseBom : unit -> DedCommand

Valore di ritorno

Tipo: DedCommand
Vedi anche

Documentazione

Classe DedLuaApplication


Classe DedLuaCommand
Classe utilizzata per implementare un comando personalizzato in LUA.
Gerarchia di ereditarietà
SystemObject
DedCommand
LuaApplicationDedLuaCommand

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedLuaCommand : DedCommand
Public Class DedLuaCommand
    Inherits DedCommand
public ref class DedLuaCommand : public DedCommand
type DedLuaCommand =
    class
        inherit DedCommand
    end

Il tipo DedLuaCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedLuaCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Solleva l'evento QueryNeedParameters che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante. (Sovrascrive DedCommand.NeedParameters.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Evento di pulitura comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Solleva l'evento QueryEnabled che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Solleva l'evento ExecutingCommand per l'esecuzione vera e propria del comando. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo protetto | OnCrearCommandEvent | Chiama l'evento ExecutingCommand.
Metodo protetto | OnExecutingCommand | Chiama l'evento ExecutingCommand.
Metodo protetto | OnQueryEnabled | Chiama l'evento QueryEnabled.
Metodo protetto | OnQueryNeedParameters | Chiama l'evento QueryNeedParameters.
Metodo protetto | OnSettingContext | Chiama l'evento SettingContext.
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Solleva l'evento SettingContext per impostare le proprietà del comando. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | SetNeedDocument | Siccome la proprietà NeedDocument non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Metodo pubblico | SetNeedRefresh | Siccome la proprietà NeedRefresh non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Metodo pubblico | SetResult | Siccome la proprietà Result non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | CrearCommandEvent | Evento su chiamata al metodo CleareCommand.
Evento pubblico | ExecutingCommand | Evento chiamato per l'esecuzione del comando.
Evento pubblico | QueryEnabled | Evento genenrato su chiamata del metodo Enabled().
Evento pubblico | QueryNeedParameters | Evento generato su chiamata della propietà NeedParameters.
Evento pubblico | SettingContext | Evento genenrato su chiamata del metodo SetContext().
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedLuaCommand

Costruttore unico.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
DedLuaCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> DedLuaCommand

Parametri

app
Tipo: DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName
Tipo: SystemString
Nome interno del comando.
name
Tipo: SystemString
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe DedLuaCommand


Proprietà di DedLuaCommand

Il tipo DedLuaCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Solleva l'evento QueryNeedParameters che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante. (Sovrascrive DedCommand.NeedParameters.)
Torna su
Vedi anche

Documentazione

Classe DedLuaCommand


Proprietà DedLuaCommand.NeedParameters

Proprietà DedLuaCommandNeedParameters

Restituisce true se i parametri del comando non sono ancora sufficienti per l'esecuzione. Solleva l'evento QueryNeedParameters che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedLuaCommand


Metodi di DedLuaCommand

Il tipo DedLuaCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Evento di pulitura comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Solleva l'evento QueryEnabled che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. Solleva l'evento ExecutingCommand per l'esecuzione vera e propria del comando. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo protetto | OnCrearCommandEvent | Chiama l'evento ExecutingCommand.
Metodo protetto | OnExecutingCommand | Chiama l'evento ExecutingCommand.
Metodo protetto | OnQueryEnabled | Chiama l'evento QueryEnabled.
Metodo protetto | OnQueryNeedParameters | Chiama l'evento QueryNeedParameters.
Metodo protetto | OnSettingContext | Chiama l'evento SettingContext.
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Solleva l'evento SettingContext per impostare le proprietà del comando. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Metodo pubblico | SetNeedDocument | Siccome la proprietà NeedDocument non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Metodo pubblico | SetNeedRefresh | Siccome la proprietà NeedRefresh non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Metodo pubblico | SetResult | Siccome la proprietà Result non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.
Torna su
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.ClearCommand

Metodo DedLuaCommandClearCommand

Evento di pulitura comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.Enabled

Metodo DedLuaCommandEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). Solleva l'evento QueryEnabled che permette all'utilizzatore della classe di decidere la risposta da dare al chiamante.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.ExecuteCommand

Metodo DedLuaCommandExecuteCommand

Esegue il comando vero e proprio. Solleva l'evento ExecutingCommand per l'esecuzione vera e propria del comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il risultato dell'operazione.
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.OnCrearCommandEvent

Metodo DedLuaCommandOnCrearCommandEvent

Chiama l'evento ExecutingCommand.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnCrearCommandEvent()
Protected Sub OnCrearCommandEvent
protected:
void OnCrearCommandEvent()
member OnCrearCommandEvent : unit -> unit
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.OnExecutingCommand

Metodo DedLuaCommandOnExecutingCommand

Chiama l'evento ExecutingCommand.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnExecutingCommand()
Protected Sub OnExecutingCommand
protected:
void OnExecutingCommand()
member OnExecutingCommand : unit -> unit
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.OnQueryEnabled

Metodo DedLuaCommandOnQueryEnabled

Chiama l'evento QueryEnabled.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnQueryEnabled(
    DedLuaCommandDedLuaCommandEventArgs e
)
Protected Sub OnQueryEnabled (
    e As DedLuaCommandDedLuaCommandEventArgs
)
protected:
void OnQueryEnabled(
    DedLuaCommandDedLuaCommandEventArgs^ e
)
member OnQueryEnabled :
        e : DedLuaCommandDedLuaCommandEventArgs -> unit

Parametri

e
Tipo: LuaApplicationDedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.OnQueryNeedParameters

Metodo DedLuaCommandOnQueryNeedParameters

Chiama l'evento QueryNeedParameters.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnQueryNeedParameters(
    DedLuaCommandDedLuaCommandEventArgs e
)
Protected Sub OnQueryNeedParameters (
    e As DedLuaCommandDedLuaCommandEventArgs
)
protected:
void OnQueryNeedParameters(
    DedLuaCommandDedLuaCommandEventArgs^ e
)
member OnQueryNeedParameters :
        e : DedLuaCommandDedLuaCommandEventArgs -> unit

Parametri

e
Tipo: LuaApplicationDedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.OnSettingContext

Metodo DedLuaCommandOnSettingContext

Chiama l'evento SettingContext.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected void OnSettingContext(
    DedLuaCommandDedLuaCommandEventArgs e
)
Protected Sub OnSettingContext (
    e As DedLuaCommandDedLuaCommandEventArgs
)
protected:
void OnSettingContext(
    DedLuaCommandDedLuaCommandEventArgs^ e
)
member OnSettingContext :
        e : DedLuaCommandDedLuaCommandEventArgs -> unit

Parametri

e
Tipo: LuaApplicationDedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.SetContext

Metodo DedLuaCommandSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. Solleva l'evento SettingContext per impostare le proprietà del comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.SetNeedDocument

Metodo DedLuaCommandSetNeedDocument

Siccome la proprietà NeedDocument non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetNeedDocument(
    bool need
)
Public Sub SetNeedDocument (
    need As Boolean
)
public:
void SetNeedDocument(
    bool need
)
member SetNeedDocument :
        need : bool -> unit

Parametri

need
Tipo: SystemBoolean
Valore da impostare.
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.SetNeedRefresh

Metodo DedLuaCommandSetNeedRefresh

Siccome la proprietà NeedRefresh non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetNeedRefresh(
    bool need
)
Public Sub SetNeedRefresh (
    need As Boolean
)
public:
void SetNeedRefresh(
    bool need
)
member SetNeedRefresh :
        need : bool -> unit

Parametri

need
Tipo: SystemBoolean
Valore da impostare.
Vedi anche

Documentazione

Classe DedLuaCommand


Metodo DedLuaCommand.SetResult

Metodo DedLuaCommandSetResult

Siccome la proprietà Result non è scrivibile, questo metodo permette l'impostazione della proprietà dall'esterno della classe.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public void SetResult(
    DedCmdResult result
)
Public Sub SetResult (
    result As DedCmdResult
)
public:
void SetResult(
    DedCmdResult result
)
member SetResult :
        result : DedCmdResult -> unit

Parametri

result
Tipo: DedCmdResult
Valore da impostare.
Vedi anche

Documentazione

Classe DedLuaCommand


Eventi di DedLuaCommand

Il tipo DedLuaCommand espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | CrearCommandEvent | Evento su chiamata al metodo CleareCommand.
Evento pubblico | ExecutingCommand | Evento chiamato per l'esecuzione del comando.
Evento pubblico | QueryEnabled | Evento genenrato su chiamata del metodo Enabled().
Evento pubblico | QueryNeedParameters | Evento generato su chiamata della propietà NeedParameters.
Evento pubblico | SettingContext | Evento genenrato su chiamata del metodo SetContext().
Torna su
Vedi anche

Documentazione

Classe DedLuaCommand


Evento DedLuaCommand.CrearCommandEvent

Evento DedLuaCommandCrearCommandEvent
Evento su chiamata al metodo CleareCommand.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler CrearCommandEvent
Public Event CrearCommandEvent As EventHandler
public:
 event EventHandler^ CrearCommandEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member CrearCommandEvent : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe DedLuaCommand


Evento DedLuaCommand.ExecutingCommand

Evento DedLuaCommandExecutingCommand
Evento chiamato per l'esecuzione del comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler ExecutingCommand
Public Event ExecutingCommand As EventHandler
public:
 event EventHandler^ ExecutingCommand {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member ExecutingCommand : IEvent<EventHandler,
    EventArgs>

Valore

Tipo: SystemEventHandler
Vedi anche

Documentazione

Classe DedLuaCommand


Evento DedLuaCommand.QueryEnabled

Evento DedLuaCommandQueryEnabled
Evento genenrato su chiamata del metodo Enabled().

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedLuaCommandDedLuaCommandEventArgs> QueryEnabled
Public Event QueryEnabled As EventHandler(Of DedLuaCommandDedLuaCommandEventArgs)
public:
 event EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ QueryEnabled {
    void add (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
    void remove (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
}
member QueryEnabled : IEvent<EventHandler<DedLuaCommandDedLuaCommandEventArgs>,
    DedLuaCommandDedLuaCommandEventArgs>

Valore

Tipo: SystemEventHandler DedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Evento DedLuaCommand.QueryNeedParameters

Evento DedLuaCommandQueryNeedParameters
Evento generato su chiamata della propietà NeedParameters.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedLuaCommandDedLuaCommandEventArgs> QueryNeedParameters
Public Event QueryNeedParameters As EventHandler(Of DedLuaCommandDedLuaCommandEventArgs)
public:
 event EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ QueryNeedParameters {
    void add (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
    void remove (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
}
member QueryNeedParameters : IEvent<EventHandler<DedLuaCommandDedLuaCommandEventArgs>,
    DedLuaCommandDedLuaCommandEventArgs>

Valore

Tipo: SystemEventHandler DedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Evento DedLuaCommand.SettingContext

Evento DedLuaCommandSettingContext
Evento genenrato su chiamata del metodo SetContext().

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public event EventHandler<DedLuaCommandDedLuaCommandEventArgs> SettingContext
Public Event SettingContext As EventHandler(Of DedLuaCommandDedLuaCommandEventArgs)
public:
 event EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ SettingContext {
    void add (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
    void remove (EventHandler<DedLuaCommandDedLuaCommandEventArgs^>^ value);
}
member SettingContext : IEvent<EventHandler<DedLuaCommandDedLuaCommandEventArgs>,
    DedLuaCommandDedLuaCommandEventArgs>

Valore

Tipo: SystemEventHandler DedLuaCommandDedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommand


Classe DedLuaCommand.DedLuaCommandEventArgs

Classe DedLuaCommandDedLuaCommandEventArgs
Argomento utilizzato per impostare la risposta all'evento.
Gerarchia di ereditarietà
SystemObject
SystemEventArgs
LuaApplicationDedLuaCommandDedLuaCommandEventArgs

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class DedLuaCommandEventArgs : EventArgs
Public Class DedLuaCommandEventArgs
    Inherits EventArgs
public ref class DedLuaCommandEventArgs : public EventArgs
type DedLuaCommandEventArgs =
    class
        inherit EventArgs
    end

Il tipo DedLuaCommandDedLuaCommandEventArgs espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | DedLuaCommandDedLuaCommandEventArgs | Inizializza una nuova istanza della classe DedLuaCommandDedLuaCommandEventArgs.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | Answer | Restituisce o imposta il valore da utilizzare come risposta all'evento.
Proprietà pubblica | Context | Restituisce il contesto di selezione. In alcuni eventi non viene utilizzato ed ha valore null.
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore DedLuaCommand.DedLuaCommandEventArgs

Costruttore DedLuaCommandDedLuaCommandEventArgs

Inizializza una nuova istanza della classe DedLuaCommandDedLuaCommandEventArgs.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedLuaCommandEventArgs()
Public Sub New
public:
DedLuaCommandEventArgs()
new : unit -> DedLuaCommandEventArgs
Vedi anche

Documentazione

Classe DedLuaCommandDedLuaCommandEventArgs


Proprietà di DedLuaCommandEventArgs

Il tipo DedLuaCommandDedLuaCommandEventArgs espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | Answer | Restituisce o imposta il valore da utilizzare come risposta all'evento.
Proprietà pubblica | Context | Restituisce il contesto di selezione. In alcuni eventi non viene utilizzato ed ha valore null.
Torna su
Vedi anche

Documentazione

Classe DedLuaCommandDedLuaCommandEventArgs


Proprietà DedLuaCommand.DedLuaCommandEventArgs.Answer

Proprietà DedLuaCommandDedLuaCommandEventArgsAnswer

Restituisce o imposta il valore da utilizzare come risposta all'evento.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public bool Answer { get; set; }
Public Property Answer As Boolean
    Get
    Set
public:
property bool Answer {
    bool get ();
    void set (bool value);
}
member Answer : bool with get, set

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe DedLuaCommandDedLuaCommandEventArgs


Proprietà DedLuaCommand.DedLuaCommandEventArgs.Context

Proprietà DedLuaCommandDedLuaCommandEventArgsContext

Restituisce il contesto di selezione. In alcuni eventi non viene utilizzato ed ha valore null.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public DedCommandContext Context { get; protected internal set; }
Public Property Context As DedCommandContext
    Get
    Protected Friend Set
public:
property DedCommandContext^ Context {
    DedCommandContext^ get ();
    protected public: void set (DedCommandContext^ value);
}
member Context : DedCommandContext with get, set

Valore della proprietà

Tipo: DedCommandContext
Vedi anche

Documentazione

Classe DedLuaCommandDedLuaCommandEventArgs


Classe Lua
Classe contenente metodi di utilità comune generale nell'ambito LUA.
Gerarchia di ereditarietà
SystemObject
LuaApplicationLua

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static class Lua
Public NotInheritable Class Lua
public ref class Lua abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Lua =  class end

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CloseLua | Chiude l'ambiente LUA correntemente attivo.
DoFile | Carica il file.
DoFileMulti | Carica tutti i file .lua presenti nella cartella passata.
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Metodi di Lua

Il tipo Lua espone i seguenti membri.

Metodi
Nome | Descrizione
CloseLua | Chiude l'ambiente LUA correntemente attivo.
DoFile | Carica il file.
DoFileMulti | Carica tutti i file .lua presenti nella cartella passata.
Torna su
Vedi anche

Documentazione

Classe Lua


Metodo Lua.CloseLua

Metodo LuaCloseLua

Chiude l'ambiente LUA correntemente attivo.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void CloseLua()
Public Shared Sub CloseLua
public:
static void CloseLua()
static member CloseLua : unit -> unit
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DoFile

Metodo LuaDoFile

Carica il file.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DoFile(
    string fileName
)
Public Shared Sub DoFile (
    fileName As String
)
public:
static void DoFile(
    String^ fileName
)
static member DoFile :
        fileName : string -> unit

Parametri

fileName
Tipo: SystemString
File .lua da caricare.
Vedi anche

Documentazione

Classe Lua


Metodo Lua.DoFileMulti

Metodo LuaDoFileMulti

Carica tutti i file .lua presenti nella cartella passata.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public static void DoFileMulti(
    string pathName
)
Public Shared Sub DoFileMulti (
    pathName As String
)
public:
static void DoFileMulti(
    String^ pathName
)
static member DoFileMulti :
        pathName : string -> unit

Parametri

pathName
Tipo: SystemString
Percorso nel quale caricare i file .lua.
Vedi anche

Documentazione

Classe Lua


Classe LuaExecuteForm

[Manca la documentazione <summary> per "T:LuaApplication.LuaExecuteForm"]

Gerarchia di ereditarietà
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
DForm
MouseWheelContainerForm
XtraForm
BaseForm
LuaApplicationLuaExecuteForm

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LuaExecuteForm : BaseForm
Public Class LuaExecuteForm
    Inherits BaseForm
public ref class LuaExecuteForm : public BaseForm
type LuaExecuteForm =
    class
        inherit BaseForm
    end

Il tipo LuaExecuteForm espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LuaExecuteForm | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LuaExecuteForm

Costruttore unico.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaExecuteForm(
    DedNetApplication app
)
Public Sub New (
    app As DedNetApplication
)
public:
LuaExecuteForm(
    DedNetApplication^ app
)
new :
        app : DedNetApplication -> LuaExecuteForm

Parametri

app
Tipo: DedNetApplication
Vedi anche

Documentazione

Classe LuaExecuteForm


Proprietà di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | AcrylicAccentTintOpacity | (Ereditato da XtraForm.)
Proprietà pubblica | ActiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | AllowBorderColorBlending | (Ereditato da XtraForm.)
Proprietà pubblica | AllowFormSkin | (Ereditato da XtraForm.)
Proprietà pubblica | AllowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | AllowSkinForEmptyText | (Ereditato da XtraForm.)
Proprietà pubblica | Appearance | (Ereditato da XtraForm.)
Proprietà pubblica | BackColor | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImage | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayout | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageLayoutStore | (Ereditato da XtraForm.)
Proprietà pubblica | BackgroundImageStore | (Ereditato da XtraForm.)
Proprietà protetta | CanDrawClientBackground | (Ereditato da XtraForm.)
Proprietà protetta | ClientBackgroundTop | (Ereditato da XtraForm.)
Proprietà pubblica | CloseBox | (Ereditato da XtraForm.)
Proprietà protetta | ColorizeInactiveIcon | (Ereditato da XtraForm.)
Proprietà protetta | CreateParams | (Ereditato da XtraForm.)
Proprietà protetta | DefaultAppearance | (Ereditato da XtraForm.)
Proprietà protetta | DesignModeCore | (Ereditato da XtraForm.)
Proprietà pubblica | EnableAcrylicAccent | (Ereditato da XtraForm.)
Proprietà pubblica | Font | (Ereditato da XtraForm.)
Proprietà protetta | ForceShowThickBorder | (Ereditato da XtraForm.)
Proprietà pubblica | ForeColor | (Ereditato da XtraForm.)
Proprietà pubblica | FormBorderEffect | (Ereditato da XtraForm.)
Proprietà protetta | FormPainter | (Ereditato da XtraForm.)
Proprietà protetta | FormShadow | (Ereditato da XtraForm.)
Proprietà protetta | Helper | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlImages | (Ereditato da XtraForm.)
Proprietà pubblica | HtmlText | (Ereditato da XtraForm.)
Proprietà pubblica | Icon | (Ereditato da XtraForm.)
Proprietà pubblica | IconOptions | (Ereditato da XtraForm.)
Proprietà pubblica | InactiveGlowColor | (Ereditato da XtraForm.)
Proprietà protetta | InMaximumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InMinimumClientSizeChanged | (Ereditato da XtraForm.)
Proprietà protetta | InvisibleDueShowingStrategy | (Ereditato da XtraForm.)
Proprietà protetta | IsActive | (Ereditato da XtraForm.)
Proprietà protetta | IsApplyingLocalizableResourcesInDesignTime | (Ereditato da XtraForm.)
Proprietà protetta | IsCaptionInNCArea | (Ereditato da XtraForm.)
Proprietà protetta | IsCustomPainter | (Ereditato da XtraForm.)
Proprietà protetta | IsInitializing | (Ereditato da XtraForm.)
Proprietà protetta | IsMinimumSizeInternalChange | (Ereditato da MouseWheelContainerForm.)
Proprietà protetta | IsOnePixelBorder | (Ereditato da XtraForm.)
Proprietà protetta | IsRegionPainted | (Ereditato da XtraForm.)
Proprietà protetta | IsRibbonForm | (Ereditato da XtraForm.)
Proprietà protetta | IsRightToLeftCaption | (Ereditato da XtraForm.)
Proprietà protetta | IsSizableWindow | (Ereditato da XtraForm.)
Proprietà pubblica | IsSuspendRedraw | (Ereditato da XtraForm.)
Proprietà protetta | LayoutSuspendCountCore | (Ereditato da XtraForm.)
Proprietà pubblica | LookAndFeel | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MaximumSize | (Ereditato da XtraForm.)
Proprietà pubblica | MdiChildCaptionFormatString | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumClientSize | (Ereditato da XtraForm.)
Proprietà pubblica | MinimumSize | (Ereditato da XtraForm.)
Proprietà protetta | NeedActivateForm | (Ereditato da XtraForm.)
Proprietà protetta | ScaleDPI | (Ereditato da XtraForm.)
Proprietà protetta | ScaleHelper | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowMdiBar | (Ereditato da XtraForm.)
Proprietà protetta | ShouldShowShadowInDesignMode | (Ereditato da XtraForm.)
Proprietà pubblica | ShowIcon | (Ereditato da XtraForm.)
Proprietà protetta | ShowingStrategy | (Ereditato da XtraForm.)
Proprietà pubblica | ShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Proprietà protetta | ShowMode | (Ereditato da XtraForm.)
Proprietà pubblica | Site | (Ereditato da XtraForm.)
Proprietà protetta | SupportAdvancedTitlePainting | (Ereditato da XtraForm.)
Proprietà protetta | TaskbarIcon | (Ereditato da XtraForm.)
Proprietà pubblica | Text | (Ereditato da XtraForm.)
Proprietà pubblica | TextMdiTab | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#ActiveLookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#CanColorizeInactiveIcon | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#Control | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#Control | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#Form | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#FormShadow#IFormShadowClient#Form | (Ereditato da DForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormShadowClientEx#FormShadow | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#IgnoreChildren | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#IsActive | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#ICustomDrawNonClientArea#IsCustomDrawNonClientArea | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IGlassForm#IsGlassForm | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#LookAndFeel#ISupportLookAndFeel#LookAndFeel | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinElementName | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProductId | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IFormIconOptionsOwner#SkinProvider | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo protetto | ActivateWindow | (Ereditato da XtraForm.)
Metodo pubblico | ApplyAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | CalcClippedRegion | (Ereditato da XtraForm.)
Metodo protetto | CalcFormBounds | (Ereditato da XtraForm.)
Metodo protetto | CalcPreferredSizeCore | (Ereditato da XtraForm.)
Metodo protetto | CanShowDXSkinColorTabCore | (Ereditato da XtraForm.)
Metodo protetto | CheckCustomDrawNonClientArea | (Ereditato da XtraForm.)
Metodo protetto | CheckFormAppearanceAsMdiTabPage | (Ereditato da XtraForm.)
Metodo protetto | CheckGlassForm | (Ereditato da XtraForm.)
Metodo protetto | CheckRightToLeft | (Ereditato da XtraForm.)
Metodo protetto | CheckUpdateSkinPainter | (Ereditato da XtraForm.)
Metodo pubblico | ClearAcrylicAccent | (Ereditato da XtraForm.)
Metodo protetto | ClientSizeFromSize | (Ereditato da XtraForm.)
Metodo protetto | ConstrainMinimumClientSize | (Ereditato da XtraForm.)
Metodo protetto | CreateControlsInstance | (Ereditato da XtraForm.)
Metodo protetto | CreateDefaultAppearance | (Ereditato da XtraForm.)
Metodo protetto | CreateFormBorderPainter | (Ereditato da XtraForm.)
Metodo protetto | CreateFormShadow | (Ereditato da XtraForm.)
Metodo protetto | CreateHandle | (Ereditato da XtraForm.)
Metodo protetto | CreateHelper | (Ereditato da XtraForm.)
Metodo protetto | CreateIconOptions | (Ereditato da XtraForm.)
Metodo protetto | CreateShowingStrategy | (Ereditato da XtraForm.)
Metodo protetto | DestroyPainter | (Ereditato da XtraForm.)
Metodo protetto | Dispose | Clean up any resources being used. (Sovrascrive BaseForm.Dispose(Boolean).)
Metodo protetto | DoDpiChange | (Ereditato da XtraForm.)
Metodo protetto | DoDpiChangeAfterBase | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | DrawClientBackgroundCore | (Ereditato da XtraForm.)
Metodo protetto | ForceActivateWindow | (Ereditato da XtraForm.)
Metodo protetto | ForceRefresh | (Ereditato da XtraForm.)
Metodo protetto | GetActiveLookAndFeel | (Ereditato da XtraForm.)
Metodo protetto | GetAllowMdiFormSkins | (Ereditato da XtraForm.)
Metodo protetto | GetAllowSkin | (Ereditato da XtraForm.)
Metodo protetto | GetBaseFont | (Ereditato da XtraForm.)
Metodo protetto | GetConstrainSize | (Ereditato da XtraForm.)
Metodo protetto | GetCreateParams | (Ereditato da XtraForm.)
Metodo protetto | GetFormBorderEffect | (Ereditato da XtraForm.)
Metodo protetto | GetScaledBounds | (Ereditato da XtraForm.)
Metodo protetto | GetScaleFactor | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImage | (Ereditato da XtraForm.)
Metodo protetto | GetSkinBackgroundImageStretch | (Ereditato da XtraForm.)
Metodo protetto | GetSkinPainterType | (Ereditato da XtraForm.)
Metodo protetto | InitCore | (Ereditato da XtraForm.)
Metodo protetto | InitFormShadow | (Ereditato da XtraForm.)
Metodo protetto | IsMdiTab | (Ereditato da XtraForm.)
Metodo protetto | IsMinimizedState | (Ereditato da XtraForm.)
Metodo protetto | OnActiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnAppearance_Changed | (Ereditato da XtraForm.)
Metodo protetto | OnClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFontChanged | (Ereditato da XtraForm.)
Metodo protetto | OnFormMinimumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnHandleCreated | (Ereditato da XtraForm.)
Metodo protetto | OnHandleDestroyed | (Ereditato da XtraForm.)
Metodo protetto | OnInactiveGlowColorChanged | (Ereditato da XtraForm.)
Metodo protetto | OnLayout | (Ereditato da XtraForm.)
Metodo protetto | OnLoad | (Ereditato da XtraForm.)
Metodo protetto | OnLookAndFeelChangedCore | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMaximumSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildActivate | (Ereditato da XtraForm.)
Metodo protetto | OnMdiChildTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumClientSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnMinimumSizeChanged | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseHWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Metodo protetto | OnPaint | (Ereditato da XtraForm.)
Metodo protetto | OnPaintBackground | (Ereditato da XtraForm.)
Metodo protetto | OnParentChanged | (Ereditato da XtraForm.)
Metodo protetto | OnScaleControl | (Ereditato da XtraForm.)
Metodo protetto | OnShowMdiChildCaptionInParentTitle | (Ereditato da XtraForm.)
Metodo protetto | OnShown | (Ereditato da XtraForm.)
Metodo protetto | OnSizeChanged | (Ereditato da XtraForm.)
Metodo protetto | OnSkinPainterChanged | (Ereditato da XtraForm.)
Metodo protetto | OnStyleChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextChanged | (Ereditato da XtraForm.)
Metodo protetto | OnTextMdiTabChanged | (Ereditato da XtraForm.)
Metodo protetto | PatchFormSizeInRestoreWindowBoundsIfNecessary | (Ereditato da XtraForm.)
Metodo protetto | RaiseFormLayoutChanged | (Ereditato da XtraForm.)
Metodo protetto | ReleaseFormShadow | (Ereditato da XtraForm.)
Metodo pubblico | ResetBackColor | (Ereditato da XtraForm.)
Metodo pubblico | ResetForeColor | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout | (Ereditato da XtraForm.)
Metodo pubblico | ResumeLayout(Boolean) | (Ereditato da XtraForm.)
Metodo pubblico | ResumeRedraw | (Ereditato da XtraForm.)
Metodo protetto | ScaleControl | (Ereditato da XtraForm.)
Metodo protetto | ScaleCore | (Ereditato da XtraForm.)
Metodo protetto | SetBoundsCore | (Ereditato da XtraForm.)
Metodo protetto | SetClientSizeCore | (Ereditato da XtraForm.)
Metodo protetto | SetEnableAcrylicAccentValue | (Ereditato da XtraForm.)
Metodo protetto | SetLayoutDeferred | (Ereditato da XtraForm.)
Metodo protetto | SetVisibleCore | (Ereditato da XtraForm.)
Metodo protetto | ShouldDrawClientBackground | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageLayoutStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldSerializeBackgroundImageStore | (Ereditato da XtraForm.)
Metodo protetto | ShouldUpdateFrame | (Ereditato da XtraForm.)
Metodo pubblico | ShowDialog | (Ereditato da XtraForm.)
Metodo protetto | SizeFromClientSize | (Ereditato da XtraForm.)
Metodo protetto | SuppressFormShadowShowing | (Ereditato da XtraForm.)
Metodo pubblico | SuspendLayout | (Ereditato da XtraForm.)
Metodo pubblico | SuspendRedraw | (Ereditato da XtraForm.)
Metodo protetto | UpdateClientBackgroundBounds | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter | (Ereditato da XtraForm.)
Metodo protetto | UpdateSkinPainter(Boolean) | (Ereditato da XtraForm.)
Metodo protetto | UpdateWindowThemeCore | (Ereditato da XtraForm.)
Metodo protetto | WndProc | (Ereditato da XtraForm.)
Torna su
Implementazioni esplicite di interfacce
 | Nome | Descrizione
Implementazione esplicita di interfacce | DevExpress#XtraEditors#Drawing#IMouseWheelContainer#BaseOnMouseWheel | (Ereditato da MouseWheelContainerForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColors#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#Utils#Colors#ISupportDXSkinColorsEx#CanShowDXSkinColorTab | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnAppearanceChanged | (Ereditato da XtraForm.)
Implementazione esplicita di interfacce | DevExpress#XtraEditors#IDXControl#OnLookAndFeelStyleChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Metodo LuaExecuteForm.Dispose

Metodo LuaExecuteFormDispose

Clean up any resources being used.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parametri

disposing
Tipo: SystemBoolean
true if managed resources should be disposed; otherwise, false.
Vedi anche

Documentazione

Classe LuaExecuteForm


Eventi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Eventi
 | Nome | Descrizione
Evento pubblico | FormLayoutChanged | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Campi di LuaExecuteForm

Il tipo LuaExecuteForm espone i seguenti membri.

Campi
 | Nome | Descrizione
Campo protetto | boundsUpdated | (Ereditato da XtraForm.)
Campo protetto | formBounds | (Ereditato da XtraForm.)
Campo protetto | isFormPainted | (Ereditato da XtraForm.)
Campo protetto | lockDrawingClientBackground | (Ereditato da XtraForm.)
Campo protetto | prevFormBounds | (Ereditato da XtraForm.)
Torna su
Vedi anche

Documentazione

Classe LuaExecuteForm


Classe LuaRunCommand
Implementa un comando per l'esecuzione di codice LUA. Visualizza un form per l'immisione di codice LUA e per il caricamento di file.
Gerarchia di ereditarietà
SystemObject
DedCommand
LuaApplicationLuaRunCommand

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class LuaRunCommand : DedCommand
Public Class LuaRunCommand
    Inherits DedCommand
public ref class LuaRunCommand : public DedCommand
type LuaRunCommand =
    class
        inherit DedCommand
    end

Il tipo LuaRunCommand espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | LuaRunCommand | Costruttore unico.
Torna su
Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Restituisce sempre false perché non ha bisogno di parametri. (Sovrascrive DedCommand.NeedParameters.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | SetContext | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore LuaRunCommand

Costruttore unico.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public LuaRunCommand(
    DedNetApplication app,
    string internalName,
    string name
)
Public Sub New (
    app As DedNetApplication,
    internalName As String,
    name As String
)
public:
LuaRunCommand(
    DedNetApplication^ app,
    String^ internalName,
    String^ name
)
new :
        app : DedNetApplication *
        internalName : string *
        name : string -> LuaRunCommand

Parametri

app
Tipo: DedNetApplication
Riferimento all'oggetto DedNetApplication.
internalName
Tipo: SystemString
Nome interno del comando.
name
Tipo: SystemString
Nome visualizzato del comando.
Vedi anche

Documentazione

Classe LuaRunCommand


Proprietà di LuaRunCommand

Il tipo LuaRunCommand espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Restituisce sempre false perché non ha bisogno di parametri. (Sovrascrive DedCommand.NeedParameters.)
Torna su
Vedi anche

Documentazione

Classe LuaRunCommand


Proprietà LuaRunCommand.NeedParameters

Proprietà LuaRunCommandNeedParameters

Restituisce sempre false perché non ha bisogno di parametri.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe LuaRunCommand


Metodi di LuaRunCommand

Il tipo LuaRunCommand espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Azzera il comando. (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | SetContext | Restituisce sempre true perché non ha bisogno di parametri. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Torna su
Vedi anche

Documentazione

Classe LuaRunCommand


Metodo LuaRunCommand.ClearCommand

Metodo LuaRunCommandClearCommand

Azzera il comando.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe LuaRunCommand


Metodo LuaRunCommand.Enabled

Metodo LuaRunCommandEnabled

Restituisce sempre true perché non ha bisogno di parametri.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext commandContext
)
Public Overrides Function Enabled (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ commandContext
) override
abstract Enabled :
        commandContext : DedCommandContext -> bool
override Enabled :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe LuaRunCommand


Metodo LuaRunCommand.ExecuteCommand

Metodo LuaRunCommandExecuteCommand

Esegue il comando vero e proprio.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Vedi anche

Documentazione

Classe LuaRunCommand


Metodo LuaRunCommand.SetContext

Metodo LuaRunCommandSetContext

Restituisce sempre true perché non ha bisogno di parametri.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext commandContext
)
Public Overrides Function SetContext (
    commandContext As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ commandContext
) override
abstract SetContext :
        commandContext : DedCommandContext -> bool
override SetContext :
        commandContext : DedCommandContext -> bool

Parametri

commandContext
Tipo: DedCommandContext

Valore di ritorno

Tipo: Boolean
Vedi anche

Documentazione

Classe LuaRunCommand


Classe QsResources
Classe usata per effettuare l'override della property 'GetString' in modo tale che il testo venga mandato a capo quando è presente il '\n'
Gerarchia di ereditarietà
SystemObject
System.ResourcesResourceManager
LuaApplicationQsResources

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class QsResources : ResourceManager
Public Class QsResources
    Inherits ResourceManager
public ref class QsResources : public ResourceManager
type QsResources =
    class
        inherit ResourceManager
    end

Il tipo QsResources espone i seguenti membri.

Costruttori
 | Nome | Descrizione
Metodo pubblico | QsResources | Inizializza una nuova istanza della classe QsResources.
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Costruttore QsResources

Inizializza una nuova istanza della classe QsResources.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public QsResources(
    string s,
    Assembly a
)
Public Sub New (
    s As String,
    a As Assembly
)
public:
QsResources(
    String^ s,
    Assembly^ a
)
new :
        s : string *
        a : Assembly -> QsResources

Parametri

s
Tipo: SystemString
a
Tipo: System.ReflectionAssembly
Vedi anche

Documentazione

Classe QsResources


Metodi di QsResources
Metodi
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString

Metodo QsResourcesGetString

Lista degli overload
 | Nome | Descrizione
Metodo pubblico | GetString(String) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String).)
Metodo pubblico | GetString(String, CultureInfo) | Override che dimezza le barre ('\') per mandare a capo il testo (Sovrascrive ResourceManagerGetString(String, CultureInfo).)
Torna su
Vedi anche

Documentazione

Classe QsResources


Metodo QsResources.GetString (String)

Metodo QsResourcesGetString (String)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name
)
Public Overrides Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
) override
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parametri

name
Tipo: SystemString

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Metodo QsResources.GetString (String, CultureInfo)

Metodo QsResourcesGetString (String, CultureInfo)
Override che dimezza le barre ('\') per mandare a capo il testo

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override string GetString(
    string name,
    CultureInfo culture
)
Public Overrides Function GetString (
    name As String,
    culture As CultureInfo
) As String
public:
virtual String^ GetString(
    String^ name,
    CultureInfo^ culture
) override
abstract GetString :
        name : string *
        culture : CultureInfo -> string
override GetString :
        name : string *
        culture : CultureInfo -> string

Parametri

name
Tipo: SystemString
culture
Tipo: System.GlobalizationCultureInfo

Valore di ritorno

Tipo: String
Vedi anche

Documentazione

Classe QsResources
Overload di GetString


Classe ShowBaseBom
Apre il visualizzatore della distinta per un'anagrafica.
Gerarchia di ereditarietà
SystemObject
DedCommand
LuaApplicationShowBaseBom

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public class ShowBaseBom : DedCommand
Public Class ShowBaseBom
    Inherits DedCommand
public ref class ShowBaseBom : public DedCommand
type ShowBaseBom =
    class
        inherit DedCommand
    end

Il tipo ShowBaseBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Ha bisogno almeno dell'anagrafica (Sovrascrive DedCommand.NeedParameters.)
Torna su
Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia campi comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Torna su
Vedi anche

Documentazione

Namespace LuaApplication

QS Informatica Srl

Inviare suggerimenti o segnalare errori relativi a questo argomento a info@qsinformatica.it


Proprietà di ShowBaseBom

Il tipo ShowBaseBom espone i seguenti membri.

Proprietà
 | Nome | Descrizione
Proprietà pubblica | NeedParameters | Ha bisogno almeno dell'anagrafica (Sovrascrive DedCommand.NeedParameters.)
Torna su
Vedi anche

Documentazione

Classe ShowBaseBom


Proprietà ShowBaseBom.NeedParameters

Proprietà ShowBaseBomNeedParameters

Ha bisogno almeno dell'anagrafica

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool NeedParameters { get; }
Public Overrides ReadOnly Property NeedParameters As Boolean
    Get
public:
virtual property bool NeedParameters {
    bool get () override;
}
abstract NeedParameters : bool with get
override NeedParameters : bool with get

Valore della proprietà

Tipo: Boolean
Vedi anche

Documentazione

Classe ShowBaseBom


Metodi di ShowBaseBom

Il tipo ShowBaseBom espone i seguenti membri.

Metodi
 | Nome | Descrizione
Metodo pubblico | ClearCommand | Pulizia campi comando (Sovrascrive DedCommand.ClearCommand.)
Metodo pubblico | Enabled | Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali). (Sovrascrive DedCommand.Enabled(DedCommandContext).)
Metodo protetto | ExecuteCommand | Esegue il comando vero e proprio. (Sovrascrive DedCommand.ExecuteCommand.)
Metodo pubblico | SetContext | Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto. (Sovrascrive DedCommand.SetContext(DedCommandContext).)
Torna su
Vedi anche

Documentazione

Classe ShowBaseBom


Metodo ShowBaseBom.ClearCommand

Metodo ShowBaseBomClearCommand

Pulizia campi comando

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override void ClearCommand()
Public Overrides Sub ClearCommand
public:
virtual void ClearCommand() override
abstract ClearCommand : unit -> unit
override ClearCommand : unit -> unit
Vedi anche

Documentazione

Classe ShowBaseBom


Metodo ShowBaseBom.Enabled

Metodo ShowBaseBomEnabled

Restituisce se il comando è abilitato in base alla selezione contestuale (se si tratta di un comando presente nei menu contestuali).

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool Enabled(
    DedCommandContext context
)
Public Overrides Function Enabled (
    context As DedCommandContext
) As Boolean
public:
virtual bool Enabled(
    DedCommandContext^ context
) override
abstract Enabled :
        context : DedCommandContext -> bool
override Enabled :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione.

Valore di ritorno

Tipo: Boolean
Restituisce true se il comando deve risultare abilitato all'utente.
Vedi anche

Documentazione

Classe ShowBaseBom


Metodo ShowBaseBom.ExecuteCommand

Metodo ShowBaseBomExecuteCommand

Esegue il comando vero e proprio.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
protected override DedCmdResult ExecuteCommand()
Protected Overrides Function ExecuteCommand As DedCmdResult
protected:
virtual DedCmdResult ExecuteCommand() override
abstract ExecuteCommand : unit -> DedCmdResult
override ExecuteCommand : unit -> DedCmdResult

Valore di ritorno

Tipo: DedCmdResult
Restituisce il valore che deve restituire il comando.
Vedi anche

Documentazione

Classe ShowBaseBom


Metodo ShowBaseBom.SetContext

Metodo ShowBaseBomSetContext

Permette al comando di auto-impostare le proprietà leggendo le informazioni dal contesto.

Namespace: LuaApplication
Assembly: DedLuaApplication (in DedLuaApplication.dll) Versione: 1.0.0.0 (1.0.0.0)
Sintassi
C#
VB
C++
F#
Copy
public override bool SetContext(
    DedCommandContext context
)
Public Overrides Function SetContext (
    context As DedCommandContext
) As Boolean
public:
virtual bool SetContext(
    DedCommandContext^ context
) override
abstract SetContext :
        context : DedCommandContext -> bool
override SetContext :
        context : DedCommandContext -> bool

Parametri

context
Tipo: DedCommandContext
Contesto di selezione con il quale impostare le proprietà del comando.

Valore di ritorno

Tipo: Boolean
Restituisce true se nel contesto ci sono tutte le informazioni necessarie, altrimenti false.
Vedi anche

Documentazione

Classe ShowBaseBom